Sparksee: Modules

Sparksee 6.0.2
  • Main Page
  • Modules
  • Classes
Modules
Here is a list of all modules:
o Gdb
o Io
o Script
\ Algorithms
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Gdb

  • Classes
Files | Classes | Macros | Typedefs | Enumerations | Functions | Variables
Gdb
Collaboration diagram for Gdb:

Files

file | common.h
It contains common includes and definitions as well as set basic data types and enumerations.
file | Database.h
It contains the definition of Database class as well as some other related classes.
file | Exception.h
It contains a hierarchy of exceptions.
file | Export.h
It contains the declaration of ExportManager interface and GraphExport, NodeExport, etc classes.
file | Graph.h
It contains the definition of Graph class.
file | Graph_data.h
It contains the definition of some Graph-related classes.
file | Handler.h
It contains the definition of Handler class.
file | Values.h
It contains the definition of Values class.
file | Objects.h
It contains the definition of Object class.
file | ObjectsIterator.h
It contains the definition of ObjectsIterator class.
file | Query.h
It contains the definition of Query class.
file | QueryContext.h
It contains the definition of QueryContext class.
file | ResultSet.h
It contains the definition of ResultSet class.
file | Session.h
It contains the definition of Session class.
file | Sparksee.h
It contains the declaration of Sparksee class.
file | SparkseeConfig.h
It contains the declaration of SparkseeProperties and SparkseeConfig classes.
file | Stream.h
It contains the definition of stream classes.
file | Value.h
It contains the definitio of Value class.
file | ValueArray.h
It contains the definition of ValueArray classes.
file | Values.h
It contains the definition of Values class.
file | ValuesIterator.h
It contains the definition of ValuesIterator class.

Classes

class | PlatformStatistics
Platform data and statistics. More...
class | Platform
Platform class. More...
class | DatabaseStatistics
Database statistics. More...
class | Database
Database class. More...
class | Exception
Exception class. More...
class | IOException
IO exception class. More...
class | FileNotFoundException
File not found exception class. More...
class | NoSuchElementException
No such element exception class. More...
class | Error
Error class. More...
class | SystemError
System error class. More...
class | AppError
Application error class. More...
class | WrongArgumentError
Wrong argument error class. More...
class | IOError
IO error class. More...
class | LicenseError
License error class. More...
class | UnsupportedOperationError
Unsupported operation error class. More...
class | QueryException
Query exception class. More...
class | EncryptionError
Wrong encryption arguments error class. More...
class | GraphExport
Stores the graph exporting values. More...
class | NodeExport
Stores the node exporting values. More...
class | EdgeExport
Stores edge exporting values. More...
class | ExportManager
Defines how to export a graph to an external format. More...
class | DefaultExport
Default implementation for ExportManager class. More...
class | Graph
Graph class. More...
class | Type
Type data class. More...
class | TypeList
Sparksee type identifier list. More...
class | TypeListIterator
TypeList iterator class. More...
class | Attribute
Attribute data class. More...
class | AttributeList
Sparksee attribute identifier list. More...
class | AttributeListIterator
AttributeList iterator class. More...
class | OIDList
Sparksee object identifier list. More...
class | OIDListIterator
OIDList iterator class. More...
class | AttributeStatistics
Attribute statistics class. More...
class | EdgeData
Edge data class. More...
class | StringList
String list. More...
class | StringListIterator
StringList iterator class. More...
class | BooleanList
Boolean list. More...
class | BooleanListIterator
BooleanList iterator class. More...
class | Int32List
Sparksee 32-bit signed integer list. More...
class | Int32ListIterator
Int32List iterator class. More...
class | Handler< T >
Handles a reference. More...
class | KeyValue
class | KeyValues
Value set class. More...
class | Objects
Object identifier set class. More...
class | ObjectsIterator
ObjectsIterator class. More...
class | QueryStream
Query stream interface. More...
class | Query
Query class. More...
class | QueryContext
Query context interface. More...
class | ResultSet
ResultSet class. More...
class | ResultSetList
ResultSet list. More...
class | ResultSetListIterator
ResultSetList iterator class. More...
class | Session
Session class. More...
class | Sparksee
Sparksee class. More...
class | SparkseeProperties
Sparksee properties file. More...
class | SparkseeConfig
Sparksee configuration class. More...
class | TextStream
TextStream class. More...
class | Value
Value class. More...
class | ValueList
Value list. More...
class | ValueListIterator
ValueList iterator class. More...
class | ValueArray
ValueArray class. More...
class | Values
Value set class. More...
class | ValuesIterator
Values iterator class. More...

Macros

#define | BEGIN_SPARKSEE_NAMESPACE namespace sparksee {
Begining macro for the sparksee namespace.
#define | END_SPARKSEE_NAMESPACE }
Ending macro for the sparksee namespace.
#define | BEGIN_SPARKSEE_GDB_NAMESPACE BEGIN_SPARKSEE_NAMESPACE namespace gdb {
Begining macro for the sparksee::gdb namespace.
#define | END_SPARKSEE_GDB_NAMESPACE END_SPARKSEE_NAMESPACE }
Ending macro for the sparksee::gdb namespace.
#define | BEGIN_SPARKSEE_IO_NAMESPACE BEGIN_SPARKSEE_NAMESPACE namespace io {
Begining macro for the sparksee::io namespace.
#define | END_SPARKSEE_IO_NAMESPACE END_SPARKSEE_NAMESPACE }
Ending macro for the sparksee::io namespace.
#define | BEGIN_SPARKSEE_SCRIPT_NAMESPACE BEGIN_SPARKSEE_NAMESPACE namespace script {
Begining macro for the sparksee::script namespace.
#define | END_SPARKSEE_SCRIPT_NAMESPACE END_SPARKSEE_NAMESPACE }
Ending macro for the sparksee::script namespace.
#define | BEGIN_SPARKSEE_ALGORITHMS_NAMESPACE BEGIN_SPARKSEE_NAMESPACE namespace algorithms {
Begining macro for the sparksee::algorithms namespace.
#define | END_SPARKSEE_ALGORITHMS_NAMESPACE END_SPARKSEE_NAMESPACE }
Ending macro for the sparksee::algorithms namespace.
#define | BEGIN_SPARKSEE_TEST_NAMESPACE BEGIN_SPARKSEE_NAMESPACE namespace test {
Begining macro for the sparksee::test namespace.
#define | END_SPARKSEE_TEST_NAMESPACE END_SPARKSEE_NAMESPACE }
Ending macro for the sparksee::test namespace.
#define | BEGIN_SPARKSEE_QUERY_STREAMS_NAMESPACE BEGIN_SPARKSEE_NAMESPACE namespace query_streams {
Begining macro for the sparksee::algorithms namespace.
#define | END_SPARKSEE_QUERY_STREAMS_NAMESPACE END_SPARKSEE_NAMESPACE }
Ending macro for the sparksee::query_streams namespace.

Typedefs

typedef bool | bool_t
Boolean type.
typedef char | char_t
Character type.
typedef wchar_t | uchar_t
Unicode character type.
typedef signed int | int32_t
32-bit signed integer type.
typedef signed long long | int64_t
64-bit signed integer type.
typedef double | double64_t
64-bit double type.
typedef int32_t | type_t
Graph node or edge type type.
typedef int32_t | attr_t
Graph attribute type.
typedef int64_t | oid_t
Graph OID type.
typedef int32_t | ColorRGB
Color codified as RGB 32-bit int.
typedef void(* | SPARKSEE_UNRECOVERABLE_ERR_CALLBACK )(UnrecoverableError error)
Signature of callback functions to call after UnrecoverableErrors are triggered.

Enumerations

enum ObjectType {
Node,
Edge
}
Object type enumeration. More...
enum DataType {
Boolean,
Integer,
Long,
Double,
Timestamp,
String,
Text,
OID
}
Data type (domain) enumeration. More...
enum Condition {
Equal,
GreaterEqual,
GreaterThan,
LessEqual,
LessThan,
NotEqual,
Like,
LikeNoCase,
Between,
RegExp
}
Condition operators enumeration. More...
enum Order {
Ascendent,
Descendent
}
Order enumeration. More...
enum EdgesDirection {
Ingoing,
Outgoing,
Any
}
Edges direction enumeration. More...
enum AttributeKind {
Basic,
Indexed,
Unique
}
Attribute kind enumeration. More...
enum LogLevel {
Off,
Severe,
Warning,
Info,
Config,
Fine,
Debug
}
Log level enumeration. More...
enum ExportType {
Graphviz,
GraphML,
YGraphML
}
Export type. More...
enum NodeShape {
Box,
Round
}
Node shape. More...
enum MissingEndpoint {
IsError,
Create,
Ignore
}
The policy to follow whenever and edge endpoint is missing during a loading. More...
enum QueryLanguage {
SparkseeAlgebra,
SparkseeCypher
}
The supported query languages. More...
enum UnrecoverableError {
SystemCallError,
InvalidChecksum
}
Enum representing unrecoverable errors. More...

Functions

std::wostream & | operator<< (std::wostream &wostrm, const enum DataType &dt)
Easy STL printing operator redefinition.
std::wostream & | operator<< (std::wostream &wostrm, const enum AttributeKind &ak)
Easy STL printing operator redefinition.

Variables

BEGIN_SPARKSEE_GDB_NAMESPACE
typedef unsigned char 		byte_t
Byte type.

Detailed Description

Typedef Documentation

typedef int32_t ColorRGB

Color codified as RGB 32-bit int.

Bits 24-31 are alpha, 16-23 are red, 8-15 are green, 0-7 are blue.

typedef void(* SPARKSEE_UNRECOVERABLE_ERR_CALLBACK)(UnrecoverableError error)

Signature of callback functions to call after UnrecoverableErrors are triggered.

Parameters
The type of UnrecoverableError that triggered the callback

Enumeration Type Documentation

enum AttributeKind

Attribute kind enumeration.

It determines the indexing-capabilities of an attribute.

Author
Sparsity Technologies http://www.sparsity-technologies.com
Enumerator:
Basic

Basic attribute (non indexed attribute).

Indexed

Indexed attribute.

Unique

Unique attribute (indexed + unique restriction).

Unique restriction sets two objects cannot have the same value for an attribute but NULL.

enum Condition

Condition operators enumeration.

It is mainly used in the attribute-based graph select operations.

Author
Sparsity Technologies http://www.sparsity-technologies.com
Enumerator:
Equal

Equal condition (==).

Null values can be used together with this condition to retrieve all objects having a null value for an attribute.

GreaterEqual

Greater or equal condition (>=).

Null values cannot be used together with this condition.

GreaterThan

Greater than condition (>).

Null values cannot be used together with this condition.

LessEqual

Less or equal condition (<=).

Null values cannot be used together with this condition.

LessThan

Less than condition (<).

Null values cannot be used together with this condition.

NotEqual

Not equal condition (!=).

Null values can be used together with this condition to retrieve all objects having a non-null value for an attribute.

Like

Substring condition.

Null values cannot be used together with this condition.

This condition can just be used together with String values. It allows for searching substrings (case sensitive). Ex:

'AAABBBCCCD' Like 'BBB'   returns TRUE
'AAABBBCCCD' Like 'bbb'   returns FALSE
'AAABBBCCCD' Like 'E'     returns FALSE
LikeNoCase

Substring (no case sensitive) condition.

Null values cannot be used together with this condition.

This condition can just be used together with String values. It allows for searching substrings (no case sensitive). Ex:

'AAABBBCCCD' LikeNoCase 'BBB'   returns TRUE
'AAABBBCCCD' LikeNoCase 'bbb'   returns TRUE
'AAABBBCCCD' LikeNoCase 'E'     returns FALSE
Between

In range operator condition ([x,y]).

Null values cannot be used together with this condition.

RegExp

Regular expression condition.

Null values cannot be used together with this condition.

This condition can just be used together with String values.

Regular expression format conforms most of the POSIX Extended Regular Expressions so it is case sensitive.

See the 'Regular expressions' section in the 'SPARKSEE User Manual' for details.

enum DataType

Data type (domain) enumeration.

Author
Sparsity Technologies http://www.sparsity-technologies.com
Enumerator:
Boolean

Boolean data type.

Integer

32-bit signed integer data type.

Long

64-bit signed integer data type.

Double

64-bit signed double data type.

Timestamp

Distance from Epoch (UTC) time in milliseconds precision.

It just works properly with timestamps in the range ['1970-01-01 00:00:01' UTC, '2038-01-19 03:14:07' UTC].

String

Unicode string data type.

2048 characters maximum length.

Text

Large unicode character object (CLOB) data type.

See Also
TextStream
OID

Object identifier (OID) data type.

enum EdgesDirection

Edges direction enumeration.

Author
Sparsity Technologies http://www.sparsity-technologies.com
Enumerator:
Ingoing

In-going edges.

Outgoing

Out-going edges.

Any

In-going or out-going edges.

enum ExportType

Export type.

Author
Sparsity Technologies http://www.sparsity-technologies.com
Enumerator:
Graphviz

Export to Graphviz format.

Graphviz home page: http://www.graphviz.org

GraphML

Export to GraphML format.

GraphML home page: http://graphml.graphdrawing.org/

YGraphML

Export to YGRAPHML format.

It is an GraphML format extended with a set of yWorks ("http://www.yworks.com") extensions. Thus, it allows for the visualization of the exported graph with the public yEd visualization tool ("http://www.yworks.com/products/yed").

enum LogLevel

Log level enumeration.

Log level priority order is as follows, from minimum to maximum log information: Off (log is disabled), Severe, Warning, Info, Config, Fine, Debug.

Author
Sparsity Technologies http://www.sparsity-technologies.com
Enumerator:
Off

Disable log.

Severe

Severe log level.

This is the lower log level, just errors are shown.

Warning

Warning log level.

Errors and warnings are shown.

Info

Info log level.

Errors, warnings and information messages are shown.

Config

Config log level.

Errors, warnings, information messages and configuration details of the different components are shown.

Fine

Fine log level.

This is the higher and finest public log level, everything is dumped to the log.

Debug

Debug log level.

This is for Sparksee development purposes and just works with debug versions of the library.

enum MissingEndpoint

The policy to follow whenever and edge endpoint is missing during a loading.

Enumerator:
IsError

Throw an error.

Create

Create the endpoint.

Ignore

Ignore the edge.

enum NodeShape

Node shape.

Author
Sparsity Technologies http://www.sparsity-technologies.com
Enumerator:
Box

Box shape.

Round

Round shape.

enum ObjectType

Object type enumeration.

Author
Sparsity Technologies http://www.sparsity-technologies.com
Enumerator:
Node

Node object type.

Edge

Edge object type.

enum Order

Order enumeration.

Author
Sparsity Technologies http://www.sparsity-technologies.com
Enumerator:
Ascendent

From lower to higher.

Descendent

From higher to lower.

enum QueryLanguage

The supported query languages.

Enumerator:
SparkseeAlgebra

The internal Sparksee Algebra.

SparkseeCypher

The Sparksee Cypher Language inspired by the OpenCypher Query Language.

enum UnrecoverableError

Enum representing unrecoverable errors.

Enumerator:
SystemCallError

Error triggered due to an unrecoverable error detected during a system call in the Sparksee core.

InvalidChecksum

Error triggered after detecting an invalid checksum during reading data from an I/O device.

Function Documentation

std::wostream& operator<< | ( | std::wostream & | wostrm,
 |  | const enum DataType & | dt
 | ) |  |

Easy STL printing operator redefinition.

It allows to do: ... << sparksee::gdb::String << ...

Parameters
wostrm | A widechar oputput stream
dt | [in] An DataType.
Returns
Returns the widechar output stream with the DataType written.
std::wostream& operator<< | ( | std::wostream & | wostrm,
 |  | const enum AttributeKind & | ak
 | ) |  |

Easy STL printing operator redefinition.

It allows to do: ... << sparksee::gdb::Basic << ...

Parameters
wostrm | A widechar oputput stream
ak | [in] An attribute kind.
Returns
Returns the widechar output stream with the AttributeKind written.
Generated on Thu Feb 24 2022 12:56:05 for Sparksee by doxygen 1.8.2


Sparksee: PlatformStatistics Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Friends | List of all members
PlatformStatistics Class Reference
Gdb

Platform data and statistics. More...

Public Member Functions

PlatformStatistics ()
Creates a new instance setting all values to 0.
int32_t | GetNumCPUs () const
Gets the number of CPUs.
int64_t | GetRealTime () const
Gets time in microseconds (since epoch).
int64_t | GetUserTime () const
Gets CPU user time.
int64_t | GetSystemTime () const
Gets CPU system time.
int64_t | GetTotalMem () const
Gets physical memory size in Bytes.
int64_t | GetAvailableMem () const
Gets avialable (free) memory size in Bytes.

Friends

class Platform

Detailed Description

Platform data and statistics.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

int64_t PlatformStatistics::GetAvailableMem ( ) const
inline

Gets avialable (free) memory size in Bytes.

Returns
Avialable (free) memory size in Bytes.
int32_t PlatformStatistics::GetNumCPUs ( ) const
inline

Gets the number of CPUs.

Returns
The number of CPUs.
int64_t PlatformStatistics::GetRealTime ( ) const
inline

Gets time in microseconds (since epoch).

Returns
Time in microseconds (since epoch).
int64_t PlatformStatistics::GetSystemTime ( ) const
inline

Gets CPU system time.

Returns
CPU system time.
int64_t PlatformStatistics::GetTotalMem ( ) const
inline

Gets physical memory size in Bytes.

Returns
Physical memory size in Bytes.
int64_t PlatformStatistics::GetUserTime ( ) const
inline

Gets CPU user time.

Returns
CPU user time.
The documentation for this class was generated from the following file:
  • common.h
Generated on Thu Feb 24 2022 12:56:06 for Sparksee by doxygen 1.8.2


Sparksee: Platform Class Reference

  • Class Hierarchy
  • Class Members
Static Public Member Functions | List of all members
Platform Class Reference
Gdb

Platform class. More...

Static Public Member Functions

static void GetStatistics (PlatformStatistics &stats)
Gets platform data and statistics.

Detailed Description

Platform class.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

static void Platform::GetStatistics ( PlatformStatistics & stats )
static

Gets platform data and statistics.

Parameters
stats [in|out] This updates the given PlatformStatistics.
The documentation for this class was generated from the following file:
  • common.h


Sparksee: DatabaseStatistics Class Reference

Public Member Functions | Friends | List of all members
DatabaseStatistics Class Reference
Gdb

Database statistics. More...

Public Member Functions

int64_t | GetRead () const
Gets total read data in KBytes.
int64_t | GetWrite () const
Gets total written data in KBytes.
int64_t | GetData () const
Gets database size in KBytes.
int64_t | GetCache () const
Gets cache size in KBytes.
int64_t | GetTemp () const
Gets temporary storage file size in KBytes.
int64_t | GetSessions () const
Gets the number of sessions.

Friends

class Database

Detailed Description

Database statistics.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

int64_t DatabaseStatistics::GetCache ( ) const
inline

Gets cache size in KBytes.

Returns
Cache size in KBytes.
int64_t DatabaseStatistics::GetData ( ) const
inline

Gets database size in KBytes.

Returns
Database size in KBytes.
int64_t DatabaseStatistics::GetRead ( ) const
inline

Gets total read data in KBytes.

Returns
Total read data in KBytes.
int64_t DatabaseStatistics::GetSessions ( ) const
inline

Gets the number of sessions.

Returns
The number of sessions.
int64_t DatabaseStatistics::GetTemp ( ) const
inline

Gets temporary storage file size in KBytes.

Returns
Temporary storage file size in KBytes.
int64_t DatabaseStatistics::GetWrite ( ) const
inline

Gets total written data in KBytes.

Returns
Total read written in KBytes.
The documentation for this class was generated from the following file:
  • Database.h


Sparksee: Database Class Reference

Public Member Functions | Private Member Functions | Friends | List of all members
Database Class Reference
Gdb

Database class. More...

Inheritance diagram for Database:
Collaboration diagram for Database:

Public Member Functions

virtual | ~Database ()
Destructor.
const std::wstring & | GetAlias () const
Gets the alias of the Database.
const std::wstring & | GetPath () const
Gets the path of the Database.
Session * NewSession ()
Creates a new Session.
void | EnableRollback ()
Enables the rollback mechanism.
void | DisableRollback ()
Disables the rollback mechanism.
void | GetStatistics (DatabaseStatistics &stats)
Gets Database statistics.
int32_t GetCacheMaxSize ()
Gets the cache maximum size (in MB).
void | SetCacheMaxSize (int32_t megaBytes)
Sets the cache maximum size (in MB).
void | FixCurrentCacheMaxSize ()
Sets the cache maximum size to the current cache size in use.
void | DumpSchema (const std::wstring &filePath)
Dump the database schema to the given file using the Sparksee scripting format.
void | RedoPrecommitted (int64_t txId)
Redo a pending precommitted transaction recovered.

Private Member Functions

sparksee_core::GraphPool * | GetHandler ()
Gets the handled reference.
const sparksee_core::GraphPool * | GetHandler () const
Gets the handled reference.
void | SetHandler (sparksee_core::GraphPool *h)
Sets the handled reference.
void | FreeHandler ()
Frees (deletes) the handled reference.
bool_t | IsNull () const
Gets if the handler is NULL.

Friends

class | Sparksee
class | Graph

Detailed Description

Database class.

All the data of the Database is stored into a persistent file which just can be created or open through a Sparksee instance.

Also, all the manipulation of a Database must be done by means of a Session which can be initiated from a Database instance.

Multiple Databases do not share the memory, that is there is no negotiation among them. In those cases, memory must be prefixed for each Database. To do that, use the SPARKSEEConfig.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

const std::wstring& Database::GetAlias ( ) const
inline

Gets the alias of the Database.

Returns
The alias of the Database.
int32_t Database::GetCacheMaxSize ( )

Gets the cache maximum size (in MB).

Returns
Returns the current cache max size.
const std::wstring& Database::GetPath ( ) const
inline

Gets the path of the Database.

Returns
The path of the Database.
void Database::GetStatistics ( DatabaseStatistics & stats )

Gets Database statistics.

Parameters
stats [out] The DatabaseStatistics instance.
void Database::RedoPrecommitted ( int64_t txId )

Redo a pending precommitted transaction recovered.

YOU SHOULD NOT USE THIS METHOD. This method only exists for a specific service.

void Database::SetCacheMaxSize ( int32_t megaBytes )

Sets the cache maximum size (in MB).

0 means unlimited which is all the physical memory of the computer minus a small margin.

Parameters
megaBytes [in] The new cache max size.
The documentation for this class was generated from the following file:
  • Database.h


Sparksee: Exception Class Reference

Public Member Functions | Protected Attributes | List of all members
Exception Class Reference
Gdb

Exception class. More...

Inheritance diagram for Exception:

Public Member Functions

Exception ()
Creates a new instance.
Exception (const std::string &mess)
Creates a new instance.
const std::string & | Message () const
Gets the message of the exception.
void | SetMessage (const std::string &mess)
Sets the message of the exception.
virtual | ~Exception ()
Destructor.

Protected Attributes

std::string message
Message of the exception.

Detailed Description

Exception class.

This is the superclass of those exceptions that can be thrown during the normal execution of a program.

It is expected all methods declare all Exception (or subclasses) they throw.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

Exception::Exception ( const std::string & mess )

Creates a new instance.

Parameters
mess [in] Message of the exception.

Member Function Documentation

const std::string& Exception::Message ( ) const

Gets the message of the exception.

It should be called GetMessage but this is not possible because of a macro defined in Windows.

Returns
The message of the exception.
void Exception::SetMessage ( const std::string & mess )

Sets the message of the exception.

Parameters
mess [in] Message.
The documentation for this class was generated from the following file:
  • Exception.h


Sparksee: IOException Class Reference

Public Member Functions | Protected Attributes | List of all members
IOException Class Reference
Gdb

IO exception class. More...

Inheritance diagram for IOException:
Collaboration diagram for IOException:

Public Member Functions

IOException ()
Creates a new instance.
IOException (const std::string &mess)
Creates a new instance.
virtual | ~IOException ()
Destructor.
const std::string & | Message () const
Gets the message of the exception.
void | SetMessage (const std::string &mess)
Sets the message of the exception.

Protected Attributes

std::string message
Message of the exception.

Detailed Description

IO exception class.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

IOException::IOException ( const std::string & mess )

Creates a new instance.

Parameters
mess [in] Message of the exception.

Member Function Documentation

const std::string& Exception::Message ( ) const
inherited

Gets the message of the exception.

It should be called GetMessage but this is not possible because of a macro defined in Windows.

Returns
The message of the exception.
void Exception::SetMessage ( const std::string & mess )
inherited

Sets the message of the exception.

Parameters
mess [in] Message.
The documentation for this class was generated from the following file:
  • Exception.h


Sparksee: FileNotFoundException Class Reference

Public Member Functions | Protected Attributes | List of all members
FileNotFoundException Class Reference
Gdb

File not found exception class. More...

Inheritance diagram for FileNotFoundException:
Collaboration diagram for FileNotFoundException:

Public Member Functions

FileNotFoundException ()
Creates a new instance.
FileNotFoundException (const std::string &mess)
Creates a new instance.
virtual | ~FileNotFoundException ()
Destructor.
const std::string & | Message () const
Gets the message of the exception.
void | SetMessage (const std::string &mess)
Sets the message of the exception.

Protected Attributes

std::string message
Message of the exception.

Detailed Description

File not found exception class.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

FileNotFoundException::FileNotFoundException ( const std::string & mess )

Creates a new instance.

Parameters
mess [in] Message of the exception.

Member Function Documentation

const std::string& Exception::Message ( ) const
inherited

Gets the message of the exception.

It should be called GetMessage but this is not possible because of a macro defined in Windows.

Returns
The message of the exception.
void Exception::SetMessage ( const std::string & mess )
inherited

Sets the message of the exception.

Parameters
mess [in] Message.
The documentation for this class was generated from the following file:
  • Exception.h


Sparksee: NoSuchElementException Class Reference

Public Member Functions | Protected Attributes | List of all members
NoSuchElementException Class Reference
Gdb

No such element exception class. More...

Inheritance diagram for NoSuchElementException:
Collaboration diagram for NoSuchElementException:

Public Member Functions

NoSuchElementException ()
Creates a new instance.
NoSuchElementException (const std::string &mess)
Creates a new instance.
virtual | ~NoSuchElementException ()
Destructor.
const std::string & | Message () const
Gets the message of the exception.
void | SetMessage (const std::string &mess)
Sets the message of the exception.

Protected Attributes

std::string message
Message of the exception.

Detailed Description

No such element exception class.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

NoSuchElementException::NoSuchElementException ( const std::string & mess )

Creates a new instance.

Parameters
mess [in] Message of the exception.

Member Function Documentation

const std::string& Exception::Message ( ) const
inherited

Gets the message of the exception.

It should be called GetMessage but this is not possible because of a macro defined in Windows.

Returns
The message of the exception.
void Exception::SetMessage ( const std::string & mess )
inherited

Sets the message of the exception.

Parameters
mess [in] Message.
The documentation for this class was generated from the following file:
  • Exception.h


Sparksee: Error Class Reference

Public Member Functions | Static Public Member Functions | Protected Attributes | List of all members
Error Class Reference
Gdb

Error class. More...

Inheritance diagram for Error:
Collaboration diagram for Error:

Public Member Functions

Error ()
Creates a new instance.
Error (const std::string &mess)
Creates a new instance.
virtual | ~Error ()
Destructor.
const std::string & | Message () const
Gets the message of the exception.
void | SetMessage (const std::string &mess)
Sets the message of the exception.

Static Public Member Functions

static void ThrowError (int32_t coreErrorCode)
Throws a new Error instance from a sparksee_core error code.

Protected Attributes

std::string message
Message of the exception.

Detailed Description

Error class.

An Error corresponds to an unexpected and unpredictable exception.

As all methods can throw an Error at any moment, it is not expected they declare the Error (or subclasses) they may throw.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

Error::Error ( const std::string & mess )

Creates a new instance.

Parameters
mess [in] Message of the exception.

Member Function Documentation

const std::string& Exception::Message ( ) const
inherited

Gets the message of the exception.

It should be called GetMessage but this is not possible because of a macro defined in Windows.

Returns
The message of the exception.
void Exception::SetMessage ( const std::string & mess )
inherited

Sets the message of the exception.

Parameters
mess [in] Message.
static void Error::ThrowError ( int32_t coreErrorCode )
static

Throws a new Error instance from a sparksee_core error code.

Parameters
coreErrorCode [in] Sparkseecore error code.
Returns
Depending on the given sparksee_core error, this will throw an Error instance of an specific Error subclass instance.
The documentation for this class was generated from the following file:
  • Exception.h


Sparksee: SystemError Class Reference

Public Member Functions | Static Public Member Functions | Protected Attributes | List of all members
SystemError Class Reference
Gdb

System error class. More...

Inheritance diagram for SystemError:
Collaboration diagram for SystemError:

Public Member Functions

SystemError ()
Creates a new instance.
SystemError (const std::string &mess)
Creates a new instance.
virtual | ~SystemError ()
Destructor.
const std::string & | Message () const
Gets the message of the exception.
void | SetMessage (const std::string &mess)
Sets the message of the exception.

Static Public Member Functions

static void ThrowError (int32_t coreErrorCode)
Throws a new Error instance from a sparksee_core error code.

Protected Attributes

std::string message
Message of the exception.

Detailed Description

System error class.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

SystemError::SystemError ( const std::string & mess )

Creates a new instance.

Parameters
mess [in] Message of the exception.

Member Function Documentation

const std::string& Exception::Message ( ) const
inherited

Gets the message of the exception.

It should be called GetMessage but this is not possible because of a macro defined in Windows.

Returns
The message of the exception.
void Exception::SetMessage ( const std::string & mess )
inherited

Sets the message of the exception.

Parameters
mess [in] Message.
static void Error::ThrowError ( int32_t coreErrorCode )
staticinherited

Throws a new Error instance from a sparksee_core error code.

Parameters
coreErrorCode [in] Sparkseecore error code.
Returns
Depending on the given sparksee_core error, this will throw an Error instance of an specific Error subclass instance.
The documentation for this class was generated from the following file:
  • Exception.h


Sparksee: AppError Class Reference

Public Member Functions | Static Public Member Functions | Protected Attributes | List of all members
AppError Class Reference
Gdb

Application error class. More...

Inheritance diagram for AppError:
Collaboration diagram for AppError:

Public Member Functions

AppError ()
Creates a new instance.
AppError (const std::string &mess)
Creates a new instance.
virtual | ~AppError ()
Destructor.
const std::string & | Message () const
Gets the message of the exception.
void | SetMessage (const std::string &mess)
Sets the message of the exception.

Static Public Member Functions

static void ThrowError (int32_t coreErrorCode)
Throws a new Error instance from a sparksee_core error code.

Protected Attributes

std::string message
Message of the exception.

Detailed Description

Application error class.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

AppError::AppError ( const std::string & mess )

Creates a new instance.

Parameters
mess [in] Message of the exception.

Member Function Documentation

const std::string& Exception::Message ( ) const
inherited

Gets the message of the exception.

It should be called GetMessage but this is not possible because of a macro defined in Windows.

Returns
The message of the exception.
void Exception::SetMessage ( const std::string & mess )
inherited

Sets the message of the exception.

Parameters
mess [in] Message.
static void Error::ThrowError ( int32_t coreErrorCode )
staticinherited

Throws a new Error instance from a sparksee_core error code.

Parameters
coreErrorCode [in] Sparkseecore error code.
Returns
Depending on the given sparksee_core error, this will throw an Error instance of an specific Error subclass instance.
The documentation for this class was generated from the following file:
  • Exception.h
Generated on Thu Feb 24 2022 12:56:05 for Sparksee by doxygen 1.8.2


Sparksee: WrongArgumentError Class Reference

Public Member Functions | Static Public Member Functions | Protected Attributes | List of all members
WrongArgumentError Class Reference
Gdb

Wrong argument error class. More...

Inheritance diagram for WrongArgumentError:
Collaboration diagram for WrongArgumentError:

Public Member Functions

WrongArgumentError ()
Creates a new instance.
WrongArgumentError (const std::string &mess)
Creates a new instance.
virtual | ~WrongArgumentError ()
Destructor.
const std::string & | Message () const
Gets the message of the exception.
void | SetMessage (const std::string &mess)
Sets the message of the exception.

Static Public Member Functions

static void ThrowError (int32_t coreErrorCode)
Throws a new Error instance from a sparksee_core error code.

Protected Attributes

std::string message
Message of the exception.

Detailed Description

Wrong argument error class.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

WrongArgumentError::WrongArgumentError ( const std::string & mess )

Creates a new instance.

Parameters
mess [in] Message of the exception.

Member Function Documentation

const std::string& Exception::Message ( ) const
inherited

Gets the message of the exception.

It should be called GetMessage but this is not possible because of a macro defined in Windows.

Returns
The message of the exception.
void Exception::SetMessage ( const std::string & mess )
inherited

Sets the message of the exception.

Parameters
mess [in] Message.
static void Error::ThrowError ( int32_t coreErrorCode )
staticinherited

Throws a new Error instance from a sparksee_core error code.

Parameters
coreErrorCode [in] Sparkseecore error code.
Returns
Depending on the given sparksee_core error, this will throw an Error instance of an specific Error subclass instance.
The documentation for this class was generated from the following file:
  • Exception.h
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: IOError Class Reference

Public Member Functions | Static Public Member Functions | Protected Attributes | List of all members
IOError Class Reference
Gdb

IO error class. More...

Inheritance diagram for IOError:
Collaboration diagram for IOError:

Public Member Functions

IOError ()
Creates a new instance.
IOError (const std::string &mess)
Creates a new instance.
virtual | ~IOError ()
Destructor.
const std::string & | Message () const
Gets the message of the exception.
void | SetMessage (const std::string &mess)
Sets the message of the exception.

Static Public Member Functions

static void ThrowError (int32_t coreErrorCode)
Throws a new Error instance from a sparksee_core error code.

Protected Attributes

std::string message
Message of the exception.

Detailed Description

IO error class.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

IOError::IOError ( const std::string & mess )

Creates a new instance.

Parameters
mess [in] Message of the exception.

Member Function Documentation

const std::string& Exception::Message ( ) const
inherited

Gets the message of the exception.

It should be called GetMessage but this is not possible because of a macro defined in Windows.

Returns
The message of the exception.
void Exception::SetMessage ( const std::string & mess )
inherited

Sets the message of the exception.

Parameters
mess [in] Message.
static void Error::ThrowError ( int32_t coreErrorCode )
staticinherited

Throws a new Error instance from a sparksee_core error code.

Parameters
coreErrorCode [in] Sparkseecore error code.
Returns
Depending on the given sparksee_core error, this will throw an Error instance of an specific Error subclass instance.
The documentation for this class was generated from the following file:
  • Exception.h


Sparksee: LicenseError Class Reference

Public Member Functions | Static Public Member Functions | Protected Attributes | List of all members
LicenseError Class Reference
Gdb

License error class. More...

Inheritance diagram for LicenseError:
Collaboration diagram for LicenseError:

Public Member Functions

LicenseError ()
Creates a new instance.
LicenseError (const std::string &mess)
Creates a new instance.
virtual | ~LicenseError ()
Destructor.
const std::string & | Message () const
Gets the message of the exception.
void | SetMessage (const std::string &mess)
Sets the message of the exception.

Static Public Member Functions

static void ThrowError (int32_t coreErrorCode)
Throws a new Error instance from a sparksee_core error code.

Protected Attributes

std::string message
Message of the exception.

Detailed Description

License error class.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

LicenseError::LicenseError ( const std::string & mess )

Creates a new instance.

Parameters
mess [in] Message of the exception.

Member Function Documentation

const std::string& Exception::Message ( ) const
inherited

Gets the message of the exception.

It should be called GetMessage but this is not possible because of a macro defined in Windows.

Returns
The message of the exception.
void Exception::SetMessage ( const std::string & mess )
inherited

Sets the message of the exception.

Parameters
mess [in] Message.
static void Error::ThrowError ( int32_t coreErrorCode )
staticinherited

Throws a new Error instance from a sparksee_core error code.

Parameters
coreErrorCode [in] Sparkseecore error code.
Returns
Depending on the given sparksee_core error, this will throw an Error instance of an specific Error subclass instance.
The documentation for this class was generated from the following file:
  • Exception.h


Sparksee: UnsupportedOperationError Class Reference

Public Member Functions | Static Public Member Functions | Protected Attributes | List of all members
UnsupportedOperationError Class Reference
Gdb

Unsupported operation error class. More...

Inheritance diagram for UnsupportedOperationError:
Collaboration diagram for UnsupportedOperationError:

Public Member Functions

UnsupportedOperationError ()
Creates a new instance.
UnsupportedOperationError (const std::string &mess)
Creates a new instance.
virtual | ~UnsupportedOperationError ()
Destructor.
const std::string & | Message () const
Gets the message of the exception.
void | SetMessage (const std::string &mess)
Sets the message of the exception.

Static Public Member Functions

static void ThrowError (int32_t coreErrorCode)
Throws a new Error instance from a sparksee_core error code.

Protected Attributes

std::string message
Message of the exception.

Detailed Description

Unsupported operation error class.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

UnsupportedOperationError::UnsupportedOperationError ( const std::string & mess )

Creates a new instance.

Parameters
mess [in] Message of the exception.

Member Function Documentation

const std::string& Exception::Message ( ) const
inherited

Gets the message of the exception.

It should be called GetMessage but this is not possible because of a macro defined in Windows.

Returns
The message of the exception.
void Exception::SetMessage ( const std::string & mess )
inherited

Sets the message of the exception.

Parameters
mess [in] Message.
static void Error::ThrowError ( int32_t coreErrorCode )
staticinherited

Throws a new Error instance from a sparksee_core error code.

Parameters
coreErrorCode [in] Sparkseecore error code.
Returns
Depending on the given sparksee_core error, this will throw an Error instance of an specific Error subclass instance.
The documentation for this class was generated from the following file:
  • Exception.h


Sparksee: QueryException Class Reference

Public Member Functions | Static Public Member Functions | Protected Attributes | List of all members
QueryException Class Reference
Gdb

Query exception class. More...

Inheritance diagram for QueryException:
Collaboration diagram for QueryException:

Public Member Functions

QueryException ()
Creates a new instance.
QueryException (const std::string &mess)
Creates a new instance.
QueryException (const sparksee_core::QueryError *core_error)
Creates a new instance.
QueryException (const sparksee_core::CypherError *cypher_error)
Creates a new instance.
virtual | ~QueryException ()
Destructor.
sparksee::gdb::int32_t GetOffset ()
Get thhe Offset in the query that may have triggered the error.
const std::string & | Message () const
Gets the message of the exception.
void | SetMessage (const std::string &mess)
Sets the message of the exception.

Static Public Member Functions

static void ThrowError (int32_t coreErrorCode)
Throws a new Error instance from a sparksee_core error code.

Protected Attributes

sparksee::gdb::int32_t m_offset
The Offset in the query that triggered the error.
std::string message
Message of the exception.

Detailed Description

Query exception class.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

QueryException::QueryException ( const std::string & mess )

Creates a new instance.

Parameters
mess [in] Message of the exception.
QueryException::QueryException ( const sparksee_core::QueryError * core_error )

Creates a new instance.

Parameters
core_error [in] Dexcore SQLError.
QueryException::QueryException ( const sparksee_core::CypherError * cypher_error )

Creates a new instance.

Parameters
core_error [in] Dexcore SQLError.

Member Function Documentation

const std::string& Exception::Message ( ) const
inherited

Gets the message of the exception.

It should be called GetMessage but this is not possible because of a macro defined in Windows.

Returns
The message of the exception.
void Exception::SetMessage ( const std::string & mess )
inherited

Sets the message of the exception.

Parameters
mess [in] Message.
static void Error::ThrowError ( int32_t coreErrorCode )
staticinherited

Throws a new Error instance from a sparksee_core error code.

Parameters
coreErrorCode [in] Sparkseecore error code.
Returns
Depending on the given sparksee_core error, this will throw an Error instance of an specific Error subclass instance.
The documentation for this class was generated from the following file:
  • Exception.h


Sparksee: EncryptionError Class Reference

Public Member Functions | Static Public Member Functions | Protected Attributes | List of all members
EncryptionError Class Reference
Gdb

Wrong encryption arguments error class. More...

Inheritance diagram for EncryptionError:
Collaboration diagram for EncryptionError:

Public Member Functions

EncryptionError ()
Creates a new instance.
EncryptionError (const std::string &mess)
Creates a new instance.
virtual | ~EncryptionError ()
Destructor.
const std::string & | Message () const
Gets the message of the exception.
void | SetMessage (const std::string &mess)
Sets the message of the exception.

Static Public Member Functions

static void ThrowError (int32_t coreErrorCode)
Throws a new Error instance from a sparksee_core error code.

Protected Attributes

std::string message
Message of the exception.

Detailed Description

Wrong encryption arguments error class.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

EncryptionError::EncryptionError ( const std::string & mess )

Creates a new instance.

Parameters
mess [in] Message of the exception.

Member Function Documentation

const std::string& Exception::Message ( ) const
inherited

Gets the message of the exception.

It should be called GetMessage but this is not possible because of a macro defined in Windows.

Returns
The message of the exception.
void Exception::SetMessage ( const std::string & mess )
inherited

Sets the message of the exception.

Parameters
mess [in] Message.
static void Error::ThrowError ( int32_t coreErrorCode )
staticinherited

Throws a new Error instance from a sparksee_core error code.

Parameters
coreErrorCode [in] Sparkseecore error code.
Returns
Depending on the given sparksee_core error, this will throw an Error instance of an specific Error subclass instance.
The documentation for this class was generated from the following file:
  • Exception.h


Sparksee: GraphExport Class Reference

Public Member Functions | List of all members
GraphExport Class Reference
Gdb

Stores the graph exporting values. More...

Public Member Functions

GraphExport ()
Creates a new GraphExport instance.
virtual | ~GraphExport ()
Destructor.
void | SetDefaults ()
Sets to default values.
const std::wstring & | GetLabel () const
Gets the graph label.
void | SetLabel (const std::wstring &label)
Sets the graph label.

Detailed Description

Stores the graph exporting values.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

const std::wstring& GraphExport::GetLabel ( ) const
inline

Gets the graph label.

Returns
The graph label.
void GraphExport::SetLabel ( const std::wstring & label )
inline

Sets the graph label.

Parameters
label [in] The graph label.
The documentation for this class was generated from the following file:
  • Export.h


Sparksee: NodeExport Class Reference

Public Member Functions | List of all members
NodeExport Class Reference
Gdb

Stores the node exporting values. More...

Public Member Functions

NodeExport ()
Creates a new instance.
virtual | ~NodeExport ()
Destructor.
void | SetDefaults ()
Sets to default values.
const std::wstring & | GetLabel () const
Gets the node label.
void | SetLabel (const std::wstring &label)
Sets the node label.
NodeShape | GetShape () const
Gets the node shape.
void | SetShape (NodeShape shape)
Sets the node shape.
ColorRGB | GetColorRGB () const
Gets the node color.
void | SetColorRGB (ColorRGB color)
Sets the node color.
ColorRGB | GetLabelColorRGB () const
Gets the node label color.
void | SetLabelColorRGB (ColorRGB color)
Sets the node label color.
int32_t | GetHeight () const
Gets the node height.
void | SetHeight (int32_t height)
Sets the node height.
int32_t | GetWidth () const
Gets the node width.
void | SetWidth (int32_t width)
Gets the node width.
bool_t | IsFit () const
Gets whether the node size is fitted to the label or not.
void | SetFit (bool_t fit)
Sets the node fit property.
int32_t | GetFontSize () const
Gets the node label font size.
void | SetFontSize (int32_t size)
Sets the node label font size.

Detailed Description

Stores the node exporting values.

When 'fit' is set to TRUE, then 'height' and 'width' will be ignored.

Some properties may be ignored depending on the exportation type.

Default values are:

Label: "" (empty string).

Shape: Box.

Color: 10863606 (0xa5c3f6).

Label color: 0 (Ox000000, Black).

Height: 25px.

Width: 25px.

Fit: TRUE.

Font size: 10.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

ColorRGB NodeExport::GetColorRGB ( ) const
inline

Gets the node color.

Returns
The node color.
int32_t NodeExport::GetFontSize ( ) const
inline

Gets the node label font size.

Returns
The node label font size.
int32_t NodeExport::GetHeight ( ) const
inline

Gets the node height.

Returns
The node height in pixels.
const std::wstring& NodeExport::GetLabel ( ) const
inline

Gets the node label.

Returns
The node label.
ColorRGB NodeExport::GetLabelColorRGB ( ) const
inline

Gets the node label color.

Returns
The node label color.
NodeShape NodeExport::GetShape ( ) const
inline

Gets the node shape.

Returns
The node shape.
int32_t NodeExport::GetWidth ( ) const
inline

Gets the node width.

Returns
The node width in pixels.
bool_t NodeExport::IsFit ( ) const
inline

Gets whether the node size is fitted to the label or not.

Returns
If TRUE, then the node size is fitted to the label, otherwise the size is fixed with the values of 'height' and 'width'.
void NodeExport::SetColorRGB ( ColorRGB color )
inline

Sets the node color.

Parameters
color The node color.
void NodeExport::SetFit ( bool_t fit )
inline

Sets the node fit property.

Parameters
fit [in] If TRUE, then the node size is fitted to the label ('height' and 'width' will be ignored), otherwise the size is fixed with the values of 'height' and 'width'.
void NodeExport::SetFontSize ( int32_t size )
inline

Sets the node label font size.

Parameters
size [in] The node label font size.
void NodeExport::SetHeight ( int32_t height )
inline

Sets the node height.

Parameters
height [in] The node height in pixels.
void NodeExport::SetLabel ( const std::wstring & label )
inline

Sets the node label.

Parameters
label [in] The node label.
void NodeExport::SetLabelColorRGB ( ColorRGB color )
inline

Sets the node label color.

Parameters
color [in] The node label color.
void NodeExport::SetShape ( NodeShape shape )
inline

Sets the node shape.

Parameters
shape [in] The node shape.
void NodeExport::SetWidth ( int32_t width )
inline

Gets the node width.

Parameters
width The node width in pixels.
The documentation for this class was generated from the following file:
  • Export.h


Sparksee: EdgeExport Class Reference

Public Member Functions | List of all members
EdgeExport Class Reference
Gdb

Stores edge exporting values. More...

Public Member Functions

EdgeExport ()
Creates a new instance.
virtual | ~EdgeExport ()
Destructor.
void | SetDefaults ()
Sets to default values.
const std::wstring & | GetLabel () const
Gets the edge label.
void | SetLabel (const std::wstring &label)
Sets the edge label.
bool_t | AsDirected () const
Gets if the edge should be managed as directed.
void | SetAsDirected (bool_t directed)
Sets if the edge should be managed as directed.
ColorRGB | GetColorRGB () const
Gets the edge color.
void | SetColorRGB (ColorRGB color)
Sets the edge color.
ColorRGB | GetLabelColorRGB () const
Gets the edge label color.
void | SetLabelColorRGB (ColorRGB color)
Sets the edge label color.
int32_t | GetWidth () const
Gets the edge width.
void | SetWidth (int32_t width)
Sets the edge width.
int32_t | GetFontSize () const
Gets the edge label font size.
void | SetFontSize (int32_t size)
Sets the edge label font size.

Detailed Description

Stores edge exporting values.

Some properties may be ignored depending on the exportation type.

Default values are:

Label: "" (empty string).

As directed: TRUE.

Color: 13882323 (OxD3D3D3, Light gray).

Label color: 0 (Ox000000, Black).

Width: 5px.

Font size: 10.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

bool_t EdgeExport::AsDirected ( ) const
inline

Gets if the edge should be managed as directed.

TRUE is the default value. If TRUE, use as directed, otherwise use as undirected.

Returns
The edge direction.
ColorRGB EdgeExport::GetColorRGB ( ) const
inline

Gets the edge color.

Returns
The edge color.
int32_t EdgeExport::GetFontSize ( ) const
inline

Gets the edge label font size.

Returns
The edge label font size.
const std::wstring& EdgeExport::GetLabel ( ) const
inline

Gets the edge label.

Returns
The edge label.
ColorRGB EdgeExport::GetLabelColorRGB ( ) const
inline

Gets the edge label color.

Returns
The edge label color.
int32_t EdgeExport::GetWidth ( ) const
inline

Gets the edge width.

Returns
The edge width.
void EdgeExport::SetAsDirected ( bool_t directed )
inline

Sets if the edge should be managed as directed.

Parameters
directed [in] If TRUE, use as directed, otherwise use as undirected.
void EdgeExport::SetColorRGB ( ColorRGB color )
inline

Sets the edge color.

Parameters
color [in] The edge color.
void EdgeExport::SetFontSize ( int32_t size )
inline

Sets the edge label font size.

Parameters
size [in] The edge label font size.
void EdgeExport::SetLabel ( const std::wstring & label )
inline

Sets the edge label.

Parameters
label [in] The edge label.
void EdgeExport::SetLabelColorRGB ( ColorRGB color )
inline

Sets the edge label color.

Parameters
color [in] The edge label color.
void EdgeExport::SetWidth ( int32_t width )
inline

Sets the edge width.

Parameters
width [in] The edge width.
The documentation for this class was generated from the following file:
  • Export.h


Sparksee: ExportManager Class Reference

Public Member Functions | List of all members
ExportManager Class Referenceabstract
Gdb

Defines how to export a graph to an external format. More...

Inheritance diagram for ExportManager:

Public Member Functions

virtual | ~ExportManager ()
Destructor.
virtual void | Prepare (Graph *graph)=0
Prepares the graph for the export process.
virtual void | Release ()=0
Ends the export process.
virtual bool_t | GetGraph (GraphExport &graphExport)=0
Gets the graph export definition.
virtual bool_t | GetNodeType (type_t type, NodeExport &nodeExport)=0
Gets the default node export definition for the given node type.
virtual bool_t | GetEdgeType (type_t type, EdgeExport &edgeExport)=0
Gets the default node export definition for the given edge type.
virtual bool_t | GetNode (oid_t node, NodeExport &nodeExport)=0
Gets the node export definition for the given node.
virtual bool_t | GetEdge (oid_t edge, EdgeExport &edgeExport)=0
Gets the edge export definition for the given edge.
virtual bool_t | EnableType (type_t type)=0
Gets whether a node or edge type must be exported or not.

Detailed Description

Defines how to export a graph to an external format.

This is an interface which must be implemented by the user. While the export proces, a call for each node or edge type and node or edge object is done to get how to export that element.

It is possible to export a Graph to a diferent fortmats. Nowadays, available formats are defined in the ExportType enum.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

virtual bool_t ExportManager::EnableType ( type_t type )
pure virtual

Gets whether a node or edge type must be exported or not.

Parameters
type Node or edge type identifier.
Returns
If TRUE all objects of the given type will be exported, otherwise they will not be exported.

Implemented in DefaultExport.

virtual bool_t ExportManager::GetEdge | ( | oid_t | edge,
 |  | EdgeExport & | edgeExport
 | ) |  |
pure virtual

Gets the edge export definition for the given edge.

Parameters
edge | Edge identifier.
edgeExport | [out] The EdgeExport which defines how to export given edge.
Returns
TRUE if the given EdgeExport has been updated, otherwise FALSE will be returned and the default EdgeExport for the type the edge belongs to will be used.

Implemented in DefaultExport.

virtual bool_t ExportManager::GetEdgeType | ( | type_t | type,
 |  | EdgeExport & | edgeExport
 | ) |  |
pure virtual

Gets the default node export definition for the given edge type.

GetEdge has a higher priority than this function. That is, only if GetEdge returns FALSE, the EdgeExport of this function will be used.

Parameters
type | [in] Edge type identifier.
edgeExport | [out] The EdgeExport which defines how to export the edges of the given type.
Returns
TRUE.

Implemented in DefaultExport.

virtual bool_t ExportManager::GetGraph ( GraphExport & graphExport )
pure virtual

Gets the graph export definition.

Parameters
graphExport [out] The GraphExport which defines how to export the graph.
Returns
TRUE.

Implemented in DefaultExport.

virtual bool_t ExportManager::GetNode | ( | oid_t | node,
 |  | NodeExport & | nodeExport
 | ) |  |
pure virtual

Gets the node export definition for the given node.

Parameters
node | Node identifier.
nodeExport | [out] The NodeExport which defines how to export given node.
Returns
TRUE if the given NodeExport has been updated, otherwise FALSE will be returned and the default NodeExport for the type the node belongs to will be used.

Implemented in DefaultExport.

virtual bool_t ExportManager::GetNodeType | ( | type_t | type,
 |  | NodeExport & | nodeExport
 | ) |  |
pure virtual

Gets the default node export definition for the given node type.

GetNode has a higher priority than this function. That is, only if GetNode returns FALSE, the NodeExport of this function will be used.

Parameters
type | [in] Node type identifier.
nodeExport | [out] The NodeExport which defines how to export the nodes of the given type.
Returns
TRUE.

Implemented in DefaultExport.

virtual void ExportManager::Prepare ( Graph * graph )
pure virtual

Prepares the graph for the export process.

It is called once before the export process.

Parameters
graph Graph to be exported.

Implemented in DefaultExport.

virtual void ExportManager::Release ( )
pure virtual

Ends the export process.

It is called once after the export process.

Implemented in DefaultExport.

The documentation for this class was generated from the following file:
  • Export.h


Sparksee: DefaultExport Class Reference

Public Member Functions | List of all members
DefaultExport Class Reference
Gdb

Default implementation for ExportManager class. More...

Inheritance diagram for DefaultExport:
Collaboration diagram for DefaultExport:

Public Member Functions

DefaultExport ()
Creates a new instance.
virtual | ~DefaultExport ()
Destructor.
void | Prepare (Graph *graph)
Default implementation of the ExportManager class method Prepare.
void | Release ()
Default implementation of the ExportManager class method Release.
bool_t | GetGraph (GraphExport &graphExport)
Default implementation of the ExportManager class method GetGraph.
bool_t | GetNodeType (type_t type, NodeExport &nodeExport)
Default implementation of the ExportManager class method GetNodeType.
bool_t | GetEdgeType (type_t type, EdgeExport &edgeExport)
Default implementation of the ExportManager class method GetEdgeType.
bool_t | GetNode (oid_t node, NodeExport &nodeExport)
Default implementation of the ExportManager class method GetNode.
bool_t | GetEdge (oid_t edge, EdgeExport &edgeExport)
Default implementation of the ExportManager class method GetEdge.
bool_t | EnableType (type_t type)
Default implementation of the ExportManager class method EnableType.

Detailed Description

Default implementation for ExportManager class.

It uses the default values from GraphExport, NodeExport and EdgeExport to export all node and edge types.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

bool_t DefaultExport::EnableType ( type_t type )
virtual

Default implementation of the ExportManager class method EnableType.

This enables all node and edge types to be exported.

Parameters
type [in] The type to enable.
Returns
TRUE.

Implements ExportManager.

bool_t DefaultExport::GetEdge | ( | oid_t | edge,
 |  | EdgeExport & | edgeExport
 | ) |  |
virtual

Default implementation of the ExportManager class method GetEdge.

This sets the default EdgeExport values and sets the OID as the label. Also, it exports the edge as directed just if the edge is directed.

Parameters
edge | [in] An edge.
edgeExport | [out] The EdgeExport that will store the information.
Returns
TRUE.

Implements ExportManager.

bool_t DefaultExport::GetEdgeType | ( | type_t | type,
 |  | EdgeExport & | edgeExport
 | ) |  |
virtual

Default implementation of the ExportManager class method GetEdgeType.

This sets de default EdgeExport values.

Parameters
type | [in] An edge type.
edgeExport | [out] The EdgeExport that will store the information.
Returns
TRUE.

Implements ExportManager.

bool_t DefaultExport::GetGraph ( GraphExport & graphExport )
virtual

Default implementation of the ExportManager class method GetGraph.

This sets the default GraphExport values and "Graph" as the label.

Parameters
graphExport [out] The GraphExport that will store the information.
Returns
TRUE.

Implements ExportManager.

bool_t DefaultExport::GetNode | ( | oid_t | node,
 |  | NodeExport & | nodeExport
 | ) |  |
virtual

Default implementation of the ExportManager class method GetNode.

This sets the default NodeExport values and sets the OID as the label.

Parameters
node | [in] A node.
nodeExport | [out] The NodeExport that will store the information.
Returns
TRUE.

Implements ExportManager.

bool_t DefaultExport::GetNodeType | ( | type_t | type,
 |  | NodeExport & | nodeExport
 | ) |  |
virtual

Default implementation of the ExportManager class method GetNodeType.

This sets de default NodeExport values.

Parameters
type | [in] A node type.
nodeExport | [out] The NodeExport that will store the information.
Returns
TRUE.

Implements ExportManager.

The documentation for this class was generated from the following file:
  • Export.h


Sparksee: Graph Class Reference

Public Member Functions | Private Member Functions | Friends | List of all members
Graph Class Reference
Gdb

Graph class. More...

Inheritance diagram for Graph:
Collaboration diagram for Graph:

Public Member Functions

virtual | ~Graph ()
Destructor.
type_t | NewNodeType (const std::wstring &name)
Creates a new node type.
oid_t | NewNode (type_t type)
Creates a new node instance.
type_t | NewEdgeType (const std::wstring &name, bool_t directed, bool_t neighbors)
Creates a new edge type.
type_t | NewRestrictedEdgeType (const std::wstring &name, type_t tail, type_t head, bool_t neighbors)
Creates a new restricted edge type.
void | IndexNeighbors (type_t edgeType, bool_t neighbors)
Creates or destroys the neighbors index of an edge type.
oid_t | NewEdge (type_t type, oid_t tail, oid_t head)
Creates a new edge instance.
oid_t | NewEdge (type_t type, attr_t tailAttr, Value &tailV, attr_t headAttr, Value &headV)
Creates a new edge instance.
int64_t CountNodes ()
Gets the number of nodes.
int64_t CountEdges ()
Gets the number of edges.
EdgeData * | GetEdgeData (oid_t edge)
Gets information about an edge.
oid_t | GetEdgePeer (oid_t edge, oid_t node)
Gets the other end for the given edge.
void | Drop (oid_t oid)
Drops the given OID.
void | Drop (Objects *objs)
Drops all the OIDs from the given collection.
type_t | GetObjectType (oid_t oid)
Gets the Sparksee node or edge type identifier for the given OID.
attr_t | NewAttribute (type_t type, const std::wstring &name, DataType dt, AttributeKind kind)
Creates a new attribute.
attr_t | NewAttribute (type_t type, const std::wstring &name, DataType dt, AttributeKind kind, Value &defaultValue)
Creates a new attribute with a default value.
attr_t | NewSessionAttribute (type_t type, DataType dt, AttributeKind kind)
Creates a new Session attribute.
attr_t | NewSessionAttribute (type_t type, DataType dt, AttributeKind kind, Value &defaultValue)
Creates a new Session attribute with a default value.
attr_t | NewArrayAttribute (type_t type, const std::wstring &name, DataType dt, int32_t size)
Creates a new array attribute.
attr_t | NewSessionArrayAttribute (type_t type, DataType dt, int32_t size)
Creates a new Session array attribute.
void | SetAttributeDefaultValue (attr_t attr, Value &value)
Sets a default value for an attribute.
void | IndexAttribute (attr_t attr, AttributeKind kind)
Updates the index of the given attribute.
void | GetAttribute (oid_t oid, attr_t attr, Value &value)
Gets the Value for the given attribute and OID.
Value * | GetAttribute (oid_t oid, attr_t attr)
Gets the Value for the given attribute and OID.
TextStream * | GetAttributeText (oid_t oid, attr_t attr)
Gets the read-only TextStream for the given text attribute and OID.
void | SetAttributeText (oid_t oid, attr_t attr, TextStream *tstream)
Sets the writable TextStream for the given text attribute and OID.
ValueArray * | GetArrayAttribute (oid_t oid, attr_t attr)
Gets the ValueArray for the given array attribute and OID or NULL if it does not exist.
ValueArray * | SetArrayAttribute (oid_t oid, attr_t attr, const Value &value)
Sets all the elements of the ValueArray for the given array attribute and OID and returns it.
void | SetArrayAttributeVoid (oid_t oid, attr_t attr, const Value &value)
Sets all the elements of the ValueArray for the given array attribute and OID.
void | SetArrayAttribute (attr_t attr, const Value &value)
Sets all the values of the array of the given array attribute for all the objects of the types the attribute applies to.
void | SetAttribute (oid_t oid, attr_t attr, Value &value)
Sets the Value for the given attribute and OID.
AttributeStatistics * | GetAttributeStatistics (attr_t attr, bool_t basic)
Gets statistics from the given attribute.
int64_t | GetAttributeIntervalCount (attr_t attr, Value &lower, bool_t includeLower, Value &higher, bool_t includeHigher)
Gets how many objects have a value into the given range for the given attribute.
void | SetAttribute (attr_t attr, Value &value)
Sets the value of the given attribute for all the objects of the types the attribute applies to.
type_t | FindType (const std::wstring &name)
Gets the Sparksee type identifier for the given type name.
Type * | GetType (type_t type)
Gets information about the given type.
void | RemoveType (type_t type)
Removes the given type.
void | RenameType (const std::wstring &oldName, const std::wstring &newName)
Renames a type.
void | RenameType (type_t type, const std::wstring &newName)
Renames a type.
attr_t | FindAttribute (type_t type, const std::wstring &name)
Gets the Sparksee attribute identifier for the given type identifier and attribute name.
Attribute * | GetAttribute (attr_t attr)
Gets information about the given attribute.
void | RemoveAttribute (attr_t attr)
Removes the given attribute.
void | RenameAttribute (attr_t attr, const std::wstring &newName)
Renames an attribute.
oid_t | FindObject (attr_t attr, Value &value)
Finds one object having the given Value for the given attribute.
oid_t | FindOrCreateObject (attr_t attr, Value &value)
Finds one object having the given Value for the attribute or it creates one does not exist any.
Objects * | Select (type_t type)
Selects all OIDs belonging to the given type.
Objects * | Select (attr_t attr, Condition cond, const Value &value)
Selects all OIDs satisfying the given condition for the given attribute.
Objects * | Select (attr_t attr, Condition cond, const Value &lower, const Value &higher)
Selects all OIDs satisfying the given condition for the given attribute.
Objects * | Select (attr_t attr, Condition cond, const Value &value, const Objects *restriction)
Selects all OIDs satisfying the given condition for the given attribute.
Objects * | Select (attr_t attr, Condition cond, const Value &lower, const Value &higher, const Objects *restriction)
Selects all OIDs satisfying the given condition for the given attribute.
KeyValues * | TopK (attr_t attribute, Order order, int32_t k)
Gets a KeyValues iterator as a result of the TopK operation.
KeyValues * | TopK (attr_t attribute, Condition operation, const Value &lower, Order order, int32_t k)
Gets a KeyValues iterator as a result of the TopK operation.
KeyValues * | TopK (attr_t attribute, Condition operation, const Value &lower, const Value &higher, Order order, int32_t k)
Gets a KeyValues iterator as a result of the TopK operation.
KeyValues * | TopK (attr_t attribute, Order order, int32_t k, Objects *restriction)
Gets a KeyValues iterator as a result of the TopK operation.
KeyValues * | TopK (attr_t attribute, Condition operation, const Value &lower, Order order, int32_t k, Objects *restriction)
Gets a KeyValues iterator as a result of the TopK operation.
KeyValues * | TopK (attr_t attribute, Condition operation, const Value &lower, const Value &higher, Order order, int32_t k, Objects *restriction)
Gets a KeyValues iterator as a result of the TopK operation.
Objects * | Explode (oid_t oid, type_t etype, EdgesDirection dir)
Selects all edges from or to the given node OID and for the given edge type.
Objects * | Explode (Objects *objs, type_t etype, EdgesDirection dir)
Selects all edges from or to each of the node OID in the given collection and for the given edge type.
int64_t | Degree (oid_t oid, type_t etype, EdgesDirection dir)
Gets the number of edges from or to the given node OID and for the given edge type.
Objects * | Neighbors (oid_t oid, type_t etype, EdgesDirection dir)
Selects all neighbor nodes from or to the given node OID and for the given edge type.
Objects * | Neighbors (Objects *objs, type_t etype, EdgesDirection dir)
Selects all neighbor nodes from or to each of the node OID in the given collection and for the given edge type.
Objects * | Edges (type_t etype, oid_t tail, oid_t head)
Gets all the edges of the given type between two given nodes (tail and head).
oid_t | FindEdge (type_t etype, oid_t tail, oid_t head)
Gets any of the edges of the given type between two given nodes (tail and head).
oid_t | FindOrCreateEdge (type_t etype, oid_t tail, oid_t head)
Gets any of the edges of the specified type between two given nodes (tail and head).
Objects * | Tails (Objects *edges)
Gets all the tails from the given edges collection.
Objects * | Heads (Objects *edges)
Gets all the heads from the given edges collection.
void | TailsAndHeads (Objects *edges, Objects *tails, Objects *heads)
Gets all the tails and heads from the given edges collection.
TypeList * FindNodeTypes ()
Gets all existing Sparksee node type identifiers.
TypeList * FindEdgeTypes ()
Gets all existing Sparksee edge type identifiers.
TypeList * FindTypes ()
Gets all existing Sparksee node and edge type identifiers.
AttributeList * | FindAttributes (type_t type)
Gets all existing Sparksee attribute identifiers for the given type identifier.
AttributeList * | GetAttributes (oid_t oid)
Gets all Sparksee attribute identifiers with a non-NULL value for the given Sparksee OID.
Values * | GetValues (attr_t attr)
Gets the Value collection for the given attribute.
void | DumpData (const std::wstring &file) throw (sparksee::gdb::FileNotFoundException, sparksee::gdb::Error)
Dumps logical data to a file.
void | DumpStorage (const std::wstring &file) throw (sparksee::gdb::FileNotFoundException, sparksee::gdb::Error)
Dumps internal storage data to a file.
void | Export (const std::wstring &file, ExportType type, ExportManager *em) throw (sparksee::gdb::IOException)
Exports the Graph.
void | Backup (const std::wstring &file) throw (sparksee::gdb::FileNotFoundException, sparksee::gdb::Error)
Dumps all the data to a backup file.
void | EncryptedBackup (const std::wstring &file, const std::wstring &keyInHex, const std::wstring &ivInHex) throw (sparksee::gdb::FileNotFoundException, sparksee::gdb::Error)
Dumps all the data to a backup file.

Private Member Functions

sparksee_core::DbGraph * | GetHandler ()
Gets the handled reference.
const sparksee_core::DbGraph * | GetHandler () const
Gets the handled reference.
void | SetHandler (sparksee_core::DbGraph *h)
Sets the handled reference.
void | FreeHandler ()
Frees (deletes) the handled reference.
bool_t | IsNull () const
Gets if the handler is NULL.

Friends

class | Session
class | Values
class | ValuesIterator

Detailed Description

Graph class.

Each Database has a Graph associated, which is the persistent graph which contains all data stored into the graph database and is retrieved from a Session.

Check out the 'API' and the 'SPARKSEE graph database' sections in the SPARKSEE User Manual for more details on the use of this class.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

void Graph::Backup ( const std::wstring & file ) throw (sparksee::gdb::FileNotFoundException, sparksee::gdb::Error)

Dumps all the data to a backup file.

See the Sparksee class Restore methods.

Parameters
file [in] Output backup file path.
Exceptions
FileNotFoundException If the given file cannot be created.
int64_t Graph::CountEdges ( )

Gets the number of edges.

Returns
The number of edges.
int64_t Graph::CountNodes ( )

Gets the number of nodes.

Returns
The number of nodes.
int64_t Graph::Degree | ( | oid_t | oid,
 |  | type_t | etype,
 |  | EdgesDirection | dir
 | ) |  |

Gets the number of edges from or to the given node OID and for the given edge type.

Parameters
oid | [in] Sparksee node OID.
etype | [in] Sparksee edge type identifier.
dir | [in] Direction.
Returns
The number of edges.
void Graph::Drop ( oid_t oid )

Drops the given OID.

It also removes its egdges as well as its attribute values.

Parameters
oid [in] Sparksee OID to be removed.
void Graph::Drop ( Objects * objs )

Drops all the OIDs from the given collection.

See Drop method with the single OID parameter. This performs the same operation for each object in the given set.

Parameters
objs [in] Objects collection with the OIDs to be removed.
void Graph::DumpData ( const std::wstring & file ) throw (sparksee::gdb::FileNotFoundException, sparksee::gdb::Error)

Dumps logical data to a file.

Parameters
file [in] Output file path.
Exceptions
FileNotFoundException If the given file cannot be created.
void Graph::DumpStorage ( const std::wstring & file ) throw (sparksee::gdb::FileNotFoundException, sparksee::gdb::Error)

Dumps internal storage data to a file.

Parameters
file [in] Output file path.
Exceptions
FileNotFoundException If the given file cannot be created.
Objects* Graph::Edges | ( | type_t | etype,
 |  | oid_t | tail,
 |  | oid_t | head
 | ) |  |

Gets all the edges of the given type between two given nodes (tail and head).

Parameters
etype | [in] Sparksee edge type identifier.
tail | [in] Tail node identifier.
head | [in] Head node identifier.
Returns
Objects instance.
void Graph::EncryptedBackup | ( | const std::wstring & | file,
 |  | const std::wstring & | keyInHex,
 |  | const std::wstring & | ivInHex
 | ) |  | throw (sparksee::gdb::FileNotFoundException, sparksee::gdb::Error)

Dumps all the data to a backup file.

See the Sparksee class RestoreEncryptedBackup methods.

Parameters
file | [in] Output backup file path.
keyInHex | [In] The AES encryption Key as an hexadecimal string (8, 16 or 32 bytes).
ivInHex | [In] The AES Initialization Vector as an hexadecimal string (16 bytes).
Exceptions
FileNotFoundException If the given file cannot be created.
Objects* Graph::Explode | ( | oid_t | oid,
 |  | type_t | etype,
 |  | EdgesDirection | dir
 | ) |  |

Selects all edges from or to the given node OID and for the given edge type.

Parameters
oid | [in] Sparksee node OID.
etype | [in] Sparksee edge type identifier.
dir | [in] Direction.
Returns
Objects instance.
Objects* Graph::Explode | ( | Objects * | objs,
 |  | type_t | etype,
 |  | EdgesDirection | dir
 | ) |  |

Selects all edges from or to each of the node OID in the given collection and for the given edge type.

Parameters
objs | [in] Sparksee node OID collection.
etype | [in] Sparksee edge type identifier.
dir | [in] Direction.
Returns
Objects instance.
void Graph::Export | ( | const std::wstring & | file,
 |  | ExportType | type,
 |  | ExportManager * | em
 | ) |  | throw (sparksee::gdb::IOException)

Exports the Graph.

Parameters
file | [in] Output file.
type | [in] Export type.
em | [in] Defines how to do the export for each graph object.
attr_t Graph::FindAttribute | ( | type_t | type,
 |  | const std::wstring & | name
 | ) |  |

Gets the Sparksee attribute identifier for the given type identifier and attribute name.

Parameters
type | [in] Sparksee type identifier.
name | [in] Unique attribute name.
Returns
The Sparksee attribute identifier for the given type and attribute name or InvalidAttribute if there is no attribute with the given name for the given type.
AttributeList* Graph::FindAttributes ( type_t type )

Gets all existing Sparksee attribute identifiers for the given type identifier.

Parameters
type [in] Sparksee type identifier.
Returns
Sparksee attribute identifier list.
oid_t Graph::FindEdge | ( | type_t | etype,
 |  | oid_t | tail,
 |  | oid_t | head
 | ) |  |

Gets any of the edges of the given type between two given nodes (tail and head).

If there are more than one, then any of them will be returned. And in case there are no edge between the given tail and head, the Objects InvalidOID will be returned.

Parameters
etype | [in] Sparksee edge type identifier.
tail | [in] Tail node identifier.
head | [in] Head node identifier.
Returns
Any of the edges or the Objects InvalidOID.
TypeList* Graph::FindEdgeTypes ( )

Gets all existing Sparksee edge type identifiers.

Returns
Sparksee edge type identifier list.
TypeList* Graph::FindNodeTypes ( )

Gets all existing Sparksee node type identifiers.

Returns
Sparksee node type identifier list.
oid_t Graph::FindObject | ( | attr_t | attr,
 |  | Value & | value
 | ) |  |

Finds one object having the given Value for the given attribute.

If there are more than one, then any of them will be returned. And in case there are no object having this Value, the Objects InvalidOID will be returned.

Parameters
attr | [in] Sparksee attribute identifier.
value | [in] Value.
Returns
Sparksee OID or the Objects InvalidOID.
oid_t Graph::FindOrCreateEdge | ( | type_t | etype,
 |  | oid_t | tail,
 |  | oid_t | head
 | ) |  |

Gets any of the edges of the specified type between two given nodes (tail and head).

If it can not find any edge of this type between them it tries to create a new one.

Parameters
etype | [in] Sparksee edge type identifier.
tail | [in] Tail node identifier.
head | [in] Head node identifier.
Returns
Any of the edges or the Objects InvalidOID.
oid_t Graph::FindOrCreateObject | ( | attr_t | attr,
 |  | Value & | value
 | ) |  |

Finds one object having the given Value for the attribute or it creates one does not exist any.

If the attribute is a node or edge attribute and at least one node/edge with that value is found, it returns one of them. But if it does not exist, then: If it's a node attribute it will create it and set the attribute. If it's an edge attribute it will return the InvalidOID.

Using this method with a global attribute will return the InvalidOID.

Parameters
attr | [in] Sparksee attribute identifier.
value | [in] Value.
Returns
Sparksee OID or the Objects InvalidOID.
type_t Graph::FindType ( const std::wstring & name )

Gets the Sparksee type identifier for the given type name.

Parameters
name [in] Unique type name.
Returns
The Sparksee type identifier for the given type name or the Type InvalidType if there is no type with the given name.
TypeList* Graph::FindTypes ( )

Gets all existing Sparksee node and edge type identifiers.

Returns
Sparksee node and edge type identifier list.
ValueArray* Graph::GetArrayAttribute | ( | oid_t | oid,
 |  | attr_t | attr
 | ) |  |

Gets the ValueArray for the given array attribute and OID or NULL if it does not exist.

Parameters
oid | [in] Sparksee OID.
attr | [in] Sparksee array attribute identifier.
Returns
A ValueArray. This returns a ValueArray, a NULL or throws an exception.
void Graph::GetAttribute | ( | oid_t | oid,
 |  | attr_t | attr,
 |  | Value & | value
 | ) |  |

Gets the Value for the given attribute and OID.

Parameters
oid | [in] Sparksee OID.
attr | [in] Sparksee attribute identifier.
value | [in|out] Value for the given attribute and for the given OID.
Value* Graph::GetAttribute | ( | oid_t | oid,
 |  | attr_t | attr
 | ) |  |

Gets the Value for the given attribute and OID.

The other version of this call, where the Value is an output parameter instead of the return, is better because it allows the user to reuse an existing Value instance, whereas this call always creates a new Value instance to be returned.

It never returns NULL. Thus, in case the OID has a NULL value for the attribute it returns a NULL Value instance.

Parameters
oid | [in] Sparksee OID.
attr | [in] Sparksee attribute identifier.
Returns
A new Value instance having the attribute value for the given OID.
Attribute* Graph::GetAttribute ( attr_t attr )

Gets information about the given attribute.

Parameters
attr [in] Sparksee attribute identifier.
Returns
The Attribute for the given Sparksee attribute identifier.
int64_t Graph::GetAttributeIntervalCount | ( | attr_t | attr,
 |  | Value & | lower,
 |  | bool_t | includeLower,
 |  | Value & | higher,
 |  | bool_t | includeHigher
 | ) |  |

Gets how many objects have a value into the given range for the given attribute.

This only works for the attributes with the AttributeKind Indexed or Unique.

Given values must belong to the same DataType than the attribute.

Parameters
attr | [in] Sparksee attribute identifier.
lower | [in] Lower bound Value of the range.
includeLower | [in] If TRUE, include lower bound Value of the range.
higher | [in] Higher bound Value of the range.
includeHigher | [in] If TRUE, include higher bound Value of the range.
Returns
Number of objects having a value into the given range.
AttributeList* Graph::GetAttributes ( oid_t oid )

Gets all Sparksee attribute identifiers with a non-NULL value for the given Sparksee OID.

Parameters
oid [in] Sparksee OID.
Returns
Sparksee attribute identifier list.
AttributeStatistics* Graph::GetAttributeStatistics | ( | attr_t | attr,
 |  | bool_t | basic
 | ) |  |

Gets statistics from the given attribute.

The statistics can only be obtained from Indexed or Unique attributes.

Parameters
attr | [in] Sparksee attribute identifier.
basic | [in] If FALSE all statistics are computed, if TRUE just those statistics marked as basic will be computed (see description of the AttributeStatistics class). Of course, computing just basic statistics will be faster than computing all of them.
Returns
An AttributeStatistics instace.
TextStream* Graph::GetAttributeText | ( | oid_t | oid,
 |  | attr_t | attr
 | ) |  |

Gets the read-only TextStream for the given text attribute and OID.

Parameters
oid | [in] Sparksee OID.
attr | [in] Sparksee attribute identifier.
Returns
A TextStream. This returns a TextStream to read.
EdgeData* Graph::GetEdgeData ( oid_t edge )

Gets information about an edge.

Parameters
edge [in] Sparksee edge identifier.
Returns
An EdgeData instance.
oid_t Graph::GetEdgePeer | ( | oid_t | edge,
 |  | oid_t | node
 | ) |  |

Gets the other end for the given edge.

Parameters
edge | [in] Sparksee edge identifier.
node | [in] Sparksee node identifier. It must be one of the ends of the edge.
Returns
The other end of the edge.
type_t Graph::GetObjectType ( oid_t oid )

Gets the Sparksee node or edge type identifier for the given OID.

Parameters
oid [in] Sparksee OID.
Returns
Sparksee node or edge type identifier.
Type* Graph::GetType ( type_t type )

Gets information about the given type.

Parameters
type [in] Sparksee type identifier.
Returns
The Type for the given Sparksee type identifier.
Values* Graph::GetValues ( attr_t attr )

Gets the Value collection for the given attribute.

Parameters
attr [in] Sparksee attribute identifier.
Returns
Returns a Values object.
Objects* Graph::Heads ( Objects * edges )

Gets all the heads from the given edges collection.

Parameters
edges [in] Sparksee edge identifier collection.
Returns
The heads collection.
void Graph::IndexAttribute | ( | attr_t | attr,
 |  | AttributeKind | kind
 | ) |  |

Updates the index of the given attribute.

This just works if the current index of the attribute corresponds to the AttributeKind Basic and the new one is Indexed or Unique.

Parameters
attr | [in] Sparksee attribute identifier.
kind | [in] Attribute kind.
void Graph::IndexNeighbors | ( | type_t | edgeType,
 |  | bool_t | neighbors
 | ) |  |

Creates or destroys the neighbors index of an edge type.

Parameters
edgeType | [in] Sparksee Edge type identifier.
neighbors | [in] If TRUE, it indexes the neighbor nodes, otherwise it removes the index.
Objects* Graph::Neighbors | ( | oid_t | oid,
 |  | type_t | etype,
 |  | EdgesDirection | dir
 | ) |  |

Selects all neighbor nodes from or to the given node OID and for the given edge type.

Parameters
oid | [in] Sparksee node OID.
etype | [in] Sparksee edge type identifier.
dir | [in] Direction.
Returns
Objects instance.
Objects* Graph::Neighbors | ( | Objects * | objs,
 |  | type_t | etype,
 |  | EdgesDirection | dir
 | ) |  |

Selects all neighbor nodes from or to each of the node OID in the given collection and for the given edge type.

Parameters
objs | [in] Sparksee node OID collection.
etype | [in] Sparksee edge type identifier.
dir | [in] Direction.
Returns
Objects instance.
attr_t Graph::NewArrayAttribute | ( | type_t | type,
 |  | const std::wstring & | name,
 |  | DataType | dt,
 |  | int32_t | size
 | ) |  |

Creates a new array attribute.

Parameters
type | [in] Sparksee node or edge type identifier.
name | [in] Unique name for the new attribute.
dt | [in] Base Data type for the new array attribute elements.
size | [in] The array size.
Returns
Unique Sparksee attribute identifier.
attr_t Graph::NewAttribute | ( | type_t | type,
 |  | const std::wstring & | name,
 |  | DataType | dt,
 |  | AttributeKind | kind
 | ) |  |

Creates a new attribute.

Parameters
type | [in] Sparksee node or edge type identifier.
name | [in] Unique name for the new attribute.
dt | [in] Data type for the new attribute.
kind | [in] Attribute kind.
Returns
Unique Sparksee attribute identifier.
attr_t Graph::NewAttribute | ( | type_t | type,
 |  | const std::wstring & | name,
 |  | DataType | dt,
 |  | AttributeKind | kind,
 |  | Value & | defaultValue
 | ) |  |

Creates a new attribute with a default value.

Parameters
type | [in] Sparksee node or edge type identifier.
name | [in] Unique name for the new attribute.
dt | [in] Data type for the new attribute.
kind | [in] Attribute kind.
defaultValue | [in] The default value to use in each new node/edge.
Returns
Unique Sparksee attribute identifier.
oid_t Graph::NewEdge | ( | type_t | type,
 |  | oid_t | tail,
 |  | oid_t | head
 | ) |  |

Creates a new edge instance.

Parameters
type | [in] Sparksee type identifier.
tail | [in] Source Sparksee OID.
head | [in] Target Sparksee OID.
Returns
Unique OID of the new edge instance.
oid_t Graph::NewEdge | ( | type_t | type,
 |  | attr_t | tailAttr,
 |  | Value & | tailV,
 |  | attr_t | headAttr,
 |  | Value & | headV
 | ) |  |

Creates a new edge instance.

The tail of the edge will be any node having the given tailV Value for the given tailAttr attribute identifier, and the head of the edge will be any node having the given headV Value for the given headAttr attribute identifier.

Parameters
type | [in] Sparksee type identifier.
tailAttr | [in] Sparksee attribute identifier.
tailV | [in] Value.
headAttr | [in] Sparksee attribute identifier.
headV | [in] Value.
Returns
Unique OID of the new edge instance.
type_t Graph::NewEdgeType | ( | const std::wstring & | name,
 |  | bool_t | directed,
 |  | bool_t | neighbors
 | ) |  |

Creates a new edge type.

Parameters
name | [in] Unique name for the new edge type.
directed | [in] If TRUE, this creates a directed edge type, otherwise this creates a undirected edge type.
neighbors | [in] If TRUE, this indexes neighbor nodes, otherwise not.
Returns
Unique Sparksee type identifier.
oid_t Graph::NewNode ( type_t type )

Creates a new node instance.

Parameters
type [in] Sparksee type identifier.
Returns
Unique OID of the new node instance.
type_t Graph::NewNodeType ( const std::wstring & name )

Creates a new node type.

Parameters
name [in] Unique name for the new node type.
Returns
Unique Sparksee type identifier.
type_t Graph::NewRestrictedEdgeType | ( | const std::wstring & | name,
 |  | type_t | tail,
 |  | type_t | head,
 |  | bool_t | neighbors
 | ) |  |

Creates a new restricted edge type.

Parameters
name | [in] Unique name for the new edge type.
tail | [in] Tail Sparksee node type identifier.
head | [in] Head Sparksee node type identifier.
neighbors | [in] If TRUE, this indexes neighbor nodes, otherwise not.
Returns
Unique Sparksee type identifier.
attr_t Graph::NewSessionArrayAttribute | ( | type_t | type,
 |  | DataType | dt,
 |  | int32_t | size
 | ) |  |

Creates a new Session array attribute.

Session attributes are exclusive for the Session (just its Session can use the attribute) and are automatically removed when the Session is closed (thus, attribute data is not persistent into the database).

Since they are not persistent, they cannot be retrieved from the database, so they do not have an identifier name.

Parameters
type | [in] Sparksee node or edge type identifier.
dt | [in] Base Data type for the new array attribute elements.
size | [in] The array size.
Returns
Unique Sparksee attribute identifier.
attr_t Graph::NewSessionAttribute | ( | type_t | type,
 |  | DataType | dt,
 |  | AttributeKind | kind
 | ) |  |

Creates a new Session attribute.

Session attributes are exclusive for the Session (just its Session can use the attribute) and are automatically removed when the Session is closed (thus, attribute data is not persistent into the database).

Since they are not persistent, they cannot be retrieved from the database, so they do not have an identifier name.

Parameters
type | [in] Sparksee node or edge type identifier.
dt | [in] Data type for the new attribute.
kind | [in] Attribute kind.
Returns
Unique Sparksee attribute identifier.
attr_t Graph::NewSessionAttribute | ( | type_t | type,
 |  | DataType | dt,
 |  | AttributeKind | kind,
 |  | Value & | defaultValue
 | ) |  |

Creates a new Session attribute with a default value.

Session attributes are exclusive for the Session (just its Session can use the attribute) and are automatically removed when the Session is closed (thus, attribute data is not persistent into the database).

Since they are not persistent, they cannot be retrieved from the database, so they do not have an identifier name.

Parameters
type | [in] Sparksee node or edge type identifier.
dt | [in] Data type for the new attribute.
kind | [in] Attribute kind.
defaultValue | [in] The default value to use in each new node/edge.
Returns
Unique Sparksee attribute identifier.
void Graph::RemoveAttribute ( attr_t attr )

Removes the given attribute.

Parameters
attr [in] Sparksee attribute identifier.
void Graph::RemoveType ( type_t type )

Removes the given type.

This fails if there exist attributes defined for the type or if there exist restricted edges referencing this type.

Parameters
type [in] Sparksee type identifier.
void Graph::RenameAttribute | ( | attr_t | attr,
 |  | const std::wstring & | newName
 | ) |  |

Renames an attribute.

The new name must be available.

Parameters
attr | [in] Sparksee attribute identifier.
newName | [in] The new name for the attribute.
void Graph::RenameType | ( | const std::wstring & | oldName,
 |  | const std::wstring & | newName
 | ) |  |

Renames a type.

The new name must be available.

Parameters
oldName | [in] The current name of the type to be renamed.
newName | [in] The new name for the type.
void Graph::RenameType | ( | type_t | type,
 |  | const std::wstring & | newName
 | ) |  |

Renames a type.

The new name must be available.

Parameters
type | [in] The type to be renamed.
newName | [in] The new name for the type.
Objects* Graph::Select ( type_t type )

Selects all OIDs belonging to the given type.

Parameters
type [in] Sparksee type identifier.
Returns
Objects instance.
Objects* Graph::Select | ( | attr_t | attr,
 |  | Condition | cond,
 |  | const Value & | value
 | ) |  |

Selects all OIDs satisfying the given condition for the given attribute.

Parameters
attr | [in] Sparksee attribute identifier.
cond | [in] Condition to be satisfied.
value | [in] Value to be satisfied.
Returns
Objects instance.
Objects* Graph::Select | ( | attr_t | attr,
 |  | Condition | cond,
 |  | const Value & | lower,
 |  | const Value & | higher
 | ) |  |

Selects all OIDs satisfying the given condition for the given attribute.

This allows to perform the Between operation, thus it has two Value arguments.

Parameters
attr | [in] Sparksee attribute identifier.
cond | [in] Condition to be satisfied. It must be the Between Condition.
lower | [in] Lower-bound Value to be satisfied.
higher | [in] Higher-bound Value to be satisfied.
Returns
Objects instance.
Objects* Graph::Select | ( | attr_t | attr,
 |  | Condition | cond,
 |  | const Value & | value,
 |  | const Objects * | restriction
 | ) |  |

Selects all OIDs satisfying the given condition for the given attribute.

Parameters
attr | [in] Sparksee attribute identifier.
cond | [in] Condition to be satisfied.
value | [in] Value to be satisfied.
restriction | [in] Objects to limit the select in this set of objects.
Returns
Objects instance.
Objects* Graph::Select | ( | attr_t | attr,
 |  | Condition | cond,
 |  | const Value & | lower,
 |  | const Value & | higher,
 |  | const Objects * | restriction
 | ) |  |

Selects all OIDs satisfying the given condition for the given attribute.

This allows to perform the Between operation, thus it has two Value arguments.

Parameters
attr | [in] Sparksee attribute identifier.
cond | [in] Condition to be satisfied. It must be the Between Condition.
lower | [in] Lower-bound Value to be satisfied.
higher | [in] Higher-bound Value to be satisfied.
restriction | [in] Objects to limit the select in this set of objects.
Returns
Objects instance.
ValueArray* Graph::SetArrayAttribute | ( | oid_t | oid,
 |  | attr_t | attr,
 |  | const Value & | value
 | ) |  |

Sets all the elements of the ValueArray for the given array attribute and OID and returns it.

Initializing the array with one of these SetArrayAttribute methods is the only way to create the array. But once created it can be updated using the ValueArray. And you can get it again with the GetArrayAttribute operation.

Parameters
oid | [in] Sparksee OID.
attr | [in] Sparksee array attribute identifier.
value | [in] Value for all the array elements of the given attribute and OID.
Returns
A ValueArray. This returns a ValueArray, a NULL or throws an exception.
void Graph::SetArrayAttribute | ( | attr_t | attr,
 |  | const Value & | value
 | ) |  |

Sets all the values of the array of the given array attribute for all the objects of the types the attribute applies to.

Parameters
attr | [in] Sparksee array attribute identifier.
value | [in] Value for all the array elements of the arrays.
void Graph::SetArrayAttributeVoid | ( | oid_t | oid,
 |  | attr_t | attr,
 |  | const Value & | value
 | ) |  |

Sets all the elements of the ValueArray for the given array attribute and OID.

Initializing the array with one of these SetArrayAttribute methods is the only way to create the array. But once created it can be updated using the ValueArray which can be obtained using the GetArrayAttribute operation.

Parameters
oid | [in] Sparksee OID.
attr | [in] Sparksee array attribute identifier.
value | [in] Value for all the array elements of the given attribute and OID.
void Graph::SetAttribute | ( | oid_t | oid,
 |  | attr_t | attr,
 |  | Value & | value
 | ) |  |

Sets the Value for the given attribute and OID.

Parameters
oid | [in] Sparksee OID.
attr | [in] Sparksee attribute identifier.
value | [in] Value for the given attribute and for the given OID.
void Graph::SetAttribute | ( | attr_t | attr,
 |  | Value & | value
 | ) |  |

Sets the value of the given attribute for all the objects of the types the attribute applies to.

Does not work for TEXT attribute types

Parameters
tx | The Transaction this operation belongs to
attribute | The attribute to initialize
value | The value to initialize the attribute to
void Graph::SetAttributeDefaultValue | ( | attr_t | attr,
 |  | Value & | value
 | ) |  |

Sets a default value for an attribute.

The default value will be applied to all the new nodes or edges.

The given value must have the same DataType as the attribute or be a NULL value to remove the current default value.

Parameters
attr | [in] The attribute.
value | [in] The default value to use for this attribute.
void Graph::SetAttributeText | ( | oid_t | oid,
 |  | attr_t | attr,
 |  | TextStream * | tstream
 | ) |  |

Sets the writable TextStream for the given text attribute and OID.

Parameters
oid | [in] Sparksee OID.
attr | [in] Sparksee attribute identifier.
tstream | [in] New Text value. This corresponds to a TextStream to write.
Objects* Graph::Tails ( Objects * edges )

Gets all the tails from the given edges collection.

Parameters
edges [in] Sparksee edge identifier collection.
Returns
The tails collection.
void Graph::TailsAndHeads | ( | Objects * | edges,
 |  | Objects * | tails,
 |  | Objects * | heads
 | ) |  |

Gets all the tails and heads from the given edges collection.

Parameters
edges | [in] Sparksee edge identifier collection.
tails | [in|out] If not NULL, all the tails will be stored here.
heads | [in|out] If not NULL, all the heads will be stored here.
KeyValues* Graph::TopK | ( | attr_t | attribute,
 |  | Order | order,
 |  | int32_t | k
 | ) |  |

Gets a KeyValues iterator as a result of the TopK operation.

Parameters
attribute | The attribute to perform the TopK on
order | The ordering semantincs of the top-k
k | The size of the TopK
Returns
A KeyValues instance
KeyValues* Graph::TopK | ( | attr_t | attribute,
 |  | Condition | operation,
 |  | const Value & | lower,
 |  | Order | order,
 |  | int32_t | k
 | ) |  |

Gets a KeyValues iterator as a result of the TopK operation.

Parameters
attribute | The attribute to perform the TopK on
operation | The operation to perform in the top k
lower | The lower bound Value to be satisfied
order | The ordering semantincs of the top-k
k | The size of the TopK
Returns
A KeyValues instance
KeyValues* Graph::TopK | ( | attr_t | attribute,
 |  | Condition | operation,
 |  | const Value & | lower,
 |  | const Value & | higher,
 |  | Order | order,
 |  | int32_t | k
 | ) |  |

Gets a KeyValues iterator as a result of the TopK operation.

Parameters
attribute | The attribute to perform the TopK on
operation | The operation to perform in the top k
lower | The lower bound Value to be satisfied
higher | The upper bound Value to be satisfied
order | The ordering semantincs of the top-k
k | The size of the TopK
Returns
A KeyValues instance
KeyValues* Graph::TopK | ( | attr_t | attribute,
 |  | Order | order,
 |  | int32_t | k,
 |  | Objects * | restriction
 | ) |  |

Gets a KeyValues iterator as a result of the TopK operation.

Parameters
attribute | The attribute to perform the TopK on
order | The ordering semantincs of the top-k
k | The size of the TopK
restricton | Objects to limit the topk to this set of objects
Returns
A KeyValues instance
KeyValues* Graph::TopK | ( | attr_t | attribute,
 |  | Condition | operation,
 |  | const Value & | lower,
 |  | Order | order,
 |  | int32_t | k,
 |  | Objects * | restriction
 | ) |  |

Gets a KeyValues iterator as a result of the TopK operation.

Parameters
attribute | The attribute to perform the TopK on
operation | The operation to perform in the top k
lower | The lower bound Value to be satisfied
order | The ordering semantincs of the top-k
k | The size of the TopK
restricton | Objects to limit the topk to this set of objects
Returns
A KeyValues instance
KeyValues* Graph::TopK | ( | attr_t | attribute,
 |  | Condition | operation,
 |  | const Value & | lower,
 |  | const Value & | higher,
 |  | Order | order,
 |  | int32_t | k,
 |  | Objects * | restriction
 | ) |  |

Gets a KeyValues iterator as a result of the TopK operation.

Parameters
attribute | The attribute to perform the TopK on
operation | The operation to perform in the top k
lower | The lower bound Value to be satisfied
higher | The upper bound Value to be satisfied
order | The ordering semantincs of the top-k
k | The size of the TopK
restricton | Objects to limit the topk to this set of objects
Returns
A KeyValues instance
The documentation for this class was generated from the following file:
  • Graph.h


Sparksee: Type Class Reference

Public Member Functions | Static Public Attributes | Friends | List of all members
Type Class Reference
Gdb

Type data class. More...

Public Member Functions

~Type ()
Destructor.
type_t | GetId () const
Gets the Sparksee type identifier.
ObjectType | GetObjectType () const
Gets the object type.
const std::wstring & | GetName () const
Gets the unique type name.
int64_t | GetNumObjects () const
Gets the number of objects belonging to the type.
bool_t | GetIsDirected () const
Gets if this is a directed edge type.
bool_t | GetIsRestricted () const
Gets if this is a restricted edge type.
bool_t | GetAreNeighborsIndexed () const
Gets if this is an edge type with neighbors index.
type_t | GetRestrictedFrom () const
Gets the tail or source type identifier for restricted edge types.
type_t | GetRestrictedTo () const
Gets the head or target type identifier for restricted edge types.

Static Public Attributes

static const type_t | InvalidType
Invalid type identifier.
static const type_t | GlobalType
Global type identifier.
static const type_t | NodesType
Identifier for all nodeType attributes.
static const type_t | EdgesType
Identifier for all edgeType attributes.

Friends

class Graph

Detailed Description

Type data class.

It contains information about a node or edge type.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

bool_t Type::GetAreNeighborsIndexed ( ) const
inline

Gets if this is an edge type with neighbors index.

Returns
TRUE for edges types with neighbors index, FALSE otherwise.
type_t Type::GetId ( ) const
inline

Gets the Sparksee type identifier.

Returns
The Sparksee type identifier.
bool_t Type::GetIsDirected ( ) const
inline

Gets if this is a directed edge type.

Returns
TRUE for directed edge types, FALSE otherwise.
bool_t Type::GetIsRestricted ( ) const
inline

Gets if this is a restricted edge type.

Returns
TRUE for restricted edge types, FALSE otherwise.
const std::wstring& Type::GetName ( ) const
inline

Gets the unique type name.

Returns
The unique type name.
int64_t Type::GetNumObjects ( ) const
inline

Gets the number of objects belonging to the type.

Returns
The number of objects belonging to the type.
ObjectType Type::GetObjectType ( ) const
inline

Gets the object type.

Returns
The object type.
type_t Type::GetRestrictedFrom ( ) const
inline

Gets the tail or source type identifier for restricted edge types.

Returns
For restricted edge types, the tail or source type identifier, the Type InvalidType otherwise.
type_t Type::GetRestrictedTo ( ) const
inline

Gets the head or target type identifier for restricted edge types.

Returns
For restricted edge types, the head or target type identifier, the Type InvalidType otherwise.
The documentation for this class was generated from the following file:
  • Graph_data.h


Sparksee: TypeList Class Reference

Public Member Functions | List of all members
TypeList Class Reference
Gdb

Sparksee type identifier list. More...

Public Member Functions

int32_t | Count () const
Number of elements in the list.
TypeListIterator * Iterator ()
Gets a new TypeListIterator.
TypeList ()
Constructor.
TypeList (const std::vector< type_t > &v)
Constructor.
void | Add (type_t type)
Adds a Sparksee type identifier at the end of the list.
void | Clear ()
Clears the list.
~TypeList ()
Destructor.

Detailed Description

Sparksee type identifier list.

It stores a Sparksee node or edge type identifier list.

Use TypeListIterator to access all elements into this collection.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

TypeList::TypeList ( )

Constructor.

This creates an empty list.

TypeList::TypeList ( const std::vector< type_t > & v )

Constructor.

Parameters
v [in] Vector.

Member Function Documentation

void TypeList::Add ( type_t type )
inline

Adds a Sparksee type identifier at the end of the list.

Parameters
type [in] Sparksee type identifier.
int32_t TypeList::Count ( ) const
inline

Number of elements in the list.

Returns
Number of elements in the list.
TypeListIterator* TypeList::Iterator ( )

Gets a new TypeListIterator.

Returns
TypeListIterator instance.
The documentation for this class was generated from the following file:
  • Graph_data.h


Sparksee: TypeListIterator Class Reference

Public Member Functions | Friends | List of all members
TypeListIterator Class Reference
Gdb

TypeList iterator class. More...

Public Member Functions

~TypeListIterator ()
Destructor.
type_t Next ()
Moves to the next element.
bool_t HasNext ()
Gets if there are more elements.

Friends

class TypeList

Detailed Description

TypeList iterator class.

Iterator to traverse all the Sparksee node or edge type identifiers into a TypeList instance.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

bool_t TypeListIterator::HasNext ( )
inline

Gets if there are more elements.

Returns
TRUE if there are more elements, FALSE otherwise.
type_t TypeListIterator::Next ( )
inline

Moves to the next element.

Returns
The next element.
The documentation for this class was generated from the following file:
  • Graph_data.h


Sparksee: Attribute Class Reference

Public Member Functions | Static Public Attributes | Friends | List of all members
Attribute Class Reference
Gdb

Attribute data class. More...

Public Member Functions

~Attribute ()
Destructor.
attr_t | GetId () const
Gets the Sparksee attribute identifier.
type_t | GetTypeId () const
Gets the Sparksee type identifier.
const std::wstring & | GetName () const
Gets the unique attribute name.
DataType | GetDataType () const
Gets the data type.
int64_t | GetSize () const
Gets the number of different values.
int64_t | GetCount () const
Gets the number of non-NULL values.
AttributeKind | GetKind () const
Gets the attribute kind.
bool_t | IsSessionAttribute () const
Check if it's a session attribute or a persistent one.
bool_t | IsArrayAttribute () const
Check if it's an array attribute.
int32_t | GetArraySize () const
Gets the number of elements in the array.

Static Public Attributes

static const attr_t InvalidAttribute
Invalid attribute identifier constant.

Friends

class Graph

Detailed Description

Attribute data class.

It contains information about an attribute.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

int32_t Attribute::GetArraySize ( ) const
inline

Gets the number of elements in the array.

Returns
The size of the array
int64_t Attribute::GetCount ( ) const
inline

Gets the number of non-NULL values.

Returns
The number of non-NULL values.
DataType Attribute::GetDataType ( ) const
inline

Gets the data type.

Returns
The DataType.
attr_t Attribute::GetId ( ) const
inline

Gets the Sparksee attribute identifier.

Returns
The Sparksee attribute identifier.
AttributeKind Attribute::GetKind ( ) const
inline

Gets the attribute kind.

Returns
The AttributeKind.
const std::wstring& Attribute::GetName ( ) const
inline

Gets the unique attribute name.

Returns
The unique attribute name.
int64_t Attribute::GetSize ( ) const
inline

Gets the number of different values.

Returns
The number of different values.
type_t Attribute::GetTypeId ( ) const
inline

Gets the Sparksee type identifier.

Returns
The Sparksee type identifier.
bool_t Attribute::IsArrayAttribute ( ) const
inline

Check if it's an array attribute.

Returns
True if it's an array attribute, or false otherwise.
bool_t Attribute::IsSessionAttribute ( ) const
inline

Check if it's a session attribute or a persistent one.

Returns
True if it's a session attribute, or false otherwise.
The documentation for this class was generated from the following file:
  • Graph_data.h
Generated on Thu Feb 24 2022 12:56:05 for Sparksee by doxygen 1.8.2


Sparksee: AttributeList Class Reference

Public Member Functions | List of all members
AttributeList Class Reference
Gdb

Sparksee attribute identifier list. More...

Public Member Functions

int32_t | Count () const
Number of elements in the list.
AttributeListIterator * Iterator ()
Gets a new AttributeListIterator.
AttributeList ()
Constructor.
AttributeList (const std::vector< attr_t > &v)
Constructor.
void | Add (attr_t attr)
Adds a Sparksee attribute identifier at the end of the list.
void | Clear ()
Clears the list.
~AttributeList ()
Destructor.

Detailed Description

Sparksee attribute identifier list.

It stores a Sparksee attribute identifier list.

Use AttributeListIterator to access all elements into this collection.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

AttributeList::AttributeList ( )

Constructor.

This creates an empty list.

AttributeList::AttributeList ( const std::vector< attr_t > & v )

Constructor.

Parameters
v [in] Vector.

Member Function Documentation

void AttributeList::Add ( attr_t attr )
inline

Adds a Sparksee attribute identifier at the end of the list.

Parameters
attr [in] Sparksee attribute identifier.
int32_t AttributeList::Count ( ) const
inline

Number of elements in the list.

Returns
Number of elements in the list.
AttributeListIterator* AttributeList::Iterator ( )

Gets a new AttributeListIterator.

Returns
AttributeListIterator instance.
The documentation for this class was generated from the following file:
  • Graph_data.h
Generated on Thu Feb 24 2022 12:56:05 for Sparksee by doxygen 1.8.2


Sparksee: AttributeListIterator Class Reference

Public Member Functions | Friends | List of all members
AttributeListIterator Class Reference
Gdb

AttributeList iterator class. More...

Public Member Functions

~AttributeListIterator ()
Destructor.
attr_t Next ()
Moves to the next element.
bool_t HasNext ()
Gets if there are more elements.

Friends

class AttributeList

Detailed Description

AttributeList iterator class.

Iterator to traverse all the Sparksee attribute identifier into a AttributeList instance.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

bool_t AttributeListIterator::HasNext ( )
inline

Gets if there are more elements.

Returns
TRUE if there are more elements, FALSE otherwise.
attr_t AttributeListIterator::Next ( )
inline

Moves to the next element.

Returns
The next element.
The documentation for this class was generated from the following file:
  • Graph_data.h
Generated on Thu Feb 24 2022 12:56:05 for Sparksee by doxygen 1.8.2


Sparksee: OIDList Class Reference

Public Member Functions | List of all members
OIDList Class Reference
Gdb

Sparksee object identifier list. More...

Public Member Functions

int32_t | Count () const
Number of elements in the list.
OIDListIterator * Iterator ()
Gets a new OIDListIterator.
OIDList ()
Constructor.
OIDList (int32_t numInvalidOIDs)
Constructor.
OIDList (const std::vector< oid_t > &v)
Constructor.
~OIDList ()
Destructor.
void | Add (oid_t attr)
Adds a Sparksee object identifier at the end of the list.
void | Set (int32_t pos, oid_t oid)
Sets a Sparksee object identifier at the specified position of the list.
void | Clear ()
Clears the list.

Detailed Description

Sparksee object identifier list.

It stores a Sparksee object identifier list.

Use OIDListIterator to access all elements into this collection.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

OIDList::OIDList ( )

Constructor.

This creates an empty list.

OIDList::OIDList ( int32_t numInvalidOIDs )

Constructor.

This creates a list with N invalid oids.

Parameters
numInvalidOIDs [in] The number of invalid oids added to the list.
OIDList::OIDList ( const std::vector< oid_t > & v )

Constructor.

Parameters
v [in] Vector.

Member Function Documentation

void OIDList::Add ( oid_t attr )
inline

Adds a Sparksee object identifier at the end of the list.

Parameters
attr [in] Sparksee object identifier.
int32_t OIDList::Count ( ) const
inline

Number of elements in the list.

Returns
Number of elements in the list.
OIDListIterator* OIDList::Iterator ( )

Gets a new OIDListIterator.

Returns
OIDListIterator instance.
void OIDList::Set | ( | int32_t | pos,
 |  | oid_t | oid
 | ) |  |
inline

Sets a Sparksee object identifier at the specified position of the list.

Parameters
pos | [in] List position [0..Count()-1].
oid | [in] Sparksee object identifier.
The documentation for this class was generated from the following file:
  • Graph_data.h


Sparksee: OIDListIterator Class Reference

Public Member Functions | Friends | List of all members
OIDListIterator Class Reference
Gdb

OIDList iterator class. More...

Public Member Functions

~OIDListIterator ()
Destructor.
oid_t Next ()
Moves to the next element.
bool_t HasNext ()
Gets if there are more elements.

Friends

class OIDList

Detailed Description

OIDList iterator class.

Iterator to traverse all the Sparksee object identifier into a OIDList instance.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

bool_t OIDListIterator::HasNext ( )
inline

Gets if there are more elements.

Returns
TRUE if there are more elements, FALSE otherwise.
oid_t OIDListIterator::Next ( )
inline

Moves to the next element.

Returns
The next element.
The documentation for this class was generated from the following file:
  • Graph_data.h


Sparksee: AttributeStatistics Class Reference

Public Member Functions | Friends | List of all members
AttributeStatistics Class Reference
Gdb

Attribute statistics class. More...

Public Member Functions

~AttributeStatistics ()
Destructor.
int64_t | GetTotal () const
Gets the number of objects with a non-NULL Value (BASIC statistic).
int64_t | GetNull () const
Gets the number of objects NULL a Value (BASIC statistics).
int64_t | GetDistinct () const
Gets the number of distinct values (BASIC statistics).
const Value & | GetMin () const
Gets the minimum existing value (BASIC statistics).
const Value & | GetMax () const
Gets the maximum existing value (BASIC statistics).
int32_t | GetMaxLengthString () const
Gets the maximum length.
int32_t | GetMinLengthString () const
Gets the minimum length.
double64_t | GetAvgLengthString () const
Gets the average length.
const Value & | GetMode () const
Gets the mode.
int64_t | GetModeCount () const
Gets the number of objects with a Value equal to the mode.
double64_t | GetMean () const
Gets the mean or average.
double64_t | GetVariance () const
Gets the variance.
double64_t | GetMedian () const
Gets the median.

Friends

class Graph

Detailed Description

Attribute statistics class.

It contains statistic data about an attribute.

Some fields are valid just for numerical attributes and others just for string attributes. Also, some statistics are considered BASIC because computing them do not require to traverse all the different values of the attribute. For each getter method the documentation tells if the statistic is BASIC or not. See the Graph class method getAttributeStatistics or check out the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

double64_t AttributeStatistics::GetAvgLengthString ( ) const
inline

Gets the average length.

If the attribute is not an string attribute, it just returns 0.

Returns
The average length.
int64_t AttributeStatistics::GetDistinct ( ) const
inline

Gets the number of distinct values (BASIC statistics).

Returns
The number of distinct values.
const Value& AttributeStatistics::GetMax ( ) const
inline

Gets the maximum existing value (BASIC statistics).

Returns
The maximum existing value.
int32_t AttributeStatistics::GetMaxLengthString ( ) const
inline

Gets the maximum length.

If the attribute is not an string attribute, it just returns 0.

Returns
The maximum length.
double64_t AttributeStatistics::GetMean ( ) const
inline

Gets the mean or average.

Mean or average: Sum of all Values divided by the number of observations.

It is computed just for numerical attributes.

Returns
The mean.
double64_t AttributeStatistics::GetMedian ( ) const
inline

Gets the median.

Median: Middle value that separates the higher half from the lower.

If a < b < c, then the median of the list {a, b, c} is b, and if a < b < c < d, then the median of the list {a, b, c, d} is the mean of b and c, i.e. it is (b + c)/2

It is computed just for numerical attributes.

Returns
The median.
const Value& AttributeStatistics::GetMin ( ) const
inline

Gets the minimum existing value (BASIC statistics).

Returns
The minimum existing value.
int32_t AttributeStatistics::GetMinLengthString ( ) const
inline

Gets the minimum length.

If the attribute is not an string attribute, it just returns 0.

Returns
The minimum length.
const Value& AttributeStatistics::GetMode ( ) const
inline

Gets the mode.

Mode: Most frequent Value.

Returns
The mode.
int64_t AttributeStatistics::GetModeCount ( ) const
inline

Gets the number of objects with a Value equal to the mode.

Returns
The number of objects with a Value equal to the mode.
int64_t AttributeStatistics::GetNull ( ) const
inline

Gets the number of objects NULL a Value (BASIC statistics).

Returns
The number of objects NULL a Value.
int64_t AttributeStatistics::GetTotal ( ) const
inline

Gets the number of objects with a non-NULL Value (BASIC statistic).

Returns
The number of objects with a non-NULL Value.
double64_t AttributeStatistics::GetVariance ( ) const
inline

Gets the variance.

It is computed just for numerical attributes.

Returns
The variance.
The documentation for this class was generated from the following file:
  • Graph_data.h
Generated on Thu Feb 24 2022 12:56:05 for Sparksee by doxygen 1.8.2


Sparksee: EdgeData Class Reference

Public Member Functions | Friends | List of all members
EdgeData Class Reference
Gdb

Edge data class. More...

Public Member Functions

~EdgeData ()
Destructor.
oid_t | GetEdge () const
Gets the edge identifier.
oid_t | GetTail () const
Gets the tail of the edge.
oid_t | GetHead () const
Gets the head of the edge.

Friends

class Graph

Detailed Description

Edge data class.

It stores the tail and the head of an edge instance.

In case of undirected eges, the tail and the head are just the two ends of the edge.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

oid_t EdgeData::GetEdge ( ) const
inline

Gets the edge identifier.

Returns
The Sparksee edge identifier.
oid_t EdgeData::GetHead ( ) const
inline

Gets the head of the edge.

Returns
The Sparksee edge identifier of the head of the edge.
oid_t EdgeData::GetTail ( ) const
inline

Gets the tail of the edge.

Returns
The Sparksee edge identifier of the tail of the edge.
The documentation for this class was generated from the following file:
  • Graph_data.h


Sparksee: StringList Class Reference

Public Member Functions | List of all members
StringList Class Reference
Gdb

String list. More...

Public Member Functions

int32_t | Count () const
Number of elements in the list.
StringListIterator * Iterator ()
Gets a new StringListIterator.
StringList ()
Constructor.
StringList (const std::vector< std::wstring > &v)
Constructor.
~StringList ()
Destructor.
void | Add (const std::wstring &str)
Adds a String at the end of the list.
void | Clear ()
Clears the list.

Detailed Description

String list.

It stores a String (unicode) list.

Use StringListIterator to access all elements into this collection.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

StringList::StringList ( )

Constructor.

This creates an empty list.

StringList::StringList ( const std::vector< std::wstring > & v )

Constructor.

Parameters
v [in] Vector.

Member Function Documentation

void StringList::Add ( const std::wstring & str )
inline

Adds a String at the end of the list.

Parameters
str [in] String.
int32_t StringList::Count ( ) const
inline

Number of elements in the list.

Returns
Number of elements in the list.
StringListIterator* StringList::Iterator ( )

Gets a new StringListIterator.

Returns
StringListIterator instance.
The documentation for this class was generated from the following file:
  • Graph_data.h


Sparksee: StringListIterator Class Reference

Public Member Functions | Friends | List of all members
StringListIterator Class Reference
Gdb

StringList iterator class. More...

Public Member Functions

~StringListIterator ()
Destructor.
const std::wstring & Next ()
Moves to the next element.
bool_t HasNext ()
Gets if there are more elements.

Friends

class StringList

Detailed Description

StringList iterator class.

Iterator to traverse all the strings into a StringList instance.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

bool_t StringListIterator::HasNext ( )
inline

Gets if there are more elements.

Returns
TRUE if there are more elements, FALSE otherwise.
const std::wstring& StringListIterator::Next ( )
inline

Moves to the next element.

Returns
The next element.
The documentation for this class was generated from the following file:
  • Graph_data.h


Sparksee: BooleanList Class Reference

Public Member Functions | List of all members
BooleanList Class Reference
Gdb

Boolean list. More...

Public Member Functions

int32_t | Count () const
Number of elements in the list.
BooleanListIterator * Iterator ()
Gets a new BooleanListIterator.
BooleanList ()
Constructor.
BooleanList (const std::vector< bool_t > &v)
Constructor.
~BooleanList ()
Destructor.
void | Add (sparksee::gdb::bool_t value)
Adds a Boolean at the end of the list.
void | Clear ()
Clears the list.

Detailed Description

Boolean list.

It stores a Boolean list.

Use BooleanListIterator to access all elements into this collection.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

BooleanList::BooleanList ( )

Constructor.

This creates an empty list.

BooleanList::BooleanList ( const std::vector< bool_t > & v )

Constructor.

Parameters
v [in] Vector.

Member Function Documentation

void BooleanList::Add ( sparksee::gdb::bool_t value )
inline

Adds a Boolean at the end of the list.

Parameters
value [in] Boolean.
int32_t BooleanList::Count ( ) const
inline

Number of elements in the list.

Returns
Number of elements in the list.
BooleanListIterator* BooleanList::Iterator ( )

Gets a new BooleanListIterator.

Returns
BooleanListIterator instance.
The documentation for this class was generated from the following file:
  • Graph_data.h
Generated on Thu Feb 24 2022 12:56:05 for Sparksee by doxygen 1.8.2


Sparksee: BooleanListIterator Class Reference

Public Member Functions | Friends | List of all members
BooleanListIterator Class Reference
Gdb

BooleanList iterator class. More...

Public Member Functions

~BooleanListIterator ()
Destructor.
sparksee::gdb::bool_t Next ()
Moves to the next element.
bool_t HasNext ()
Gets if there are more elements.

Friends

class BooleanList

Detailed Description

BooleanList iterator class.

Iterator to traverse all the strings into a BooleanList instance.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

bool_t BooleanListIterator::HasNext ( )
inline

Gets if there are more elements.

Returns
TRUE if there are more elements, FALSE otherwise.
sparksee::gdb::bool_t BooleanListIterator::Next ( )
inline

Moves to the next element.

Returns
The next element.
The documentation for this class was generated from the following file:
  • Graph_data.h
Generated on Thu Feb 24 2022 12:56:05 for Sparksee by doxygen 1.8.2


Sparksee: Int32List Class Reference

Public Member Functions | List of all members
Int32List Class Reference
Gdb

Sparksee 32-bit signed integer list. More...

Public Member Functions

int32_t | Count () const
Number of elements in the list.
Int32ListIterator * Iterator ()
Gets a new Int32ListIterator.
Int32List ()
Constructor.
Int32List (const std::vector< int32_t > &v)
Constructor.
~Int32List ()
Destructor.
void | Add (int32_t value)
Adds an 32-bit signed integer at the end of the list.
void | Clear ()
Clears the list.

Detailed Description

Sparksee 32-bit signed integer list.

It stores a 32-bit signed integer list.

Use Int32ListIterator to access all elements into this collection.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

Int32List::Int32List ( )

Constructor.

This creates an empty list.

Int32List::Int32List ( const std::vector< int32_t > & v )

Constructor.

Parameters
v [in] Vector.

Member Function Documentation

void Int32List::Add ( int32_t value )
inline

Adds an 32-bit signed integer at the end of the list.

Parameters
value [in] The integer.
int32_t Int32List::Count ( ) const
inline

Number of elements in the list.

Returns
Number of elements in the list.
Int32ListIterator* Int32List::Iterator ( )

Gets a new Int32ListIterator.

Returns
Int32ListIterator instance.
The documentation for this class was generated from the following file:
  • Graph_data.h


Sparksee: Int32ListIterator Class Reference

Public Member Functions | Friends | List of all members
Int32ListIterator Class Reference
Gdb

Int32List iterator class. More...

Public Member Functions

~Int32ListIterator ()
Destructor.
int32_t Next ()
Moves to the next element.
bool_t HasNext ()
Gets if there are more elements.

Friends

class Int32List

Detailed Description

Int32List iterator class.

Iterator to traverse all the integer into a Int32List instance.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

bool_t Int32ListIterator::HasNext ( )
inline

Gets if there are more elements.

Returns
TRUE if there are more elements, FALSE otherwise.
int32_t Int32ListIterator::Next ( )
inline

Moves to the next element.

Returns
The next element.
The documentation for this class was generated from the following file:
  • Graph_data.h


Sparksee: Handler< T > Class Template Reference

Public Member Functions | Protected Member Functions | List of all members
Handler< T > Class Template Reference
Gdb

Handles a reference. More...

Inheritance diagram for Handler< T >:

Public Member Functions

Handler ()
Creates a new instance.
Handler (T *h)
Creates a new instance with the given reference.
virtual | ~Handler ()
Destructor.
T * | GetHandler ()
Gets the handled reference.
const T * | GetHandler () const
Gets the handled reference.

Protected Member Functions

void | SetHandler (T *h)
Sets the handled reference.
void | FreeHandler ()
Frees (deletes) the handled reference.
bool_t | IsNull () const
Gets if the handler is NULL.

Detailed Description

template<typename T>
class Handler< T >

Handles a reference.

The handled reference is automatically destroyed (deleted) when the instance is destroyed.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

template<typename T>
Handler< T >::Handler ( T * h )
inline

Creates a new instance with the given reference.

Parameters
h [in] Reference to be handled.
template<typename T>
virtual Handler< T >::~Handler ( )
inlinevirtual

Destructor.

Frees the handled reference.

Member Function Documentation

template<typename T>
T* Handler< T >::GetHandler ( )
inline

Gets the handled reference.

Returns
The handled reference.
template<typename T>
const T* Handler< T >::GetHandler ( ) const
inline

Gets the handled reference.

Returns
The handled reference.
template<typename T>
bool_t Handler< T >::IsNull ( ) const
inlineprotected

Gets if the handler is NULL.

Returns
TRUE if the handler is NULL, FALSE otherwise.
template<typename T>
void Handler< T >::SetHandler ( T * h )
inlineprotected

Sets the handled reference.

Parameters
h [in] The handled reference.
The documentation for this class was generated from the following file:
  • Handler.h


Sparksee: KeyValue Class Reference

Friends | List of all members
KeyValue Class Reference
Gdb

Friends

class KeyValues
The documentation for this class was generated from the following file:
  • KeyValues.h


Sparksee: KeyValues Class Reference

Public Member Functions | Private Member Functions | Friends | List of all members
KeyValues Class Reference
Gdb

Value set class. More...

Inheritance diagram for KeyValues:
Collaboration diagram for KeyValues:

Public Member Functions

virtual | ~KeyValues ()
Destructor.
bool_t HasNext ()
Checks if the KeyValues has more KeyValue pairs.
KeyValue * Next ()
Gets the next KeyValue pair.
void | Next (KeyValue &kv)
Gets the next KeyValue pair.

Private Member Functions

sparksee_core::KeyValues * | GetHandler ()
Gets the handled reference.
const sparksee_core::KeyValues * | GetHandler () const
Gets the handled reference.
void | SetHandler (sparksee_core::KeyValues *h)
Sets the handled reference.
void | FreeHandler ()
Frees (deletes) the handled reference.
bool_t | IsNull () const
Gets if the handler is NULL.

Friends

class Graph

Detailed Description

Value set class.

This is a set of Value instances, that is there is no duplicated elements.

Use a ValuesIterator to traverse all the elements into the set.

When the Values instance is closed, it closes all existing and non-closed ValuesIterator instances too.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

bool_t KeyValues::HasNext ( )

Checks if the KeyValues has more KeyValue pairs.

Returns
Returns ture if there are more KeyValue pairs
KeyValue* KeyValues::Next ( )

Gets the next KeyValue pair.

Returns
Returns the next KeyValue pair
void KeyValues::Next ( KeyValue & kv )

Gets the next KeyValue pair.

Parameters
kv Returns the next KeyValue pair
The documentation for this class was generated from the following file:
  • KeyValues.h


Sparksee: Objects Class Reference

Public Member Functions | Static Public Member Functions | Static Public Attributes | Private Member Functions | Friends | List of all members
Objects Class Reference
Gdb

Object identifier set class. More...

Inheritance diagram for Objects:
Collaboration diagram for Objects:

Public Member Functions

virtual | ~Objects ()
Destructor.
Objects * Copy ()
Creates a new Objects instance as a copy of the given one.
int64_t Count ()
Gets the number of elements into the collection.
bool_t | Add (oid_t e)
Adds an element into the collection.
bool_t | Exists (oid_t e)
Gets if the given element exists into the collection.
oid_t | Any () throw (sparksee::gdb::NoSuchElementException, sparksee::gdb::Error)
Gets an element from the collection.
bool_t | Remove (oid_t e)
Removes an element from the collection.
void | Clear ()
Clears the collection removing all its elements.
int64_t | Union (Objects *objs)
Performs the union operation.
int64_t | Intersection (Objects *objs)
Performs the intersection operation.
int64_t | Difference (Objects *objs)
Performs the difference operation.
bool_t | Equals (Objects *objs)
Checks if the given Objects contains the same information.
bool_t | Contains (Objects *objs)
Check if this objects contains the other one.
int64_t | Copy (Objects *objs)
Performs the copy operation.
Objects * | Sample (Objects *exclude, int64_t samples)
Creates a new Objects instance which is a sample of the calling one.
ObjectsIterator * Iterator ()
Gets an ObjectsIterator.
ObjectsIterator * | IteratorFromIndex (int64_t index)
Gets an ObjectsIterator skipping index elements.
ObjectsIterator * | IteratorFromElement (oid_t e)
Gets an ObjectsIterator starting from the given element.

Static Public Member Functions

static Objects * | CombineUnion (Objects *objs1, Objects *objs2)
Creates a new Objects instance which is the union of the two given.
static Objects * | CombineIntersection (Objects *objs1, Objects *objs2)
Creates a new Objects instance which is the intersection of the two given.
static Objects * | CombineDifference (Objects *objs1, Objects *objs2)
Creates a new Objects instance which is the difference of the two given.

Static Public Attributes

static const oid_t InvalidOID
Invalid OID constant.

Private Member Functions

sparksee_core::Objects * | GetHandler ()
Gets the handled reference.
const sparksee_core::Objects * | GetHandler () const
Gets the handled reference.
void | SetHandler (sparksee_core::Objects *h)
Sets the handled reference.
void | FreeHandler ()
Frees (deletes) the handled reference.
bool_t | IsNull () const
Gets if the handler is NULL.

Friends

class | Session
class | Graph
class | ObjectsIterator

Detailed Description

Object identifier set class.

It stores a collection of Sparksee object identifiers as a set. As a set, there is no order and no duplicated elements.

This class should be used just to store large collections. Otherwise, it is strongly recommended to use common classes from the language API.

This class is not thread-safe.

ObjectsIterator must be used to traverse all the elements into the set.

When the Objects instance is closed, it closes all existing and non-closed ObjectsIterator instances too.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

bool_t Objects::Add ( oid_t e )

Adds an element into the collection.

Parameters
e [in] Element to be added.
Returns
TRUE if the element is added, FALSE if the element was already into the collection.
oid_t Objects::Any ( ) throw (sparksee::gdb::NoSuchElementException, sparksee::gdb::Error)

Gets an element from the collection.

Returns
Any element from the collection.
Exceptions
NoSuchElementException whether the collection is empty.
static Objects* Objects::CombineDifference | ( | Objects * | objs1,
 |  | Objects * | objs2
 | ) |  |
static

Creates a new Objects instance which is the difference of the two given.

Two given Objects belong to the same Session.

Parameters
objs1 | [in] Objects instance.
objs2 | [in] Objects instance.
Returns
New Objects instance.
static Objects* Objects::CombineIntersection | ( | Objects * | objs1,
 |  | Objects * | objs2
 | ) |  |
static

Creates a new Objects instance which is the intersection of the two given.

Two given Objects belong to the same Session.

Parameters
objs1 | [in] Objects instance.
objs2 | [in] Objects instance.
Returns
New Objects instance.
static Objects* Objects::CombineUnion | ( | Objects * | objs1,
 |  | Objects * | objs2
 | ) |  |
static

Creates a new Objects instance which is the union of the two given.

Two given Objects belong to the same Session.

Parameters
objs1 | [in] Objects instance.
objs2 | [in] Objects instance.
Returns
New Objects instance.
bool_t Objects::Contains ( Objects * objs )

Check if this objects contains the other one.

Parameters
objs Objects collection.
Returns
True if it contains the given object.
Objects* Objects::Copy ( )

Creates a new Objects instance as a copy of the given one.

Returns
The new Objects instance.
int64_t Objects::Copy ( Objects * objs )

Performs the copy operation.

This updates the Objects calling instance and copies the given Objects instance.

Parameters
objs [in] Objects instance.
Returns
Number of elements into the collection once the operation has been executed.
int64_t Objects::Count ( )

Gets the number of elements into the collection.

Returns
The number of elements into the collection.
int64_t Objects::Difference ( Objects * objs )

Performs the difference operation.

This updates the Objects calling instance removing those existing elements at the given Objects instance.

Parameters
objs [in] Objects instance.
Returns
Number of elements into the collection once the operation has been executed.
bool_t Objects::Equals ( Objects * objs )

Checks if the given Objects contains the same information.

Parameters
objs [in] Objects instance.
Returns
True if the objects are equal or false otherwise.
bool_t Objects::Exists ( oid_t e )

Gets if the given element exists into the collection.

Parameters
e [in] Element.
Returns
TRUE if the element exists into the collection, FALSE otherwise.
int64_t Objects::Intersection ( Objects * objs )

Performs the intersection operation.

Updates the Objects calling instance setting those existing elements at both two collections and removing all others.

Parameters
objs [in] Objects instance.
Returns
Number of elements into the collection once the operation has been executed.
ObjectsIterator* Objects::Iterator ( )

Gets an ObjectsIterator.

Returns
ObjectsIterator instance.
ObjectsIterator* Objects::IteratorFromElement ( oid_t e )

Gets an ObjectsIterator starting from the given element.

Objects collection has no order, so this method is implementation-dependent.

Parameters
e [in] The first element to traverse in the resulting ObjectsIterator instance.
Returns
ObjectsIterator instance.
ObjectsIterator* Objects::IteratorFromIndex ( int64_t index )

Gets an ObjectsIterator skipping index elements.

Objects collection has no order, so this method is implementation-dependent.

Parameters
index [in] The number of elements to skip from the beginning. It must be in the range [0..Size).
Returns
ObjectsIterator instance.
bool_t Objects::Remove ( oid_t e )

Removes an element from the collection.

Parameters
e [in] Element to be removed.
Returns
TRUE if the element is removed, FALSE if the element was not into the collection.
Objects* Objects::Sample | ( | Objects * | exclude,
 |  | int64_t | samples
 | ) |  |

Creates a new Objects instance which is a sample of the calling one.

Parameters
exclude | [in] If not NULL, elements into this collection will be excluded from the resulting one.
samples | [in] Number of elements into the resulting collection.
Returns
Sample collection.
int64_t Objects::Union ( Objects * objs )

Performs the union operation.

This adds all existing elements of the given Objects instance to the Objects calling instance

Parameters
objs [in] Objects instance.
Returns
Number of elements into the collection once the operation has been executed.
The documentation for this class was generated from the following file:
  • Objects.h


Sparksee: ObjectsIterator Class Reference

Public Member Functions | Friends | List of all members
ObjectsIterator Class Reference
Gdb

ObjectsIterator class. More...

Public Member Functions

virtual ~ObjectsIterator ()
Destructor.
bool_t HasNext ()
Gets if there are more elements to traverse.
oid_t Next ()
Gets the next element to traverse.

Friends

class Objects

Detailed Description

ObjectsIterator class.

Iterator to traverse all the object identifiers from an Objects instance.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

bool_t ObjectsIterator::HasNext ( )

Gets if there are more elements to traverse.

Returns
TRUE if there are more elements to traverse, FALSE otherwise.
oid_t ObjectsIterator::Next ( )

Gets the next element to traverse.

Returns
The next element.
The documentation for this class was generated from the following file:
  • ObjectsIterator.h


Sparksee: QueryStream Class Reference

Public Member Functions | Protected Member Functions | List of all members
QueryStream Class Referenceabstract
Gdb

Query stream interface. More...

Public Member Functions

virtual | ~QueryStream ()
Destructor.
virtual bool_t | Prepare (const ValueList &list)=0
Prepares the stream before it is started.
virtual bool_t | Start (ResultSetList &list)=0
Starts the stream.
virtual bool_t | Fetch (ValueList &list)=0
Gets the next row and moves the iterator forward.

Protected Member Functions

QueryStream ()
Default constructor.

Detailed Description

Query stream interface.

A QueryStream is the interface between the application and the STREAM operator. When the operator starts inside a Query, the method is prepared with query-defined arguments. Then, if there are input operations, the STREAM operator builds the ResultSets and starts the iteration. Finally, the operator fetches rows until no more are available.

Application exceptions must be cached by the subclass that implements the interface.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

virtual bool_t QueryStream::Fetch ( ValueList & list )
pure virtual

Gets the next row and moves the iterator forward.

The end of sequence is denoted by returning TRUE with an empty row. A valid row must contain as many values (even NULL) as expected by the query.

Parameters
list [out] Storage for the new rows
Returns
TRUE if there is a row or end of sequence, FALSE on error
virtual bool_t QueryStream::Prepare ( const ValueList & list )
pure virtual

Prepares the stream before it is started.

Parameters
list [in] Optional list of arguments
Returns
FALSE on error
virtual bool_t QueryStream::Start ( ResultSetList & list )
pure virtual

Starts the stream.

Parameters
list [in] Optional list of input ResultSets
Returns
FALSE on error
The documentation for this class was generated from the following file:
  • Query.h


Sparksee: Query Class Reference

Public Member Functions | Private Member Functions | Friends | List of all members
Query Class Reference
Gdb

Query class. More...

Inheritance diagram for Query:
Collaboration diagram for Query:

Public Member Functions

virtual | ~Query ()
Destructor.
ResultSet * | Execute (const std::wstring &stmt, bool_t reiterable=false)
Executes the given statement.
QueryStream * | SetStream (const std::wstring &stream, QueryStream *handler)
Sets a query stream handler.
void | SetDynamic (const std::wstring &name, Value &value)
Sets the value for a dynamic paramater.

Private Member Functions

sparksee_core::Query * | GetHandler ()
Gets the handled reference.
const sparksee_core::Query * | GetHandler () const
Gets the handled reference.
void | SetHandler (sparksee_core::Query *h)
Sets the handled reference.
void | FreeHandler ()
Frees (deletes) the handled reference.
bool_t | IsNull () const
Gets if the handler is NULL.

Friends

class | Session
class | QueryContext

Detailed Description

Query class.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

ResultSet* Query::Execute | ( | const std::wstring & | stmt,
 |  | bool_t | reiterable = false
 | ) |  |

Executes the given statement.

Parameters
stmt | [in] Query statement.
reiterable | [in] Whether we want the resultset to be reiterable or not
Returns
A ResultSet instance with the contents of the result of the query.
void Query::SetDynamic | ( | const std::wstring & | name,
 |  | Value & | value
 | ) |  |

Sets the value for a dynamic paramater.

Parameters
name | [in] Parameter name
value | [in] Parameter value
QueryStream* Query::SetStream | ( | const std::wstring & | stream,
 |  | QueryStream * | handler
 | ) |  |

Sets a query stream handler.

Query streams handlers are created and destroyed by the caller.

Parameters
stream | [in] The stream name
handler | [in] Query stream handler
Returns
The previous handler, or NULL if it does not exists
The documentation for this class was generated from the following file:
  • Query.h


Sparksee: QueryContext Class Reference

Public Member Functions | List of all members
QueryContext Class Reference
Gdb

Query context interface. More...

Public Member Functions

QueryContext ()
Default constructor.
virtual ~QueryContext ()
Destructor.
Query * NewQuery ()
Creates a new Query.

Detailed Description

Query context interface.

A QueryContext contains and manages the resources required to run a Query. A Session is one example of a QueryContext connected to a Sparksee database. The applications can implement their own contexts to run queries out of Sparksee.

Author
Sparsity Technologies http://www.sparsity-technologies.com
The documentation for this class was generated from the following file:
  • QueryContext.h


Sparksee: ResultSet Class Reference

Public Member Functions | Private Member Functions | Friends | List of all members
ResultSet Class Reference
Gdb

ResultSet class. More...

Inheritance diagram for ResultSet:
Collaboration diagram for ResultSet:

Public Member Functions

virtual | ~ResultSet ()
Destructor.
int32_t | GetNumColumns () const
Gets the number of columns.
const std::wstring & | GetColumnName (int32_t index) const
Gets the name for the given column.
int32_t | GetColumnIndex (const std::wstring &name) const
Gets the column index for the given column name.
DataType | GetColumnDataType (int32_t index) const
Gets the datatype for the given column.
bool_t Next ()
Fetches the next row.
void | GetColumn (int32_t index, Value &value) const
Gets the value for the given column.
Value * | GetColumn (int32_t index) const
Gets the value for the given column.
void | Rewind ()
Positions the cursor before the first row.
const std::wstring & | GetJSON (int32_t rows)
Returns rows in JSON format.

Private Member Functions

sparksee_core::ResultSet * | GetHandler ()
Gets the handled reference.
const sparksee_core::ResultSet * | GetHandler () const
Gets the handled reference.
void | SetHandler (sparksee_core::ResultSet *h)
Sets the handled reference.
void | FreeHandler ()
Frees (deletes) the handled reference.
bool_t | IsNull () const
Gets if the handler is NULL.

Friends

class Query

Detailed Description

ResultSet class.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

void ResultSet::GetColumn | ( | int32_t | index,
 |  | Value & | value
 | ) |  | const

Gets the value for the given column.

Parameters
index | [in] Column index.
value | [in|out] Value.
Exceptions
QueryException If a database access error occurs.
Value* ResultSet::GetColumn ( int32_t index ) const

Gets the value for the given column.

Parameters
index [in] Column index.
Returns
The Value of the given column.
Exceptions
QueryException If a database access error occurs.
DataType ResultSet::GetColumnDataType ( int32_t index ) const

Gets the datatype for the given column.

Parameters
index [in] Column index.
Returns
DataType for the given column.
int32_t ResultSet::GetColumnIndex ( const std::wstring & name ) const

Gets the column index for the given column name.

Parameters
name [in] Column name.
Returns
Column index.
const std::wstring& ResultSet::GetColumnName ( int32_t index ) const

Gets the name for the given column.

Parameters
index [in] Column index.
Returns
Column name.
const std::wstring& ResultSet::GetJSON ( int32_t rows )

Returns rows in JSON format.

Rows are returned from the current position.

Parameters
rows [in] Maximum number of rows
Returns
JSON representation of the next <rows> rows in the resultset
int32_t ResultSet::GetNumColumns ( ) const

Gets the number of columns.

Columns are in the range [0...COLUMNS).

Returns
The number of columns.
bool_t ResultSet::Next ( )

Fetches the next row.

A ResultSet cursor is initially positioned before the first row; the first call to the method "Next" makes the first row the current row; the second call makes the second row the current row, and so on.

Returns
TRUE if the next row has been successfully fetched, FALSE otherwise.
Exceptions
QueryException If a database access error occurs.
The documentation for this class was generated from the following file:
  • ResultSet.h


Sparksee: ResultSetList Class Reference

Public Member Functions | List of all members
ResultSetList Class Reference
Gdb

ResultSet list. More...

Public Member Functions

int32_t | Count () const
Number of elements in the list.
ResultSetList ()
Constructor.
~ResultSetList ()
Destructor.
void | Clear ()
Clears the list.
ResultSet * | Get (int32_t index) const
Returns the ResultSet at the specified position in the list.
ResultSetListIterator * Iterator ()
Gets a new ResultSetListIterator.

Detailed Description

ResultSet list.

It stores a ResultSet list.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

ResultSetList::ResultSetList ( )

Constructor.

This creates an empty list.

Member Function Documentation

int32_t ResultSetList::Count ( ) const

Number of elements in the list.

Returns
Number of elements in the list.
ResultSet* ResultSetList::Get ( int32_t index ) const

Returns the ResultSet at the specified position in the list.

Parameters
index [in] Index of the element to return, starting at 0.
ResultSetListIterator* ResultSetList::Iterator ( )

Gets a new ResultSetListIterator.

Returns
ResultSetListIterator instance.
The documentation for this class was generated from the following file:
  • ResultSet.h


Sparksee: ResultSetListIterator Class Reference

Public Member Functions | Friends | List of all members
ResultSetListIterator Class Reference
Gdb

ResultSetList iterator class. More...

Public Member Functions

~ResultSetListIterator ()
Destructor.
const ResultSet * Next ()
Moves to the next element.
bool_t HasNext ()
Gets if there are more elements.

Friends

class ResultSetList

Detailed Description

ResultSetList iterator class.

Iterator to traverse all the values into a ResultSetList instance.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

bool_t ResultSetListIterator::HasNext ( )

Gets if there are more elements.

Returns
TRUE if there are more elements, FALSE otherwise.
const ResultSet* ResultSetListIterator::Next ( )

Moves to the next element.

Returns
The next element.
The documentation for this class was generated from the following file:
  • ResultSet.h


Sparksee: Session Class Reference

Public Member Functions | Private Member Functions | Friends | List of all members
Session Class Reference
Gdb

Session class. More...

Inheritance diagram for Session:
Collaboration diagram for Session:

Public Member Functions

virtual | ~Session ()
Destructor.
Graph * GetGraph ()
Gets the Graph instance.
Objects * NewObjects ()
Creates a new Objects instance.
void | Begin ()
Begins a transaction.
void | BeginUpdate ()
Begins an update transaction.
void | Commit ()
Commits a transaction.
void | Rollback ()
Rollbacks a transaction.
Query * | NewQuery (sparksee::gdb::QueryLanguage lang)
Creates a new Query.
int64_t PreCommit ()
PreCommits a transaction.
int64_t GetInMemoryPoolCapacity ()
Gets the capacity of the in-memory pool.

Private Member Functions

sparksee_core::Session * | GetHandler ()
Gets the handled reference.
const sparksee_core::Session * | GetHandler () const
Gets the handled reference.
void | SetHandler (sparksee_core::Session *h)
Sets the handled reference.
void | FreeHandler ()
Frees (deletes) the handled reference.
bool_t | IsNull () const
Gets if the handler is NULL.

Friends

class | Database
class | Graph
class | Objects
class | ObjectsIterator
class | KeyValues
class | Values
class | ValuesIterator
class | TextStream
class | ValueArray

Detailed Description

Session class.

A Session is a stateful period of activity of a user with the Database.

All the manipulation of a Database must be enclosed into a Session. A Session can be initiated from a Database instance and allows for getting a Graph instance which represents the persistent graph (the graph database).

Also, temporary data is associated to the Session, thus when a Session is closed, all the temporary data associated to the Session is removed too. Objects or Values instances or even session attributes are an example of temporary data.

Moreover, a Session is exclusive for a thread, thus if it is shared among threads results may be fatal or unexpected.

Check out the 'Processing' and 'Transactions' sections in the SPARKSEE User Manual for details about how Sessions work and the use of transactions.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

Graph* Session::GetGraph ( )

Gets the Graph instance.

Returns
The Graph instance.
int64_t Session::GetInMemoryPoolCapacity ( )

Gets the capacity of the in-memory pool.

Returns
Returns the capacity of the in-memory pool
Objects* Session::NewObjects ( )

Creates a new Objects instance.

Returns
The new Objects instance.
Query* Session::NewQuery ( sparksee::gdb::QueryLanguage lang )

Creates a new Query.

Parameters
lang The query language to create the query for
int64_t Session::PreCommit ( )

PreCommits a transaction.

YOU SHOULD NOT USE THIS METHOD. This method exists for a specific service and it is used to force that the transaction is written in the recovery log even though it had not been committed yet (and may never be).

Returns
The transaction id. This has to be used in RedoPrecommited in case of a recovery process.
The documentation for this class was generated from the following file:
  • Session.h


Sparksee: Sparksee Class Reference

Public Member Functions | Static Public Attributes | Private Member Functions | List of all members
Sparksee Class Reference
Gdb

Sparksee class. More...

Inheritance diagram for Sparksee:
Collaboration diagram for Sparksee:

Public Member Functions

Sparksee (SparkseeConfig &config)
Creates a new instance.
virtual | ~Sparksee ()
Destructor.
Database * | Create (const std::wstring &path, const std::wstring &alias) throw (sparksee::gdb::FileNotFoundException, sparksee::gdb::Error)
Creates a new Database instance.
Database * | Create (const std::wstring &path, const std::wstring &alias, const SparkseeConfig &config) throw (sparksee::gdb::FileNotFoundException, sparksee::gdb::Error)
Creates a new Database instance.
Database * | Open (const std::wstring &path, bool_t readOnly) throw (sparksee::gdb::FileNotFoundException, sparksee::gdb::Error)
Opens an existing Database instance.
Database * | Open (const std::wstring &path, bool_t readOnly, const SparkseeConfig &config) throw (sparksee::gdb::FileNotFoundException, sparksee::gdb::Error)
Opens an existing Database instance.
Database * | Restore (const std::wstring &path, const std::wstring &backupFile) throw (sparksee::gdb::FileNotFoundException, sparksee::gdb::Error)
Restores a Database from a backup file.
Database * | Restore (const std::wstring &path, const std::wstring &backupFile, const SparkseeConfig &config) throw (sparksee::gdb::FileNotFoundException, sparksee::gdb::Error)
Restores a Database from a backup file.
Database * | RestoreEncryptedBackup (const std::wstring &path, const std::wstring &backupFile, const std::wstring &keyInHex, const std::wstring &ivInHex) throw (sparksee::gdb::FileNotFoundException, sparksee::gdb::Error)
Restores a Database from an encrypted backup file.
Database * | RestoreEncryptedBackup (const std::wstring &path, const std::wstring &backupFile, const SparkseeConfig &config, const std::wstring &keyInHex, const std::wstring &ivInHex) throw (sparksee::gdb::FileNotFoundException, sparksee::gdb::Error)
Restores a Database from an encrypted backup file.
bool_t | VerifyChecksums (const std::wstring &path) throw (sparksee::gdb::FileNotFoundException, sparksee::gdb::Error)
Verifies the Checksum integrity of the given image file and it's recovery log file.
bool_t | AddChecksums (const std::wstring &path) throw (sparksee::gdb::FileNotFoundException, sparksee::gdb::Error)
Converts a database WITHOUT checksums into a database WITH checksums.
bool_t | RemoveChecksums (const std::wstring &path) throw (sparksee::gdb::FileNotFoundException, sparksee::gdb::Error)
Converts a database WITH checksums into a database WITHOUT checksums.
void | SetUnrecoverableErrorCallback (SPARKSEE_UNRECOVERABLE_ERR_CALLBACK callback)
Sets the unrecoverable error callback.
bool_t | Encrypt (const std::wstring &path) throw (sparksee::gdb::FileNotFoundException, sparksee::gdb::Error)
Converts a database WITHOUT encryption into an encrypted database.
bool_t | Decrypt (const std::wstring &path) throw (sparksee::gdb::FileNotFoundException, sparksee::gdb::Error)
Converts a database WITH encryption into a database WITHOUT encryption.
void | ResizeInMemoryPool (int64_t newCapacity) throw (sparksee::gdb::SystemError)
Resizes the in memory pool allocator.
int64_t GetInMemoryPoolCapacity ()
Gets the capacity of the in-memory pool (in Megabytes)

Static Public Attributes

static const std::wstring Version
Sparksee version.

Private Member Functions

sparksee_core::SPARKSEE * | GetHandler ()
Gets the handled reference.
const sparksee_core::SPARKSEE * | GetHandler () const
Gets the handled reference.
void | SetHandler (sparksee_core::SPARKSEE *h)
Sets the handled reference.
void | FreeHandler ()
Frees (deletes) the handled reference.
bool_t | IsNull () const
Gets if the handler is NULL.

Detailed Description

Sparksee class.

All Sparksee programs must have one single Sparksee instance to manage one or more Database instances.

This class allows for the creation of new Databases or open an existing one.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

Sparksee::Sparksee ( SparkseeConfig & config )

Creates a new instance.

Parameters
config [in/out] Sparksee configuration (may be updated).

Member Function Documentation

bool_t Sparksee::AddChecksums ( const std::wstring & path ) throw (sparksee::gdb::FileNotFoundException, sparksee::gdb::Error)

Converts a database WITHOUT checksums into a database WITH checksums.

Any error found is logged.

Precondition
The database (and it's recovery log if present) does NOT have checksums.
Parameters
path The path to the database image file
Returns
Returns true if the checksum could be added or false otherwise.
Exceptions
sparksee::gdb::FileNotFoundException
sparksee::gdb::Error
Database* Sparksee::Create | ( | const std::wstring & | path,
 |  | const std::wstring & | alias
 | ) |  | throw (sparksee::gdb::FileNotFoundException, sparksee::gdb::Error)

Creates a new Database instance.

Parameters
path | [in] Database storage file.
alias | [in] Database alias name.
Returns
A Database instance.
Exceptions
FileNotFoundException If the given file cannot be created.
Database* Sparksee::Create | ( | const std::wstring & | path,
 |  | const std::wstring & | alias,
 |  | const SparkseeConfig & | config
 | ) |  | throw (sparksee::gdb::FileNotFoundException, sparksee::gdb::Error)

Creates a new Database instance.

Parameters
path | [in] Database storage file.
alias | [in] Database alias name.
config | [in] Use a specific configuration instead of the one in this Sparksee
Returns
A Database instance.
Exceptions
FileNotFoundException If the given file cannot be created.
bool_t Sparksee::Decrypt ( const std::wstring & path ) throw (sparksee::gdb::FileNotFoundException, sparksee::gdb::Error)

Converts a database WITH encryption into a database WITHOUT encryption.

Any error found is logged.

Precondition
The database (and it's recovery log if present) is encrypted.
The current encryption had been configured using SparkseeConfig.
Parameters
path The path to the database image file
Returns
Returns true if the database could be unencrypted. The errors are returned with an exception.
Exceptions
sparksee::gdb::FileNotFoundException
sparksee::gdb::Error
bool_t Sparksee::Encrypt ( const std::wstring & path ) throw (sparksee::gdb::FileNotFoundException, sparksee::gdb::Error)

Converts a database WITHOUT encryption into an encrypted database.

Any error found is logged.

Precondition
The database (and it's recovery log if present) does is NOT encrypted.
The encryption had already been configured using SparkseeConfig.
Parameters
path The path to the database image file
Returns
Returns true if the database could be encrypted. The errors are returned with an exception.
Exceptions
sparksee::gdb::FileNotFoundException
sparksee::gdb::Error
int64_t Sparksee::GetInMemoryPoolCapacity ( )

Gets the capacity of the in-memory pool (in Megabytes)

Returns
Returns the capacity of the in memory pool
Database* Sparksee::Open | ( | const std::wstring & | path,
 |  | bool_t | readOnly
 | ) |  | throw (sparksee::gdb::FileNotFoundException, sparksee::gdb::Error)

Opens an existing Database instance.

Parameters
path | [in] Database storage file.
readOnly | [in] If TRUE, open Database in read-only mode.
Returns
A Database instance.
Exceptions
FileNotFoundException If the given file does not exist.
Database* Sparksee::Open | ( | const std::wstring & | path,
 |  | bool_t | readOnly,
 |  | const SparkseeConfig & | config
 | ) |  | throw (sparksee::gdb::FileNotFoundException, sparksee::gdb::Error)

Opens an existing Database instance.

The provided configuration will be used for all the database settings but not for the license, which must already be properly setup in this class.

Parameters
path | [in] Database storage file.
readOnly | [in] If TRUE, open Database in read-only mode.
config | [in] Use a specific configuration instead of the one in this Sparksee
Returns
A Database instance.
Exceptions
FileNotFoundException If the given file does not exist.
bool_t Sparksee::RemoveChecksums ( const std::wstring & path ) throw (sparksee::gdb::FileNotFoundException, sparksee::gdb::Error)

Converts a database WITH checksums into a database WITHOUT checksums.

Any error found is logged.

Precondition
The database (and it's recovery log if present) have checksums.
Parameters
path The path to the database image file
Returns
Returns true if the checksum could be removed. The errors are returned with an exception.
Exceptions
sparksee::gdb::FileNotFoundException
sparksee::gdb::Error
void Sparksee::ResizeInMemoryPool ( int64_t newCapacity ) throw (sparksee::gdb::SystemError)

Resizes the in memory pool allocator.

Parameters
newCapacity The new capacity of the in memory pool allocator
Returns
Returns true if was successful
Database* Sparksee::Restore | ( | const std::wstring & | path,
 |  | const std::wstring & | backupFile
 | ) |  | throw (sparksee::gdb::FileNotFoundException, sparksee::gdb::Error)

Restores a Database from a backup file.

See the Graph class Backup method.

Parameters
path | [in] Database storage file.
backupFile | [in] The Backup file to be restored.
Returns
A Database instance.
Exceptions
FileNotFoundException If the given file cannot be created, or the exported data file does not exists.
Database* Sparksee::Restore | ( | const std::wstring & | path,
 |  | const std::wstring & | backupFile,
 |  | const SparkseeConfig & | config
 | ) |  | throw (sparksee::gdb::FileNotFoundException, sparksee::gdb::Error)

Restores a Database from a backup file.

See the Graph class Backup method.

Parameters
path | [in] Database storage file.
backupFile | [in] The Backup file to be restored.
config | [in] Use a specific configuration instead of the one in this Sparksee
Returns
A Database instance.
Exceptions
FileNotFoundException If the given file cannot be created, or the exported data file does not exists.
Database* Sparksee::RestoreEncryptedBackup | ( | const std::wstring & | path,
 |  | const std::wstring & | backupFile,
 |  | const std::wstring & | keyInHex,
 |  | const std::wstring & | ivInHex
 | ) |  | throw (sparksee::gdb::FileNotFoundException, sparksee::gdb::Error)

Restores a Database from an encrypted backup file.

See the Graph class EncryptedBackup method.

Parameters
path | [in] Database storage file.
backupFile | [in] The Backup file to be restored.
keyInHex | [In] The AES encryption Key of the backup file as an hexadecimal string (8, 16 or 32 bytes).
ivInHex | [In] The AES Initialization Vector of the backup file as an hexadecimal string (16 bytes).
Returns
A Database instance.
Exceptions
FileNotFoundException If the given file cannot be created, or the exported data file does not exists.
Database* Sparksee::RestoreEncryptedBackup | ( | const std::wstring & | path,
 |  | const std::wstring & | backupFile,
 |  | const SparkseeConfig & | config,
 |  | const std::wstring & | keyInHex,
 |  | const std::wstring & | ivInHex
 | ) |  | throw (sparksee::gdb::FileNotFoundException, sparksee::gdb::Error)

Restores a Database from an encrypted backup file.

See the Graph class EncryptedBackup method.

Parameters
path | [in] Database storage file.
backupFile | [in] The Backup file to be restored.
config | [in] Use a specific configuration instead of the one in this Sparksee
keyInHex | [In] The AES encryption Key of the backup file as an hexadecimal string (8, 16 or 32 bytes).
ivInHex | [In] The AES Initialization Vector of the backup file as an hexadecimal string (16 bytes).
Returns
A Database instance.
Exceptions
FileNotFoundException If the given file cannot be created, or the exported data file does not exists.
void Sparksee::SetUnrecoverableErrorCallback ( SPARKSEE_UNRECOVERABLE_ERR_CALLBACK callback )

Sets the unrecoverable error callback.

Parameters
callback The unrecoverable error callback to set
bool_t Sparksee::VerifyChecksums ( const std::wstring & path ) throw (sparksee::gdb::FileNotFoundException, sparksee::gdb::Error)

Verifies the Checksum integrity of the given image file and it's recovery log file.

The main database file checksums are always checked.

When the recovery log file exists, the recovery log file is also checked for checksum and format errors.

When the checksums of the main file or the recovery file are incorrect, the funcion returns false, in any other error it throws an exception.

Any error found is logged as a WARNING.

Parameters
path The path to the image file
Returns
Returns true if the checksum verification succeeded. Returns false if an invalid checksum was detected.
Exceptions
sparksee::gdb::FileNotFoundException
sparksee::gdb::Error
The documentation for this class was generated from the following file:
  • Sparksee.h


Sparksee: SparkseeProperties Class Reference

Static Public Member Functions | Friends | List of all members
SparkseeProperties Class Reference
Gdb

Sparksee properties file. More...

Static Public Member Functions

static void | Load (const std::wstring &path)
Loads properties from the given file path.
static const std::wstring & | Get (const std::wstring &key, const std::wstring &def)
Gets a property.
static int32_t | GetInteger (const std::wstring &key, int32_t def)
Gets a property as an integer.
static bool_t | GetBoolean (const std::wstring &key, bool_t def)
Gets a property as a boolean.
static int64_t | GetTimeUnit (const std::wstring &key, int64_t def)
Gets a property as a time unit.
static void | Clear ()
Remove all the properties.
static void | SetHI (const std::wstring &value)
YOU SHOULD NOT USE THIS METHOD.

Friends

class SparkseeConfig

Detailed Description

Sparksee properties file.

This class is implemented as a singleton, so all public methods are static.

It allows for getting the property values stored in a properties file. A properties file is a file where there is one line per property. A property is defined by a key and a value as follows: key=value

By default, this loads properties from the file './sparksee.cfg'. The user may choose to load a different file by calling the method Load().

If the default properties file or the one loaded by the user do not exist, then this behaves as loading an empty properties file.

Member Function Documentation

static const std::wstring& SparkseeProperties::Get | ( | const std::wstring & | key,
 |  | const std::wstring & | def
 | ) |  |
static

Gets a property.

Parameters
key | [in] The name of the property to lookup.
def | [in] Default value to be returned in case there is no property with the name key.
Returns
The value of the property, or def if the key is not found.
static bool_t SparkseeProperties::GetBoolean | ( | const std::wstring & | key,
 |  | bool_t | def
 | ) |  |
static

Gets a property as a boolean.

Parameters
key | [in] The name of the property to lookup.
def | [in] Default value to be returned in case there is no property with the name key.
Returns
The property value, or def if the key is not found or in case of error.
static int32_t SparkseeProperties::GetInteger | ( | const std::wstring & | key,
 |  | int32_t | def
 | ) |  |
static

Gets a property as an integer.

Parameters
key | [in] The name of the property to lookup.
def | [in] Default value to be returned in case there is no property with the name key.
Returns
The property value, or def if the key is not found or in case of error.
static int64_t SparkseeProperties::GetTimeUnit | ( | const std::wstring & | key,
 |  | int64_t | def
 | ) |  |
static

Gets a property as a time unit.

A time unit is a string representation of a time duration with a time unit such as '10s' or '3H'.

Valid format for the string representation: Blanks at the begining or at the end are ignored. No blanks are allowed between the time duration and the unit time.

Allowed time units: 'D' for days, 'H' for hours, 'M' for minutes, 'S' o 's' for seconds, 'm' for milliseconds and 'u' for microseconds.

There is a special case: If no time unit is given, seconds is the default. So, '10' means 10 seconds.

Parameters
key | [in] The name of the property to lookup.
def | [in] The default value (in microseconds) to be returned in case there is no property with the name key.
Returns
The time duration in microseconds, or def if the key is not found or in case of error.
static void SparkseeProperties::Load ( const std::wstring & path )
static

Loads properties from the given file path.

Parameters
path [in] File path to load properties from.
static void SparkseeProperties::SetHI ( const std::wstring & value )
static

YOU SHOULD NOT USE THIS METHOD.

This method exists only for a specific service.

The documentation for this class was generated from the following file:
  • SparkseeConfig.h


Sparksee: SparkseeConfig Class Reference

Public Member Functions | Friends | List of all members
SparkseeConfig Class Reference
Gdb

Sparksee configuration class. More...

Public Member Functions

SparkseeConfig ()
Creates a new instance.
SparkseeConfig (const std::wstring &path)
Creates a new instance with a specific config file.
SparkseeConfig (const std::wstring &path, const std::wstring &clientId, const std::wstring &licenseId)
Creates a new instance with a specific config file and IDs.
virtual | ~SparkseeConfig ()
Destructor.
int32_t | GetExtentSize () const
Gets the size of a extent.
void | SetExtentSize (int32_t kBytes)
Sets the size of the extents in KB.
int32_t | GetExtentPages () const
Gets the number of pages per extent.
void | SetExtentPages (int32_t pages)
Sets the number of pages per extent.
int32_t | GetPoolFrameSize () const
Gets the size of a pool frame in number of extents.
void | SetPoolFrameSize (int32_t extents)
Sets the size of a pool frame in number of extents.
int32_t | GetPoolPersistentMinSize () const
Gets the minimum size for the persistent pool in number of frames.
void | SetPoolPersistentMinSize (int32_t frames)
Sets the minimum size for the persistent pool in number of frames.
int32_t | GetPoolPersistentMaxSize () const
Gets the maximum size for the persistent pool in number of frames.
void | SetPoolPersistentMaxSize (int32_t frames)
Sets the maximum size for the persistent pool in number of frames.
int32_t | GetPoolTemporaryMinSize () const
Gets the minimum size for the temporary pool in number of frames.
void | SetPoolTemporaryMinSize (int32_t frames)
Sets the minimum size for the temporary pool in number of frames.
int32_t | GetPoolTemporaryMaxSize () const
Gets the maximum size for the temporary pool in number of frames.
void | SetPoolTemporaryMaxSize (int32_t frames)
Sets the maximum size for the temporary pool in number of frames.
int32_t | GetPoolPartitions () const
Gets the number of partitions in each PartitionedPool.
void | SetPoolPartitions (int32_t pools)
Sets the number of pools in each PartitionedPool.
int32_t | GetCacheMaxSize () const
Gets the maximum size for the cache (all pools) in MB.
void | SetCacheMaxSize (int32_t megaBytes)
Sets the maximum size for the cache (all pools) in MB.
const std::wstring & | GetLicense () const
Gets the license key.
int32_t | SetLicense (const std::wstring &key)
Sets the license key.
const std::wstring & | GetLogFile () const
Gets the log file.
void | SetLogFile (const std::wstring &filePath)
Sets the log file.
LogLevel | GetLogLevel () const
Gets the log level.
void | SetLogLevel (LogLevel level)
Sets the log level.
bool_t | GetCacheStatisticsEnabled () const
Gets whether cache statistics are enabled or disabled.
void | SetCacheStatisticsEnabled (bool_t status)
Enables or disables cache statistics.
const std::wstring & | GetCacheStatisticsFile () const
Gets the cache statistics log file.
void | SetCacheStatisticsFile (const std::wstring &filePath)
Sets the cache statistics log file.
int64_t | GetCacheStatisticsSnapshotTime () const
Gets the cache statistics snapshot time in microseconds.
void | SetCacheStatisticsSnapshotTime (int64_t microSeconds)
Sets the cache statistics snapshot time.
bool_t | GetRollbackEnabled () const
Gets whether the rollback is enabled or disabled.
void | SetRollbackEnabled (bool_t status)
Enables or disables the rollback.
bool_t | GetRecoveryEnabled () const
Gets whether the recovery is enabled or disabled.
void | SetRecoveryEnabled (bool_t status)
Enables or disables the recovery.
const std::wstring & | GetRecoveryLogFile () const
Gets the recovery log file.
void | SetRecoveryLogFile (const std::wstring &filePath)
Sets the recovery log file.
int32_t | GetRecoveryCacheMaxSize () const
Gets the maximum size for the recovery log cache in extents.
void | SetRecoveryCacheMaxSize (int32_t extents)
Sets the maximum size for the recovery log cache in extents.
int64_t | GetRecoveryCheckpointTime () const
Gets the delay time (in microseconds) between automatic checkpoints.
void | SetRecoveryCheckpointTime (int64_t microSeconds)
Sets the delay time (in microseconds) between automatic checkpoints.
bool_t | GetChecksumEnabled () const
Gets whether the storage checksum usage is enabled or disabled.
void | SetChecksumEnabled (bool_t status)
Enables or disables the storage checksum usage.
bool_t | GetHighAvailabilityEnabled () const
Gets whether high availability mode is enabled or disabled.
void | SetHighAvailabilityEnabled (bool_t status)
Enables or disables high availability mode.
const std::wstring & | GetHighAvailabilityIP () const
Gets the IP address and port of the instance.
void | SetHighAvailabilityIP (const std::wstring &ip)
Sets the IP address and port of the instance.
const std::wstring & | GetHighAvailabilityCoordinators () const
Gets the coordinators address and port list.
void | SetHighAvailabilityCoordinators (const std::wstring &ip)
Sets the coordinators address and port list.
int64_t | GetHighAvailabilitySynchronization () const
Gets the synchronization polling time.
void | SetHighAvailabilitySynchronization (int64_t microSeconds)
Sets the synchronization polling time.
int64_t | GetHighAvailabilityMasterHistory () const
Gets the master's history log.
void | SetHighAvailabilityMasterHistory (int64_t filePath)
Sets the master's history log.
bool_t | GetCallStackDump () const
Gets whether the signals will be captured to dump the call stack or not.
void | SetCallStackDump (bool_t status)
Sets whether the signals will be captured to dump the call stack or not.
const std::wstring & | GetClientId () const
Gets the client identifier.
void | SetClientId (const std::wstring &clientId)
Set the client identifier.
const std::wstring & | GetLicenseId () const
Gets the license identifier.
void | SetLicenseId (const std::wstring &licenseId)
Set the license identifier.
int32_t | GetLicensePreDownloadDays () const
Get the number of days before expiration when a new license will be downloaded.
void | SetLicensePreDownloadDays (int32_t days)
Start trying to automatically download a new license at the specified number of days before expiration.
int32_t DownloadLicense ()
Try to download a license key Can be used to explicitly download a license when the autodownload is disabled (LicensePreDownloadDays == -1).
const std::wstring & | GetDownloadStatus () const
Gets a message with the license download result.
bool_t DownloadExpected ()
Check if a new license will be automatically downloaded with the current settings.
std::wstring | GetLicenseRequest ()
Get information useful to manually request a license.
const std::wstring & | GetTmpFolder () const
Gets the temporary folder used for temporary staging.
void | SetTmpFolder (const std::wstring &tmpFolder)
Sets the temporary folder used for temporary staging.
bool_t | GetTmpEnabled () const
Gets whether using temporary storage for computations is enabled.
void | SetTmpEnabled (bool_t enabled)
Sets whether to use temporary storage for computations or not.
int64_t | GetInMemAllocSize () const
Gets the in-memory allocator size.
void | SetInMemAllocSize (int64_t size)
Sets the in-memory allocator size.
bool_t Save ()
Save the current configuration in the specified config file.
bool_t SaveAll ()
Save all the current configuration settings in the specified config file.
bool_t | GetEncryptionEnabled () const
Gets whether the storage encryption is enabled or disabled.
bool_t | SetAESEncryptionEnabled (const std::wstring &keyInHex, const std::wstring &ivInHex)
Enables storage encryption using AES with the given key and iv.
bool_t | SetAESEncryptionEnabled (int32_t keySize)
Enables storage encryption using AES and GENARATES a key and an iv.
const std::wstring & | GetAESKey () const
Get the AES encryption key in a hexadecimal encoded string.
const std::wstring & | GetAESIV () const
Get the AES initialization vector in a hexadecimal encoded string.
void | SetEncryptionDisabled ()
Disables storage encryption.
void | SetSparkseeConfigFile (const std::wstring &path)
Sets the config file path.
const std::wstring & | GetSparkseeConfigFile () const
Gets the config file path.

Friends

class Sparksee

Detailed Description

Sparksee configuration class.

If not specified, 0 means unlimited which is the maximum available. For the pools that's the total cache size. For the cache unlimited means nearly all the physical memory of the computer.

For each field, there is a default value. This value can be overrided with values from a properties file (see SparkseeProperties class). Also, this settings can be overrided calling a specific setter.

For each field, it is shown its default value and the property to override this value:

Extent size: 4KB ('sparksee.storage.extentsize' at SparkseeProperties).

Pages per extent: 1 page ('sparksee.storage.extentpages' at SparkseeProperties).

Checksums enabled: true ('sparksee.storage.checksum' at SparkseeProperties).

Pool frame size: 1 extent ('sparksee.io.pool.frame.size' at SparkseeProperties).

Minimum size for the persistent pool: 64 frames ('sparksee.io.pool.persistent.minsize' at SparkseeProperties).

Maximum size for the persistent pool: 0 frames ('sparksee.io.pool.persistent.maxsize' at SparkseeProperties).

Minimum size for the temporary pool: 16 frames ('sparksee.io.pool.temporal.minsize' at SparkseeProperties).

Maximum size for the temporary pool: 0 frames ('sparksee.io.pool.temporal.maxsize' at SparkseeProperties).

Number of pools in the pool cluster: 0 pools ('sparksee.io.pool.clustersize' at SparkseeProperties). 0 or 1 means the clustering is disabled.

Maximum size for the cache (all pools): 0 MB ('sparksee.io.cache.maxsize' at SparkseeProperties).

License code: "" ('sparksee.license' at SparkseeProperties). No license code means evaluation license.

Log level: Info ('sparksee.log.level' at SparkseeProperties).

Log file: "sparksee.log" ('sparksee.log.file' at SparkseeProperties).

Cache statistics: false (disabled) ('sparksee.cache.statistics' at SparkseeProperties).

Cache statistics log file: "statistics.log" ('sparksee.cache.statisticsFile' at SparkseeProperties).

Cache statistics snapshot time: 1000 msecs [TimeUnit] ('sparksee.cache.statisticsSnapshotTime' at SparkseeProperties).

Recovery enabled: false ('sparksee.io.recovery' at SparkseeProperties).

Recovery log file: "" ('sparksee.io.recovery.logfile' at SparkseeProperties).

Recovery cache max size: 1MB ('sparksee.io.recovery.cachesize' at SparkseeProperties).

Recovery checkpoint time: 60 seconds [TimeUnit] ('sparksee.io.recovery.checkpointTime' at SparkseeProperties).

High-availability: false (disabled) ('sparksee.ha' at SparkseeProperties).

High-availability coordinators: "" ('sparksee.ha.coordinators' at SparkseeProperties).

High-availability IP: "" ('sparksee.ha.ip' at SparkseeProperties).

High-availability sync polling: 0 (disabled) [TimeUnit] ('sparksee.ha.sync' at SparkseeProperties).

High-availability master history: 1D (1 day) [TimeUnit] ('sparksee.ha.master.history' at SparkseeProperties).

Use of TimeUnit:

Those variables using TimeUnit allow for:

<X>[D|H|M|S|s|m|u]

where <X> is a number followed by an optional character which represents the unit: D for days, H for hours, M for minutes, S or s for seconds, m for milliseconds and u for microseconds. If no unit character is given, seconds are assumed.

Capture abort signals to dump the call stack ('sparksee.callstackdump' at SparkseeProperties) is enabled by default on most platforms.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

SparkseeConfig::SparkseeConfig ( )

Creates a new instance.

Values are set with default values.

SparkseeConfig::SparkseeConfig ( const std::wstring & path )

Creates a new instance with a specific config file.

The config file will be loaded using the global properties class and the file may be automatically overwritten with the config changes. If the file doesn't exists, it will be created.

Parameters
path [in] File path to the config file.
SparkseeConfig::SparkseeConfig | ( | const std::wstring & | path,
 |  | const std::wstring & | clientId,
 |  | const std::wstring & | licenseId
 | ) |  |

Creates a new instance with a specific config file and IDs.

The config file will be loaded using the global properties class and the file may be automatically overwritten with the config changes. If the config file already exists, the client and license ids should have the same values as the given arguments. If the file doesn't exists, it will be created.

Parameters
path | [in] File path to the config file.
clientId | [in] The client identifier.
licenseId | [in] The license identifier.

Member Function Documentation

int32_t SparkseeConfig::DownloadLicense ( )

Try to download a license key Can be used to explicitly download a license when the autodownload is disabled (LicensePreDownloadDays == -1).

Returns
Returns -1 if a valid license key couldn't be downloaded, 0 if the same license was downloaded or 1 if a different license is downloaded.
const std::wstring& SparkseeConfig::GetAESIV ( ) const

Get the AES initialization vector in a hexadecimal encoded string.

Returns
The AES initialization vector as an hexadecimal string.
const std::wstring& SparkseeConfig::GetAESKey ( ) const

Get the AES encryption key in a hexadecimal encoded string.

Returns
The AES encryption Key as an hexadecimal string.
int32_t SparkseeConfig::GetCacheMaxSize ( ) const

Gets the maximum size for the cache (all pools) in MB.

Returns
The maximum size for the cache (all pools) in MB.
bool_t SparkseeConfig::GetCacheStatisticsEnabled ( ) const

Gets whether cache statistics are enabled or disabled.

Returns
TRUE if cache statistics are enabled, FALSE otherwise.
const std::wstring& SparkseeConfig::GetCacheStatisticsFile ( ) const

Gets the cache statistics log file.

Useless if cache statistics are disabled.

Returns
The cache statistics log file.
int64_t SparkseeConfig::GetCacheStatisticsSnapshotTime ( ) const

Gets the cache statistics snapshot time in microseconds.

Useless if cache statistics are disabled.

Returns
The cache statistics snapshot time in microseconds.
bool_t SparkseeConfig::GetCallStackDump ( ) const

Gets whether the signals will be captured to dump the call stack or not.

Returns
TRUE if the signals must be captured, FALSE otherwise.
bool_t SparkseeConfig::GetChecksumEnabled ( ) const

Gets whether the storage checksum usage is enabled or disabled.

Returns
TRUE if the checksum is enabled, FALSE otherwise.
const std::wstring& SparkseeConfig::GetClientId ( ) const

Gets the client identifier.

Returns
The client identifier.
const std::wstring& SparkseeConfig::GetDownloadStatus ( ) const

Gets a message with the license download result.

It can be used when the DownloadLicense call failed.

Returns
The log download result.
bool_t SparkseeConfig::GetEncryptionEnabled ( ) const

Gets whether the storage encryption is enabled or disabled.

Returns
TRUE if the encryption is enabled, FALSE otherwise.
int32_t SparkseeConfig::GetExtentPages ( ) const

Gets the number of pages per extent.

Returns
The number of pages per extent.
int32_t SparkseeConfig::GetExtentSize ( ) const

Gets the size of a extent.

Returns
The size of a extent in KB.
const std::wstring& SparkseeConfig::GetHighAvailabilityCoordinators ( ) const

Gets the coordinators address and port list.

Returns
The coordinators address and port list.
bool_t SparkseeConfig::GetHighAvailabilityEnabled ( ) const

Gets whether high availability mode is enabled or disabled.

Returns
TRUE if high availability mode is enabled, FALSE otherwise.
const std::wstring& SparkseeConfig::GetHighAvailabilityIP ( ) const

Gets the IP address and port of the instance.

Returns
The IP address and port of the instance.
int64_t SparkseeConfig::GetHighAvailabilityMasterHistory ( ) const

Gets the master's history log.

Returns
The master's history log.
int64_t SparkseeConfig::GetHighAvailabilitySynchronization ( ) const

Gets the synchronization polling time.

Returns
The Synchronization polling time.
int64_t SparkseeConfig::GetInMemAllocSize ( ) const

Gets the in-memory allocator size.

Returns
Returns the in-memory allocator size
const std::wstring& SparkseeConfig::GetLicense ( ) const

Gets the license key.

Returns
The license key.
const std::wstring& SparkseeConfig::GetLicenseId ( ) const

Gets the license identifier.

Returns
The license identifier.
int32_t SparkseeConfig::GetLicensePreDownloadDays ( ) const

Get the number of days before expiration when a new license will be downloaded.

Returns
Returns the number of days or -1 if it will never be automatically downloaded.
const std::wstring& SparkseeConfig::GetLogFile ( ) const

Gets the log file.

Returns
The log file.
LogLevel SparkseeConfig::GetLogLevel ( ) const

Gets the log level.

Returns
The LogLevel.
int32_t SparkseeConfig::GetPoolFrameSize ( ) const

Gets the size of a pool frame in number of extents.

Returns
The size of a pool frame in number of extents.
int32_t SparkseeConfig::GetPoolPartitions ( ) const

Gets the number of partitions in each PartitionedPool.

Returns
The number of partitions in each PartitionedPool.
int32_t SparkseeConfig::GetPoolPersistentMaxSize ( ) const

Gets the maximum size for the persistent pool in number of frames.

Returns
The maximum size for the persistent pool in number of frames.
int32_t SparkseeConfig::GetPoolPersistentMinSize ( ) const

Gets the minimum size for the persistent pool in number of frames.

Returns
The minimum size for the persistent pool in number of frames.
int32_t SparkseeConfig::GetPoolTemporaryMaxSize ( ) const

Gets the maximum size for the temporary pool in number of frames.

Returns
The maximum size for the temporary pool in number of frames.
int32_t SparkseeConfig::GetPoolTemporaryMinSize ( ) const

Gets the minimum size for the temporary pool in number of frames.

Returns
The minimum size for the temporary pool in number of frames.
int32_t SparkseeConfig::GetRecoveryCacheMaxSize ( ) const

Gets the maximum size for the recovery log cache in extents.

Returns
The maximum size for the recovery log cache in extents.
int64_t SparkseeConfig::GetRecoveryCheckpointTime ( ) const

Gets the delay time (in microseconds) between automatic checkpoints.

Returns
The delay time (in microseconds) between automatic checkpoints.
bool_t SparkseeConfig::GetRecoveryEnabled ( ) const

Gets whether the recovery is enabled or disabled.

Returns
TRUE if the recovery is enabled, FALSE otherwise.
const std::wstring& SparkseeConfig::GetRecoveryLogFile ( ) const

Gets the recovery log file.

Returns
The recovery log file.
bool_t SparkseeConfig::GetRollbackEnabled ( ) const

Gets whether the rollback is enabled or disabled.

Returns
TRUE if the rollback is enabled, FALSE otherwise.
const std::wstring& SparkseeConfig::GetSparkseeConfigFile ( ) const

Gets the config file path.

Returns
Returns the configured path or an empty string
bool_t SparkseeConfig::GetTmpEnabled ( ) const

Gets whether using temporary storage for computations is enabled.

Returns
True if enabled
const std::wstring& SparkseeConfig::GetTmpFolder ( ) const

Gets the temporary folder used for temporary staging.

Returns
The temporary folder path
bool_t SparkseeConfig::Save ( )

Save the current configuration in the specified config file.

It will try to save the current configuration only if a config file was specified. This method will be automatically used when a Sparksee class downloads a new License.

Returns
Returns true if the config file is successfully written or false otherwise.
bool_t SparkseeConfig::SaveAll ( )

Save all the current configuration settings in the specified config file.

It will try to save the current configuration only if a config file was specified. The saved config file WILL CONATAIN all the modified settings including the secret ENCRYPTION KEYS. You should usually just use the Save method instead.

Returns
Returns true if the config file is successfully written or false otherwise.
bool_t SparkseeConfig::SetAESEncryptionEnabled | ( | const std::wstring & | keyInHex,
 |  | const std::wstring & | ivInHex
 | ) |  |

Enables storage encryption using AES with the given key and iv.

The key and initialization vector will not be saved in the config file.

Parameters
keyInHex | [In] The AES encryption Key as an hexadecimal string (8, 16 or 32 bytes).
ivInHex | [In] The AES Initialization Vector as an hexadecimal string (16 bytes).
Returns
Returns true if the encryption had been enabled with the given arguments or false otherwise.
bool_t SparkseeConfig::SetAESEncryptionEnabled ( int32_t keySize )

Enables storage encryption using AES and GENARATES a key and an iv.

YOU MUST GET AND KEEP SAFE THE GENERATED KEY AND IV! The key and initialization vector will not be saved in the config file.

Parameters
keySize [In] The key size in bytes (8, 16 or 32).
Returns
Returns true if the encryption had been enabled.
void SparkseeConfig::SetCacheMaxSize ( int32_t megaBytes )

Sets the maximum size for the cache (all pools) in MB.

Parameters
megaBytes [in] The maximum size for the cache (all pools) in MB. It must be non-negative.
void SparkseeConfig::SetCacheStatisticsEnabled ( bool_t status )

Enables or disables cache statistics.

Parameters
status [in] If TRUE this enables cache statistics, if FALSE this disables cache statistics.
void SparkseeConfig::SetCacheStatisticsFile ( const std::wstring & filePath )

Sets the cache statistics log file.

Useless if cache statistics are disabled.

Parameters
filePath [in] The cache statistics log file.
void SparkseeConfig::SetCacheStatisticsSnapshotTime ( int64_t microSeconds )

Sets the cache statistics snapshot time.

Useless if cache statistics are disabled.

Parameters
microSeconds [in] The cache statistics snapshot time in microseconds.
void SparkseeConfig::SetCallStackDump ( bool_t status )

Sets whether the signals will be captured to dump the call stack or not.

Parameters
status [in] If TRUE signals must be captured.
void SparkseeConfig::SetChecksumEnabled ( bool_t status )

Enables or disables the storage checksum usage.

Parameters
status [in] If TRUE this enables the checksum, if FALSE then disables it.
void SparkseeConfig::SetClientId ( const std::wstring & clientId )

Set the client identifier.

If you don't have a client identifier, you may want to register at http://sparsity-technologies.com/#sparksee

Parameters
clientId [in] The client identifier.
void SparkseeConfig::SetExtentPages ( int32_t pages )

Sets the number of pages per extent.

Parameters
pages [in] The number of pages. It must be at least 1 page and the page size must be greater than or equal to 4KB.
void SparkseeConfig::SetExtentSize ( int32_t kBytes )

Sets the size of the extents in KB.

Parameters
kBytes [in] The size of an extent in KB. An extent can have a size between 4KB and 64KB, and it must be a power of 2.
void SparkseeConfig::SetHighAvailabilityCoordinators ( const std::wstring & ip )

Sets the coordinators address and port list.

Parameters
ip [in] The coordinators address and port list.
void SparkseeConfig::SetHighAvailabilityEnabled ( bool_t status )

Enables or disables high availability mode.

Parameters
status [in] If TRUE this enables high availability mode, if FALSE this disables high availability mode.
void SparkseeConfig::SetHighAvailabilityIP ( const std::wstring & ip )

Sets the IP address and port of the instance.

Parameters
ip [in] The IP address and port of the instance.
void SparkseeConfig::SetHighAvailabilityMasterHistory ( int64_t filePath )

Sets the master's history log.

Parameters
filePath [in] The master's history log.
void SparkseeConfig::SetHighAvailabilitySynchronization ( int64_t microSeconds )

Sets the synchronization polling time.

Parameters
microSeconds [in] The synchronization polling time.
void SparkseeConfig::SetInMemAllocSize ( int64_t size )

Sets the in-memory allocator size.

Parameters
size The size to set the in-memory allocator to
int32_t SparkseeConfig::SetLicense ( const std::wstring & key )

Sets the license key.

Parameters
key [in] The license key. Returns -1 if the new key can't be used, 0 if it's the same license or 1 if the new license is applied.
void SparkseeConfig::SetLicenseId ( const std::wstring & licenseId )

Set the license identifier.

If you don't have a license identifier, you may want to register at http://sparsity-technologies.com/#sparksee

Parameters
licenseId [in] The license identifier.
void SparkseeConfig::SetLicensePreDownloadDays ( int32_t days )

Start trying to automatically download a new license at the specified number of days before expiration.

Parameters
days [in] Number of days before expiration or -1 if the license should never be downloaded.
void SparkseeConfig::SetLogFile ( const std::wstring & filePath )

Sets the log file.

Parameters
filePath [in] The log file.
void SparkseeConfig::SetLogLevel ( LogLevel level )

Sets the log level.

Parameters
level [in] The LogLevel.
void SparkseeConfig::SetPoolFrameSize ( int32_t extents )

Sets the size of a pool frame in number of extents.

Parameters
extents [in] The size of a pool frame in number of extents. It must be non-negative.
void SparkseeConfig::SetPoolPartitions ( int32_t pools )

Sets the number of pools in each PartitionedPool.

Parameters
pools [in] The number of pools in each PartitionedPool. It must be non-negative.
void SparkseeConfig::SetPoolPersistentMaxSize ( int32_t frames )

Sets the maximum size for the persistent pool in number of frames.

Parameters
frames [in] The maximum size for the persistent pool in number of frames. It must be non-negative.
void SparkseeConfig::SetPoolPersistentMinSize ( int32_t frames )

Sets the minimum size for the persistent pool in number of frames.

Parameters
frames [in] The minimum size for the persistent pool in number of frames. It must be non-negative.
void SparkseeConfig::SetPoolTemporaryMaxSize ( int32_t frames )

Sets the maximum size for the temporary pool in number of frames.

Parameters
frames [in] The maximum size for the temporary pool in number of frames. It must be non-negative.
void SparkseeConfig::SetPoolTemporaryMinSize ( int32_t frames )

Sets the minimum size for the temporary pool in number of frames.

Parameters
frames [in] The minimum size for the temporary pool in number of frames. It must be non-negative.
void SparkseeConfig::SetRecoveryCacheMaxSize ( int32_t extents )

Sets the maximum size for the recovery log cache in extents.

Parameters
extents [in] The maximum size for the recovery log cache in extents. A 0 sets the default value (extents up to 1MB).
void SparkseeConfig::SetRecoveryCheckpointTime ( int64_t microSeconds )

Sets the delay time (in microseconds) between automatic checkpoints.

Parameters
microSeconds [in] The delay time (in microseconds) between automatic checkpoints. A 0 forces a checkpoint after each commited transaction.
void SparkseeConfig::SetRecoveryEnabled ( bool_t status )

Enables or disables the recovery.

Parameters
status [in] If TRUE this enables the recovery, if FALSE then disables it.
void SparkseeConfig::SetRecoveryLogFile ( const std::wstring & filePath )

Sets the recovery log file.

Parameters
filePath [in] The recovery log file. Left it empty for the default log file (same as <database_file_name>.log)
void SparkseeConfig::SetRollbackEnabled ( bool_t status )

Enables or disables the rollback.

Parameters
status [in] If TRUE this enables the rollback, if FALSE then disables it.
void SparkseeConfig::SetSparkseeConfigFile ( const std::wstring & path )

Sets the config file path.

The file is not loaded in this operation, see the constructor options if you need to load the file. The config file may be automatically overwritten with the config changes. If the file doesn't exists, it will be created.

Parameters
path [in] File path to the config file.
void SparkseeConfig::SetTmpEnabled ( bool_t enabled )

Sets whether to use temporary storage for computations or not.

Parameters
enabled True to use temporary storage for computation
void SparkseeConfig::SetTmpFolder ( const std::wstring & tmpFolder )

Sets the temporary folder used for temporary staging.

Parameters
tmpFolder The temporary folder to set
The documentation for this class was generated from the following file:
  • SparkseeConfig.h


Sparksee: TextStream Class Reference

Public Member Functions | Private Member Functions | Friends | List of all members
TextStream Class Reference
Gdb

TextStream class. More...

Inheritance diagram for TextStream:
Collaboration diagram for TextStream:

Public Member Functions

TextStream (bool_t append)
Creates a new instance.
int32_t | Read (uchar_t *dataOUT, int32_t length) const
Read data from the stream.
void | Write (const uchar_t *dataIN, int32_t length)
Write data to the stream.
void | Close ()
Closes the stream.
virtual | ~TextStream ()
Destructor.
bool_t | IsNull () const
Returns TRUE if the stream is not available.

Private Member Functions

sparksee_core::GraphTextStream * | GetHandler ()
Gets the handled reference.
const
sparksee_core::GraphTextStream * 		GetHandler () const
Gets the handled reference.
void | SetHandler (sparksee_core::GraphTextStream *h)
Sets the handled reference.
void | FreeHandler ()
Frees (deletes) the handled reference.

Friends

class Graph

Detailed Description

TextStream class.

It allows for reading and writting Text attribute values.

It is very important to close the stream once no more reading or writting operations will be performed to ensure data is successfully stored.

Whereas string attributes are set and got using the Value class, text attributes are operated using a stream pattern.

Use of TextStream for writing: (i) Create a TextStream instance and (ii) set the stream for a text attribute of a node or edge instance with the graph SetAttributeText method. Once the set attribute text has been done, (iii) perform as many write operations as you need to the TextStream instance. Lastly, (iv) exeucte Close to flush and close the stream.

Use of TextStream for reading: (i) Get the stream of a text attribute of a node or edge instance with the GetAttributeText graph method. Once you have the TextStream instance, (ii) you can execute Read operations to read from the stream. (iii) The end of the stream is reached when Read returns 0. Finally, (iv) execute Close to close stream resources.

Check out the 'Attributes and values' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

TextStream::TextStream ( bool_t append )

Creates a new instance.

A TextStream only can be created by the user to write data.

Parameters
append [in] If TRUE, the it is created in append mode to write from the end of the stream, otherwise it is created to write from the begining of the stream.

Member Function Documentation

void TextStream::Close ( )

Closes the stream.

Once the Stream is closed, it cannot be used again.

Closing the stream is mandatory when the stream is not null and strongly recommended when it's null to avoid deallocation problems in some platforms.

bool_t TextStream::IsNull ( ) const

Returns TRUE if the stream is not available.

It returns FALSE if the stream is ready for reading or writing data.

Returns
FALSE if the stream is ready
int32_t TextStream::Read | ( | uchar_t * | dataOUT,
 |  | int32_t | length
 | ) |  | const

Read data from the stream.

Parameters
dataOUT | [out] Buffer to read data to. It must be allocated by the user.
length | [in] Length of the given data buffer. It must be > 0.
Returns
Amount of read data (<= length). If 0, there is no more data to be read from the stream.
void TextStream::Write | ( | const uchar_t * | dataIN,
 |  | int32_t | length
 | ) |  |

Write data to the stream.

Parameters
dataIN | [in] Buffer to write data from.
length | [in] Length of the data buffer. It must be > 0.
The documentation for this class was generated from the following file:
  • Stream.h


Sparksee: Value Class Reference

Public Member Functions | Static Public Attributes | Private Member Functions | Friends | List of all members
Value Class Reference
Gdb

Value class. More...

Inheritance diagram for Value:
Collaboration diagram for Value:

Public Member Functions

Value ()
Creates a new instance.
Value (const Value &value)
Copy constructor.
virtual | ~Value ()
Destructor.
Value & | operator= (const Value &value)
Assignment operator.
bool_t | IsNull () const
Gets if this is a NULL Value.
void | SetNullVoid ()
Sets the Value to NULL.
Value & SetNull ()
Sets the Value to NULL.
DataType | GetDataType () const
Gets the DataType.
bool_t | GetBoolean () const
Gets Boolean Value.
int32_t | GetInteger () const
Gets Integer Value.
int64_t | GetLong () const
Gets Long Value.
double64_t | GetDouble () const
Gets Double Value.
int64_t | GetTimestamp () const
Gets Timestamp Value.
const std::wstring & | GetString () const
Gets String Value.
oid_t | GetOID () const
Gets OID Value.
void | SetBooleanVoid (bool_t value)
Sets the Value.
Value & | SetBoolean (bool_t value)
Sets the Value.
void | SetIntegerVoid (int32_t value)
Sets the Value.
Value & | SetInteger (int32_t value)
Sets the Value.
void | SetLongVoid (int64_t value)
Sets the Value.
Value & | SetLong (int64_t value)
Sets the Value.
void | SetDoubleVoid (double64_t value)
Sets the Value.
Value & | SetDouble (double64_t value)
Sets the Value.
void | SetTimestampVoid (int64_t value)
Sets the Value.
void | SetTimestampVoid (int32_t year, int32_t month, int32_t day, int32_t hour, int32_t minutes, int32_t seconds, int32_t millisecs)
Sets the Value.
Value & | SetTimestamp (int64_t value)
Sets the Value.
Value & | SetTimestamp (int32_t year, int32_t month, int32_t day, int32_t hour, int32_t minutes, int32_t seconds, int32_t millisecs)
Sets the Value.
void | SetStringVoid (const std::wstring &value)
Sets the Value.
Value & | SetString (const std::wstring &value)
Sets the Value.
void | SetOIDVoid (oid_t value)
Sets the OID Value.
Value & | SetOID (oid_t value)
Sets the Value.
void | SetVoid (Value &value)
Sets the Value.
Value & | Set (Value &value)
Sets the Value.
int32_t | Compare (const Value &value) const
Compares with the given Value.
bool_t | Equals (const Value &value) const
Compares with the given Value.
std::wstring & | ToString (std::wstring &str) const
Gets a string representation of the Value.

Static Public Attributes

static const int32_t MaxLengthString
Maximum number of characters allowed for a String.

Private Member Functions

sparksee_core::Value * | GetHandler ()
Gets the handled reference.
const sparksee_core::Value * | GetHandler () const
Gets the handled reference.
void | SetHandler (sparksee_core::Value *h)
Sets the handled reference.
void | FreeHandler ()
Frees (deletes) the handled reference.

Friends

class | Graph
class | ValuesIterator
class | ResultSet
class | Query
class | KeyValues
class | KeyValue
class | ValueArray

Detailed Description

Value class.

It is a container which stores a value and its data type (domain). A Value can be NULL.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

Value::Value ( )

Creates a new instance.

It creates a NULL Value.

Value::Value ( const Value & value )

Copy constructor.

Parameters
value [in] Value to be copied.

Member Function Documentation

int32_t Value::Compare ( const Value & value ) const

Compares with the given Value.

It does not work if the given Value objects does not have the same DataType.

Parameters
value Given value to compare to.
Returns
0 if this Value is equal to the given one; a value less than 0 if this Value is less than the given one; and a value greater than 0 if this Value is greater than the given one.
bool_t Value::Equals ( const Value & value ) const

Compares with the given Value.

It does not work if the given Value objects does not have the same DataType.

Parameters
value Given value to compare to.
Returns
TRUE if this Value is equal to the given one; FALSE otherwise.
bool_t Value::GetBoolean ( ) const

Gets Boolean Value.

This must be a non-NULL Boolean Value.

Returns
The Boolean Value.
DataType Value::GetDataType ( ) const

Gets the DataType.

Value cannot be NULL.

Returns
The DataType.
double64_t Value::GetDouble ( ) const

Gets Double Value.

This must be a non-NULL Double Value.

Returns
The Double Value.
int32_t Value::GetInteger ( ) const

Gets Integer Value.

This must be a non-NULL Integer Value.

Returns
The Integer Value.
int64_t Value::GetLong ( ) const

Gets Long Value.

This must be a non-NULL Long Value.

Returns
The Long Value.
oid_t Value::GetOID ( ) const

Gets OID Value.

This must be an non-NULL OID Value.

Returns
The OID Value.
const std::wstring& Value::GetString ( ) const

Gets String Value.

This must be a non-NULL String Value.

Returns
The String Value.
int64_t Value::GetTimestamp ( ) const

Gets Timestamp Value.

This must be a non-NULL Timestamp Value.

Returns
The Timestamp Value.
bool_t Value::IsNull ( ) const

Gets if this is a NULL Value.

Returns
TRUE if this is a NULL Value, FALSE otherwise.
Value& Value::operator= ( const Value & value )

Assignment operator.

Parameters
value [in] Value to be copied.
Returns
Returns the Value reference.
Value& Value::Set ( Value & value )
inline

Sets the Value.

Parameters
value [in] New value.
Returns
The calling instance.
Value& Value::SetBoolean ( bool_t value )
inline

Sets the Value.

Parameters
value [in] Nex Boolean value.
Returns
The calling instance.
void Value::SetBooleanVoid ( bool_t value )

Sets the Value.

Parameters
value [in] New Boolean value.
Value& Value::SetDouble ( double64_t value )
inline

Sets the Value.

Parameters
value [in] New Double value.
Returns
The calling instance.
void Value::SetDoubleVoid ( double64_t value )

Sets the Value.

Parameters
value [in] New Double value.
Value& Value::SetInteger ( int32_t value )
inline

Sets the Value.

Parameters
value [in] New Integer value.
Returns
The calling instance.
void Value::SetIntegerVoid ( int32_t value )

Sets the Value.

Parameters
value [in] New Integer value.
Value& Value::SetLong ( int64_t value )
inline

Sets the Value.

Parameters
value [in] New Long value.
Returns
The calling instance.
void Value::SetLongVoid ( int64_t value )

Sets the Value.

Parameters
value [in] New Long value.
Value& Value::SetNull ( )
inline

Sets the Value to NULL.

Returns
The calling instance.
Value& Value::SetOID ( oid_t value )
inline

Sets the Value.

Parameters
value [in] New OID Value.
Returns
The calling instance.
void Value::SetOIDVoid ( oid_t value )

Sets the OID Value.

Parameters
value [in] New OID value.
Value& Value::SetString ( const std::wstring & value )
inline

Sets the Value.

Parameters
value [in] New String value.
Returns
The calling instance.
void Value::SetStringVoid ( const std::wstring & value )

Sets the Value.

Parameters
value [in] New String value.
Value& Value::SetTimestamp ( int64_t value )
inline

Sets the Value.

Parameters
value [in] New Timestamp value.
Returns
The calling instance.
Value& Value::SetTimestamp | ( | int32_t | year,
 |  | int32_t | month,
 |  | int32_t | day,
 |  | int32_t | hour,
 |  | int32_t | minutes,
 |  | int32_t | seconds,
 |  | int32_t | millisecs
 | ) |  |
inline

Sets the Value.

Parameters
year | [in] The year (>=1970).
month | [in] The month ([1..12]).
day | [in] The of the month ([1..31]).
hour | [in] The hour ([0..23]).
minutes | [in] The minutes ([0..59]).
seconds | [in] The seconds ([0..59]).
millisecs | [in] The milliseconds ([0..999]).
Returns
The calling instance.
void Value::SetTimestampVoid ( int64_t value )

Sets the Value.

Parameters
value [in] New Timestamp value.
void Value::SetTimestampVoid | ( | int32_t | year,
 |  | int32_t | month,
 |  | int32_t | day,
 |  | int32_t | hour,
 |  | int32_t | minutes,
 |  | int32_t | seconds,
 |  | int32_t | millisecs
 | ) |  |

Sets the Value.

Parameters
year | [in] The year (>=1970).
month | [in] The month ([1..12]).
day | [in] The of the month ([1..31]).
hour | [in] The hour ([0..23]).
minutes | [in] The minutes ([0..59]).
seconds | [in] The seconds ([0..59]).
millisecs | [in] The milliseconds ([0..999]).
void Value::SetVoid ( Value & value )
inline

Sets the Value.

Parameters
value [in] New value.
std::wstring& Value::ToString ( std::wstring & str ) const

Gets a string representation of the Value.

Parameters
str String to be used. It is cleared and set with the string representation of the Value.
Returns
The given string which has been updated.
The documentation for this class was generated from the following file:
  • Value.h


Sparksee: ValueList Class Reference

Public Member Functions | List of all members
ValueList Class Reference
Gdb

Value list. More...

Public Member Functions

int32_t | Count () const
Number of elements in the list.
ValueListIterator * Iterator ()
Gets a new ValueListIterator.
ValueList ()
Constructor.
~ValueList ()
Destructor.
void | Clear ()
Clears the list.
void | Add (Value *value)
Adds a value to the end of the list.
Value * | Get (int32_t index) const
Returns the Value at the specified position in the list.

Detailed Description

Value list.

It stores a Value list.

Use ValueListIterator to access all elements into this collection.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

ValueList::ValueList ( )
inline

Constructor.

This creates an empty list.

Member Function Documentation

void ValueList::Add ( Value * value )

Adds a value to the end of the list.

Parameters
value [in] The value to add
int32_t ValueList::Count ( ) const
inline

Number of elements in the list.

Returns
Number of elements in the list.
Value* ValueList::Get ( int32_t index ) const

Returns the Value at the specified position in the list.

Parameters
index [in] Index of the element to return, starting at 0.
ValueListIterator* ValueList::Iterator ( )

Gets a new ValueListIterator.

Returns
ValueListIterator instance.
The documentation for this class was generated from the following file:
  • Value.h
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: ValueListIterator Class Reference

Public Member Functions | Friends | List of all members
ValueListIterator Class Reference
Gdb

ValueList iterator class. More...

Public Member Functions

~ValueListIterator ()
Destructor.
const Value * Next ()
Moves to the next element.
bool_t HasNext ()
Gets if there are more elements.

Friends

class ValueList

Detailed Description

ValueList iterator class.

Iterator to traverse all the values into a ValueList instance.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

bool_t ValueListIterator::HasNext ( )
inline

Gets if there are more elements.

Returns
TRUE if there are more elements, FALSE otherwise.
const Value* ValueListIterator::Next ( )
inline

Moves to the next element.

Returns
The next element.
The documentation for this class was generated from the following file:
  • Value.h
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: ValueArray Class Reference

Public Member Functions | Private Member Functions | Friends | List of all members
ValueArray Class Reference
Gdb

ValueArray class. More...

Inheritance diagram for ValueArray:
Collaboration diagram for ValueArray:

Public Member Functions

void | Get (int32_t index, Value &value) const throw (sparksee::gdb::WrongArgumentError, sparksee::gdb::AppError)
Get a Value from the array.
void | Set (int32_t index, const Value &value) throw (sparksee::gdb::WrongArgumentError, sparksee::gdb::AppError)
Set a Value to a specific array position.
void | Set (const Value &value) throw (sparksee::gdb::WrongArgumentError, sparksee::gdb::AppError)
Set a Value to the whole array.
void | MakeNull () throw (sparksee::gdb::AppError)
Sets the attribute array to Null.
virtual | ~ValueArray ()
Destructor.
int32_t | Size () const
Returns the array size.
void | GetDouble (std::vector< sparksee::gdb::double64_t > &values) const throw (sparksee::gdb::AppError, sparksee::gdb::UnsupportedOperationError)
Get all the values from this double array.
void | GetDouble (int32_t index, int32_t size, std::vector< sparksee::gdb::double64_t > &values) const throw (sparksee::gdb::WrongArgumentError, sparksee::gdb::UnsupportedOperationError, sparksee::gdb::AppError)
Get a subset of the values from this double array.
void | SetDouble (const std::vector< sparksee::gdb::double64_t > &values) throw (sparksee::gdb::UnsupportedOperationError, sparksee::gdb::AppError)
Set all the values of this double array.
void | SetDouble (int32_t index, const std::vector< sparksee::gdb::double64_t > &values) throw (sparksee::gdb::WrongArgumentError, sparksee::gdb::UnsupportedOperationError, sparksee::gdb::AppError)
Set a subset of the values of this double array.
void | GetInteger (std::vector< sparksee::gdb::int32_t > &values) const throw (sparksee::gdb::AppError, sparksee::gdb::UnsupportedOperationError)
Get all the values from this int array.
void | GetInteger (int32_t index, int32_t size, std::vector< sparksee::gdb::int32_t > &values) const throw (sparksee::gdb::WrongArgumentError, sparksee::gdb::UnsupportedOperationError, sparksee::gdb::AppError)
Get a subset of the values from this int array.
void | SetInteger (const std::vector< sparksee::gdb::int32_t > &values) throw (sparksee::gdb::UnsupportedOperationError, sparksee::gdb::AppError)
Set all the values of this int array.
void | SetInteger (int32_t index, const std::vector< sparksee::gdb::int32_t > &values) throw (sparksee::gdb::WrongArgumentError, sparksee::gdb::UnsupportedOperationError, sparksee::gdb::AppError)
Set a subset of the values of this int array.
void | GetLong (std::vector< sparksee::gdb::int64_t > &values) const throw (sparksee::gdb::AppError, sparksee::gdb::UnsupportedOperationError)
Get all the values from this long array.
void | GetLong (int32_t index, int32_t size, std::vector< sparksee::gdb::int64_t > &values) const throw (sparksee::gdb::WrongArgumentError, sparksee::gdb::UnsupportedOperationError, sparksee::gdb::AppError)
Get a subset of the values from this long array.
void | SetLong (const std::vector< sparksee::gdb::int64_t > &values) throw (sparksee::gdb::UnsupportedOperationError, sparksee::gdb::AppError)
Set all the values of this long array.
void | SetLong (int32_t index, const std::vector< sparksee::gdb::int64_t > &values) throw (sparksee::gdb::WrongArgumentError, sparksee::gdb::UnsupportedOperationError, sparksee::gdb::AppError)
Set a subset of the values of this long array.
void | GetBoolean (std::vector< sparksee::gdb::bool_t > &values) const throw (sparksee::gdb::AppError, sparksee::gdb::UnsupportedOperationError)
Get all the values from this bool array.
void | GetBoolean (int32_t index, int32_t size, std::vector< sparksee::gdb::bool_t > &values) const throw (sparksee::gdb::WrongArgumentError, sparksee::gdb::UnsupportedOperationError, sparksee::gdb::AppError)
Get a subset of the values from this bool array.
void | SetBoolean (const std::vector< sparksee::gdb::bool_t > &values) throw (sparksee::gdb::UnsupportedOperationError, sparksee::gdb::AppError)
Set all the values of this bool array.
void | SetBoolean (int32_t index, const std::vector< sparksee::gdb::bool_t > &values) throw (sparksee::gdb::WrongArgumentError, sparksee::gdb::UnsupportedOperationError, sparksee::gdb::AppError)
Set a subset of the values of this bool array.
void | GetTimestamp (std::vector< sparksee::gdb::int64_t > &values) const throw (sparksee::gdb::AppError, sparksee::gdb::UnsupportedOperationError)
Get all the values from this timestamp array.
void | GetTimestamp (int32_t index, int32_t size, std::vector< sparksee::gdb::int64_t > &values) const throw (sparksee::gdb::WrongArgumentError, sparksee::gdb::UnsupportedOperationError, sparksee::gdb::AppError)
Get a subset of the values from this timestamp array.
void | SetTimestamp (const std::vector< sparksee::gdb::int64_t > &values) throw (sparksee::gdb::UnsupportedOperationError, sparksee::gdb::AppError)
Set all the values of this timestamp array.
void | SetTimestamp (int32_t index, const std::vector< sparksee::gdb::int64_t > &values) throw (sparksee::gdb::WrongArgumentError, sparksee::gdb::UnsupportedOperationError, sparksee::gdb::AppError)
Set a subset of the values of this timestamp array.
void | GetOID (std::vector< sparksee::gdb::oid_t > &values) const throw (sparksee::gdb::AppError, sparksee::gdb::UnsupportedOperationError)
Get all the values from this oid array.
void | GetOID (int32_t index, int32_t size, std::vector< sparksee::gdb::oid_t > &values) const throw (sparksee::gdb::WrongArgumentError, sparksee::gdb::UnsupportedOperationError, sparksee::gdb::AppError)
Get a subset of the values from this oid array.
void | SetOID (const std::vector< sparksee::gdb::oid_t > &values) throw (sparksee::gdb::UnsupportedOperationError, sparksee::gdb::AppError)
Set all the values of this oid array.
void | SetOID (int32_t index, const std::vector< sparksee::gdb::oid_t > &values) throw (sparksee::gdb::WrongArgumentError, sparksee::gdb::UnsupportedOperationError, sparksee::gdb::AppError)
Set a subset of the values of this oid array.

Private Member Functions

sparksee_core::GraphValueArray * | GetHandler ()
Gets the handled reference.
const
sparksee_core::GraphValueArray * 		GetHandler () const
Gets the handled reference.
void | SetHandler (sparksee_core::GraphValueArray *h)
Sets the handled reference.
void | FreeHandler ()
Frees (deletes) the handled reference.

Friends

class Graph

Detailed Description

ValueArray class.

It allows for getting and setting ValueArray attribute values.

It is very important to close the ValueArray once no more get or set operations will be performed.

Creation of a new ValueArray: (i) Set all the ValueArray elements using Graph::SetAttributeArray (ii) perform as many get/set operations as you need to the ValueArray instance. Lastly, (iii) Close the ValueArray

Use of an existing ValueArray: (i) Get a ValueArray instance using Graph::GetAttributeArray (ii) perform as many get/set operations as you need to the ValueArray instance. Lastly, (iii) Close the ValueArray

Check out the 'Attributes and values' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

void ValueArray::Get | ( | int32_t | index,
 |  | Value & | value
 | ) |  | const throw (sparksee::gdb::WrongArgumentError, sparksee::gdb::AppError)

Get a Value from the array.

Parameters
index | [in] Position of the element to get [0..N-1]
value | [out] Value to get the array element
Exceptions
WrongArgumentError | If the index is out of range or the Value not valid
AppError | If the ValueArray is not available
void ValueArray::GetBoolean ( std::vector< sparksee::gdb::bool_t > & values ) const throw (sparksee::gdb::AppError, sparksee::gdb::UnsupportedOperationError)

Get all the values from this bool array.

Parameters
values [out] All the values will be returned here
Exceptions
AppError | If the ValueArray is not available
UnsupportedOperationError | If array DataType is not bool
void ValueArray::GetBoolean | ( | int32_t | index,
 |  | int32_t | size,
 |  | std::vector< sparksee::gdb::bool_t > & | values
 | ) |  | const throw (sparksee::gdb::WrongArgumentError, sparksee::gdb::UnsupportedOperationError, sparksee::gdb::AppError)

Get a subset of the values from this bool array.

Parameters
index | [in] Position of the first element to get [0..N-1]
size | [in] Number of elements to get [1..N]
values | [out] All the requested values will be returned here
Exceptions
WrongArgumentError | If the index or size is out of range
UnsupportedOperationError | If array DataType is not bool
AppError | If the ValueArray is not available
void ValueArray::GetDouble ( std::vector< sparksee::gdb::double64_t > & values ) const throw (sparksee::gdb::AppError, sparksee::gdb::UnsupportedOperationError)

Get all the values from this double array.

Parameters
values [out] All the values will be returned here
Exceptions
AppError | If the ValueArray is not available
UnsupportedOperationError | If array DataType is not Double
void ValueArray::GetDouble | ( | int32_t | index,
 |  | int32_t | size,
 |  | std::vector< sparksee::gdb::double64_t > & | values
 | ) |  | const throw (sparksee::gdb::WrongArgumentError, sparksee::gdb::UnsupportedOperationError, sparksee::gdb::AppError)

Get a subset of the values from this double array.

Parameters
index | [in] Position of the first element to get [0..N-1]
size | [in] Number of elements to get [1..N]
values | [out] All the requested values will be returned here
Exceptions
WrongArgumentError | If the index or size is out of range
UnsupportedOperationError | If array DataType is not Double
AppError | If the ValueArray is not available
void ValueArray::GetInteger ( std::vector< sparksee::gdb::int32_t > & values ) const throw (sparksee::gdb::AppError, sparksee::gdb::UnsupportedOperationError)

Get all the values from this int array.

Parameters
values [out] All the values will be returned here
Exceptions
AppError | If the ValueArray is not available
UnsupportedOperationError | If array DataType is not int
void ValueArray::GetInteger | ( | int32_t | index,
 |  | int32_t | size,
 |  | std::vector< sparksee::gdb::int32_t > & | values
 | ) |  | const throw (sparksee::gdb::WrongArgumentError, sparksee::gdb::UnsupportedOperationError, sparksee::gdb::AppError)

Get a subset of the values from this int array.

Parameters
index | [in] Position of the first element to get [0..N-1]
size | [in] Number of elements to get [1..N]
values | [out] All the requested values will be returned here
Exceptions
WrongArgumentError | If the index or size is out of range
UnsupportedOperationError | If array DataType is not int
AppError | If the ValueArray is not available
void ValueArray::GetLong ( std::vector< sparksee::gdb::int64_t > & values ) const throw (sparksee::gdb::AppError, sparksee::gdb::UnsupportedOperationError)

Get all the values from this long array.

Parameters
values [out] All the values will be returned here
Exceptions
AppError | If the ValueArray is not available
UnsupportedOperationError | If array DataType is not long
void ValueArray::GetLong | ( | int32_t | index,
 |  | int32_t | size,
 |  | std::vector< sparksee::gdb::int64_t > & | values
 | ) |  | const throw (sparksee::gdb::WrongArgumentError, sparksee::gdb::UnsupportedOperationError, sparksee::gdb::AppError)

Get a subset of the values from this long array.

Parameters
index | [in] Position of the first element to get [0..N-1]
size | [in] Number of elements to get [1..N]
values | [out] All the requested values will be returned here
Exceptions
WrongArgumentError | If the index or size is out of range
UnsupportedOperationError | If array DataType is not long
AppError | If the ValueArray is not available
void ValueArray::GetOID ( std::vector< sparksee::gdb::oid_t > & values ) const throw (sparksee::gdb::AppError, sparksee::gdb::UnsupportedOperationError)

Get all the values from this oid array.

Parameters
values [out] All the values will be returned here
Exceptions
AppError | If the ValueArray is not available
UnsupportedOperationError | If array DataType is not oid
void ValueArray::GetOID | ( | int32_t | index,
 |  | int32_t | size,
 |  | std::vector< sparksee::gdb::oid_t > & | values
 | ) |  | const throw (sparksee::gdb::WrongArgumentError, sparksee::gdb::UnsupportedOperationError, sparksee::gdb::AppError)

Get a subset of the values from this oid array.

Parameters
index | [in] Position of the first element to get [0..N-1]
size | [in] Number of elements to get [1..N]
values | [out] All the requested values will be returned here
Exceptions
WrongArgumentError | If the index or size is out of range
UnsupportedOperationError | If array DataType is not oid
AppError | If the ValueArray is not available
void ValueArray::GetTimestamp ( std::vector< sparksee::gdb::int64_t > & values ) const throw (sparksee::gdb::AppError, sparksee::gdb::UnsupportedOperationError)

Get all the values from this timestamp array.

Parameters
values [out] All the values will be returned here
Exceptions
AppError | If the ValueArray is not available
UnsupportedOperationError | If array DataType is not timestamp
void ValueArray::GetTimestamp | ( | int32_t | index,
 |  | int32_t | size,
 |  | std::vector< sparksee::gdb::int64_t > & | values
 | ) |  | const throw (sparksee::gdb::WrongArgumentError, sparksee::gdb::UnsupportedOperationError, sparksee::gdb::AppError)

Get a subset of the values from this timestamp array.

Parameters
index | [in] Position of the first element to get [0..N-1]
size | [in] Number of elements to get [1..N]
values | [out] All the requested values will be returned here
Exceptions
WrongArgumentError | If the index or size is out of range
UnsupportedOperationError | If array DataType is not timestamp
AppError | If the ValueArray is not available
void ValueArray::MakeNull ( ) throw (sparksee::gdb::AppError)

Sets the attribute array to Null.

The ValueArray can not be used after this call.

void ValueArray::Set | ( | int32_t | index,
 |  | const Value & | value
 | ) |  | throw (sparksee::gdb::WrongArgumentError, sparksee::gdb::AppError)

Set a Value to a specific array position.

Parameters
index | [in] Position of the element to set [0..N-1]
value | [in] Value to set in the array element
Exceptions
WrongArgumentError | If the index is out of range or the Value not valid
AppError | If the ValueArray is not available
void ValueArray::Set ( const Value & value ) throw (sparksee::gdb::WrongArgumentError, sparksee::gdb::AppError)

Set a Value to the whole array.

Parameters
value [in] Value to set in all the array elements
Exceptions
WrongArgumentError | If the Value is not valid
AppError | If the ValueArray is not available
void ValueArray::SetBoolean ( const std::vector< sparksee::gdb::bool_t > & values ) throw (sparksee::gdb::UnsupportedOperationError, sparksee::gdb::AppError)

Set all the values of this bool array.

Parameters
values [in] All the values to set
Exceptions
AppError | If the ValueArray is not available
UnsupportedOperationError | If array DataType is not bool
void ValueArray::SetBoolean | ( | int32_t | index,
 |  | const std::vector< sparksee::gdb::bool_t > & | values
 | ) |  | throw (sparksee::gdb::WrongArgumentError, sparksee::gdb::UnsupportedOperationError, sparksee::gdb::AppError)

Set a subset of the values of this bool array.

Parameters
index | [in] Position of the first element to set [0..N-1]
values | [in] All the values to set
Exceptions
WrongArgumentError | If the index or size is out of range
UnsupportedOperationError | If array DataType is not bool
AppError | If the ValueArray is not available
void ValueArray::SetDouble ( const std::vector< sparksee::gdb::double64_t > & values ) throw (sparksee::gdb::UnsupportedOperationError, sparksee::gdb::AppError)

Set all the values of this double array.

Parameters
values [in] All the values to set
Exceptions
AppError | If the ValueArray is not available
UnsupportedOperationError | If array DataType is not Double
void ValueArray::SetDouble | ( | int32_t | index,
 |  | const std::vector< sparksee::gdb::double64_t > & | values
 | ) |  | throw (sparksee::gdb::WrongArgumentError, sparksee::gdb::UnsupportedOperationError, sparksee::gdb::AppError)

Set a subset of the values of this double array.

Parameters
index | [in] Position of the first element to set [0..N-1]
values | [in] All the values to set
Exceptions
WrongArgumentError | If the index or size is out of range
UnsupportedOperationError | If array DataType is not Double
AppError | If the ValueArray is not available
void ValueArray::SetInteger ( const std::vector< sparksee::gdb::int32_t > & values ) throw (sparksee::gdb::UnsupportedOperationError, sparksee::gdb::AppError)

Set all the values of this int array.

Parameters
values [in] All the values to set
Exceptions
AppError | If the ValueArray is not available
UnsupportedOperationError | If array DataType is not int
void ValueArray::SetInteger | ( | int32_t | index,
 |  | const std::vector< sparksee::gdb::int32_t > & | values
 | ) |  | throw (sparksee::gdb::WrongArgumentError, sparksee::gdb::UnsupportedOperationError, sparksee::gdb::AppError)

Set a subset of the values of this int array.

Parameters
index | [in] Position of the first element to set [0..N-1]
values | [in] All the values to set
Exceptions
WrongArgumentError | If the index or size is out of range
UnsupportedOperationError | If array DataType is not int
AppError | If the ValueArray is not available
void ValueArray::SetLong ( const std::vector< sparksee::gdb::int64_t > & values ) throw (sparksee::gdb::UnsupportedOperationError, sparksee::gdb::AppError)

Set all the values of this long array.

Parameters
values [in] All the values to set
Exceptions
AppError | If the ValueArray is not available
UnsupportedOperationError | If array DataType is not long
void ValueArray::SetLong | ( | int32_t | index,
 |  | const std::vector< sparksee::gdb::int64_t > & | values
 | ) |  | throw (sparksee::gdb::WrongArgumentError, sparksee::gdb::UnsupportedOperationError, sparksee::gdb::AppError)

Set a subset of the values of this long array.

Parameters
index | [in] Position of the first element to set [0..N-1]
values | [in] All the values to set
Exceptions
WrongArgumentError | If the index or size is out of range
UnsupportedOperationError | If array DataType is not long
AppError | If the ValueArray is not available
void ValueArray::SetOID ( const std::vector< sparksee::gdb::oid_t > & values ) throw (sparksee::gdb::UnsupportedOperationError, sparksee::gdb::AppError)

Set all the values of this oid array.

Parameters
values [in] All the values to set
Exceptions
AppError | If the ValueArray is not available
UnsupportedOperationError | If array DataType is not oid
void ValueArray::SetOID | ( | int32_t | index,
 |  | const std::vector< sparksee::gdb::oid_t > & | values
 | ) |  | throw (sparksee::gdb::WrongArgumentError, sparksee::gdb::UnsupportedOperationError, sparksee::gdb::AppError)

Set a subset of the values of this oid array.

Parameters
index | [in] Position of the first element to set [0..N-1]
values | [in] All the values to set
Exceptions
WrongArgumentError | If the index or size is out of range
UnsupportedOperationError | If array DataType is not oid
AppError | If the ValueArray is not available
void ValueArray::SetTimestamp ( const std::vector< sparksee::gdb::int64_t > & values ) throw (sparksee::gdb::UnsupportedOperationError, sparksee::gdb::AppError)

Set all the values of this timestamp array.

Parameters
values [in] All the values to set
Exceptions
AppError | If the ValueArray is not available
UnsupportedOperationError | If array DataType is not timestamp
void ValueArray::SetTimestamp | ( | int32_t | index,
 |  | const std::vector< sparksee::gdb::int64_t > & | values
 | ) |  | throw (sparksee::gdb::WrongArgumentError, sparksee::gdb::UnsupportedOperationError, sparksee::gdb::AppError)

Set a subset of the values of this timestamp array.

Parameters
index | [in] Position of the first element to set [0..N-1]
values | [in] All the values to set
Exceptions
WrongArgumentError | If the index or size is out of range
UnsupportedOperationError | If array DataType is not timestamp
AppError | If the ValueArray is not available
The documentation for this class was generated from the following file:
  • ValueArray.h
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Values Class Reference

Public Member Functions | Private Member Functions | Friends | List of all members
Values Class Reference
Gdb

Value set class. More...

Inheritance diagram for Values:
Collaboration diagram for Values:

Public Member Functions

virtual | ~Values ()
Destructor.
int64_t Count ()
Gets the number of elements into the collection.
ValuesIterator * | Iterator (Order order)
Gets a ValuesIterator.

Private Member Functions

sparksee_core::Values * | GetHandler ()
Gets the handled reference.
const sparksee_core::Values * | GetHandler () const
Gets the handled reference.
void | SetHandler (sparksee_core::Values *h)
Sets the handled reference.
void | FreeHandler ()
Frees (deletes) the handled reference.
bool_t | IsNull () const
Gets if the handler is NULL.

Friends

class | Graph
class | ValuesIterator

Detailed Description

Value set class.

This is a set of Value instances, that is there is no duplicated elements.

Use a ValuesIterator to traverse all the elements into the set.

When the Values instance is closed, it closes all existing and non-closed ValuesIterator instances too.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

int64_t Values::Count ( )

Gets the number of elements into the collection.

Returns
The number of elements into the collection.
ValuesIterator* Values::Iterator ( Order order )

Gets a ValuesIterator.

Returns
ValuesIterator instance.
Parameters
order [in] Ascending or descending order.
The documentation for this class was generated from the following file:
  • Values.h
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: ValuesIterator Class Reference

Public Member Functions | Private Member Functions | Friends | List of all members
ValuesIterator Class Reference
Gdb

Values iterator class. More...

Inheritance diagram for ValuesIterator:
Collaboration diagram for ValuesIterator:

Public Member Functions

virtual ~ValuesIterator ()
Destructor.
bool_t HasNext ()
Gets if there are more elements to traverse.
Value * Next ()
Gets the next element to traverse.

Private Member Functions

sparksee_core::Values * | GetHandler ()
Gets the handled reference.
const sparksee_core::Values * | GetHandler () const
Gets the handled reference.
void | SetHandler (sparksee_core::Values *h)
Sets the handled reference.
void | FreeHandler ()
Frees (deletes) the handled reference.
bool_t | IsNull () const
Gets if the handler is NULL.

Friends

class Values

Detailed Description

Values iterator class.

It allows for traversing all the elements into a Values instance.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

bool_t ValuesIterator::HasNext ( )

Gets if there are more elements to traverse.

Returns
TRUE if there are more elements to traverse, FALSE otherwise.
Value* ValuesIterator::Next ( )

Gets the next element to traverse.

Returns
The next element.
The documentation for this class was generated from the following file:
  • ValuesIterator.h
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Io

Files | Classes | Functions
Io
Collaboration diagram for Io:

Files

file | TypeLoader.h
It contains the definition of TypeLoader classes.
file | CSVReader.h
It contains the definition of CSVReader class.
file | CSVWriter.h
It contains the definition of CSVWriter class.
file | EdgeTypeExporter.h
It contains the definition of EdgeTypeExporter class.
file | EdgeTypeLoader.h
It contains the definition of EdgeTypeLoader class.
file | NodeTypeExporter.h
It contains the definition of NodeTypeExporter class.
file | NodeTypeLoader.h
It contains the definition of NodeTypeLoader class.
file | RowReader.h
It contains the definition of RowReader interface.
file | RowWriter.h
It contains the definition of RowWriter interface.
file | TypeExporter.h
It contains the definition of TypeExporter classes.
file | TypeLoader.h
It contains the definition of TypeLoader classes.

Classes

class | BulkLoader
Base TypeLoader class. More...
class | CSVReader
CSVReader interface. More...
class | CSVWriter
CSVWriter interface. More...
class | EdgeTypeExporter
EdgeTypeExporter class. More...
class | EdgeTypeLoader
EdgeTypeLoader class. More...
class | NodeTypeExporter
NodeTypeExporter class. More...
class | NodeTypeLoader
NodeTypeLoader class. More...
class | RowReader
RowReader interface. More...
class | RowWriter
RowWriter interface. More...
class | TypeExporterEvent
Provides information about the progress of an TypeExproter instance. More...
class | TypeExporterListener
Interface to be implemented to receive TypeExporterEvent events from a TypeExporter. More...
class | TypeExporter
Base TypeExporter class. More...
class | TypeLoaderEvent
Provides information about the progress of a TypeLoader instance. More...
class | TypeLoaderListener
Interface to be implemented to receive TypeLoaderEvent events from a TypeLoader. More...
class | TypeLoader
Base TypeLoader class. More...

Functions

std::wostream & | operator<< (std::wostream &wostrm, const TypeExporterEvent &ev)
Easy STL printing operator redefinition.
std::wostream & | operator<< (std::wostream &wostrm, const TypeLoaderEvent &ev)
Output Stream TypeLoaderEvent operator definition.
sparksee::gdb::type_t | TypeLoaderEvent::GetTypeId () const
Gets the type identifier.
sparksee::gdb::int64_t | TypeLoaderEvent::GetCount () const
Gets the current number of objects created.
sparksee::gdb::int32_t | TypeLoaderEvent::GetPhase () const
Gets the current phase.
sparksee::gdb::int32_t | TypeLoaderEvent::GetTotalPhases () const
Gets the total number of phases.
sparksee::gdb::int32_t | TypeLoaderEvent::GetPartition () const
Gets the current partition.
sparksee::gdb::int32_t | TypeLoaderEvent::GetTotalPartitions () const
Gets the total number of partitions.
sparksee::gdb::int32_t | TypeLoaderEvent::GetTotalPartitionSteps () const
Gets the total number of steps in the current partition.
sparksee::gdb::bool_t | TypeLoaderEvent::IsLast () const
Gets if this is the last event or not.

Detailed Description

Function Documentation

sparksee::gdb::int64_t TypeLoaderEvent::GetCount ( ) const
inline

Gets the current number of objects created.

Returns
The current number of objects created.
sparksee::gdb::int32_t TypeLoaderEvent::GetPartition ( ) const
inline

Gets the current partition.

Returns
The current partition.
sparksee::gdb::int32_t TypeLoaderEvent::GetPhase ( ) const
inline

Gets the current phase.

Returns
The current phase.
sparksee::gdb::int32_t TypeLoaderEvent::GetTotalPartitions ( ) const
inline

Gets the total number of partitions.

Returns
The total number of partitions.
sparksee::gdb::int32_t TypeLoaderEvent::GetTotalPartitionSteps ( ) const
inline

Gets the total number of steps in the current partition.

Returns
The total number steps in the current partition.
sparksee::gdb::int32_t TypeLoaderEvent::GetTotalPhases ( ) const
inline

Gets the total number of phases.

Returns
The total number of phases.
sparksee::gdb::type_t TypeLoaderEvent::GetTypeId ( ) const
inline

Gets the type identifier.

Returns
The type identifier.
sparksee::gdb::bool_t TypeLoaderEvent::IsLast ( ) const
inline

Gets if this is the last event or not.

Returns
TRUE if this is the last event, FALSE otherwise.
std::wostream& operator<< | ( | std::wostream & | wostrm,
 |  | const TypeLoaderEvent & | ev
 | ) |  |

Output Stream TypeLoaderEvent operator definition.

Parameters
wostrm | The stream to print to
ev | The TypeLoaderEvent to print
Returns
A reference to the stream
Generated on Thu Feb 24 2022 12:56:05 for Sparksee by doxygen 1.8.2


Sparksee: BulkLoader Class Reference

Public Member Functions | List of all members
BulkLoader Class Reference
Io

Base TypeLoader class. More...

Inheritance diagram for BulkLoader:
Collaboration diagram for BulkLoader:

Public Member Functions

void | SetLogError (const std::wstring &path) throw (sparksee::gdb::IOException)
Sets a log error file.
virtual | ~BulkLoader ()
Destructor.
virtual void | Run () throw (sparksee::gdb::IOException, sparksee::gdb::Error)
Run the loader.
void | SetFilename (const std::wstring &filename)
Sets the input data source.
void | SetLocale (const std::wstring &localeStr)
Sets the locale that will be used to read the data.
void | SetType (sparksee::gdb::type_t type)
Sets the type to be loaded.
void | SetAttributes (sparksee::gdb::AttributeList &attrs)
Sets the list of Attributes.
void | SetAttributePositions (sparksee::gdb::Int32List &attrsPos)
Sets the list of attribute positions.
void | SetTimestampFormat (const std::wstring &timestampFormat)
Sets a specific timestamp format.

Detailed Description

Base TypeLoader class.

Base class to load a node or edge type from a graph using a RowReader.

TypeLoaderListener can be registered to receive information about the progress of the load process by means of TypeLoaderEvent. The default frequency of notification to listeners is 100000.

Check out the 'Data import' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

void BulkLoader::SetAttributePositions ( sparksee::gdb::Int32List & attrsPos )

Sets the list of attribute positions.

Parameters
attrsPos [in] Attribute positions (column index >=0).
void BulkLoader::SetAttributes ( sparksee::gdb::AttributeList & attrs )

Sets the list of Attributes.

Parameters
attrs [in] Attribute identifiers to be loaded
void BulkLoader::SetFilename ( const std::wstring & filename )

Sets the input data source.

Parameters
rr [in] Input RowReader.
void BulkLoader::SetLocale ( const std::wstring & localeStr )

Sets the locale that will be used to read the data.

It should match the locale used in the rowreader.

Parameters
localeStr [in] The locale string for the read data. See CSVReader.
void BulkLoader::SetLogError ( const std::wstring & path ) throw (sparksee::gdb::IOException)

Sets a log error file.

By default errors are thrown as a exception and the load process ends. If a log file is set, errors are logged there and the load process does not stop.

Parameters
path [in] The path to the error log file.
Exceptions
IOException If bad things happen opening the file.
void BulkLoader::SetTimestampFormat ( const std::wstring & timestampFormat )

Sets a specific timestamp format.

Parameters
timestampFormat [in] A string with the timestamp format definition.
void BulkLoader::SetType ( sparksee::gdb::type_t type )

Sets the type to be loaded.

Parameters
type [in] Type identifier.
The documentation for this class was generated from the following file:
  • BulkLoader.h
Generated on Thu Feb 24 2022 12:56:05 for Sparksee by doxygen 1.8.2


Sparksee: CSVReader Class Reference

Public Member Functions | List of all members
CSVReader Class Reference
Io

CSVReader interface. More...

Inheritance diagram for CSVReader:
Collaboration diagram for CSVReader:

Public Member Functions

CSVReader ()
Constructs CSVReader.
void | SetSeparator (const std::wstring &sep) throw (sparksee::gdb::Error)
Sets the character used to separate fields in the file.
void | SetQuotes (const std::wstring &quotes) throw (sparksee::gdb::Error)
Sets the character used to quote fields.
void | SetMultilines (sparksee::gdb::int32_t numExtralines)
Allows the use of fields with more than one line.
void | SetSingleLine ()
Only allows single line fields.
void | SetStartLine (sparksee::gdb::int32_t startLine)
Sets the number of lines to be skiped from the beginning.
void | SetNumLines (sparksee::gdb::int32_t numLines)
Used to limit the number of lines that will be read.
void | SetLocale (const std::wstring &localeStr)
Sets the locale that will be used to read the file.
void | Open (const std::wstring &filePath) throw (sparksee::gdb::IOException)
Opens the source file path.
sparksee::gdb::bool_t | Reset () throw (sparksee::gdb::IOException)
Moves the reader to the beginning.
virtual sparksee::gdb::bool_t | Read (sparksee::gdb::StringList &row) throw (sparksee::gdb::IOException)
Reads the next row as a string array.
sparksee::gdb::int32_t | GetRow () throw (sparksee::gdb::IOException)
The row number for the current row.
void | Close () throw (sparksee::gdb::IOException)
Closes the reader.
virtual | ~CSVReader ()
Destructor.

Detailed Description

CSVReader interface.

A very simple CSV reader.

It works as any other RowReader, but open must be called once before the first read operation.

Using the format RFC 4180.
Except: leading and trailing spaces, adjacent to CSV separator character, are trimmed.

You can use your own separators and quote characters. By default the separator is the comma (,) and the quote character is the double quotes (").

Fields with multiple lines can be allowed (and the maximum lines specified), but the default is a single line.

The locale string can be used to set the language, country and the file encoding. The format must be "[language_territory][.codeset]". But only the file encoding is being used in the current version.

The languages supported are: "en_US", "es_ES" and "ca_ES".
The file encodings supported are: "utf8" and "iso88591".

For example:

To don't change the default locales, use an empty string: "".
To read a file in utf8 with the default language settings use ".utf8".
To read a file in iso88591 with English language use: "en_US.iso88591".

Check out the 'Data import' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

void CSVReader::Close ( ) throw (sparksee::gdb::IOException)
virtual

Closes the reader.

Exceptions
IOException If the close fails.

Implements RowReader.

sparksee::gdb::int32_t CSVReader::GetRow ( ) throw (sparksee::gdb::IOException)
virtual

The row number for the current row.

Returns
The current row number; 0 if there is no current row.
Exceptions
IOException If it fails.

Implements RowReader.

void CSVReader::Open ( const std::wstring & filePath ) throw (sparksee::gdb::IOException)

Opens the source file path.

File can be optionally compressed in GZIP format.

Parameters
filePath [in] CSV file path.
Exceptions
IOException If bad things happen opening the file.
virtual sparksee::gdb::bool_t CSVReader::Read ( sparksee::gdb::StringList & row ) throw (sparksee::gdb::IOException)
virtual

Reads the next row as a string array.

Parameters
row [out] A string list with each comma-separated element as a separate entry.
Returns
Returns true if a row had been read or false otherwise.
Exceptions
IOException If bad things happen during the read.

Implements RowReader.

sparksee::gdb::bool_t CSVReader::Reset ( ) throw (sparksee::gdb::IOException)
virtual

Moves the reader to the beginning.

Restarts the reader.

Returns
true if the reader can be restarted, false otherwise.
Exceptions
IOException If bad things happen during the restart.

Implements RowReader.

void CSVReader::SetLocale ( const std::wstring & localeStr )

Sets the locale that will be used to read the file.

Parameters
localeStr [in] The locale string for the file encoding.
void CSVReader::SetMultilines ( sparksee::gdb::int32_t numExtralines )

Allows the use of fields with more than one line.

Parameters
numExtralines [in] Maximum number of extra lines for each column (0==unlimited, N==N+1 total rows).
void CSVReader::SetNumLines ( sparksee::gdb::int32_t numLines )

Used to limit the number of lines that will be read.

Parameters
numLines [in] The maximum number of lines to read (0 == unlimited)
void CSVReader::SetQuotes ( const std::wstring & quotes ) throw (sparksee::gdb::Error)

Sets the character used to quote fields.

Parameters
quotes [in] Quote character.
void CSVReader::SetSeparator ( const std::wstring & sep ) throw (sparksee::gdb::Error)

Sets the character used to separate fields in the file.

Parameters
sep [in] Separator character.
void CSVReader::SetStartLine ( sparksee::gdb::int32_t startLine )

Sets the number of lines to be skiped from the beginning.

Parameters
startLine [in] The line number to skip for start reading
The documentation for this class was generated from the following file:
  • CSVReader.h


Sparksee: CSVWriter Class Reference

Public Member Functions | List of all members
CSVWriter Class Reference
Io

CSVWriter interface. More...

Inheritance diagram for CSVWriter:
Collaboration diagram for CSVWriter:

Public Member Functions

CSVWriter ()
Creates a new instance.
void | SetSeparator (const std::wstring &sep) throw (sparksee::gdb::Error)
Sets the character used to separate fields in the file.
void | SetQuotes (const std::wstring &quotes) throw (sparksee::gdb::Error)
Sets the character used to quote fields.
void | SetAutoQuotes (sparksee::gdb::bool_t autoquotes)
Sets on/off the automatic quote mode.
void | SetForcedQuotes (sparksee::gdb::BooleanList &forcequotes)
Disables the automatic quote mode and forces to be quoted those positions set to TRUE in the given vector.
void | SetLocale (const std::wstring &localeStr)
Sets the locale that will be used to write the file.
void | Open (const std::wstring &f) throw (sparksee::gdb::IOException)
Opens the output file path.
void | Write (sparksee::gdb::StringList &row) throw (sparksee::gdb::IOException, sparksee::gdb::Error)
Writes the next row.
void | Close () throw (sparksee::gdb::IOException, sparksee::gdb::Error)
Closes the writer.
virtual | ~CSVWriter ()
Destructor.

Detailed Description

CSVWriter interface.

A very simple CSV writer implementing RowWriter.

It works as any other RowWriter, but open must be called once before the first write operation.

It uses the format RFC 4180: http://tools.ietf.org/html/rfc4180

You can use your own separators and quote characters. By default the separator is the comma (,) and the quote character is the double quotes (") and autoquote is enabled.

See the CSVReader locale documentation or the SPARKSEE User Manual.

Check out the 'Data export' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

void CSVWriter::Close ( ) throw (sparksee::gdb::IOException, sparksee::gdb::Error)
virtual

Closes the writer.

Exceptions
IOException If the close fails.

Implements RowWriter.

void CSVWriter::Open ( const std::wstring & f ) throw (sparksee::gdb::IOException)

Opens the output file path.

Parameters
f [in] Output file path.
Exceptions
IOException If bad things happen opening the file.
void CSVWriter::SetAutoQuotes ( sparksee::gdb::bool_t autoquotes )

Sets on/off the automatic quote mode.

If there are forced quotes, setting autoquotes on will clear them. If the autoquotes is set to off and no forced quotes are provided, there will not be any quote.

Parameters
autoquotes [in] If TRUE it enables the automatic quote mode, if FALSE it disables it.
void CSVWriter::SetForcedQuotes ( sparksee::gdb::BooleanList & forcequotes )

Disables the automatic quote mode and forces to be quoted those positions set to TRUE in the given vector.

Parameters
forcequotes [in] A booleanList with the position for each column that must be quoted set to true.
void CSVWriter::SetLocale ( const std::wstring & localeStr )

Sets the locale that will be used to write the file.

Parameters
localeStr [in] The locale string for the file encoding.
void CSVWriter::SetQuotes ( const std::wstring & quotes ) throw (sparksee::gdb::Error)

Sets the character used to quote fields.

Parameters
quotes [in] Quote character.
void CSVWriter::SetSeparator ( const std::wstring & sep ) throw (sparksee::gdb::Error)

Sets the character used to separate fields in the file.

Parameters
sep [in] Separator character.
void CSVWriter::Write ( sparksee::gdb::StringList & row ) throw (sparksee::gdb::IOException, sparksee::gdb::Error)
virtual

Writes the next row.

Parameters
row [in] Row of data.
Exceptions
IOException If bad things happen during the write.

Implements RowWriter.

The documentation for this class was generated from the following file:
  • CSVWriter.h


Sparksee: EdgeTypeExporter Class Reference

Public Member Functions | Protected Member Functions | List of all members
EdgeTypeExporter Class Reference
Io

EdgeTypeExporter class. More...

Inheritance diagram for EdgeTypeExporter:
Collaboration diagram for EdgeTypeExporter:

Public Member Functions

EdgeTypeExporter ()
Creates a new instance.
EdgeTypeExporter (RowWriter &rowWriter, sparksee::gdb::Graph &graph, sparksee::gdb::type_t type, sparksee::gdb::AttributeList &attrs, sparksee::gdb::int32_t hPos, sparksee::gdb::int32_t tPos, sparksee::gdb::attr_t hAttr, sparksee::gdb::attr_t tAttr)
Creates a new instance.
virtual | ~EdgeTypeExporter ()
Destructor.
void | Run () throw (sparksee::gdb::IOException, sparksee::gdb::Error)
See the TypeExporter class Run method.
void | SetHeadAttribute (sparksee::gdb::attr_t attr)
Sets the attribute that will be used to get the value to be dumped for the head of the edge.
void | SetHeadPosition (sparksee::gdb::int32_t pos)
Sets the position (index column) of the head attribute in the exported data.
void | SetTailAttribute (sparksee::gdb::attr_t attr)
Sets the attribute that will be used to get the value to be dumped for the tail of the edge.
void | SetTailPosition (sparksee::gdb::int32_t pos)
Sets the position (index column) of the tail attribute in the exported data.
void | Register (TypeExporterListener &tel)
Registers a new listener.
void | SetRowWriter (RowWriter &rw)
Sets the output data destination.
void | SetGraph (sparksee::gdb::Graph &graph)
Sets the graph that will be exported.
void | SetType (sparksee::gdb::type_t type)
Sets the type to be exported.
void | SetAttributes (sparksee::gdb::AttributeList &attrs)
Sets the list of Attributes.
void | SetFrequency (sparksee::gdb::int32_t freq)
Sets the frequency of listener notification.
void | SetHeader (sparksee::gdb::bool_t header)
Sets the presence of a header row.

Protected Member Functions

sparksee::gdb::bool_t CanRun ()
Checks that all the required settings are ready to run.
void | NotifyListeners (const TypeExporterEvent &ev)
Notifies progress to all registered listeners.
void | RunProcess () throw (sparksee::gdb::IOException, sparksee::gdb::Error)
Runs export process.

Detailed Description

EdgeTypeExporter class.

Specific TypeExporter implementation for edge types.

Check out the 'Data export' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

EdgeTypeExporter::EdgeTypeExporter | ( | RowWriter & | rowWriter,
 |  | sparksee::gdb::Graph & | graph,
 |  | sparksee::gdb::type_t | type,
 |  | sparksee::gdb::AttributeList & | attrs,
 |  | sparksee::gdb::int32_t | hPos,
 |  | sparksee::gdb::int32_t | tPos,
 |  | sparksee::gdb::attr_t | hAttr,
 |  | sparksee::gdb::attr_t | tAttr
 | ) |  |
inline

Creates a new instance.

Parameters
rowWriter | [in] Output RowWriter.
graph | [in] Graph.
type | [in] Type identifier.
attrs | [in] Attribute identifiers to be exported.
hPos | [in] The position (index column) for the head value.
tPos | [in] The position (index column) for the tail value.
hAttr | [in] The attribute identifier to get the value to be dumped for the head.
tAttr | [in] The attribute identifier to get the value to be dumped for the tail.

Member Function Documentation

sparksee::gdb::bool_t TypeExporter::CanRun ( )
protectedinherited

Checks that all the required settings are ready to run.

Returns
Returns true if all the settings are ready.
void TypeExporter::NotifyListeners ( const TypeExporterEvent & ev )
protectedinherited

Notifies progress to all registered listeners.

Parameters
ev [in] Progress event to be notified.
void TypeExporter::Register ( TypeExporterListener & tel )
inherited

Registers a new listener.

Parameters
tel [in] TypeExporterListener to be registered.
void TypeExporter::RunProcess ( ) throw (sparksee::gdb::IOException, sparksee::gdb::Error)
protectedinherited

Runs export process.

Exceptions
IOException If bad things happen writting to the RowWriter.
void TypeExporter::SetAttributes ( sparksee::gdb::AttributeList & attrs )
inherited

Sets the list of Attributes.

Parameters
attrs [in] Attribute identifiers to be exported
void TypeExporter::SetFrequency ( sparksee::gdb::int32_t freq )
inherited

Sets the frequency of listener notification.

Parameters
freq [in] Frequency in number of rows managed to notify progress to all listeners
void TypeExporter::SetGraph ( sparksee::gdb::Graph & graph )
inherited

Sets the graph that will be exported.

Parameters
graph [in] Graph.
void EdgeTypeExporter::SetHeadAttribute ( sparksee::gdb::attr_t attr )
inline

Sets the attribute that will be used to get the value to be dumped for the head of the edge.

Parameters
attr [in] Head Attribute
void TypeExporter::SetHeader ( sparksee::gdb::bool_t header )
inherited

Sets the presence of a header row.

Parameters
header [in] If TRUE, a header row is dumped with the name of the attributes.
void EdgeTypeExporter::SetHeadPosition ( sparksee::gdb::int32_t pos )
inline

Sets the position (index column) of the head attribute in the exported data.

Parameters
pos [in] Head position
void TypeExporter::SetRowWriter ( RowWriter & rw )
inherited

Sets the output data destination.

Parameters
rw [in] Input RowWriter.
void EdgeTypeExporter::SetTailAttribute ( sparksee::gdb::attr_t attr )
inline

Sets the attribute that will be used to get the value to be dumped for the tail of the edge.

Parameters
attr [in] Tail Attribute
void EdgeTypeExporter::SetTailPosition ( sparksee::gdb::int32_t pos )
inline

Sets the position (index column) of the tail attribute in the exported data.

Parameters
pos [in] Tail position
void TypeExporter::SetType ( sparksee::gdb::type_t type )
inherited

Sets the type to be exported.

Parameters
type [in] Type identifier.
The documentation for this class was generated from the following file:
  • EdgeTypeExporter.h


Sparksee: EdgeTypeLoader Class Reference

Public Member Functions | Protected Types | Protected Member Functions | List of all members
EdgeTypeLoader Class Reference
Io

EdgeTypeLoader class. More...

Inheritance diagram for EdgeTypeLoader:
Collaboration diagram for EdgeTypeLoader:

Public Member Functions

EdgeTypeLoader ()
Creates a new instance.
EdgeTypeLoader (RowReader &rowReader, sparksee::gdb::Graph &graph, sparksee::gdb::type_t type, sparksee::gdb::AttributeList &attrs, sparksee::gdb::Int32List &attrsPos, sparksee::gdb::int32_t hPos, sparksee::gdb::int32_t tPos, sparksee::gdb::attr_t hAttr, sparksee::gdb::attr_t tAttr, sparksee::gdb::MissingEndpoint headMEP, sparksee::gdb::MissingEndpoint tailMEP)
Creates a new instance.
virtual | ~EdgeTypeLoader ()
Destructor.
void | Run () throw (sparksee::gdb::IOException, sparksee::gdb::Error)
See the TypeLoader class Run method.
void | RunTwoPhases () throw (sparksee::gdb::IOException, sparksee::gdb::Error)
See the TypeLoader class RunTwoPhases method.
void | RunNPhases (sparksee::gdb::int32_t partitions) throw (sparksee::gdb::IOException, sparksee::gdb::Error)
See the TypeLoader class RunNPhases method.
void | SetHeadAttribute (sparksee::gdb::attr_t attr)
Sets the attribute that will be used to find the head of the edge.
void | SetHeadPosition (sparksee::gdb::int32_t pos)
Sets the position of the head attribute in the source data.
void | SetTailAttribute (sparksee::gdb::attr_t attr)
Sets the attribute that will be used to find the tail of the edge.
void | SetTailPosition (sparksee::gdb::int32_t pos)
Sets the position of the tail attribute in the source data.
void | SetTailMEP (sparksee::gdb::MissingEndpoint mep)
Sets the flag to create missing tail nodes when loading nodes or edges.
void | SetHeadMEP (sparksee::gdb::MissingEndpoint mep)
Sets the flag to create missing head nodes when loading nodes or edges.
void | SetLogError (const std::wstring &path) throw (sparksee::gdb::IOException)
Sets a log error file.
void | SetLogOff ()
Truns off all the error reporting.
void | Register (TypeLoaderListener &tel)
Registers a new listener.
void | SetRowReader (RowReader &rr)
Sets the input data source.
void | SetGraph (sparksee::gdb::Graph &graph)
Sets the graph where the data will be loaded.
void | SetLocale (const std::wstring &localeStr)
Sets the locale that will be used to read the data.
void | SetType (sparksee::gdb::type_t type)
Sets the type to be loaded.
void | SetAttributes (sparksee::gdb::AttributeList &attrs)
Sets the list of Attributes.
void | SetAttributePositions (sparksee::gdb::Int32List &attrsPos)
Sets the list of attribute positions.
void | SetTimestampFormat (const std::wstring &timestampFormat)
Sets a specific timestamp format.
void | SetFrequency (sparksee::gdb::int32_t freq)
Sets the frequency of listener notification.

Protected Types

enum Mode {
ONE_PHASE,
TWO_PHASES,
N_PHASES
}
Load can work in different ways. More...

Protected Member Functions

void | Run (Mode ph, sparksee::gdb::int32_t par) throw (sparksee::gdb::IOException, sparksee::gdb::Error)
Runs load process.
sparksee::gdb::bool_t CanRun ()
Checks that all the required settings are ready to run.
void | NotifyListeners (const TypeLoaderEvent &ev)
Notifies progress to all registered listeners.

Detailed Description

EdgeTypeLoader class.

Specific TypeLoader implementation for edge types.

Check out the 'Data import' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Enumeration Documentation

enum TypeLoader::Mode
protectedinherited

Load can work in different ways.

Enumerator:
ONE_PHASE

Performs the load in a phases.

Load all objects an attributes at the same time.

TWO_PHASES

Performs the load in two phases.

Firstly load all objects (and create them if necessary) and secondly loads all the attributes.

Working on this mode it is necessary to build a temporary file.

N_PHASES

Performs the load in N phases.

Firstly load all objects (and create them if necessary) and secondly loads all the attributes. But in this case, attributes are loaded one by one. This way, if there are three attributes, then 4 traverses to the RowReader are necessary.

Working on this mode it is necessary to build a temporary file.

Constructor & Destructor Documentation

EdgeTypeLoader::EdgeTypeLoader | ( | RowReader & | rowReader,
 |  | sparksee::gdb::Graph & | graph,
 |  | sparksee::gdb::type_t | type,
 |  | sparksee::gdb::AttributeList & | attrs,
 |  | sparksee::gdb::Int32List & | attrsPos,
 |  | sparksee::gdb::int32_t | hPos,
 |  | sparksee::gdb::int32_t | tPos,
 |  | sparksee::gdb::attr_t | hAttr,
 |  | sparksee::gdb::attr_t | tAttr,
 |  | sparksee::gdb::MissingEndpoint | headMEP,
 |  | sparksee::gdb::MissingEndpoint | tailMEP
 | ) |  |
inline

Creates a new instance.

Parameters
rowReader | [in] Input RowReader.
graph | [in] Graph.
type | [in] Type identifier.
attrs | [in] Attribute identifiers to be loaded.
attrsPos | [in] Attribute positions (column index >=0). to all listeners.
hPos | [in] The position (index column) for the head value.
tPos | [in] The position (index column) for the tail value.
hAttr | [in] The attribute identifier for the head.
tAttr | [in] The attribute identifier for the tail.
tailMEP | [in] The MissingEndpoint policy for the tail nodes
headMEP | [in] The MissingEndpoint policy for the head nodes

Member Function Documentation

sparksee::gdb::bool_t TypeLoader::CanRun ( )
protectedinherited

Checks that all the required settings are ready to run.

Returns
Returns true if all the settings are ready.
void TypeLoader::NotifyListeners ( const TypeLoaderEvent & ev )
protectedinherited

Notifies progress to all registered listeners.

Parameters
ev [in] Progress event to be notified.
void TypeLoader::Register ( TypeLoaderListener & tel )
inherited

Registers a new listener.

Parameters
[in] tel TypeLoaderListener to be registered.
void TypeLoader::Run | ( | Mode | ph,
 |  | sparksee::gdb::int32_t | par
 | ) |  | throw (sparksee::gdb::IOException, sparksee::gdb::Error)
 protectedinherited

Runs load process.

Exceptions
IOException If bad things happen reading from the RowReader.
Parameters
ph | [in] The load mode.
par | [in] Number of horizontal partitions to perform the load.
void TypeLoader::SetAttributePositions ( sparksee::gdb::Int32List & attrsPos )
inherited

Sets the list of attribute positions.

Parameters
attrsPos [in] Attribute positions (column index >=0).
void TypeLoader::SetAttributes ( sparksee::gdb::AttributeList & attrs )
inherited

Sets the list of Attributes.

Parameters
attrs [in] Attribute identifiers to be loaded
void TypeLoader::SetFrequency ( sparksee::gdb::int32_t freq )
inherited

Sets the frequency of listener notification.

Parameters
freq [in] Frequency in number of rows managed to notify progress to all listeners
void TypeLoader::SetGraph ( sparksee::gdb::Graph & graph )
inherited

Sets the graph where the data will be loaded.

Parameters
graph [in] Graph.
void EdgeTypeLoader::SetHeadAttribute ( sparksee::gdb::attr_t attr )
inline

Sets the attribute that will be used to find the head of the edge.

This method is protected because only the Edge loaders should have it.

Parameters
attr [in] Head Attribute
void EdgeTypeLoader::SetHeadMEP ( sparksee::gdb::MissingEndpoint mep )
inline

Sets the flag to create missing head nodes when loading nodes or edges.

Parameters
flag True if the nodes need to be created. False otherwise
void EdgeTypeLoader::SetHeadPosition ( sparksee::gdb::int32_t pos )
inline

Sets the position of the head attribute in the source data.

This method is protected because only the Edge loaders should have it.

Parameters
pos [in] Head position
void TypeLoader::SetLocale ( const std::wstring & localeStr )
inherited

Sets the locale that will be used to read the data.

It should match the locale used in the rowreader.

Parameters
localeStr [in] The locale string for the read data. See CSVReader.
void TypeLoader::SetLogError ( const std::wstring & path ) throw (sparksee::gdb::IOException)
inherited

Sets a log error file.

By default errors are thrown as a exception and the load process ends. If a log file is set, errors are logged there and the load process does not stop.

Parameters
path [in] The path to the error log file.
Exceptions
IOException If bad things happen opening the file.
void TypeLoader::SetLogOff ( )
inherited

Truns off all the error reporting.

The log file will not be created and no exceptions for invalid data will be thrown. If you just want to turn off the logs, but abort at the first error what you should do is not call this method and not set a logError file.

void TypeLoader::SetRowReader ( RowReader & rr )
inherited

Sets the input data source.

Parameters
rr [in] Input RowReader.
void EdgeTypeLoader::SetTailAttribute ( sparksee::gdb::attr_t attr )
inline

Sets the attribute that will be used to find the tail of the edge.

This method is protected because only the Edge loaders should have it.

Parameters
attr [in] Tail Attribute
void EdgeTypeLoader::SetTailMEP ( sparksee::gdb::MissingEndpoint mep )
inline

Sets the flag to create missing tail nodes when loading nodes or edges.

Parameters
flag True if the nodes need to be created. False otherwise
void EdgeTypeLoader::SetTailPosition ( sparksee::gdb::int32_t pos )
inline

Sets the position of the tail attribute in the source data.

This method is protected because only the Edge loaders should have it.

Parameters
pos [in] Tail position
void TypeLoader::SetTimestampFormat ( const std::wstring & timestampFormat )
inherited

Sets a specific timestamp format.

Parameters
timestampFormat [in] A string with the timestamp format definition.
void TypeLoader::SetType ( sparksee::gdb::type_t type )
inherited

Sets the type to be loaded.

Parameters
type [in] Type identifier.
The documentation for this class was generated from the following file:
  • EdgeTypeLoader.h


Sparksee: NodeTypeExporter Class Reference

Public Member Functions | Protected Member Functions | List of all members
NodeTypeExporter Class Reference
Io

NodeTypeExporter class. More...

Inheritance diagram for NodeTypeExporter:
Collaboration diagram for NodeTypeExporter:

Public Member Functions

NodeTypeExporter ()
Creates a new instance.
NodeTypeExporter (RowWriter &rowWriter, sparksee::gdb::Graph &graph, sparksee::gdb::type_t type, sparksee::gdb::AttributeList &attrs)
Creates a new instance.
virtual | ~NodeTypeExporter ()
Destructor.
void | Run () throw (sparksee::gdb::IOException, sparksee::gdb::Error)
See the TypeExporter class Run method.
void | Register (TypeExporterListener &tel)
Registers a new listener.
void | SetRowWriter (RowWriter &rw)
Sets the output data destination.
void | SetGraph (sparksee::gdb::Graph &graph)
Sets the graph that will be exported.
void | SetType (sparksee::gdb::type_t type)
Sets the type to be exported.
void | SetAttributes (sparksee::gdb::AttributeList &attrs)
Sets the list of Attributes.
void | SetFrequency (sparksee::gdb::int32_t freq)
Sets the frequency of listener notification.
void | SetHeader (sparksee::gdb::bool_t header)
Sets the presence of a header row.

Protected Member Functions

sparksee::gdb::bool_t CanRun ()
Checks that all the required settings are ready to run.
void | NotifyListeners (const TypeExporterEvent &ev)
Notifies progress to all registered listeners.
void | RunProcess () throw (sparksee::gdb::IOException, sparksee::gdb::Error)
Runs export process.
void | SetHeadAttribute (sparksee::gdb::attr_t attr)
Sets the attribute that will be used to get the value to be dumped for the head of the edge.
void | SetHeadPosition (sparksee::gdb::int32_t pos)
Sets the position (index column) of the head attribute in the exported data.
void | SetTailAttribute (sparksee::gdb::attr_t attr)
Sets the attribute that will be used to get the value to be dumped for the tail of the edge.
void | SetTailPosition (sparksee::gdb::int32_t pos)
Sets the position (index column) of the tail attribute in the exported data.

Detailed Description

NodeTypeExporter class.

Specific TypeExporter implementation for node types.

Check out the 'Data export' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

NodeTypeExporter::NodeTypeExporter | ( | RowWriter & | rowWriter,
 |  | sparksee::gdb::Graph & | graph,
 |  | sparksee::gdb::type_t | type,
 |  | sparksee::gdb::AttributeList & | attrs
 | ) |  |
inline

Creates a new instance.

Parameters
rowWriter | [in] Output RowWriter.
graph | [in] Graph.
type | [in] Type identifier.
attrs | [in] Attribute identifiers to be exported.

Member Function Documentation

sparksee::gdb::bool_t TypeExporter::CanRun ( )
protectedinherited

Checks that all the required settings are ready to run.

Returns
Returns true if all the settings are ready.
void TypeExporter::NotifyListeners ( const TypeExporterEvent & ev )
protectedinherited

Notifies progress to all registered listeners.

Parameters
ev [in] Progress event to be notified.
void TypeExporter::Register ( TypeExporterListener & tel )
inherited

Registers a new listener.

Parameters
tel [in] TypeExporterListener to be registered.
void TypeExporter::RunProcess ( ) throw (sparksee::gdb::IOException, sparksee::gdb::Error)
protectedinherited

Runs export process.

Exceptions
IOException If bad things happen writting to the RowWriter.
void TypeExporter::SetAttributes ( sparksee::gdb::AttributeList & attrs )
inherited

Sets the list of Attributes.

Parameters
attrs [in] Attribute identifiers to be exported
void TypeExporter::SetFrequency ( sparksee::gdb::int32_t freq )
inherited

Sets the frequency of listener notification.

Parameters
freq [in] Frequency in number of rows managed to notify progress to all listeners
void TypeExporter::SetGraph ( sparksee::gdb::Graph & graph )
inherited

Sets the graph that will be exported.

Parameters
graph [in] Graph.
void TypeExporter::SetHeadAttribute ( sparksee::gdb::attr_t attr )
protectedinherited

Sets the attribute that will be used to get the value to be dumped for the head of the edge.

This method is protected because only the Edge exporters should have it.

Parameters
attr [in] Head Attribute
void TypeExporter::SetHeader ( sparksee::gdb::bool_t header )
inherited

Sets the presence of a header row.

Parameters
header [in] If TRUE, a header row is dumped with the name of the attributes.
void TypeExporter::SetHeadPosition ( sparksee::gdb::int32_t pos )
protectedinherited

Sets the position (index column) of the head attribute in the exported data.

This method is protected because only the Edge exporters should have it.

Parameters
pos [in] Head position
void TypeExporter::SetRowWriter ( RowWriter & rw )
inherited

Sets the output data destination.

Parameters
rw [in] Input RowWriter.
void TypeExporter::SetTailAttribute ( sparksee::gdb::attr_t attr )
protectedinherited

Sets the attribute that will be used to get the value to be dumped for the tail of the edge.

This method is protected because only the Edge exporters should have it.

Parameters
attr [in] Tail Attribute
void TypeExporter::SetTailPosition ( sparksee::gdb::int32_t pos )
protectedinherited

Sets the position (index column) of the tail attribute in the exported data.

This method is protected because only the Edge exporters should have it.

Parameters
pos [in] Tail position
void TypeExporter::SetType ( sparksee::gdb::type_t type )
inherited

Sets the type to be exported.

Parameters
type [in] Type identifier.
The documentation for this class was generated from the following file:
  • NodeTypeExporter.h


Sparksee: NodeTypeLoader Class Reference

Public Member Functions | Protected Types | Protected Member Functions | List of all members
NodeTypeLoader Class Reference
Io

NodeTypeLoader class. More...

Inheritance diagram for NodeTypeLoader:
Collaboration diagram for NodeTypeLoader:

Public Member Functions

NodeTypeLoader ()
Creates a new instance.
NodeTypeLoader (RowReader &rowReader, sparksee::gdb::Graph &graph, sparksee::gdb::type_t type, sparksee::gdb::AttributeList &attrs, sparksee::gdb::Int32List &attrsPos)
Creates a new instance.
virtual | ~NodeTypeLoader ()
Destructor.
void | Run () throw (sparksee::gdb::IOException, sparksee::gdb::Error)
See the TypeLoader class Run method.
void | RunTwoPhases () throw (sparksee::gdb::IOException, sparksee::gdb::Error)
See the TypeLoader class RunTwoPhases method.
void | RunNPhases (sparksee::gdb::int32_t partitions) throw (sparksee::gdb::IOException, sparksee::gdb::Error)
See the TypeLoader class RunNPhases method.
void | SetLogError (const std::wstring &path) throw (sparksee::gdb::IOException)
Sets a log error file.
void | SetLogOff ()
Truns off all the error reporting.
void | Register (TypeLoaderListener &tel)
Registers a new listener.
void | SetRowReader (RowReader &rr)
Sets the input data source.
void | SetGraph (sparksee::gdb::Graph &graph)
Sets the graph where the data will be loaded.
void | SetLocale (const std::wstring &localeStr)
Sets the locale that will be used to read the data.
void | SetType (sparksee::gdb::type_t type)
Sets the type to be loaded.
void | SetAttributes (sparksee::gdb::AttributeList &attrs)
Sets the list of Attributes.
void | SetAttributePositions (sparksee::gdb::Int32List &attrsPos)
Sets the list of attribute positions.
void | SetTimestampFormat (const std::wstring &timestampFormat)
Sets a specific timestamp format.
void | SetFrequency (sparksee::gdb::int32_t freq)
Sets the frequency of listener notification.

Protected Types

enum Mode {
ONE_PHASE,
TWO_PHASES,
N_PHASES
}
Load can work in different ways. More...

Protected Member Functions

void | Run (Mode ph, sparksee::gdb::int32_t par) throw (sparksee::gdb::IOException, sparksee::gdb::Error)
Runs load process.
sparksee::gdb::bool_t CanRun ()
Checks that all the required settings are ready to run.
void | NotifyListeners (const TypeLoaderEvent &ev)
Notifies progress to all registered listeners.
void | SetHeadAttribute (sparksee::gdb::attr_t attr)
Sets the attribute that will be used to find the head of the edge.
void | SetHeadPosition (sparksee::gdb::int32_t pos)
Sets the position of the head attribute in the source data.
void | SetTailAttribute (sparksee::gdb::attr_t attr)
Sets the attribute that will be used to find the tail of the edge.
void | SetTailPosition (sparksee::gdb::int32_t pos)
Sets the position of the tail attribute in the source data.
void | SetTailMEP (sparksee::gdb::MissingEndpoint mep)
Sets the flag to create missing tail nodes when loading nodes or edges.
void | SetHeadMEP (sparksee::gdb::MissingEndpoint mep)
Sets the flag to create missing head nodes when loading nodes or edges.

Detailed Description

NodeTypeLoader class.

Specific TypeLoader implementation for node types.

Check out the 'Data import' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Enumeration Documentation

enum TypeLoader::Mode
protectedinherited

Load can work in different ways.

Enumerator:
ONE_PHASE

Performs the load in a phases.

Load all objects an attributes at the same time.

TWO_PHASES

Performs the load in two phases.

Firstly load all objects (and create them if necessary) and secondly loads all the attributes.

Working on this mode it is necessary to build a temporary file.

N_PHASES

Performs the load in N phases.

Firstly load all objects (and create them if necessary) and secondly loads all the attributes. But in this case, attributes are loaded one by one. This way, if there are three attributes, then 4 traverses to the RowReader are necessary.

Working on this mode it is necessary to build a temporary file.

Constructor & Destructor Documentation

NodeTypeLoader::NodeTypeLoader | ( | RowReader & | rowReader,
 |  | sparksee::gdb::Graph & | graph,
 |  | sparksee::gdb::type_t | type,
 |  | sparksee::gdb::AttributeList & | attrs,
 |  | sparksee::gdb::Int32List & | attrsPos
 | ) |  |
inline

Creates a new instance.

Parameters
rowReader | [in] Input RowReader.
graph | [in] Graph.
type | [in] Type identifier.
attrs | [in] Attribute identifiers to be loaded.
attrsPos | [in] Attribute positions (column index >=0).

Member Function Documentation

sparksee::gdb::bool_t TypeLoader::CanRun ( )
protectedinherited

Checks that all the required settings are ready to run.

Returns
Returns true if all the settings are ready.
void TypeLoader::NotifyListeners ( const TypeLoaderEvent & ev )
protectedinherited

Notifies progress to all registered listeners.

Parameters
ev [in] Progress event to be notified.
void TypeLoader::Register ( TypeLoaderListener & tel )
inherited

Registers a new listener.

Parameters
[in] tel TypeLoaderListener to be registered.
void TypeLoader::Run | ( | Mode | ph,
 |  | sparksee::gdb::int32_t | par
 | ) |  | throw (sparksee::gdb::IOException, sparksee::gdb::Error)
 protectedinherited

Runs load process.

Exceptions
IOException If bad things happen reading from the RowReader.
Parameters
ph | [in] The load mode.
par | [in] Number of horizontal partitions to perform the load.
void TypeLoader::SetAttributePositions ( sparksee::gdb::Int32List & attrsPos )
inherited

Sets the list of attribute positions.

Parameters
attrsPos [in] Attribute positions (column index >=0).
void TypeLoader::SetAttributes ( sparksee::gdb::AttributeList & attrs )
inherited

Sets the list of Attributes.

Parameters
attrs [in] Attribute identifiers to be loaded
void TypeLoader::SetFrequency ( sparksee::gdb::int32_t freq )
inherited

Sets the frequency of listener notification.

Parameters
freq [in] Frequency in number of rows managed to notify progress to all listeners
void TypeLoader::SetGraph ( sparksee::gdb::Graph & graph )
inherited

Sets the graph where the data will be loaded.

Parameters
graph [in] Graph.
void TypeLoader::SetHeadAttribute ( sparksee::gdb::attr_t attr )
protectedinherited

Sets the attribute that will be used to find the head of the edge.

This method is protected because only the Edge loaders should have it.

Parameters
attr [in] Head Attribute
void TypeLoader::SetHeadMEP ( sparksee::gdb::MissingEndpoint mep )
protectedinherited

Sets the flag to create missing head nodes when loading nodes or edges.

Parameters
flag True if the nodes need to be created. False otherwise
void TypeLoader::SetHeadPosition ( sparksee::gdb::int32_t pos )
protectedinherited

Sets the position of the head attribute in the source data.

This method is protected because only the Edge loaders should have it.

Parameters
pos [in] Head position
void TypeLoader::SetLocale ( const std::wstring & localeStr )
inherited

Sets the locale that will be used to read the data.

It should match the locale used in the rowreader.

Parameters
localeStr [in] The locale string for the read data. See CSVReader.
void TypeLoader::SetLogError ( const std::wstring & path ) throw (sparksee::gdb::IOException)
inherited

Sets a log error file.

By default errors are thrown as a exception and the load process ends. If a log file is set, errors are logged there and the load process does not stop.

Parameters
path [in] The path to the error log file.
Exceptions
IOException If bad things happen opening the file.
void TypeLoader::SetLogOff ( )
inherited

Truns off all the error reporting.

The log file will not be created and no exceptions for invalid data will be thrown. If you just want to turn off the logs, but abort at the first error what you should do is not call this method and not set a logError file.

void TypeLoader::SetRowReader ( RowReader & rr )
inherited

Sets the input data source.

Parameters
rr [in] Input RowReader.
void TypeLoader::SetTailAttribute ( sparksee::gdb::attr_t attr )
protectedinherited

Sets the attribute that will be used to find the tail of the edge.

This method is protected because only the Edge loaders should have it.

Parameters
attr [in] Tail Attribute
void TypeLoader::SetTailMEP ( sparksee::gdb::MissingEndpoint mep )
protectedinherited

Sets the flag to create missing tail nodes when loading nodes or edges.

Parameters
flag True if the nodes need to be created. False otherwise
void TypeLoader::SetTailPosition ( sparksee::gdb::int32_t pos )
protectedinherited

Sets the position of the tail attribute in the source data.

This method is protected because only the Edge loaders should have it.

Parameters
pos [in] Tail position
void TypeLoader::SetTimestampFormat ( const std::wstring & timestampFormat )
inherited

Sets a specific timestamp format.

Parameters
timestampFormat [in] A string with the timestamp format definition.
void TypeLoader::SetType ( sparksee::gdb::type_t type )
inherited

Sets the type to be loaded.

Parameters
type [in] Type identifier.
The documentation for this class was generated from the following file:
  • NodeTypeLoader.h


Sparksee: RowReader Class Reference

Public Member Functions | Protected Member Functions | List of all members
RowReader Class Referenceabstract
Io

RowReader interface. More...

Inheritance diagram for RowReader:

Public Member Functions

virtual sparksee::gdb::bool_t | Reset ()=0 throw (sparksee::gdb::IOException)
Moves the reader to the beginning.
virtual sparksee::gdb::bool_t | Read (sparksee::gdb::StringList &row)=0 throw (sparksee::gdb::IOException)
Reads the next row as a string array.
virtual sparksee::gdb::int32_t | GetRow ()=0 throw (sparksee::gdb::IOException)
The row number for the current row.
virtual void | Close ()=0 throw (sparksee::gdb::IOException)
Closes the reader.
virtual | ~RowReader ()
Destructor.

Protected Member Functions

RowReader ()
Empty constructor.

Detailed Description

RowReader interface.

Common interface for those readers which get the data as an string array.

It works as follows: perform as many read operations as necessary and call close once at the end. Once close is called no more read operations can be executed.

Check out the 'Data import' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

RowReader::RowReader ( )
inlineprotected

Empty constructor.

Protected because no one should instantiate a RowReader. Just inherited classes can use this empty constructor.

Member Function Documentation

virtual void RowReader::Close ( ) throw (sparksee::gdb::IOException)
pure virtual

Closes the reader.

Exceptions
IOException If the close fails.

Implemented in CSVReader.

virtual sparksee::gdb::int32_t RowReader::GetRow ( ) throw (sparksee::gdb::IOException)
pure virtual

The row number for the current row.

Returns
The current row number; 0 if there is no current row.
Exceptions
IOException If it fails.

Implemented in CSVReader.

virtual sparksee::gdb::bool_t RowReader::Read ( sparksee::gdb::StringList & row ) throw (sparksee::gdb::IOException)
pure virtual

Reads the next row as a string array.

Parameters
row [out] A string list with each comma-separated element as a separate entry.
Returns
Returns true if a row had been read or false otherwise.
Exceptions
IOException If bad things happen during the read.

Implemented in CSVReader.

virtual sparksee::gdb::bool_t RowReader::Reset ( ) throw (sparksee::gdb::IOException)
pure virtual

Moves the reader to the beginning.

Restarts the reader.

Returns
true if the reader can be restarted, false otherwise.
Exceptions
IOException If bad things happen during the restart.

Implemented in CSVReader.

The documentation for this class was generated from the following file:
  • RowReader.h


Sparksee: RowWriter Class Reference

Public Member Functions | Protected Member Functions | List of all members
RowWriter Class Referenceabstract
Io

RowWriter interface. More...

Inheritance diagram for RowWriter:

Public Member Functions

virtual void | Write (sparksee::gdb::StringList &row)=0 throw (sparksee::gdb::IOException, sparksee::gdb::Error)
Writes the next row.
virtual void | Close ()=0 throw (sparksee::gdb::IOException, sparksee::gdb::Error)
Closes the writer.
virtual | ~RowWriter ()
Destructor.

Protected Member Functions

RowWriter ()
Empty constructor.

Detailed Description

RowWriter interface.

Common interface for those writers which dump the data from an string array.

It works as follows: perform as many write operations as necessary and call close once at the end. Once close is called no more write operations can be executed.

Check out the 'Data export' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

RowWriter::RowWriter ( )
inlineprotected

Empty constructor.

Protected because no one should instantiate a RowWriter. Just inherited classes can use this empty constructor.

Member Function Documentation

virtual void RowWriter::Close ( ) throw (sparksee::gdb::IOException, sparksee::gdb::Error)
pure virtual

Closes the writer.

Exceptions
IOException If the close fails.

Implemented in CSVWriter.

virtual void RowWriter::Write ( sparksee::gdb::StringList & row ) throw (sparksee::gdb::IOException, sparksee::gdb::Error)
pure virtual

Writes the next row.

Parameters
row [in] Row of data.
Exceptions
IOException If bad things happen during the write.

Implemented in CSVWriter.

The documentation for this class was generated from the following file:
  • RowWriter.h


Sparksee: TypeExporterEvent Class Reference

Public Member Functions | Friends | List of all members
TypeExporterEvent Class Reference
Io

Provides information about the progress of an TypeExproter instance. More...

Public Member Functions

virtual | ~TypeExporterEvent ()
Destructor.
sparksee::gdb::type_t | GetTypeId () const
Gets the type identifier.
sparksee::gdb::int64_t | GetCount () const
Gets the current number of objects exported.
sparksee::gdb::int64_t | GetTotal () const
Gets the total number of objects exported.
sparksee::gdb::bool_t | IsLast () const
Gets if this is the last event or not.

Friends

class TypeExporter

Detailed Description

Provides information about the progress of an TypeExproter instance.

Check out the 'Data export' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

sparksee::gdb::int64_t TypeExporterEvent::GetCount ( ) const
inline

Gets the current number of objects exported.

Returns
The current number of objects exported.
sparksee::gdb::int64_t TypeExporterEvent::GetTotal ( ) const
inline

Gets the total number of objects exported.

Returns
The total number of objects exported.
sparksee::gdb::type_t TypeExporterEvent::GetTypeId ( ) const
inline

Gets the type identifier.

Returns
The type identifier.
sparksee::gdb::bool_t TypeExporterEvent::IsLast ( ) const
inline

Gets if this is the last event or not.

Returns
TRUE if this is the last event, FALSE otherwise.
The documentation for this class was generated from the following file:
  • TypeExporter.h


Sparksee: TypeExporterListener Class Reference

Public Member Functions | Protected Member Functions | List of all members
TypeExporterListener Class Referenceabstract
Io

Interface to be implemented to receive TypeExporterEvent events from a TypeExporter. More...

Public Member Functions

virtual void | NotifyEvent (const TypeExporterEvent &tee)=0
Method to be notified from a TypeExporter.
virtual | ~TypeExporterListener ()
Destructor.

Protected Member Functions

TypeExporterListener ()
Protected because none should instantiate a RowWriter.

Detailed Description

Interface to be implemented to receive TypeExporterEvent events from a TypeExporter.

Check out the 'Data export' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

TypeExporterListener::TypeExporterListener ( )
inlineprotected

Protected because none should instantiate a RowWriter.

Just inherited classes may use this empty constructor.

Member Function Documentation

virtual void TypeExporterListener::NotifyEvent ( const TypeExporterEvent & tee )
pure virtual

Method to be notified from a TypeExporter.

Parameters
tee [in] Notified event.
The documentation for this class was generated from the following file:
  • TypeExporter.h


Sparksee: TypeExporter Class Reference

Public Member Functions | Protected Member Functions | List of all members
TypeExporter Class Referenceabstract
Io

Base TypeExporter class. More...

Inheritance diagram for TypeExporter:

Public Member Functions

virtual | ~TypeExporter ()
Destructor.
void | Register (TypeExporterListener &tel)
Registers a new listener.
virtual void | Run ()=0 throw (sparksee::gdb::IOException, sparksee::gdb::Error)
Runs export process.
void | SetRowWriter (RowWriter &rw)
Sets the output data destination.
void | SetGraph (sparksee::gdb::Graph &graph)
Sets the graph that will be exported.
void | SetType (sparksee::gdb::type_t type)
Sets the type to be exported.
void | SetAttributes (sparksee::gdb::AttributeList &attrs)
Sets the list of Attributes.
void | SetFrequency (sparksee::gdb::int32_t freq)
Sets the frequency of listener notification.
void | SetHeader (sparksee::gdb::bool_t header)
Sets the presence of a header row.

Protected Member Functions

TypeExporter ()
Creates a new instance.
TypeExporter (RowWriter &rw, sparksee::gdb::Graph &g, sparksee::gdb::type_t t, sparksee::gdb::AttributeList &attrs)
Creates a new instance with the minimum common required arguments.
sparksee::gdb::bool_t CanRun ()
Checks that all the required settings are ready to run.
void | NotifyListeners (const TypeExporterEvent &ev)
Notifies progress to all registered listeners.
void | RunProcess () throw (sparksee::gdb::IOException, sparksee::gdb::Error)
Runs export process.
void | SetHeadAttribute (sparksee::gdb::attr_t attr)
Sets the attribute that will be used to get the value to be dumped for the head of the edge.
void | SetHeadPosition (sparksee::gdb::int32_t pos)
Sets the position (index column) of the head attribute in the exported data.
void | SetTailAttribute (sparksee::gdb::attr_t attr)
Sets the attribute that will be used to get the value to be dumped for the tail of the edge.
void | SetTailPosition (sparksee::gdb::int32_t pos)
Sets the position (index column) of the tail attribute in the exported data.

Detailed Description

Base TypeExporter class.

Base class to export a node or edge type from a graph using a RowWriter.

TypeExporterListener can be registered to receive information about the progress of the export process by means of TypeExporterEvent. The default frequency of notification to listeners is 100000.

By default no header row is created.

Check out the 'Data export' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

TypeExporter::TypeExporter | ( | RowWriter & | rw,
 |  | sparksee::gdb::Graph & | g,
 |  | sparksee::gdb::type_t | t,
 |  | sparksee::gdb::AttributeList & | attrs
 | ) |  |
protected

Creates a new instance with the minimum common required arguments.

Parameters
rw | [in] Output RowWriter.
g | [in] Graph.
t | [in] Type identifier.
attrs | [in] Attribute identifiers to be exported.

Member Function Documentation

sparksee::gdb::bool_t TypeExporter::CanRun ( )
protected

Checks that all the required settings are ready to run.

Returns
Returns true if all the settings are ready.
void TypeExporter::NotifyListeners ( const TypeExporterEvent & ev )
protected

Notifies progress to all registered listeners.

Parameters
ev [in] Progress event to be notified.
void TypeExporter::Register ( TypeExporterListener & tel )

Registers a new listener.

Parameters
tel [in] TypeExporterListener to be registered.
virtual void TypeExporter::Run ( ) throw (sparksee::gdb::IOException, sparksee::gdb::Error)
pure virtual

Runs export process.

Exceptions
IOException If bad things happen writing to the RowWriter.

Implemented in EdgeTypeExporter, and NodeTypeExporter.

void TypeExporter::RunProcess ( ) throw (sparksee::gdb::IOException, sparksee::gdb::Error)
protected

Runs export process.

Exceptions
IOException If bad things happen writting to the RowWriter.
void TypeExporter::SetAttributes ( sparksee::gdb::AttributeList & attrs )

Sets the list of Attributes.

Parameters
attrs [in] Attribute identifiers to be exported
void TypeExporter::SetFrequency ( sparksee::gdb::int32_t freq )

Sets the frequency of listener notification.

Parameters
freq [in] Frequency in number of rows managed to notify progress to all listeners
void TypeExporter::SetGraph ( sparksee::gdb::Graph & graph )

Sets the graph that will be exported.

Parameters
graph [in] Graph.
void TypeExporter::SetHeadAttribute ( sparksee::gdb::attr_t attr )
protected

Sets the attribute that will be used to get the value to be dumped for the head of the edge.

This method is protected because only the Edge exporters should have it.

Parameters
attr [in] Head Attribute
void TypeExporter::SetHeader ( sparksee::gdb::bool_t header )

Sets the presence of a header row.

Parameters
header [in] If TRUE, a header row is dumped with the name of the attributes.
void TypeExporter::SetHeadPosition ( sparksee::gdb::int32_t pos )
protected

Sets the position (index column) of the head attribute in the exported data.

This method is protected because only the Edge exporters should have it.

Parameters
pos [in] Head position
void TypeExporter::SetRowWriter ( RowWriter & rw )

Sets the output data destination.

Parameters
rw [in] Input RowWriter.
void TypeExporter::SetTailAttribute ( sparksee::gdb::attr_t attr )
protected

Sets the attribute that will be used to get the value to be dumped for the tail of the edge.

This method is protected because only the Edge exporters should have it.

Parameters
attr [in] Tail Attribute
void TypeExporter::SetTailPosition ( sparksee::gdb::int32_t pos )
protected

Sets the position (index column) of the tail attribute in the exported data.

This method is protected because only the Edge exporters should have it.

Parameters
pos [in] Tail position
void TypeExporter::SetType ( sparksee::gdb::type_t type )

Sets the type to be exported.

Parameters
type [in] Type identifier.
The documentation for this class was generated from the following file:
  • TypeExporter.h


Sparksee: TypeLoaderEvent Class Reference

Public Member Functions | Friends | List of all members
TypeLoaderEvent Class Reference
Io

Provides information about the progress of a TypeLoader instance. More...

Public Member Functions

virtual | ~TypeLoaderEvent ()
Destructor.
sparksee::gdb::type_t | GetTypeId () const
Gets the type identifier.
sparksee::gdb::int64_t | GetCount () const
Gets the current number of objects created.
sparksee::gdb::int32_t | GetPhase () const
Gets the current phase.
sparksee::gdb::int32_t | GetTotalPhases () const
Gets the total number of phases.
sparksee::gdb::int32_t | GetPartition () const
Gets the current partition.
sparksee::gdb::int32_t | GetTotalPartitions () const
Gets the total number of partitions.
sparksee::gdb::int32_t | GetTotalPartitionSteps () const
Gets the total number of steps in the current partition.
sparksee::gdb::bool_t | IsLast () const
Gets if this is the last event or not.

Friends

class TypeLoader

Detailed Description

Provides information about the progress of a TypeLoader instance.

Check out the 'Data import' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com
The documentation for this class was generated from the following file:
  • TypeLoader.h


Sparksee: TypeLoaderListener Class Reference

Public Member Functions | Protected Member Functions | List of all members
TypeLoaderListener Class Referenceabstract
Io

Interface to be implemented to receive TypeLoaderEvent events from a TypeLoader. More...

Public Member Functions

virtual void | NotifyEvent (const TypeLoaderEvent &ev)=0
Method to receive events from a Loader.
virtual | ~TypeLoaderListener ()
Destructor.

Protected Member Functions

TypeLoaderListener ()
Protected because none should instantiate a RowWriter.

Detailed Description

Interface to be implemented to receive TypeLoaderEvent events from a TypeLoader.

Check out the 'Data import' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

TypeLoaderListener::TypeLoaderListener ( )
inlineprotected

Protected because none should instantiate a RowWriter.

Just inherited classes may use this empty constructor.

Member Function Documentation

virtual void TypeLoaderListener::NotifyEvent ( const TypeLoaderEvent & ev )
pure virtual

Method to receive events from a Loader.

Parameters
ev Loader.LoaderEvent with information from a running Loader.
The documentation for this class was generated from the following file:
  • TypeLoader.h


Sparksee: TypeLoader Class Reference

Public Member Functions | Protected Types | Protected Member Functions | List of all members
TypeLoader Class Referenceabstract
Io

Base TypeLoader class. More...

Inheritance diagram for TypeLoader:

Public Member Functions

void | SetLogError (const std::wstring &path) throw (sparksee::gdb::IOException)
Sets a log error file.
void | SetLogOff ()
Truns off all the error reporting.
virtual | ~TypeLoader ()
Destructor.
void | Register (TypeLoaderListener &tel)
Registers a new listener.
virtual void | Run ()=0 throw (sparksee::gdb::IOException, sparksee::gdb::Error)
Run the loader.
virtual void | RunTwoPhases ()=0 throw (sparksee::gdb::IOException, sparksee::gdb::Error)
Run the loader for two phases loading.
virtual void | RunNPhases (sparksee::gdb::int32_t partitions)=0 throw (sparksee::gdb::IOException, sparksee::gdb::Error)
Run the loader for N phases loading.
void | SetRowReader (RowReader &rr)
Sets the input data source.
void | SetGraph (sparksee::gdb::Graph &graph)
Sets the graph where the data will be loaded.
void | SetLocale (const std::wstring &localeStr)
Sets the locale that will be used to read the data.
void | SetType (sparksee::gdb::type_t type)
Sets the type to be loaded.
void | SetAttributes (sparksee::gdb::AttributeList &attrs)
Sets the list of Attributes.
void | SetAttributePositions (sparksee::gdb::Int32List &attrsPos)
Sets the list of attribute positions.
void | SetTimestampFormat (const std::wstring &timestampFormat)
Sets a specific timestamp format.
void | SetFrequency (sparksee::gdb::int32_t freq)
Sets the frequency of listener notification.

Protected Types

enum Mode {
ONE_PHASE,
TWO_PHASES,
N_PHASES
}
Load can work in different ways. More...

Protected Member Functions

sparksee::gdb::bool_t CanRun ()
Checks that all the required settings are ready to run.
void | Run (Mode ph, sparksee::gdb::int32_t par) throw (sparksee::gdb::IOException, sparksee::gdb::Error)
Runs load process.
TypeLoader (RowReader &rr, sparksee::gdb::Graph &g, sparksee::gdb::type_t t, sparksee::gdb::AttributeList &attrs, sparksee::gdb::Int32List &attrsPos)
Creates a new instance with the minimum common required arguments.
TypeLoader ()
Creates a new instance.
void | NotifyListeners (const TypeLoaderEvent &ev)
Notifies progress to all registered listeners.
void | SetHeadAttribute (sparksee::gdb::attr_t attr)
Sets the attribute that will be used to find the head of the edge.
void | SetHeadPosition (sparksee::gdb::int32_t pos)
Sets the position of the head attribute in the source data.
void | SetTailAttribute (sparksee::gdb::attr_t attr)
Sets the attribute that will be used to find the tail of the edge.
void | SetTailPosition (sparksee::gdb::int32_t pos)
Sets the position of the tail attribute in the source data.
void | SetTailMEP (sparksee::gdb::MissingEndpoint mep)
Sets the flag to create missing tail nodes when loading nodes or edges.
void | SetHeadMEP (sparksee::gdb::MissingEndpoint mep)
Sets the flag to create missing head nodes when loading nodes or edges.

Detailed Description

Base TypeLoader class.

Base class to load a node or edge type from a graph using a RowReader.

TypeLoaderListener can be registered to receive information about the progress of the load process by means of TypeLoaderEvent. The default frequency of notification to listeners is 100000.

Check out the 'Data import' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Enumeration Documentation

enum TypeLoader::Mode
protected

Load can work in different ways.

Enumerator:
ONE_PHASE

Performs the load in a phases.

Load all objects an attributes at the same time.

TWO_PHASES

Performs the load in two phases.

Firstly load all objects (and create them if necessary) and secondly loads all the attributes.

Working on this mode it is necessary to build a temporary file.

N_PHASES

Performs the load in N phases.

Firstly load all objects (and create them if necessary) and secondly loads all the attributes. But in this case, attributes are loaded one by one. This way, if there are three attributes, then 4 traverses to the RowReader are necessary.

Working on this mode it is necessary to build a temporary file.

Constructor & Destructor Documentation

TypeLoader::TypeLoader | ( | RowReader & | rr,
 |  | sparksee::gdb::Graph & | g,
 |  | sparksee::gdb::type_t | t,
 |  | sparksee::gdb::AttributeList & | attrs,
 |  | sparksee::gdb::Int32List & | attrsPos
 | ) |  |
protected

Creates a new instance with the minimum common required arguments.

Parameters
rr | [in] Input RowReader.
g | [in] Graph.
t | [in] Type identifier.
attrs | [in] Attribute identifiers to be loaded
attrsPos | [in] Attribute positions (column index >=0)

Member Function Documentation

sparksee::gdb::bool_t TypeLoader::CanRun ( )
protected

Checks that all the required settings are ready to run.

Returns
Returns true if all the settings are ready.
void TypeLoader::NotifyListeners ( const TypeLoaderEvent & ev )
protected

Notifies progress to all registered listeners.

Parameters
ev [in] Progress event to be notified.
void TypeLoader::Register ( TypeLoaderListener & tel )

Registers a new listener.

Parameters
[in] tel TypeLoaderListener to be registered.
void TypeLoader::Run | ( | Mode | ph,
 |  | sparksee::gdb::int32_t | par
 | ) |  | throw (sparksee::gdb::IOException, sparksee::gdb::Error)
 protected

Runs load process.

Exceptions
IOException If bad things happen reading from the RowReader.
Parameters
ph | [in] The load mode.
par | [in] Number of horizontal partitions to perform the load.
virtual void TypeLoader::RunNPhases ( sparksee::gdb::int32_t partitions ) throw (sparksee::gdb::IOException, sparksee::gdb::Error)
pure virtual

Run the loader for N phases loading.

Firstly load all objects (and create them if necessary) and secondly loads all the attributes. But in this case, attributes are loaded one by one. This way, if there are three attributes, then 4 traverses are necessary.

Working on this mode it is necessary to build a temporary file.

Parameters
partitions [in] Number of horizontal partitions to perform the load.

Implemented in EdgeTypeLoader, and NodeTypeLoader.

virtual void TypeLoader::RunTwoPhases ( ) throw (sparksee::gdb::IOException, sparksee::gdb::Error)
pure virtual

Run the loader for two phases loading.

Firstly load all objects (and create them if necessary) and secondly loads all the attributes.

Working on this mode it is necessary to build a temporary file.

Implemented in EdgeTypeLoader, and NodeTypeLoader.

void TypeLoader::SetAttributePositions ( sparksee::gdb::Int32List & attrsPos )

Sets the list of attribute positions.

Parameters
attrsPos [in] Attribute positions (column index >=0).
void TypeLoader::SetAttributes ( sparksee::gdb::AttributeList & attrs )

Sets the list of Attributes.

Parameters
attrs [in] Attribute identifiers to be loaded
void TypeLoader::SetFrequency ( sparksee::gdb::int32_t freq )

Sets the frequency of listener notification.

Parameters
freq [in] Frequency in number of rows managed to notify progress to all listeners
void TypeLoader::SetGraph ( sparksee::gdb::Graph & graph )

Sets the graph where the data will be loaded.

Parameters
graph [in] Graph.
void TypeLoader::SetHeadAttribute ( sparksee::gdb::attr_t attr )
protected

Sets the attribute that will be used to find the head of the edge.

This method is protected because only the Edge loaders should have it.

Parameters
attr [in] Head Attribute
void TypeLoader::SetHeadMEP ( sparksee::gdb::MissingEndpoint mep )
protected

Sets the flag to create missing head nodes when loading nodes or edges.

Parameters
flag True if the nodes need to be created. False otherwise
void TypeLoader::SetHeadPosition ( sparksee::gdb::int32_t pos )
protected

Sets the position of the head attribute in the source data.

This method is protected because only the Edge loaders should have it.

Parameters
pos [in] Head position
void TypeLoader::SetLocale ( const std::wstring & localeStr )

Sets the locale that will be used to read the data.

It should match the locale used in the rowreader.

Parameters
localeStr [in] The locale string for the read data. See CSVReader.
void TypeLoader::SetLogError ( const std::wstring & path ) throw (sparksee::gdb::IOException)

Sets a log error file.

By default errors are thrown as a exception and the load process ends. If a log file is set, errors are logged there and the load process does not stop.

Parameters
path [in] The path to the error log file.
Exceptions
IOException If bad things happen opening the file.
void TypeLoader::SetLogOff ( )

Truns off all the error reporting.

The log file will not be created and no exceptions for invalid data will be thrown. If you just want to turn off the logs, but abort at the first error what you should do is not call this method and not set a logError file.

void TypeLoader::SetRowReader ( RowReader & rr )

Sets the input data source.

Parameters
rr [in] Input RowReader.
void TypeLoader::SetTailAttribute ( sparksee::gdb::attr_t attr )
protected

Sets the attribute that will be used to find the tail of the edge.

This method is protected because only the Edge loaders should have it.

Parameters
attr [in] Tail Attribute
void TypeLoader::SetTailMEP ( sparksee::gdb::MissingEndpoint mep )
protected

Sets the flag to create missing tail nodes when loading nodes or edges.

Parameters
flag True if the nodes need to be created. False otherwise
void TypeLoader::SetTailPosition ( sparksee::gdb::int32_t pos )
protected

Sets the position of the tail attribute in the source data.

This method is protected because only the Edge loaders should have it.

Parameters
pos [in] Tail position
void TypeLoader::SetTimestampFormat ( const std::wstring & timestampFormat )

Sets a specific timestamp format.

Parameters
timestampFormat [in] A string with the timestamp format definition.
void TypeLoader::SetType ( sparksee::gdb::type_t type )

Sets the type to be loaded.

Parameters
type [in] Type identifier.
The documentation for this class was generated from the following file:
  • TypeLoader.h


Sparksee: Script

Files | Classes | Functions
Script
Collaboration diagram for Script:

Files

file ScriptParser.h
It contains the declaration of ScriptParser class.

Classes

class ScriptParser
ScriptParser. More...

Functions

std::wostream & operator<< (std::wostream &wostrm, const enum ScriptParserState &state)
Easy STL printing operator redefinition.

Detailed Description

Function Documentation

std::wostream& operator<< | ( | std::wostream & | wostrm,
 |  | const enum ScriptParserState & | state
 | ) |  |

Easy STL printing operator redefinition.

It allows to do: ... << sparksee::script::SyntaxError << ...

Parameters
wostrm | A widechar oputput stream
state | [in] A ScriptParserState.
Returns
Returns the widechar output stream with the ScriptParserState written.
Generated on Thu Feb 24 2022 12:56:05 for Sparksee by doxygen 1.8.2


Sparksee: ScriptParser Class Reference

Public Member Functions | Static Public Member Functions | List of all members
ScriptParser Class Reference
Script

ScriptParser. More...

Public Member Functions

ScriptParser ()
Constructor.
virtual | ~ScriptParser ()
Destructor.
void | SetOutputLog (const std::wstring &path) throw (sparksee::gdb::IOException)
Sets the output log.
void | SetErrorLog (const std::wstring &path) throw (sparksee::gdb::IOException)
Sets the error log.
sparksee::gdb::bool_t | Parse (sparksee_core::FileReader *fileReader, sparksee::gdb::bool_t execute)
Parser the given input stream.
sparksee::gdb::bool_t | Parse (const std::wstring &path, sparksee::gdb::bool_t execute, const std::wstring &localeStr) throw (sparksee::gdb::IOException)
Parses the given input file.

Static Public Member Functions

static void GenerateSchemaScript (const std::wstring &path, sparksee::gdb::Database &db) throw (sparksee::gdb::IOException)
Writes an script with the schema definition for the given database.

Detailed Description

ScriptParser.

The ScriptParser can create schemas and load data from a set of commands in a sparksee script.

A SPARKSEE script contains an ordered list of commands. ScriptParser will execute each one of them in order. Commands may create schemas, define nodes and edges, and load data into a previous defined SPARKSEE schema.

Check out the 'Scripting' chapter in the SPARKSEE User Manual for a comprehensive explanation on the grammar of the SPARKSEE commands and how they work.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

static void ScriptParser::GenerateSchemaScript | ( | const std::wstring & | path,
 |  | sparksee::gdb::Database & | db
 | ) |  | throw (sparksee::gdb::IOException)
 static

Writes an script with the schema definition for the given database.

Parameters
path | [in] Filename of the script to be writen.
db | [in] Database.
Exceptions
IOException If bad things happen opening or writing the file.
sparksee::gdb::bool_t ScriptParser::Parse | ( | sparksee_core::FileReader * | fileReader,
 |  | sparksee::gdb::bool_t | execute
 | ) |  |

Parser the given input stream.

Parameters
fileReader | [in] Input file reader.
execute | [in] If TRUE the script is executed, if FALSE it is just parsed.
Returns
TRUE if ok, FALSE in case of error.
sparksee::gdb::bool_t ScriptParser::Parse | ( | const std::wstring & | path,
 |  | sparksee::gdb::bool_t | execute,
 |  | const std::wstring & | localeStr
 | ) |  | throw (sparksee::gdb::IOException)

Parses the given input file.

Parameters
path | [in] Input file path.
execute | [in] If TRUE the script is executed, if FALSE it is just parsed.
localeStr | [in] The locale string for reading the input file. See CSVReader.
Returns
TRUE if ok, FALSE in case of error.
Exceptions
IOException If bad things happen opening the file.
void ScriptParser::SetErrorLog ( const std::wstring & path ) throw (sparksee::gdb::IOException)

Sets the error log.

If not set, error log corresponds to standard error output.

Parameters
path [in] Path of the error log.
Exceptions
IOException If bad things happen opening the file.
void ScriptParser::SetOutputLog ( const std::wstring & path ) throw (sparksee::gdb::IOException)

Sets the output log.

If not set, output log corresponds to standard output.

Parameters
path [in] Path of the output log.
Exceptions
IOException If bad things happen opening the file.
The documentation for this class was generated from the following file:
  • ScriptParser.h


Sparksee: Algorithms

Files | Classes | Functions
Algorithms
Collaboration diagram for Algorithms:

Files

file | CommunitiesSCD.h
It contains the definition of CommunitiesSCD class.
file | CommunityDetection.h
It contains the definition of CommunityDetection class.
file | ConnectedComponents.h
It contains the definition of ConnectedComponents class.
file | Connectivity.h
It contains the definition of Connectivity class.
file | Context.h
It contains the definition of Context class.
file | DisjointCommunities.h
It contains the definition of DisjointCommunities class.
file | DisjointCommunityDetection.h
It contains the definition of DisjointCommunityDetection class.
file | KOpt.h
It contains the definition of KOpt class.
file | PageRank.h
It contains the definition of PageRank class.
file | RandomWalk.h
It contains the definition of RandomWalk class.
file | ShortestPath.h
It contains the definition of ShortestPath class.
file | SinglePairShortestPath.h
It contains the definition of SinglePairShortestPath class.
file | SinglePairShortestPathBFS.h
It contains the definition of SinglePairShortestPathBFS class.
file | SinglePairShortestPathDijkstra.h
It contains the definition of SinglePairShortestPathDijkstra class.
file | StrongConnectivity.h
It contains the definition of StrongConnectivity class.
file | StrongConnectivityGabow.h
It contains the definition of StrongConnectivityGabow class.
file | Traversal.h
It contains the definition of Traversal class.
file | TraversalBFS.h
It contains the definition of TraversalBFS class.
file | TraversalDFS.h
It contains the definition of TraversalDFS class.
file | WeakConnectivity.h
It contains the definition of WeakConnectivity class.
file | WeakConnectivityDFS.h
It contains the definition of WeakConnectivityDFS class.

Classes

class | CommunitiesSCD
CommunitiesSCD class. More...
class | CommunityDetection
CommunityDetection class. More...
class | ConnectedComponents
ConnectedComponents class. More...
class | Connectivity
Connectivity class. More...
class | Context
Context class. More...
class | DisjointCommunities
DisjointCommunities class. More...
class | DisjointCommunityDetection
DisjointCommunityDetection class. More...
class | KOpt
KOpt class. More...
class | PageRank
PageRank class. More...
class | RandomWalk
RandomWalk class. More...
class | ShortestPath
ShortestPath class. More...
class | SinglePairShortestPath
SinglePairShortestPath class. More...
class | SinglePairShortestPathBFS
SinglePairShortestPathBFS class. More...
class | SinglePairShortestPathDijkstraDynamicCost
Defines how to calculate an edge weight. More...
class | SinglePairShortestPathDijkstra
SinglePairShortestPathDijkstra class. More...
struct | SinglePairShortestPathDijkstra::FibonacciHeap::Node
A FibonacciHeap node structure. More...
class | StrongConnectivity
StrongConnectivity class. More...
class | StrongConnectivityGabow
This class can be used to solve the problem of finding strongly connected components in a directed graph. More...
class | Traversal
Traversal class. More...
class | TraversalBFS
Breadth-First Search implementation of Traversal. More...
class | TraversalDFS
Depth-First Search (DFS) implementation of Traversal. More...
class | WeakConnectivity
WeakConnectivity class. More...
class | WeakConnectivityDFS
WeakConnectivityDFS class. More...

Functions

KOpt::KOpt (sparksee::gdb::Session &session)
Creates a new instance.
KOpt::KOpt (sparksee::gdb::Session &session, sparksee::gdb::OIDList &tour)
Creates a new instance.
virtual | KOpt::~KOpt ()
Destructor.
void | KOpt::AddNodeType (sparksee::gdb::type_t type) throw (sparksee::gdb::Error)
Allows for traversing nodes of the given type.
void | KOpt::AddAllNodeTypes ()
Allows for traversing all node types of the graph.
void | KOpt::AddEdgeType (sparksee::gdb::type_t type, sparksee::gdb::EdgesDirection dir) throw (sparksee::gdb::Error)
Allows for traversing edges of the given type.
void | KOpt::AddAllEdgeTypes (sparksee::gdb::EdgesDirection dir)
Allows for traversing all edge types of the graph.
void | KOpt::SetEdgeWeightAttributeType (sparksee::gdb::attr_t attr) throw (sparksee::gdb::Error)
Sets the attribute to use as edge weight.
double | KOpt::GetCurrentCost () const
Returns tour cost.
sparksee::gdb::OIDList * | KOpt::GetCurrentTour ()
Returns tour as a list of nodes.
void | KOpt::SetCurrentTour (sparksee::gdb::OIDList &tour)
Sets current tour as a list of nodes.
void | KOpt::SetMaxIterations (sparksee::gdb::int64_t maxIterations)
Sets maximum number of iterations.
void | KOpt::SetTimeLimit (sparksee::gdb::int64_t maxTime)
Limits execution time.
void | KOpt::RunTwoOpt ()
Runs 2-Opt local search.
void | KOpt::RunThreeOpt ()
Runs 3-Opt local search.

Detailed Description

Function Documentation

void KOpt::AddAllEdgeTypes ( sparksee::gdb::EdgesDirection dir )

Allows for traversing all edge types of the graph.

Parameters
dir [in] Edge direction.
void KOpt::AddEdgeType | ( | sparksee::gdb::type_t | type,
 |  | sparksee::gdb::EdgesDirection | dir
 | ) |  | throw (sparksee::gdb::Error)

Allows for traversing edges of the given type.

If the edge type was already added, the existing direction is overwritten

Parameters
type | [in] Edge type.
dir | [in] Edge direction.
void KOpt::AddNodeType ( sparksee::gdb::type_t type ) throw (sparksee::gdb::Error)

Allows for traversing nodes of the given type.

Parameters
type [in] Node type.
Exceptions
sparksee::gdb::Error
KOpt::KOpt ( sparksee::gdb::Session & session )
explicit

Creates a new instance.

Parameters
session [in] Session to get the graph from and perform algorithm.
KOpt::KOpt | ( | sparksee::gdb::Session & | session,
 |  | sparksee::gdb::OIDList & | tour
 | ) |  |

Creates a new instance.

Parameters
session | [in] Session to get the graph from and perform algorithm.
tour | [in] Initial tour that needs to be improved.
void KOpt::SetCurrentTour ( sparksee::gdb::OIDList & tour )

Sets current tour as a list of nodes.

Parameters
tour [in] Initial tour that needs to be improved.
void KOpt::SetEdgeWeightAttributeType ( sparksee::gdb::attr_t attr ) throw (sparksee::gdb::Error)

Sets the attribute to use as edge weight.

If the multiple edge are set for traversal, this attribute must be of type GLOBAL_TYPE or EDGES_TYPE. Additionally, the attribute must be of type Double.

Parameters
attr [in] The attribute type to use as a weight. Default: InvalidAttribute
Exceptions
sparksee::gdb::Error
void KOpt::SetMaxIterations ( sparksee::gdb::int64_t maxIterations )

Sets maximum number of iterations.

By default the algorithm will run until no improvement can be made in the current tour.

Parameters
maxIterations [in] Maximum number of iterations
void KOpt::SetTimeLimit ( sparksee::gdb::int64_t maxTime )

Limits execution time.

Parameters
maxTime [in] Time limit in miliseconds
Generated on Thu Feb 24 2022 12:56:05 for Sparksee by doxygen 1.8.2


Sparksee: CommunitiesSCD Class Reference

Public Member Functions | Protected Types | Protected Member Functions | Protected Attributes | List of all members
CommunitiesSCD Class Reference
Algorithms

CommunitiesSCD class. More...

Inheritance diagram for CommunitiesSCD:
Collaboration diagram for CommunitiesSCD:

Public Member Functions

CommunitiesSCD (sparksee::gdb::Session &session)
Creates a new instance of CommunitiesSCD.
virtual | ~CommunitiesSCD ()
Destructor.
void | SetLookAhead (sparksee::gdb::int32_t lookahead)
Sets the size of the lookahead iterations to look (5 by default).
void | Run ()
Executes the algorithm.
virtual void | AddEdgeType (sparksee::gdb::type_t type)
Allows connectivity through edges of the given type.
virtual void | AddAllEdgeTypes ()
Allows connectivity through all edge types of the graph.
DisjointCommunities * GetCommunities ()
Returns the results generated by the execution of the algorithm.
void | SetMaterializedAttribute (const std::wstring &attributeName)
Creates a new common attribute type for all node types in the graph in order to store, persistently, the results related to the disjoint communities found while executing this algorithm.
virtual void | AddNodeType (sparksee::gdb::type_t type)
Allows connectivity through nodes of the given type.
virtual void | AddAllNodeTypes ()
Allows connectivity through all node types of the graph.
virtual void | ExcludeNodes (sparksee::gdb::Objects &nodes)
Set which nodes can't be used.
virtual void | ExcludeEdges (sparksee::gdb::Objects &edges)
Set which edges can't be used.
virtual void | IncludeNodes (sparksee::gdb::Objects &nodes)
Set additional nodes that can be used.
virtual void | IncludeEdges (sparksee::gdb::Objects &edges)
Set additional edges that can be used.

Protected Types

typedef std::map
< sparksee::gdb::type_t,
sparksee::gdb::EdgesDirection > 		EdgeTypes_t
A type definition to store allowed edge types.
typedef std::vector
< sparksee::gdb::type_t > 		NodeTypes_t
A type definition to store allowed node types.

Protected Member Functions

void | AddEdgeType (sparksee::gdb::type_t type, sparksee::gdb::EdgesDirection direction)
Allows connectivity through edges of the given type.
void | AddAllEdgeTypes (sparksee::gdb::EdgesDirection direction)
Allows connectivity through all edge types of the graph.
void | SetCommunity (sparksee::gdb::oid_t idNode)
Assigns the current community to the given node.
void | AssertNotCommunityAttribute (const std::wstring &attributeName)
Check that the given attribute name is not already in use.
void | CreateGlobalPersistentAttribute (const std::wstring &attributeName)
Set a new persistent global attribute to store the disjoint communities information.
void | CreateGlobalTransientAttribute ()
Set a new temporary global attribute to store the disjoint communities information.
void | RemoveGlobalAttribute ()
Removes the global attribute where the disjoint communities information is stored.
void | AssertAddedEdges ()
Check that edges had been added.
void | AssertAddedNodes ()
Check that nodes had been added.
void | AssertNotComputed ()
Check that the connectivity had not been calculated yet.
void | SetNodesNotVisited ()
Set all the selected nodes in nodesNotVisited.
void | AssertComputed ()
Check that the communities had been calculated.
void | AssertEdgeType (sparksee::gdb::type_t edgetype)
Check that the given edge type is valid.
void | AssertNodeType (sparksee::gdb::type_t nodetype)
Check that the given node type is valid.
sparksee::gdb::bool_t | IsNodeTypeAllowed (sparksee::gdb::oid_t nodeId)
Check if the given node has an allowed type.
sparksee::gdb::bool_t | IsEdgeTypeAllowed (sparksee::gdb::oid_t edgeId)
Check if the given edge has an allowed type.
sparksee::gdb::bool_t | IsNodeAllowed (sparksee::gdb::oid_t nodeId)
Check if the given node is allowed (by type or by explicit inclusion).
sparksee::gdb::bool_t | IsEdgeAllowed (sparksee::gdb::oid_t edgeId)
Check if the given edge is allowed (by type or by explicit inclusion).
sparksee::gdb::bool_t | IsNodeExcluded (sparksee::gdb::oid_t node)
Check if the given node is forbidden.
sparksee::gdb::bool_t | IsEdgeExcluded (sparksee::gdb::oid_t edge)
Check if the given edge is forbidden.
sparksee::gdb::bool_t | IsNodeIncluded (sparksee::gdb::oid_t node)
Check if the given node is EXPLICITLY allowed using the include set.
sparksee::gdb::bool_t | IsEdgeIncluded (sparksee::gdb::oid_t edge)
Check if the given edge is EXPLICITLY allowed using the include set.

Protected Attributes

sparksee::gdb::attr_t attrCommunity
common attribute where the connected component information is stored.
std::wstring | attrCommunityName
name of the common attribute where the connected component information is stored.
sparksee::gdb::int64_t actualCommunity
Current community identifier.
sparksee::gdb::bool_t matResults
Materialized results.
DisjointCommunities * dcs
The calculated communities information.
sparksee::gdb::Session * | sess
Session.
sparksee::gdb::Graph * | graph
Graph.
EdgeTypes_t edgeTypes
Allowed edge types.
std::vector
< sparksee::gdb::type_t > 		nodeTypes
Allowed node types.
sparksee::gdb::Objects * | nodesNotVisited
Identifiers of the nodes not visited.
sparksee::gdb::bool_t computed
True if the connectivity has been calculated.
sparksee::gdb::Objects * | excludedNodes
The set of excluded nodes.
sparksee::gdb::Objects * | excludedEdges
The set of excluded edges.
sparksee::gdb::Objects * | includedNodes
The set of explicitly included nodes.
sparksee::gdb::Objects * | includedEdges
The set of explicitly included edges.

Detailed Description

CommunitiesSCD class.

Implementation of the community detection algorithm "Scalable Community Detection" based on the paper "High quality, scalable and parallel community detection for large real graphs" by Arnau Prat-Perez, David Dominguez-Sal, Josep-Lluis Larriba-Pey - WWW 2014.

The purpose of this algorithm is to find disjoint communities in an undirected graph or in a directed graph which will be considered as an undirected one.

It is possible to set some restrictions after constructing a new instance of this class and before running it in order to limit the results.

After the execution, we can retrieve the results stored in an instance of the DisjointCommunities class using the getCommunities method.

Check out the 'Algorithms' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

CommunitiesSCD::CommunitiesSCD ( sparksee::gdb::Session & session )

Creates a new instance of CommunitiesSCD.

After creating this instance is required to indicate the set of edge types and the set of node types which will be navigated through while traversing the graph in order to find the communities.

Parameters
session [in] Session to get the graph from and calculate the communities

Member Function Documentation

virtual void DisjointCommunityDetection::AddAllEdgeTypes ( )
virtualinherited

Allows connectivity through all edge types of the graph.

The edges can be used in Any direction.

void CommunityDetection::AddAllEdgeTypes ( sparksee::gdb::EdgesDirection direction )
protectedinherited

Allows connectivity through all edge types of the graph.

Parameters
d [in] Edge direction.
virtual void DisjointCommunityDetection::AddEdgeType ( sparksee::gdb::type_t type )
virtualinherited

Allows connectivity through edges of the given type.

The edges can be used in Any direction.

Parameters
type [in] Edge type.
void CommunityDetection::AddEdgeType | ( | sparksee::gdb::type_t | type,
 |  | sparksee::gdb::EdgesDirection | direction
 | ) |  |
protectedinherited

Allows connectivity through edges of the given type.

Parameters
t | [in] Edge type.
d | [in] Edge direction.
virtual void CommunityDetection::ExcludeEdges ( sparksee::gdb::Objects & edges )
virtualinherited

Set which edges can't be used.

This will replace any previously specified set of excluded edges. Should only be used to exclude the usage of specific edges from allowed edge types because it's less efficient than not allowing an edge type.

Parameters
edges [in] A set of edge identifiers that must be kept intact until the destruction of the class.
virtual void CommunityDetection::ExcludeNodes ( sparksee::gdb::Objects & nodes )
virtualinherited

Set which nodes can't be used.

This will replace any previously specified set of excluded nodes. Should only be used to exclude the usage of specific nodes from allowed node types because it's less efficient than not allowing a node type.

Parameters
nodes [in] A set of node identifiers that must be kept intact until the destruction of the class.
DisjointCommunities* DisjointCommunityDetection::GetCommunities ( )
inherited

Returns the results generated by the execution of the algorithm.

These results contain information related to the disjoint communities found as the number of different components, the set of nodes contained in each component or many other data.

Returns
Returns an instance of the class DisjointCommunities which contain information related to the disjoint communities found.
virtual void CommunityDetection::IncludeEdges ( sparksee::gdb::Objects & edges )
virtualinherited

Set additional edges that can be used.

This will replace any previously specified set of include edges. Using this optional method adds valid edges to the edges of any edge type explicitly set as a valid type. Should only be used to include specific small sets of edges because it's less efficient than just using an edge type. For any edge to be used, both nodes must be also valid.

Parameters
edges [in] A set of edge identifiers that must be kept intact until the destruction of the class.
virtual void CommunityDetection::IncludeNodes ( sparksee::gdb::Objects & nodes )
virtualinherited

Set additional nodes that can be used.

This will replace any previously specified set of include nodes. Using this optional method adds valid nodes to the nodes of any node type explicitly set as a valid type. Should only be used to include specific small sets of nodes because it's less efficient than just using a node type.

Parameters
nodes [in] A set of node identifiers that must be kept intact until the destruction of the class.
void CommunitiesSCD::SetLookAhead ( sparksee::gdb::int32_t lookahead )

Sets the size of the lookahead iterations to look (5 by default).

Parameters
lookahead [in] Number of iterations. It must be positive or zero.
void DisjointCommunityDetection::SetMaterializedAttribute ( const std::wstring & attributeName )
inherited

Creates a new common attribute type for all node types in the graph in order to store, persistently, the results related to the disjoint communities found while executing this algorithm.

Whenever the user wants to retrieve the results, even when the graph has been closed and opened again, it is only necessary to create a new instance of the class DisjointCommunities indicating the graph and the name of the common attribute type which stores the results. This instance will have all the information related to the disjoint communities found in the moment of the execution of the algorithm that stored this data.

It is possible to run the algorithm without specifying this parameter in order to avoid materializing the results of the execution.

Parameters
attributeName [in] The name of the common attribute type for all node types in the graph which will store persistently the results generated by the execution of the algorithm.
void CommunityDetection::SetNodesNotVisited ( )
protectedinherited

Set all the selected nodes in nodesNotVisited.

That's all the nodes of the allowed node types but not the excluded ones.

The documentation for this class was generated from the following file:
  • CommunitiesSCD.h
Generated on Thu Feb 24 2022 12:56:05 for Sparksee by doxygen 1.8.2


Sparksee: CommunityDetection Class Reference

Public Member Functions | Protected Types | Protected Member Functions | Protected Attributes | List of all members
CommunityDetection Class Referenceabstract
Algorithms

CommunityDetection class. More...

Inheritance diagram for CommunityDetection:

Public Member Functions

virtual | ~CommunityDetection ()
Destructor.
virtual void | AddNodeType (sparksee::gdb::type_t type)
Allows connectivity through nodes of the given type.
virtual void | AddAllNodeTypes ()
Allows connectivity through all node types of the graph.
virtual void | ExcludeNodes (sparksee::gdb::Objects &nodes)
Set which nodes can't be used.
virtual void | ExcludeEdges (sparksee::gdb::Objects &edges)
Set which edges can't be used.
virtual void | IncludeNodes (sparksee::gdb::Objects &nodes)
Set additional nodes that can be used.
virtual void | IncludeEdges (sparksee::gdb::Objects &edges)
Set additional edges that can be used.
virtual void | Run ()=0
Runs the algorithm in order to find the connected components.

Protected Types

typedef std::map
< sparksee::gdb::type_t,
sparksee::gdb::EdgesDirection > 		EdgeTypes_t
A type definition to store allowed edge types.
typedef std::vector
< sparksee::gdb::type_t > 		NodeTypes_t
A type definition to store allowed node types.

Protected Member Functions

CommunityDetection (sparksee::gdb::Session &s)
Creates a new instance of CommunityDetection.
void | AddEdgeType (sparksee::gdb::type_t type, sparksee::gdb::EdgesDirection direction)
Allows connectivity through edges of the given type.
void | AddAllEdgeTypes (sparksee::gdb::EdgesDirection direction)
Allows connectivity through all edge types of the graph.
void | AssertAddedEdges ()
Check that edges had been added.
void | AssertAddedNodes ()
Check that nodes had been added.
void | AssertNotComputed ()
Check that the connectivity had not been calculated yet.
void | SetNodesNotVisited ()
Set all the selected nodes in nodesNotVisited.
void | AssertComputed ()
Check that the communities had been calculated.
void | AssertEdgeType (sparksee::gdb::type_t edgetype)
Check that the given edge type is valid.
void | AssertNodeType (sparksee::gdb::type_t nodetype)
Check that the given node type is valid.
sparksee::gdb::bool_t | IsNodeTypeAllowed (sparksee::gdb::oid_t nodeId)
Check if the given node has an allowed type.
sparksee::gdb::bool_t | IsEdgeTypeAllowed (sparksee::gdb::oid_t edgeId)
Check if the given edge has an allowed type.
sparksee::gdb::bool_t | IsNodeAllowed (sparksee::gdb::oid_t nodeId)
Check if the given node is allowed (by type or by explicit inclusion).
sparksee::gdb::bool_t | IsEdgeAllowed (sparksee::gdb::oid_t edgeId)
Check if the given edge is allowed (by type or by explicit inclusion).
sparksee::gdb::bool_t | IsNodeExcluded (sparksee::gdb::oid_t node)
Check if the given node is forbidden.
sparksee::gdb::bool_t | IsEdgeExcluded (sparksee::gdb::oid_t edge)
Check if the given edge is forbidden.
sparksee::gdb::bool_t | IsNodeIncluded (sparksee::gdb::oid_t node)
Check if the given node is EXPLICITLY allowed using the include set.
sparksee::gdb::bool_t | IsEdgeIncluded (sparksee::gdb::oid_t edge)
Check if the given edge is EXPLICITLY allowed using the include set.

Protected Attributes

sparksee::gdb::Session * | sess
Session.
sparksee::gdb::Graph * | graph
Graph.
EdgeTypes_t edgeTypes
Allowed edge types.
std::vector
< sparksee::gdb::type_t > 		nodeTypes
Allowed node types.
sparksee::gdb::Objects * | nodesNotVisited
Identifiers of the nodes not visited.
sparksee::gdb::bool_t computed
True if the connectivity has been calculated.
sparksee::gdb::Objects * | excludedNodes
The set of excluded nodes.
sparksee::gdb::Objects * | excludedEdges
The set of excluded edges.
sparksee::gdb::Objects * | includedNodes
The set of explicitly included nodes.
sparksee::gdb::Objects * | includedEdges
The set of explicitly included edges.

Detailed Description

CommunityDetection class.

Any class implementing this abstract class can be used to solve a problem related to graph connectivity as finding the strongly connected components, finding the weakly connected components.

Check out the 'Algorithms' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

CommunityDetection::CommunityDetection ( sparksee::gdb::Session & s )
protected

Creates a new instance of CommunityDetection.

Parameters
s [in] Session to get the graph from and calculate the communities

Member Function Documentation

void CommunityDetection::AddAllEdgeTypes ( sparksee::gdb::EdgesDirection direction )
protected

Allows connectivity through all edge types of the graph.

Parameters
d [in] Edge direction.
void CommunityDetection::AddEdgeType | ( | sparksee::gdb::type_t | type,
 |  | sparksee::gdb::EdgesDirection | direction
 | ) |  |
protected

Allows connectivity through edges of the given type.

Parameters
t | [in] Edge type.
d | [in] Edge direction.
virtual void CommunityDetection::ExcludeEdges ( sparksee::gdb::Objects & edges )
virtual

Set which edges can't be used.

This will replace any previously specified set of excluded edges. Should only be used to exclude the usage of specific edges from allowed edge types because it's less efficient than not allowing an edge type.

Parameters
edges [in] A set of edge identifiers that must be kept intact until the destruction of the class.
virtual void CommunityDetection::ExcludeNodes ( sparksee::gdb::Objects & nodes )
virtual

Set which nodes can't be used.

This will replace any previously specified set of excluded nodes. Should only be used to exclude the usage of specific nodes from allowed node types because it's less efficient than not allowing a node type.

Parameters
nodes [in] A set of node identifiers that must be kept intact until the destruction of the class.
virtual void CommunityDetection::IncludeEdges ( sparksee::gdb::Objects & edges )
virtual

Set additional edges that can be used.

This will replace any previously specified set of include edges. Using this optional method adds valid edges to the edges of any edge type explicitly set as a valid type. Should only be used to include specific small sets of edges because it's less efficient than just using an edge type. For any edge to be used, both nodes must be also valid.

Parameters
edges [in] A set of edge identifiers that must be kept intact until the destruction of the class.
virtual void CommunityDetection::IncludeNodes ( sparksee::gdb::Objects & nodes )
virtual

Set additional nodes that can be used.

This will replace any previously specified set of include nodes. Using this optional method adds valid nodes to the nodes of any node type explicitly set as a valid type. Should only be used to include specific small sets of nodes because it's less efficient than just using a node type.

Parameters
nodes [in] A set of node identifiers that must be kept intact until the destruction of the class.
virtual void CommunityDetection::Run ( )
pure virtual

Runs the algorithm in order to find the connected components.

This method can be called only once.

Implemented in DisjointCommunityDetection, and CommunitiesSCD.

void CommunityDetection::SetNodesNotVisited ( )
protected

Set all the selected nodes in nodesNotVisited.

That's all the nodes of the allowed node types but not the excluded ones.

The documentation for this class was generated from the following file:
  • CommunityDetection.h
Generated on Thu Feb 24 2022 12:56:05 for Sparksee by doxygen 1.8.2


Sparksee: ConnectedComponents Class Reference

Public Member Functions | List of all members
ConnectedComponents Class Reference
Algorithms

ConnectedComponents class. More...

Public Member Functions

ConnectedComponents (sparksee::gdb::Session &s, const std::wstring &materializedattribute)
Creates a new instance of ConnectedComponents.
virtual | ~ConnectedComponents ()
Destructor.
sparksee::gdb::int64_t | GetConnectedComponent (sparksee::gdb::oid_t idNode)
Returns the connected component where the given node belongs to.
sparksee::gdb::int64_t GetCount ()
Returns the number of connected components found in the graph.
sparksee::gdb::Objects * | GetNodes (sparksee::gdb::int64_t idConnectedComponent)
Returns the collection of nodes contained in the given connected component.
sparksee::gdb::int64_t | GetSize (sparksee::gdb::int64_t idConnectedComponent)
Returns the number of nodes contained in the given connected component.

Detailed Description

ConnectedComponents class.

This class contains the results processed on a Connectivity algorithm.

These results contain information related to the connected components found. We must consider that each connected component has a number in order to identify it. These number identifiers are values from 0 to N-1, where N is the number of different connected components found.

When executing any implementation of the Connectivity, it is possible to indicate whether the results of the execution must be stored persistently using the class Connectivity setMaterializedAttribute method. In case the results are set to be materialized, users can retrieve this data whenever they want, even if the graph has been closed and opened again, just by creating a new instance of this class.

Check out the 'Algorithms' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

ConnectedComponents::ConnectedComponents | ( | sparksee::gdb::Session & | s,
 |  | const std::wstring & | materializedattribute
 | ) |  |

Creates a new instance of ConnectedComponents.

This constructor method can only be called when a previous execution of any implementation of the Connectivity class has materialized the results in a common attribute type for all the nodes in the graph. For further information about materializing the results processed on any Connectivity execution see the documentation of the Connectivity#SetMaterializedAttribute method.

Parameters
s | [in] Session to get the graph Graph on which the information will be retrieved just by getting the values contained in the given common attribute type for all the nodes in the graph and processing them.
materializedattribute | [in] The common attribute type for all the nodes in the graph where data will be retrieved in order to process the results related to the connected components found in the graph.

Member Function Documentation

sparksee::gdb::int64_t ConnectedComponents::GetConnectedComponent ( sparksee::gdb::oid_t idNode )

Returns the connected component where the given node belongs to.

Parameters
idNode [in] The node identifier for which the connected component identifier where it belongs will be returned.
Returns
The connected component identifier where the given node identifier belongs to.
sparksee::gdb::int64_t ConnectedComponents::GetCount ( )

Returns the number of connected components found in the graph.

Returns
The number of connected components found in the graph.
sparksee::gdb::Objects* ConnectedComponents::GetNodes ( sparksee::gdb::int64_t idConnectedComponent )

Returns the collection of nodes contained in the given connected component.

Parameters
[in] idConnectedComponent The connected component for which the collection of nodes contained in it will be returned.
Returns
The collection of node identifiers contained in the given connected component.
sparksee::gdb::int64_t ConnectedComponents::GetSize ( sparksee::gdb::int64_t idConnectedComponent )

Returns the number of nodes contained in the given connected component.

Parameters
[in] idConnectedComponent The connected component for which the number of nodes contained in it will be returned.
Returns
The number of nodes contained in the given connected component.
The documentation for this class was generated from the following file:
  • ConnectedComponents.h
Generated on Thu Feb 24 2022 12:56:05 for Sparksee by doxygen 1.8.2


Sparksee: Connectivity Class Reference

Public Member Functions | Protected Types | Protected Member Functions | Protected Attributes | List of all members
Connectivity Class Referenceabstract
Algorithms

Connectivity class. More...

Inheritance diagram for Connectivity:
Collaboration diagram for Connectivity:

Public Member Functions

virtual | ~Connectivity ()
Destructor.
virtual void | AddNodeType (sparksee::gdb::type_t t)
Allows connectivity through nodes of the given type.
virtual void | AddAllNodeTypes ()
Allows connectivity through all node types of the graph.
virtual void | ExcludeNodes (sparksee::gdb::Objects &nodes)
Set which nodes can't be used.
virtual void | ExcludeEdges (sparksee::gdb::Objects &edges)
Set which edges can't be used.
ConnectedComponents * GetConnectedComponents ()
Returns the results generated by the execution of the algorithm.
virtual void | Run ()=0
Runs the algorithm in order to find the connected components.
void | SetMaterializedAttribute (const std::wstring &attributeName)
Creates a new common attribute type for all node types in the graph in order to store, persistently, the results related to the connected components found while executing this algorithm.

Protected Types

typedef std::map
< sparksee::gdb::type_t,
sparksee::gdb::EdgesDirection > 		EdgeTypes_t
A type definition to store allowed edge types.
typedef std::vector
< sparksee::gdb::type_t > 		NodeTypes_t
A type definition to store allowed node types.

Protected Member Functions

Connectivity (sparksee::gdb::Session &s)
Creates a new instance of Connectivity.
void | AddEdgeType (sparksee::gdb::type_t t, sparksee::gdb::EdgesDirection d)
Allows connectivity through edges of the given type.
void | AddAllEdgeTypes (sparksee::gdb::EdgesDirection d)
Allows connectivity through all edge types of the graph.
void | AssertAddedEdges ()
Check that edges had been added.
void | AssertAddedNodes ()
Check that nodes had been added.
void | AssertNotComputed ()
Check that the connectivity had not been calculated yet.
void | SetConnectedComponent (sparksee::gdb::oid_t idNode)
Assigns the current component to the given node.
void | SetNodesNotVisited ()
Set all the selected nodes in nodesNotVisited.
void | AssertNotComponentAttribute (const std::wstring &attributeName)
Check that the given attribute name is not already in use.
void | AssertComputed ()
Check that the connectivity had been calculated.
void | AssertEdgeType (sparksee::gdb::type_t edgetype)
Check that the given edge type is valid.
void | AssertNodeType (sparksee::gdb::type_t nodetype)
Check that the given node type is valid.
void | CreateGlobalPersistentAttribute (const std::wstring &attributeName)
Set a new persistent global attribute to store the connectivity information.
void | CreateGlobalTransientAttribute ()
Set a new temporary global attribute to store the connectivity information.
void | RemoveGlobalAttribute ()
Removes the global attribute where the connectivity information is stored.
sparksee::gdb::bool_t | IsNodeTypeAllowed (sparksee::gdb::oid_t nodeId)
Check if the given node has an allowed type.
sparksee::gdb::bool_t | IsNodeExcluded (sparksee::gdb::oid_t node)
Check if the given node is forbidden.
sparksee::gdb::bool_t | IsEdgeExcluded (sparksee::gdb::oid_t edge)
Check if the given edge is forbidden.

Protected Attributes

sparksee::gdb::Session * | sess
Session.
sparksee::gdb::Graph * | graph
Graph.
EdgeTypes_t edgeTypes
Allowed edge types.
std::vector
< sparksee::gdb::type_t > 		nodeTypes
Allowed node types.
sparksee::gdb::attr_t attrComponent
common attribute where the connected component information is stored.
std::wstring | attrComponentName
name of the common attribute where the connected component information is stored.
sparksee::gdb::int64_t actualComponent
Current component identifier.
sparksee::gdb::Objects * | nodesNotVisited
Identifiers of the nodes not visited.
sparksee::gdb::bool_t matResults
Materialized results.
sparksee::gdb::bool_t computed
True if the connectivity has been calculated.
sparksee::gdb::Objects * | excludedNodes
The set of excluded nodes.
sparksee::gdb::Objects * | excludedEdges
The set of excluded edges.
ConnectedComponents * ccs
The calculated connectivity information.

Detailed Description

Connectivity class.

Any class implementing this abstract class can be used to solve a problem related to graph connectivity as finding the strongly connected components, finding the weakly connected components.

Check out the 'Algorithms' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

Connectivity::Connectivity ( sparksee::gdb::Session & s )
protected

Creates a new instance of Connectivity.

Parameters
s [in] Session to get the graph from and calculate the connectivity

Member Function Documentation

void Connectivity::AddAllEdgeTypes ( sparksee::gdb::EdgesDirection d )
protected

Allows connectivity through all edge types of the graph.

Parameters
d [in] Edge direction.
void Connectivity::AddEdgeType | ( | sparksee::gdb::type_t | t,
 |  | sparksee::gdb::EdgesDirection | d
 | ) |  |
protected

Allows connectivity through edges of the given type.

Parameters
t | [in] Edge type.
d | [in] Edge direction.
virtual void Connectivity::ExcludeEdges ( sparksee::gdb::Objects & edges )
virtual

Set which edges can't be used.

This will replace any previously specified set of excluded edges. Should only be used to exclude the usage of specific edges from allowed edge types because it's less efficient than not allowing an edge type.

Parameters
edges [in] A set of edge identifiers that must be kept intact until the destruction of the class.
virtual void Connectivity::ExcludeNodes ( sparksee::gdb::Objects & nodes )
virtual

Set which nodes can't be used.

This will replace any previously specified set of excluded nodes. Should only be used to exclude the usage of specific nodes from allowed node types because it's less efficient than not allowing a node type.

Parameters
nodes [in] A set of node identifiers that must be kept intact until the destruction of the class.
ConnectedComponents* Connectivity::GetConnectedComponents ( )

Returns the results generated by the execution of the algorithm.

These results contain information related to the connected components found as the number of different components, the set of nodes contained in each component or many other data.

Returns
Returns an instance of the class ConnectedComponents which contain information related to the connected components found.
virtual void Connectivity::Run ( )
pure virtual

Runs the algorithm in order to find the connected components.

This method can be called only once.

Implemented in WeakConnectivityDFS, and StrongConnectivityGabow.

void Connectivity::SetMaterializedAttribute ( const std::wstring & attributeName )

Creates a new common attribute type for all node types in the graph in order to store, persistently, the results related to the connected components found while executing this algorithm.

Whenever the user wants to retrieve the results, even when the graph has been closed and opened again, it is only necessary to create a new instance of the class ConnectedComponents indicating the graph and the name of the common attribute type which stores the results. This instance will have all the information related to the connected components found in the moment of the execution of the algorithm that stored this data.

It is possible to run the algorithm without specifying this parameter in order to avoid materializing the results of the execution.

Parameters
attributeName [in] The name of the common attribute type for all node types in the graph which will store persistently the results generated by the execution of the algorithm.
void Connectivity::SetNodesNotVisited ( )
protected

Set all the selected nodes in nodesNotVisited.

That's all the nodes of the allowed node types but not the excluded ones.

The documentation for this class was generated from the following file:
  • Connectivity.h


Sparksee: Context Class Reference

Public Member Functions | Static Public Member Functions | Protected Attributes | List of all members
Context Class Reference
Algorithms

Context class. More...

Public Member Functions

void | AddEdgeType (sparksee::gdb::type_t t, sparksee::gdb::EdgesDirection d)
Allows for traversing edges of the given type.
void | AddAllEdgeTypes (sparksee::gdb::EdgesDirection d)
Allows for traversing all edge types of the graph.
void | AddNodeType (sparksee::gdb::type_t t)
Allows for traversing nodes of the given type.
void | AddAllNodeTypes ()
Allows for traversing all node types of the graph.
void | ExcludeNodes (sparksee::gdb::Objects &nodes)
Set which nodes can't be used.
void | ExcludeEdges (sparksee::gdb::Objects &edges)
Set which edges can't be used.
sparksee::gdb::Objects * | Compute ()
Gets the resulting collection of nodes.
void | SetMaximumHops (sparksee::gdb::int32_t maxhops, sparksee::gdb::bool_t include)
Sets the maximum hops restriction.
virtual | ~Context ()
Destructor.
Context (sparksee::gdb::Session &session, sparksee::gdb::oid_t node)
Creates a new instance.

Static Public Member Functions

static sparksee::gdb::Objects * Compute (sparksee::gdb::Session &session, sparksee::gdb::oid_t node, sparksee::gdb::TypeList *nodeTypes, sparksee::gdb::TypeList *edgeTypes, sparksee::gdb::EdgesDirection dir, sparksee::gdb::int32_t maxhops, sparksee::gdb::bool_t include)
Helper method to easily compute a context from a node.

Protected Attributes

sparksee::gdb::Session * | sess
Session.
sparksee::gdb::Graph * | graph
Graph.
sparksee::gdb::oid_t src
Source node of the traversal.
std::map
< sparksee::gdb::type_t,
sparksee::gdb::EdgesDirection > 		edgeTypes
Allowed edge types.
std::vector
< sparksee::gdb::type_t > 		nodeTypes
Allowed node types.
sparksee::gdb::int32_t maxHops
Maximum number of hops allowed.
sparksee::gdb::bool_t inclusive
Include those nodes at distance <= maxhops or just those nodes at distance == maxhops.
sparksee::gdb::Objects * | excludedNodes
The set of excluded nodes.
sparksee::gdb::Objects * | excludedEdges
The set of excluded edges.

Detailed Description

Context class.

It provides a very similar functionality than the Traversal classes. The main difference is Context returns a resulting collection whereas Traversal provides an iterator behaviour.

Check out the 'Algorithms' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

Context::Context | ( | sparksee::gdb::Session & | session,
 |  | sparksee::gdb::oid_t | node
 | ) |  |

Creates a new instance.

Parameters
session | [in] Session to get the graph from and perform operation.
node | [in] Node to start traversal from.

Member Function Documentation

void Context::AddAllEdgeTypes ( sparksee::gdb::EdgesDirection d )

Allows for traversing all edge types of the graph.

Parameters
d [in] Edge direction.
void Context::AddEdgeType | ( | sparksee::gdb::type_t | t,
 |  | sparksee::gdb::EdgesDirection | d
 | ) |  |

Allows for traversing edges of the given type.

Parameters
t | [in] Edge type.
d | [in] Edge direction.
sparksee::gdb::Objects* Context::Compute ( )

Gets the resulting collection of nodes.

Returns
The resulting collection of nodes.
static sparksee::gdb::Objects* Context::Compute | ( | sparksee::gdb::Session & | session,
 |  | sparksee::gdb::oid_t | node,
 |  | sparksee::gdb::TypeList * | nodeTypes,
 |  | sparksee::gdb::TypeList * | edgeTypes,
 |  | sparksee::gdb::EdgesDirection | dir,
 |  | sparksee::gdb::int32_t | maxhops,
 |  | sparksee::gdb::bool_t | include
 | ) |  |
static

Helper method to easily compute a context from a node.

Parameters
session | [in] Session to get the graph from and perform operation.
node | [in] Node to start traversal from.
nodeTypes | [in] Allowed node type list. NULL means all node types are allowed.
edgeTypes | [in] Allowed edge type list. NULL means all edge types are allowed.
dir | [in] Allowed direction for the allowed edge types.
maxhops | [in] The maximum hops restriction. It must be positive or zero. Zero, the default value, means unlimited.
include | [in] If TRUE, the resulting collection will include those nodes at distance less or equal than the given one, otherwise it will just include those nodes at distance equal than the given one. This parameter just makes sense if maxhops is different from 0; in that case it includes all nodes no matters the distance.
Returns
Returns an Objects with the computed context of a node.
void Context::ExcludeEdges ( sparksee::gdb::Objects & edges )

Set which edges can't be used.

This will replace any previously specified set of excluded edges. Should only be used to exclude the usage of specific edges from allowed edge types because it's less efficient than not allowing an edge type.

Parameters
edges [in] A set of edge identifiers that must be kept intact until the destruction of the class.
void Context::ExcludeNodes ( sparksee::gdb::Objects & nodes )

Set which nodes can't be used.

This will replace any previously specified set of excluded nodes. Should only be used to exclude the usage of specific nodes from allowed node types because it's less efficient than not allowing a node type.

Parameters
nodes [in] A set of node identifiers that must be kept intact until the destruction of the class.
void Context::SetMaximumHops | ( | sparksee::gdb::int32_t | maxhops,
 |  | sparksee::gdb::bool_t | include
 | ) |  |

Sets the maximum hops restriction.

All paths longer than the maximum hops restriction will be ignored.

Parameters
maxhops | [in] The maximum hops restriction. It must be positive or zero. Zero, the default value, means unlimited.
include | [in] If TRUE, the resulting collection will include those nodes at distance less or equal than the given one, otherwise it will just include those nodes at distance equal than the given one. This parameter just makes sense if maxhops is different from 0; in that case it includes all nodes no matters the distance.
The documentation for this class was generated from the following file:
  • Context.h


Sparksee: DisjointCommunities Class Reference

Public Member Functions | List of all members
DisjointCommunities Class Reference
Algorithms

DisjointCommunities class. More...

Public Member Functions

DisjointCommunities (sparksee::gdb::Session &session, const std::wstring &materializedattribute)
Creates a new instance of DisjointCommunities.
virtual | ~DisjointCommunities ()
Destructor.
sparksee::gdb::int64_t | GetCommunity (sparksee::gdb::oid_t idNode)
Returns the disjoint community where the given node belongs to.
sparksee::gdb::int64_t GetCount ()
Returns the number of communities found in the graph.
sparksee::gdb::Objects * | GetNodes (sparksee::gdb::int64_t idCommunity)
Returns the collection of nodes contained in the given community.
sparksee::gdb::int64_t | GetSize (sparksee::gdb::int64_t idCommunity)
Returns the number of nodes contained in the given community.

Detailed Description

DisjointCommunities class.

This class contains the results processed on a DisjointCommunityDetection algorithm.

These results contain information related to the communities found. We must consider that each community has a number in order to identify it. These number identifiers are values from 0 to N-1, where N is the number of different communities found.

When executing any implementation of the DisjointCommunityDetection, it is possible to indicate whether the results of the execution must be stored persistently using the class DisjointCommunityDetection setMaterializedAttribute method. In case the results are set to be materialized, users can retrieve this data whenever they want, even if the graph has been closed and opened again, just by creating a new instance of this class.

Check out the 'Algorithms' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

DisjointCommunities::DisjointCommunities | ( | sparksee::gdb::Session & | session,
 |  | const std::wstring & | materializedattribute
 | ) |  |

Creates a new instance of DisjointCommunities.

This constructor method can only be called when a previous execution of any implementation of the DisjointCommunityDetection class has materialized the results in a common attribute type for all the nodes in the graph. For further information about materializing the results processed on any DisjointCommunityDetection execution see the documentation of the DisjointCommunityDetection#SetMaterializedAttribute method.

Parameters
session | [in] Session to get the graph Graph on which the information will be retrieved just by getting the values contained in the given common attribute type for all the nodes in the graph and processing them.
materializedattribute | [in] The common attribute type for all the nodes in the graph where data will be retrieved in order to process the results related to the communities found in the graph.

Member Function Documentation

sparksee::gdb::int64_t DisjointCommunities::GetCommunity ( sparksee::gdb::oid_t idNode )

Returns the disjoint community where the given node belongs to.

Parameters
idNode [in] The node identifier for which the disjoint community identifier where it belongs will be returned.
Returns
The disjoint community identifier where the given node identifier belongs to.
sparksee::gdb::int64_t DisjointCommunities::GetCount ( )

Returns the number of communities found in the graph.

Returns
The number of communities found in the graph.
sparksee::gdb::Objects* DisjointCommunities::GetNodes ( sparksee::gdb::int64_t idCommunity )

Returns the collection of nodes contained in the given community.

Parameters
[in] idCommunity The community for which the collection of nodes contained in it will be returned.
Returns
The collection of node identifiers contained in the given community.
sparksee::gdb::int64_t DisjointCommunities::GetSize ( sparksee::gdb::int64_t idCommunity )

Returns the number of nodes contained in the given community.

Parameters
[in] idCommunity The community for which the number of nodes contained in it will be returned.
Returns
The number of nodes contained in the given community.
The documentation for this class was generated from the following file:
  • DisjointCommunities.h


Sparksee: DisjointCommunityDetection Class Reference

Public Member Functions | Protected Types | Protected Member Functions | Protected Attributes | List of all members
DisjointCommunityDetection Class Referenceabstract
Algorithms

DisjointCommunityDetection class. More...

Inheritance diagram for DisjointCommunityDetection:
Collaboration diagram for DisjointCommunityDetection:

Public Member Functions

virtual | ~DisjointCommunityDetection ()
Destructor.
virtual void | AddEdgeType (sparksee::gdb::type_t type)
Allows connectivity through edges of the given type.
virtual void | AddAllEdgeTypes ()
Allows connectivity through all edge types of the graph.
DisjointCommunities * GetCommunities ()
Returns the results generated by the execution of the algorithm.
virtual void | Run ()=0
Runs the algorithm in order to find the communities.
void | SetMaterializedAttribute (const std::wstring &attributeName)
Creates a new common attribute type for all node types in the graph in order to store, persistently, the results related to the disjoint communities found while executing this algorithm.
virtual void | AddNodeType (sparksee::gdb::type_t type)
Allows connectivity through nodes of the given type.
virtual void | AddAllNodeTypes ()
Allows connectivity through all node types of the graph.
virtual void | ExcludeNodes (sparksee::gdb::Objects &nodes)
Set which nodes can't be used.
virtual void | ExcludeEdges (sparksee::gdb::Objects &edges)
Set which edges can't be used.
virtual void | IncludeNodes (sparksee::gdb::Objects &nodes)
Set additional nodes that can be used.
virtual void | IncludeEdges (sparksee::gdb::Objects &edges)
Set additional edges that can be used.

Protected Types

typedef std::map
< sparksee::gdb::type_t,
sparksee::gdb::EdgesDirection > 		EdgeTypes_t
A type definition to store allowed edge types.
typedef std::vector
< sparksee::gdb::type_t > 		NodeTypes_t
A type definition to store allowed node types.

Protected Member Functions

DisjointCommunityDetection (sparksee::gdb::Session &s)
Creates a new instance of DisjointCommunityDetection.
void | SetCommunity (sparksee::gdb::oid_t idNode)
Assigns the current community to the given node.
void | AssertNotCommunityAttribute (const std::wstring &attributeName)
Check that the given attribute name is not already in use.
void | CreateGlobalPersistentAttribute (const std::wstring &attributeName)
Set a new persistent global attribute to store the disjoint communities information.
void | CreateGlobalTransientAttribute ()
Set a new temporary global attribute to store the disjoint communities information.
void | RemoveGlobalAttribute ()
Removes the global attribute where the disjoint communities information is stored.
void | AddEdgeType (sparksee::gdb::type_t type, sparksee::gdb::EdgesDirection direction)
Allows connectivity through edges of the given type.
void | AddAllEdgeTypes (sparksee::gdb::EdgesDirection direction)
Allows connectivity through all edge types of the graph.
void | AssertAddedEdges ()
Check that edges had been added.
void | AssertAddedNodes ()
Check that nodes had been added.
void | AssertNotComputed ()
Check that the connectivity had not been calculated yet.
void | SetNodesNotVisited ()
Set all the selected nodes in nodesNotVisited.
void | AssertComputed ()
Check that the communities had been calculated.
void | AssertEdgeType (sparksee::gdb::type_t edgetype)
Check that the given edge type is valid.
void | AssertNodeType (sparksee::gdb::type_t nodetype)
Check that the given node type is valid.
sparksee::gdb::bool_t | IsNodeTypeAllowed (sparksee::gdb::oid_t nodeId)
Check if the given node has an allowed type.
sparksee::gdb::bool_t | IsEdgeTypeAllowed (sparksee::gdb::oid_t edgeId)
Check if the given edge has an allowed type.
sparksee::gdb::bool_t | IsNodeAllowed (sparksee::gdb::oid_t nodeId)
Check if the given node is allowed (by type or by explicit inclusion).
sparksee::gdb::bool_t | IsEdgeAllowed (sparksee::gdb::oid_t edgeId)
Check if the given edge is allowed (by type or by explicit inclusion).
sparksee::gdb::bool_t | IsNodeExcluded (sparksee::gdb::oid_t node)
Check if the given node is forbidden.
sparksee::gdb::bool_t | IsEdgeExcluded (sparksee::gdb::oid_t edge)
Check if the given edge is forbidden.
sparksee::gdb::bool_t | IsNodeIncluded (sparksee::gdb::oid_t node)
Check if the given node is EXPLICITLY allowed using the include set.
sparksee::gdb::bool_t | IsEdgeIncluded (sparksee::gdb::oid_t edge)
Check if the given edge is EXPLICITLY allowed using the include set.

Protected Attributes

sparksee::gdb::attr_t attrCommunity
common attribute where the connected component information is stored.
std::wstring | attrCommunityName
name of the common attribute where the connected component information is stored.
sparksee::gdb::int64_t actualCommunity
Current community identifier.
sparksee::gdb::bool_t matResults
Materialized results.
DisjointCommunities * dcs
The calculated communities information.
sparksee::gdb::Session * | sess
Session.
sparksee::gdb::Graph * | graph
Graph.
EdgeTypes_t edgeTypes
Allowed edge types.
std::vector
< sparksee::gdb::type_t > 		nodeTypes
Allowed node types.
sparksee::gdb::Objects * | nodesNotVisited
Identifiers of the nodes not visited.
sparksee::gdb::bool_t computed
True if the connectivity has been calculated.
sparksee::gdb::Objects * | excludedNodes
The set of excluded nodes.
sparksee::gdb::Objects * | excludedEdges
The set of excluded edges.
sparksee::gdb::Objects * | includedNodes
The set of explicitly included nodes.
sparksee::gdb::Objects * | includedEdges
The set of explicitly included edges.

Detailed Description

DisjointCommunityDetection class.

Any class implementing this abstract class can be used to solve a problem related to graph connectivity as finding the strongly connected components, finding the weakly connected components.

Check out the 'Algorithms' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

DisjointCommunityDetection::DisjointCommunityDetection ( sparksee::gdb::Session & s )
protected

Creates a new instance of DisjointCommunityDetection.

Parameters
s [in] Session to get the graph from and calculate the communities

Member Function Documentation

virtual void DisjointCommunityDetection::AddAllEdgeTypes ( )
virtual

Allows connectivity through all edge types of the graph.

The edges can be used in Any direction.

void CommunityDetection::AddAllEdgeTypes ( sparksee::gdb::EdgesDirection direction )
protectedinherited

Allows connectivity through all edge types of the graph.

Parameters
d [in] Edge direction.
virtual void DisjointCommunityDetection::AddEdgeType ( sparksee::gdb::type_t type )
virtual

Allows connectivity through edges of the given type.

The edges can be used in Any direction.

Parameters
type [in] Edge type.
void CommunityDetection::AddEdgeType | ( | sparksee::gdb::type_t | type,
 |  | sparksee::gdb::EdgesDirection | direction
 | ) |  |
protectedinherited

Allows connectivity through edges of the given type.

Parameters
t | [in] Edge type.
d | [in] Edge direction.
virtual void CommunityDetection::ExcludeEdges ( sparksee::gdb::Objects & edges )
virtualinherited

Set which edges can't be used.

This will replace any previously specified set of excluded edges. Should only be used to exclude the usage of specific edges from allowed edge types because it's less efficient than not allowing an edge type.

Parameters
edges [in] A set of edge identifiers that must be kept intact until the destruction of the class.
virtual void CommunityDetection::ExcludeNodes ( sparksee::gdb::Objects & nodes )
virtualinherited

Set which nodes can't be used.

This will replace any previously specified set of excluded nodes. Should only be used to exclude the usage of specific nodes from allowed node types because it's less efficient than not allowing a node type.

Parameters
nodes [in] A set of node identifiers that must be kept intact until the destruction of the class.
DisjointCommunities* DisjointCommunityDetection::GetCommunities ( )

Returns the results generated by the execution of the algorithm.

These results contain information related to the disjoint communities found as the number of different components, the set of nodes contained in each component or many other data.

Returns
Returns an instance of the class DisjointCommunities which contain information related to the disjoint communities found.
virtual void CommunityDetection::IncludeEdges ( sparksee::gdb::Objects & edges )
virtualinherited

Set additional edges that can be used.

This will replace any previously specified set of include edges. Using this optional method adds valid edges to the edges of any edge type explicitly set as a valid type. Should only be used to include specific small sets of edges because it's less efficient than just using an edge type. For any edge to be used, both nodes must be also valid.

Parameters
edges [in] A set of edge identifiers that must be kept intact until the destruction of the class.
virtual void CommunityDetection::IncludeNodes ( sparksee::gdb::Objects & nodes )
virtualinherited

Set additional nodes that can be used.

This will replace any previously specified set of include nodes. Using this optional method adds valid nodes to the nodes of any node type explicitly set as a valid type. Should only be used to include specific small sets of nodes because it's less efficient than just using a node type.

Parameters
nodes [in] A set of node identifiers that must be kept intact until the destruction of the class.
virtual void DisjointCommunityDetection::Run ( )
pure virtual

Runs the algorithm in order to find the communities.

This method can be called only once.

Implements CommunityDetection.

Implemented in CommunitiesSCD.

void DisjointCommunityDetection::SetMaterializedAttribute ( const std::wstring & attributeName )

Creates a new common attribute type for all node types in the graph in order to store, persistently, the results related to the disjoint communities found while executing this algorithm.

Whenever the user wants to retrieve the results, even when the graph has been closed and opened again, it is only necessary to create a new instance of the class DisjointCommunities indicating the graph and the name of the common attribute type which stores the results. This instance will have all the information related to the disjoint communities found in the moment of the execution of the algorithm that stored this data.

It is possible to run the algorithm without specifying this parameter in order to avoid materializing the results of the execution.

Parameters
attributeName [in] The name of the common attribute type for all node types in the graph which will store persistently the results generated by the execution of the algorithm.
void CommunityDetection::SetNodesNotVisited ( )
protectedinherited

Set all the selected nodes in nodesNotVisited.

That's all the nodes of the allowed node types but not the excluded ones.

The documentation for this class was generated from the following file:
  • DisjointCommunityDetection.h


Sparksee: KOpt Class Reference

Public Member Functions | List of all members
KOpt Class Reference
Algorithms

KOpt class. More...

Public Member Functions

KOpt (sparksee::gdb::Session &session)
Creates a new instance.
KOpt (sparksee::gdb::Session &session, sparksee::gdb::OIDList &tour)
Creates a new instance.
virtual | ~KOpt ()
Destructor.
void | AddNodeType (sparksee::gdb::type_t type) throw (sparksee::gdb::Error)
Allows for traversing nodes of the given type.
void | AddAllNodeTypes ()
Allows for traversing all node types of the graph.
void | AddEdgeType (sparksee::gdb::type_t type, sparksee::gdb::EdgesDirection dir) throw (sparksee::gdb::Error)
Allows for traversing edges of the given type.
void | AddAllEdgeTypes (sparksee::gdb::EdgesDirection dir)
Allows for traversing all edge types of the graph.
void | SetEdgeWeightAttributeType (sparksee::gdb::attr_t attr) throw (sparksee::gdb::Error)
Sets the attribute to use as edge weight.
double | GetCurrentCost () const
Returns tour cost.
sparksee::gdb::OIDList * | GetCurrentTour ()
Returns tour as a list of nodes.
void | SetCurrentTour (sparksee::gdb::OIDList &tour)
Sets current tour as a list of nodes.
void | SetMaxIterations (sparksee::gdb::int64_t maxIterations)
Sets maximum number of iterations.
void | SetTimeLimit (sparksee::gdb::int64_t maxTime)
Limits execution time.
void | RunTwoOpt ()
Runs 2-Opt local search.
void | RunThreeOpt ()
Runs 3-Opt local search.

Detailed Description

KOpt class.

Implements the 2-Opt and 3-Opt algorithms

Author
Sparsity Technologies http://www.sparsity-technologies.com
The documentation for this class was generated from the following file:
  • KOpt.h


Sparksee: PageRank Class Reference

Classes | Public Member Functions | List of all members
PageRank Class Reference
Algorithms

PageRank class. More...

Public Member Functions

PageRank (sparksee::gdb::Session &session)
Builds the PageRank.
virtual | ~PageRank ()
Destructor.
void | AddEdgeType (sparksee::gdb::type_t type, sparksee::gdb::EdgesDirection dir) throw (sparksee::gdb::Error)
Allows for traversing edges of the given type.
void | AddAllEdgeTypes (sparksee::gdb::EdgesDirection dir)
Allows for traversing all edge types of the graph.
void | AddNodeType (sparksee::gdb::type_t type) throw (sparksee::gdb::Error)
Allows for traversing nodes of the given type.
void | AddAllNodeTypes ()
Allows for traversing all node types of the graph.
void | SetNumIterations (sparksee::gdb::int32_t numIterations)
Sets the number of iterations to run the PageRank for.
void | SetTolerance (sparksee::gdb::double64_t tolerance)
Sets the tolerance threashold to continue computing the PageRank after each iteration.
void | SetDamping (sparksee::gdb::double64_t damping)
Sets the damping value for the PageRank.
void | SetInitialPageRankValue (sparksee::gdb::double64_t startValue)
Sets the initial PageRank value.
void | SetOutputAttributeType (sparksee::gdb::attr_t attr) throw (sparksee::gdb::Error)
Sets the output attribute type.
void | SetEdgeWeightAttributeType (sparksee::gdb::attr_t attr) throw (sparksee::gdb::Error)
Sets the attribute to use as edge weight.
void | SetDefaultWeight (sparksee::gdb::double64_t weight)
Sets the default weight for those cases when a given edge does not have a weight attribute set.
void | SetStartingNode (sparksee::gdb::oid_t startNode) throw (sparksee::gdb::Error)
Sets the starting node of the page rank to compute the Personalized PageRank variant.
void | Run () throw (sparksee::gdb::Error)
Runs the algorithm.

Detailed Description

PageRank class.

Implements the PageRank algorithm

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

PageRank::PageRank ( sparksee::gdb::Session & session )

Builds the PageRank.

Parameters
session [in] The session to use

Member Function Documentation

void PageRank::AddAllEdgeTypes ( sparksee::gdb::EdgesDirection dir )

Allows for traversing all edge types of the graph.

The direction is interpreted as in which direction an edge can be followed from a node to influence other nodes.

Parameters
dir [in] Edge direction.
void PageRank::AddEdgeType | ( | sparksee::gdb::type_t | type,
 |  | sparksee::gdb::EdgesDirection | dir
 | ) |  | throw (sparksee::gdb::Error)

Allows for traversing edges of the given type.

If the edge type was already added, the existing direction is overwritten The direction is interpreted as in which direction an edge can be followed from a node to influence other nodes.

Parameters
type | [in] Edge type.
dir | [in] Edge direction.
void PageRank::Run ( ) throw (sparksee::gdb::Error)

Runs the algorithm.

Exceptions
sparksee::gdb::Error
void PageRank::SetDamping ( sparksee::gdb::double64_t damping )

Sets the damping value for the PageRank.

Parameters
damping [in] The damping value. Default: 0.85
void PageRank::SetDefaultWeight ( sparksee::gdb::double64_t weight )

Sets the default weight for those cases when a given edge does not have a weight attribute set.

Default: 0.0

Parameters
weight [in] The default weight
void PageRank::SetEdgeWeightAttributeType ( sparksee::gdb::attr_t attr ) throw (sparksee::gdb::Error)

Sets the attribute to use as edge weight.

If the multiple edge are set for traversal, this attribute must be of type GLOBAL_TYPE or EDGES_TYPE. Additionally, the attribute must be of type Double. Finally, negative weights are treated as non existing, so the default weight applies.

Parameters
attr [in] The attribute type to use as a weight. Default: InvalidAttribute
Exceptions
sparksee::gdb::Error
void PageRank::SetInitialPageRankValue ( sparksee::gdb::double64_t startValue )

Sets the initial PageRank value.

If a starting node is set, this initial value is only set for the starting node and the rest of nodes are set to 0.0

Parameters
startValue [in] The initial value to set. Default: 0.0
void PageRank::SetNumIterations ( sparksee::gdb::int32_t numIterations )

Sets the number of iterations to run the PageRank for.

Parameters
numIterations [in] The number of interations to set. Default: 20
void PageRank::SetOutputAttributeType ( sparksee::gdb::attr_t attr ) throw (sparksee::gdb::Error)

Sets the output attribute type.

If the PageRank will run on more than one node type, then the output attribute must be of type GLOBAL_TYPE or NODES_TYPE. Otherwise, it must be a valid attribute for the used node type.

Parameters
attr [in] The attribute to store the result. Default: InvalidAttribute
void PageRank::SetStartingNode ( sparksee::gdb::oid_t startNode ) throw (sparksee::gdb::Error)

Sets the starting node of the page rank to compute the Personalized PageRank variant.

Exceptions
sparksee::gdb::Error
void PageRank::SetTolerance ( sparksee::gdb::double64_t tolerance )

Sets the tolerance threashold to continue computing the PageRank after each iteration.

If all the changes to any PPR value after an iteration are below that tolerance threshold, the algorithm finishes.

Parameters
tolerance [in] The tolerance to use normalized between 0 and 1. Default: 0.000001
The documentation for this class was generated from the following file:
  • PageRank.h


Sparksee: RandomWalk Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
RandomWalk Class Reference
Algorithms

RandomWalk class. More...

Inheritance diagram for RandomWalk:
Collaboration diagram for RandomWalk:

Public Member Functions

RandomWalk (sparksee::gdb::Session &session, sparksee::gdb::oid_t node)
Builds the RandomWalk.
virtual | ~RandomWalk ()
Destructor.
virtual void | AddEdgeType (sparksee::gdb::type_t type, sparksee::gdb::EdgesDirection dir)
Allows for traversing edges of the given type.
virtual void | AddAllEdgeTypes (sparksee::gdb::EdgesDirection dir)
Allows for traversing all edge types of the graph.
virtual void | AddNodeType (sparksee::gdb::type_t type)
Allows for traversing nodes of the given type.
virtual void | AddAllNodeTypes ()
Allows for traversing all node types of the graph.
virtual void | ExcludeNodes (sparksee::gdb::Objects &nodes)
Set which nodes can't be used.
virtual void | ExcludeEdges (sparksee::gdb::Objects &edges)
Set which edges can't be used.
virtual sparksee::gdb::oid_t | Next ()
Gets the next object of the traversal.
virtual sparksee::gdb::bool_t | HasNext ()
Gets if there are more objects to be traversed.
virtual sparksee::gdb::int32_t | GetCurrentDepth () const
Returns the depth of the current node.
void | SetEdgeWeightAttributeType (sparksee::gdb::attr_t attr)
Sets the attribute to use as edge weight.
void | SetDefaultWeight (sparksee::gdb::double64_t weight)
Sets the default weight for those cases when a given edge does not have a weight attribute set.
void | Reset (sparksee::gdb::oid_t startNode)
Sets the starting node of the RandomWalk.
void | SetReturnParameter (sparksee::gdb::double64_t val)
Sets the return parameter of the RandomWalk.
void | SetInOutParameter (sparksee::gdb::double64_t val)
Sets the In-Out parameter of the RandomWalk.
void | SetSeed (sparksee::gdb::int32_t seed)
Sets the seed of the random walk.
virtual void | SetMaximumHops (sparksee::gdb::int32_t maxhops)
Sets the maximum hops restriction.

Protected Member Functions

void | AssertAddedEdges ()
Check that edges had been added.
void | AssertAddedNodes ()
Check that nodes had been added.
void | AssertEdgeType (sparksee::gdb::type_t edgetype)
Check that the given edge type is valid.
void | AssertNodeType (sparksee::gdb::type_t nodetype)
Check that the given node type is valid.
sparksee::gdb::bool_t | IsNodeTypeAllowed (sparksee::gdb::oid_t nodeId)
Check if the given node has an allowed type.
sparksee::gdb::bool_t | IsNodeExcluded (sparksee::gdb::oid_t node)
Check if the given node is forbidden.
sparksee::gdb::bool_t | IsEdgeExcluded (sparksee::gdb::oid_t edge)
Check if the given edge is forbidden.

Protected Attributes

sparksee::gdb::Session * | sess
Session.
sparksee::gdb::Graph * | graph
Graph.
sparksee::gdb::oid_t src
Source node of the traversal.
std::map
< sparksee::gdb::type_t,
sparksee::gdb::EdgesDirection > 		edgeTypes
Allowed edge types.
std::vector
< sparksee::gdb::type_t > 		nodeTypes
Allowed node types.
sparksee::gdb::int32_t maxHops
Maximum number of hops allowed.
sparksee::gdb::Objects * | excludedNodes
The set of excluded nodes.
sparksee::gdb::Objects * | excludedEdges
The set of excluded edges.

Detailed Description

RandomWalk class.

Implements the RandomWalk algorithm

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

RandomWalk::RandomWalk | ( | sparksee::gdb::Session & | session,
 |  | sparksee::gdb::oid_t | node
 | ) |  |

Builds the RandomWalk.

Parameters
session | [in] The session to use
node | [in] The starting node of the traversal

Member Function Documentation

virtual void RandomWalk::AddAllEdgeTypes ( sparksee::gdb::EdgesDirection dir )
virtual

Allows for traversing all edge types of the graph.

Parameters
dir [in] Edge direction.

Reimplemented from Traversal.

virtual void RandomWalk::AddEdgeType | ( | sparksee::gdb::type_t | type,
 |  | sparksee::gdb::EdgesDirection | dir
 | ) |  |
virtual

Allows for traversing edges of the given type.

If the edge type was already added, the existing direction is overwritten

Parameters
type | [in] Edge type.
dir | [in] Edge direction.

Reimplemented from Traversal.

virtual void RandomWalk::AddNodeType ( sparksee::gdb::type_t type )
virtual

Allows for traversing nodes of the given type.

Parameters
type The node type to add

Reimplemented from Traversal.

virtual void RandomWalk::ExcludeEdges ( sparksee::gdb::Objects & edges )
virtual

Set which edges can't be used.

This will replace any previously specified set of excluded edges. Should only be used to exclude the usage of specific edges from allowed edge types because it's less efficient than not allowing an edge type.

Parameters
edges [in] A set of edge identifiers that must be kept intact until the destruction of the class.

Reimplemented from Traversal.

virtual void RandomWalk::ExcludeNodes ( sparksee::gdb::Objects & nodes )
virtual

Set which nodes can't be used.

This will replace any previously specified set of excluded nodes. Should only be used to exclude the usage of specific nodes from allowed node types because it's less efficient than not allowing a node type.

Parameters
nodes [in] A set of node identifiers that must be kept intact until the destruction of the class.

Reimplemented from Traversal.

virtual sparksee::gdb::int32_t RandomWalk::GetCurrentDepth ( ) const
virtual

Returns the depth of the current node.

That is, it returns the depth of the node returned in the last call to Next().

Returns
The depth of the current node.

Implements Traversal.

virtual sparksee::gdb::bool_t RandomWalk::HasNext ( )
virtual

Gets if there are more objects to be traversed.

Returns
TRUE if there are more objects, FALSE otherwise.

Implements Traversal.

virtual sparksee::gdb::oid_t RandomWalk::Next ( )
virtual

Gets the next object of the traversal.

Returns
A node or edge identifier.

Implements Traversal.

void RandomWalk::Reset ( sparksee::gdb::oid_t startNode )

Sets the starting node of the RandomWalk.

This method resets the RandomWalk.

Exceptions
sparksee::gdb::Error
void RandomWalk::SetDefaultWeight ( sparksee::gdb::double64_t weight )

Sets the default weight for those cases when a given edge does not have a weight attribute set.

Default: 0.0

Parameters
weight [in] The default weight
void RandomWalk::SetEdgeWeightAttributeType ( sparksee::gdb::attr_t attr )

Sets the attribute to use as edge weight.

If the multiple edge are set for traversal, this attribute must be of type GLOBAL_TYPE or EDGES_TYPE. Additionally, the attribute must be of type Double. Finally, negative weights are treated as non existing, so the default weight applies.

Parameters
attr [in] The attribute type to use as a weight. Default: InvalidAttribute
void RandomWalk::SetInOutParameter ( sparksee::gdb::double64_t val )

Sets the In-Out parameter of the RandomWalk.

Parameters
val The In-Out parameter to set. Default: 1.0
virtual void Traversal::SetMaximumHops ( sparksee::gdb::int32_t maxhops )
virtualinherited

Sets the maximum hops restriction.

All paths longer than the maximum hops restriction will be ignored.

Parameters
maxhops [in] The maximum hops restriction. It must be positive or zero. Zero, the default value, means unlimited.
void RandomWalk::SetReturnParameter ( sparksee::gdb::double64_t val )

Sets the return parameter of the RandomWalk.

Parameters
val The return parameter to set. Default: 1.0
void RandomWalk::SetSeed ( sparksee::gdb::int32_t seed )

Sets the seed of the random walk.

Parameters
seed The seed to generate the random numbers that drive the random walk
The documentation for this class was generated from the following file:
  • RandomWalk.h


Sparksee: ShortestPath Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
ShortestPath Class Referenceabstract
Algorithms

ShortestPath class. More...

Inheritance diagram for ShortestPath:

Public Member Functions

void | SetMaximumHops (sparksee::gdb::int32_t maxhops)
Sets the maximum hops restriction.
virtual void | AddEdgeType (sparksee::gdb::type_t type, sparksee::gdb::EdgesDirection dir)
Allows for traversing edges of the given type.
virtual void | AddAllEdgeTypes (sparksee::gdb::EdgesDirection dir)
Allows for traversing all edge types of the graph.
virtual void | AddNodeType (sparksee::gdb::type_t type)
Allows for traversing nodes of the given type.
virtual void | AddAllNodeTypes ()
Allows for traversing all node types of the graph.
virtual void | ExcludeNodes (sparksee::gdb::Objects &nodes)
Set which nodes can't be used.
virtual void | ExcludeEdges (sparksee::gdb::Objects &edges)
Set which edges can't be used.
virtual void | Run ()=0
Runs the algorithm.
virtual | ~ShortestPath ()
Destructor.

Protected Member Functions

ShortestPath (sparksee::gdb::Session &s)
Creates a new instance.
void | AssertEdgeType (sparksee::gdb::type_t edgetype)
Check that the given edge type is valid.
void | AssertAddedEdges ()
Check that edges had been added.
void | AssertAddedNodes ()
Check that nodes had been added.
void | AssertNodeType (sparksee::gdb::type_t nodetype)
Check that the given node type is valid.
sparksee::gdb::bool_t | IsNodeTypeAllowed (sparksee::gdb::oid_t nodeId)
Check if the given node has an allowed type.
void | AssertNotComputed ()
Check that the shortest path had not been calculated yet.
void | AssertComputed ()
Check that the shortest path had been calculated.
sparksee::gdb::bool_t | IsNodeExcluded (sparksee::gdb::oid_t node)
Check if the given node is forbidden.
sparksee::gdb::bool_t | IsEdgeExcluded (sparksee::gdb::oid_t edge)
Check if the given edge is forbidden.

Protected Attributes

sparksee::gdb::Session * | sess
Session.
sparksee::gdb::Graph * | graph
Graph.
std::map
< sparksee::gdb::type_t,
sparksee::gdb::EdgesDirection > 		edgeTypes
Allowed edge types.
std::vector
< sparksee::gdb::type_t > 		nodeTypes
Allowed node types.
sparksee::gdb::int32_t maxHops
Maximum hops restriction.
sparksee::gdb::bool_t computed
True if the shortest path has been calculated.
sparksee::gdb::Objects * | excludedNodes
The set of excluded nodes.
sparksee::gdb::Objects * | excludedEdges
The set of excluded edges.
sparksee::gdb::bool_t areAllNodeTypesAllowed
True if all the node types are allowed.

Detailed Description

ShortestPath class.

Classes implementing this abstract class solve the shortest path problem in a graph.

The user must set which node and edge types can be used for the traversal.

Check out the 'Algorithms' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

ShortestPath::ShortestPath ( sparksee::gdb::Session & s )
protected

Creates a new instance.

Parameters
s [in] Session to get the graph from and perform traversal.

Member Function Documentation

virtual void ShortestPath::AddAllEdgeTypes ( sparksee::gdb::EdgesDirection dir )
virtual

Allows for traversing all edge types of the graph.

Parameters
dir [in] Edge direction.
virtual void ShortestPath::AddEdgeType | ( | sparksee::gdb::type_t | type,
 |  | sparksee::gdb::EdgesDirection | dir
 | ) |  |
virtual

Allows for traversing edges of the given type.

Parameters
type | [in] Edge type.
dir | [in] Edge direction.
virtual void ShortestPath::ExcludeEdges ( sparksee::gdb::Objects & edges )
virtual

Set which edges can't be used.

This will replace any previously specified set of excluded edges. Should only be used to exclude the usage of specific edges from allowed edge types because it's less efficient than not allowing an edge type.

Parameters
edges [in] A set of edge identifiers that must be kept intact until the destruction of the class.
virtual void ShortestPath::ExcludeNodes ( sparksee::gdb::Objects & nodes )
virtual

Set which nodes can't be used.

This will replace any previously specified set of excluded nodes. Should only be used to exclude the usage of specific nodes from allowed node types because it's less efficient than not allowing a node type.

Parameters
nodes [in] A set of node identifiers that must be kept intact until the destruction of the class.
virtual void ShortestPath::Run ( )
pure virtual

Runs the algorithm.

This method can only be called once.

Implemented in SinglePairShortestPathDijkstra, and SinglePairShortestPathBFS.

void ShortestPath::SetMaximumHops ( sparksee::gdb::int32_t maxhops )

Sets the maximum hops restriction.

All paths longer than the maximum hops restriction will be ignored.

Parameters
maxhops [in] The maximum hops restriction. It must be positive or zero. Zero, the default value, means unlimited.

Member Data Documentation

sparksee::gdb::int32_t ShortestPath::maxHops
protected

Maximum hops restriction.

It must be positive or zero. Zero means unlimited.

The documentation for this class was generated from the following file:
  • ShortestPath.h


Sparksee: SinglePairShortestPath Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
SinglePairShortestPath Class Referenceabstract
Algorithms

SinglePairShortestPath class. More...

Inheritance diagram for SinglePairShortestPath:
Collaboration diagram for SinglePairShortestPath:

Public Member Functions

virtual sparksee::gdb::OIDList * | GetPathAsNodes ()=0
Gets the shortest path between the source node and the destination node as an ordered set of nodes.
virtual sparksee::gdb::OIDList * | GetPathAsEdges ()=0
Gets the shortest path between the source node and the destination node as an ordered set of edges.
virtual sparksee::gdb::double64_t | GetCost ()=0
Gets the cost of the shortest path.
virtual sparksee::gdb::bool_t | Exists ()
Returns TRUE If a path exists or FALSE otherwise.
virtual | ~SinglePairShortestPath ()
Destructor.
void | SetMaximumHops (sparksee::gdb::int32_t maxhops)
Sets the maximum hops restriction.
virtual void | AddEdgeType (sparksee::gdb::type_t type, sparksee::gdb::EdgesDirection dir)
Allows for traversing edges of the given type.
virtual void | AddAllEdgeTypes (sparksee::gdb::EdgesDirection dir)
Allows for traversing all edge types of the graph.
virtual void | AddNodeType (sparksee::gdb::type_t type)
Allows for traversing nodes of the given type.
virtual void | AddAllNodeTypes ()
Allows for traversing all node types of the graph.
virtual void | ExcludeNodes (sparksee::gdb::Objects &nodes)
Set which nodes can't be used.
virtual void | ExcludeEdges (sparksee::gdb::Objects &edges)
Set which edges can't be used.
virtual void | Run ()=0
Runs the algorithm.

Protected Member Functions

SinglePairShortestPath (sparksee::gdb::Session &s, sparksee::gdb::oid_t src, sparksee::gdb::oid_t dst)
Creates a new instance.
void | AssertEdgeType (sparksee::gdb::type_t edgetype)
Check that the given edge type is valid.
void | AssertAddedEdges ()
Check that edges had been added.
void | AssertAddedNodes ()
Check that nodes had been added.
void | AssertNodeType (sparksee::gdb::type_t nodetype)
Check that the given node type is valid.
sparksee::gdb::bool_t | IsNodeTypeAllowed (sparksee::gdb::oid_t nodeId)
Check if the given node has an allowed type.
void | AssertNotComputed ()
Check that the shortest path had not been calculated yet.
void | AssertComputed ()
Check that the shortest path had been calculated.
sparksee::gdb::bool_t | IsNodeExcluded (sparksee::gdb::oid_t node)
Check if the given node is forbidden.
sparksee::gdb::bool_t | IsEdgeExcluded (sparksee::gdb::oid_t edge)
Check if the given edge is forbidden.

Protected Attributes

sparksee::gdb::oid_t source
Source node.
sparksee::gdb::oid_t destination
Destination node.
sparksee::gdb::OIDList * | pathAsNodes
Ordered set of node identifiers representing the shortest path.
sparksee::gdb::OIDList * | pathAsEdges
Ordered set of edge identifiers representing the shortest path.
sparksee::gdb::Session * | sess
Session.
sparksee::gdb::Graph * | graph
Graph.
std::map
< sparksee::gdb::type_t,
sparksee::gdb::EdgesDirection > 		edgeTypes
Allowed edge types.
std::vector
< sparksee::gdb::type_t > 		nodeTypes
Allowed node types.
sparksee::gdb::int32_t maxHops
Maximum hops restriction.
sparksee::gdb::bool_t computed
True if the shortest path has been calculated.
sparksee::gdb::Objects * | excludedNodes
The set of excluded nodes.
sparksee::gdb::Objects * | excludedEdges
The set of excluded edges.
sparksee::gdb::bool_t areAllNodeTypesAllowed
True if all the node types are allowed.

Detailed Description

SinglePairShortestPath class.

Classes implementing this abstract class solve the shortest path problem in a graph from a given source node and to a given destination node.

Check out the 'Algorithms' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

SinglePairShortestPath::SinglePairShortestPath | ( | sparksee::gdb::Session & | s,
 |  | sparksee::gdb::oid_t | src,
 |  | sparksee::gdb::oid_t | dst
 | ) |  |
protected

Creates a new instance.

Parameters
s | [in] Session to get the graph from and perform traversal.
src | [in] Source node.
dst | [dst] Destination node.

Member Function Documentation

virtual void ShortestPath::AddAllEdgeTypes ( sparksee::gdb::EdgesDirection dir )
virtualinherited

Allows for traversing all edge types of the graph.

Parameters
dir [in] Edge direction.
virtual void ShortestPath::AddEdgeType | ( | sparksee::gdb::type_t | type,
 |  | sparksee::gdb::EdgesDirection | dir
 | ) |  |
virtualinherited

Allows for traversing edges of the given type.

Parameters
type | [in] Edge type.
dir | [in] Edge direction.
virtual void ShortestPath::ExcludeEdges ( sparksee::gdb::Objects & edges )
virtualinherited

Set which edges can't be used.

This will replace any previously specified set of excluded edges. Should only be used to exclude the usage of specific edges from allowed edge types because it's less efficient than not allowing an edge type.

Parameters
edges [in] A set of edge identifiers that must be kept intact until the destruction of the class.
virtual void ShortestPath::ExcludeNodes ( sparksee::gdb::Objects & nodes )
virtualinherited

Set which nodes can't be used.

This will replace any previously specified set of excluded nodes. Should only be used to exclude the usage of specific nodes from allowed node types because it's less efficient than not allowing a node type.

Parameters
nodes [in] A set of node identifiers that must be kept intact until the destruction of the class.
virtual sparksee::gdb::double64_t SinglePairShortestPath::GetCost ( )
pure virtual

Gets the cost of the shortest path.

The cost for unweighted algorithms is the number of hops of the shortest path. For weighted algoritms, the cost is the sum of the costs of the edges of the shortest path.

Returns
The cost of the shortest path.

Implemented in SinglePairShortestPathDijkstra, and SinglePairShortestPathBFS.

virtual sparksee::gdb::OIDList* SinglePairShortestPath::GetPathAsEdges ( )
pure virtual

Gets the shortest path between the source node and the destination node as an ordered set of edges.

Returns
Ordered set of edge identifiers.

Implemented in SinglePairShortestPathDijkstra, and SinglePairShortestPathBFS.

virtual sparksee::gdb::OIDList* SinglePairShortestPath::GetPathAsNodes ( )
pure virtual

Gets the shortest path between the source node and the destination node as an ordered set of nodes.

Returns
Ordered set of node identifiers.

Implemented in SinglePairShortestPathDijkstra, and SinglePairShortestPathBFS.

virtual void ShortestPath::Run ( )
pure virtualinherited

Runs the algorithm.

This method can only be called once.

Implemented in SinglePairShortestPathDijkstra, and SinglePairShortestPathBFS.

void ShortestPath::SetMaximumHops ( sparksee::gdb::int32_t maxhops )
inherited

Sets the maximum hops restriction.

All paths longer than the maximum hops restriction will be ignored.

Parameters
maxhops [in] The maximum hops restriction. It must be positive or zero. Zero, the default value, means unlimited.

Member Data Documentation

sparksee::gdb::int32_t ShortestPath::maxHops
protectedinherited

Maximum hops restriction.

It must be positive or zero. Zero means unlimited.

sparksee::gdb::OIDList* SinglePairShortestPath::pathAsEdges
protected

Ordered set of edge identifiers representing the shortest path.

May be computed lazily when requested from the pathAsNodes.

The documentation for this class was generated from the following file:
  • SinglePairShortestPath.h


Sparksee: SinglePairShortestPathBFS Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
SinglePairShortestPathBFS Class Reference
Algorithms

SinglePairShortestPathBFS class. More...

Inheritance diagram for SinglePairShortestPathBFS:
Collaboration diagram for SinglePairShortestPathBFS:

Public Member Functions

virtual | ~SinglePairShortestPathBFS ()
Destructor.
virtual void | Run ()
Executes the algorithm.
virtual sparksee::gdb::OIDList * | GetPathAsNodes ()
Gets the shortest path between the source node and the destination node as an ordered set of nodes.
virtual sparksee::gdb::OIDList * | GetPathAsEdges ()
Gets the shortest path between the source node and the destination node as an ordered set of edges.
virtual sparksee::gdb::double64_t | GetCost ()
Gets the cost of the shortest path.
SinglePairShortestPathBFS (sparksee::gdb::Session &session, sparksee::gdb::oid_t src, sparksee::gdb::oid_t dst)
Creates a new instance.
virtual void | CheckOnlyExistence ()
Set that only the path existence must be calculated and not the path itself.
virtual sparksee::gdb::bool_t | Exists ()
Returns TRUE If a path exists or FALSE otherwise.
void | SetMaximumHops (sparksee::gdb::int32_t maxhops)
Sets the maximum hops restriction.
virtual void | AddEdgeType (sparksee::gdb::type_t type, sparksee::gdb::EdgesDirection dir)
Allows for traversing edges of the given type.
virtual void | AddAllEdgeTypes (sparksee::gdb::EdgesDirection dir)
Allows for traversing all edge types of the graph.
virtual void | AddNodeType (sparksee::gdb::type_t type)
Allows for traversing nodes of the given type.
virtual void | AddAllNodeTypes ()
Allows for traversing all node types of the graph.
virtual void | ExcludeNodes (sparksee::gdb::Objects &nodes)
Set which nodes can't be used.
virtual void | ExcludeEdges (sparksee::gdb::Objects &edges)
Set which edges can't be used.

Protected Member Functions

void | AssertEdgeType (sparksee::gdb::type_t edgetype)
Check that the given edge type is valid.
void | AssertAddedEdges ()
Check that edges had been added.
void | AssertAddedNodes ()
Check that nodes had been added.
void | AssertNodeType (sparksee::gdb::type_t nodetype)
Check that the given node type is valid.
sparksee::gdb::bool_t | IsNodeTypeAllowed (sparksee::gdb::oid_t nodeId)
Check if the given node has an allowed type.
void | AssertNotComputed ()
Check that the shortest path had not been calculated yet.
void | AssertComputed ()
Check that the shortest path had been calculated.
sparksee::gdb::bool_t | IsNodeExcluded (sparksee::gdb::oid_t node)
Check if the given node is forbidden.
sparksee::gdb::bool_t | IsEdgeExcluded (sparksee::gdb::oid_t edge)
Check if the given edge is forbidden.

Protected Attributes

sparksee::gdb::oid_t source
Source node.
sparksee::gdb::oid_t destination
Destination node.
sparksee::gdb::OIDList * | pathAsNodes
Ordered set of node identifiers representing the shortest path.
sparksee::gdb::OIDList * | pathAsEdges
Ordered set of edge identifiers representing the shortest path.
sparksee::gdb::Session * | sess
Session.
sparksee::gdb::Graph * | graph
Graph.
std::map
< sparksee::gdb::type_t,
sparksee::gdb::EdgesDirection > 		edgeTypes
Allowed edge types.
std::vector
< sparksee::gdb::type_t > 		nodeTypes
Allowed node types.
sparksee::gdb::int32_t maxHops
Maximum hops restriction.
sparksee::gdb::bool_t computed
True if the shortest path has been calculated.
sparksee::gdb::Objects * | excludedNodes
The set of excluded nodes.
sparksee::gdb::Objects * | excludedEdges
The set of excluded edges.
sparksee::gdb::bool_t areAllNodeTypesAllowed
True if all the node types are allowed.

Detailed Description

SinglePairShortestPathBFS class.

It solves the single-pair shortest path problem using a BFS-based implementation.

It is a unweighted algorithm, that is it assumes all edges have the same cost.

Check out the 'Algorithms' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

SinglePairShortestPathBFS::SinglePairShortestPathBFS | ( | sparksee::gdb::Session & | session,
 |  | sparksee::gdb::oid_t | src,
 |  | sparksee::gdb::oid_t | dst
 | ) |  |

Creates a new instance.

Parameters
session | [in] Session to get the graph from and perform traversal.
src | [in] Source node.
dst | [dst] Destination node.

Member Function Documentation

virtual void ShortestPath::AddAllEdgeTypes ( sparksee::gdb::EdgesDirection dir )
virtualinherited

Allows for traversing all edge types of the graph.

Parameters
dir [in] Edge direction.
virtual void ShortestPath::AddEdgeType | ( | sparksee::gdb::type_t | type,
 |  | sparksee::gdb::EdgesDirection | dir
 | ) |  |
virtualinherited

Allows for traversing edges of the given type.

Parameters
type | [in] Edge type.
dir | [in] Edge direction.
virtual void SinglePairShortestPathBFS::CheckOnlyExistence ( )
virtual

Set that only the path existence must be calculated and not the path itself.

That method should improve the performance of the algorithm, but a call to GetPathAsNodes or GetPathAsEdges will generate an exception even if the path exists.

virtual void ShortestPath::ExcludeEdges ( sparksee::gdb::Objects & edges )
virtualinherited

Set which edges can't be used.

This will replace any previously specified set of excluded edges. Should only be used to exclude the usage of specific edges from allowed edge types because it's less efficient than not allowing an edge type.

Parameters
edges [in] A set of edge identifiers that must be kept intact until the destruction of the class.
virtual void ShortestPath::ExcludeNodes ( sparksee::gdb::Objects & nodes )
virtualinherited

Set which nodes can't be used.

This will replace any previously specified set of excluded nodes. Should only be used to exclude the usage of specific nodes from allowed node types because it's less efficient than not allowing a node type.

Parameters
nodes [in] A set of node identifiers that must be kept intact until the destruction of the class.
virtual sparksee::gdb::double64_t SinglePairShortestPathBFS::GetCost ( )
virtual

Gets the cost of the shortest path.

The cost is the number of hops of the shortest path.

Returns
The cost of the shortest path.

Implements SinglePairShortestPath.

virtual sparksee::gdb::OIDList* SinglePairShortestPathBFS::GetPathAsEdges ( )
virtual

Gets the shortest path between the source node and the destination node as an ordered set of edges.

Returns
Ordered set of edge identifiers.

Implements SinglePairShortestPath.

virtual sparksee::gdb::OIDList* SinglePairShortestPathBFS::GetPathAsNodes ( )
virtual

Gets the shortest path between the source node and the destination node as an ordered set of nodes.

Returns
Ordered set of node identifiers.

Implements SinglePairShortestPath.

void ShortestPath::SetMaximumHops ( sparksee::gdb::int32_t maxhops )
inherited

Sets the maximum hops restriction.

All paths longer than the maximum hops restriction will be ignored.

Parameters
maxhops [in] The maximum hops restriction. It must be positive or zero. Zero, the default value, means unlimited.

Member Data Documentation

sparksee::gdb::int32_t ShortestPath::maxHops
protectedinherited

Maximum hops restriction.

It must be positive or zero. Zero means unlimited.

sparksee::gdb::OIDList* SinglePairShortestPath::pathAsEdges
protectedinherited

Ordered set of edge identifiers representing the shortest path.

May be computed lazily when requested from the pathAsNodes.

The documentation for this class was generated from the following file:
  • SinglePairShortestPathBFS.h


Sparksee: SinglePairShortestPathDijkstraDynamicCost Class Reference

Public Member Functions | List of all members
SinglePairShortestPathDijkstraDynamicCost Class Referenceabstract
Algorithms

Defines how to calculate an edge weight. More...

Public Member Functions

virtual | ~SinglePairShortestPathDijkstraDynamicCost ()
Destructor.
virtual sparksee::gdb::double64_t | CalculateEdgeCost (sparksee::gdb::oid_t sourceNode, sparksee::gdb::double64_t sourceCost, sparksee::gdb::int32_t sourceLevel, sparksee::gdb::oid_t targetNode, sparksee::gdb::oid_t edge, sparksee::gdb::attr_t edgeWeightAttr)=0
Dynamic calculation of an edge weight.

Detailed Description

Defines how to calculate an edge weight.

This is an interface which must be implemented by the user. While the algorithm is running, one or more calls for each edge that can be in the shortest path will be issued to get the weight of the edge that could change based on the predecessor node and the current minimum path from the source.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

virtual sparksee::gdb::double64_t SinglePairShortestPathDijkstraDynamicCost::CalculateEdgeCost | ( | sparksee::gdb::oid_t | sourceNode,
 |  | sparksee::gdb::double64_t | sourceCost,
 |  | sparksee::gdb::int32_t | sourceLevel,
 |  | sparksee::gdb::oid_t | targetNode,
 |  | sparksee::gdb::oid_t | edge,
 |  | sparksee::gdb::attr_t | edgeWeightAttr
 | ) |  |
pure virtual

Dynamic calculation of an edge weight.

This method will be called several times during the algorithm execution. It can be called for the same edge multiple times because the path to the source node (and as a consequence the source weight and levels) might change while the algorithm is running. This method will have the normal default implementation that only uses the specified edge attribute to get the weight or the unweighted edge cost if the edge doesn't have the specified cost attribute. But it can be overriden in a derived user class to implement a dinamic edge weight, that may need the sourceCost and sourceLevels to calculate the weight.

Parameters
sourceNode | [in] The current node
sourceCost | [in] Current total cost up to the source node
sourceLevel | [in] Current path size up to the source node
targetNode | [in] The next node
edge | [in] The edge to the next node that this methos must weight
edgeWeightAttr | [in] The attribute that stores the edge weight or InvalidAttribute
Returns
Returns the current weight of the edge (>=0) or <0 if the edge can not be used.
The documentation for this class was generated from the following file:
  • SinglePairShortestPathDijkstra.h


Sparksee: SinglePairShortestPathDijkstra Class Reference

Classes | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
SinglePairShortestPathDijkstra Class Reference
Algorithms

SinglePairShortestPathDijkstra class. More...

Inheritance diagram for SinglePairShortestPathDijkstra:
Collaboration diagram for SinglePairShortestPathDijkstra:

Public Member Functions

virtual | ~SinglePairShortestPathDijkstra ()
Destructor.
virtual void | Run ()
Executes the algorithm.
virtual sparksee::gdb::OIDList * | GetPathAsNodes ()
Gets the shortest path between the source node and the destination node as an ordered set of nodes.
virtual sparksee::gdb::OIDList * | GetPathAsEdges ()
Gets the shortest path between the source node and the destination node as an ordered set of edges.
virtual sparksee::gdb::double64_t | GetCost ()
Gets the cost of the shortest path.
SinglePairShortestPathDijkstra (sparksee::gdb::Session &session, sparksee::gdb::oid_t src, sparksee::gdb::oid_t dst)
Creates a new instance.
virtual void | AddWeightedEdgeType (sparksee::gdb::type_t type, sparksee::gdb::EdgesDirection dir, sparksee::gdb::attr_t attr)
Allows for traversing edges of the given type using the given attribute as the weight.
virtual void | SetUnweightedEdgeCost (sparksee::gdb::double64_t weight)
Sets the weight assigned to the unweighted edges.
virtual void | SetDynamicEdgeCostCallback (SinglePairShortestPathDijkstraDynamicCost *dynCostCalculator)
Set a class callback to dynamically calculate the cost of the edges.
virtual sparksee::gdb::bool_t | Exists ()
Returns TRUE If a path exists or FALSE otherwise.
void | SetMaximumHops (sparksee::gdb::int32_t maxhops)
Sets the maximum hops restriction.
virtual void | AddEdgeType (sparksee::gdb::type_t type, sparksee::gdb::EdgesDirection dir)
Allows for traversing edges of the given type.
virtual void | AddAllEdgeTypes (sparksee::gdb::EdgesDirection dir)
Allows for traversing all edge types of the graph.
virtual void | AddNodeType (sparksee::gdb::type_t type)
Allows for traversing nodes of the given type.
virtual void | AddAllNodeTypes ()
Allows for traversing all node types of the graph.
virtual void | ExcludeNodes (sparksee::gdb::Objects &nodes)
Set which nodes can't be used.
virtual void | ExcludeEdges (sparksee::gdb::Objects &edges)
Set which edges can't be used.

Protected Member Functions

void | AssertEdgeType (sparksee::gdb::type_t edgetype)
Check that the given edge type is valid.
void | AssertAddedEdges ()
Check that edges had been added.
void | AssertAddedNodes ()
Check that nodes had been added.
void | AssertNodeType (sparksee::gdb::type_t nodetype)
Check that the given node type is valid.
sparksee::gdb::bool_t | IsNodeTypeAllowed (sparksee::gdb::oid_t nodeId)
Check if the given node has an allowed type.
void | AssertNotComputed ()
Check that the shortest path had not been calculated yet.
void | AssertComputed ()
Check that the shortest path had been calculated.
sparksee::gdb::bool_t | IsNodeExcluded (sparksee::gdb::oid_t node)
Check if the given node is forbidden.
sparksee::gdb::bool_t | IsEdgeExcluded (sparksee::gdb::oid_t edge)
Check if the given edge is forbidden.

Protected Attributes

sparksee::gdb::oid_t source
Source node.
sparksee::gdb::oid_t destination
Destination node.
sparksee::gdb::OIDList * | pathAsNodes
Ordered set of node identifiers representing the shortest path.
sparksee::gdb::OIDList * | pathAsEdges
Ordered set of edge identifiers representing the shortest path.
sparksee::gdb::Session * | sess
Session.
sparksee::gdb::Graph * | graph
Graph.
std::map
< sparksee::gdb::type_t,
sparksee::gdb::EdgesDirection > 		edgeTypes
Allowed edge types.
std::vector
< sparksee::gdb::type_t > 		nodeTypes
Allowed node types.
sparksee::gdb::int32_t maxHops
Maximum hops restriction.
sparksee::gdb::bool_t computed
True if the shortest path has been calculated.
sparksee::gdb::Objects * | excludedNodes
The set of excluded nodes.
sparksee::gdb::Objects * | excludedEdges
The set of excluded edges.
sparksee::gdb::bool_t areAllNodeTypesAllowed
True if all the node types are allowed.

Detailed Description

SinglePairShortestPathDijkstra class.

It solves the single-pair shortest path problem using a Dijkstra-based implementation.

It is a weighted algorithm, so it takes into account the cost of the edges to compute a minimum-cost shortest path. That is, the user may set for each edge type which attribute should be used to retrieve the cost of the edge. If no attribute is given for an edge type, this will assume the edge has a fixed cost (the default is 1). Only numerical attribute can be set as weight attributes (that is Long, Integer or Double attributes are allowed).

Check out the 'Algorithms' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

SinglePairShortestPathDijkstra::SinglePairShortestPathDijkstra | ( | sparksee::gdb::Session & | session,
 |  | sparksee::gdb::oid_t | src,
 |  | sparksee::gdb::oid_t | dst
 | ) |  |

Creates a new instance.

Parameters
session | [in] Session to get the graph from and perform traversal.
src | [in] Source node.
dst | [dst] Destination node.

Member Function Documentation

virtual void ShortestPath::AddAllEdgeTypes ( sparksee::gdb::EdgesDirection dir )
virtualinherited

Allows for traversing all edge types of the graph.

Parameters
dir [in] Edge direction.
virtual void ShortestPath::AddEdgeType | ( | sparksee::gdb::type_t | type,
 |  | sparksee::gdb::EdgesDirection | dir
 | ) |  |
virtualinherited

Allows for traversing edges of the given type.

Parameters
type | [in] Edge type.
dir | [in] Edge direction.
virtual void SinglePairShortestPathDijkstra::AddWeightedEdgeType | ( | sparksee::gdb::type_t | type,
 |  | sparksee::gdb::EdgesDirection | dir,
 |  | sparksee::gdb::attr_t | attr
 | ) |  |
virtual

Allows for traversing edges of the given type using the given attribute as the weight.

Parameters
type | [in] Edge type.
dir | [in] Edge direction.
attr | [in] Attribute to be used as the weight. It must be a global attribute or an attribute of the given edge type.
virtual void ShortestPath::ExcludeEdges ( sparksee::gdb::Objects & edges )
virtualinherited

Set which edges can't be used.

This will replace any previously specified set of excluded edges. Should only be used to exclude the usage of specific edges from allowed edge types because it's less efficient than not allowing an edge type.

Parameters
edges [in] A set of edge identifiers that must be kept intact until the destruction of the class.
virtual void ShortestPath::ExcludeNodes ( sparksee::gdb::Objects & nodes )
virtualinherited

Set which nodes can't be used.

This will replace any previously specified set of excluded nodes. Should only be used to exclude the usage of specific nodes from allowed node types because it's less efficient than not allowing a node type.

Parameters
nodes [in] A set of node identifiers that must be kept intact until the destruction of the class.
virtual sparksee::gdb::double64_t SinglePairShortestPathDijkstra::GetCost ( )
virtual

Gets the cost of the shortest path.

The cost is the sum of the weights of the edges in the shortest path.

Returns
The cost of the shortest path.

Implements SinglePairShortestPath.

virtual sparksee::gdb::OIDList* SinglePairShortestPathDijkstra::GetPathAsEdges ( )
virtual

Gets the shortest path between the source node and the destination node as an ordered set of edges.

Returns
Ordered set of edge identifiers.

Implements SinglePairShortestPath.

virtual sparksee::gdb::OIDList* SinglePairShortestPathDijkstra::GetPathAsNodes ( )
virtual

Gets the shortest path between the source node and the destination node as an ordered set of nodes.

Returns
Ordered set of node identifiers.

Implements SinglePairShortestPath.

virtual void SinglePairShortestPathDijkstra::SetDynamicEdgeCostCallback ( SinglePairShortestPathDijkstraDynamicCost * dynCostCalculator )
virtual

Set a class callback to dynamically calculate the cost of the edges.

The callback can be set to NULL (the default) to use the normal attribute based cost weights. The given class must be kept alive by the user for as long as the algorithm is running.

Parameters
dynCostCalculator [in] Class callback to calculate the edge costs
void ShortestPath::SetMaximumHops ( sparksee::gdb::int32_t maxhops )
inherited

Sets the maximum hops restriction.

All paths longer than the maximum hops restriction will be ignored.

Parameters
maxhops [in] The maximum hops restriction. It must be positive or zero. Zero, the default value, means unlimited.
virtual void SinglePairShortestPathDijkstra::SetUnweightedEdgeCost ( sparksee::gdb::double64_t weight )
virtual

Sets the weight assigned to the unweighted edges.

All the edges from the types added without an explicit weight attribute will get this weight. The default weight for this edges is 1.

Parameters
weight [in] The weight value for unweighted edges.

Member Data Documentation

sparksee::gdb::int32_t ShortestPath::maxHops
protectedinherited

Maximum hops restriction.

It must be positive or zero. Zero means unlimited.

sparksee::gdb::OIDList* SinglePairShortestPath::pathAsEdges
protectedinherited

Ordered set of edge identifiers representing the shortest path.

May be computed lazily when requested from the pathAsNodes.

The documentation for this class was generated from the following file:
  • SinglePairShortestPathDijkstra.h


Sparksee: SinglePairShortestPathDijkstra::FibonacciHeap::Node Struct Reference

  • SinglePairShortestPathDijkstra
  • FibonacciHeap
  • Node
List of all members
SinglePairShortestPathDijkstra::FibonacciHeap::Node Struct Reference
Algorithms

A FibonacciHeap node structure. More...

Collaboration diagram for SinglePairShortestPathDijkstra::FibonacciHeap::Node:

Detailed Description

A FibonacciHeap node structure.

The documentation for this struct was generated from the following file:
  • SinglePairShortestPathDijkstra.h


Sparksee: StrongConnectivity Class Reference

Public Member Functions | Protected Types | Protected Member Functions | Protected Attributes | List of all members
StrongConnectivity Class Referenceabstract
Algorithms

StrongConnectivity class. More...

Inheritance diagram for StrongConnectivity:
Collaboration diagram for StrongConnectivity:

Public Member Functions

virtual | ~StrongConnectivity ()
Destructor.
virtual void | AddEdgeType (sparksee::gdb::type_t type, sparksee::gdb::EdgesDirection dir)
Allows connectivity through edges of the given type.
virtual void | AddAllEdgeTypes (sparksee::gdb::EdgesDirection dir)
Allows connectivity through all edge types of the graph.
virtual void | AddNodeType (sparksee::gdb::type_t t)
Allows connectivity through nodes of the given type.
virtual void | AddAllNodeTypes ()
Allows connectivity through all node types of the graph.
virtual void | ExcludeNodes (sparksee::gdb::Objects &nodes)
Set which nodes can't be used.
virtual void | ExcludeEdges (sparksee::gdb::Objects &edges)
Set which edges can't be used.
ConnectedComponents * GetConnectedComponents ()
Returns the results generated by the execution of the algorithm.
virtual void | Run ()=0
Runs the algorithm in order to find the connected components.
void | SetMaterializedAttribute (const std::wstring &attributeName)
Creates a new common attribute type for all node types in the graph in order to store, persistently, the results related to the connected components found while executing this algorithm.

Protected Types

typedef std::map
< sparksee::gdb::type_t,
sparksee::gdb::EdgesDirection > 		EdgeTypes_t
A type definition to store allowed edge types.
typedef std::vector
< sparksee::gdb::type_t > 		NodeTypes_t
A type definition to store allowed node types.

Protected Member Functions

StrongConnectivity (sparksee::gdb::Session &s)
Creates a new instance of StrongConnectivity.
void | AssertAddedEdges ()
Check that edges had been added.
void | AssertAddedNodes ()
Check that nodes had been added.
void | AssertNotComputed ()
Check that the connectivity had not been calculated yet.
void | SetConnectedComponent (sparksee::gdb::oid_t idNode)
Assigns the current component to the given node.
void | SetNodesNotVisited ()
Set all the selected nodes in nodesNotVisited.
void | AssertNotComponentAttribute (const std::wstring &attributeName)
Check that the given attribute name is not already in use.
void | AssertComputed ()
Check that the connectivity had been calculated.
void | AssertEdgeType (sparksee::gdb::type_t edgetype)
Check that the given edge type is valid.
void | AssertNodeType (sparksee::gdb::type_t nodetype)
Check that the given node type is valid.
void | CreateGlobalPersistentAttribute (const std::wstring &attributeName)
Set a new persistent global attribute to store the connectivity information.
void | CreateGlobalTransientAttribute ()
Set a new temporary global attribute to store the connectivity information.
void | RemoveGlobalAttribute ()
Removes the global attribute where the connectivity information is stored.
sparksee::gdb::bool_t | IsNodeTypeAllowed (sparksee::gdb::oid_t nodeId)
Check if the given node has an allowed type.
sparksee::gdb::bool_t | IsNodeExcluded (sparksee::gdb::oid_t node)
Check if the given node is forbidden.
sparksee::gdb::bool_t | IsEdgeExcluded (sparksee::gdb::oid_t edge)
Check if the given edge is forbidden.

Protected Attributes

sparksee::gdb::Session * | sess
Session.
sparksee::gdb::Graph * | graph
Graph.
EdgeTypes_t edgeTypes
Allowed edge types.
std::vector
< sparksee::gdb::type_t > 		nodeTypes
Allowed node types.
sparksee::gdb::attr_t attrComponent
common attribute where the connected component information is stored.
std::wstring | attrComponentName
name of the common attribute where the connected component information is stored.
sparksee::gdb::int64_t actualComponent
Current component identifier.
sparksee::gdb::Objects * | nodesNotVisited
Identifiers of the nodes not visited.
sparksee::gdb::bool_t matResults
Materialized results.
sparksee::gdb::bool_t computed
True if the connectivity has been calculated.
sparksee::gdb::Objects * | excludedNodes
The set of excluded nodes.
sparksee::gdb::Objects * | excludedEdges
The set of excluded edges.
ConnectedComponents * ccs
The calculated connectivity information.

Detailed Description

StrongConnectivity class.

Any class implementing this abstract class can be used to solve the problem of finding strongly connected components in a directed graph.

It consists in finding components where every pair (u,v) of nodes contained in it has a path from u to v using the specified direction for each edge type.

It is possible to set some restrictions after constructing a new instance of this class and before running it in order to limit the results.

After the execution, we can retrieve the results stored in an instance of the ConnectedComponents class using the GetConnectedComponents method.

Check out the 'Algorithms' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

StrongConnectivity::StrongConnectivity ( sparksee::gdb::Session & s )
protected

Creates a new instance of StrongConnectivity.

Parameters
s [in] Session to get the graph from and calculate the connectivity

Member Function Documentation

virtual void StrongConnectivity::AddAllEdgeTypes ( sparksee::gdb::EdgesDirection dir )
virtual

Allows connectivity through all edge types of the graph.

Parameters
dir [in] Edge direction.
virtual void StrongConnectivity::AddEdgeType | ( | sparksee::gdb::type_t | type,
 |  | sparksee::gdb::EdgesDirection | dir
 | ) |  |
virtual

Allows connectivity through edges of the given type.

Parameters
type | [in] Edge type.
dir | [in] Edge direction.
virtual void Connectivity::ExcludeEdges ( sparksee::gdb::Objects & edges )
virtualinherited

Set which edges can't be used.

This will replace any previously specified set of excluded edges. Should only be used to exclude the usage of specific edges from allowed edge types because it's less efficient than not allowing an edge type.

Parameters
edges [in] A set of edge identifiers that must be kept intact until the destruction of the class.
virtual void Connectivity::ExcludeNodes ( sparksee::gdb::Objects & nodes )
virtualinherited

Set which nodes can't be used.

This will replace any previously specified set of excluded nodes. Should only be used to exclude the usage of specific nodes from allowed node types because it's less efficient than not allowing a node type.

Parameters
nodes [in] A set of node identifiers that must be kept intact until the destruction of the class.
ConnectedComponents* Connectivity::GetConnectedComponents ( )
inherited

Returns the results generated by the execution of the algorithm.

These results contain information related to the connected components found as the number of different components, the set of nodes contained in each component or many other data.

Returns
Returns an instance of the class ConnectedComponents which contain information related to the connected components found.
virtual void Connectivity::Run ( )
pure virtualinherited

Runs the algorithm in order to find the connected components.

This method can be called only once.

Implemented in WeakConnectivityDFS, and StrongConnectivityGabow.

void Connectivity::SetMaterializedAttribute ( const std::wstring & attributeName )
inherited

Creates a new common attribute type for all node types in the graph in order to store, persistently, the results related to the connected components found while executing this algorithm.

Whenever the user wants to retrieve the results, even when the graph has been closed and opened again, it is only necessary to create a new instance of the class ConnectedComponents indicating the graph and the name of the common attribute type which stores the results. This instance will have all the information related to the connected components found in the moment of the execution of the algorithm that stored this data.

It is possible to run the algorithm without specifying this parameter in order to avoid materializing the results of the execution.

Parameters
attributeName [in] The name of the common attribute type for all node types in the graph which will store persistently the results generated by the execution of the algorithm.
void Connectivity::SetNodesNotVisited ( )
protectedinherited

Set all the selected nodes in nodesNotVisited.

That's all the nodes of the allowed node types but not the excluded ones.

The documentation for this class was generated from the following file:
  • StrongConnectivity.h


Sparksee: StrongConnectivityGabow Class Reference

Classes | Public Member Functions | Protected Types | Protected Member Functions | Protected Attributes | List of all members
StrongConnectivityGabow Class Reference
Algorithms

This class can be used to solve the problem of finding strongly connected components in a directed graph. More...

Inheritance diagram for StrongConnectivityGabow:
Collaboration diagram for StrongConnectivityGabow:

Public Member Functions

StrongConnectivityGabow (sparksee::gdb::Session &session)
Creates a new instance of StrongConnectivityGabow.
virtual | ~StrongConnectivityGabow ()
Destructor.
void | Run ()
Executes the algorithm.
virtual void | AddEdgeType (sparksee::gdb::type_t type, sparksee::gdb::EdgesDirection dir)
Allows connectivity through edges of the given type.
virtual void | AddAllEdgeTypes (sparksee::gdb::EdgesDirection dir)
Allows connectivity through all edge types of the graph.
virtual void | AddNodeType (sparksee::gdb::type_t t)
Allows connectivity through nodes of the given type.
virtual void | AddAllNodeTypes ()
Allows connectivity through all node types of the graph.
virtual void | ExcludeNodes (sparksee::gdb::Objects &nodes)
Set which nodes can't be used.
virtual void | ExcludeEdges (sparksee::gdb::Objects &edges)
Set which edges can't be used.
ConnectedComponents * GetConnectedComponents ()
Returns the results generated by the execution of the algorithm.
void | SetMaterializedAttribute (const std::wstring &attributeName)
Creates a new common attribute type for all node types in the graph in order to store, persistently, the results related to the connected components found while executing this algorithm.

Protected Types

typedef std::map
< sparksee::gdb::type_t,
sparksee::gdb::EdgesDirection > 		EdgeTypes_t
A type definition to store allowed edge types.
typedef std::vector
< sparksee::gdb::type_t > 		NodeTypes_t
A type definition to store allowed node types.

Protected Member Functions

void | AssertAddedEdges ()
Check that edges had been added.
void | AssertAddedNodes ()
Check that nodes had been added.
void | AssertNotComputed ()
Check that the connectivity had not been calculated yet.
void | SetConnectedComponent (sparksee::gdb::oid_t idNode)
Assigns the current component to the given node.
void | SetNodesNotVisited ()
Set all the selected nodes in nodesNotVisited.
void | AssertNotComponentAttribute (const std::wstring &attributeName)
Check that the given attribute name is not already in use.
void | AssertComputed ()
Check that the connectivity had been calculated.
void | AssertEdgeType (sparksee::gdb::type_t edgetype)
Check that the given edge type is valid.
void | AssertNodeType (sparksee::gdb::type_t nodetype)
Check that the given node type is valid.
void | CreateGlobalPersistentAttribute (const std::wstring &attributeName)
Set a new persistent global attribute to store the connectivity information.
void | CreateGlobalTransientAttribute ()
Set a new temporary global attribute to store the connectivity information.
void | RemoveGlobalAttribute ()
Removes the global attribute where the connectivity information is stored.
sparksee::gdb::bool_t | IsNodeTypeAllowed (sparksee::gdb::oid_t nodeId)
Check if the given node has an allowed type.
sparksee::gdb::bool_t | IsNodeExcluded (sparksee::gdb::oid_t node)
Check if the given node is forbidden.
sparksee::gdb::bool_t | IsEdgeExcluded (sparksee::gdb::oid_t edge)
Check if the given edge is forbidden.

Protected Attributes

sparksee::gdb::Session * | sess
Session.
sparksee::gdb::Graph * | graph
Graph.
EdgeTypes_t edgeTypes
Allowed edge types.
std::vector
< sparksee::gdb::type_t > 		nodeTypes
Allowed node types.
sparksee::gdb::attr_t attrComponent
common attribute where the connected component information is stored.
std::wstring | attrComponentName
name of the common attribute where the connected component information is stored.
sparksee::gdb::int64_t actualComponent
Current component identifier.
sparksee::gdb::Objects * | nodesNotVisited
Identifiers of the nodes not visited.
sparksee::gdb::bool_t matResults
Materialized results.
sparksee::gdb::bool_t computed
True if the connectivity has been calculated.
sparksee::gdb::Objects * | excludedNodes
The set of excluded nodes.
sparksee::gdb::Objects * | excludedEdges
The set of excluded edges.
ConnectedComponents * ccs
The calculated connectivity information.

Detailed Description

This class can be used to solve the problem of finding strongly connected components in a directed graph.

It consists in finding components where every pair (u,v) of nodes contained in it has a path from u to v using the specified direction for each edge type. This implementation is based on the Gabow algorithm.

It is possible to set some restrictions after constructing a new instance of this class and before running it in order to limit the results.

After the execution, we can retrieve the results stored in an instance of the ConnectedComponents class using the GetConnectedComponents method.

Check out the 'Algorithms' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

StrongConnectivityGabow::StrongConnectivityGabow ( sparksee::gdb::Session & session )

Creates a new instance of StrongConnectivityGabow.

After creating this instance is required to indicate the set of edge types and the set of node types which will be navigated through while traversing the graph in order to find the strong connected components.

Parameters
session [in] Session to get the graph from and calculate the connectivity

Member Function Documentation

virtual void StrongConnectivity::AddAllEdgeTypes ( sparksee::gdb::EdgesDirection dir )
virtualinherited

Allows connectivity through all edge types of the graph.

Parameters
dir [in] Edge direction.
virtual void StrongConnectivity::AddEdgeType | ( | sparksee::gdb::type_t | type,
 |  | sparksee::gdb::EdgesDirection | dir
 | ) |  |
virtualinherited

Allows connectivity through edges of the given type.

Parameters
type | [in] Edge type.
dir | [in] Edge direction.
virtual void Connectivity::ExcludeEdges ( sparksee::gdb::Objects & edges )
virtualinherited

Set which edges can't be used.

This will replace any previously specified set of excluded edges. Should only be used to exclude the usage of specific edges from allowed edge types because it's less efficient than not allowing an edge type.

Parameters
edges [in] A set of edge identifiers that must be kept intact until the destruction of the class.
virtual void Connectivity::ExcludeNodes ( sparksee::gdb::Objects & nodes )
virtualinherited

Set which nodes can't be used.

This will replace any previously specified set of excluded nodes. Should only be used to exclude the usage of specific nodes from allowed node types because it's less efficient than not allowing a node type.

Parameters
nodes [in] A set of node identifiers that must be kept intact until the destruction of the class.
ConnectedComponents* Connectivity::GetConnectedComponents ( )
inherited

Returns the results generated by the execution of the algorithm.

These results contain information related to the connected components found as the number of different components, the set of nodes contained in each component or many other data.

Returns
Returns an instance of the class ConnectedComponents which contain information related to the connected components found.
void Connectivity::SetMaterializedAttribute ( const std::wstring & attributeName )
inherited

Creates a new common attribute type for all node types in the graph in order to store, persistently, the results related to the connected components found while executing this algorithm.

Whenever the user wants to retrieve the results, even when the graph has been closed and opened again, it is only necessary to create a new instance of the class ConnectedComponents indicating the graph and the name of the common attribute type which stores the results. This instance will have all the information related to the connected components found in the moment of the execution of the algorithm that stored this data.

It is possible to run the algorithm without specifying this parameter in order to avoid materializing the results of the execution.

Parameters
attributeName [in] The name of the common attribute type for all node types in the graph which will store persistently the results generated by the execution of the algorithm.
void Connectivity::SetNodesNotVisited ( )
protectedinherited

Set all the selected nodes in nodesNotVisited.

That's all the nodes of the allowed node types but not the excluded ones.

The documentation for this class was generated from the following file:
  • StrongConnectivityGabow.h


Sparksee: Traversal Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
Traversal Class Referenceabstract
Algorithms

Traversal class. More...

Inheritance diagram for Traversal:

Public Member Functions

virtual void | AddEdgeType (sparksee::gdb::type_t type, sparksee::gdb::EdgesDirection dir)
Allows for traversing edges of the given type.
virtual void | AddAllEdgeTypes (sparksee::gdb::EdgesDirection dir)
Allows for traversing all edge types of the graph.
virtual void | AddNodeType (sparksee::gdb::type_t type)
Allows for traversing nodes of the given type.
virtual void | AddAllNodeTypes ()
Allows for traversing all node types of the graph.
virtual void | ExcludeNodes (sparksee::gdb::Objects &nodes)
Set which nodes can't be used.
virtual void | ExcludeEdges (sparksee::gdb::Objects &edges)
Set which edges can't be used.
virtual sparksee::gdb::oid_t | Next ()=0
Gets the next object of the traversal.
virtual sparksee::gdb::bool_t | HasNext ()=0
Gets if there are more objects to be traversed.
virtual sparksee::gdb::int32_t | GetCurrentDepth () const =0
Returns the depth of the current node.
virtual void | SetMaximumHops (sparksee::gdb::int32_t maxhops)
Sets the maximum hops restriction.
virtual | ~Traversal ()
Destructor.

Protected Member Functions

Traversal (sparksee::gdb::Session &s, sparksee::gdb::oid_t node)
Creates a new instance.
void | AssertAddedEdges ()
Check that edges had been added.
void | AssertAddedNodes ()
Check that nodes had been added.
void | AssertEdgeType (sparksee::gdb::type_t edgetype)
Check that the given edge type is valid.
void | AssertNodeType (sparksee::gdb::type_t nodetype)
Check that the given node type is valid.
sparksee::gdb::bool_t | IsNodeTypeAllowed (sparksee::gdb::oid_t nodeId)
Check if the given node has an allowed type.
sparksee::gdb::bool_t | IsNodeExcluded (sparksee::gdb::oid_t node)
Check if the given node is forbidden.
sparksee::gdb::bool_t | IsEdgeExcluded (sparksee::gdb::oid_t edge)
Check if the given edge is forbidden.

Protected Attributes

sparksee::gdb::Session * | sess
Session.
sparksee::gdb::Graph * | graph
Graph.
sparksee::gdb::oid_t src
Source node of the traversal.
std::map
< sparksee::gdb::type_t,
sparksee::gdb::EdgesDirection > 		edgeTypes
Allowed edge types.
std::vector
< sparksee::gdb::type_t > 		nodeTypes
Allowed node types.
sparksee::gdb::int32_t maxHops
Maximum number of hops allowed.
sparksee::gdb::Objects * | excludedNodes
The set of excluded nodes.
sparksee::gdb::Objects * | excludedEdges
The set of excluded edges.

Detailed Description

Traversal class.

Any class implementing this abstract class can be used to traverse a graph.

Once the instance has been created and the allowed node and edge types has been set, it can be used as an iterator, retrieving the next object identifier of the traversal until there are no more.

Check out the 'Algorithms' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

Traversal::Traversal | ( | sparksee::gdb::Session & | s,
 |  | sparksee::gdb::oid_t | node
 | ) |  |
protected

Creates a new instance.

Parameters
s | [in] Session to get the graph from and perform traversal.
node | [in] Node to start traversal from.

Member Function Documentation

virtual void Traversal::AddAllEdgeTypes ( sparksee::gdb::EdgesDirection dir )
virtual

Allows for traversing all edge types of the graph.

Parameters
dir [in] Edge direction.

Reimplemented in RandomWalk.

virtual void Traversal::AddEdgeType | ( | sparksee::gdb::type_t | type,
 |  | sparksee::gdb::EdgesDirection | dir
 | ) |  |
virtual

Allows for traversing edges of the given type.

Parameters
type | [in] Edge type.
dir | [in] Edge direction.

Reimplemented in RandomWalk.

virtual void Traversal::AddNodeType ( sparksee::gdb::type_t type )
virtual

Allows for traversing nodes of the given type.

Parameters
type The node type to add

Reimplemented in RandomWalk.

virtual void Traversal::ExcludeEdges ( sparksee::gdb::Objects & edges )
virtual

Set which edges can't be used.

This will replace any previously specified set of excluded edges. Should only be used to exclude the usage of specific edges from allowed edge types because it's less efficient than not allowing an edge type.

Parameters
edges [in] A set of edge identifiers that must be kept intact until the destruction of the class.

Reimplemented in RandomWalk.

virtual void Traversal::ExcludeNodes ( sparksee::gdb::Objects & nodes )
virtual

Set which nodes can't be used.

This will replace any previously specified set of excluded nodes. Should only be used to exclude the usage of specific nodes from allowed node types because it's less efficient than not allowing a node type.

Parameters
nodes [in] A set of node identifiers that must be kept intact until the destruction of the class.

Reimplemented in RandomWalk.

virtual sparksee::gdb::int32_t Traversal::GetCurrentDepth ( ) const
pure virtual

Returns the depth of the current node.

That is, it returns the depth of the node returned in the last call to Next().

Returns
The depth of the current node.

Implemented in RandomWalk, TraversalBFS, and TraversalDFS.

virtual sparksee::gdb::bool_t Traversal::HasNext ( )
pure virtual

Gets if there are more objects to be traversed.

Returns
TRUE if there are more objects, FALSE otherwise.

Implemented in RandomWalk, TraversalBFS, and TraversalDFS.

virtual sparksee::gdb::oid_t Traversal::Next ( )
pure virtual

Gets the next object of the traversal.

Returns
A node or edge identifier.

Implemented in RandomWalk, TraversalBFS, and TraversalDFS.

virtual void Traversal::SetMaximumHops ( sparksee::gdb::int32_t maxhops )
virtual

Sets the maximum hops restriction.

All paths longer than the maximum hops restriction will be ignored.

Parameters
maxhops [in] The maximum hops restriction. It must be positive or zero. Zero, the default value, means unlimited.
The documentation for this class was generated from the following file:
  • Traversal.h


Sparksee: TraversalBFS Class Reference

Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
TraversalBFS Class Reference
Algorithms

Breadth-First Search implementation of Traversal. More...

Inheritance diagram for TraversalBFS:
Collaboration diagram for TraversalBFS:

Public Member Functions

virtual sparksee::gdb::oid_t | Next ()
Gets the next object of the traversal.
virtual sparksee::gdb::bool_t | HasNext ()
Gets if there are more objects to be traversed.
virtual | ~TraversalBFS ()
Destructor.
virtual sparksee::gdb::int32_t | GetCurrentDepth () const
Returns the depth of the current node.
TraversalBFS (sparksee::gdb::Session &session, sparksee::gdb::oid_t node)
Creates a new instance.
virtual void | AddEdgeType (sparksee::gdb::type_t type, sparksee::gdb::EdgesDirection dir)
Allows for traversing edges of the given type.
virtual void | AddAllEdgeTypes (sparksee::gdb::EdgesDirection dir)
Allows for traversing all edge types of the graph.
virtual void | AddNodeType (sparksee::gdb::type_t type)
Allows for traversing nodes of the given type.
virtual void | AddAllNodeTypes ()
Allows for traversing all node types of the graph.
virtual void | ExcludeNodes (sparksee::gdb::Objects &nodes)
Set which nodes can't be used.
virtual void | ExcludeEdges (sparksee::gdb::Objects &edges)
Set which edges can't be used.
virtual void | SetMaximumHops (sparksee::gdb::int32_t maxhops)
Sets the maximum hops restriction.

Protected Member Functions

void | AssertAddedEdges ()
Check that edges had been added.
void | AssertAddedNodes ()
Check that nodes had been added.
void | AssertEdgeType (sparksee::gdb::type_t edgetype)
Check that the given edge type is valid.
void | AssertNodeType (sparksee::gdb::type_t nodetype)
Check that the given node type is valid.
sparksee::gdb::bool_t | IsNodeTypeAllowed (sparksee::gdb::oid_t nodeId)
Check if the given node has an allowed type.
sparksee::gdb::bool_t | IsNodeExcluded (sparksee::gdb::oid_t node)
Check if the given node is forbidden.
sparksee::gdb::bool_t | IsEdgeExcluded (sparksee::gdb::oid_t edge)
Check if the given edge is forbidden.

Protected Attributes

sparksee::gdb::Session * | sess
Session.
sparksee::gdb::Graph * | graph
Graph.
sparksee::gdb::oid_t src
Source node of the traversal.
std::map
< sparksee::gdb::type_t,
sparksee::gdb::EdgesDirection > 		edgeTypes
Allowed edge types.
std::vector
< sparksee::gdb::type_t > 		nodeTypes
Allowed node types.
sparksee::gdb::int32_t maxHops
Maximum number of hops allowed.
sparksee::gdb::Objects * | excludedNodes
The set of excluded nodes.
sparksee::gdb::Objects * | excludedEdges
The set of excluded edges.

Detailed Description

Breadth-First Search implementation of Traversal.

Starting from a source node, it visits all its neighbors at distance 1, then all its neighbors at distance 2, and so on.

Check out the 'Algorithms' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

TraversalBFS::TraversalBFS | ( | sparksee::gdb::Session & | session,
 |  | sparksee::gdb::oid_t | node
 | ) |  |

Creates a new instance.

Parameters
session | [in] Session to get the graph from and perform traversal.
node | [in] Node to start traversal from.

Member Function Documentation

virtual void Traversal::AddAllEdgeTypes ( sparksee::gdb::EdgesDirection dir )
virtualinherited

Allows for traversing all edge types of the graph.

Parameters
dir [in] Edge direction.

Reimplemented in RandomWalk.

virtual void Traversal::AddEdgeType | ( | sparksee::gdb::type_t | type,
 |  | sparksee::gdb::EdgesDirection | dir
 | ) |  |
virtualinherited

Allows for traversing edges of the given type.

Parameters
type | [in] Edge type.
dir | [in] Edge direction.

Reimplemented in RandomWalk.

virtual void Traversal::AddNodeType ( sparksee::gdb::type_t type )
virtualinherited

Allows for traversing nodes of the given type.

Parameters
type The node type to add

Reimplemented in RandomWalk.

virtual void Traversal::ExcludeEdges ( sparksee::gdb::Objects & edges )
virtualinherited

Set which edges can't be used.

This will replace any previously specified set of excluded edges. Should only be used to exclude the usage of specific edges from allowed edge types because it's less efficient than not allowing an edge type.

Parameters
edges [in] A set of edge identifiers that must be kept intact until the destruction of the class.

Reimplemented in RandomWalk.

virtual void Traversal::ExcludeNodes ( sparksee::gdb::Objects & nodes )
virtualinherited

Set which nodes can't be used.

This will replace any previously specified set of excluded nodes. Should only be used to exclude the usage of specific nodes from allowed node types because it's less efficient than not allowing a node type.

Parameters
nodes [in] A set of node identifiers that must be kept intact until the destruction of the class.

Reimplemented in RandomWalk.

virtual sparksee::gdb::int32_t TraversalBFS::GetCurrentDepth ( ) const
virtual

Returns the depth of the current node.

That is, it returns the depth of the node returned in the last call to Next().

Returns
The depth of the current node.

Implements Traversal.

virtual sparksee::gdb::bool_t TraversalBFS::HasNext ( )
virtual

Gets if there are more objects to be traversed.

Returns
TRUE if there are more objects, FALSE otherwise.

Implements Traversal.

virtual sparksee::gdb::oid_t TraversalBFS::Next ( )
virtual

Gets the next object of the traversal.

Returns
A node or edge identifier.

Implements Traversal.

virtual void Traversal::SetMaximumHops ( sparksee::gdb::int32_t maxhops )
virtualinherited

Sets the maximum hops restriction.

All paths longer than the maximum hops restriction will be ignored.

Parameters
maxhops [in] The maximum hops restriction. It must be positive or zero. Zero, the default value, means unlimited.
The documentation for this class was generated from the following file:
  • TraversalBFS.h


Sparksee: TraversalDFS Class Reference

Classes | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
TraversalDFS Class Reference
Algorithms

Depth-First Search (DFS) implementation of Traversal. More...

Inheritance diagram for TraversalDFS:
Collaboration diagram for TraversalDFS:

Public Member Functions

virtual sparksee::gdb::oid_t | Next ()
Gets the next object of the traversal.
virtual sparksee::gdb::bool_t | HasNext ()
Gets if there are more objects to be traversed.
virtual sparksee::gdb::int32_t | GetCurrentDepth () const
Returns the depth of the current node.
virtual | ~TraversalDFS ()
Destructor.
TraversalDFS (sparksee::gdb::Session &session, sparksee::gdb::oid_t node)
Creates a new instance.
virtual void | AddEdgeType (sparksee::gdb::type_t type, sparksee::gdb::EdgesDirection dir)
Allows for traversing edges of the given type.
virtual void | AddAllEdgeTypes (sparksee::gdb::EdgesDirection dir)
Allows for traversing all edge types of the graph.
virtual void | AddNodeType (sparksee::gdb::type_t type)
Allows for traversing nodes of the given type.
virtual void | AddAllNodeTypes ()
Allows for traversing all node types of the graph.
virtual void | ExcludeNodes (sparksee::gdb::Objects &nodes)
Set which nodes can't be used.
virtual void | ExcludeEdges (sparksee::gdb::Objects &edges)
Set which edges can't be used.
virtual void | SetMaximumHops (sparksee::gdb::int32_t maxhops)
Sets the maximum hops restriction.

Protected Member Functions

void | AssertAddedEdges ()
Check that edges had been added.
void | AssertAddedNodes ()
Check that nodes had been added.
void | AssertEdgeType (sparksee::gdb::type_t edgetype)
Check that the given edge type is valid.
void | AssertNodeType (sparksee::gdb::type_t nodetype)
Check that the given node type is valid.
sparksee::gdb::bool_t | IsNodeTypeAllowed (sparksee::gdb::oid_t nodeId)
Check if the given node has an allowed type.
sparksee::gdb::bool_t | IsNodeExcluded (sparksee::gdb::oid_t node)
Check if the given node is forbidden.
sparksee::gdb::bool_t | IsEdgeExcluded (sparksee::gdb::oid_t edge)
Check if the given edge is forbidden.

Protected Attributes

sparksee::gdb::Session * | sess
Session.
sparksee::gdb::Graph * | graph
Graph.
sparksee::gdb::oid_t src
Source node of the traversal.
std::map
< sparksee::gdb::type_t,
sparksee::gdb::EdgesDirection > 		edgeTypes
Allowed edge types.
std::vector
< sparksee::gdb::type_t > 		nodeTypes
Allowed node types.
sparksee::gdb::int32_t maxHops
Maximum number of hops allowed.
sparksee::gdb::Objects * | excludedNodes
The set of excluded nodes.
sparksee::gdb::Objects * | excludedEdges
The set of excluded edges.

Detailed Description

Depth-First Search (DFS) implementation of Traversal.

Starting from a source or root node, it visits as far as possible along each branch before backtracking.

Check out the 'Algorithms' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

TraversalDFS::TraversalDFS | ( | sparksee::gdb::Session & | session,
 |  | sparksee::gdb::oid_t | node
 | ) |  |

Creates a new instance.

Parameters
session | [in] Session to get the graph from and perform traversal.
node | [in] Node to start traversal from.

Member Function Documentation

virtual void Traversal::AddAllEdgeTypes ( sparksee::gdb::EdgesDirection dir )
virtualinherited

Allows for traversing all edge types of the graph.

Parameters
dir [in] Edge direction.

Reimplemented in RandomWalk.

virtual void Traversal::AddEdgeType | ( | sparksee::gdb::type_t | type,
 |  | sparksee::gdb::EdgesDirection | dir
 | ) |  |
virtualinherited

Allows for traversing edges of the given type.

Parameters
type | [in] Edge type.
dir | [in] Edge direction.

Reimplemented in RandomWalk.

virtual void Traversal::AddNodeType ( sparksee::gdb::type_t type )
virtualinherited

Allows for traversing nodes of the given type.

Parameters
type The node type to add

Reimplemented in RandomWalk.

virtual void Traversal::ExcludeEdges ( sparksee::gdb::Objects & edges )
virtualinherited

Set which edges can't be used.

This will replace any previously specified set of excluded edges. Should only be used to exclude the usage of specific edges from allowed edge types because it's less efficient than not allowing an edge type.

Parameters
edges [in] A set of edge identifiers that must be kept intact until the destruction of the class.

Reimplemented in RandomWalk.

virtual void Traversal::ExcludeNodes ( sparksee::gdb::Objects & nodes )
virtualinherited

Set which nodes can't be used.

This will replace any previously specified set of excluded nodes. Should only be used to exclude the usage of specific nodes from allowed node types because it's less efficient than not allowing a node type.

Parameters
nodes [in] A set of node identifiers that must be kept intact until the destruction of the class.

Reimplemented in RandomWalk.

virtual sparksee::gdb::int32_t TraversalDFS::GetCurrentDepth ( ) const
virtual

Returns the depth of the current node.

That is, it returns the depth of the node returned in the last call to Next().

Returns
The depth of the current node.

Implements Traversal.

virtual sparksee::gdb::bool_t TraversalDFS::HasNext ( )
virtual

Gets if there are more objects to be traversed.

Returns
TRUE if there are more objects, FALSE otherwise.

Implements Traversal.

virtual sparksee::gdb::oid_t TraversalDFS::Next ( )
virtual

Gets the next object of the traversal.

Returns
A node or edge identifier.

Implements Traversal.

virtual void Traversal::SetMaximumHops ( sparksee::gdb::int32_t maxhops )
virtualinherited

Sets the maximum hops restriction.

All paths longer than the maximum hops restriction will be ignored.

Parameters
maxhops [in] The maximum hops restriction. It must be positive or zero. Zero, the default value, means unlimited.
The documentation for this class was generated from the following file:
  • TraversalDFS.h


Sparksee: WeakConnectivity Class Reference

Public Member Functions | Protected Types | Protected Member Functions | Protected Attributes | List of all members
WeakConnectivity Class Referenceabstract
Algorithms

WeakConnectivity class. More...

Inheritance diagram for WeakConnectivity:
Collaboration diagram for WeakConnectivity:

Public Member Functions

virtual | ~WeakConnectivity ()
Destructor.
virtual void | AddEdgeType (sparksee::gdb::type_t type)
Allows connectivity through edges of the given type.
virtual void | AddAllEdgeTypes ()
Allows connectivity through all edge types of the graph.
virtual void | AddNodeType (sparksee::gdb::type_t t)
Allows connectivity through nodes of the given type.
virtual void | AddAllNodeTypes ()
Allows connectivity through all node types of the graph.
virtual void | ExcludeNodes (sparksee::gdb::Objects &nodes)
Set which nodes can't be used.
virtual void | ExcludeEdges (sparksee::gdb::Objects &edges)
Set which edges can't be used.
ConnectedComponents * GetConnectedComponents ()
Returns the results generated by the execution of the algorithm.
virtual void | Run ()=0
Runs the algorithm in order to find the connected components.
void | SetMaterializedAttribute (const std::wstring &attributeName)
Creates a new common attribute type for all node types in the graph in order to store, persistently, the results related to the connected components found while executing this algorithm.

Protected Types

typedef std::map
< sparksee::gdb::type_t,
sparksee::gdb::EdgesDirection > 		EdgeTypes_t
A type definition to store allowed edge types.
typedef std::vector
< sparksee::gdb::type_t > 		NodeTypes_t
A type definition to store allowed node types.

Protected Member Functions

WeakConnectivity (sparksee::gdb::Session &s)
Creates a new instance of WeakConnectivity.
void | AddEdgeType (sparksee::gdb::type_t t, sparksee::gdb::EdgesDirection d)
Allows connectivity through edges of the given type.
void | AddAllEdgeTypes (sparksee::gdb::EdgesDirection d)
Allows connectivity through all edge types of the graph.
void | AssertAddedEdges ()
Check that edges had been added.
void | AssertAddedNodes ()
Check that nodes had been added.
void | AssertNotComputed ()
Check that the connectivity had not been calculated yet.
void | SetConnectedComponent (sparksee::gdb::oid_t idNode)
Assigns the current component to the given node.
void | SetNodesNotVisited ()
Set all the selected nodes in nodesNotVisited.
void | AssertNotComponentAttribute (const std::wstring &attributeName)
Check that the given attribute name is not already in use.
void | AssertComputed ()
Check that the connectivity had been calculated.
void | AssertEdgeType (sparksee::gdb::type_t edgetype)
Check that the given edge type is valid.
void | AssertNodeType (sparksee::gdb::type_t nodetype)
Check that the given node type is valid.
void | CreateGlobalPersistentAttribute (const std::wstring &attributeName)
Set a new persistent global attribute to store the connectivity information.
void | CreateGlobalTransientAttribute ()
Set a new temporary global attribute to store the connectivity information.
void | RemoveGlobalAttribute ()
Removes the global attribute where the connectivity information is stored.
sparksee::gdb::bool_t | IsNodeTypeAllowed (sparksee::gdb::oid_t nodeId)
Check if the given node has an allowed type.
sparksee::gdb::bool_t | IsNodeExcluded (sparksee::gdb::oid_t node)
Check if the given node is forbidden.
sparksee::gdb::bool_t | IsEdgeExcluded (sparksee::gdb::oid_t edge)
Check if the given edge is forbidden.

Protected Attributes

sparksee::gdb::Session * | sess
Session.
sparksee::gdb::Graph * | graph
Graph.
EdgeTypes_t edgeTypes
Allowed edge types.
std::vector
< sparksee::gdb::type_t > 		nodeTypes
Allowed node types.
sparksee::gdb::attr_t attrComponent
common attribute where the connected component information is stored.
std::wstring | attrComponentName
name of the common attribute where the connected component information is stored.
sparksee::gdb::int64_t actualComponent
Current component identifier.
sparksee::gdb::Objects * | nodesNotVisited
Identifiers of the nodes not visited.
sparksee::gdb::bool_t matResults
Materialized results.
sparksee::gdb::bool_t computed
True if the connectivity has been calculated.
sparksee::gdb::Objects * | excludedNodes
The set of excluded nodes.
sparksee::gdb::Objects * | excludedEdges
The set of excluded edges.
ConnectedComponents * ccs
The calculated connectivity information.

Detailed Description

WeakConnectivity class.

Any class implementing this abstract class can be used to solve the problem of finding weakly connected components in an undirected graph or in a directed graph which will be considered as an undirected one.

It consists in finding components where every pair (u,v) of nodes contained in it has a path from u to v and from v to u.

It is possible to set some restrictions after constructing a new instance of this class and before running it in order to limit the results.

After the execution, we can retrieve the results stored in an instance of the ConnectedComponents class using the getConnectedComponents method.

Check out the 'Algorithms' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

WeakConnectivity::WeakConnectivity ( sparksee::gdb::Session & s )
protected

Creates a new instance of WeakConnectivity.

Parameters
s [in] Session to get the graph from and calculate the connectivity

Member Function Documentation

virtual void WeakConnectivity::AddAllEdgeTypes ( )
virtual

Allows connectivity through all edge types of the graph.

In a weak connectivity the edges can be used in Any direction.

void Connectivity::AddAllEdgeTypes ( sparksee::gdb::EdgesDirection d )
protectedinherited

Allows connectivity through all edge types of the graph.

Parameters
d [in] Edge direction.
virtual void WeakConnectivity::AddEdgeType ( sparksee::gdb::type_t type )
virtual

Allows connectivity through edges of the given type.

In a weak connectivity the edges can be used in Any direction.

Parameters
type [in] Edge type.
void Connectivity::AddEdgeType | ( | sparksee::gdb::type_t | t,
 |  | sparksee::gdb::EdgesDirection | d
 | ) |  |
protectedinherited

Allows connectivity through edges of the given type.

Parameters
t | [in] Edge type.
d | [in] Edge direction.
virtual void Connectivity::ExcludeEdges ( sparksee::gdb::Objects & edges )
virtualinherited

Set which edges can't be used.

This will replace any previously specified set of excluded edges. Should only be used to exclude the usage of specific edges from allowed edge types because it's less efficient than not allowing an edge type.

Parameters
edges [in] A set of edge identifiers that must be kept intact until the destruction of the class.
virtual void Connectivity::ExcludeNodes ( sparksee::gdb::Objects & nodes )
virtualinherited

Set which nodes can't be used.

This will replace any previously specified set of excluded nodes. Should only be used to exclude the usage of specific nodes from allowed node types because it's less efficient than not allowing a node type.

Parameters
nodes [in] A set of node identifiers that must be kept intact until the destruction of the class.
ConnectedComponents* Connectivity::GetConnectedComponents ( )
inherited

Returns the results generated by the execution of the algorithm.

These results contain information related to the connected components found as the number of different components, the set of nodes contained in each component or many other data.

Returns
Returns an instance of the class ConnectedComponents which contain information related to the connected components found.
virtual void Connectivity::Run ( )
pure virtualinherited

Runs the algorithm in order to find the connected components.

This method can be called only once.

Implemented in WeakConnectivityDFS, and StrongConnectivityGabow.

void Connectivity::SetMaterializedAttribute ( const std::wstring & attributeName )
inherited

Creates a new common attribute type for all node types in the graph in order to store, persistently, the results related to the connected components found while executing this algorithm.

Whenever the user wants to retrieve the results, even when the graph has been closed and opened again, it is only necessary to create a new instance of the class ConnectedComponents indicating the graph and the name of the common attribute type which stores the results. This instance will have all the information related to the connected components found in the moment of the execution of the algorithm that stored this data.

It is possible to run the algorithm without specifying this parameter in order to avoid materializing the results of the execution.

Parameters
attributeName [in] The name of the common attribute type for all node types in the graph which will store persistently the results generated by the execution of the algorithm.
void Connectivity::SetNodesNotVisited ( )
protectedinherited

Set all the selected nodes in nodesNotVisited.

That's all the nodes of the allowed node types but not the excluded ones.

The documentation for this class was generated from the following file:
  • WeakConnectivity.h
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: WeakConnectivityDFS Class Reference

Public Member Functions | Protected Types | Protected Member Functions | Protected Attributes | List of all members
WeakConnectivityDFS Class Reference
Algorithms

WeakConnectivityDFS class. More...

Inheritance diagram for WeakConnectivityDFS:
Collaboration diagram for WeakConnectivityDFS:

Public Member Functions

WeakConnectivityDFS (sparksee::gdb::Session &session)
Creates a new instance of WeakConnectivityDFS.
virtual | ~WeakConnectivityDFS ()
Destructor.
void | Run ()
Executes the algorithm.
virtual void | AddEdgeType (sparksee::gdb::type_t type)
Allows connectivity through edges of the given type.
virtual void | AddAllEdgeTypes ()
Allows connectivity through all edge types of the graph.
virtual void | AddNodeType (sparksee::gdb::type_t t)
Allows connectivity through nodes of the given type.
virtual void | AddAllNodeTypes ()
Allows connectivity through all node types of the graph.
virtual void | ExcludeNodes (sparksee::gdb::Objects &nodes)
Set which nodes can't be used.
virtual void | ExcludeEdges (sparksee::gdb::Objects &edges)
Set which edges can't be used.
ConnectedComponents * GetConnectedComponents ()
Returns the results generated by the execution of the algorithm.
void | SetMaterializedAttribute (const std::wstring &attributeName)
Creates a new common attribute type for all node types in the graph in order to store, persistently, the results related to the connected components found while executing this algorithm.

Protected Types

typedef std::map
< sparksee::gdb::type_t,
sparksee::gdb::EdgesDirection > 		EdgeTypes_t
A type definition to store allowed edge types.
typedef std::vector
< sparksee::gdb::type_t > 		NodeTypes_t
A type definition to store allowed node types.

Protected Member Functions

void | AddEdgeType (sparksee::gdb::type_t t, sparksee::gdb::EdgesDirection d)
Allows connectivity through edges of the given type.
void | AddAllEdgeTypes (sparksee::gdb::EdgesDirection d)
Allows connectivity through all edge types of the graph.
void | AssertAddedEdges ()
Check that edges had been added.
void | AssertAddedNodes ()
Check that nodes had been added.
void | AssertNotComputed ()
Check that the connectivity had not been calculated yet.
void | SetConnectedComponent (sparksee::gdb::oid_t idNode)
Assigns the current component to the given node.
void | SetNodesNotVisited ()
Set all the selected nodes in nodesNotVisited.
void | AssertNotComponentAttribute (const std::wstring &attributeName)
Check that the given attribute name is not already in use.
void | AssertComputed ()
Check that the connectivity had been calculated.
void | AssertEdgeType (sparksee::gdb::type_t edgetype)
Check that the given edge type is valid.
void | AssertNodeType (sparksee::gdb::type_t nodetype)
Check that the given node type is valid.
void | CreateGlobalPersistentAttribute (const std::wstring &attributeName)
Set a new persistent global attribute to store the connectivity information.
void | CreateGlobalTransientAttribute ()
Set a new temporary global attribute to store the connectivity information.
void | RemoveGlobalAttribute ()
Removes the global attribute where the connectivity information is stored.
sparksee::gdb::bool_t | IsNodeTypeAllowed (sparksee::gdb::oid_t nodeId)
Check if the given node has an allowed type.
sparksee::gdb::bool_t | IsNodeExcluded (sparksee::gdb::oid_t node)
Check if the given node is forbidden.
sparksee::gdb::bool_t | IsEdgeExcluded (sparksee::gdb::oid_t edge)
Check if the given edge is forbidden.

Protected Attributes

sparksee::gdb::Session * | sess
Session.
sparksee::gdb::Graph * | graph
Graph.
EdgeTypes_t edgeTypes
Allowed edge types.
std::vector
< sparksee::gdb::type_t > 		nodeTypes
Allowed node types.
sparksee::gdb::attr_t attrComponent
common attribute where the connected component information is stored.
std::wstring | attrComponentName
name of the common attribute where the connected component information is stored.
sparksee::gdb::int64_t actualComponent
Current component identifier.
sparksee::gdb::Objects * | nodesNotVisited
Identifiers of the nodes not visited.
sparksee::gdb::bool_t matResults
Materialized results.
sparksee::gdb::bool_t computed
True if the connectivity has been calculated.
sparksee::gdb::Objects * | excludedNodes
The set of excluded nodes.
sparksee::gdb::Objects * | excludedEdges
The set of excluded edges.
ConnectedComponents * ccs
The calculated connectivity information.

Detailed Description

WeakConnectivityDFS class.

This class can be used to solve the problem of finding weakly connected components in an undirected graph or in a directed graph which will be considered as an undirected one.

It consists in finding components where every pair (u,v) of nodes contained in it has a path from u to v and from v to u. This implementation is based on the Depth-First Search (DFS) algorithm.

It is possible to set some restrictions after constructing a new instance of this class and before running it in order to limit the results.

After the execution, we can retrieve the results stored in an instance of the ConnectedComponents class using the getConnectedComponents method.

Check out the 'Algorithms' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

WeakConnectivityDFS::WeakConnectivityDFS ( sparksee::gdb::Session & session )

Creates a new instance of WeakConnectivityDFS.

After creating this instance is required to indicate the set of edge types and the set of node types which will be navigated through while traversing the graph in order to find the weak connected components.

Parameters
session [in] Session to get the graph from and calculate the connectivity

Member Function Documentation

virtual void WeakConnectivity::AddAllEdgeTypes ( )
virtualinherited

Allows connectivity through all edge types of the graph.

In a weak connectivity the edges can be used in Any direction.

void Connectivity::AddAllEdgeTypes ( sparksee::gdb::EdgesDirection d )
protectedinherited

Allows connectivity through all edge types of the graph.

Parameters
d [in] Edge direction.
virtual void WeakConnectivity::AddEdgeType ( sparksee::gdb::type_t type )
virtualinherited

Allows connectivity through edges of the given type.

In a weak connectivity the edges can be used in Any direction.

Parameters
type [in] Edge type.
void Connectivity::AddEdgeType | ( | sparksee::gdb::type_t | t,
 |  | sparksee::gdb::EdgesDirection | d
 | ) |  |
protectedinherited

Allows connectivity through edges of the given type.

Parameters
t | [in] Edge type.
d | [in] Edge direction.
virtual void Connectivity::ExcludeEdges ( sparksee::gdb::Objects & edges )
virtualinherited

Set which edges can't be used.

This will replace any previously specified set of excluded edges. Should only be used to exclude the usage of specific edges from allowed edge types because it's less efficient than not allowing an edge type.

Parameters
edges [in] A set of edge identifiers that must be kept intact until the destruction of the class.
virtual void Connectivity::ExcludeNodes ( sparksee::gdb::Objects & nodes )
virtualinherited

Set which nodes can't be used.

This will replace any previously specified set of excluded nodes. Should only be used to exclude the usage of specific nodes from allowed node types because it's less efficient than not allowing a node type.

Parameters
nodes [in] A set of node identifiers that must be kept intact until the destruction of the class.
ConnectedComponents* Connectivity::GetConnectedComponents ( )
inherited

Returns the results generated by the execution of the algorithm.

These results contain information related to the connected components found as the number of different components, the set of nodes contained in each component or many other data.

Returns
Returns an instance of the class ConnectedComponents which contain information related to the connected components found.
void Connectivity::SetMaterializedAttribute ( const std::wstring & attributeName )
inherited

Creates a new common attribute type for all node types in the graph in order to store, persistently, the results related to the connected components found while executing this algorithm.

Whenever the user wants to retrieve the results, even when the graph has been closed and opened again, it is only necessary to create a new instance of the class ConnectedComponents indicating the graph and the name of the common attribute type which stores the results. This instance will have all the information related to the connected components found in the moment of the execution of the algorithm that stored this data.

It is possible to run the algorithm without specifying this parameter in order to avoid materializing the results of the execution.

Parameters
attributeName [in] The name of the common attribute type for all node types in the graph which will store persistently the results generated by the execution of the algorithm.
void Connectivity::SetNodesNotVisited ( )
protectedinherited

Set all the selected nodes in nodesNotVisited.

That's all the nodes of the allowed node types but not the excluded ones.

The documentation for this class was generated from the following file:
  • WeakConnectivityDFS.h
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
o C AppError | Application error class
o C Attribute | Attribute data class
o C AttributeList | Sparksee attribute identifier list
o C AttributeListIterator | AttributeList iterator class
o C AttributeStatistics | Attribute statistics class
o C BooleanList | Boolean list
o C BooleanListIterator | BooleanList iterator class
o C BulkLoader | Base TypeLoader class
o C CommunitiesSCD | CommunitiesSCD class
o C CommunityDetection | CommunityDetection class
o C ConnectedComponents | ConnectedComponents class
o C Connectivity | Connectivity class
o C Context | Context class
o C CSVLoader |
o C CSVReader | CSVReader interface
o C CSVWriter | CSVWriter interface
o C Database | Database class
o C DatabaseStatistics | Database statistics
o C DefaultExport | Default implementation for ExportManager class
o C DisjointCommunities | DisjointCommunities class
o C DisjointCommunityDetection | DisjointCommunityDetection class
o C EdgeData | Edge data class
o C EdgeExport | Stores edge exporting values
o C EdgeTypeExporter | EdgeTypeExporter class
o C EdgeTypeLoader | EdgeTypeLoader class
o C EncryptionError | Wrong encryption arguments error class
o C Error | Error class
o C Exception | Exception class
o C ExportManager | Defines how to export a graph to an external format
o C FileNotFoundException | File not found exception class
o C Graph | Graph class
o C GraphExport | Stores the graph exporting values
o C Handler | Handles a reference
o C Int32List | Sparksee 32-bit signed integer list
o C Int32ListIterator | Int32List iterator class
o C IOError | IO error class
o C IOException | IO exception class
o C KeyValue |
o C KeyValues | Value set class
o C KOpt | KOpt class
o C LicenseError | License error class
o C NodeExport | Stores the node exporting values
o C NodeTypeExporter | NodeTypeExporter class
o C NodeTypeLoader | NodeTypeLoader class
o C NoSuchElementException | No such element exception class
o C Objects | Object identifier set class
o C ObjectsIterator | ObjectsIterator class
o C OIDList | Sparksee object identifier list
o C OIDListIterator | OIDList iterator class
o C PageRank | PageRank class
o C Platform | Platform class
o C PlatformStatistics | Platform data and statistics
o C Query | Query class
o C QueryContext | Query context interface
o C QueryException | Query exception class
o C QueryStream | Query stream interface
o C RandomWalk | RandomWalk class
o C ResultSet | ResultSet class
o C ResultSetList | ResultSet list
o C ResultSetListIterator | ResultSetList iterator class
o C RowReader | RowReader interface
o C RowWriter | RowWriter interface
o C ScriptParser | ScriptParser
o C Session | Session class
o C ShortestPath | ShortestPath class
o C SinglePairShortestPath | SinglePairShortestPath class
o C SinglePairShortestPathBFS | SinglePairShortestPathBFS class
o C SinglePairShortestPathDijkstra | SinglePairShortestPathDijkstra class
o C SinglePairShortestPathDijkstraDynamicCost | Defines how to calculate an edge weight
o C Sparksee | Sparksee class
o C SparkseeConfig | Sparksee configuration class
o C SparkseeProperties | Sparksee properties file
o C StringList | String list
o C StringListIterator | StringList iterator class
o C StrongConnectivity | StrongConnectivity class
o C StrongConnectivityGabow | This class can be used to solve the problem of finding strongly connected components in a directed graph
o C SystemError | System error class
o C TextStream | TextStream class
o C Traversal | Traversal class
o C TraversalBFS | Breadth-First Search implementation of Traversal
o C TraversalDFS | Depth-First Search (DFS) implementation of Traversal
o C Type | Type data class
o C TypeExporter | Base TypeExporter class
o C TypeExporterEvent | Provides information about the progress of an TypeExproter instance
o C TypeExporterListener | Interface to be implemented to receive TypeExporterEvent events from a TypeExporter
o C TypeList | Sparksee type identifier list
o C TypeListIterator | TypeList iterator class
o C TypeLoader | Base TypeLoader class
o C TypeLoaderEvent | Provides information about the progress of a TypeLoader instance
o C TypeLoaderListener | Interface to be implemented to receive TypeLoaderEvent events from a TypeLoader
o C UnsupportedOperationError | Unsupported operation error class
o C Value | Value class
o C ValueArray | ValueArray class
o C ValueList | Value list
o C ValueListIterator | ValueList iterator class
o C Values | Value set class
o C ValuesIterator | Values iterator class
o C WeakConnectivity | WeakConnectivity class
o C WeakConnectivityDFS | WeakConnectivityDFS class
\ C WrongArgumentError | Wrong argument error class
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: CSVLoader Class Reference

Static Public Member Functions | List of all members
CSVLoader Class Reference

Static Public Member Functions

static void | LoadNodes (sparksee::gdb::Graph &graph, const std::wstring &fileName, const std::wstring &nodeType, const std::wstring &separator=std::wstring(L","), sparksee::gdb::bool_t header=true, const std::vector< sparksee::gdb::int32_t > &columns=std::vector< sparksee::gdb::int32_t >(), const std::vector< std::wstring > &attrNames=std::vector< std::wstring >(), const std::vector< sparksee::gdb::DataType > &dataTypes=std::vector< sparksee::gdb::DataType >(), const std::vector< sparksee::gdb::AttributeKind > &attrKinds=std::vector< sparksee::gdb::AttributeKind >())
Loads nodes from a CSV file.
static void | LoadEdges (sparksee::gdb::Graph &graph, const std::wstring &fileName, const std::wstring &edgeType, const std::wstring &tailNodeType, const std::wstring &headNodeType, sparksee::gdb::int32_t tail=0, sparksee::gdb::int32_t head=1, const std::wstring &separator=std::wstring(L","), sparksee::gdb::bool_t directed=true, sparksee::gdb::bool_t header=true, sparksee::gdb::MissingEndpoint onMissingTail=gdb::IsError, sparksee::gdb::MissingEndpoint onMissingHead=gdb::IsError, const std::vector< sparksee::gdb::int32_t > &columns=std::vector< sparksee::gdb::int32_t >(), const std::vector< std::wstring > &attrNames=std::vector< std::wstring >(), const std::vector< sparksee::gdb::DataType > &dataTypes=std::vector< sparksee::gdb::DataType >(), const std::vector< sparksee::gdb::AttributeKind > &attrKinds=std::vector< sparksee::gdb::AttributeKind >())
Loads edges from a CSV file.

Member Function Documentation

static void CSVLoader::LoadEdges | ( | sparksee::gdb::Graph & | graph,
 |  | const std::wstring & | fileName,
 |  | const std::wstring & | edgeType,
 |  | const std::wstring & | tailNodeType,
 |  | const std::wstring & | headNodeType,
 |  | sparksee::gdb::int32_t | tail = 0,
 |  | sparksee::gdb::int32_t | head = 1,
 |  | const std::wstring & | separator = std::wstring(L","),
 |  | sparksee::gdb::bool_t | directed = true,
 |  | sparksee::gdb::bool_t | header = true,
 |  | sparksee::gdb::MissingEndpoint | onMissingTail = gdb::IsError,
 |  | sparksee::gdb::MissingEndpoint | onMissingHead = gdb::IsError,
 |  | const std::vector< sparksee::gdb::int32_t > & | columns = std::vector< sparksee::gdb::int32_t >(),
 |  | const std::vector< std::wstring > & | attrNames = std::vector< std::wstring >(),
 |  | const std::vector< sparksee::gdb::DataType > & | dataTypes = std::vector< sparksee::gdb::DataType >(),
 |  | const std::vector< sparksee::gdb::AttributeKind > & | attrKinds = std::vector< sparksee::gdb::AttributeKind >()
 | ) |  |
static

Loads edges from a CSV file.

Parameters
graph | [in] The graph to load the edges into
fileName | [in] The name of the file
nodeType | [in] The type of the edge to load. If it does not exist, it creates it
tailNodeType | [in] The type of the tail nodes. If it does not exist and onMissingTail is set to "Create", it creates it. Otherwise, an exception is thrown
headNodeType | [in] The type of the head nodes. It it does not exist and onMissingHead is set to "Create", it creates it. Otherwise, an exception is thrown
tail | [in] The tail column index. Default: 0
head | [in] The head column index. Default: 1
separator | [in] The column separator. Default: ","
directed | [in] True if this edge is directed or not. False otherwise. Default: True
header | [in] True if the CSV contains a header. False otherwise. Default: True
onMissingTail | [in] The policy to follow when a tail is missing. Default: "IsError"
onMissingHead | [in] The policy to follow when a head is missing. Default: "IsError"
columns | [in] The list of columns to load. tail and head columns must be in this list if this list is specified. If the list is empty, all columns are loaded. Default: empty
attrNames | [in] The attribute names. If this list is empty and hasHeader is set to true, the header values are used as attribute names. Default: empty
dataTypes | [in] The dataTypes of the attributes if this do not already exist. If this list is empty, the method tries to infer the data type from the first non-header row. Default: empty
attrKinds | [in] The attributeKinds of the attributes if these do not already exist. If this list is empty, the attributeKind of the created attributes are set to Basic. Default: empty
static void CSVLoader::LoadNodes | ( | sparksee::gdb::Graph & | graph,
 |  | const std::wstring & | fileName,
 |  | const std::wstring & | nodeType,
 |  | const std::wstring & | separator = std::wstring(L","),
 |  | sparksee::gdb::bool_t | header = true,
 |  | const std::vector< sparksee::gdb::int32_t > & | columns = std::vector< sparksee::gdb::int32_t >(),
 |  | const std::vector< std::wstring > & | attrNames = std::vector< std::wstring >(),
 |  | const std::vector< sparksee::gdb::DataType > & | dataTypes = std::vector< sparksee::gdb::DataType >(),
 |  | const std::vector< sparksee::gdb::AttributeKind > & | attrKinds = std::vector< sparksee::gdb::AttributeKind >()
 | ) |  |
static

Loads nodes from a CSV file.

Parameters
graph | [in] The graph to load the nodes into
fileName | [in] The name of the file
nodeType | [in] The type of the node to load. If it does not exist, it creates it
separator | [in] The separator of the CSV file. Default: ","
header | [in] True if the CSV contains a header. False otherwise. Default: True
columns | [in] The list of columns to load. tail and head columns mus be in this list if this list is specified. Default: all columns
attrNames | [in] The attribute names. If this list is empty and hasHeader is set to true, the header values are used as attribute names. Default: empty
dataTypes | [in] The dataTypes of the attributes if this do not already exist. Default: empty If this list is empty, the method tries to infer the data type from the first non-header row
attrKinds | [in] The attributeKinds of the attributes if these do not already exist. Default: empty If this list is empty, the attributeKind of the created attributes are set to Basic. Default: empty
The documentation for this class was generated from the following file:
  • CSVLoader.h


Sparksee: Class Index

Class Index
A | B | C | D | E | F | G | H | I | K | L | N | O | P | Q | R | S | T | U | V | W
A
E
KeyValues
R
TraversalBFS
KOpt TraversalDFS
AppError EdgeData
L
RandomWalk Type
Attribute EdgeExport ResultSet TypeExporter
AttributeList EdgeTypeExporter LicenseError ResultSetList TypeExporterEvent
AttributeListIterator EdgeTypeLoader
N
ResultSetListIterator TypeExporterListener
AttributeStatistics EncryptionError RowReader TypeList
B
Error SinglePairShortestPathDijkstra::FibonacciHeap::Node RowWriter TypeListIterator
Exception NodeExport
S
TypeLoader
BooleanList ExportManager NodeTypeExporter TypeLoaderEvent
BooleanListIterator
F
NodeTypeLoader ScriptParser TypeLoaderListener
BulkLoader NoSuchElementException Session
U
C
FileNotFoundException
O
ShortestPath
G
SinglePairShortestPath UnsupportedOperationError
CommunitiesSCD Objects SinglePairShortestPathBFS
V
CommunityDetection Graph ObjectsIterator SinglePairShortestPathDijkstra
ConnectedComponents GraphExport OIDList SinglePairShortestPathDijkstraDynamicCost Value
Connectivity
H
OIDListIterator Sparksee ValueArray
Context
P
SparkseeConfig ValueList
CSVLoader Handler SparkseeProperties ValueListIterator
CSVReader
I
PageRank StringList Values
CSVWriter Platform StringListIterator ValuesIterator
D
Int32List PlatformStatistics StrongConnectivity
W
Int32ListIterator
Q
StrongConnectivityGabow
Database IOError SystemError WeakConnectivity
DatabaseStatistics IOException Query
T
WeakConnectivityDFS
DefaultExport
K
QueryContext WrongArgumentError
DisjointCommunities QueryException TextStream
DisjointCommunityDetection KeyValue QueryStream Traversal
A | B | C | D | E | F | G | H | I | K | L | N | O | P | Q | R | S | T | U | V | W
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Hierarchy

Class Hierarchy

Go to the graphical class hierarchy

This inheritance list is sorted roughly, but not completely, alphabetically:
[detail level 1234]
o C Attribute | Attribute data class
o C AttributeList | Sparksee attribute identifier list
o C AttributeListIterator | AttributeList iterator class
o C AttributeStatistics | Attribute statistics class
o C BooleanList | Boolean list
o C BooleanListIterator | BooleanList iterator class
o C CommunityDetection | CommunityDetection class
| \ C DisjointCommunityDetection | DisjointCommunityDetection class
| \ C CommunitiesSCD | CommunitiesSCD class
o C ConnectedComponents | ConnectedComponents class
o C Connectivity | Connectivity class
| o C StrongConnectivity | StrongConnectivity class
| | \ C StrongConnectivityGabow | This class can be used to solve the problem of finding strongly connected components in a directed graph
| \ C WeakConnectivity | WeakConnectivity class
| \ C WeakConnectivityDFS | WeakConnectivityDFS class
o C Context | Context class
o C CSVLoader |
o C DatabaseStatistics | Database statistics
o C DisjointCommunities | DisjointCommunities class
o C EdgeData | Edge data class
o C EdgeExport | Stores edge exporting values
o C Exception | Exception class
| o C Error | Error class
| | o C AppError | Application error class
| | | o C EncryptionError | Wrong encryption arguments error class
| | | o C LicenseError | License error class
| | | o C QueryException | Query exception class
| | | o C UnsupportedOperationError | Unsupported operation error class
| | | \ C WrongArgumentError | Wrong argument error class
| | \ C SystemError | System error class
| | \ C IOError | IO error class
| o C IOException | IO exception class
| | \ C FileNotFoundException | File not found exception class
| \ C NoSuchElementException | No such element exception class
o C ExportManager | Defines how to export a graph to an external format
| \ C DefaultExport | Default implementation for ExportManager class
o C GraphExport | Stores the graph exporting values
o C Handler< T > | Handles a reference
o C Handler |
| \ C BulkLoader | Base TypeLoader class
o C Handler< sparksee_core::DbGraph > |
| \ C Graph | Graph class
o C Handler< sparksee_core::GraphPool > |
| \ C Database | Database class
o C Handler< sparksee_core::GraphTextStream > |
| \ C TextStream | TextStream class
o C Handler< sparksee_core::GraphValueArray > |
| \ C ValueArray | ValueArray class
o C Handler< sparksee_core::KeyValues > |
| \ C KeyValues | Value set class
o C Handler< sparksee_core::Objects > |
| \ C Objects | Object identifier set class
o C Handler< sparksee_core::Query > |
| \ C Query | Query class
o C Handler< sparksee_core::ResultSet > |
| \ C ResultSet | ResultSet class
o C Handler< sparksee_core::Session > |
| \ C Session | Session class
o C Handler< sparksee_core::SPARKSEE > |
| \ C Sparksee | Sparksee class
o C Handler< sparksee_core::Value > |
| \ C Value | Value class
o C Handler< sparksee_core::Values > |
| o C Values | Value set class
| \ C ValuesIterator | Values iterator class
o C Int32List | Sparksee 32-bit signed integer list
o C Int32ListIterator | Int32List iterator class
o C KeyValue |
o C KOpt | KOpt class
o C SinglePairShortestPathDijkstra::FibonacciHeap::Node | A FibonacciHeap node structure
o C NodeExport | Stores the node exporting values
o C ObjectsIterator | ObjectsIterator class
o C OIDList | Sparksee object identifier list
o C OIDListIterator | OIDList iterator class
o C PageRank | PageRank class
o C Platform | Platform class
o C PlatformStatistics | Platform data and statistics
o C QueryContext | Query context interface
o C QueryStream | Query stream interface
o C ResultSetList | ResultSet list
o C ResultSetListIterator | ResultSetList iterator class
o C RowReader | RowReader interface
| \ C CSVReader | CSVReader interface
o C RowWriter | RowWriter interface
| \ C CSVWriter | CSVWriter interface
o C ScriptParser | ScriptParser
o C ShortestPath | ShortestPath class
| \ C SinglePairShortestPath | SinglePairShortestPath class
| o C SinglePairShortestPathBFS | SinglePairShortestPathBFS class
| \ C SinglePairShortestPathDijkstra | SinglePairShortestPathDijkstra class
o C SinglePairShortestPathDijkstraDynamicCost | Defines how to calculate an edge weight
o C SparkseeConfig | Sparksee configuration class
o C SparkseeProperties | Sparksee properties file
o C StringList | String list
o C StringListIterator | StringList iterator class
o C Traversal | Traversal class
| o C RandomWalk | RandomWalk class
| o C TraversalBFS | Breadth-First Search implementation of Traversal
| \ C TraversalDFS | Depth-First Search (DFS) implementation of Traversal
o C Type | Type data class
o C TypeExporter | Base TypeExporter class
| o C EdgeTypeExporter | EdgeTypeExporter class
| \ C NodeTypeExporter | NodeTypeExporter class
o C TypeExporterEvent | Provides information about the progress of an TypeExproter instance
o C TypeExporterListener | Interface to be implemented to receive TypeExporterEvent events from a TypeExporter
o C TypeList | Sparksee type identifier list
o C TypeListIterator | TypeList iterator class
o C TypeLoader | Base TypeLoader class
| o C EdgeTypeLoader | EdgeTypeLoader class
| \ C NodeTypeLoader | NodeTypeLoader class
o C TypeLoaderEvent | Provides information about the progress of a TypeLoader instance
o C TypeLoaderListener | Interface to be implemented to receive TypeLoaderEvent events from a TypeLoader
o C ValueList | Value list
\ C ValueListIterator | ValueList iterator class
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- a -

  • actualCommunity : DisjointCommunityDetection
  • actualComponent : Connectivity
  • Add() : AttributeList , Int32List , Objects , OIDList , ValueList , TypeList , StringList , BooleanList
  • AddAllEdgeTypes() : PageRank , RandomWalk , ShortestPath , StrongConnectivity , Traversal , WeakConnectivity , CommunityDetection , Connectivity , Context , DisjointCommunityDetection , KOpt
  • AddAllNodeTypes() : CommunityDetection , Connectivity , Context , KOpt , PageRank , RandomWalk , ShortestPath , Traversal
  • AddChecksums() : Sparksee
  • AddEdgeType() : Connectivity , Context , DisjointCommunityDetection , KOpt , PageRank , RandomWalk , ShortestPath , StrongConnectivity , Traversal , WeakConnectivity , CommunityDetection
  • AddNodeType() : RandomWalk , CommunityDetection , Connectivity , Context , KOpt , PageRank , ShortestPath , Traversal
  • AddWeightedEdgeType() : SinglePairShortestPathDijkstra
  • Any() : Objects
  • AppError() : AppError
  • areAllNodeTypesAllowed : ShortestPath
  • AsDirected() : EdgeExport
  • AssertAddedEdges() : CommunityDetection , Connectivity , ShortestPath , Traversal
  • AssertAddedNodes() : Traversal , ShortestPath , Connectivity , CommunityDetection
  • AssertComputed() : CommunityDetection , Connectivity , ShortestPath
  • AssertEdgeType() : Connectivity , ShortestPath , Traversal , CommunityDetection
  • AssertNodeType() : Connectivity , ShortestPath , CommunityDetection , Traversal
  • AssertNotCommunityAttribute() : DisjointCommunityDetection
  • AssertNotComponentAttribute() : Connectivity
  • AssertNotComputed() : CommunityDetection , Connectivity , ShortestPath
  • attrCommunity : DisjointCommunityDetection
  • attrCommunityName : DisjointCommunityDetection
  • attrComponent : Connectivity
  • attrComponentName : Connectivity
  • AttributeList() : AttributeList
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- b -

  • Backup() : Graph
  • Begin() : Session
  • BeginUpdate() : Session
  • BooleanList() : BooleanList
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- c -

  • CalculateEdgeCost() : SinglePairShortestPathDijkstraDynamicCost
  • CanRun() : TypeExporter , TypeLoader
  • ccs : Connectivity
  • CheckOnlyExistence() : SinglePairShortestPathBFS
  • Clear() : OIDList , StringList , BooleanList , Int32List , TypeList , Objects , ResultSetList , AttributeList , SparkseeProperties , ValueList
  • Close() : TextStream , CSVReader , CSVWriter , RowReader , RowWriter
  • CombineDifference() : Objects
  • CombineIntersection() : Objects
  • CombineUnion() : Objects
  • Commit() : Session
  • CommunitiesSCD() : CommunitiesSCD
  • CommunityDetection() : CommunityDetection
  • Compare() : Value
  • Compute() : Context
  • computed : ShortestPath , CommunityDetection , Connectivity
  • ConnectedComponents() : ConnectedComponents
  • Connectivity() : Connectivity
  • Contains() : Objects
  • Context() : Context
  • Copy() : Objects
  • Count() : StringList , Int32List , OIDList , AttributeList , TypeList , Objects , ValueList , Values , BooleanList , ResultSetList
  • CountEdges() : Graph
  • CountNodes() : Graph
  • Create() : Sparksee
  • CreateGlobalPersistentAttribute() : DisjointCommunityDetection , Connectivity
  • CreateGlobalTransientAttribute() : DisjointCommunityDetection , Connectivity
  • CSVReader() : CSVReader
  • CSVWriter() : CSVWriter
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- d -

  • dcs : DisjointCommunityDetection
  • Decrypt() : Sparksee
  • DefaultExport() : DefaultExport
  • Degree() : Graph
  • destination : SinglePairShortestPath
  • Difference() : Objects
  • DisableRollback() : Database
  • DisjointCommunities() : DisjointCommunities
  • DisjointCommunityDetection() : DisjointCommunityDetection
  • DownloadExpected() : SparkseeConfig
  • DownloadLicense() : SparkseeConfig
  • Drop() : Graph
  • DumpData() : Graph
  • DumpSchema() : Database
  • DumpStorage() : Graph
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- e -

  • EdgeExport() : EdgeExport
  • Edges() : Graph
  • EdgesType : Type
  • EdgeTypeExporter() : EdgeTypeExporter
  • EdgeTypeLoader() : EdgeTypeLoader
  • edgeTypes : CommunityDetection , Connectivity , Context , ShortestPath , Traversal
  • EdgeTypes_t : CommunityDetection , Connectivity
  • EnableRollback() : Database
  • EnableType() : ExportManager , DefaultExport
  • Encrypt() : Sparksee
  • EncryptedBackup() : Graph
  • EncryptionError() : EncryptionError
  • Equals() : Objects , Value
  • Error() : Error
  • Exception() : Exception
  • excludedEdges : Traversal , ShortestPath , CommunityDetection , Connectivity , Context
  • excludedNodes : CommunityDetection , Connectivity , ShortestPath , Traversal , Context
  • ExcludeEdges() : Context , Traversal , Connectivity , RandomWalk , ShortestPath , CommunityDetection
  • ExcludeNodes() : Context , ShortestPath , Traversal , CommunityDetection , Connectivity , RandomWalk
  • Execute() : Query
  • Exists() : Objects , SinglePairShortestPath
  • Explode() : Graph
  • Export() : Graph
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- f -

  • Fetch() : QueryStream
  • FileNotFoundException() : FileNotFoundException
  • FindAttribute() : Graph
  • FindAttributes() : Graph
  • FindEdge() : Graph
  • FindEdgeTypes() : Graph
  • FindNodeTypes() : Graph
  • FindObject() : Graph
  • FindOrCreateEdge() : Graph
  • FindOrCreateObject() : Graph
  • FindType() : Graph
  • FindTypes() : Graph
  • FixCurrentCacheMaxSize() : Database
  • FreeHandler() : Handler< T >
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- g -

  • GenerateSchemaScript() : ScriptParser
  • Get() : ResultSetList , ValueList , ValueArray , SparkseeProperties
  • GetAESIV() : SparkseeConfig
  • GetAESKey() : SparkseeConfig
  • GetAlias() : Database
  • GetAreNeighborsIndexed() : Type
  • GetArrayAttribute() : Graph
  • GetArraySize() : Attribute
  • GetAttribute() : Graph
  • GetAttributeIntervalCount() : Graph
  • GetAttributes() : Graph
  • GetAttributeStatistics() : Graph
  • GetAttributeText() : Graph
  • GetAvailableMem() : PlatformStatistics
  • GetAvgLengthString() : AttributeStatistics
  • GetBoolean() : SparkseeProperties , Value , ValueArray
  • GetCache() : DatabaseStatistics
  • GetCacheMaxSize() : Database , SparkseeConfig
  • GetCacheStatisticsEnabled() : SparkseeConfig
  • GetCacheStatisticsFile() : SparkseeConfig
  • GetCacheStatisticsSnapshotTime() : SparkseeConfig
  • GetCallStackDump() : SparkseeConfig
  • GetChecksumEnabled() : SparkseeConfig
  • GetClientId() : SparkseeConfig
  • GetColorRGB() : NodeExport , EdgeExport
  • GetColumn() : ResultSet
  • GetColumnDataType() : ResultSet
  • GetColumnIndex() : ResultSet
  • GetColumnName() : ResultSet
  • GetCommunities() : DisjointCommunityDetection
  • GetCommunity() : DisjointCommunities
  • GetConnectedComponent() : ConnectedComponents
  • GetConnectedComponents() : Connectivity
  • GetCost() : SinglePairShortestPath , SinglePairShortestPathBFS , SinglePairShortestPathDijkstra
  • GetCount() : Attribute , TypeExporterEvent , TypeLoaderEvent , ConnectedComponents , DisjointCommunities
  • GetCurrentCost() : KOpt
  • GetCurrentDepth() : RandomWalk , Traversal , TraversalBFS , TraversalDFS
  • GetCurrentTour() : KOpt
  • GetData() : DatabaseStatistics
  • GetDataType() : Attribute , Value
  • GetDistinct() : AttributeStatistics
  • GetDouble() : ValueArray , Value
  • GetDownloadStatus() : SparkseeConfig
  • GetEdge() : ExportManager , DefaultExport , EdgeData
  • GetEdgeData() : Graph
  • GetEdgePeer() : Graph
  • GetEdgeType() : ExportManager , DefaultExport
  • GetEncryptionEnabled() : SparkseeConfig
  • GetExtentPages() : SparkseeConfig
  • GetExtentSize() : SparkseeConfig
  • GetFontSize() : NodeExport , EdgeExport
  • GetGraph() : ExportManager , DefaultExport , Session
  • GetHandler() : Handler< T >
  • GetHead() : EdgeData
  • GetHeight() : NodeExport
  • GetHighAvailabilityCoordinators() : SparkseeConfig
  • GetHighAvailabilityEnabled() : SparkseeConfig
  • GetHighAvailabilityIP() : SparkseeConfig
  • GetHighAvailabilityMasterHistory() : SparkseeConfig
  • GetHighAvailabilitySynchronization() : SparkseeConfig
  • GetId() : Type , Attribute
  • GetInMemAllocSize() : SparkseeConfig
  • GetInMemoryPoolCapacity() : Session , Sparksee
  • GetInteger() : SparkseeProperties , Value , ValueArray
  • GetIsDirected() : Type
  • GetIsRestricted() : Type
  • GetJSON() : ResultSet
  • GetKind() : Attribute
  • GetLabel() : GraphExport , NodeExport , EdgeExport
  • GetLabelColorRGB() : NodeExport , EdgeExport
  • GetLicense() : SparkseeConfig
  • GetLicenseId() : SparkseeConfig
  • GetLicensePreDownloadDays() : SparkseeConfig
  • GetLicenseRequest() : SparkseeConfig
  • GetLogFile() : SparkseeConfig
  • GetLogLevel() : SparkseeConfig
  • GetLong() : Value , ValueArray
  • GetMax() : AttributeStatistics
  • GetMaxLengthString() : AttributeStatistics
  • GetMean() : AttributeStatistics
  • GetMedian() : AttributeStatistics
  • GetMin() : AttributeStatistics
  • GetMinLengthString() : AttributeStatistics
  • GetMode() : AttributeStatistics
  • GetModeCount() : AttributeStatistics
  • GetName() : Attribute , Type
  • GetNode() : ExportManager , DefaultExport
  • GetNodes() : ConnectedComponents , DisjointCommunities
  • GetNodeType() : ExportManager , DefaultExport
  • GetNull() : AttributeStatistics
  • GetNumColumns() : ResultSet
  • GetNumCPUs() : PlatformStatistics
  • GetNumObjects() : Type
  • GetObjectType() : Graph , Type
  • GetOffset() : QueryException
  • GetOID() : ValueArray , Value , ValueArray
  • GetPartition() : TypeLoaderEvent
  • GetPath() : Database
  • GetPathAsEdges() : SinglePairShortestPath , SinglePairShortestPathDijkstra , SinglePairShortestPathBFS
  • GetPathAsNodes() : SinglePairShortestPath , SinglePairShortestPathBFS , SinglePairShortestPathDijkstra
  • GetPhase() : TypeLoaderEvent
  • GetPoolFrameSize() : SparkseeConfig
  • GetPoolPartitions() : SparkseeConfig
  • GetPoolPersistentMaxSize() : SparkseeConfig
  • GetPoolPersistentMinSize() : SparkseeConfig
  • GetPoolTemporaryMaxSize() : SparkseeConfig
  • GetPoolTemporaryMinSize() : SparkseeConfig
  • GetRead() : DatabaseStatistics
  • GetRealTime() : PlatformStatistics
  • GetRecoveryCacheMaxSize() : SparkseeConfig
  • GetRecoveryCheckpointTime() : SparkseeConfig
  • GetRecoveryEnabled() : SparkseeConfig
  • GetRecoveryLogFile() : SparkseeConfig
  • GetRestrictedFrom() : Type
  • GetRestrictedTo() : Type
  • GetRollbackEnabled() : SparkseeConfig
  • GetRow() : CSVReader , RowReader
  • GetSessions() : DatabaseStatistics
  • GetShape() : NodeExport
  • GetSize() : DisjointCommunities , ConnectedComponents , Attribute
  • GetSparkseeConfigFile() : SparkseeConfig
  • GetStatistics() : Database , Platform
  • GetString() : Value
  • GetSystemTime() : PlatformStatistics
  • GetTail() : EdgeData
  • GetTemp() : DatabaseStatistics
  • GetTimestamp() : ValueArray , Value , ValueArray
  • GetTimeUnit() : SparkseeProperties
  • GetTmpEnabled() : SparkseeConfig
  • GetTmpFolder() : SparkseeConfig
  • GetTotal() : TypeExporterEvent , AttributeStatistics
  • GetTotalMem() : PlatformStatistics
  • GetTotalPartitions() : TypeLoaderEvent
  • GetTotalPartitionSteps() : TypeLoaderEvent
  • GetTotalPhases() : TypeLoaderEvent
  • GetType() : Graph
  • GetTypeId() : Attribute , TypeExporterEvent , TypeLoaderEvent
  • GetUserTime() : PlatformStatistics
  • GetValues() : Graph
  • GetVariance() : AttributeStatistics
  • GetWidth() : NodeExport , EdgeExport
  • GetWrite() : DatabaseStatistics
  • GlobalType : Type
  • graph : Context , Traversal , ShortestPath , CommunityDetection , Connectivity
  • GraphExport() : GraphExport
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- h -

  • Handler() : Handler< T >
  • HasNext() : TraversalDFS , AttributeListIterator , Traversal , RandomWalk , ValuesIterator , ValueListIterator , ResultSetListIterator , ObjectsIterator , KeyValues , Int32ListIterator , BooleanListIterator , StringListIterator , OIDListIterator , TraversalBFS , TypeListIterator
  • Heads() : Graph
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- i -

  • includedEdges : CommunityDetection
  • includedNodes : CommunityDetection
  • IncludeEdges() : CommunityDetection
  • IncludeNodes() : CommunityDetection
  • inclusive : Context
  • IndexAttribute() : Graph
  • IndexNeighbors() : Graph
  • Int32List() : Int32List
  • Intersection() : Objects
  • InvalidAttribute : Attribute
  • InvalidOID : Objects
  • InvalidType : Type
  • IOError() : IOError
  • IOException() : IOException
  • IsArrayAttribute() : Attribute
  • IsEdgeAllowed() : CommunityDetection
  • IsEdgeExcluded() : CommunityDetection , Connectivity , ShortestPath , Traversal
  • IsEdgeIncluded() : CommunityDetection
  • IsEdgeTypeAllowed() : CommunityDetection
  • IsFit() : NodeExport
  • IsLast() : TypeExporterEvent , TypeLoaderEvent
  • IsNodeAllowed() : CommunityDetection
  • IsNodeExcluded() : ShortestPath , Traversal , Connectivity , CommunityDetection
  • IsNodeIncluded() : CommunityDetection
  • IsNodeTypeAllowed() : Connectivity , ShortestPath , Traversal , CommunityDetection
  • IsNull() : TextStream , Handler< T > , Value
  • IsSessionAttribute() : Attribute
  • Iterator() : TypeList , Int32List , BooleanList , Values , Objects , AttributeList , StringList , ValueList , OIDList , ResultSetList
  • IteratorFromElement() : Objects
  • IteratorFromIndex() : Objects
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- k -

  • KOpt() : KOpt
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- l -

  • LicenseError() : LicenseError
  • Load() : SparkseeProperties
  • LoadEdges() : CSVLoader
  • LoadNodes() : CSVLoader
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- m -

  • m_offset : QueryException
  • MakeNull() : ValueArray
  • matResults : DisjointCommunityDetection , Connectivity
  • maxHops : Context , Traversal , ShortestPath
  • MaxLengthString : Value
  • message : Exception
  • Message() : Exception
  • Mode : TypeLoader
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- n -

  • N_PHASES : TypeLoader
  • Neighbors() : Graph
  • NewArrayAttribute() : Graph
  • NewAttribute() : Graph
  • NewEdge() : Graph
  • NewEdgeType() : Graph
  • NewNode() : Graph
  • NewNodeType() : Graph
  • NewObjects() : Session
  • NewQuery() : QueryContext , Session
  • NewRestrictedEdgeType() : Graph
  • NewSession() : Database
  • NewSessionArrayAttribute() : Graph
  • NewSessionAttribute() : Graph
  • Next() : ValuesIterator , RandomWalk , Traversal , TraversalBFS , TraversalDFS , TypeListIterator , AttributeListIterator , OIDListIterator , ValueListIterator , StringListIterator , BooleanListIterator , Int32ListIterator , KeyValues , ObjectsIterator , ResultSet , ResultSetListIterator
  • NodeExport() : NodeExport
  • nodesNotVisited : Connectivity , CommunityDetection
  • NodesType : Type
  • NodeTypeExporter() : NodeTypeExporter
  • NodeTypeLoader() : NodeTypeLoader
  • nodeTypes : Connectivity , CommunityDetection , Traversal , ShortestPath , Context
  • NodeTypes_t : Connectivity , CommunityDetection
  • NoSuchElementException() : NoSuchElementException
  • NotifyEvent() : TypeLoaderListener , TypeExporterListener
  • NotifyListeners() : TypeLoader , TypeExporter
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- o -

  • OIDList() : OIDList
  • ONE_PHASE : TypeLoader
  • Open() : CSVReader , Sparksee , CSVWriter , Sparksee
  • operator=() : Value
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- p -

  • PageRank() : PageRank
  • Parse() : ScriptParser
  • pathAsEdges : SinglePairShortestPath
  • pathAsNodes : SinglePairShortestPath
  • PlatformStatistics() : PlatformStatistics
  • PreCommit() : Session
  • Prepare() : QueryStream , DefaultExport , ExportManager
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- q -

  • QueryContext() : QueryContext
  • QueryException() : QueryException
  • QueryStream() : QueryStream
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- r -

  • RandomWalk() : RandomWalk
  • Read() : TextStream , RowReader , CSVReader
  • RedoPrecommitted() : Database
  • Register() : TypeExporter , TypeLoader
  • Release() : ExportManager , DefaultExport
  • Remove() : Objects
  • RemoveAttribute() : Graph
  • RemoveChecksums() : Sparksee
  • RemoveGlobalAttribute() : Connectivity , DisjointCommunityDetection
  • RemoveType() : Graph
  • RenameAttribute() : Graph
  • RenameType() : Graph
  • Reset() : CSVReader , RowReader , RandomWalk
  • ResizeInMemoryPool() : Sparksee
  • Restore() : Sparksee
  • RestoreEncryptedBackup() : Sparksee
  • ResultSetList() : ResultSetList
  • Rewind() : ResultSet
  • Rollback() : Session
  • RowReader() : RowReader
  • RowWriter() : RowWriter
  • Run() : TypeExporter , WeakConnectivityDFS , BulkLoader , EdgeTypeExporter , EdgeTypeLoader , DisjointCommunityDetection , PageRank , Connectivity , NodeTypeLoader , TypeLoader , CommunityDetection , CommunitiesSCD , TypeLoader , SinglePairShortestPathDijkstra , ShortestPath , StrongConnectivityGabow , NodeTypeExporter , SinglePairShortestPathBFS
  • RunNPhases() : NodeTypeLoader , TypeLoader , EdgeTypeLoader
  • RunProcess() : TypeExporter
  • RunThreeOpt() : KOpt
  • RunTwoOpt() : KOpt
  • RunTwoPhases() : NodeTypeLoader , TypeLoader , EdgeTypeLoader
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- s -

  • Sample() : Objects
  • Save() : SparkseeConfig
  • SaveAll() : SparkseeConfig
  • ScriptParser() : ScriptParser
  • Select() : Graph
  • sess : CommunityDetection , Connectivity , Context , ShortestPath , Traversal
  • Set() : Value , ValueArray , OIDList
  • SetAESEncryptionEnabled() : SparkseeConfig
  • SetArrayAttribute() : Graph
  • SetArrayAttributeVoid() : Graph
  • SetAsDirected() : EdgeExport
  • SetAttribute() : Graph
  • SetAttributeDefaultValue() : Graph
  • SetAttributePositions() : BulkLoader , TypeLoader
  • SetAttributes() : TypeLoader , BulkLoader , TypeExporter
  • SetAttributeText() : Graph
  • SetAutoQuotes() : CSVWriter
  • SetBoolean() : Value , ValueArray
  • SetBooleanVoid() : Value
  • SetCacheMaxSize() : Database , SparkseeConfig
  • SetCacheStatisticsEnabled() : SparkseeConfig
  • SetCacheStatisticsFile() : SparkseeConfig
  • SetCacheStatisticsSnapshotTime() : SparkseeConfig
  • SetCallStackDump() : SparkseeConfig
  • SetChecksumEnabled() : SparkseeConfig
  • SetClientId() : SparkseeConfig
  • SetColorRGB() : NodeExport , EdgeExport
  • SetCommunity() : DisjointCommunityDetection
  • SetConnectedComponent() : Connectivity
  • SetCurrentTour() : KOpt
  • SetDamping() : PageRank
  • SetDefaults() : GraphExport , NodeExport , EdgeExport
  • SetDefaultWeight() : PageRank , RandomWalk
  • SetDouble() : Value , ValueArray
  • SetDoubleVoid() : Value
  • SetDynamic() : Query
  • SetDynamicEdgeCostCallback() : SinglePairShortestPathDijkstra
  • SetEdgeWeightAttributeType() : KOpt , PageRank , RandomWalk
  • SetEncryptionDisabled() : SparkseeConfig
  • SetErrorLog() : ScriptParser
  • SetExtentPages() : SparkseeConfig
  • SetExtentSize() : SparkseeConfig
  • SetFilename() : BulkLoader
  • SetFit() : NodeExport
  • SetFontSize() : NodeExport , EdgeExport
  • SetForcedQuotes() : CSVWriter
  • SetFrequency() : TypeExporter , TypeLoader
  • SetGraph() : TypeExporter , TypeLoader
  • SetHandler() : Handler< T >
  • SetHeadAttribute() : EdgeTypeExporter , EdgeTypeLoader , TypeExporter , TypeLoader
  • SetHeader() : TypeExporter
  • SetHeadMEP() : EdgeTypeLoader , TypeLoader
  • SetHeadPosition() : EdgeTypeExporter , EdgeTypeLoader , TypeExporter , TypeLoader
  • SetHeight() : NodeExport
  • SetHI() : SparkseeProperties
  • SetHighAvailabilityCoordinators() : SparkseeConfig
  • SetHighAvailabilityEnabled() : SparkseeConfig
  • SetHighAvailabilityIP() : SparkseeConfig
  • SetHighAvailabilityMasterHistory() : SparkseeConfig
  • SetHighAvailabilitySynchronization() : SparkseeConfig
  • SetInitialPageRankValue() : PageRank
  • SetInMemAllocSize() : SparkseeConfig
  • SetInOutParameter() : RandomWalk
  • SetInteger() : Value , ValueArray
  • SetIntegerVoid() : Value
  • SetLabel() : GraphExport , NodeExport , EdgeExport
  • SetLabelColorRGB() : NodeExport , EdgeExport
  • SetLicense() : SparkseeConfig
  • SetLicenseId() : SparkseeConfig
  • SetLicensePreDownloadDays() : SparkseeConfig
  • SetLocale() : BulkLoader , CSVReader , CSVWriter , TypeLoader
  • SetLogError() : TypeLoader , BulkLoader
  • SetLogFile() : SparkseeConfig
  • SetLogLevel() : SparkseeConfig
  • SetLogOff() : TypeLoader
  • SetLong() : Value , ValueArray
  • SetLongVoid() : Value
  • SetLookAhead() : CommunitiesSCD
  • SetMaterializedAttribute() : Connectivity , DisjointCommunityDetection
  • SetMaximumHops() : Context , ShortestPath , Traversal
  • SetMaxIterations() : KOpt
  • SetMessage() : Exception
  • SetMultilines() : CSVReader
  • SetNodesNotVisited() : CommunityDetection , Connectivity
  • SetNull() : Value
  • SetNullVoid() : Value
  • SetNumIterations() : PageRank
  • SetNumLines() : CSVReader
  • SetOID() : Value , ValueArray
  • SetOIDVoid() : Value
  • SetOutputAttributeType() : PageRank
  • SetOutputLog() : ScriptParser
  • SetPoolFrameSize() : SparkseeConfig
  • SetPoolPartitions() : SparkseeConfig
  • SetPoolPersistentMaxSize() : SparkseeConfig
  • SetPoolPersistentMinSize() : SparkseeConfig
  • SetPoolTemporaryMaxSize() : SparkseeConfig
  • SetPoolTemporaryMinSize() : SparkseeConfig
  • SetQuotes() : CSVReader , CSVWriter
  • SetRecoveryCacheMaxSize() : SparkseeConfig
  • SetRecoveryCheckpointTime() : SparkseeConfig
  • SetRecoveryEnabled() : SparkseeConfig
  • SetRecoveryLogFile() : SparkseeConfig
  • SetReturnParameter() : RandomWalk
  • SetRollbackEnabled() : SparkseeConfig
  • SetRowReader() : TypeLoader
  • SetRowWriter() : TypeExporter
  • SetSeed() : RandomWalk
  • SetSeparator() : CSVWriter , CSVReader
  • SetShape() : NodeExport
  • SetSingleLine() : CSVReader
  • SetSparkseeConfigFile() : SparkseeConfig
  • SetStartingNode() : PageRank
  • SetStartLine() : CSVReader
  • SetStream() : Query
  • SetString() : Value
  • SetStringVoid() : Value
  • SetTailAttribute() : EdgeTypeLoader , TypeExporter , TypeLoader , EdgeTypeExporter
  • SetTailMEP() : TypeLoader , EdgeTypeLoader
  • SetTailPosition() : EdgeTypeLoader , TypeLoader , EdgeTypeExporter , TypeExporter
  • SetTimeLimit() : KOpt
  • SetTimestamp() : Value , ValueArray , Value
  • SetTimestampFormat() : BulkLoader , TypeLoader
  • SetTimestampVoid() : Value
  • SetTmpEnabled() : SparkseeConfig
  • SetTmpFolder() : SparkseeConfig
  • SetTolerance() : PageRank
  • SetType() : TypeLoader , TypeExporter , BulkLoader
  • SetUnrecoverableErrorCallback() : Sparksee
  • SetUnweightedEdgeCost() : SinglePairShortestPathDijkstra
  • SetVoid() : Value
  • SetWidth() : EdgeExport , NodeExport
  • ShortestPath() : ShortestPath
  • SinglePairShortestPath() : SinglePairShortestPath
  • SinglePairShortestPathBFS() : SinglePairShortestPathBFS
  • SinglePairShortestPathDijkstra() : SinglePairShortestPathDijkstra
  • Size() : ValueArray
  • source : SinglePairShortestPath
  • Sparksee() : Sparksee
  • SparkseeConfig() : SparkseeConfig
  • src : Context , Traversal
  • Start() : QueryStream
  • StringList() : StringList
  • StrongConnectivity() : StrongConnectivity
  • StrongConnectivityGabow() : StrongConnectivityGabow
  • SystemError() : SystemError
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- t -

  • Tails() : Graph
  • TailsAndHeads() : Graph
  • TextStream() : TextStream
  • ThrowError() : Error
  • TopK() : Graph
  • ToString() : Value
  • Traversal() : Traversal
  • TraversalBFS() : TraversalBFS
  • TraversalDFS() : TraversalDFS
  • TWO_PHASES : TypeLoader
  • TypeExporter() : TypeExporter
  • TypeExporterListener() : TypeExporterListener
  • TypeList() : TypeList
  • TypeLoader() : TypeLoader
  • TypeLoaderListener() : TypeLoaderListener
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- u -

  • Union() : Objects
  • UnsupportedOperationError() : UnsupportedOperationError
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- v -

  • Value() : Value
  • ValueList() : ValueList
  • VerifyChecksums() : Sparksee
  • Version : Sparksee
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- w -

  • WeakConnectivity() : WeakConnectivity
  • WeakConnectivityDFS() : WeakConnectivityDFS
  • Write() : CSVWriter , RowWriter , TextStream
  • WrongArgumentError() : WrongArgumentError
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- ~ -

  • ~AppError() : AppError
  • ~Attribute() : Attribute
  • ~AttributeList() : AttributeList
  • ~AttributeListIterator() : AttributeListIterator
  • ~AttributeStatistics() : AttributeStatistics
  • ~BooleanList() : BooleanList
  • ~BooleanListIterator() : BooleanListIterator
  • ~BulkLoader() : BulkLoader
  • ~CommunitiesSCD() : CommunitiesSCD
  • ~CommunityDetection() : CommunityDetection
  • ~ConnectedComponents() : ConnectedComponents
  • ~Connectivity() : Connectivity
  • ~Context() : Context
  • ~CSVReader() : CSVReader
  • ~CSVWriter() : CSVWriter
  • ~Database() : Database
  • ~DefaultExport() : DefaultExport
  • ~DisjointCommunities() : DisjointCommunities
  • ~DisjointCommunityDetection() : DisjointCommunityDetection
  • ~EdgeData() : EdgeData
  • ~EdgeExport() : EdgeExport
  • ~EdgeTypeExporter() : EdgeTypeExporter
  • ~EdgeTypeLoader() : EdgeTypeLoader
  • ~EncryptionError() : EncryptionError
  • ~Error() : Error
  • ~Exception() : Exception
  • ~ExportManager() : ExportManager
  • ~FileNotFoundException() : FileNotFoundException
  • ~Graph() : Graph
  • ~GraphExport() : GraphExport
  • ~Handler() : Handler< T >
  • ~Int32List() : Int32List
  • ~Int32ListIterator() : Int32ListIterator
  • ~IOError() : IOError
  • ~IOException() : IOException
  • ~KeyValues() : KeyValues
  • ~KOpt() : KOpt
  • ~LicenseError() : LicenseError
  • ~NodeExport() : NodeExport
  • ~NodeTypeExporter() : NodeTypeExporter
  • ~NodeTypeLoader() : NodeTypeLoader
  • ~NoSuchElementException() : NoSuchElementException
  • ~Objects() : Objects
  • ~ObjectsIterator() : ObjectsIterator
  • ~OIDList() : OIDList
  • ~OIDListIterator() : OIDListIterator
  • ~PageRank() : PageRank
  • ~Query() : Query
  • ~QueryContext() : QueryContext
  • ~QueryException() : QueryException
  • ~QueryStream() : QueryStream
  • ~RandomWalk() : RandomWalk
  • ~ResultSet() : ResultSet
  • ~ResultSetList() : ResultSetList
  • ~ResultSetListIterator() : ResultSetListIterator
  • ~RowReader() : RowReader
  • ~RowWriter() : RowWriter
  • ~ScriptParser() : ScriptParser
  • ~Session() : Session
  • ~ShortestPath() : ShortestPath
  • ~SinglePairShortestPath() : SinglePairShortestPath
  • ~SinglePairShortestPathBFS() : SinglePairShortestPathBFS
  • ~SinglePairShortestPathDijkstra() : SinglePairShortestPathDijkstra
  • ~SinglePairShortestPathDijkstraDynamicCost() : SinglePairShortestPathDijkstraDynamicCost
  • ~Sparksee() : Sparksee
  • ~SparkseeConfig() : SparkseeConfig
  • ~StringList() : StringList
  • ~StringListIterator() : StringListIterator
  • ~StrongConnectivity() : StrongConnectivity
  • ~StrongConnectivityGabow() : StrongConnectivityGabow
  • ~SystemError() : SystemError
  • ~TextStream() : TextStream
  • ~Traversal() : Traversal
  • ~TraversalBFS() : TraversalBFS
  • ~TraversalDFS() : TraversalDFS
  • ~Type() : Type
  • ~TypeExporter() : TypeExporter
  • ~TypeExporterEvent() : TypeExporterEvent
  • ~TypeExporterListener() : TypeExporterListener
  • ~TypeList() : TypeList
  • ~TypeListIterator() : TypeListIterator
  • ~TypeLoader() : TypeLoader
  • ~TypeLoaderEvent() : TypeLoaderEvent
  • ~TypeLoaderListener() : TypeLoaderListener
  • ~UnsupportedOperationError() : UnsupportedOperationError
  • ~Value() : Value
  • ~ValueArray() : ValueArray
  • ~ValueList() : ValueList
  • ~ValueListIterator() : ValueListIterator
  • ~Values() : Values
  • ~ValuesIterator() : ValuesIterator
  • ~WeakConnectivity() : WeakConnectivity
  • ~WeakConnectivityDFS() : WeakConnectivityDFS
  • ~WrongArgumentError() : WrongArgumentError
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- a -

  • Add() : TypeList , AttributeList , StringList , ValueList , BooleanList , OIDList , Int32List , Objects
  • AddAllEdgeTypes() : ShortestPath , StrongConnectivity , CommunityDetection , Traversal , WeakConnectivity , Connectivity , Context , DisjointCommunityDetection , KOpt , PageRank , RandomWalk
  • AddAllNodeTypes() : CommunityDetection , Connectivity , Context , KOpt , PageRank , RandomWalk , ShortestPath , Traversal
  • AddChecksums() : Sparksee
  • AddEdgeType() : DisjointCommunityDetection , KOpt , PageRank , RandomWalk , ShortestPath , StrongConnectivity , Traversal , WeakConnectivity , CommunityDetection , Connectivity , Context
  • AddNodeType() : Traversal , CommunityDetection , Connectivity , Context , PageRank , RandomWalk , ShortestPath , KOpt
  • AddWeightedEdgeType() : SinglePairShortestPathDijkstra
  • Any() : Objects
  • AppError() : AppError
  • AsDirected() : EdgeExport
  • AssertAddedEdges() : ShortestPath , Connectivity , CommunityDetection , Traversal
  • AssertAddedNodes() : CommunityDetection , ShortestPath , Connectivity , Traversal
  • AssertComputed() : ShortestPath , Connectivity , CommunityDetection
  • AssertEdgeType() : CommunityDetection , Connectivity , Traversal , ShortestPath
  • AssertNodeType() : Connectivity , ShortestPath , CommunityDetection , Traversal
  • AssertNotCommunityAttribute() : DisjointCommunityDetection
  • AssertNotComponentAttribute() : Connectivity
  • AssertNotComputed() : Connectivity , CommunityDetection , ShortestPath
  • AttributeList() : AttributeList
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- b -

  • Backup() : Graph
  • Begin() : Session
  • BeginUpdate() : Session
  • BooleanList() : BooleanList
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- c -

  • CalculateEdgeCost() : SinglePairShortestPathDijkstraDynamicCost
  • CanRun() : TypeExporter , TypeLoader
  • CheckOnlyExistence() : SinglePairShortestPathBFS
  • Clear() : StringList , BooleanList , TypeList , Int32List , Objects , AttributeList , ResultSetList , SparkseeProperties , OIDList , ValueList
  • Close() : CSVReader , CSVWriter , RowReader , RowWriter , TextStream
  • CombineDifference() : Objects
  • CombineIntersection() : Objects
  • CombineUnion() : Objects
  • Commit() : Session
  • CommunitiesSCD() : CommunitiesSCD
  • CommunityDetection() : CommunityDetection
  • Compare() : Value
  • Compute() : Context
  • ConnectedComponents() : ConnectedComponents
  • Connectivity() : Connectivity
  • Contains() : Objects
  • Context() : Context
  • Copy() : Objects
  • Count() : ResultSetList , Values , Objects , BooleanList , AttributeList , OIDList , StringList , Int32List , TypeList , ValueList
  • CountEdges() : Graph
  • CountNodes() : Graph
  • Create() : Sparksee
  • CreateGlobalPersistentAttribute() : DisjointCommunityDetection , Connectivity
  • CreateGlobalTransientAttribute() : DisjointCommunityDetection , Connectivity
  • CSVReader() : CSVReader
  • CSVWriter() : CSVWriter
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- d -

  • Decrypt() : Sparksee
  • DefaultExport() : DefaultExport
  • Degree() : Graph
  • Difference() : Objects
  • DisableRollback() : Database
  • DisjointCommunities() : DisjointCommunities
  • DisjointCommunityDetection() : DisjointCommunityDetection
  • DownloadExpected() : SparkseeConfig
  • DownloadLicense() : SparkseeConfig
  • Drop() : Graph
  • DumpData() : Graph
  • DumpSchema() : Database
  • DumpStorage() : Graph
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- e -

  • EdgeExport() : EdgeExport
  • Edges() : Graph
  • EdgeTypeExporter() : EdgeTypeExporter
  • EdgeTypeLoader() : EdgeTypeLoader
  • EnableRollback() : Database
  • EnableType() : ExportManager , DefaultExport
  • Encrypt() : Sparksee
  • EncryptedBackup() : Graph
  • EncryptionError() : EncryptionError
  • Equals() : Objects , Value
  • Error() : Error
  • Exception() : Exception
  • ExcludeEdges() : RandomWalk , CommunityDetection , Connectivity , Context , ShortestPath , Traversal
  • ExcludeNodes() : Traversal , RandomWalk , ShortestPath , Context , CommunityDetection , Connectivity
  • Execute() : Query
  • Exists() : SinglePairShortestPath , Objects
  • Explode() : Graph
  • Export() : Graph
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- f -

  • Fetch() : QueryStream
  • FileNotFoundException() : FileNotFoundException
  • FindAttribute() : Graph
  • FindAttributes() : Graph
  • FindEdge() : Graph
  • FindEdgeTypes() : Graph
  • FindNodeTypes() : Graph
  • FindObject() : Graph
  • FindOrCreateEdge() : Graph
  • FindOrCreateObject() : Graph
  • FindType() : Graph
  • FindTypes() : Graph
  • FixCurrentCacheMaxSize() : Database
  • FreeHandler() : Handler< T >
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- g -

  • GenerateSchemaScript() : ScriptParser
  • Get() : ResultSetList , ValueList , ValueArray , SparkseeProperties
  • GetAESIV() : SparkseeConfig
  • GetAESKey() : SparkseeConfig
  • GetAlias() : Database
  • GetAreNeighborsIndexed() : Type
  • GetArrayAttribute() : Graph
  • GetArraySize() : Attribute
  • GetAttribute() : Graph
  • GetAttributeIntervalCount() : Graph
  • GetAttributes() : Graph
  • GetAttributeStatistics() : Graph
  • GetAttributeText() : Graph
  • GetAvailableMem() : PlatformStatistics
  • GetAvgLengthString() : AttributeStatistics
  • GetBoolean() : SparkseeProperties , Value , ValueArray
  • GetCache() : DatabaseStatistics
  • GetCacheMaxSize() : Database , SparkseeConfig
  • GetCacheStatisticsEnabled() : SparkseeConfig
  • GetCacheStatisticsFile() : SparkseeConfig
  • GetCacheStatisticsSnapshotTime() : SparkseeConfig
  • GetCallStackDump() : SparkseeConfig
  • GetChecksumEnabled() : SparkseeConfig
  • GetClientId() : SparkseeConfig
  • GetColorRGB() : NodeExport , EdgeExport
  • GetColumn() : ResultSet
  • GetColumnDataType() : ResultSet
  • GetColumnIndex() : ResultSet
  • GetColumnName() : ResultSet
  • GetCommunities() : DisjointCommunityDetection
  • GetCommunity() : DisjointCommunities
  • GetConnectedComponent() : ConnectedComponents
  • GetConnectedComponents() : Connectivity
  • GetCost() : SinglePairShortestPath , SinglePairShortestPathBFS , SinglePairShortestPathDijkstra
  • GetCount() : Attribute , TypeExporterEvent , TypeLoaderEvent , ConnectedComponents , DisjointCommunities
  • GetCurrentCost() : KOpt
  • GetCurrentDepth() : RandomWalk , Traversal , TraversalBFS , TraversalDFS
  • GetCurrentTour() : KOpt
  • GetData() : DatabaseStatistics
  • GetDataType() : Attribute , Value
  • GetDistinct() : AttributeStatistics
  • GetDouble() : ValueArray , Value
  • GetDownloadStatus() : SparkseeConfig
  • GetEdge() : ExportManager , DefaultExport , EdgeData
  • GetEdgeData() : Graph
  • GetEdgePeer() : Graph
  • GetEdgeType() : ExportManager , DefaultExport
  • GetEncryptionEnabled() : SparkseeConfig
  • GetExtentPages() : SparkseeConfig
  • GetExtentSize() : SparkseeConfig
  • GetFontSize() : NodeExport , EdgeExport
  • GetGraph() : ExportManager , DefaultExport , Session
  • GetHandler() : Handler< T >
  • GetHead() : EdgeData
  • GetHeight() : NodeExport
  • GetHighAvailabilityCoordinators() : SparkseeConfig
  • GetHighAvailabilityEnabled() : SparkseeConfig
  • GetHighAvailabilityIP() : SparkseeConfig
  • GetHighAvailabilityMasterHistory() : SparkseeConfig
  • GetHighAvailabilitySynchronization() : SparkseeConfig
  • GetId() : Type , Attribute
  • GetInMemAllocSize() : SparkseeConfig
  • GetInMemoryPoolCapacity() : Session , Sparksee
  • GetInteger() : SparkseeProperties , Value , ValueArray
  • GetIsDirected() : Type
  • GetIsRestricted() : Type
  • GetJSON() : ResultSet
  • GetKind() : Attribute
  • GetLabel() : GraphExport , NodeExport , EdgeExport
  • GetLabelColorRGB() : NodeExport , EdgeExport
  • GetLicense() : SparkseeConfig
  • GetLicenseId() : SparkseeConfig
  • GetLicensePreDownloadDays() : SparkseeConfig
  • GetLicenseRequest() : SparkseeConfig
  • GetLogFile() : SparkseeConfig
  • GetLogLevel() : SparkseeConfig
  • GetLong() : Value , ValueArray
  • GetMax() : AttributeStatistics
  • GetMaxLengthString() : AttributeStatistics
  • GetMean() : AttributeStatistics
  • GetMedian() : AttributeStatistics
  • GetMin() : AttributeStatistics
  • GetMinLengthString() : AttributeStatistics
  • GetMode() : AttributeStatistics
  • GetModeCount() : AttributeStatistics
  • GetName() : Attribute , Type
  • GetNode() : ExportManager , DefaultExport
  • GetNodes() : ConnectedComponents , DisjointCommunities
  • GetNodeType() : ExportManager , DefaultExport
  • GetNull() : AttributeStatistics
  • GetNumColumns() : ResultSet
  • GetNumCPUs() : PlatformStatistics
  • GetNumObjects() : Type
  • GetObjectType() : Graph , Type
  • GetOffset() : QueryException
  • GetOID() : ValueArray , Value
  • GetPartition() : TypeLoaderEvent
  • GetPath() : Database
  • GetPathAsEdges() : SinglePairShortestPath , SinglePairShortestPathDijkstra , SinglePairShortestPathBFS
  • GetPathAsNodes() : SinglePairShortestPathDijkstra , SinglePairShortestPathBFS , SinglePairShortestPath
  • GetPhase() : TypeLoaderEvent
  • GetPoolFrameSize() : SparkseeConfig
  • GetPoolPartitions() : SparkseeConfig
  • GetPoolPersistentMaxSize() : SparkseeConfig
  • GetPoolPersistentMinSize() : SparkseeConfig
  • GetPoolTemporaryMaxSize() : SparkseeConfig
  • GetPoolTemporaryMinSize() : SparkseeConfig
  • GetRead() : DatabaseStatistics
  • GetRealTime() : PlatformStatistics
  • GetRecoveryCacheMaxSize() : SparkseeConfig
  • GetRecoveryCheckpointTime() : SparkseeConfig
  • GetRecoveryEnabled() : SparkseeConfig
  • GetRecoveryLogFile() : SparkseeConfig
  • GetRestrictedFrom() : Type
  • GetRestrictedTo() : Type
  • GetRollbackEnabled() : SparkseeConfig
  • GetRow() : CSVReader , RowReader
  • GetSessions() : DatabaseStatistics
  • GetShape() : NodeExport
  • GetSize() : DisjointCommunities , ConnectedComponents , Attribute
  • GetSparkseeConfigFile() : SparkseeConfig
  • GetStatistics() : Platform , Database
  • GetString() : Value
  • GetSystemTime() : PlatformStatistics
  • GetTail() : EdgeData
  • GetTemp() : DatabaseStatistics
  • GetTimestamp() : ValueArray , Value , ValueArray
  • GetTimeUnit() : SparkseeProperties
  • GetTmpEnabled() : SparkseeConfig
  • GetTmpFolder() : SparkseeConfig
  • GetTotal() : AttributeStatistics , TypeExporterEvent
  • GetTotalMem() : PlatformStatistics
  • GetTotalPartitions() : TypeLoaderEvent
  • GetTotalPartitionSteps() : TypeLoaderEvent
  • GetTotalPhases() : TypeLoaderEvent
  • GetType() : Graph
  • GetTypeId() : Attribute , TypeExporterEvent , TypeLoaderEvent
  • GetUserTime() : PlatformStatistics
  • GetValues() : Graph
  • GetVariance() : AttributeStatistics
  • GetWidth() : EdgeExport , NodeExport
  • GetWrite() : DatabaseStatistics
  • GraphExport() : GraphExport
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- h -

  • Handler() : Handler< T >
  • HasNext() : TraversalDFS , AttributeListIterator , Traversal , RandomWalk , ValuesIterator , ValueListIterator , ResultSetListIterator , ObjectsIterator , KeyValues , Int32ListIterator , BooleanListIterator , StringListIterator , OIDListIterator , TraversalBFS , TypeListIterator
  • Heads() : Graph
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- i -

  • IncludeEdges() : CommunityDetection
  • IncludeNodes() : CommunityDetection
  • IndexAttribute() : Graph
  • IndexNeighbors() : Graph
  • Int32List() : Int32List
  • Intersection() : Objects
  • IOError() : IOError
  • IOException() : IOException
  • IsArrayAttribute() : Attribute
  • IsEdgeAllowed() : CommunityDetection
  • IsEdgeExcluded() : ShortestPath , Traversal , CommunityDetection , Connectivity
  • IsEdgeIncluded() : CommunityDetection
  • IsEdgeTypeAllowed() : CommunityDetection
  • IsFit() : NodeExport
  • IsLast() : TypeExporterEvent , TypeLoaderEvent
  • IsNodeAllowed() : CommunityDetection
  • IsNodeExcluded() : Traversal , CommunityDetection , Connectivity , ShortestPath
  • IsNodeIncluded() : CommunityDetection
  • IsNodeTypeAllowed() : Traversal , ShortestPath , CommunityDetection , Connectivity
  • IsNull() : Handler< T > , TextStream , Value
  • IsSessionAttribute() : Attribute
  • Iterator() : AttributeList , BooleanList , Int32List , ResultSetList , Values , Objects , ValueList , OIDList , StringList , TypeList
  • IteratorFromElement() : Objects
  • IteratorFromIndex() : Objects
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- k -

  • KOpt() : KOpt
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- l -

  • LicenseError() : LicenseError
  • Load() : SparkseeProperties
  • LoadEdges() : CSVLoader
  • LoadNodes() : CSVLoader
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- m -

  • MakeNull() : ValueArray
  • Message() : Exception
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- n -

  • Neighbors() : Graph
  • NewArrayAttribute() : Graph
  • NewAttribute() : Graph
  • NewEdge() : Graph
  • NewEdgeType() : Graph
  • NewNode() : Graph
  • NewNodeType() : Graph
  • NewObjects() : Session
  • NewQuery() : QueryContext , Session
  • NewRestrictedEdgeType() : Graph
  • NewSession() : Database
  • NewSessionArrayAttribute() : Graph
  • NewSessionAttribute() : Graph
  • Next() : ValueListIterator , ValuesIterator , ObjectsIterator , RandomWalk , Traversal , TraversalBFS , BooleanListIterator , TypeListIterator , AttributeListIterator , OIDListIterator , StringListIterator , Int32ListIterator , KeyValues , TraversalDFS , ResultSet , ResultSetListIterator
  • NodeExport() : NodeExport
  • NodeTypeExporter() : NodeTypeExporter
  • NodeTypeLoader() : NodeTypeLoader
  • NoSuchElementException() : NoSuchElementException
  • NotifyEvent() : TypeExporterListener , TypeLoaderListener
  • NotifyListeners() : TypeLoader , TypeExporter
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- o -

  • OIDList() : OIDList
  • Open() : CSVReader , Sparksee , CSVWriter
  • operator=() : Value
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- p -

  • PageRank() : PageRank
  • Parse() : ScriptParser
  • PlatformStatistics() : PlatformStatistics
  • PreCommit() : Session
  • Prepare() : QueryStream , DefaultExport , ExportManager
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- q -

  • QueryContext() : QueryContext
  • QueryException() : QueryException
  • QueryStream() : QueryStream
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- r -

  • RandomWalk() : RandomWalk
  • Read() : TextStream , RowReader , CSVReader
  • RedoPrecommitted() : Database
  • Register() : TypeExporter , TypeLoader
  • Release() : ExportManager , DefaultExport
  • Remove() : Objects
  • RemoveAttribute() : Graph
  • RemoveChecksums() : Sparksee
  • RemoveGlobalAttribute() : Connectivity , DisjointCommunityDetection
  • RemoveType() : Graph
  • RenameAttribute() : Graph
  • RenameType() : Graph
  • Reset() : CSVReader , RowReader , RandomWalk
  • ResizeInMemoryPool() : Sparksee
  • Restore() : Sparksee
  • RestoreEncryptedBackup() : Sparksee
  • ResultSetList() : ResultSetList
  • Rewind() : ResultSet
  • Rollback() : Session
  • RowReader() : RowReader
  • RowWriter() : RowWriter
  • Run() : TypeExporter , WeakConnectivityDFS , BulkLoader , EdgeTypeExporter , EdgeTypeLoader , DisjointCommunityDetection , PageRank , Connectivity , NodeTypeLoader , TypeLoader , CommunityDetection , CommunitiesSCD , TypeLoader , SinglePairShortestPathDijkstra , ShortestPath , StrongConnectivityGabow , NodeTypeExporter , SinglePairShortestPathBFS
  • RunNPhases() : NodeTypeLoader , TypeLoader , EdgeTypeLoader
  • RunProcess() : TypeExporter
  • RunThreeOpt() : KOpt
  • RunTwoOpt() : KOpt
  • RunTwoPhases() : NodeTypeLoader , TypeLoader , EdgeTypeLoader
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- s -

  • Sample() : Objects
  • Save() : SparkseeConfig
  • SaveAll() : SparkseeConfig
  • ScriptParser() : ScriptParser
  • Select() : Graph
  • Set() : OIDList , Value , ValueArray
  • SetAESEncryptionEnabled() : SparkseeConfig
  • SetArrayAttribute() : Graph
  • SetArrayAttributeVoid() : Graph
  • SetAsDirected() : EdgeExport
  • SetAttribute() : Graph
  • SetAttributeDefaultValue() : Graph
  • SetAttributePositions() : BulkLoader , TypeLoader
  • SetAttributes() : BulkLoader , TypeExporter , TypeLoader
  • SetAttributeText() : Graph
  • SetAutoQuotes() : CSVWriter
  • SetBoolean() : ValueArray , Value , ValueArray
  • SetBooleanVoid() : Value
  • SetCacheMaxSize() : Database , SparkseeConfig
  • SetCacheStatisticsEnabled() : SparkseeConfig
  • SetCacheStatisticsFile() : SparkseeConfig
  • SetCacheStatisticsSnapshotTime() : SparkseeConfig
  • SetCallStackDump() : SparkseeConfig
  • SetChecksumEnabled() : SparkseeConfig
  • SetClientId() : SparkseeConfig
  • SetColorRGB() : NodeExport , EdgeExport
  • SetCommunity() : DisjointCommunityDetection
  • SetConnectedComponent() : Connectivity
  • SetCurrentTour() : KOpt
  • SetDamping() : PageRank
  • SetDefaults() : GraphExport , NodeExport , EdgeExport
  • SetDefaultWeight() : PageRank , RandomWalk
  • SetDouble() : Value , ValueArray
  • SetDoubleVoid() : Value
  • SetDynamic() : Query
  • SetDynamicEdgeCostCallback() : SinglePairShortestPathDijkstra
  • SetEdgeWeightAttributeType() : KOpt , PageRank , RandomWalk
  • SetEncryptionDisabled() : SparkseeConfig
  • SetErrorLog() : ScriptParser
  • SetExtentPages() : SparkseeConfig
  • SetExtentSize() : SparkseeConfig
  • SetFilename() : BulkLoader
  • SetFit() : NodeExport
  • SetFontSize() : NodeExport , EdgeExport
  • SetForcedQuotes() : CSVWriter
  • SetFrequency() : TypeExporter , TypeLoader
  • SetGraph() : TypeExporter , TypeLoader
  • SetHandler() : Handler< T >
  • SetHeadAttribute() : EdgeTypeExporter , EdgeTypeLoader , TypeExporter , TypeLoader
  • SetHeader() : TypeExporter
  • SetHeadMEP() : EdgeTypeLoader , TypeLoader
  • SetHeadPosition() : EdgeTypeExporter , EdgeTypeLoader , TypeExporter , TypeLoader
  • SetHeight() : NodeExport
  • SetHI() : SparkseeProperties
  • SetHighAvailabilityCoordinators() : SparkseeConfig
  • SetHighAvailabilityEnabled() : SparkseeConfig
  • SetHighAvailabilityIP() : SparkseeConfig
  • SetHighAvailabilityMasterHistory() : SparkseeConfig
  • SetHighAvailabilitySynchronization() : SparkseeConfig
  • SetInitialPageRankValue() : PageRank
  • SetInMemAllocSize() : SparkseeConfig
  • SetInOutParameter() : RandomWalk
  • SetInteger() : Value , ValueArray
  • SetIntegerVoid() : Value
  • SetLabel() : GraphExport , NodeExport , EdgeExport
  • SetLabelColorRGB() : NodeExport , EdgeExport
  • SetLicense() : SparkseeConfig
  • SetLicenseId() : SparkseeConfig
  • SetLicensePreDownloadDays() : SparkseeConfig
  • SetLocale() : CSVWriter , BulkLoader , CSVReader , TypeLoader
  • SetLogError() : BulkLoader , TypeLoader
  • SetLogFile() : SparkseeConfig
  • SetLogLevel() : SparkseeConfig
  • SetLogOff() : TypeLoader
  • SetLong() : ValueArray , Value , ValueArray
  • SetLongVoid() : Value
  • SetLookAhead() : CommunitiesSCD
  • SetMaterializedAttribute() : Connectivity , DisjointCommunityDetection
  • SetMaximumHops() : Traversal , Context , ShortestPath
  • SetMaxIterations() : KOpt
  • SetMessage() : Exception
  • SetMultilines() : CSVReader
  • SetNodesNotVisited() : CommunityDetection , Connectivity
  • SetNull() : Value
  • SetNullVoid() : Value
  • SetNumIterations() : PageRank
  • SetNumLines() : CSVReader
  • SetOID() : ValueArray , Value , ValueArray
  • SetOIDVoid() : Value
  • SetOutputAttributeType() : PageRank
  • SetOutputLog() : ScriptParser
  • SetPoolFrameSize() : SparkseeConfig
  • SetPoolPartitions() : SparkseeConfig
  • SetPoolPersistentMaxSize() : SparkseeConfig
  • SetPoolPersistentMinSize() : SparkseeConfig
  • SetPoolTemporaryMaxSize() : SparkseeConfig
  • SetPoolTemporaryMinSize() : SparkseeConfig
  • SetQuotes() : CSVReader , CSVWriter
  • SetRecoveryCacheMaxSize() : SparkseeConfig
  • SetRecoveryCheckpointTime() : SparkseeConfig
  • SetRecoveryEnabled() : SparkseeConfig
  • SetRecoveryLogFile() : SparkseeConfig
  • SetReturnParameter() : RandomWalk
  • SetRollbackEnabled() : SparkseeConfig
  • SetRowReader() : TypeLoader
  • SetRowWriter() : TypeExporter
  • SetSeed() : RandomWalk
  • SetSeparator() : CSVReader , CSVWriter
  • SetShape() : NodeExport
  • SetSingleLine() : CSVReader
  • SetSparkseeConfigFile() : SparkseeConfig
  • SetStartingNode() : PageRank
  • SetStartLine() : CSVReader
  • SetStream() : Query
  • SetString() : Value
  • SetStringVoid() : Value
  • SetTailAttribute() : EdgeTypeExporter , TypeExporter , TypeLoader , EdgeTypeLoader
  • SetTailMEP() : TypeLoader , EdgeTypeLoader
  • SetTailPosition() : EdgeTypeLoader , TypeLoader , TypeExporter , EdgeTypeExporter
  • SetTimeLimit() : KOpt
  • SetTimestamp() : ValueArray , Value
  • SetTimestampFormat() : BulkLoader , TypeLoader
  • SetTimestampVoid() : Value
  • SetTmpEnabled() : SparkseeConfig
  • SetTmpFolder() : SparkseeConfig
  • SetTolerance() : PageRank
  • SetType() : TypeLoader , TypeExporter , BulkLoader
  • SetUnrecoverableErrorCallback() : Sparksee
  • SetUnweightedEdgeCost() : SinglePairShortestPathDijkstra
  • SetVoid() : Value
  • SetWidth() : NodeExport , EdgeExport
  • ShortestPath() : ShortestPath
  • SinglePairShortestPath() : SinglePairShortestPath
  • SinglePairShortestPathBFS() : SinglePairShortestPathBFS
  • SinglePairShortestPathDijkstra() : SinglePairShortestPathDijkstra
  • Size() : ValueArray
  • Sparksee() : Sparksee
  • SparkseeConfig() : SparkseeConfig
  • Start() : QueryStream
  • StringList() : StringList
  • StrongConnectivity() : StrongConnectivity
  • StrongConnectivityGabow() : StrongConnectivityGabow
  • SystemError() : SystemError
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- t -

  • Tails() : Graph
  • TailsAndHeads() : Graph
  • TextStream() : TextStream
  • ThrowError() : Error
  • TopK() : Graph
  • ToString() : Value
  • Traversal() : Traversal
  • TraversalBFS() : TraversalBFS
  • TraversalDFS() : TraversalDFS
  • TypeExporter() : TypeExporter
  • TypeExporterListener() : TypeExporterListener
  • TypeList() : TypeList
  • TypeLoader() : TypeLoader
  • TypeLoaderListener() : TypeLoaderListener
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- u -

  • Union() : Objects
  • UnsupportedOperationError() : UnsupportedOperationError
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- v -

  • Value() : Value
  • ValueList() : ValueList
  • VerifyChecksums() : Sparksee
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- w -

  • WeakConnectivity() : WeakConnectivity
  • WeakConnectivityDFS() : WeakConnectivityDFS
  • Write() : CSVWriter , RowWriter , TextStream
  • WrongArgumentError() : WrongArgumentError
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- ~ -

  • ~AppError() : AppError
  • ~Attribute() : Attribute
  • ~AttributeList() : AttributeList
  • ~AttributeListIterator() : AttributeListIterator
  • ~AttributeStatistics() : AttributeStatistics
  • ~BooleanList() : BooleanList
  • ~BooleanListIterator() : BooleanListIterator
  • ~BulkLoader() : BulkLoader
  • ~CommunitiesSCD() : CommunitiesSCD
  • ~CommunityDetection() : CommunityDetection
  • ~ConnectedComponents() : ConnectedComponents
  • ~Connectivity() : Connectivity
  • ~Context() : Context
  • ~CSVReader() : CSVReader
  • ~CSVWriter() : CSVWriter
  • ~Database() : Database
  • ~DefaultExport() : DefaultExport
  • ~DisjointCommunities() : DisjointCommunities
  • ~DisjointCommunityDetection() : DisjointCommunityDetection
  • ~EdgeData() : EdgeData
  • ~EdgeExport() : EdgeExport
  • ~EdgeTypeExporter() : EdgeTypeExporter
  • ~EdgeTypeLoader() : EdgeTypeLoader
  • ~EncryptionError() : EncryptionError
  • ~Error() : Error
  • ~Exception() : Exception
  • ~ExportManager() : ExportManager
  • ~FileNotFoundException() : FileNotFoundException
  • ~Graph() : Graph
  • ~GraphExport() : GraphExport
  • ~Handler() : Handler< T >
  • ~Int32List() : Int32List
  • ~Int32ListIterator() : Int32ListIterator
  • ~IOError() : IOError
  • ~IOException() : IOException
  • ~KeyValues() : KeyValues
  • ~KOpt() : KOpt
  • ~LicenseError() : LicenseError
  • ~NodeExport() : NodeExport
  • ~NodeTypeExporter() : NodeTypeExporter
  • ~NodeTypeLoader() : NodeTypeLoader
  • ~NoSuchElementException() : NoSuchElementException
  • ~Objects() : Objects
  • ~ObjectsIterator() : ObjectsIterator
  • ~OIDList() : OIDList
  • ~OIDListIterator() : OIDListIterator
  • ~PageRank() : PageRank
  • ~Query() : Query
  • ~QueryContext() : QueryContext
  • ~QueryException() : QueryException
  • ~QueryStream() : QueryStream
  • ~RandomWalk() : RandomWalk
  • ~ResultSet() : ResultSet
  • ~ResultSetList() : ResultSetList
  • ~ResultSetListIterator() : ResultSetListIterator
  • ~RowReader() : RowReader
  • ~RowWriter() : RowWriter
  • ~ScriptParser() : ScriptParser
  • ~Session() : Session
  • ~ShortestPath() : ShortestPath
  • ~SinglePairShortestPath() : SinglePairShortestPath
  • ~SinglePairShortestPathBFS() : SinglePairShortestPathBFS
  • ~SinglePairShortestPathDijkstra() : SinglePairShortestPathDijkstra
  • ~SinglePairShortestPathDijkstraDynamicCost() : SinglePairShortestPathDijkstraDynamicCost
  • ~Sparksee() : Sparksee
  • ~SparkseeConfig() : SparkseeConfig
  • ~StringList() : StringList
  • ~StringListIterator() : StringListIterator
  • ~StrongConnectivity() : StrongConnectivity
  • ~StrongConnectivityGabow() : StrongConnectivityGabow
  • ~SystemError() : SystemError
  • ~TextStream() : TextStream
  • ~Traversal() : Traversal
  • ~TraversalBFS() : TraversalBFS
  • ~TraversalDFS() : TraversalDFS
  • ~Type() : Type
  • ~TypeExporter() : TypeExporter
  • ~TypeExporterEvent() : TypeExporterEvent
  • ~TypeExporterListener() : TypeExporterListener
  • ~TypeList() : TypeList
  • ~TypeListIterator() : TypeListIterator
  • ~TypeLoader() : TypeLoader
  • ~TypeLoaderEvent() : TypeLoaderEvent
  • ~TypeLoaderListener() : TypeLoaderListener
  • ~UnsupportedOperationError() : UnsupportedOperationError
  • ~Value() : Value
  • ~ValueArray() : ValueArray
  • ~ValueList() : ValueList
  • ~ValueListIterator() : ValueListIterator
  • ~Values() : Values
  • ~ValuesIterator() : ValuesIterator
  • ~WeakConnectivity() : WeakConnectivity
  • ~WeakConnectivityDFS() : WeakConnectivityDFS
  • ~WrongArgumentError() : WrongArgumentError
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members - Variables

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • c
  • d
  • e
  • g
  • i
  • m
  • n
  • p
  • s
  • v

- a -

  • actualCommunity : DisjointCommunityDetection
  • actualComponent : Connectivity
  • areAllNodeTypesAllowed : ShortestPath
  • attrCommunity : DisjointCommunityDetection
  • attrCommunityName : DisjointCommunityDetection
  • attrComponent : Connectivity
  • attrComponentName : Connectivity

- c -

  • ccs : Connectivity
  • computed : ShortestPath , Connectivity , CommunityDetection

- d -

  • dcs : DisjointCommunityDetection
  • destination : SinglePairShortestPath

- e -

  • EdgesType : Type
  • edgeTypes : CommunityDetection , Context , ShortestPath , Connectivity , Traversal
  • excludedEdges : Traversal , Connectivity , Context , ShortestPath , CommunityDetection
  • excludedNodes : Connectivity , Context , ShortestPath , CommunityDetection , Traversal

- g -

  • GlobalType : Type
  • graph : Traversal , ShortestPath , Context , Connectivity , CommunityDetection

- i -

  • includedEdges : CommunityDetection
  • includedNodes : CommunityDetection
  • inclusive : Context
  • InvalidAttribute : Attribute
  • InvalidOID : Objects
  • InvalidType : Type

- m -

  • m_offset : QueryException
  • matResults : Connectivity , DisjointCommunityDetection
  • maxHops : Context , ShortestPath , Traversal
  • MaxLengthString : Value
  • message : Exception

- n -

  • nodesNotVisited : CommunityDetection , Connectivity
  • NodesType : Type
  • nodeTypes : Context , Connectivity , CommunityDetection , ShortestPath , Traversal

- p -

  • pathAsEdges : SinglePairShortestPath
  • pathAsNodes : SinglePairShortestPath

- s -

  • sess : CommunityDetection , Connectivity , ShortestPath , Traversal , Context
  • source : SinglePairShortestPath
  • src : Context , Traversal

- v -

  • Version : Sparksee
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members - Typedefs

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • EdgeTypes_t : CommunityDetection , Connectivity
  • NodeTypes_t : CommunityDetection , Connectivity
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members - Enumerations

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Mode : TypeLoader
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Members - Enumerator

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • N_PHASES : TypeLoader
  • ONE_PHASE : TypeLoader
  • TWO_PHASES : TypeLoader
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Member List

AppError Member List

This is the complete list of members for AppError, including all inherited members.

AppError() | AppError |
AppError(const std::string &mess) | AppError |
Error() | Error |
Error(const std::string &mess) | Error |
Exception() | Exception |
Exception(const std::string &mess) | Exception |
Message() const | Exception |
message | Exception | protected
SetMessage(const std::string &mess) | Exception |
ThrowError(int32_t coreErrorCode) | Error | static
~AppError() | AppError | virtual
~Error() | Error | virtual
~Exception() | Exception | virtual
Generated on Thu Feb 24 2022 12:56:05 for Sparksee by doxygen 1.8.2


Sparksee: Member List

Attribute Member List

This is the complete list of members for Attribute, including all inherited members.

GetArraySize() const | Attribute | inline
GetCount() const | Attribute | inline
GetDataType() const | Attribute | inline
GetId() const | Attribute | inline
GetKind() const | Attribute | inline
GetName() const | Attribute | inline
GetSize() const | Attribute | inline
GetTypeId() const | Attribute | inline
InvalidAttribute | Attribute | static
IsArrayAttribute() const | Attribute | inline
IsSessionAttribute() const | Attribute | inline
~Attribute() | Attribute |
Generated on Thu Feb 24 2022 12:56:05 for Sparksee by doxygen 1.8.2


Sparksee: Member List

AttributeList Member List

This is the complete list of members for AttributeList, including all inherited members.

Add(attr_t attr) | AttributeList | inline
AttributeList() | AttributeList |
AttributeList(const std::vector< attr_t > &v) | AttributeList |
Clear() | AttributeList |
Count() const | AttributeList | inline
Iterator() | AttributeList |
~AttributeList() | AttributeList |
Generated on Thu Feb 24 2022 12:56:05 for Sparksee by doxygen 1.8.2


Sparksee: Member List

AttributeListIterator Member List

This is the complete list of members for AttributeListIterator, including all inherited members.

HasNext() | AttributeListIterator | inline
Next() | AttributeListIterator | inline
~AttributeListIterator() | AttributeListIterator |
Generated on Thu Feb 24 2022 12:56:05 for Sparksee by doxygen 1.8.2


Sparksee: Member List

AttributeStatistics Member List

This is the complete list of members for AttributeStatistics, including all inherited members.

GetAvgLengthString() const | AttributeStatistics | inline
GetDistinct() const | AttributeStatistics | inline
GetMax() const | AttributeStatistics | inline
GetMaxLengthString() const | AttributeStatistics | inline
GetMean() const | AttributeStatistics | inline
GetMedian() const | AttributeStatistics | inline
GetMin() const | AttributeStatistics | inline
GetMinLengthString() const | AttributeStatistics | inline
GetMode() const | AttributeStatistics | inline
GetModeCount() const | AttributeStatistics | inline
GetNull() const | AttributeStatistics | inline
GetTotal() const | AttributeStatistics | inline
GetVariance() const | AttributeStatistics | inline
~AttributeStatistics() | AttributeStatistics | inline
Generated on Thu Feb 24 2022 12:56:05 for Sparksee by doxygen 1.8.2


Sparksee: Member List

BooleanList Member List

This is the complete list of members for BooleanList, including all inherited members.

Add(sparksee::gdb::bool_t value) | BooleanList | inline
BooleanList() | BooleanList |
BooleanList(const std::vector< bool_t > &v) | BooleanList |
Clear() | BooleanList |
Count() const | BooleanList | inline
Iterator() | BooleanList |
~BooleanList() | BooleanList |
Generated on Thu Feb 24 2022 12:56:05 for Sparksee by doxygen 1.8.2


Sparksee: Member List

BooleanListIterator Member List

This is the complete list of members for BooleanListIterator, including all inherited members.

HasNext() | BooleanListIterator | inline
Next() | BooleanListIterator | inline
~BooleanListIterator() | BooleanListIterator |
Generated on Thu Feb 24 2022 12:56:05 for Sparksee by doxygen 1.8.2


Sparksee: Member List

BulkLoader Member List

This is the complete list of members for BulkLoader, including all inherited members.

Run() | BulkLoader | virtual
SetAttributePositions(sparksee::gdb::Int32List &attrsPos) | BulkLoader |
SetAttributes(sparksee::gdb::AttributeList &attrs) | BulkLoader |
SetFilename(const std::wstring &filename) | BulkLoader |
SetLocale(const std::wstring &localeStr) | BulkLoader |
SetLogError(const std::wstring &path) | BulkLoader |
SetTimestampFormat(const std::wstring &timestampFormat) | BulkLoader |
SetType(sparksee::gdb::type_t type) | BulkLoader |
~BulkLoader() | BulkLoader | virtual
Generated on Thu Feb 24 2022 12:56:05 for Sparksee by doxygen 1.8.2


Sparksee: Member List

CommunitiesSCD Member List

This is the complete list of members for CommunitiesSCD, including all inherited members.

actualCommunity | DisjointCommunityDetection | protected
AddAllEdgeTypes() | DisjointCommunityDetection | virtual
CommunityDetection::AddAllEdgeTypes(sparksee::gdb::EdgesDirection direction) | CommunityDetection | protected
AddAllNodeTypes() | CommunityDetection | virtual
AddEdgeType(sparksee::gdb::type_t type) | DisjointCommunityDetection | virtual
CommunityDetection::AddEdgeType(sparksee::gdb::type_t type, sparksee::gdb::EdgesDirection direction) | CommunityDetection | protected
AddNodeType(sparksee::gdb::type_t type) | CommunityDetection | virtual
AssertAddedEdges() | CommunityDetection | protected
AssertAddedNodes() | CommunityDetection | protected
AssertComputed() | CommunityDetection | protected
AssertEdgeType(sparksee::gdb::type_t edgetype) | CommunityDetection | protected
AssertNodeType(sparksee::gdb::type_t nodetype) | CommunityDetection | protected
AssertNotCommunityAttribute(const std::wstring &attributeName) | DisjointCommunityDetection | protected
AssertNotComputed() | CommunityDetection | protected
attrCommunity | DisjointCommunityDetection | protected
attrCommunityName | DisjointCommunityDetection | protected
CommunitiesSCD(sparksee::gdb::Session &session) | CommunitiesSCD |
CommunityDetection(sparksee::gdb::Session &s) | CommunityDetection | protected
computed | CommunityDetection | protected
CreateGlobalPersistentAttribute(const std::wstring &attributeName) | DisjointCommunityDetection | protected
CreateGlobalTransientAttribute() | DisjointCommunityDetection | protected
dcs | DisjointCommunityDetection | protected
DisjointCommunityDetection(sparksee::gdb::Session &s) | DisjointCommunityDetection | protected
edgeTypes | CommunityDetection | protected
EdgeTypes_t typedef | CommunityDetection | protected
excludedEdges | CommunityDetection | protected
excludedNodes | CommunityDetection | protected
ExcludeEdges(sparksee::gdb::Objects &edges) | CommunityDetection | virtual
ExcludeNodes(sparksee::gdb::Objects &nodes) | CommunityDetection | virtual
GetCommunities() | DisjointCommunityDetection |
graph | CommunityDetection | protected
includedEdges | CommunityDetection | protected
includedNodes | CommunityDetection | protected
IncludeEdges(sparksee::gdb::Objects &edges) | CommunityDetection | virtual
IncludeNodes(sparksee::gdb::Objects &nodes) | CommunityDetection | virtual
IsEdgeAllowed(sparksee::gdb::oid_t edgeId) | CommunityDetection | protected
IsEdgeExcluded(sparksee::gdb::oid_t edge) | CommunityDetection | protected
IsEdgeIncluded(sparksee::gdb::oid_t edge) | CommunityDetection | protected
IsEdgeTypeAllowed(sparksee::gdb::oid_t edgeId) | CommunityDetection | protected
IsNodeAllowed(sparksee::gdb::oid_t nodeId) | CommunityDetection | protected
IsNodeExcluded(sparksee::gdb::oid_t node) | CommunityDetection | protected
IsNodeIncluded(sparksee::gdb::oid_t node) | CommunityDetection | protected
IsNodeTypeAllowed(sparksee::gdb::oid_t nodeId) | CommunityDetection | protected
matResults | DisjointCommunityDetection | protected
nodesNotVisited | CommunityDetection | protected
nodeTypes | CommunityDetection | protected
NodeTypes_t typedef | CommunityDetection | protected
RemoveGlobalAttribute() | DisjointCommunityDetection | protected
Run() | CommunitiesSCD | virtual
sess | CommunityDetection | protected
SetCommunity(sparksee::gdb::oid_t idNode) | DisjointCommunityDetection | protected
SetLookAhead(sparksee::gdb::int32_t lookahead) | CommunitiesSCD |
SetMaterializedAttribute(const std::wstring &attributeName) | DisjointCommunityDetection |
SetNodesNotVisited() | CommunityDetection | protected
~CommunitiesSCD() | CommunitiesSCD | virtual
~CommunityDetection() | CommunityDetection | virtual
~DisjointCommunityDetection() | DisjointCommunityDetection | virtual
Generated on Thu Feb 24 2022 12:56:05 for Sparksee by doxygen 1.8.2


Sparksee: Member List

CommunityDetection Member List

This is the complete list of members for CommunityDetection, including all inherited members.

AddAllEdgeTypes(sparksee::gdb::EdgesDirection direction) | CommunityDetection | protected
AddAllNodeTypes() | CommunityDetection | virtual
AddEdgeType(sparksee::gdb::type_t type, sparksee::gdb::EdgesDirection direction) | CommunityDetection | protected
AddNodeType(sparksee::gdb::type_t type) | CommunityDetection | virtual
AssertAddedEdges() | CommunityDetection | protected
AssertAddedNodes() | CommunityDetection | protected
AssertComputed() | CommunityDetection | protected
AssertEdgeType(sparksee::gdb::type_t edgetype) | CommunityDetection | protected
AssertNodeType(sparksee::gdb::type_t nodetype) | CommunityDetection | protected
AssertNotComputed() | CommunityDetection | protected
CommunityDetection(sparksee::gdb::Session &s) | CommunityDetection | protected
computed | CommunityDetection | protected
edgeTypes | CommunityDetection | protected
EdgeTypes_t typedef | CommunityDetection | protected
excludedEdges | CommunityDetection | protected
excludedNodes | CommunityDetection | protected
ExcludeEdges(sparksee::gdb::Objects &edges) | CommunityDetection | virtual
ExcludeNodes(sparksee::gdb::Objects &nodes) | CommunityDetection | virtual
graph | CommunityDetection | protected
includedEdges | CommunityDetection | protected
includedNodes | CommunityDetection | protected
IncludeEdges(sparksee::gdb::Objects &edges) | CommunityDetection | virtual
IncludeNodes(sparksee::gdb::Objects &nodes) | CommunityDetection | virtual
IsEdgeAllowed(sparksee::gdb::oid_t edgeId) | CommunityDetection | protected
IsEdgeExcluded(sparksee::gdb::oid_t edge) | CommunityDetection | protected
IsEdgeIncluded(sparksee::gdb::oid_t edge) | CommunityDetection | protected
IsEdgeTypeAllowed(sparksee::gdb::oid_t edgeId) | CommunityDetection | protected
IsNodeAllowed(sparksee::gdb::oid_t nodeId) | CommunityDetection | protected
IsNodeExcluded(sparksee::gdb::oid_t node) | CommunityDetection | protected
IsNodeIncluded(sparksee::gdb::oid_t node) | CommunityDetection | protected
IsNodeTypeAllowed(sparksee::gdb::oid_t nodeId) | CommunityDetection | protected
nodesNotVisited | CommunityDetection | protected
nodeTypes | CommunityDetection | protected
NodeTypes_t typedef | CommunityDetection | protected
Run()=0 | CommunityDetection | pure virtual
sess | CommunityDetection | protected
SetNodesNotVisited() | CommunityDetection | protected
~CommunityDetection() | CommunityDetection | virtual
Generated on Thu Feb 24 2022 12:56:05 for Sparksee by doxygen 1.8.2


Sparksee: Member List

ConnectedComponents Member List

This is the complete list of members for ConnectedComponents, including all inherited members.

ConnectedComponents(sparksee::gdb::Session &s, const std::wstring &materializedattribute) | ConnectedComponents |
GetConnectedComponent(sparksee::gdb::oid_t idNode) | ConnectedComponents |
GetCount() | ConnectedComponents |
GetNodes(sparksee::gdb::int64_t idConnectedComponent) | ConnectedComponents |
GetSize(sparksee::gdb::int64_t idConnectedComponent) | ConnectedComponents |
~ConnectedComponents() | ConnectedComponents | virtual
Generated on Thu Feb 24 2022 12:56:05 for Sparksee by doxygen 1.8.2


Sparksee: Member List

Connectivity Member List

This is the complete list of members for Connectivity, including all inherited members.

actualComponent | Connectivity | protected
AddAllEdgeTypes(sparksee::gdb::EdgesDirection d) | Connectivity | protected
AddAllNodeTypes() | Connectivity | virtual
AddEdgeType(sparksee::gdb::type_t t, sparksee::gdb::EdgesDirection d) | Connectivity | protected
AddNodeType(sparksee::gdb::type_t t) | Connectivity | virtual
AssertAddedEdges() | Connectivity | protected
AssertAddedNodes() | Connectivity | protected
AssertComputed() | Connectivity | protected
AssertEdgeType(sparksee::gdb::type_t edgetype) | Connectivity | protected
AssertNodeType(sparksee::gdb::type_t nodetype) | Connectivity | protected
AssertNotComponentAttribute(const std::wstring &attributeName) | Connectivity | protected
AssertNotComputed() | Connectivity | protected
attrComponent | Connectivity | protected
attrComponentName | Connectivity | protected
ccs | Connectivity | protected
computed | Connectivity | protected
Connectivity(sparksee::gdb::Session &s) | Connectivity | protected
CreateGlobalPersistentAttribute(const std::wstring &attributeName) | Connectivity | protected
CreateGlobalTransientAttribute() | Connectivity | protected
edgeTypes | Connectivity | protected
EdgeTypes_t typedef | Connectivity | protected
excludedEdges | Connectivity | protected
excludedNodes | Connectivity | protected
ExcludeEdges(sparksee::gdb::Objects &edges) | Connectivity | virtual
ExcludeNodes(sparksee::gdb::Objects &nodes) | Connectivity | virtual
GetConnectedComponents() | Connectivity |
graph | Connectivity | protected
IsEdgeExcluded(sparksee::gdb::oid_t edge) | Connectivity | protected
IsNodeExcluded(sparksee::gdb::oid_t node) | Connectivity | protected
IsNodeTypeAllowed(sparksee::gdb::oid_t nodeId) | Connectivity | protected
matResults | Connectivity | protected
nodesNotVisited | Connectivity | protected
nodeTypes | Connectivity | protected
NodeTypes_t typedef | Connectivity | protected
RemoveGlobalAttribute() | Connectivity | protected
Run()=0 | Connectivity | pure virtual
sess | Connectivity | protected
SetConnectedComponent(sparksee::gdb::oid_t idNode) | Connectivity | protected
SetMaterializedAttribute(const std::wstring &attributeName) | Connectivity |
SetNodesNotVisited() | Connectivity | protected
~Connectivity() | Connectivity | virtual


Sparksee: Member List

Context Member List

This is the complete list of members for Context, including all inherited members.

AddAllEdgeTypes(sparksee::gdb::EdgesDirection d) | Context |
AddAllNodeTypes() | Context |
AddEdgeType(sparksee::gdb::type_t t, sparksee::gdb::EdgesDirection d) | Context |
AddNodeType(sparksee::gdb::type_t t) | Context |
Compute() | Context |
Compute(sparksee::gdb::Session &session, sparksee::gdb::oid_t node, sparksee::gdb::TypeList *nodeTypes, sparksee::gdb::TypeList *edgeTypes, sparksee::gdb::EdgesDirection dir, sparksee::gdb::int32_t maxhops, sparksee::gdb::bool_t include) | Context | static
Context(sparksee::gdb::Session &session, sparksee::gdb::oid_t node) | Context |
edgeTypes | Context | protected
excludedEdges | Context | protected
excludedNodes | Context | protected
ExcludeEdges(sparksee::gdb::Objects &edges) | Context |
ExcludeNodes(sparksee::gdb::Objects &nodes) | Context |
graph | Context | protected
inclusive | Context | protected
maxHops | Context | protected
nodeTypes | Context | protected
sess | Context | protected
SetMaximumHops(sparksee::gdb::int32_t maxhops, sparksee::gdb::bool_t include) | Context |
src | Context | protected
~Context() | Context | virtual


Sparksee: Member List

CSVLoader Member List

This is the complete list of members for CSVLoader, including all inherited members.

LoadEdges(sparksee::gdb::Graph &graph, const std::wstring &fileName, const std::wstring &edgeType, const std::wstring &tailNodeType, const std::wstring &headNodeType, sparksee::gdb::int32_t tail=0, sparksee::gdb::int32_t head=1, const std::wstring &separator=std::wstring(L","), sparksee::gdb::bool_t directed=true, sparksee::gdb::bool_t header=true, sparksee::gdb::MissingEndpoint onMissingTail=gdb::IsError, sparksee::gdb::MissingEndpoint onMissingHead=gdb::IsError, const std::vector< sparksee::gdb::int32_t > &columns=std::vector< sparksee::gdb::int32_t >(), const std::vector< std::wstring > &attrNames=std::vector< std::wstring >(), const std::vector< sparksee::gdb::DataType > &dataTypes=std::vector< sparksee::gdb::DataType >(), const std::vector< sparksee::gdb::AttributeKind > &attrKinds=std::vector< sparksee::gdb::AttributeKind >()) | CSVLoader | static
LoadNodes(sparksee::gdb::Graph &graph, const std::wstring &fileName, const std::wstring &nodeType, const std::wstring &separator=std::wstring(L","), sparksee::gdb::bool_t header=true, const std::vector< sparksee::gdb::int32_t > &columns=std::vector< sparksee::gdb::int32_t >(), const std::vector< std::wstring > &attrNames=std::vector< std::wstring >(), const std::vector< sparksee::gdb::DataType > &dataTypes=std::vector< sparksee::gdb::DataType >(), const std::vector< sparksee::gdb::AttributeKind > &attrKinds=std::vector< sparksee::gdb::AttributeKind >()) | CSVLoader | static


Sparksee: Member List

CSVReader Member List

This is the complete list of members for CSVReader, including all inherited members.

Close() | CSVReader | virtual
CSVReader() | CSVReader |
GetRow() | CSVReader | virtual
Open(const std::wstring &filePath) | CSVReader |
Read(sparksee::gdb::StringList &row) | CSVReader | virtual
Reset() | CSVReader | virtual
RowReader() | RowReader | inlineprotected
SetLocale(const std::wstring &localeStr) | CSVReader |
SetMultilines(sparksee::gdb::int32_t numExtralines) | CSVReader |
SetNumLines(sparksee::gdb::int32_t numLines) | CSVReader |
SetQuotes(const std::wstring &quotes) | CSVReader |
SetSeparator(const std::wstring &sep) | CSVReader |
SetSingleLine() | CSVReader |
SetStartLine(sparksee::gdb::int32_t startLine) | CSVReader |
~CSVReader() | CSVReader | virtual
~RowReader() | RowReader | inlinevirtual


Sparksee: Member List

CSVWriter Member List

This is the complete list of members for CSVWriter, including all inherited members.

Close() | CSVWriter | virtual
CSVWriter() | CSVWriter |
Open(const std::wstring &f) | CSVWriter |
RowWriter() | RowWriter | inlineprotected
SetAutoQuotes(sparksee::gdb::bool_t autoquotes) | CSVWriter |
SetForcedQuotes(sparksee::gdb::BooleanList &forcequotes) | CSVWriter |
SetLocale(const std::wstring &localeStr) | CSVWriter |
SetQuotes(const std::wstring &quotes) | CSVWriter |
SetSeparator(const std::wstring &sep) | CSVWriter |
Write(sparksee::gdb::StringList &row) | CSVWriter | virtual
~CSVWriter() | CSVWriter | virtual
~RowWriter() | RowWriter | inlinevirtual


Sparksee: Member List

Database Member List

This is the complete list of members for Database, including all inherited members.

DisableRollback() | Database |
DumpSchema(const std::wstring &filePath) | Database |
EnableRollback() | Database |
FixCurrentCacheMaxSize() | Database |
FreeHandler() | Handler< sparksee_core::GraphPool > | private
GetAlias() const | Database | inline
GetCacheMaxSize() | Database |
GetHandler() | Handler< sparksee_core::GraphPool > | inlineprivate
GetHandler() const | Handler< sparksee_core::GraphPool > | inlineprivate
GetPath() const | Database | inline
GetStatistics(DatabaseStatistics &stats) | Database |
Handler() | Handler< sparksee_core::GraphPool > | inlineprivate
Handler(sparksee_core::GraphPool *h) | Handler< sparksee_core::GraphPool > | inlineprivate
IsNull() const | Handler< sparksee_core::GraphPool > | inlineprivate
NewSession() | Database |
RedoPrecommitted(int64_t txId) | Database |
SetCacheMaxSize(int32_t megaBytes) | Database |
SetHandler(sparksee_core::GraphPool *h) | Handler< sparksee_core::GraphPool > | inlineprivate
~Database() | Database | virtual
~Handler() | Handler< sparksee_core::GraphPool > | inlineprivatevirtual


Sparksee: Member List

DatabaseStatistics Member List

This is the complete list of members for DatabaseStatistics, including all inherited members.

GetCache() const | DatabaseStatistics | inline
GetData() const | DatabaseStatistics | inline
GetRead() const | DatabaseStatistics | inline
GetSessions() const | DatabaseStatistics | inline
GetTemp() const | DatabaseStatistics | inline
GetWrite() const | DatabaseStatistics | inline


Sparksee: Member List

DefaultExport Member List

This is the complete list of members for DefaultExport, including all inherited members.

DefaultExport() | DefaultExport |
EnableType(type_t type) | DefaultExport | virtual
GetEdge(oid_t edge, EdgeExport &edgeExport) | DefaultExport | virtual
GetEdgeType(type_t type, EdgeExport &edgeExport) | DefaultExport | virtual
GetGraph(GraphExport &graphExport) | DefaultExport | virtual
GetNode(oid_t node, NodeExport &nodeExport) | DefaultExport | virtual
GetNodeType(type_t type, NodeExport &nodeExport) | DefaultExport | virtual
Prepare(Graph *graph) | DefaultExport | virtual
Release() | DefaultExport | virtual
~DefaultExport() | DefaultExport | virtual
~ExportManager() | ExportManager | inlinevirtual


Sparksee: Member List

DisjointCommunities Member List

This is the complete list of members for DisjointCommunities, including all inherited members.

DisjointCommunities(sparksee::gdb::Session &session, const std::wstring &materializedattribute) | DisjointCommunities |
GetCommunity(sparksee::gdb::oid_t idNode) | DisjointCommunities |
GetCount() | DisjointCommunities |
GetNodes(sparksee::gdb::int64_t idCommunity) | DisjointCommunities |
GetSize(sparksee::gdb::int64_t idCommunity) | DisjointCommunities |
~DisjointCommunities() | DisjointCommunities | virtual


Sparksee: Member List

DisjointCommunityDetection Member List

This is the complete list of members for DisjointCommunityDetection, including all inherited members.

actualCommunity | DisjointCommunityDetection | protected
AddAllEdgeTypes() | DisjointCommunityDetection | virtual
CommunityDetection::AddAllEdgeTypes(sparksee::gdb::EdgesDirection direction) | CommunityDetection | protected
AddAllNodeTypes() | CommunityDetection | virtual
AddEdgeType(sparksee::gdb::type_t type) | DisjointCommunityDetection | virtual
CommunityDetection::AddEdgeType(sparksee::gdb::type_t type, sparksee::gdb::EdgesDirection direction) | CommunityDetection | protected
AddNodeType(sparksee::gdb::type_t type) | CommunityDetection | virtual
AssertAddedEdges() | CommunityDetection | protected
AssertAddedNodes() | CommunityDetection | protected
AssertComputed() | CommunityDetection | protected
AssertEdgeType(sparksee::gdb::type_t edgetype) | CommunityDetection | protected
AssertNodeType(sparksee::gdb::type_t nodetype) | CommunityDetection | protected
AssertNotCommunityAttribute(const std::wstring &attributeName) | DisjointCommunityDetection | protected
AssertNotComputed() | CommunityDetection | protected
attrCommunity | DisjointCommunityDetection | protected
attrCommunityName | DisjointCommunityDetection | protected
CommunityDetection(sparksee::gdb::Session &s) | CommunityDetection | protected
computed | CommunityDetection | protected
CreateGlobalPersistentAttribute(const std::wstring &attributeName) | DisjointCommunityDetection | protected
CreateGlobalTransientAttribute() | DisjointCommunityDetection | protected
dcs | DisjointCommunityDetection | protected
DisjointCommunityDetection(sparksee::gdb::Session &s) | DisjointCommunityDetection | protected
edgeTypes | CommunityDetection | protected
EdgeTypes_t typedef | CommunityDetection | protected
excludedEdges | CommunityDetection | protected
excludedNodes | CommunityDetection | protected
ExcludeEdges(sparksee::gdb::Objects &edges) | CommunityDetection | virtual
ExcludeNodes(sparksee::gdb::Objects &nodes) | CommunityDetection | virtual
GetCommunities() | DisjointCommunityDetection |
graph | CommunityDetection | protected
includedEdges | CommunityDetection | protected
includedNodes | CommunityDetection | protected
IncludeEdges(sparksee::gdb::Objects &edges) | CommunityDetection | virtual
IncludeNodes(sparksee::gdb::Objects &nodes) | CommunityDetection | virtual
IsEdgeAllowed(sparksee::gdb::oid_t edgeId) | CommunityDetection | protected
IsEdgeExcluded(sparksee::gdb::oid_t edge) | CommunityDetection | protected
IsEdgeIncluded(sparksee::gdb::oid_t edge) | CommunityDetection | protected
IsEdgeTypeAllowed(sparksee::gdb::oid_t edgeId) | CommunityDetection | protected
IsNodeAllowed(sparksee::gdb::oid_t nodeId) | CommunityDetection | protected
IsNodeExcluded(sparksee::gdb::oid_t node) | CommunityDetection | protected
IsNodeIncluded(sparksee::gdb::oid_t node) | CommunityDetection | protected
IsNodeTypeAllowed(sparksee::gdb::oid_t nodeId) | CommunityDetection | protected
matResults | DisjointCommunityDetection | protected
nodesNotVisited | CommunityDetection | protected
nodeTypes | CommunityDetection | protected
NodeTypes_t typedef | CommunityDetection | protected
RemoveGlobalAttribute() | DisjointCommunityDetection | protected
Run()=0 | DisjointCommunityDetection | pure virtual
sess | CommunityDetection | protected
SetCommunity(sparksee::gdb::oid_t idNode) | DisjointCommunityDetection | protected
SetMaterializedAttribute(const std::wstring &attributeName) | DisjointCommunityDetection |
SetNodesNotVisited() | CommunityDetection | protected
~CommunityDetection() | CommunityDetection | virtual
~DisjointCommunityDetection() | DisjointCommunityDetection | virtual


Sparksee: Member List

EdgeData Member List

This is the complete list of members for EdgeData, including all inherited members.

GetEdge() const | EdgeData | inline
GetHead() const | EdgeData | inline
GetTail() const | EdgeData | inline
~EdgeData() | EdgeData |


Sparksee: Member List

EdgeExport Member List

This is the complete list of members for EdgeExport, including all inherited members.

AsDirected() const | EdgeExport | inline
EdgeExport() | EdgeExport | inline
GetColorRGB() const | EdgeExport | inline
GetFontSize() const | EdgeExport | inline
GetLabel() const | EdgeExport | inline
GetLabelColorRGB() const | EdgeExport | inline
GetWidth() const | EdgeExport | inline
SetAsDirected(bool_t directed) | EdgeExport | inline
SetColorRGB(ColorRGB color) | EdgeExport | inline
SetDefaults() | EdgeExport |
SetFontSize(int32_t size) | EdgeExport | inline
SetLabel(const std::wstring &label) | EdgeExport | inline
SetLabelColorRGB(ColorRGB color) | EdgeExport | inline
SetWidth(int32_t width) | EdgeExport | inline
~EdgeExport() | EdgeExport | inlinevirtual


Sparksee: Member List

EdgeTypeExporter Member List

This is the complete list of members for EdgeTypeExporter, including all inherited members.

CanRun() | TypeExporter | protected
EdgeTypeExporter() | EdgeTypeExporter | inline
EdgeTypeExporter(RowWriter &rowWriter, sparksee::gdb::Graph &graph, sparksee::gdb::type_t type, sparksee::gdb::AttributeList &attrs, sparksee::gdb::int32_t hPos, sparksee::gdb::int32_t tPos, sparksee::gdb::attr_t hAttr, sparksee::gdb::attr_t tAttr) | EdgeTypeExporter | inline
NotifyListeners(const TypeExporterEvent &ev) | TypeExporter | protected
Register(TypeExporterListener &tel) | TypeExporter |
Run() | EdgeTypeExporter | inlinevirtual
RunProcess() | TypeExporter | protected
SetAttributes(sparksee::gdb::AttributeList &attrs) | TypeExporter |
SetFrequency(sparksee::gdb::int32_t freq) | TypeExporter |
SetGraph(sparksee::gdb::Graph &graph) | TypeExporter |
SetHeadAttribute(sparksee::gdb::attr_t attr) | EdgeTypeExporter | inline
SetHeader(sparksee::gdb::bool_t header) | TypeExporter |
SetHeadPosition(sparksee::gdb::int32_t pos) | EdgeTypeExporter | inline
SetRowWriter(RowWriter &rw) | TypeExporter |
SetTailAttribute(sparksee::gdb::attr_t attr) | EdgeTypeExporter | inline
SetTailPosition(sparksee::gdb::int32_t pos) | EdgeTypeExporter | inline
SetType(sparksee::gdb::type_t type) | TypeExporter |
TypeExporter() | TypeExporter | protected
TypeExporter(RowWriter &rw, sparksee::gdb::Graph &g, sparksee::gdb::type_t t, sparksee::gdb::AttributeList &attrs) | TypeExporter | protected
~EdgeTypeExporter() | EdgeTypeExporter | inlinevirtual
~TypeExporter() | TypeExporter | virtual


Sparksee: Member List

EdgeTypeLoader Member List

This is the complete list of members for EdgeTypeLoader, including all inherited members.

CanRun() | TypeLoader | protected
EdgeTypeLoader() | EdgeTypeLoader | inline
EdgeTypeLoader(RowReader &rowReader, sparksee::gdb::Graph &graph, sparksee::gdb::type_t type, sparksee::gdb::AttributeList &attrs, sparksee::gdb::Int32List &attrsPos, sparksee::gdb::int32_t hPos, sparksee::gdb::int32_t tPos, sparksee::gdb::attr_t hAttr, sparksee::gdb::attr_t tAttr, sparksee::gdb::MissingEndpoint headMEP, sparksee::gdb::MissingEndpoint tailMEP) | EdgeTypeLoader | inline
Mode enum name | TypeLoader | protected
N_PHASES enum value | TypeLoader | protected
NotifyListeners(const TypeLoaderEvent &ev) | TypeLoader | protected
ONE_PHASE enum value | TypeLoader | protected
Register(TypeLoaderListener &tel) | TypeLoader |
Run() | EdgeTypeLoader | inlinevirtual
TypeLoader::Run(Mode ph, sparksee::gdb::int32_t par) | TypeLoader | protected
RunNPhases(sparksee::gdb::int32_t partitions) | EdgeTypeLoader | inlinevirtual
RunTwoPhases() | EdgeTypeLoader | inlinevirtual
SetAttributePositions(sparksee::gdb::Int32List &attrsPos) | TypeLoader |
SetAttributes(sparksee::gdb::AttributeList &attrs) | TypeLoader |
SetFrequency(sparksee::gdb::int32_t freq) | TypeLoader |
SetGraph(sparksee::gdb::Graph &graph) | TypeLoader |
SetHeadAttribute(sparksee::gdb::attr_t attr) | EdgeTypeLoader | inline
SetHeadMEP(sparksee::gdb::MissingEndpoint mep) | EdgeTypeLoader | inline
SetHeadPosition(sparksee::gdb::int32_t pos) | EdgeTypeLoader | inline
SetLocale(const std::wstring &localeStr) | TypeLoader |
SetLogError(const std::wstring &path) | TypeLoader |
SetLogOff() | TypeLoader |
SetRowReader(RowReader &rr) | TypeLoader |
SetTailAttribute(sparksee::gdb::attr_t attr) | EdgeTypeLoader | inline
SetTailMEP(sparksee::gdb::MissingEndpoint mep) | EdgeTypeLoader | inline
SetTailPosition(sparksee::gdb::int32_t pos) | EdgeTypeLoader | inline
SetTimestampFormat(const std::wstring &timestampFormat) | TypeLoader |
SetType(sparksee::gdb::type_t type) | TypeLoader |
TWO_PHASES enum value | TypeLoader | protected
TypeLoader(RowReader &rr, sparksee::gdb::Graph &g, sparksee::gdb::type_t t, sparksee::gdb::AttributeList &attrs, sparksee::gdb::Int32List &attrsPos) | TypeLoader | protected
TypeLoader() | TypeLoader | protected
~EdgeTypeLoader() | EdgeTypeLoader | inlinevirtual
~TypeLoader() | TypeLoader | virtual


Sparksee: Member List

EncryptionError Member List

This is the complete list of members for EncryptionError, including all inherited members.

AppError() | AppError |
AppError(const std::string &mess) | AppError |
EncryptionError() | EncryptionError |
EncryptionError(const std::string &mess) | EncryptionError |
Error() | Error |
Error(const std::string &mess) | Error |
Exception() | Exception |
Exception(const std::string &mess) | Exception |
message | Exception | protected
Message() const | Exception |
SetMessage(const std::string &mess) | Exception |
ThrowError(int32_t coreErrorCode) | Error | static
~AppError() | AppError | virtual
~EncryptionError() | EncryptionError | virtual
~Error() | Error | virtual
~Exception() | Exception | virtual


Sparksee: Member List

Error Member List

This is the complete list of members for Error, including all inherited members.

Error() | Error |
Error(const std::string &mess) | Error |
Exception() | Exception |
Exception(const std::string &mess) | Exception |
message | Exception | protected
Message() const | Exception |
SetMessage(const std::string &mess) | Exception |
ThrowError(int32_t coreErrorCode) | Error | static
~Error() | Error | virtual
~Exception() | Exception | virtual


Sparksee: Member List

Exception Member List

This is the complete list of members for Exception, including all inherited members.

Exception() | Exception |
Exception(const std::string &mess) | Exception |
message | Exception | protected
Message() const | Exception |
SetMessage(const std::string &mess) | Exception |
~Exception() | Exception | virtual


Sparksee: Member List

ExportManager Member List

This is the complete list of members for ExportManager, including all inherited members.

EnableType(type_t type)=0 | ExportManager | pure virtual
GetEdge(oid_t edge, EdgeExport &edgeExport)=0 | ExportManager | pure virtual
GetEdgeType(type_t type, EdgeExport &edgeExport)=0 | ExportManager | pure virtual
GetGraph(GraphExport &graphExport)=0 | ExportManager | pure virtual
GetNode(oid_t node, NodeExport &nodeExport)=0 | ExportManager | pure virtual
GetNodeType(type_t type, NodeExport &nodeExport)=0 | ExportManager | pure virtual
Prepare(Graph *graph)=0 | ExportManager | pure virtual
Release()=0 | ExportManager | pure virtual
~ExportManager() | ExportManager | inlinevirtual


Sparksee: Member List

FileNotFoundException Member List

This is the complete list of members for FileNotFoundException, including all inherited members.

Exception() | Exception |
Exception(const std::string &mess) | Exception |
FileNotFoundException() | FileNotFoundException |
FileNotFoundException(const std::string &mess) | FileNotFoundException |
IOException() | IOException |
IOException(const std::string &mess) | IOException |
message | Exception | protected
Message() const | Exception |
SetMessage(const std::string &mess) | Exception |
~Exception() | Exception | virtual
~FileNotFoundException() | FileNotFoundException | virtual
~IOException() | IOException | virtual


Sparksee: Member List

Graph Member List

This is the complete list of members for Graph, including all inherited members.

Backup(const std::wstring &file) | Graph |
CountEdges() | Graph |
CountNodes() | Graph |
Degree(oid_t oid, type_t etype, EdgesDirection dir) | Graph |
Drop(oid_t oid) | Graph |
Drop(Objects *objs) | Graph |
DumpData(const std::wstring &file) | Graph |
DumpStorage(const std::wstring &file) | Graph |
Edges(type_t etype, oid_t tail, oid_t head) | Graph |
EncryptedBackup(const std::wstring &file, const std::wstring &keyInHex, const std::wstring &ivInHex) | Graph |
Explode(oid_t oid, type_t etype, EdgesDirection dir) | Graph |
Explode(Objects *objs, type_t etype, EdgesDirection dir) | Graph |
Export(const std::wstring &file, ExportType type, ExportManager *em) | Graph |
FindAttribute(type_t type, const std::wstring &name) | Graph |
FindAttributes(type_t type) | Graph |
FindEdge(type_t etype, oid_t tail, oid_t head) | Graph |
FindEdgeTypes() | Graph |
FindNodeTypes() | Graph |
FindObject(attr_t attr, Value &value) | Graph |
FindOrCreateEdge(type_t etype, oid_t tail, oid_t head) | Graph |
FindOrCreateObject(attr_t attr, Value &value) | Graph |
FindType(const std::wstring &name) | Graph |
FindTypes() | Graph |
FreeHandler() | Handler< sparksee_core::DbGraph > | private
GetArrayAttribute(oid_t oid, attr_t attr) | Graph |
GetAttribute(oid_t oid, attr_t attr, Value &value) | Graph |
GetAttribute(oid_t oid, attr_t attr) | Graph |
GetAttribute(attr_t attr) | Graph |
GetAttributeIntervalCount(attr_t attr, Value &lower, bool_t includeLower, Value &higher, bool_t includeHigher) | Graph |
GetAttributes(oid_t oid) | Graph |
GetAttributeStatistics(attr_t attr, bool_t basic) | Graph |
GetAttributeText(oid_t oid, attr_t attr) | Graph |
GetEdgeData(oid_t edge) | Graph |
GetEdgePeer(oid_t edge, oid_t node) | Graph |
GetHandler() | Handler< sparksee_core::DbGraph > | inlineprivate
GetHandler() const | Handler< sparksee_core::DbGraph > | inlineprivate
GetObjectType(oid_t oid) | Graph |
GetType(type_t type) | Graph |
GetValues(attr_t attr) | Graph |
Handler() | Handler< sparksee_core::DbGraph > | inlineprivate
Handler(sparksee_core::DbGraph *h) | Handler< sparksee_core::DbGraph > | inlineprivate
Heads(Objects *edges) | Graph |
IndexAttribute(attr_t attr, AttributeKind kind) | Graph |
IndexNeighbors(type_t edgeType, bool_t neighbors) | Graph |
IsNull() const | Handler< sparksee_core::DbGraph > | inlineprivate
Neighbors(oid_t oid, type_t etype, EdgesDirection dir) | Graph |
Neighbors(Objects *objs, type_t etype, EdgesDirection dir) | Graph |
NewArrayAttribute(type_t type, const std::wstring &name, DataType dt, int32_t size) | Graph |
NewAttribute(type_t type, const std::wstring &name, DataType dt, AttributeKind kind) | Graph |
NewAttribute(type_t type, const std::wstring &name, DataType dt, AttributeKind kind, Value &defaultValue) | Graph |
NewEdge(type_t type, oid_t tail, oid_t head) | Graph |
NewEdge(type_t type, attr_t tailAttr, Value &tailV, attr_t headAttr, Value &headV) | Graph |
NewEdgeType(const std::wstring &name, bool_t directed, bool_t neighbors) | Graph |
NewNode(type_t type) | Graph |
NewNodeType(const std::wstring &name) | Graph |
NewRestrictedEdgeType(const std::wstring &name, type_t tail, type_t head, bool_t neighbors) | Graph |
NewSessionArrayAttribute(type_t type, DataType dt, int32_t size) | Graph |
NewSessionAttribute(type_t type, DataType dt, AttributeKind kind) | Graph |
NewSessionAttribute(type_t type, DataType dt, AttributeKind kind, Value &defaultValue) | Graph |
RemoveAttribute(attr_t attr) | Graph |
RemoveType(type_t type) | Graph |
RenameAttribute(attr_t attr, const std::wstring &newName) | Graph |
RenameType(const std::wstring &oldName, const std::wstring &newName) | Graph |
RenameType(type_t type, const std::wstring &newName) | Graph |
Select(type_t type) | Graph |
Select(attr_t attr, Condition cond, const Value &value) | Graph |
Select(attr_t attr, Condition cond, const Value &lower, const Value &higher) | Graph |
Select(attr_t attr, Condition cond, const Value &value, const Objects *restriction) | Graph |
Select(attr_t attr, Condition cond, const Value &lower, const Value &higher, const Objects *restriction) | Graph |
SetArrayAttribute(oid_t oid, attr_t attr, const Value &value) | Graph |
SetArrayAttribute(attr_t attr, const Value &value) | Graph |
SetArrayAttributeVoid(oid_t oid, attr_t attr, const Value &value) | Graph |
SetAttribute(oid_t oid, attr_t attr, Value &value) | Graph |
SetAttribute(attr_t attr, Value &value) | Graph |
SetAttributeDefaultValue(attr_t attr, Value &value) | Graph |
SetAttributeText(oid_t oid, attr_t attr, TextStream *tstream) | Graph |
SetHandler(sparksee_core::DbGraph *h) | Handler< sparksee_core::DbGraph > | inlineprivate
Tails(Objects *edges) | Graph |
TailsAndHeads(Objects *edges, Objects *tails, Objects *heads) | Graph |
TopK(attr_t attribute, Order order, int32_t k) | Graph |
TopK(attr_t attribute, Condition operation, const Value &lower, Order order, int32_t k) | Graph |
TopK(attr_t attribute, Condition operation, const Value &lower, const Value &higher, Order order, int32_t k) | Graph |
TopK(attr_t attribute, Order order, int32_t k, Objects *restriction) | Graph |
TopK(attr_t attribute, Condition operation, const Value &lower, Order order, int32_t k, Objects *restriction) | Graph |
TopK(attr_t attribute, Condition operation, const Value &lower, const Value &higher, Order order, int32_t k, Objects *restriction) | Graph |
~Graph() | Graph | virtual
~Handler() | Handler< sparksee_core::DbGraph > | inlineprivatevirtual


Sparksee: Member List

GraphExport Member List

This is the complete list of members for GraphExport, including all inherited members.

GetLabel() const | GraphExport | inline
GraphExport() | GraphExport | inline
SetDefaults() | GraphExport |
SetLabel(const std::wstring &label) | GraphExport | inline
~GraphExport() | GraphExport | inlinevirtual


Sparksee: Member List

Handler< T > Member List

This is the complete list of members for Handler< T >, including all inherited members.

FreeHandler() | Handler< T > | protected
GetHandler() | Handler< T > | inline
GetHandler() const | Handler< T > | inline
Handler() | Handler< T > | inline
Handler(T *h) | Handler< T > | inline
IsNull() const | Handler< T > | inlineprotected
SetHandler(T *h) | Handler< T > | inlineprotected
~Handler() | Handler< T > | inlinevirtual


Sparksee: Member List

Int32List Member List

This is the complete list of members for Int32List, including all inherited members.

Add(int32_t value) | Int32List | inline
Clear() | Int32List |
Count() const | Int32List | inline
Int32List() | Int32List |
Int32List(const std::vector< int32_t > &v) | Int32List |
Iterator() | Int32List |
~Int32List() | Int32List |


Sparksee: Member List

Int32ListIterator Member List

This is the complete list of members for Int32ListIterator, including all inherited members.

HasNext() | Int32ListIterator | inline
Next() | Int32ListIterator | inline
~Int32ListIterator() | Int32ListIterator |


Sparksee: Member List

IOError Member List

This is the complete list of members for IOError, including all inherited members.

Error() | Error |
Error(const std::string &mess) | Error |
Exception() | Exception |
Exception(const std::string &mess) | Exception |
IOError() | IOError |
IOError(const std::string &mess) | IOError |
message | Exception | protected
Message() const | Exception |
SetMessage(const std::string &mess) | Exception |
SystemError() | SystemError |
SystemError(const std::string &mess) | SystemError |
ThrowError(int32_t coreErrorCode) | Error | static
~Error() | Error | virtual
~Exception() | Exception | virtual
~IOError() | IOError | virtual
~SystemError() | SystemError | virtual


Sparksee: Member List

IOException Member List

This is the complete list of members for IOException, including all inherited members.

Exception() | Exception |
Exception(const std::string &mess) | Exception |
IOException() | IOException |
IOException(const std::string &mess) | IOException |
Message() const | Exception |
message | Exception | protected
SetMessage(const std::string &mess) | Exception |
~Exception() | Exception | virtual
~IOException() | IOException | virtual


Sparksee: Member List

KeyValue Member List

This is the complete list of members for KeyValue, including all inherited members.


Sparksee: Member List

KeyValues Member List

This is the complete list of members for KeyValues, including all inherited members.

FreeHandler() | Handler< sparksee_core::KeyValues > | private
GetHandler() | Handler< sparksee_core::KeyValues > | inlineprivate
GetHandler() const | Handler< sparksee_core::KeyValues > | inlineprivate
Handler() | Handler< sparksee_core::KeyValues > | inlineprivate
Handler(sparksee_core::KeyValues *h) | Handler< sparksee_core::KeyValues > | inlineprivate
HasNext() | KeyValues |
IsNull() const | Handler< sparksee_core::KeyValues > | inlineprivate
Next() | KeyValues |
Next(KeyValue &kv) | KeyValues |
SetHandler(sparksee_core::KeyValues *h) | Handler< sparksee_core::KeyValues > | inlineprivate
~Handler() | Handler< sparksee_core::KeyValues > | inlineprivatevirtual
~KeyValues() | KeyValues | virtual


Sparksee: Member List

KOpt Member List

This is the complete list of members for KOpt, including all inherited members.

AddAllEdgeTypes(sparksee::gdb::EdgesDirection dir) | KOpt |
AddAllNodeTypes() | KOpt |
AddEdgeType(sparksee::gdb::type_t type, sparksee::gdb::EdgesDirection dir) | KOpt |
AddNodeType(sparksee::gdb::type_t type) | KOpt |
GetCurrentCost() const | KOpt |
GetCurrentTour() | KOpt |
KOpt(sparksee::gdb::Session &session) | KOpt | explicit
KOpt(sparksee::gdb::Session &session, sparksee::gdb::OIDList &tour) | KOpt |
RunThreeOpt() | KOpt |
RunTwoOpt() | KOpt |
SetCurrentTour(sparksee::gdb::OIDList &tour) | KOpt |
SetEdgeWeightAttributeType(sparksee::gdb::attr_t attr) | KOpt |
SetMaxIterations(sparksee::gdb::int64_t maxIterations) | KOpt |
SetTimeLimit(sparksee::gdb::int64_t maxTime) | KOpt |
~KOpt() | KOpt | virtual


Sparksee: Member List

LicenseError Member List

This is the complete list of members for LicenseError, including all inherited members.

AppError() | AppError |
AppError(const std::string &mess) | AppError |
Error() | Error |
Error(const std::string &mess) | Error |
Exception() | Exception |
Exception(const std::string &mess) | Exception |
LicenseError() | LicenseError |
LicenseError(const std::string &mess) | LicenseError |
message | Exception | protected
Message() const | Exception |
SetMessage(const std::string &mess) | Exception |
ThrowError(int32_t coreErrorCode) | Error | static
~AppError() | AppError | virtual
~Error() | Error | virtual
~Exception() | Exception | virtual
~LicenseError() | LicenseError | virtual


Sparksee: Member List

NodeExport Member List

This is the complete list of members for NodeExport, including all inherited members.

GetColorRGB() const | NodeExport | inline
GetFontSize() const | NodeExport | inline
GetHeight() const | NodeExport | inline
GetLabel() const | NodeExport | inline
GetLabelColorRGB() const | NodeExport | inline
GetShape() const | NodeExport | inline
GetWidth() const | NodeExport | inline
IsFit() const | NodeExport | inline
NodeExport() | NodeExport | inline
SetColorRGB(ColorRGB color) | NodeExport | inline
SetDefaults() | NodeExport |
SetFit(bool_t fit) | NodeExport | inline
SetFontSize(int32_t size) | NodeExport | inline
SetHeight(int32_t height) | NodeExport | inline
SetLabel(const std::wstring &label) | NodeExport | inline
SetLabelColorRGB(ColorRGB color) | NodeExport | inline
SetShape(NodeShape shape) | NodeExport | inline
SetWidth(int32_t width) | NodeExport | inline
~NodeExport() | NodeExport | inlinevirtual


Sparksee: Member List

NodeTypeExporter Member List

This is the complete list of members for NodeTypeExporter, including all inherited members.

CanRun() | TypeExporter | protected
NodeTypeExporter() | NodeTypeExporter | inline
NodeTypeExporter(RowWriter &rowWriter, sparksee::gdb::Graph &graph, sparksee::gdb::type_t type, sparksee::gdb::AttributeList &attrs) | NodeTypeExporter | inline
NotifyListeners(const TypeExporterEvent &ev) | TypeExporter | protected
Register(TypeExporterListener &tel) | TypeExporter |
Run() | NodeTypeExporter | inlinevirtual
RunProcess() | TypeExporter | protected
SetAttributes(sparksee::gdb::AttributeList &attrs) | TypeExporter |
SetFrequency(sparksee::gdb::int32_t freq) | TypeExporter |
SetGraph(sparksee::gdb::Graph &graph) | TypeExporter |
SetHeadAttribute(sparksee::gdb::attr_t attr) | TypeExporter | protected
SetHeader(sparksee::gdb::bool_t header) | TypeExporter |
SetHeadPosition(sparksee::gdb::int32_t pos) | TypeExporter | protected
SetRowWriter(RowWriter &rw) | TypeExporter |
SetTailAttribute(sparksee::gdb::attr_t attr) | TypeExporter | protected
SetTailPosition(sparksee::gdb::int32_t pos) | TypeExporter | protected
SetType(sparksee::gdb::type_t type) | TypeExporter |
TypeExporter() | TypeExporter | protected
TypeExporter(RowWriter &rw, sparksee::gdb::Graph &g, sparksee::gdb::type_t t, sparksee::gdb::AttributeList &attrs) | TypeExporter | protected
~NodeTypeExporter() | NodeTypeExporter | inlinevirtual
~TypeExporter() | TypeExporter | virtual


Sparksee: Member List

NodeTypeLoader Member List

This is the complete list of members for NodeTypeLoader, including all inherited members.

CanRun() | TypeLoader | protected
Mode enum name | TypeLoader | protected
N_PHASES enum value | TypeLoader | protected
NodeTypeLoader() | NodeTypeLoader | inline
NodeTypeLoader(RowReader &rowReader, sparksee::gdb::Graph &graph, sparksee::gdb::type_t type, sparksee::gdb::AttributeList &attrs, sparksee::gdb::Int32List &attrsPos) | NodeTypeLoader | inline
NotifyListeners(const TypeLoaderEvent &ev) | TypeLoader | protected
ONE_PHASE enum value | TypeLoader | protected
Register(TypeLoaderListener &tel) | TypeLoader |
Run() | NodeTypeLoader | inlinevirtual
TypeLoader::Run(Mode ph, sparksee::gdb::int32_t par) | TypeLoader | protected
RunNPhases(sparksee::gdb::int32_t partitions) | NodeTypeLoader | inlinevirtual
RunTwoPhases() | NodeTypeLoader | inlinevirtual
SetAttributePositions(sparksee::gdb::Int32List &attrsPos) | TypeLoader |
SetAttributes(sparksee::gdb::AttributeList &attrs) | TypeLoader |
SetFrequency(sparksee::gdb::int32_t freq) | TypeLoader |
SetGraph(sparksee::gdb::Graph &graph) | TypeLoader |
SetHeadAttribute(sparksee::gdb::attr_t attr) | TypeLoader | protected
SetHeadMEP(sparksee::gdb::MissingEndpoint mep) | TypeLoader | protected
SetHeadPosition(sparksee::gdb::int32_t pos) | TypeLoader | protected
SetLocale(const std::wstring &localeStr) | TypeLoader |
SetLogError(const std::wstring &path) | TypeLoader |
SetLogOff() | TypeLoader |
SetRowReader(RowReader &rr) | TypeLoader |
SetTailAttribute(sparksee::gdb::attr_t attr) | TypeLoader | protected
SetTailMEP(sparksee::gdb::MissingEndpoint mep) | TypeLoader | protected
SetTailPosition(sparksee::gdb::int32_t pos) | TypeLoader | protected
SetTimestampFormat(const std::wstring &timestampFormat) | TypeLoader |
SetType(sparksee::gdb::type_t type) | TypeLoader |
TWO_PHASES enum value | TypeLoader | protected
TypeLoader(RowReader &rr, sparksee::gdb::Graph &g, sparksee::gdb::type_t t, sparksee::gdb::AttributeList &attrs, sparksee::gdb::Int32List &attrsPos) | TypeLoader | protected
TypeLoader() | TypeLoader | protected
~NodeTypeLoader() | NodeTypeLoader | inlinevirtual
~TypeLoader() | TypeLoader | virtual


Sparksee: Member List

NoSuchElementException Member List

This is the complete list of members for NoSuchElementException, including all inherited members.

Exception() | Exception |
Exception(const std::string &mess) | Exception |
message | Exception | protected
Message() const | Exception |
NoSuchElementException() | NoSuchElementException |
NoSuchElementException(const std::string &mess) | NoSuchElementException |
SetMessage(const std::string &mess) | Exception |
~Exception() | Exception | virtual
~NoSuchElementException() | NoSuchElementException | virtual


Sparksee: Member List

Objects Member List

This is the complete list of members for Objects, including all inherited members.

Add(oid_t e) | Objects |
Any() | Objects |
Clear() | Objects |
CombineDifference(Objects *objs1, Objects *objs2) | Objects | static
CombineIntersection(Objects *objs1, Objects *objs2) | Objects | static
CombineUnion(Objects *objs1, Objects *objs2) | Objects | static
Contains(Objects *objs) | Objects |
Copy() | Objects |
Copy(Objects *objs) | Objects |
Count() | Objects |
Difference(Objects *objs) | Objects |
Equals(Objects *objs) | Objects |
Exists(oid_t e) | Objects |
FreeHandler() | Handler< sparksee_core::Objects > | private
GetHandler() | Handler< sparksee_core::Objects > | inlineprivate
GetHandler() const | Handler< sparksee_core::Objects > | inlineprivate
Handler() | Handler< sparksee_core::Objects > | inlineprivate
Handler(sparksee_core::Objects *h) | Handler< sparksee_core::Objects > | inlineprivate
Intersection(Objects *objs) | Objects |
InvalidOID | Objects | static
IsNull() const | Handler< sparksee_core::Objects > | inlineprivate
Iterator() | Objects |
IteratorFromElement(oid_t e) | Objects |
IteratorFromIndex(int64_t index) | Objects |
Remove(oid_t e) | Objects |
Sample(Objects *exclude, int64_t samples) | Objects |
SetHandler(sparksee_core::Objects *h) | Handler< sparksee_core::Objects > | inlineprivate
Union(Objects *objs) | Objects |
~Handler() | Handler< sparksee_core::Objects > | inlineprivatevirtual
~Objects() | Objects | virtual


Sparksee: Member List

ObjectsIterator Member List

This is the complete list of members for ObjectsIterator, including all inherited members.

HasNext() | ObjectsIterator |
Next() | ObjectsIterator |
~ObjectsIterator() | ObjectsIterator | virtual


Sparksee: Member List

OIDList Member List

This is the complete list of members for OIDList, including all inherited members.

Add(oid_t attr) | OIDList | inline
Clear() | OIDList |
Count() const | OIDList | inline
Iterator() | OIDList |
OIDList() | OIDList |
OIDList(int32_t numInvalidOIDs) | OIDList |
OIDList(const std::vector< oid_t > &v) | OIDList |
Set(int32_t pos, oid_t oid) | OIDList | inline
~OIDList() | OIDList |


Sparksee: Member List

OIDListIterator Member List

This is the complete list of members for OIDListIterator, including all inherited members.

HasNext() | OIDListIterator | inline
Next() | OIDListIterator | inline
~OIDListIterator() | OIDListIterator |


Sparksee: Member List

PageRank Member List

This is the complete list of members for PageRank, including all inherited members.

AddAllEdgeTypes(sparksee::gdb::EdgesDirection dir) | PageRank |
AddAllNodeTypes() | PageRank |
AddEdgeType(sparksee::gdb::type_t type, sparksee::gdb::EdgesDirection dir) | PageRank |
AddNodeType(sparksee::gdb::type_t type) | PageRank |
PageRank(sparksee::gdb::Session &session) | PageRank |
Run() | PageRank |
SetDamping(sparksee::gdb::double64_t damping) | PageRank |
SetDefaultWeight(sparksee::gdb::double64_t weight) | PageRank |
SetEdgeWeightAttributeType(sparksee::gdb::attr_t attr) | PageRank |
SetInitialPageRankValue(sparksee::gdb::double64_t startValue) | PageRank |
SetNumIterations(sparksee::gdb::int32_t numIterations) | PageRank |
SetOutputAttributeType(sparksee::gdb::attr_t attr) | PageRank |
SetStartingNode(sparksee::gdb::oid_t startNode) | PageRank |
SetTolerance(sparksee::gdb::double64_t tolerance) | PageRank |
~PageRank() | PageRank | virtual


Sparksee: Member List

Platform Member List

This is the complete list of members for Platform, including all inherited members.

GetStatistics(PlatformStatistics &stats) Platform static


Sparksee: Member List

PlatformStatistics Member List

This is the complete list of members for PlatformStatistics, including all inherited members.

GetAvailableMem() const | PlatformStatistics | inline
GetNumCPUs() const | PlatformStatistics | inline
GetRealTime() const | PlatformStatistics | inline
GetSystemTime() const | PlatformStatistics | inline
GetTotalMem() const | PlatformStatistics | inline
GetUserTime() const | PlatformStatistics | inline
PlatformStatistics() | PlatformStatistics | inline


Sparksee: Member List

Query Member List

This is the complete list of members for Query, including all inherited members.

Execute(const std::wstring &stmt, bool_t reiterable=false) | Query |
FreeHandler() | Handler< sparksee_core::Query > | private
GetHandler() | Handler< sparksee_core::Query > | inlineprivate
GetHandler() const | Handler< sparksee_core::Query > | inlineprivate
Handler() | Handler< sparksee_core::Query > | inlineprivate
Handler(sparksee_core::Query *h) | Handler< sparksee_core::Query > | inlineprivate
IsNull() const | Handler< sparksee_core::Query > | inlineprivate
SetDynamic(const std::wstring &name, Value &value) | Query |
SetHandler(sparksee_core::Query *h) | Handler< sparksee_core::Query > | inlineprivate
SetStream(const std::wstring &stream, QueryStream *handler) | Query |
~Handler() | Handler< sparksee_core::Query > | inlineprivatevirtual
~Query() | Query | virtual


Sparksee: Member List

QueryContext Member List

This is the complete list of members for QueryContext, including all inherited members.

NewQuery() | QueryContext |
QueryContext() | QueryContext |
~QueryContext() | QueryContext | virtual


Sparksee: Member List

QueryException Member List

This is the complete list of members for QueryException, including all inherited members.

AppError() | AppError |
AppError(const std::string &mess) | AppError |
Error() | Error |
Error(const std::string &mess) | Error |
Exception() | Exception |
Exception(const std::string &mess) | Exception |
GetOffset() | QueryException |
m_offset | QueryException | protected
message | Exception | protected
Message() const | Exception |
QueryException() | QueryException |
QueryException(const std::string &mess) | QueryException |
QueryException(const sparksee_core::QueryError *core_error) | QueryException |
QueryException(const sparksee_core::CypherError *cypher_error) | QueryException |
SetMessage(const std::string &mess) | Exception |
ThrowError(int32_t coreErrorCode) | Error | static
~AppError() | AppError | virtual
~Error() | Error | virtual
~Exception() | Exception | virtual
~QueryException() | QueryException | virtual


Sparksee: Member List

QueryStream Member List

This is the complete list of members for QueryStream, including all inherited members.

Fetch(ValueList &list)=0 | QueryStream | pure virtual
Prepare(const ValueList &list)=0 | QueryStream | pure virtual
QueryStream() | QueryStream | protected
Start(ResultSetList &list)=0 | QueryStream | pure virtual
~QueryStream() | QueryStream | virtual


Sparksee: Member List

RandomWalk Member List

This is the complete list of members for RandomWalk, including all inherited members.

AddAllEdgeTypes(sparksee::gdb::EdgesDirection dir) | RandomWalk | virtual
AddAllNodeTypes() | RandomWalk | virtual
AddEdgeType(sparksee::gdb::type_t type, sparksee::gdb::EdgesDirection dir) | RandomWalk | virtual
AddNodeType(sparksee::gdb::type_t type) | RandomWalk | virtual
AssertAddedEdges() | Traversal | protected
AssertAddedNodes() | Traversal | protected
AssertEdgeType(sparksee::gdb::type_t edgetype) | Traversal | protected
AssertNodeType(sparksee::gdb::type_t nodetype) | Traversal | protected
edgeTypes | Traversal | protected
excludedEdges | Traversal | protected
excludedNodes | Traversal | protected
ExcludeEdges(sparksee::gdb::Objects &edges) | RandomWalk | virtual
ExcludeNodes(sparksee::gdb::Objects &nodes) | RandomWalk | virtual
GetCurrentDepth() const | RandomWalk | virtual
graph | Traversal | protected
HasNext() | RandomWalk | virtual
IsEdgeExcluded(sparksee::gdb::oid_t edge) | Traversal | protected
IsNodeExcluded(sparksee::gdb::oid_t node) | Traversal | protected
IsNodeTypeAllowed(sparksee::gdb::oid_t nodeId) | Traversal | protected
maxHops | Traversal | protected
Next() | RandomWalk | virtual
nodeTypes | Traversal | protected
RandomWalk(sparksee::gdb::Session &session, sparksee::gdb::oid_t node) | RandomWalk |
Reset(sparksee::gdb::oid_t startNode) | RandomWalk |
sess | Traversal | protected
SetDefaultWeight(sparksee::gdb::double64_t weight) | RandomWalk |
SetEdgeWeightAttributeType(sparksee::gdb::attr_t attr) | RandomWalk |
SetInOutParameter(sparksee::gdb::double64_t val) | RandomWalk |
SetMaximumHops(sparksee::gdb::int32_t maxhops) | Traversal | virtual
SetReturnParameter(sparksee::gdb::double64_t val) | RandomWalk |
SetSeed(sparksee::gdb::int32_t seed) | RandomWalk |
src | Traversal | protected
Traversal(sparksee::gdb::Session &s, sparksee::gdb::oid_t node) | Traversal | protected
~RandomWalk() | RandomWalk | virtual
~Traversal() | Traversal | virtual


Sparksee: Member List

ResultSet Member List

This is the complete list of members for ResultSet, including all inherited members.

FreeHandler() | Handler< sparksee_core::ResultSet > | private
GetColumn(int32_t index, Value &value) const | ResultSet |
GetColumn(int32_t index) const | ResultSet |
GetColumnDataType(int32_t index) const | ResultSet |
GetColumnIndex(const std::wstring &name) const | ResultSet |
GetColumnName(int32_t index) const | ResultSet |
GetHandler() | Handler< sparksee_core::ResultSet > | inlineprivate
GetHandler() const | Handler< sparksee_core::ResultSet > | inlineprivate
GetJSON(int32_t rows) | ResultSet |
GetNumColumns() const | ResultSet |
Handler() | Handler< sparksee_core::ResultSet > | inlineprivate
Handler(sparksee_core::ResultSet *h) | Handler< sparksee_core::ResultSet > | inlineprivate
IsNull() const | Handler< sparksee_core::ResultSet > | inlineprivate
Next() | ResultSet |
Rewind() | ResultSet |
SetHandler(sparksee_core::ResultSet *h) | Handler< sparksee_core::ResultSet > | inlineprivate
~Handler() | Handler< sparksee_core::ResultSet > | inlineprivatevirtual
~ResultSet() | ResultSet | virtual


Sparksee: Member List

ResultSetList Member List

This is the complete list of members for ResultSetList, including all inherited members.

Clear() | ResultSetList
Count() const | ResultSetList
Get(int32_t index) const | ResultSetList
Iterator() | ResultSetList
ResultSetList() | ResultSetList
~ResultSetList() | ResultSetList


Sparksee: Member List

ResultSetListIterator Member List

This is the complete list of members for ResultSetListIterator, including all inherited members.

HasNext() | ResultSetListIterator
Next() | ResultSetListIterator
~ResultSetListIterator() | ResultSetListIterator


Sparksee: Member List

RowReader Member List

This is the complete list of members for RowReader, including all inherited members.

Close()=0 | RowReader | pure virtual
GetRow()=0 | RowReader | pure virtual
Read(sparksee::gdb::StringList &row)=0 | RowReader | pure virtual
Reset()=0 | RowReader | pure virtual
RowReader() | RowReader | inlineprotected
~RowReader() | RowReader | inlinevirtual


Sparksee: Member List

RowWriter Member List

This is the complete list of members for RowWriter, including all inherited members.

Close()=0 | RowWriter | pure virtual
RowWriter() | RowWriter | inlineprotected
Write(sparksee::gdb::StringList &row)=0 | RowWriter | pure virtual
~RowWriter() | RowWriter | inlinevirtual


Sparksee: Member List

ScriptParser Member List

This is the complete list of members for ScriptParser, including all inherited members.

GenerateSchemaScript(const std::wstring &path, sparksee::gdb::Database &db) | ScriptParser | static
Parse(sparksee_core::FileReader *fileReader, sparksee::gdb::bool_t execute) | ScriptParser |
Parse(const std::wstring &path, sparksee::gdb::bool_t execute, const std::wstring &localeStr) | ScriptParser |
ScriptParser() | ScriptParser |
SetErrorLog(const std::wstring &path) | ScriptParser |
SetOutputLog(const std::wstring &path) | ScriptParser |
~ScriptParser() | ScriptParser | virtual


Sparksee: Member List

Session Member List

This is the complete list of members for Session, including all inherited members.

Begin() | Session |
BeginUpdate() | Session |
Commit() | Session |
FreeHandler() | Handler< sparksee_core::Session > | private
GetGraph() | Session |
GetHandler() | Handler< sparksee_core::Session > | inlineprivate
GetHandler() const | Handler< sparksee_core::Session > | inlineprivate
GetInMemoryPoolCapacity() | Session |
Handler() | Handler< sparksee_core::Session > | inlineprivate
Handler(sparksee_core::Session *h) | Handler< sparksee_core::Session > | inlineprivate
IsNull() const | Handler< sparksee_core::Session > | inlineprivate
NewObjects() | Session |
NewQuery(sparksee::gdb::QueryLanguage lang) | Session |
PreCommit() | Session |
Rollback() | Session |
SetHandler(sparksee_core::Session *h) | Handler< sparksee_core::Session > | inlineprivate
~Handler() | Handler< sparksee_core::Session > | inlineprivatevirtual
~Session() | Session | virtual


Sparksee: Member List

ShortestPath Member List

This is the complete list of members for ShortestPath, including all inherited members.

AddAllEdgeTypes(sparksee::gdb::EdgesDirection dir) | ShortestPath | virtual
AddAllNodeTypes() | ShortestPath | virtual
AddEdgeType(sparksee::gdb::type_t type, sparksee::gdb::EdgesDirection dir) | ShortestPath | virtual
AddNodeType(sparksee::gdb::type_t type) | ShortestPath | virtual
areAllNodeTypesAllowed | ShortestPath | protected
AssertAddedEdges() | ShortestPath | protected
AssertAddedNodes() | ShortestPath | protected
AssertComputed() | ShortestPath | protected
AssertEdgeType(sparksee::gdb::type_t edgetype) | ShortestPath | protected
AssertNodeType(sparksee::gdb::type_t nodetype) | ShortestPath | protected
AssertNotComputed() | ShortestPath | protected
computed | ShortestPath | protected
edgeTypes | ShortestPath | protected
excludedEdges | ShortestPath | protected
excludedNodes | ShortestPath | protected
ExcludeEdges(sparksee::gdb::Objects &edges) | ShortestPath | virtual
ExcludeNodes(sparksee::gdb::Objects &nodes) | ShortestPath | virtual
graph | ShortestPath | protected
IsEdgeExcluded(sparksee::gdb::oid_t edge) | ShortestPath | protected
IsNodeExcluded(sparksee::gdb::oid_t node) | ShortestPath | protected
IsNodeTypeAllowed(sparksee::gdb::oid_t nodeId) | ShortestPath | protected
maxHops | ShortestPath | protected
nodeTypes | ShortestPath | protected
Run()=0 | ShortestPath | pure virtual
sess | ShortestPath | protected
SetMaximumHops(sparksee::gdb::int32_t maxhops) | ShortestPath |
ShortestPath(sparksee::gdb::Session &s) | ShortestPath | protected
~ShortestPath() | ShortestPath | virtual


Sparksee: Member List

SinglePairShortestPath Member List

This is the complete list of members for SinglePairShortestPath, including all inherited members.

AddAllEdgeTypes(sparksee::gdb::EdgesDirection dir) | ShortestPath | virtual
AddAllNodeTypes() | ShortestPath | virtual
AddEdgeType(sparksee::gdb::type_t type, sparksee::gdb::EdgesDirection dir) | ShortestPath | virtual
AddNodeType(sparksee::gdb::type_t type) | ShortestPath | virtual
areAllNodeTypesAllowed | ShortestPath | protected
AssertAddedEdges() | ShortestPath | protected
AssertAddedNodes() | ShortestPath | protected
AssertComputed() | ShortestPath | protected
AssertEdgeType(sparksee::gdb::type_t edgetype) | ShortestPath | protected
AssertNodeType(sparksee::gdb::type_t nodetype) | ShortestPath | protected
AssertNotComputed() | ShortestPath | protected
computed | ShortestPath | protected
destination | SinglePairShortestPath | protected
edgeTypes | ShortestPath | protected
excludedEdges | ShortestPath | protected
excludedNodes | ShortestPath | protected
ExcludeEdges(sparksee::gdb::Objects &edges) | ShortestPath | virtual
ExcludeNodes(sparksee::gdb::Objects &nodes) | ShortestPath | virtual
Exists() | SinglePairShortestPath | virtual
GetCost()=0 | SinglePairShortestPath | pure virtual
GetPathAsEdges()=0 | SinglePairShortestPath | pure virtual
GetPathAsNodes()=0 | SinglePairShortestPath | pure virtual
graph | ShortestPath | protected
IsEdgeExcluded(sparksee::gdb::oid_t edge) | ShortestPath | protected
IsNodeExcluded(sparksee::gdb::oid_t node) | ShortestPath | protected
IsNodeTypeAllowed(sparksee::gdb::oid_t nodeId) | ShortestPath | protected
maxHops | ShortestPath | protected
nodeTypes | ShortestPath | protected
pathAsEdges | SinglePairShortestPath | protected
pathAsNodes | SinglePairShortestPath | protected
Run()=0 | ShortestPath | pure virtual
sess | ShortestPath | protected
SetMaximumHops(sparksee::gdb::int32_t maxhops) | ShortestPath |
ShortestPath(sparksee::gdb::Session &s) | ShortestPath | protected
SinglePairShortestPath(sparksee::gdb::Session &s, sparksee::gdb::oid_t src, sparksee::gdb::oid_t dst) | SinglePairShortestPath | protected
source | SinglePairShortestPath | protected
~ShortestPath() | ShortestPath | virtual
~SinglePairShortestPath() | SinglePairShortestPath | virtual


Sparksee: Member List

SinglePairShortestPathBFS Member List

This is the complete list of members for SinglePairShortestPathBFS, including all inherited members.

AddAllEdgeTypes(sparksee::gdb::EdgesDirection dir) | ShortestPath | virtual
AddAllNodeTypes() | ShortestPath | virtual
AddEdgeType(sparksee::gdb::type_t type, sparksee::gdb::EdgesDirection dir) | ShortestPath | virtual
AddNodeType(sparksee::gdb::type_t type) | ShortestPath | virtual
areAllNodeTypesAllowed | ShortestPath | protected
AssertAddedEdges() | ShortestPath | protected
AssertAddedNodes() | ShortestPath | protected
AssertComputed() | ShortestPath | protected
AssertEdgeType(sparksee::gdb::type_t edgetype) | ShortestPath | protected
AssertNodeType(sparksee::gdb::type_t nodetype) | ShortestPath | protected
AssertNotComputed() | ShortestPath | protected
CheckOnlyExistence() | SinglePairShortestPathBFS | virtual
computed | ShortestPath | protected
destination | SinglePairShortestPath | protected
edgeTypes | ShortestPath | protected
excludedEdges | ShortestPath | protected
excludedNodes | ShortestPath | protected
ExcludeEdges(sparksee::gdb::Objects &edges) | ShortestPath | virtual
ExcludeNodes(sparksee::gdb::Objects &nodes) | ShortestPath | virtual
Exists() | SinglePairShortestPath | virtual
GetCost() | SinglePairShortestPathBFS | virtual
GetPathAsEdges() | SinglePairShortestPathBFS | virtual
GetPathAsNodes() | SinglePairShortestPathBFS | virtual
graph | ShortestPath | protected
IsEdgeExcluded(sparksee::gdb::oid_t edge) | ShortestPath | protected
IsNodeExcluded(sparksee::gdb::oid_t node) | ShortestPath | protected
IsNodeTypeAllowed(sparksee::gdb::oid_t nodeId) | ShortestPath | protected
maxHops | ShortestPath | protected
nodeTypes | ShortestPath | protected
pathAsEdges | SinglePairShortestPath | protected
pathAsNodes | SinglePairShortestPath | protected
Run() | SinglePairShortestPathBFS | virtual
sess | ShortestPath | protected
SetMaximumHops(sparksee::gdb::int32_t maxhops) | ShortestPath |
ShortestPath(sparksee::gdb::Session &s) | ShortestPath | protected
SinglePairShortestPath(sparksee::gdb::Session &s, sparksee::gdb::oid_t src, sparksee::gdb::oid_t dst) | SinglePairShortestPath | protected
SinglePairShortestPathBFS(sparksee::gdb::Session &session, sparksee::gdb::oid_t src, sparksee::gdb::oid_t dst) | SinglePairShortestPathBFS |
source | SinglePairShortestPath | protected
~ShortestPath() | ShortestPath | virtual
~SinglePairShortestPath() | SinglePairShortestPath | virtual
~SinglePairShortestPathBFS() | SinglePairShortestPathBFS | virtual


Sparksee: Member List

SinglePairShortestPathDijkstra Member List

This is the complete list of members for SinglePairShortestPathDijkstra, including all inherited members.

AddAllEdgeTypes(sparksee::gdb::EdgesDirection dir) | ShortestPath | virtual
AddAllNodeTypes() | ShortestPath | virtual
AddEdgeType(sparksee::gdb::type_t type, sparksee::gdb::EdgesDirection dir) | ShortestPath | virtual
AddNodeType(sparksee::gdb::type_t type) | ShortestPath | virtual
AddWeightedEdgeType(sparksee::gdb::type_t type, sparksee::gdb::EdgesDirection dir, sparksee::gdb::attr_t attr) | SinglePairShortestPathDijkstra | virtual
areAllNodeTypesAllowed | ShortestPath | protected
AssertAddedEdges() | ShortestPath | protected
AssertAddedNodes() | ShortestPath | protected
AssertComputed() | ShortestPath | protected
AssertEdgeType(sparksee::gdb::type_t edgetype) | ShortestPath | protected
AssertNodeType(sparksee::gdb::type_t nodetype) | ShortestPath | protected
AssertNotComputed() | ShortestPath | protected
computed | ShortestPath | protected
destination | SinglePairShortestPath | protected
edgeTypes | ShortestPath | protected
excludedEdges | ShortestPath | protected
excludedNodes | ShortestPath | protected
ExcludeEdges(sparksee::gdb::Objects &edges) | ShortestPath | virtual
ExcludeNodes(sparksee::gdb::Objects &nodes) | ShortestPath | virtual
Exists() | SinglePairShortestPath | virtual
GetCost() | SinglePairShortestPathDijkstra | virtual
GetPathAsEdges() | SinglePairShortestPathDijkstra | virtual
GetPathAsNodes() | SinglePairShortestPathDijkstra | virtual
graph | ShortestPath | protected
IsEdgeExcluded(sparksee::gdb::oid_t edge) | ShortestPath | protected
IsNodeExcluded(sparksee::gdb::oid_t node) | ShortestPath | protected
IsNodeTypeAllowed(sparksee::gdb::oid_t nodeId) | ShortestPath | protected
maxHops | ShortestPath | protected
nodeTypes | ShortestPath | protected
pathAsEdges | SinglePairShortestPath | protected
pathAsNodes | SinglePairShortestPath | protected
Run() | SinglePairShortestPathDijkstra | virtual
sess | ShortestPath | protected
SetDynamicEdgeCostCallback(SinglePairShortestPathDijkstraDynamicCost *dynCostCalculator) | SinglePairShortestPathDijkstra | virtual
SetMaximumHops(sparksee::gdb::int32_t maxhops) | ShortestPath |
SetUnweightedEdgeCost(sparksee::gdb::double64_t weight) | SinglePairShortestPathDijkstra | virtual
ShortestPath(sparksee::gdb::Session &s) | ShortestPath | protected
SinglePairShortestPath(sparksee::gdb::Session &s, sparksee::gdb::oid_t src, sparksee::gdb::oid_t dst) | SinglePairShortestPath | protected
SinglePairShortestPathDijkstra(sparksee::gdb::Session &session, sparksee::gdb::oid_t src, sparksee::gdb::oid_t dst) | SinglePairShortestPathDijkstra |
source | SinglePairShortestPath | protected
~ShortestPath() | ShortestPath | virtual
~SinglePairShortestPath() | SinglePairShortestPath | virtual
~SinglePairShortestPathDijkstra() | SinglePairShortestPathDijkstra | virtual


Sparksee: Member List

SinglePairShortestPathDijkstraDynamicCost Member List

This is the complete list of members for SinglePairShortestPathDijkstraDynamicCost, including all inherited members.

CalculateEdgeCost(sparksee::gdb::oid_t sourceNode, sparksee::gdb::double64_t sourceCost, sparksee::gdb::int32_t sourceLevel, sparksee::gdb::oid_t targetNode, sparksee::gdb::oid_t edge, sparksee::gdb::attr_t edgeWeightAttr)=0 | SinglePairShortestPathDijkstraDynamicCost | pure virtual
~SinglePairShortestPathDijkstraDynamicCost() | SinglePairShortestPathDijkstraDynamicCost | inlinevirtual


Sparksee: Member List

Sparksee Member List

This is the complete list of members for Sparksee, including all inherited members.

AddChecksums(const std::wstring &path) | Sparksee |
Create(const std::wstring &path, const std::wstring &alias) | Sparksee |
Create(const std::wstring &path, const std::wstring &alias, const SparkseeConfig &config) | Sparksee |
Decrypt(const std::wstring &path) | Sparksee |
Encrypt(const std::wstring &path) | Sparksee |
FreeHandler() | Handler< sparksee_core::SPARKSEE > | private
GetHandler() | Handler< sparksee_core::SPARKSEE > | inlineprivate
GetHandler() const | Handler< sparksee_core::SPARKSEE > | inlineprivate
GetInMemoryPoolCapacity() | Sparksee |
Handler() | Handler< sparksee_core::SPARKSEE > | inlineprivate
Handler(sparksee_core::SPARKSEE *h) | Handler< sparksee_core::SPARKSEE > | inlineprivate
IsNull() const | Handler< sparksee_core::SPARKSEE > | inlineprivate
Open(const std::wstring &path, bool_t readOnly) | Sparksee |
Open(const std::wstring &path, bool_t readOnly, const SparkseeConfig &config) | Sparksee |
RemoveChecksums(const std::wstring &path) | Sparksee |
ResizeInMemoryPool(int64_t newCapacity) | Sparksee |
Restore(const std::wstring &path, const std::wstring &backupFile) | Sparksee |
Restore(const std::wstring &path, const std::wstring &backupFile, const SparkseeConfig &config) | Sparksee |
RestoreEncryptedBackup(const std::wstring &path, const std::wstring &backupFile, const std::wstring &keyInHex, const std::wstring &ivInHex) | Sparksee |
RestoreEncryptedBackup(const std::wstring &path, const std::wstring &backupFile, const SparkseeConfig &config, const std::wstring &keyInHex, const std::wstring &ivInHex) | Sparksee |
SetHandler(sparksee_core::SPARKSEE *h) | Handler< sparksee_core::SPARKSEE > | inlineprivate
SetUnrecoverableErrorCallback(SPARKSEE_UNRECOVERABLE_ERR_CALLBACK callback) | Sparksee |
Sparksee(SparkseeConfig &config) | Sparksee |
VerifyChecksums(const std::wstring &path) | Sparksee |
Version | Sparksee | static
~Handler() | Handler< sparksee_core::SPARKSEE > | inlineprivatevirtual
~Sparksee() | Sparksee | virtual


Sparksee: Member List

SparkseeConfig Member List

This is the complete list of members for SparkseeConfig, including all inherited members.

DownloadExpected() | SparkseeConfig |
DownloadLicense() | SparkseeConfig |
GetAESIV() const | SparkseeConfig |
GetAESKey() const | SparkseeConfig |
GetCacheMaxSize() const | SparkseeConfig |
GetCacheStatisticsEnabled() const | SparkseeConfig |
GetCacheStatisticsFile() const | SparkseeConfig |
GetCacheStatisticsSnapshotTime() const | SparkseeConfig |
GetCallStackDump() const | SparkseeConfig |
GetChecksumEnabled() const | SparkseeConfig |
GetClientId() const | SparkseeConfig |
GetDownloadStatus() const | SparkseeConfig |
GetEncryptionEnabled() const | SparkseeConfig |
GetExtentPages() const | SparkseeConfig |
GetExtentSize() const | SparkseeConfig |
GetHighAvailabilityCoordinators() const | SparkseeConfig |
GetHighAvailabilityEnabled() const | SparkseeConfig |
GetHighAvailabilityIP() const | SparkseeConfig |
GetHighAvailabilityMasterHistory() const | SparkseeConfig |
GetHighAvailabilitySynchronization() const | SparkseeConfig |
GetInMemAllocSize() const | SparkseeConfig |
GetLicense() const | SparkseeConfig |
GetLicenseId() const | SparkseeConfig |
GetLicensePreDownloadDays() const | SparkseeConfig |
GetLicenseRequest() | SparkseeConfig |
GetLogFile() const | SparkseeConfig |
GetLogLevel() const | SparkseeConfig |
GetPoolFrameSize() const | SparkseeConfig |
GetPoolPartitions() const | SparkseeConfig |
GetPoolPersistentMaxSize() const | SparkseeConfig |
GetPoolPersistentMinSize() const | SparkseeConfig |
GetPoolTemporaryMaxSize() const | SparkseeConfig |
GetPoolTemporaryMinSize() const | SparkseeConfig |
GetRecoveryCacheMaxSize() const | SparkseeConfig |
GetRecoveryCheckpointTime() const | SparkseeConfig |
GetRecoveryEnabled() const | SparkseeConfig |
GetRecoveryLogFile() const | SparkseeConfig |
GetRollbackEnabled() const | SparkseeConfig |
GetSparkseeConfigFile() const | SparkseeConfig |
GetTmpEnabled() const | SparkseeConfig |
GetTmpFolder() const | SparkseeConfig |
Save() | SparkseeConfig |
SaveAll() | SparkseeConfig |
SetAESEncryptionEnabled(const std::wstring &keyInHex, const std::wstring &ivInHex) | SparkseeConfig |
SetAESEncryptionEnabled(int32_t keySize) | SparkseeConfig |
SetCacheMaxSize(int32_t megaBytes) | SparkseeConfig |
SetCacheStatisticsEnabled(bool_t status) | SparkseeConfig |
SetCacheStatisticsFile(const std::wstring &filePath) | SparkseeConfig |
SetCacheStatisticsSnapshotTime(int64_t microSeconds) | SparkseeConfig |
SetCallStackDump(bool_t status) | SparkseeConfig |
SetChecksumEnabled(bool_t status) | SparkseeConfig |
SetClientId(const std::wstring &clientId) | SparkseeConfig |
SetEncryptionDisabled() | SparkseeConfig |
SetExtentPages(int32_t pages) | SparkseeConfig |
SetExtentSize(int32_t kBytes) | SparkseeConfig |
SetHighAvailabilityCoordinators(const std::wstring &ip) | SparkseeConfig |
SetHighAvailabilityEnabled(bool_t status) | SparkseeConfig |
SetHighAvailabilityIP(const std::wstring &ip) | SparkseeConfig |
SetHighAvailabilityMasterHistory(int64_t filePath) | SparkseeConfig |
SetHighAvailabilitySynchronization(int64_t microSeconds) | SparkseeConfig |
SetInMemAllocSize(int64_t size) | SparkseeConfig |
SetLicense(const std::wstring &key) | SparkseeConfig |
SetLicenseId(const std::wstring &licenseId) | SparkseeConfig |
SetLicensePreDownloadDays(int32_t days) | SparkseeConfig |
SetLogFile(const std::wstring &filePath) | SparkseeConfig |
SetLogLevel(LogLevel level) | SparkseeConfig |
SetPoolFrameSize(int32_t extents) | SparkseeConfig |
SetPoolPartitions(int32_t pools) | SparkseeConfig |
SetPoolPersistentMaxSize(int32_t frames) | SparkseeConfig |
SetPoolPersistentMinSize(int32_t frames) | SparkseeConfig |
SetPoolTemporaryMaxSize(int32_t frames) | SparkseeConfig |
SetPoolTemporaryMinSize(int32_t frames) | SparkseeConfig |
SetRecoveryCacheMaxSize(int32_t extents) | SparkseeConfig |
SetRecoveryCheckpointTime(int64_t microSeconds) | SparkseeConfig |
SetRecoveryEnabled(bool_t status) | SparkseeConfig |
SetRecoveryLogFile(const std::wstring &filePath) | SparkseeConfig |
SetRollbackEnabled(bool_t status) | SparkseeConfig |
SetSparkseeConfigFile(const std::wstring &path) | SparkseeConfig |
SetTmpEnabled(bool_t enabled) | SparkseeConfig |
SetTmpFolder(const std::wstring &tmpFolder) | SparkseeConfig |
SparkseeConfig() | SparkseeConfig |
SparkseeConfig(const std::wstring &path) | SparkseeConfig |
SparkseeConfig(const std::wstring &path, const std::wstring &clientId, const std::wstring &licenseId) | SparkseeConfig |
~SparkseeConfig() | SparkseeConfig | virtual


Sparksee: Member List

SparkseeProperties Member List

This is the complete list of members for SparkseeProperties, including all inherited members.

Clear() | SparkseeProperties | static
Get(const std::wstring &key, const std::wstring &def) | SparkseeProperties | static
GetBoolean(const std::wstring &key, bool_t def) | SparkseeProperties | static
GetInteger(const std::wstring &key, int32_t def) | SparkseeProperties | static
GetTimeUnit(const std::wstring &key, int64_t def) | SparkseeProperties | static
Load(const std::wstring &path) | SparkseeProperties | static
SetHI(const std::wstring &value) | SparkseeProperties | static


Sparksee: Member List

StringList Member List

This is the complete list of members for StringList, including all inherited members.

Add(const std::wstring &str) | StringList | inline
Clear() | StringList |
Count() const | StringList | inline
Iterator() | StringList |
StringList() | StringList |
StringList(const std::vector< std::wstring > &v) | StringList |
~StringList() | StringList |


Sparksee: Member List

StringListIterator Member List

This is the complete list of members for StringListIterator, including all inherited members.

HasNext() | StringListIterator | inline
Next() | StringListIterator | inline
~StringListIterator() | StringListIterator |


Sparksee: Member List

StrongConnectivity Member List

This is the complete list of members for StrongConnectivity, including all inherited members.

actualComponent | Connectivity | protected
AddAllEdgeTypes(sparksee::gdb::EdgesDirection dir) | StrongConnectivity | virtual
AddAllNodeTypes() | Connectivity | virtual
AddEdgeType(sparksee::gdb::type_t type, sparksee::gdb::EdgesDirection dir) | StrongConnectivity | virtual
AddNodeType(sparksee::gdb::type_t t) | Connectivity | virtual
AssertAddedEdges() | Connectivity | protected
AssertAddedNodes() | Connectivity | protected
AssertComputed() | Connectivity | protected
AssertEdgeType(sparksee::gdb::type_t edgetype) | Connectivity | protected
AssertNodeType(sparksee::gdb::type_t nodetype) | Connectivity | protected
AssertNotComponentAttribute(const std::wstring &attributeName) | Connectivity | protected
AssertNotComputed() | Connectivity | protected
attrComponent | Connectivity | protected
attrComponentName | Connectivity | protected
ccs | Connectivity | protected
computed | Connectivity | protected
Connectivity(sparksee::gdb::Session &s) | Connectivity | protected
CreateGlobalPersistentAttribute(const std::wstring &attributeName) | Connectivity | protected
CreateGlobalTransientAttribute() | Connectivity | protected
edgeTypes | Connectivity | protected
EdgeTypes_t typedef | Connectivity | protected
excludedEdges | Connectivity | protected
excludedNodes | Connectivity | protected
ExcludeEdges(sparksee::gdb::Objects &edges) | Connectivity | virtual
ExcludeNodes(sparksee::gdb::Objects &nodes) | Connectivity | virtual
GetConnectedComponents() | Connectivity |
graph | Connectivity | protected
IsEdgeExcluded(sparksee::gdb::oid_t edge) | Connectivity | protected
IsNodeExcluded(sparksee::gdb::oid_t node) | Connectivity | protected
IsNodeTypeAllowed(sparksee::gdb::oid_t nodeId) | Connectivity | protected
matResults | Connectivity | protected
nodesNotVisited | Connectivity | protected
nodeTypes | Connectivity | protected
NodeTypes_t typedef | Connectivity | protected
RemoveGlobalAttribute() | Connectivity | protected
Run()=0 | Connectivity | pure virtual
sess | Connectivity | protected
SetConnectedComponent(sparksee::gdb::oid_t idNode) | Connectivity | protected
SetMaterializedAttribute(const std::wstring &attributeName) | Connectivity |
SetNodesNotVisited() | Connectivity | protected
StrongConnectivity(sparksee::gdb::Session &s) | StrongConnectivity | protected
~Connectivity() | Connectivity | virtual
~StrongConnectivity() | StrongConnectivity | virtual


Sparksee: Member List

StrongConnectivityGabow Member List

This is the complete list of members for StrongConnectivityGabow, including all inherited members.

actualComponent | Connectivity | protected
AddAllEdgeTypes(sparksee::gdb::EdgesDirection dir) | StrongConnectivity | virtual
AddAllNodeTypes() | Connectivity | virtual
AddEdgeType(sparksee::gdb::type_t type, sparksee::gdb::EdgesDirection dir) | StrongConnectivity | virtual
AddNodeType(sparksee::gdb::type_t t) | Connectivity | virtual
AssertAddedEdges() | Connectivity | protected
AssertAddedNodes() | Connectivity | protected
AssertComputed() | Connectivity | protected
AssertEdgeType(sparksee::gdb::type_t edgetype) | Connectivity | protected
AssertNodeType(sparksee::gdb::type_t nodetype) | Connectivity | protected
AssertNotComponentAttribute(const std::wstring &attributeName) | Connectivity | protected
AssertNotComputed() | Connectivity | protected
attrComponent | Connectivity | protected
attrComponentName | Connectivity | protected
ccs | Connectivity | protected
computed | Connectivity | protected
Connectivity(sparksee::gdb::Session &s) | Connectivity | protected
CreateGlobalPersistentAttribute(const std::wstring &attributeName) | Connectivity | protected
CreateGlobalTransientAttribute() | Connectivity | protected
edgeTypes | Connectivity | protected
EdgeTypes_t typedef | Connectivity | protected
excludedEdges | Connectivity | protected
excludedNodes | Connectivity | protected
ExcludeEdges(sparksee::gdb::Objects &edges) | Connectivity | virtual
ExcludeNodes(sparksee::gdb::Objects &nodes) | Connectivity | virtual
GetConnectedComponents() | Connectivity |
graph | Connectivity | protected
IsEdgeExcluded(sparksee::gdb::oid_t edge) | Connectivity | protected
IsNodeExcluded(sparksee::gdb::oid_t node) | Connectivity | protected
IsNodeTypeAllowed(sparksee::gdb::oid_t nodeId) | Connectivity | protected
matResults | Connectivity | protected
nodesNotVisited | Connectivity | protected
nodeTypes | Connectivity | protected
NodeTypes_t typedef | Connectivity | protected
RemoveGlobalAttribute() | Connectivity | protected
Run() | StrongConnectivityGabow | virtual
sess | Connectivity | protected
SetConnectedComponent(sparksee::gdb::oid_t idNode) | Connectivity | protected
SetMaterializedAttribute(const std::wstring &attributeName) | Connectivity |
SetNodesNotVisited() | Connectivity | protected
StrongConnectivity(sparksee::gdb::Session &s) | StrongConnectivity | protected
StrongConnectivityGabow(sparksee::gdb::Session &session) | StrongConnectivityGabow |
~Connectivity() | Connectivity | virtual
~StrongConnectivity() | StrongConnectivity | virtual
~StrongConnectivityGabow() | StrongConnectivityGabow | virtual


Sparksee: Member List

SystemError Member List

This is the complete list of members for SystemError, including all inherited members.

Error() | Error |
Error(const std::string &mess) | Error |
Exception() | Exception |
Exception(const std::string &mess) | Exception |
Message() const | Exception |
message | Exception | protected
SetMessage(const std::string &mess) | Exception |
SystemError() | SystemError |
SystemError(const std::string &mess) | SystemError |
ThrowError(int32_t coreErrorCode) | Error | static
~Error() | Error | virtual
~Exception() | Exception | virtual
~SystemError() | SystemError | virtual


Sparksee: Member List

TextStream Member List

This is the complete list of members for TextStream, including all inherited members.

Close() | TextStream |
FreeHandler() | Handler< sparksee_core::GraphTextStream > | private
GetHandler() | Handler< sparksee_core::GraphTextStream > | inlineprivate
GetHandler() const | Handler< sparksee_core::GraphTextStream > | inlineprivate
Handler() | Handler< sparksee_core::GraphTextStream > | inlineprivate
Handler(sparksee_core::GraphTextStream *h) | Handler< sparksee_core::GraphTextStream > | inlineprivate
IsNull() const | TextStream |
Read(uchar_t *dataOUT, int32_t length) const | TextStream |
SetHandler(sparksee_core::GraphTextStream *h) | Handler< sparksee_core::GraphTextStream > | inlineprivate
TextStream(bool_t append) | TextStream |
Write(const uchar_t *dataIN, int32_t length) | TextStream |
~Handler() | Handler< sparksee_core::GraphTextStream > | inlineprivatevirtual
~TextStream() | TextStream | virtual


Sparksee: Member List

Traversal Member List

This is the complete list of members for Traversal, including all inherited members.

AddAllEdgeTypes(sparksee::gdb::EdgesDirection dir) | Traversal | virtual
AddAllNodeTypes() | Traversal | virtual
AddEdgeType(sparksee::gdb::type_t type, sparksee::gdb::EdgesDirection dir) | Traversal | virtual
AddNodeType(sparksee::gdb::type_t type) | Traversal | virtual
AssertAddedEdges() | Traversal | protected
AssertAddedNodes() | Traversal | protected
AssertEdgeType(sparksee::gdb::type_t edgetype) | Traversal | protected
AssertNodeType(sparksee::gdb::type_t nodetype) | Traversal | protected
edgeTypes | Traversal | protected
excludedEdges | Traversal | protected
excludedNodes | Traversal | protected
ExcludeEdges(sparksee::gdb::Objects &edges) | Traversal | virtual
ExcludeNodes(sparksee::gdb::Objects &nodes) | Traversal | virtual
GetCurrentDepth() const =0 | Traversal | pure virtual
graph | Traversal | protected
HasNext()=0 | Traversal | pure virtual
IsEdgeExcluded(sparksee::gdb::oid_t edge) | Traversal | protected
IsNodeExcluded(sparksee::gdb::oid_t node) | Traversal | protected
IsNodeTypeAllowed(sparksee::gdb::oid_t nodeId) | Traversal | protected
maxHops | Traversal | protected
Next()=0 | Traversal | pure virtual
nodeTypes | Traversal | protected
sess | Traversal | protected
SetMaximumHops(sparksee::gdb::int32_t maxhops) | Traversal | virtual
src | Traversal | protected
Traversal(sparksee::gdb::Session &s, sparksee::gdb::oid_t node) | Traversal | protected
~Traversal() | Traversal | virtual


Sparksee: Member List

TraversalBFS Member List

This is the complete list of members for TraversalBFS, including all inherited members.

AddAllEdgeTypes(sparksee::gdb::EdgesDirection dir) | Traversal | virtual
AddAllNodeTypes() | Traversal | virtual
AddEdgeType(sparksee::gdb::type_t type, sparksee::gdb::EdgesDirection dir) | Traversal | virtual
AddNodeType(sparksee::gdb::type_t type) | Traversal | virtual
AssertAddedEdges() | Traversal | protected
AssertAddedNodes() | Traversal | protected
AssertEdgeType(sparksee::gdb::type_t edgetype) | Traversal | protected
AssertNodeType(sparksee::gdb::type_t nodetype) | Traversal | protected
edgeTypes | Traversal | protected
excludedEdges | Traversal | protected
excludedNodes | Traversal | protected
ExcludeEdges(sparksee::gdb::Objects &edges) | Traversal | virtual
ExcludeNodes(sparksee::gdb::Objects &nodes) | Traversal | virtual
GetCurrentDepth() const | TraversalBFS | virtual
graph | Traversal | protected
HasNext() | TraversalBFS | virtual
IsEdgeExcluded(sparksee::gdb::oid_t edge) | Traversal | protected
IsNodeExcluded(sparksee::gdb::oid_t node) | Traversal | protected
IsNodeTypeAllowed(sparksee::gdb::oid_t nodeId) | Traversal | protected
maxHops | Traversal | protected
Next() | TraversalBFS | virtual
nodeTypes | Traversal | protected
sess | Traversal | protected
SetMaximumHops(sparksee::gdb::int32_t maxhops) | Traversal | virtual
src | Traversal | protected
Traversal(sparksee::gdb::Session &s, sparksee::gdb::oid_t node) | Traversal | protected
TraversalBFS(sparksee::gdb::Session &session, sparksee::gdb::oid_t node) | TraversalBFS |
~Traversal() | Traversal | virtual
~TraversalBFS() | TraversalBFS | virtual


Sparksee: Member List

TraversalDFS Member List

This is the complete list of members for TraversalDFS, including all inherited members.

AddAllEdgeTypes(sparksee::gdb::EdgesDirection dir) | Traversal | virtual
AddAllNodeTypes() | Traversal | virtual
AddEdgeType(sparksee::gdb::type_t type, sparksee::gdb::EdgesDirection dir) | Traversal | virtual
AddNodeType(sparksee::gdb::type_t type) | Traversal | virtual
AssertAddedEdges() | Traversal | protected
AssertAddedNodes() | Traversal | protected
AssertEdgeType(sparksee::gdb::type_t edgetype) | Traversal | protected
AssertNodeType(sparksee::gdb::type_t nodetype) | Traversal | protected
edgeTypes | Traversal | protected
excludedEdges | Traversal | protected
excludedNodes | Traversal | protected
ExcludeEdges(sparksee::gdb::Objects &edges) | Traversal | virtual
ExcludeNodes(sparksee::gdb::Objects &nodes) | Traversal | virtual
GetCurrentDepth() const | TraversalDFS | virtual
graph | Traversal | protected
HasNext() | TraversalDFS | virtual
IsEdgeExcluded(sparksee::gdb::oid_t edge) | Traversal | protected
IsNodeExcluded(sparksee::gdb::oid_t node) | Traversal | protected
IsNodeTypeAllowed(sparksee::gdb::oid_t nodeId) | Traversal | protected
maxHops | Traversal | protected
Next() | TraversalDFS | virtual
nodeTypes | Traversal | protected
sess | Traversal | protected
SetMaximumHops(sparksee::gdb::int32_t maxhops) | Traversal | virtual
src | Traversal | protected
Traversal(sparksee::gdb::Session &s, sparksee::gdb::oid_t node) | Traversal | protected
TraversalDFS(sparksee::gdb::Session &session, sparksee::gdb::oid_t node) | TraversalDFS |
~Traversal() | Traversal | virtual
~TraversalDFS() | TraversalDFS | virtual


Sparksee: Member List

Type Member List

This is the complete list of members for Type, including all inherited members.

EdgesType | Type | static
GetAreNeighborsIndexed() const | Type | inline
GetId() const | Type | inline
GetIsDirected() const | Type | inline
GetIsRestricted() const | Type | inline
GetName() const | Type | inline
GetNumObjects() const | Type | inline
GetObjectType() const | Type | inline
GetRestrictedFrom() const | Type | inline
GetRestrictedTo() const | Type | inline
GlobalType | Type | static
InvalidType | Type | static
NodesType | Type | static
~Type() | Type |


Sparksee: Member List

TypeExporter Member List

This is the complete list of members for TypeExporter, including all inherited members.

CanRun() | TypeExporter | protected
NotifyListeners(const TypeExporterEvent &ev) | TypeExporter | protected
Register(TypeExporterListener &tel) | TypeExporter |
Run()=0 | TypeExporter | pure virtual
RunProcess() | TypeExporter | protected
SetAttributes(sparksee::gdb::AttributeList &attrs) | TypeExporter |
SetFrequency(sparksee::gdb::int32_t freq) | TypeExporter |
SetGraph(sparksee::gdb::Graph &graph) | TypeExporter |
SetHeadAttribute(sparksee::gdb::attr_t attr) | TypeExporter | protected
SetHeader(sparksee::gdb::bool_t header) | TypeExporter |
SetHeadPosition(sparksee::gdb::int32_t pos) | TypeExporter | protected
SetRowWriter(RowWriter &rw) | TypeExporter |
SetTailAttribute(sparksee::gdb::attr_t attr) | TypeExporter | protected
SetTailPosition(sparksee::gdb::int32_t pos) | TypeExporter | protected
SetType(sparksee::gdb::type_t type) | TypeExporter |
TypeExporter() | TypeExporter | protected
TypeExporter(RowWriter &rw, sparksee::gdb::Graph &g, sparksee::gdb::type_t t, sparksee::gdb::AttributeList &attrs) | TypeExporter | protected
~TypeExporter() | TypeExporter | virtual


Sparksee: Member List

TypeExporterEvent Member List

This is the complete list of members for TypeExporterEvent, including all inherited members.

GetCount() const | TypeExporterEvent | inline
GetTotal() const | TypeExporterEvent | inline
GetTypeId() const | TypeExporterEvent | inline
IsLast() const | TypeExporterEvent | inline
~TypeExporterEvent() | TypeExporterEvent | inlinevirtual


Sparksee: Member List

TypeExporterListener Member List

This is the complete list of members for TypeExporterListener, including all inherited members.

NotifyEvent(const TypeExporterEvent &tee)=0 | TypeExporterListener | pure virtual
TypeExporterListener() | TypeExporterListener | inlineprotected
~TypeExporterListener() | TypeExporterListener | inlinevirtual


Sparksee: Member List

TypeList Member List

This is the complete list of members for TypeList, including all inherited members.

Add(type_t type) | TypeList | inline
Clear() | TypeList |
Count() const | TypeList | inline
Iterator() | TypeList |
TypeList() | TypeList |
TypeList(const std::vector< type_t > &v) | TypeList |
~TypeList() | TypeList |


Sparksee: Member List

TypeListIterator Member List

This is the complete list of members for TypeListIterator, including all inherited members.

HasNext() | TypeListIterator | inline
Next() | TypeListIterator | inline
~TypeListIterator() | TypeListIterator |


Sparksee: Member List

TypeLoader Member List

This is the complete list of members for TypeLoader, including all inherited members.

CanRun() | TypeLoader | protected
Mode enum name | TypeLoader | protected
N_PHASES enum value | TypeLoader | protected
NotifyListeners(const TypeLoaderEvent &ev) | TypeLoader | protected
ONE_PHASE enum value | TypeLoader | protected
Register(TypeLoaderListener &tel) | TypeLoader |
Run()=0 | TypeLoader | pure virtual
Run(Mode ph, sparksee::gdb::int32_t par) | TypeLoader | protected
RunNPhases(sparksee::gdb::int32_t partitions)=0 | TypeLoader | pure virtual
RunTwoPhases()=0 | TypeLoader | pure virtual
SetAttributePositions(sparksee::gdb::Int32List &attrsPos) | TypeLoader |
SetAttributes(sparksee::gdb::AttributeList &attrs) | TypeLoader |
SetFrequency(sparksee::gdb::int32_t freq) | TypeLoader |
SetGraph(sparksee::gdb::Graph &graph) | TypeLoader |
SetHeadAttribute(sparksee::gdb::attr_t attr) | TypeLoader | protected
SetHeadMEP(sparksee::gdb::MissingEndpoint mep) | TypeLoader | protected
SetHeadPosition(sparksee::gdb::int32_t pos) | TypeLoader | protected
SetLocale(const std::wstring &localeStr) | TypeLoader |
SetLogError(const std::wstring &path) | TypeLoader |
SetLogOff() | TypeLoader |
SetRowReader(RowReader &rr) | TypeLoader |
SetTailAttribute(sparksee::gdb::attr_t attr) | TypeLoader | protected
SetTailMEP(sparksee::gdb::MissingEndpoint mep) | TypeLoader | protected
SetTailPosition(sparksee::gdb::int32_t pos) | TypeLoader | protected
SetTimestampFormat(const std::wstring &timestampFormat) | TypeLoader |
SetType(sparksee::gdb::type_t type) | TypeLoader |
TWO_PHASES enum value | TypeLoader | protected
TypeLoader(RowReader &rr, sparksee::gdb::Graph &g, sparksee::gdb::type_t t, sparksee::gdb::AttributeList &attrs, sparksee::gdb::Int32List &attrsPos) | TypeLoader | protected
TypeLoader() | TypeLoader | protected
~TypeLoader() | TypeLoader | virtual


Sparksee: Member List

TypeLoaderEvent Member List

This is the complete list of members for TypeLoaderEvent, including all inherited members.

GetCount() const | TypeLoaderEvent | inline
GetPartition() const | TypeLoaderEvent | inline
GetPhase() const | TypeLoaderEvent | inline
GetTotalPartitions() const | TypeLoaderEvent | inline
GetTotalPartitionSteps() const | TypeLoaderEvent | inline
GetTotalPhases() const | TypeLoaderEvent | inline
GetTypeId() const | TypeLoaderEvent | inline
IsLast() const | TypeLoaderEvent | inline
~TypeLoaderEvent() | TypeLoaderEvent | inlinevirtual


Sparksee: Member List

TypeLoaderListener Member List

This is the complete list of members for TypeLoaderListener, including all inherited members.

NotifyEvent(const TypeLoaderEvent &ev)=0 | TypeLoaderListener | pure virtual
TypeLoaderListener() | TypeLoaderListener | inlineprotected
~TypeLoaderListener() | TypeLoaderListener | inlinevirtual


Sparksee: Member List

UnsupportedOperationError Member List

This is the complete list of members for UnsupportedOperationError, including all inherited members.

AppError() | AppError |
AppError(const std::string &mess) | AppError |
Error() | Error |
Error(const std::string &mess) | Error |
Exception() | Exception |
Exception(const std::string &mess) | Exception |
message | Exception | protected
Message() const | Exception |
SetMessage(const std::string &mess) | Exception |
ThrowError(int32_t coreErrorCode) | Error | static
UnsupportedOperationError() | UnsupportedOperationError |
UnsupportedOperationError(const std::string &mess) | UnsupportedOperationError |
~AppError() | AppError | virtual
~Error() | Error | virtual
~Exception() | Exception | virtual
~UnsupportedOperationError() | UnsupportedOperationError | virtual


Sparksee: Member List

Value Member List

This is the complete list of members for Value, including all inherited members.

Compare(const Value &value) const | Value |
Equals(const Value &value) const | Value |
FreeHandler() | Handler< sparksee_core::Value > | private
GetBoolean() const | Value |
GetDataType() const | Value |
GetDouble() const | Value |
GetHandler() | Handler< sparksee_core::Value > | inlineprivate
GetHandler() const | Handler< sparksee_core::Value > | inlineprivate
GetInteger() const | Value |
GetLong() const | Value |
GetOID() const | Value |
GetString() const | Value |
GetTimestamp() const | Value |
Handler() | Handler< sparksee_core::Value > | inlineprivate
Handler(sparksee_core::Value *h) | Handler< sparksee_core::Value > | inlineprivate
IsNull() const | Value |
MaxLengthString | Value | static
operator=(const Value &value) | Value |
Set(Value &value) | Value | inline
SetBoolean(bool_t value) | Value | inline
SetBooleanVoid(bool_t value) | Value |
SetDouble(double64_t value) | Value | inline
SetDoubleVoid(double64_t value) | Value |
SetHandler(sparksee_core::Value *h) | Handler< sparksee_core::Value > | inlineprivate
SetInteger(int32_t value) | Value | inline
SetIntegerVoid(int32_t value) | Value |
SetLong(int64_t value) | Value | inline
SetLongVoid(int64_t value) | Value |
SetNull() | Value | inline
SetNullVoid() | Value |
SetOID(oid_t value) | Value | inline
SetOIDVoid(oid_t value) | Value |
SetString(const std::wstring &value) | Value | inline
SetStringVoid(const std::wstring &value) | Value |
SetTimestamp(int64_t value) | Value | inline
SetTimestamp(int32_t year, int32_t month, int32_t day, int32_t hour, int32_t minutes, int32_t seconds, int32_t millisecs) | Value | inline
SetTimestampVoid(int64_t value) | Value |
SetTimestampVoid(int32_t year, int32_t month, int32_t day, int32_t hour, int32_t minutes, int32_t seconds, int32_t millisecs) | Value |
SetVoid(Value &value) | Value | inline
ToString(std::wstring &str) const | Value |
Value() | Value |
Value(const Value &value) | Value |
~Handler() | Handler< sparksee_core::Value > | inlineprivatevirtual
~Value() | Value | virtual


Sparksee: Member List

ValueArray Member List

This is the complete list of members for ValueArray, including all inherited members.

FreeHandler() | Handler< sparksee_core::GraphValueArray > | private
Get(int32_t index, Value &value) const | ValueArray |
GetBoolean(std::vector< sparksee::gdb::bool_t > &values) const | ValueArray |
GetBoolean(int32_t index, int32_t size, std::vector< sparksee::gdb::bool_t > &values) const | ValueArray |
GetDouble(std::vector< sparksee::gdb::double64_t > &values) const | ValueArray |
GetDouble(int32_t index, int32_t size, std::vector< sparksee::gdb::double64_t > &values) const | ValueArray |
GetHandler() | Handler< sparksee_core::GraphValueArray > | inlineprivate
GetHandler() const | Handler< sparksee_core::GraphValueArray > | inlineprivate
GetInteger(std::vector< sparksee::gdb::int32_t > &values) const | ValueArray |
GetInteger(int32_t index, int32_t size, std::vector< sparksee::gdb::int32_t > &values) const | ValueArray |
GetLong(std::vector< sparksee::gdb::int64_t > &values) const | ValueArray |
GetLong(int32_t index, int32_t size, std::vector< sparksee::gdb::int64_t > &values) const | ValueArray |
GetOID(std::vector< sparksee::gdb::oid_t > &values) const | ValueArray |
GetOID(int32_t index, int32_t size, std::vector< sparksee::gdb::oid_t > &values) const | ValueArray |
GetTimestamp(std::vector< sparksee::gdb::int64_t > &values) const | ValueArray |
GetTimestamp(int32_t index, int32_t size, std::vector< sparksee::gdb::int64_t > &values) const | ValueArray |
Handler() | Handler< sparksee_core::GraphValueArray > | inlineprivate
Handler(sparksee_core::GraphValueArray *h) | Handler< sparksee_core::GraphValueArray > | inlineprivate
MakeNull() | ValueArray |
Set(int32_t index, const Value &value) | ValueArray |
Set(const Value &value) | ValueArray |
SetBoolean(const std::vector< sparksee::gdb::bool_t > &values) | ValueArray |
SetBoolean(int32_t index, const std::vector< sparksee::gdb::bool_t > &values) | ValueArray |
SetDouble(const std::vector< sparksee::gdb::double64_t > &values) | ValueArray |
SetDouble(int32_t index, const std::vector< sparksee::gdb::double64_t > &values) | ValueArray |
SetHandler(sparksee_core::GraphValueArray *h) | Handler< sparksee_core::GraphValueArray > | inlineprivate
SetInteger(const std::vector< sparksee::gdb::int32_t > &values) | ValueArray |
SetInteger(int32_t index, const std::vector< sparksee::gdb::int32_t > &values) | ValueArray |
SetLong(const std::vector< sparksee::gdb::int64_t > &values) | ValueArray |
SetLong(int32_t index, const std::vector< sparksee::gdb::int64_t > &values) | ValueArray |
SetOID(const std::vector< sparksee::gdb::oid_t > &values) | ValueArray |
SetOID(int32_t index, const std::vector< sparksee::gdb::oid_t > &values) | ValueArray |
SetTimestamp(const std::vector< sparksee::gdb::int64_t > &values) | ValueArray |
SetTimestamp(int32_t index, const std::vector< sparksee::gdb::int64_t > &values) | ValueArray |
Size() const | ValueArray |
~Handler() | Handler< sparksee_core::GraphValueArray > | inlineprivatevirtual
~ValueArray() | ValueArray | virtual
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Member List

ValueList Member List

This is the complete list of members for ValueList, including all inherited members.

Add(Value *value) | ValueList |
Clear() | ValueList |
Count() const | ValueList | inline
Get(int32_t index) const | ValueList |
Iterator() | ValueList |
ValueList() | ValueList | inline
~ValueList() | ValueList | inline
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Member List

ValueListIterator Member List

This is the complete list of members for ValueListIterator, including all inherited members.

HasNext() | ValueListIterator | inline
Next() | ValueListIterator | inline
~ValueListIterator() | ValueListIterator | inline
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Member List

Values Member List

This is the complete list of members for Values, including all inherited members.

Count() | Values |
FreeHandler() | Handler< sparksee_core::Values > | private
GetHandler() | Handler< sparksee_core::Values > | inlineprivate
GetHandler() const | Handler< sparksee_core::Values > | inlineprivate
Handler() | Handler< sparksee_core::Values > | inlineprivate
Handler(sparksee_core::Values *h) | Handler< sparksee_core::Values > | inlineprivate
IsNull() const | Handler< sparksee_core::Values > | inlineprivate
Iterator(Order order) | Values |
SetHandler(sparksee_core::Values *h) | Handler< sparksee_core::Values > | inlineprivate
~Handler() | Handler< sparksee_core::Values > | inlineprivatevirtual
~Values() | Values | virtual
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Member List

ValuesIterator Member List

This is the complete list of members for ValuesIterator, including all inherited members.

FreeHandler() | Handler< sparksee_core::Values > | private
GetHandler() | Handler< sparksee_core::Values > | inlineprivate
GetHandler() const | Handler< sparksee_core::Values > | inlineprivate
Handler() | Handler< sparksee_core::Values > | inlineprivate
Handler(sparksee_core::Values *h) | Handler< sparksee_core::Values > | inlineprivate
HasNext() | ValuesIterator |
IsNull() const | Handler< sparksee_core::Values > | inlineprivate
Next() | ValuesIterator |
SetHandler(sparksee_core::Values *h) | Handler< sparksee_core::Values > | inlineprivate
~Handler() | Handler< sparksee_core::Values > | inlineprivatevirtual
~ValuesIterator() | ValuesIterator | virtual
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Member List

WeakConnectivity Member List

This is the complete list of members for WeakConnectivity, including all inherited members.

actualComponent | Connectivity | protected
AddAllEdgeTypes() | WeakConnectivity | virtual
Connectivity::AddAllEdgeTypes(sparksee::gdb::EdgesDirection d) | Connectivity | protected
AddAllNodeTypes() | Connectivity | virtual
AddEdgeType(sparksee::gdb::type_t type) | WeakConnectivity | virtual
Connectivity::AddEdgeType(sparksee::gdb::type_t t, sparksee::gdb::EdgesDirection d) | Connectivity | protected
AddNodeType(sparksee::gdb::type_t t) | Connectivity | virtual
AssertAddedEdges() | Connectivity | protected
AssertAddedNodes() | Connectivity | protected
AssertComputed() | Connectivity | protected
AssertEdgeType(sparksee::gdb::type_t edgetype) | Connectivity | protected
AssertNodeType(sparksee::gdb::type_t nodetype) | Connectivity | protected
AssertNotComponentAttribute(const std::wstring &attributeName) | Connectivity | protected
AssertNotComputed() | Connectivity | protected
attrComponent | Connectivity | protected
attrComponentName | Connectivity | protected
ccs | Connectivity | protected
computed | Connectivity | protected
Connectivity(sparksee::gdb::Session &s) | Connectivity | protected
CreateGlobalPersistentAttribute(const std::wstring &attributeName) | Connectivity | protected
CreateGlobalTransientAttribute() | Connectivity | protected
edgeTypes | Connectivity | protected
EdgeTypes_t typedef | Connectivity | protected
excludedEdges | Connectivity | protected
excludedNodes | Connectivity | protected
ExcludeEdges(sparksee::gdb::Objects &edges) | Connectivity | virtual
ExcludeNodes(sparksee::gdb::Objects &nodes) | Connectivity | virtual
GetConnectedComponents() | Connectivity |
graph | Connectivity | protected
IsEdgeExcluded(sparksee::gdb::oid_t edge) | Connectivity | protected
IsNodeExcluded(sparksee::gdb::oid_t node) | Connectivity | protected
IsNodeTypeAllowed(sparksee::gdb::oid_t nodeId) | Connectivity | protected
matResults | Connectivity | protected
nodesNotVisited | Connectivity | protected
nodeTypes | Connectivity | protected
NodeTypes_t typedef | Connectivity | protected
RemoveGlobalAttribute() | Connectivity | protected
Run()=0 | Connectivity | pure virtual
sess | Connectivity | protected
SetConnectedComponent(sparksee::gdb::oid_t idNode) | Connectivity | protected
SetMaterializedAttribute(const std::wstring &attributeName) | Connectivity |
SetNodesNotVisited() | Connectivity | protected
WeakConnectivity(sparksee::gdb::Session &s) | WeakConnectivity | protected
~Connectivity() | Connectivity | virtual
~WeakConnectivity() | WeakConnectivity | virtual
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Member List

WeakConnectivityDFS Member List

This is the complete list of members for WeakConnectivityDFS, including all inherited members.

actualComponent | Connectivity | protected
AddAllEdgeTypes() | WeakConnectivity | virtual
Connectivity::AddAllEdgeTypes(sparksee::gdb::EdgesDirection d) | Connectivity | protected
AddAllNodeTypes() | Connectivity | virtual
AddEdgeType(sparksee::gdb::type_t type) | WeakConnectivity | virtual
Connectivity::AddEdgeType(sparksee::gdb::type_t t, sparksee::gdb::EdgesDirection d) | Connectivity | protected
AddNodeType(sparksee::gdb::type_t t) | Connectivity | virtual
AssertAddedEdges() | Connectivity | protected
AssertAddedNodes() | Connectivity | protected
AssertComputed() | Connectivity | protected
AssertEdgeType(sparksee::gdb::type_t edgetype) | Connectivity | protected
AssertNodeType(sparksee::gdb::type_t nodetype) | Connectivity | protected
AssertNotComponentAttribute(const std::wstring &attributeName) | Connectivity | protected
AssertNotComputed() | Connectivity | protected
attrComponent | Connectivity | protected
attrComponentName | Connectivity | protected
ccs | Connectivity | protected
computed | Connectivity | protected
Connectivity(sparksee::gdb::Session &s) | Connectivity | protected
CreateGlobalPersistentAttribute(const std::wstring &attributeName) | Connectivity | protected
CreateGlobalTransientAttribute() | Connectivity | protected
edgeTypes | Connectivity | protected
EdgeTypes_t typedef | Connectivity | protected
excludedEdges | Connectivity | protected
excludedNodes | Connectivity | protected
ExcludeEdges(sparksee::gdb::Objects &edges) | Connectivity | virtual
ExcludeNodes(sparksee::gdb::Objects &nodes) | Connectivity | virtual
GetConnectedComponents() | Connectivity |
graph | Connectivity | protected
IsEdgeExcluded(sparksee::gdb::oid_t edge) | Connectivity | protected
IsNodeExcluded(sparksee::gdb::oid_t node) | Connectivity | protected
IsNodeTypeAllowed(sparksee::gdb::oid_t nodeId) | Connectivity | protected
matResults | Connectivity | protected
nodesNotVisited | Connectivity | protected
nodeTypes | Connectivity | protected
NodeTypes_t typedef | Connectivity | protected
RemoveGlobalAttribute() | Connectivity | protected
Run() | WeakConnectivityDFS | virtual
sess | Connectivity | protected
SetConnectedComponent(sparksee::gdb::oid_t idNode) | Connectivity | protected
SetMaterializedAttribute(const std::wstring &attributeName) | Connectivity |
SetNodesNotVisited() | Connectivity | protected
WeakConnectivity(sparksee::gdb::Session &s) | WeakConnectivity | protected
WeakConnectivityDFS(sparksee::gdb::Session &session) | WeakConnectivityDFS |
~Connectivity() | Connectivity | virtual
~WeakConnectivity() | WeakConnectivity | virtual
~WeakConnectivityDFS() | WeakConnectivityDFS | virtual
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Member List

WrongArgumentError Member List

This is the complete list of members for WrongArgumentError, including all inherited members.

AppError() | AppError |
AppError(const std::string &mess) | AppError |
Error() | Error |
Error(const std::string &mess) | Error |
Exception() | Exception |
Exception(const std::string &mess) | Exception |
message | Exception | protected
Message() const | Exception |
SetMessage(const std::string &mess) | Exception |
ThrowError(int32_t coreErrorCode) | Error | static
WrongArgumentError() | WrongArgumentError |
WrongArgumentError(const std::string &mess) | WrongArgumentError |
~AppError() | AppError | virtual
~Error() | Error | virtual
~Exception() | Exception | virtual
~WrongArgumentError() | WrongArgumentError | virtual
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: algorithms Directory Reference

  • sparksee
  • algorithms
algorithms Directory Reference
Directory dependency graph for algorithms:

Files

file | CommunitiesSCD.h
It contains the definition of CommunitiesSCD class.
file | CommunityDetection.h
It contains the definition of CommunityDetection class.
file | ConnectedComponents.h
It contains the definition of ConnectedComponents class.
file | Connectivity.h
It contains the definition of Connectivity class.
file | Context.h
It contains the definition of Context class.
file | DisjointCommunities.h
It contains the definition of DisjointCommunities class.
file | DisjointCommunityDetection.h
It contains the definition of DisjointCommunityDetection class.
file | KOpt.h
It contains the definition of KOpt class.
file | PageRank.h
It contains the definition of PageRank class.
file | RandomWalk.h
It contains the definition of RandomWalk class.
file | ShortestPath.h
It contains the definition of ShortestPath class.
file | SinglePairShortestPath.h
It contains the definition of SinglePairShortestPath class.
file | SinglePairShortestPathBFS.h
It contains the definition of SinglePairShortestPathBFS class.
file | SinglePairShortestPathDijkstra.h
It contains the definition of SinglePairShortestPathDijkstra class.
file | StrongConnectivity.h
It contains the definition of StrongConnectivity class.
file | StrongConnectivityGabow.h
It contains the definition of StrongConnectivityGabow class.
file | Traversal.h
It contains the definition of Traversal class.
file | TraversalBFS.h
It contains the definition of TraversalBFS class.
file | TraversalDFS.h
It contains the definition of TraversalDFS class.
file | WeakConnectivity.h
It contains the definition of WeakConnectivity class.
file | WeakConnectivityDFS.h
It contains the definition of WeakConnectivityDFS class.
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: io Directory Reference

  • sparksee
  • io
io Directory Reference
Directory dependency graph for io:

Files

file | BulkLoader.h
file | CSVLoader.h
file | CSVReader.h
It contains the definition of CSVReader class.
file | CSVWriter.h
It contains the definition of CSVWriter class.
file | EdgeTypeExporter.h
It contains the definition of EdgeTypeExporter class.
file | EdgeTypeLoader.h
It contains the definition of EdgeTypeLoader class.
file | NodeTypeExporter.h
It contains the definition of NodeTypeExporter class.
file | NodeTypeLoader.h
It contains the definition of NodeTypeLoader class.
file | RowReader.h
It contains the definition of RowReader interface.
file | RowWriter.h
It contains the definition of RowWriter interface.
file | TypeExporter.h
It contains the definition of TypeExporter classes.
file | TypeLoader.h
It contains the definition of TypeLoader classes.
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: sparksee Directory Reference

  • sparksee
sparksee Directory Reference
Directory dependency graph for sparksee:

Directories

directory | algorithms
directory | gdb
directory | io
directory | script
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: script Directory Reference

  • sparksee
  • script
script Directory Reference
Directory dependency graph for script:

Files

file | Parser.h
file | ScriptParser.h
It contains the declaration of ScriptParser class.
file | Tokenizer.h
It contains the declaration of Tokenizer class.
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: gdb Directory Reference

  • sparksee
  • gdb
gdb Directory Reference
Directory dependency graph for gdb:

Files

file | common.h
It contains common includes and definitions as well as set basic data types and enumerations.
file | Database.h
It contains the definition of Database class as well as some other related classes.
file | Exception.h
It contains a hierarchy of exceptions.
file | Export.h
It contains the declaration of ExportManager interface and GraphExport, NodeExport, etc classes.
file | Graph.h
It contains the definition of Graph class.
file | Graph_data.h
It contains the definition of some Graph-related classes.
file | Handler.h
It contains the definition of Handler class.
file | KeyValues.h
file | Objects.h
It contains the definition of Object class.
file | ObjectsIterator.h
It contains the definition of ObjectsIterator class.
file | Query.h
It contains the definition of Query class.
file | QueryContext.h
It contains the definition of QueryContext class.
file | ResultSet.h
It contains the definition of ResultSet class.
file | Session.h
It contains the definition of Session class.
file | Sparksee.h
It contains the declaration of Sparksee class.
file | SparkseeConfig.h
It contains the declaration of SparkseeProperties and SparkseeConfig classes.
file | Stream.h
It contains the definition of stream classes.
file | Value.h
It contains the definitio of Value class.
file | ValueArray.h
It contains the definition of ValueArray classes.
file | Values.h
It contains the definition of Values class.
file | ValuesIterator.h
It contains the definition of ValuesIterator class.
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Main Page

Sparksee Documentation
Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Class Hierarchy

Class Hierarchy

Go to the textual class hierarchy

Generated on Thu Feb 24 2022 12:56:07 for Sparksee by doxygen 1.8.2


Sparksee: Member List

  • SinglePairShortestPathDijkstra
  • FibonacciHeap
  • Node
SinglePairShortestPathDijkstra::FibonacciHeap::Node Member List

This is the complete list of members for SinglePairShortestPathDijkstra::FibonacciHeap::Node, including all inherited members.