SparkseeNet: Namespace List

SparkseeNet 6.0.2
  • Main Page
  • Namespaces
  • Classes
  • Namespace List
  • Namespace Members
Namespace List
Here is a list of all documented namespaces with brief descriptions:
[detail level 1234]
\ N com
  \ N sparsity
    \ N sparksee
      o N algorithms
      o N gdb
      o N io
      \ N script
Generated on Thu Feb 24 2022 11:05:32 for SparkseeNet by doxygen 1.8.2


SparkseeNet: Package com

  • Classes
  • Namespace List
  • Namespace Members
Namespaces
Package com

Namespaces

package sparsity


SparkseeNet: Package com.sparsity

  • Namespace List
  • Namespace Members
  • com
  • sparsity
Namespaces
Package com.sparsity

Namespaces

package sparksee


SparkseeNet: Package com.sparsity.sparksee

  • Namespace List
  • Namespace Members
  • com
  • sparsity
  • sparksee
Namespaces
Package com.sparsity.sparksee

Namespaces

package | algorithms
package | gdb
package | io
package | script


SparkseeNet: Package com.sparsity.sparksee.algorithms

  • Namespace List
  • Namespace Members
  • com
  • sparsity
  • sparksee
  • algorithms
Classes
Package com.sparsity.sparksee.algorithms

Classes

class | CommunitiesSCD
CommunitiesSCD class. More...
class | CommunityDetection
CommunityDetection class. More...
class | ConnectedComponents
ConnectedComponents class. More...
class | Connectivity
Connectivity class. More...
class | Context
Context class. More...
class | DisjointCommunities
DisjointCommunities class. More...
class | DisjointCommunityDetection
DisjointCommunityDetection class. More...
class | KOpt
KOpt class. More...
class | PageRank
PageRank class. More...
class | RandomWalk
RandomWalk class. More...
class | ShortestPath
ShortestPath class. More...
class | SinglePairShortestPath
SinglePairShortestPath class. More...
class | SinglePairShortestPathBFS
SinglePairShortestPathBFS class. More...
class | SinglePairShortestPathDijkstra
SinglePairShortestPathDijkstra class. More...
class | SinglePairShortestPathDijkstraDynamicCost
Defines how to calculate an edge weight. More...
class | StrongConnectivity
StrongConnectivity class. More...
class | StrongConnectivityGabow
This class can be used to solve the problem of finding strongly connected components in a directed graph. More...
class | Traversal
Traversal class. More...
class | TraversalBFS
Breadth-First Search implementation of Traversal. More...
class | TraversalDFS
Depth-First Search (DFS) implementation of Traversal. More...
class | WeakConnectivity
WeakConnectivity class. More...
class | WeakConnectivityDFS
WeakConnectivityDFS class. More...


SparkseeNet: Package com.sparsity.sparksee.gdb

  • Namespace List
  • Namespace Members
  • com
  • sparsity
  • sparksee
  • gdb
Classes | Enumerations
Package com.sparsity.sparksee.gdb

Classes

class | Attribute
Attribute data class. More...
class | AttributeList
Sparksee attribute identifier list. More...
class | AttributeListIterator
AttributeList iterator class. More...
class | AttributeStatistics
Attribute statistics class. More...
class | BooleanList
Boolean list. More...
class | BooleanListIterator
BooleanList iterator class. More...
class | Database
Database class. More...
class | DatabaseStatistics
Database statistics. More...
class | DefaultExport
Default implementation for ExportManager class. More...
class | EdgeData
Edge data class. More...
class | EdgeExport
Stores edge exporting values. More...
class | ExportManager
Defines how to export a graph to an external format. More...
class | Graph
Graph class. More...
class | GraphExport
Stores the graph exporting values. More...
class | Int32List
Sparksee 32-bit signed integer list. More...
class | Int32ListIterator
Int32List iterator class. More...
class | KeyValue
class | KeyValues
Value set class. More...
class | NodeExport
Stores the node exporting values. More...
class | Objects
Object identifier set class. More...
class | ObjectsIterator
ObjectsIterator class. More...
class | OIDList
Sparksee object identifier list. More...
class | OIDListIterator
OIDList iterator class. More...
class | Platform
Platform class. More...
class | PlatformStatistics
Platform data and statistics. More...
class | Query
Query class. More...
class | QueryContext
Query context interface. More...
class | QueryStream
Query stream interface. More...
class | ResultSet
ResultSet class. More...
class | ResultSetList
ResultSet list. More...
class | ResultSetListIterator
ResultSetList iterator class. More...
class | Session
Session class. More...
class | Sparksee
Sparksee class. More...
class | SparkseeConfig
Sparksee configuration class. More...
class | SparkseeProperties
Sparksee properties file. More...
class | StringList
String list. More...
class | StringListIterator
StringList iterator class. More...
class | TextStream
TextStream class. More...
class | Type
Type data class. More...
class | TypeList
Sparksee type identifier list. More...
class | TypeListIterator
TypeList iterator class. More...
class | Value
Value class. More...
class | ValueArray
ValueArray class. More...
class | ValueList
Value list. More...
class | ValueListIterator
ValueList iterator class. More...
class | Values
Value set class. More...
class | ValuesIterator
Values iterator class. More...

Enumerations

enum AttributeKind {
Basic,
Indexed,
Unique
}
Attribute kind enumeration. More...
enum Condition {
Equal,
GreaterEqual,
GreaterThan,
LessEqual,
LessThan,
NotEqual,
Like,
LikeNoCase,
Between,
RegExp
}
Condition operators enumeration. More...
enum DataType {
Boolean,
Integer,
Long,
Double,
Timestamp,
String,
Text,
OID
}
Data type (domain) enumeration. More...
enum EdgesDirection {
Ingoing,
Outgoing,
Any
}
Edges direction enumeration. More...
enum ExportType {
Graphviz,
GraphML,
YGraphML
}
Export type. More...
enum LogLevel {
Off,
Severe,
Warning,
Info,
Config,
Fine,
Debug
}
Log level enumeration. More...
enum MissingEndpoint {
IsError,
Create,
Ignore
}
The policy to follow whenever and edge endpoint is missing during a loading. More...
enum NodeShape {
Box,
Round
}
Node shape. More...
enum ObjectType {
Node,
Edge
}
Object type enumeration. More...
enum Order {
Ascendent,
Descendent
}
Order enumeration. More...
enum QueryLanguage {
SparkseeAlgebra,
SparkseeCypher
}
The supported query languages. More...

Enumeration Type Documentation

enum com.sparsity.sparksee.gdb.AttributeKind

Attribute kind enumeration.

It determines the indexing-capabilities of an attribute.

Author
Sparsity Technologies http://www.sparsity-technologies.com
Enumerator:
Basic

Basic attribute (non indexed attribute).

Indexed

Indexed attribute.

Unique

Unique attribute (indexed + unique restriction).

Unique restriction sets two objects cannot have the same value for an attribute but NULL.

enum com.sparsity.sparksee.gdb.Condition

Condition operators enumeration.

It is mainly used in the attribute-based graph select operations.

Author
Sparsity Technologies http://www.sparsity-technologies.com
Enumerator:
Equal

Equal condition (==).

Null values can be used together with this condition to retrieve all objects having a null value for an attribute.

GreaterEqual

Greater or equal condition (>=).

Null values cannot be used together with this condition.

GreaterThan

Greater than condition (>).

Null values cannot be used together with this condition.

LessEqual

Less or equal condition (<=).

Null values cannot be used together with this condition.

LessThan

Less than condition (<).

Null values cannot be used together with this condition.

NotEqual

Not equal condition (!=).

Null values can be used together with this condition to retrieve all objects having a non-null value for an attribute.

Like

Substring condition.

Null values cannot be used together with this condition.

This condition can just be used together with String values. It allows for searching substrings (case sensitive). Ex:

'AAABBBCCCD' Like 'BBB'   returns TRUE

'AAABBBCCCD' Like 'bbb'   returns FALSE

'AAABBBCCCD' Like 'E'     returns FALSE
LikeNoCase

Substring (no case sensitive) condition.

Null values cannot be used together with this condition.

This condition can just be used together with String values. It allows for searching substrings (no case sensitive). Ex:

'AAABBBCCCD' LikeNoCase 'BBB'   returns TRUE

'AAABBBCCCD' LikeNoCase 'bbb'   returns TRUE

'AAABBBCCCD' LikeNoCase 'E'     returns FALSE
Between

In range operator condition ([x,y]).

Null values cannot be used together with this condition.

RegExp

Regular expression condition.

Null values cannot be used together with this condition.

This condition can just be used together with String values.

Regular expression format conforms most of the POSIX Extended Regular Expressions so it is case sensitive.

See the 'Regular expressions' section in the 'SPARKSEE User Manual' for details.
enum com.sparsity.sparksee.gdb.DataType

Data type (domain) enumeration.

Author
Sparsity Technologies http://www.sparsity-technologies.com
Enumerator:
Boolean

Boolean data type.

Integer

32-bit signed integer data type.

Long

64-bit signed integer data type.

Double

64-bit signed double data type.

Timestamp

Distance from Epoch (UTC) time in milliseconds precision.

It just works properly with timestamps in the range ['1970-01-01 00:00:01' UTC, '2038-01-19 03:14:07' UTC].

String

Unicode string data type.

2048 characters maximum length.

Text

Large unicode character object (CLOB) data type.

TextStream

OID

Object identifier (OID) data type.

enum com.sparsity.sparksee.gdb.EdgesDirection

Edges direction enumeration.

Author
Sparsity Technologies http://www.sparsity-technologies.com
Enumerator:
Ingoing

In-going edges.

Outgoing

Out-going edges.

Any

In-going or out-going edges.

enum com.sparsity.sparksee.gdb.ExportType

Export type.

Author
Sparsity Technologies http://www.sparsity-technologies.com
Enumerator:
Graphviz

Export to Graphviz format.

Graphviz home page: http://www.graphviz.org

GraphML

Export to GraphML format.

GraphML home page: http://graphml.graphdrawing.org/

YGraphML

Export to YGRAPHML format.

It is an GraphML format extended with a set of yWorks ("http://www.yworks.com") extensions. Thus, it allows for the visualization of the exported graph with the public yEd visualization tool ("http://www.yworks.com/products/yed").

enum com.sparsity.sparksee.gdb.LogLevel

Log level enumeration.

Log level priority order is as follows, from minimum to maximum log information: Off (log is disabled), Severe, Warning, Info, Config, Fine, Debug.

Author
Sparsity Technologies http://www.sparsity-technologies.com
Enumerator:
Off

Disable log.

Severe

Severe log level.

This is the lower log level, just errors are shown.

Warning

Warning log level.

Errors and warnings are shown.

Info

Info log level.

Errors, warnings and information messages are shown.

Config

Config log level.

Errors, warnings, information messages and configuration details of the different components are shown.

Fine

Fine log level.

This is the higher and finest public log level, everything is dumped to the log.

Debug

Debug log level.

This is for Sparksee development purposes and just works with debug versions of the library.

enum com.sparsity.sparksee.gdb.MissingEndpoint

The policy to follow whenever and edge endpoint is missing during a loading.

Enumerator:
IsError

Throw an error.

Create

Create the endpoint.

Ignore

Ignore the edge.

enum com.sparsity.sparksee.gdb.NodeShape

Node shape.

Author
Sparsity Technologies http://www.sparsity-technologies.com
Enumerator:
Box

Box shape.

Round

Round shape.

enum com.sparsity.sparksee.gdb.ObjectType

Object type enumeration.

Author
Sparsity Technologies http://www.sparsity-technologies.com
Enumerator:
Node

Node object type.

Edge

Edge object type.

enum com.sparsity.sparksee.gdb.Order

Order enumeration.

Author
Sparsity Technologies http://www.sparsity-technologies.com
Enumerator:
Ascendent

From lower to higher.

Descendent

From higher to lower.

enum com.sparsity.sparksee.gdb.QueryLanguage

The supported query languages.

Enumerator:
SparkseeAlgebra

The internal Sparksee Algebra.

SparkseeCypher

The Sparksee Cypher Language inspired by the OpenCypher Query Language.


SparkseeNet: Package com.sparsity.sparksee.io

  • Namespace List
  • Namespace Members
  • com
  • sparsity
  • sparksee
  • io
Classes
Package com.sparsity.sparksee.io

Classes

class | CSVLoader
class | CSVReader
CSVReader interface. More...
class | CSVWriter
CSVWriter interface. More...
class | EdgeTypeExporter
EdgeTypeExporter class. More...
class | EdgeTypeLoader
EdgeTypeLoader class. More...
class | NodeTypeExporter
NodeTypeExporter class. More...
class | NodeTypeLoader
NodeTypeLoader class. More...
class | RowReader
RowReader interface. More...
class | RowWriter
RowWriter interface. More...
class | TypeExporter
Base TypeExporter class. More...
class | TypeExporterEvent
Provides information about the progress of an TypeExproter instance. More...
class | TypeExporterListener
Interface to be implemented to receive TypeExporterEvent events from a TypeExporter. More...
class | TypeLoader
Base TypeLoader class. More...
class | TypeLoaderEvent
Provides information about the progress of a TypeLoader instance. More...
class | TypeLoaderListener
Interface to be implemented to receive TypeLoaderEvent events from a TypeLoader. More...


SparkseeNet: Package com.sparsity.sparksee.script

  • Namespace List
  • Namespace Members
  • com
  • sparsity
  • sparksee
  • script
Classes
Package com.sparsity.sparksee.script

Classes

class ScriptParser
ScriptParser. More...


SparkseeNet: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Enumerations
Here is a list of all documented namespace members with links to the namespaces they belong to:
  • AttributeKind : com::sparsity::sparksee::gdb
  • Condition : com::sparsity::sparksee::gdb
  • DataType : com::sparsity::sparksee::gdb
  • EdgesDirection : com::sparsity::sparksee::gdb
  • ExportType : com::sparsity::sparksee::gdb
  • LogLevel : com::sparsity::sparksee::gdb
  • MissingEndpoint : com::sparsity::sparksee::gdb
  • NodeShape : com::sparsity::sparksee::gdb
  • ObjectType : com::sparsity::sparksee::gdb
  • Order : com::sparsity::sparksee::gdb
  • QueryLanguage : com::sparsity::sparksee::gdb


SparkseeNet: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Enumerations
  • AttributeKind : com::sparsity::sparksee::gdb
  • Condition : com::sparsity::sparksee::gdb
  • DataType : com::sparsity::sparksee::gdb
  • EdgesDirection : com::sparsity::sparksee::gdb
  • ExportType : com::sparsity::sparksee::gdb
  • LogLevel : com::sparsity::sparksee::gdb
  • MissingEndpoint : com::sparsity::sparksee::gdb
  • NodeShape : com::sparsity::sparksee::gdb
  • ObjectType : com::sparsity::sparksee::gdb
  • Order : com::sparsity::sparksee::gdb
  • QueryLanguage : com::sparsity::sparksee::gdb


SparkseeNet: Class List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12345]
\ N com |
\ N sparsity |
\ N sparksee |
o N algorithms |
| o C CommunitiesSCD | CommunitiesSCD class
| o C CommunityDetection | CommunityDetection class
| o C ConnectedComponents | ConnectedComponents class
| o C Connectivity | Connectivity class
| o C Context | Context class
| o C DisjointCommunities | DisjointCommunities class
| o C DisjointCommunityDetection | DisjointCommunityDetection class
| o C KOpt | KOpt class
| o C PageRank | PageRank class
| o C RandomWalk | RandomWalk class
| o C ShortestPath | ShortestPath class
| o C SinglePairShortestPath | SinglePairShortestPath class
| o C SinglePairShortestPathBFS | SinglePairShortestPathBFS class
| o C SinglePairShortestPathDijkstra | SinglePairShortestPathDijkstra class
| o C SinglePairShortestPathDijkstraDynamicCost | Defines how to calculate an edge weight
| o C StrongConnectivity | StrongConnectivity class
| o C StrongConnectivityGabow | This class can be used to solve the problem of finding strongly connected components in a directed graph
| o C Traversal | Traversal class
| o C TraversalBFS | Breadth-First Search implementation of Traversal
| o C TraversalDFS | Depth-First Search (DFS) implementation of Traversal
| o C WeakConnectivity | WeakConnectivity class
| \ C WeakConnectivityDFS | WeakConnectivityDFS class
o N gdb |
| o C Attribute | Attribute data class
| o C AttributeList | Sparksee attribute identifier list
| o C AttributeListIterator | AttributeList iterator class
| o C AttributeStatistics | Attribute statistics class
| o C BooleanList | Boolean list
| o C BooleanListIterator | BooleanList iterator class
| o C Database | Database class
| o C DatabaseStatistics | Database statistics
| o C DefaultExport | Default implementation for ExportManager class
| o C EdgeData | Edge data class
| o C EdgeExport | Stores edge exporting values
| o C ExportManager | Defines how to export a graph to an external format
| o C Graph | Graph class
| o C GraphExport | Stores the graph exporting values
| o C Int32List | Sparksee 32-bit signed integer list
| o C Int32ListIterator | Int32List iterator class
| o C KeyValue |
| o C KeyValues | Value set class
| o C NodeExport | Stores the node exporting values
| o C Objects | Object identifier set class
| o C ObjectsIterator | ObjectsIterator class
| o C OIDList | Sparksee object identifier list
| o C OIDListIterator | OIDList iterator class
| o C Platform | Platform class
| o C PlatformStatistics | Platform data and statistics
| o C Query | Query class
| o C QueryContext | Query context interface
| o C QueryStream | Query stream interface
| o C ResultSet | ResultSet class
| o C ResultSetList | ResultSet list
| o C ResultSetListIterator | ResultSetList iterator class
| o C Session | Session class
| o C Sparksee | Sparksee class
| o C SparkseeConfig | Sparksee configuration class
| o C SparkseeProperties | Sparksee properties file
| o C StringList | String list
| o C StringListIterator | StringList iterator class
| o C TextStream | TextStream class
| o C Type | Type data class
| o C TypeList | Sparksee type identifier list
| o C TypeListIterator | TypeList iterator class
| o C Value | Value class
| o C ValueArray | ValueArray class
| o C ValueList | Value list
| o C ValueListIterator | ValueList iterator class
| o C Values | Value set class
| \ C ValuesIterator | Values iterator class
o N io |
| o C CSVLoader |
| o C CSVReader | CSVReader interface
| o C CSVWriter | CSVWriter interface
| o C EdgeTypeExporter | EdgeTypeExporter class
| o C EdgeTypeLoader | EdgeTypeLoader class
| o C NodeTypeExporter | NodeTypeExporter class
| o C NodeTypeLoader | NodeTypeLoader class
| o C RowReader | RowReader interface
| o C RowWriter | RowWriter interface
| o C TypeExporter | Base TypeExporter class
| o C TypeExporterEvent | Provides information about the progress of an TypeExproter instance
| o C TypeExporterListener | Interface to be implemented to receive TypeExporterEvent events from a TypeExporter
| o C TypeLoader | Base TypeLoader class
| o C TypeLoaderEvent | Provides information about the progress of a TypeLoader instance
| \ C TypeLoaderListener | Interface to be implemented to receive TypeLoaderEvent events from a TypeLoader
\ N script |
\ C ScriptParser | ScriptParser


SparkseeNet: com.sparsity.sparksee.algorithms.CommunitiesSCD Class Reference

  • Class Hierarchy
  • Class Members
  • com
  • sparsity
  • sparksee
  • algorithms
  • CommunitiesSCD
Public Member Functions | List of all members
com.sparsity.sparksee.algorithms.CommunitiesSCD Class Reference

CommunitiesSCD class. More...

Inheritance diagram for com.sparsity.sparksee.algorithms.CommunitiesSCD:
Collaboration diagram for com.sparsity.sparksee.algorithms.CommunitiesSCD:

Public Member Functions

void | IncludeNodes (com.sparsity.sparksee.gdb.Objects nodes)
Set additional nodes that can be used.
void | AddNodeType (int type)
Allows connectivity through nodes of the given type.
void | IncludeEdges (com.sparsity.sparksee.gdb.Objects edges)
Set additional edges that can be used.
void | ExcludeNodes (com.sparsity.sparksee.gdb.Objects nodes)
Set which nodes can't be used.
com.sparsity.sparksee.algorithms.DisjointCommunities GetCommunities ()
Returns the results generated by the execution of the algorithm.
void | AddEdgeType (int type)
Allows connectivity through edges of the given type.
void | AddAllEdgeTypes ()
Allows connectivity through all edge types of the graph.
void | AddAllNodeTypes ()
Allows connectivity through all node types of the graph.
CommunitiesSCD (com.sparsity.sparksee.gdb.Session session)
Creates a new instance of CommunitiesSCD.
void | Run ()
Executes the algorithm.
void | SetMaterializedAttribute (System.String attributeName)
Creates a new common attribute type for all node types in the graph in order to store, persistently, the results related to the disjoint communities found while executing this algorithm.
void | ExcludeEdges (com.sparsity.sparksee.gdb.Objects edges)
Set which edges can't be used.
void | SetLookAhead (int lookahead)
Sets the size of the lookahead iterations to look (5 by default).
boolean | IsClosed ()
Gets if CommunityDetection instance has been closed or not.
void | Close ()
Closes the CommunityDetection instance.

Detailed Description

CommunitiesSCD class.

Implementation of the community detection algorithm "Scalable Community Detection" based on the paper "High quality, scalable and parallel community detection for large real graphs" by Arnau Prat-Perez, David Dominguez-Sal, Josep-Lluis Larriba-Pey - WWW 2014.

The purpose of this algorithm is to find disjoint communities in an undirected graph or in a directed graph which will be considered as an undirected one.

It is possible to set some restrictions after constructing a new instance of this class and before running it in order to limit the results.

After the execution, we can retrieve the results stored in an instance of the DisjointCommunities class using the getCommunities method.

Check out the 'Algorithms' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

com.sparsity.sparksee.algorithms.CommunitiesSCD.CommunitiesSCD ( com.sparsity.sparksee.gdb.Session session )

Creates a new instance of CommunitiesSCD.

After creating this instance is required to indicate the set of edge types and the set of node types which will be navigated through while traversing the graph in order to find the communities.

Parameters
session [in] Session to get the graph from and calculate the communities

Member Function Documentation

void com.sparsity.sparksee.algorithms.CommunitiesSCD.AddAllEdgeTypes ( )

Allows connectivity through all edge types of the graph.

The edges can be used in Any direction.

void com.sparsity.sparksee.algorithms.CommunitiesSCD.AddEdgeType ( int type )

Allows connectivity through edges of the given type.

The edges can be used in Any direction.

Parameters
type [in] Edge type.
void com.sparsity.sparksee.algorithms.CommunitiesSCD.AddNodeType ( int type )

Allows connectivity through nodes of the given type.

Parameters
type null
void com.sparsity.sparksee.algorithms.CommunityDetection.Close ( )
inherited

Closes the CommunityDetection instance.

It must be called to ensure the integrity of all data.

void com.sparsity.sparksee.algorithms.CommunitiesSCD.ExcludeEdges ( com.sparsity.sparksee.gdb.Objects edges )

Set which edges can't be used.

This will replace any previously specified set of excluded edges. Should only be used to exclude the usage of specific edges from allowed edge types because it's less efficient than not allowing an edge type.

Parameters
edges [in] A set of edge identifiers that must be kept intact until the destruction of the class.
void com.sparsity.sparksee.algorithms.CommunitiesSCD.ExcludeNodes ( com.sparsity.sparksee.gdb.Objects nodes )

Set which nodes can't be used.

This will replace any previously specified set of excluded nodes. Should only be used to exclude the usage of specific nodes from allowed node types because it's less efficient than not allowing a node type.

Parameters
nodes [in] A set of node identifiers that must be kept intact until the destruction of the class.
com.sparsity.sparksee.algorithms.DisjointCommunities com.sparsity.sparksee.algorithms.CommunitiesSCD.GetCommunities ( )

Returns the results generated by the execution of the algorithm.

These results contain information related to the disjoint communities found as the number of different components, the set of nodes contained in each component or many other data.

Returns
Returns an instance of the class DisjointCommunities which contain information related to the disjoint communities found.
void com.sparsity.sparksee.algorithms.CommunitiesSCD.IncludeEdges ( com.sparsity.sparksee.gdb.Objects edges )

Set additional edges that can be used.

This will replace any previously specified set of include edges. Using this optional method adds valid edges to the edges of any edge type explicitly set as a valid type. Should only be used to include specific small sets of edges because it's less efficient than just using an edge type. For any edge to be used, both nodes must be also valid.

Parameters
edges [in] A set of edge identifiers that must be kept intact until the destruction of the class.
void com.sparsity.sparksee.algorithms.CommunitiesSCD.IncludeNodes ( com.sparsity.sparksee.gdb.Objects nodes )

Set additional nodes that can be used.

This will replace any previously specified set of include nodes. Using this optional method adds valid nodes to the nodes of any node type explicitly set as a valid type. Should only be used to include specific small sets of nodes because it's less efficient than just using a node type.

Parameters
nodes [in] A set of node identifiers that must be kept intact until the destruction of the class.
boolean com.sparsity.sparksee.algorithms.CommunityDetection.IsClosed ( )
inherited

Gets if CommunityDetection instance has been closed or not.

See Also
Close()
Returns
TRUE if the CommunityDetection instance has been closed, FALSE otherwise.
void com.sparsity.sparksee.algorithms.CommunitiesSCD.SetLookAhead ( int lookahead )

Sets the size of the lookahead iterations to look (5 by default).

Parameters
lookahead [in] Number of iterations. It must be positive or zero.
void com.sparsity.sparksee.algorithms.CommunitiesSCD.SetMaterializedAttribute ( System.String attributeName )

Creates a new common attribute type for all node types in the graph in order to store, persistently, the results related to the disjoint communities found while executing this algorithm.

Whenever the user wants to retrieve the results, even when the graph has been closed and opened again, it is only necessary to create a new instance of the class DisjointCommunities indicating the graph and the name of the common attribute type which stores the results. This instance will have all the information related to the disjoint communities found in the moment of the execution of the algorithm that stored this data.

It is possible to run the algorithm without specifying this parameter in order to avoid materializing the results of the execution.

Parameters
attributeName [in] The name of the common attribute type for all node types in the graph which will store persistently the results generated by the execution of the algorithm.


SparkseeNet: Member List

  • sparsity
  • sparksee
  • algorithms
  • CommunitiesSCD
com.sparsity.sparksee.algorithms.CommunitiesSCD Member List

This is the complete list of members for com.sparsity.sparksee.algorithms.CommunitiesSCD, including all inherited members.

AddAllEdgeTypes() | com.sparsity.sparksee.algorithms.CommunitiesSCD
AddAllNodeTypes() | com.sparsity.sparksee.algorithms.CommunitiesSCD
AddEdgeType(int type) | com.sparsity.sparksee.algorithms.CommunitiesSCD
AddNodeType(int type) | com.sparsity.sparksee.algorithms.CommunitiesSCD
Close() | com.sparsity.sparksee.algorithms.CommunityDetection
CommunitiesSCD(com.sparsity.sparksee.gdb.Session session) | com.sparsity.sparksee.algorithms.CommunitiesSCD
ExcludeEdges(com.sparsity.sparksee.gdb.Objects edges) | com.sparsity.sparksee.algorithms.CommunitiesSCD
ExcludeNodes(com.sparsity.sparksee.gdb.Objects nodes) | com.sparsity.sparksee.algorithms.CommunitiesSCD
GetCommunities() | com.sparsity.sparksee.algorithms.CommunitiesSCD
IncludeEdges(com.sparsity.sparksee.gdb.Objects edges) | com.sparsity.sparksee.algorithms.CommunitiesSCD
IncludeNodes(com.sparsity.sparksee.gdb.Objects nodes) | com.sparsity.sparksee.algorithms.CommunitiesSCD
IsClosed() | com.sparsity.sparksee.algorithms.CommunityDetection
Run() | com.sparsity.sparksee.algorithms.CommunitiesSCD
SetLookAhead(int lookahead) | com.sparsity.sparksee.algorithms.CommunitiesSCD
SetMaterializedAttribute(System.String attributeName) | com.sparsity.sparksee.algorithms.CommunitiesSCD


SparkseeNet: com.sparsity.sparksee.algorithms.CommunityDetection Class Reference

  • algorithms
  • CommunityDetection
Public Member Functions | List of all members
com.sparsity.sparksee.algorithms.CommunityDetection Class Reference

CommunityDetection class. More...

Inheritance diagram for com.sparsity.sparksee.algorithms.CommunityDetection:

Public Member Functions

boolean | IsClosed ()
Gets if CommunityDetection instance has been closed or not.
void | IncludeNodes (com.sparsity.sparksee.gdb.Objects nodes)
Set additional nodes that can be used.
void | AddNodeType (int type)
Allows connectivity through nodes of the given type.
void | AddAllNodeTypes ()
Allows connectivity through all node types of the graph.
void | Close ()
Closes the CommunityDetection instance.
void | IncludeEdges (com.sparsity.sparksee.gdb.Objects edges)
Set additional edges that can be used.
void | Run ()
Runs the algorithm in order to find the connected components.
void | ExcludeNodes (com.sparsity.sparksee.gdb.Objects nodes)
Set which nodes can't be used.
void | ExcludeEdges (com.sparsity.sparksee.gdb.Objects edges)
Set which edges can't be used.

Detailed Description

CommunityDetection class.

Any class implementing this abstract class can be used to solve a problem related to graph connectivity as finding the strongly connected components, finding the weakly connected components.

Check out the 'Algorithms' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

void com.sparsity.sparksee.algorithms.CommunityDetection.AddNodeType ( int type )

Allows connectivity through nodes of the given type.

Parameters
type null
void com.sparsity.sparksee.algorithms.CommunityDetection.Close ( )

Closes the CommunityDetection instance.

It must be called to ensure the integrity of all data.

void com.sparsity.sparksee.algorithms.CommunityDetection.ExcludeEdges ( com.sparsity.sparksee.gdb.Objects edges )

Set which edges can't be used.

This will replace any previously specified set of excluded edges. Should only be used to exclude the usage of specific edges from allowed edge types because it's less efficient than not allowing an edge type.

Parameters
edges [in] A set of edge identifiers that must be kept intact until the destruction of the class.
void com.sparsity.sparksee.algorithms.CommunityDetection.ExcludeNodes ( com.sparsity.sparksee.gdb.Objects nodes )

Set which nodes can't be used.

This will replace any previously specified set of excluded nodes. Should only be used to exclude the usage of specific nodes from allowed node types because it's less efficient than not allowing a node type.

Parameters
nodes [in] A set of node identifiers that must be kept intact until the destruction of the class.
void com.sparsity.sparksee.algorithms.CommunityDetection.IncludeEdges ( com.sparsity.sparksee.gdb.Objects edges )

Set additional edges that can be used.

This will replace any previously specified set of include edges. Using this optional method adds valid edges to the edges of any edge type explicitly set as a valid type. Should only be used to include specific small sets of edges because it's less efficient than just using an edge type. For any edge to be used, both nodes must be also valid.

Parameters
edges [in] A set of edge identifiers that must be kept intact until the destruction of the class.
void com.sparsity.sparksee.algorithms.CommunityDetection.IncludeNodes ( com.sparsity.sparksee.gdb.Objects nodes )

Set additional nodes that can be used.

This will replace any previously specified set of include nodes. Using this optional method adds valid nodes to the nodes of any node type explicitly set as a valid type. Should only be used to include specific small sets of nodes because it's less efficient than just using a node type.

Parameters
nodes [in] A set of node identifiers that must be kept intact until the destruction of the class.
boolean com.sparsity.sparksee.algorithms.CommunityDetection.IsClosed ( )

Gets if CommunityDetection instance has been closed or not.

See Also
Close()
Returns
TRUE if the CommunityDetection instance has been closed, FALSE otherwise.
void com.sparsity.sparksee.algorithms.CommunityDetection.Run ( )

Runs the algorithm in order to find the connected components.

This method can be called only once.


SparkseeNet: Member List

  • algorithms
  • CommunityDetection
com.sparsity.sparksee.algorithms.CommunityDetection Member List

This is the complete list of members for com.sparsity.sparksee.algorithms.CommunityDetection, including all inherited members.

AddAllNodeTypes() | com.sparsity.sparksee.algorithms.CommunityDetection
AddNodeType(int type) | com.sparsity.sparksee.algorithms.CommunityDetection
Close() | com.sparsity.sparksee.algorithms.CommunityDetection
ExcludeEdges(com.sparsity.sparksee.gdb.Objects edges) | com.sparsity.sparksee.algorithms.CommunityDetection
ExcludeNodes(com.sparsity.sparksee.gdb.Objects nodes) | com.sparsity.sparksee.algorithms.CommunityDetection
IncludeEdges(com.sparsity.sparksee.gdb.Objects edges) | com.sparsity.sparksee.algorithms.CommunityDetection
IncludeNodes(com.sparsity.sparksee.gdb.Objects nodes) | com.sparsity.sparksee.algorithms.CommunityDetection
IsClosed() | com.sparsity.sparksee.algorithms.CommunityDetection
Run() | com.sparsity.sparksee.algorithms.CommunityDetection


SparkseeNet: com.sparsity.sparksee.algorithms.ConnectedComponents Class Reference

  • algorithms
  • ConnectedComponents
Public Member Functions | List of all members
com.sparsity.sparksee.algorithms.ConnectedComponents Class Reference

ConnectedComponents class. More...

Public Member Functions

boolean | IsClosed ()
Gets if ConnectedComponents instance has been closed or not.
ConnectedComponents (com.sparsity.sparksee.gdb.Session s, System.String materializedattribute)
Creates a new instance of ConnectedComponents.
long | GetSize (long idConnectedComponent)
Returns the number of nodes contained in the given connected component.
void | Close ()
Closes the ConnectedComponents instance.
long | GetCount ()
Returns the number of connected components found in the graph.
long | GetConnectedComponent (long idNode)
Returns the connected component where the given node belongs to.
com.sparsity.sparksee.gdb.Objects | GetNodes (long idConnectedComponent)
Returns the collection of nodes contained in the given connected component.

Detailed Description

ConnectedComponents class.

This class contains the results processed on a Connectivity algorithm.

These results contain information related to the connected components found. We must consider that each connected component has a number in order to identify it. These number identifiers are values from 0 to N-1, where N is the number of different connected components found.

When executing any implementation of the Connectivity, it is possible to indicate whether the results of the execution must be stored persistently using the class Connectivity setMaterializedAttribute method. In case the results are set to be materialized, users can retrieve this data whenever they want, even if the graph has been closed and opened again, just by creating a new instance of this class.

Check out the 'Algorithms' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

com.sparsity.sparksee.algorithms.ConnectedComponents.ConnectedComponents | ( | com.sparsity.sparksee.gdb.Session | s,
 |  | System.String | materializedattribute
 | ) |  |

Creates a new instance of ConnectedComponents.

This constructor method can only be called when a previous execution of any implementation of the Connectivity class has materialized the results in a common attribute type for all the nodes in the graph. For further information about materializing the results processed on any Connectivity execution see the documentation of the Connectivity::SetMaterializedAttribute method.

Parameters
s | [in] Session to get the graph Graph on which the information will be retrieved just by getting the values contained in the given common attribute type for all the nodes in the graph and processing them.
materializedattribute | [in] The common attribute type for all the nodes in the graph where data will be retrieved in order to process the results related to the connected components found in the graph.

Member Function Documentation

void com.sparsity.sparksee.algorithms.ConnectedComponents.Close ( )

Closes the ConnectedComponents instance.

It must be called to ensure the integrity of all data.

long com.sparsity.sparksee.algorithms.ConnectedComponents.GetConnectedComponent ( long idNode )

Returns the connected component where the given node belongs to.

Parameters
idNode [in] The node identifier for which the connected component identifier where it belongs will be returned.
Returns
The connected component identifier where the given node identifier belongs to.
long com.sparsity.sparksee.algorithms.ConnectedComponents.GetCount ( )

Returns the number of connected components found in the graph.

Returns
The number of connected components found in the graph.
com.sparsity.sparksee.gdb.Objects com.sparsity.sparksee.algorithms.ConnectedComponents.GetNodes ( long idConnectedComponent )

Returns the collection of nodes contained in the given connected component.

Parameters
idConnectedComponent The connected component for which the collection of nodes contained in it will be returned.
Returns
The collection of node identifiers contained in the given connected component.
long com.sparsity.sparksee.algorithms.ConnectedComponents.GetSize ( long idConnectedComponent )

Returns the number of nodes contained in the given connected component.

Parameters
idConnectedComponent The connected component for which the number of nodes contained in it will be returned.
Returns
The number of nodes contained in the given connected component.
boolean com.sparsity.sparksee.algorithms.ConnectedComponents.IsClosed ( )

Gets if ConnectedComponents instance has been closed or not.

See Also
Close()
Returns
TRUE if the ConnectedComponents instance has been closed, FALSE otherwise.


SparkseeNet: Member List

  • algorithms
  • ConnectedComponents
com.sparsity.sparksee.algorithms.ConnectedComponents Member List

This is the complete list of members for com.sparsity.sparksee.algorithms.ConnectedComponents, including all inherited members.

Close() | com.sparsity.sparksee.algorithms.ConnectedComponents
ConnectedComponents(com.sparsity.sparksee.gdb.Session s, System.String materializedattribute) | com.sparsity.sparksee.algorithms.ConnectedComponents
GetConnectedComponent(long idNode) | com.sparsity.sparksee.algorithms.ConnectedComponents
GetCount() | com.sparsity.sparksee.algorithms.ConnectedComponents
GetNodes(long idConnectedComponent) | com.sparsity.sparksee.algorithms.ConnectedComponents
GetSize(long idConnectedComponent) | com.sparsity.sparksee.algorithms.ConnectedComponents
IsClosed() | com.sparsity.sparksee.algorithms.ConnectedComponents


SparkseeNet: com.sparsity.sparksee.algorithms.Connectivity Class Reference

  • algorithms
  • Connectivity
Public Member Functions | List of all members
com.sparsity.sparksee.algorithms.Connectivity Class Reference

Connectivity class. More...

Inheritance diagram for com.sparsity.sparksee.algorithms.Connectivity:

Public Member Functions

boolean | IsClosed ()
Gets if Connectivity instance has been closed or not.
void | AddAllNodeTypes ()
Allows connectivity through all node types of the graph.
void | Close ()
Closes the Connectivity instance.
void | Run ()
Runs the algorithm in order to find the connected components.
void | ExcludeNodes (com.sparsity.sparksee.gdb.Objects nodes)
Set which nodes can't be used.
void | AddNodeType (int t)
Allows connectivity through nodes of the given type.
void | SetMaterializedAttribute (System.String attributeName)
Creates a new common attribute type for all node types in the graph in order to store, persistently, the results related to the connected components found while executing this algorithm.
void | ExcludeEdges (com.sparsity.sparksee.gdb.Objects edges)
Set which edges can't be used.
com.sparsity.sparksee.algorithms.ConnectedComponents GetConnectedComponents ()
Returns the results generated by the execution of the algorithm.

Detailed Description

Connectivity class.

Any class implementing this abstract class can be used to solve a problem related to graph connectivity as finding the strongly connected components, finding the weakly connected components.

Check out the 'Algorithms' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

void com.sparsity.sparksee.algorithms.Connectivity.AddNodeType ( int t )

Allows connectivity through nodes of the given type.

Parameters
t null
void com.sparsity.sparksee.algorithms.Connectivity.Close ( )

Closes the Connectivity instance.

It must be called to ensure the integrity of all data.

void com.sparsity.sparksee.algorithms.Connectivity.ExcludeEdges ( com.sparsity.sparksee.gdb.Objects edges )

Set which edges can't be used.

This will replace any previously specified set of excluded edges. Should only be used to exclude the usage of specific edges from allowed edge types because it's less efficient than not allowing an edge type.

Parameters
edges [in] A set of edge identifiers that must be kept intact until the destruction of the class.
void com.sparsity.sparksee.algorithms.Connectivity.ExcludeNodes ( com.sparsity.sparksee.gdb.Objects nodes )

Set which nodes can't be used.

This will replace any previously specified set of excluded nodes. Should only be used to exclude the usage of specific nodes from allowed node types because it's less efficient than not allowing a node type.

Parameters
nodes [in] A set of node identifiers that must be kept intact until the destruction of the class.
com.sparsity.sparksee.algorithms.ConnectedComponents com.sparsity.sparksee.algorithms.Connectivity.GetConnectedComponents ( )

Returns the results generated by the execution of the algorithm.

These results contain information related to the connected components found as the number of different components, the set of nodes contained in each component or many other data.

Returns
Returns an instance of the class ConnectedComponents which contain information related to the connected components found.
boolean com.sparsity.sparksee.algorithms.Connectivity.IsClosed ( )

Gets if Connectivity instance has been closed or not.

See Also
Close()
Returns
TRUE if the Connectivity instance has been closed, FALSE otherwise.
void com.sparsity.sparksee.algorithms.Connectivity.Run ( )

Runs the algorithm in order to find the connected components.

This method can be called only once.

void com.sparsity.sparksee.algorithms.Connectivity.SetMaterializedAttribute ( System.String attributeName )

Creates a new common attribute type for all node types in the graph in order to store, persistently, the results related to the connected components found while executing this algorithm.

Whenever the user wants to retrieve the results, even when the graph has been closed and opened again, it is only necessary to create a new instance of the class ConnectedComponents indicating the graph and the name of the common attribute type which stores the results. This instance will have all the information related to the connected components found in the moment of the execution of the algorithm that stored this data.

It is possible to run the algorithm without specifying this parameter in order to avoid materializing the results of the execution.

Parameters
attributeName [in] The name of the common attribute type for all node types in the graph which will store persistently the results generated by the execution of the algorithm.


SparkseeNet: Member List

  • algorithms
  • Connectivity
com.sparsity.sparksee.algorithms.Connectivity Member List

This is the complete list of members for com.sparsity.sparksee.algorithms.Connectivity, including all inherited members.

AddAllNodeTypes() | com.sparsity.sparksee.algorithms.Connectivity
AddNodeType(int t) | com.sparsity.sparksee.algorithms.Connectivity
Close() | com.sparsity.sparksee.algorithms.Connectivity
ExcludeEdges(com.sparsity.sparksee.gdb.Objects edges) | com.sparsity.sparksee.algorithms.Connectivity
ExcludeNodes(com.sparsity.sparksee.gdb.Objects nodes) | com.sparsity.sparksee.algorithms.Connectivity
GetConnectedComponents() | com.sparsity.sparksee.algorithms.Connectivity
IsClosed() | com.sparsity.sparksee.algorithms.Connectivity
Run() | com.sparsity.sparksee.algorithms.Connectivity
SetMaterializedAttribute(System.String attributeName) | com.sparsity.sparksee.algorithms.Connectivity


SparkseeNet: com.sparsity.sparksee.algorithms.Context Class Reference

  • algorithms
  • Context
Public Member Functions | Static Public Member Functions | List of all members
com.sparsity.sparksee.algorithms.Context Class Reference

Context class. More...

Public Member Functions

void | AddEdgeType (int t, com.sparsity.sparksee.gdb.EdgesDirection d)
Allows for traversing edges of the given type.
void | ExcludeNodes (com.sparsity.sparksee.gdb.Objects nodes)
Set which nodes can't be used.
com.sparsity.sparksee.gdb.Objects Compute ()
Gets the resulting collection of nodes.
void | AddAllEdgeTypes (com.sparsity.sparksee.gdb.EdgesDirection d)
Allows for traversing all edge types of the graph.
void | AddNodeType (int t)
Allows for traversing nodes of the given type.
boolean | IsClosed ()
Gets if Context instance has been closed or not.
Context (com.sparsity.sparksee.gdb.Session session, long node)
Creates a new instance.
void | AddAllNodeTypes ()
Allows for traversing all node types of the graph.
void | Close ()
Closes the Context instance.
void | SetMaximumHops (int maxhops, bool include)
Sets the maximum hops restriction.
void | ExcludeEdges (com.sparsity.sparksee.gdb.Objects edges)
Set which edges can't be used.

Static Public Member Functions

static
com.sparsity.sparksee.gdb.Objects 		Compute (com.sparsity.sparksee.gdb.Session session, long node, com.sparsity.sparksee.gdb.TypeList nodeTypes, com.sparsity.sparksee.gdb.TypeList edgeTypes, com.sparsity.sparksee.gdb.EdgesDirection dir, int maxhops, bool include)
Helper method to easily compute a context from a node.

Detailed Description

Context class.

It provides a very similar functionality than the Traversal classes. The main difference is Context returns a resulting collection whereas Traversal provides an iterator behaviour.

Check out the 'Algorithms' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

com.sparsity.sparksee.algorithms.Context.Context | ( | com.sparsity.sparksee.gdb.Session | session,
 |  | long | node
 | ) |  |

Creates a new instance.

Parameters
session | [in] Session to get the graph from and perform operation.
node | [in] Node to start traversal from.

Member Function Documentation

void com.sparsity.sparksee.algorithms.Context.AddAllEdgeTypes ( com.sparsity.sparksee.gdb.EdgesDirection d )

Allows for traversing all edge types of the graph.

Parameters
d [in] Edge direction.
void com.sparsity.sparksee.algorithms.Context.AddEdgeType | ( | int | t,
 |  | com.sparsity.sparksee.gdb.EdgesDirection | d
 | ) |  |

Allows for traversing edges of the given type.

Parameters
t | [in] Edge type.
d | [in] Edge direction.
void com.sparsity.sparksee.algorithms.Context.AddNodeType ( int t )

Allows for traversing nodes of the given type.

Parameters
t null
void com.sparsity.sparksee.algorithms.Context.Close ( )

Closes the Context instance.

It must be called to ensure the integrity of all data.

static com.sparsity.sparksee.gdb.Objects com.sparsity.sparksee.algorithms.Context.Compute | ( | com.sparsity.sparksee.gdb.Session | session,
 |  | long | node,
 |  | com.sparsity.sparksee.gdb.TypeList | nodeTypes,
 |  | com.sparsity.sparksee.gdb.TypeList | edgeTypes,
 |  | com.sparsity.sparksee.gdb.EdgesDirection | dir,
 |  | int | maxhops,
 |  | bool | include
 | ) |  |
static

Helper method to easily compute a context from a node.

Parameters
session | [in] Session to get the graph from and perform operation.
node | [in] Node to start traversal from.
nodeTypes | [in] Allowed node type list. NULL means all node types are allowed.
edgeTypes | [in] Allowed edge type list. NULL means all edge types are allowed.
dir | [in] Allowed direction for the allowed edge types.
maxhops | [in] The maximum hops restriction. It must be positive or zero. Zero, the default value, means unlimited.
include | [in] If TRUE, the resulting collection will include those nodes at distance less or equal than the given one, otherwise it will just include those nodes at distance equal than the given one. This parameter just makes sense if maxhops is different from 0; in that case it includes all nodes no matters the distance.
Returns
Returns an Objects with the computed context of a node.
com.sparsity.sparksee.gdb.Objects com.sparsity.sparksee.algorithms.Context.Compute ( )

Gets the resulting collection of nodes.

Returns
The resulting collection of nodes.
void com.sparsity.sparksee.algorithms.Context.ExcludeEdges ( com.sparsity.sparksee.gdb.Objects edges )

Set which edges can't be used.

This will replace any previously specified set of excluded edges. Should only be used to exclude the usage of specific edges from allowed edge types because it's less efficient than not allowing an edge type.

Parameters
edges [in] A set of edge identifiers that must be kept intact until the destruction of the class.
void com.sparsity.sparksee.algorithms.Context.ExcludeNodes ( com.sparsity.sparksee.gdb.Objects nodes )

Set which nodes can't be used.

This will replace any previously specified set of excluded nodes. Should only be used to exclude the usage of specific nodes from allowed node types because it's less efficient than not allowing a node type.

Parameters
nodes [in] A set of node identifiers that must be kept intact until the destruction of the class.
boolean com.sparsity.sparksee.algorithms.Context.IsClosed ( )

Gets if Context instance has been closed or not.

See Also
Close()
Returns
TRUE if the Context instance has been closed, FALSE otherwise.
void com.sparsity.sparksee.algorithms.Context.SetMaximumHops | ( | int | maxhops,
 |  | bool | include
 | ) |  |

Sets the maximum hops restriction.

All paths longer than the maximum hops restriction will be ignored.

Parameters
maxhops | [in] The maximum hops restriction. It must be positive or zero. Zero, the default value, means unlimited.
include | [in] If TRUE, the resulting collection will include those nodes at distance less or equal than the given one, otherwise it will just include those nodes at distance equal than the given one. This parameter just makes sense if maxhops is different from 0; in that case it includes all nodes no matters the distance.


SparkseeNet: Member List

  • algorithms
  • Context
com.sparsity.sparksee.algorithms.Context Member List

This is the complete list of members for com.sparsity.sparksee.algorithms.Context, including all inherited members.

AddAllEdgeTypes(com.sparsity.sparksee.gdb.EdgesDirection d) | com.sparsity.sparksee.algorithms.Context |
AddAllNodeTypes() | com.sparsity.sparksee.algorithms.Context |
AddEdgeType(int t, com.sparsity.sparksee.gdb.EdgesDirection d) | com.sparsity.sparksee.algorithms.Context |
AddNodeType(int t) | com.sparsity.sparksee.algorithms.Context |
Close() | com.sparsity.sparksee.algorithms.Context |
Compute(com.sparsity.sparksee.gdb.Session session, long node, com.sparsity.sparksee.gdb.TypeList nodeTypes, com.sparsity.sparksee.gdb.TypeList edgeTypes, com.sparsity.sparksee.gdb.EdgesDirection dir, int maxhops, bool include) | com.sparsity.sparksee.algorithms.Context | static
Compute() | com.sparsity.sparksee.algorithms.Context |
Context(com.sparsity.sparksee.gdb.Session session, long node) | com.sparsity.sparksee.algorithms.Context |
ExcludeEdges(com.sparsity.sparksee.gdb.Objects edges) | com.sparsity.sparksee.algorithms.Context |
ExcludeNodes(com.sparsity.sparksee.gdb.Objects nodes) | com.sparsity.sparksee.algorithms.Context |
IsClosed() | com.sparsity.sparksee.algorithms.Context |
SetMaximumHops(int maxhops, bool include) | com.sparsity.sparksee.algorithms.Context |


SparkseeNet: com.sparsity.sparksee.algorithms.DisjointCommunities Class Reference

  • algorithms
  • DisjointCommunities
Public Member Functions | List of all members
com.sparsity.sparksee.algorithms.DisjointCommunities Class Reference

DisjointCommunities class. More...

Public Member Functions

boolean | IsClosed ()
Gets if DisjointCommunities instance has been closed or not.
DisjointCommunities (com.sparsity.sparksee.gdb.Session session, System.String materializedattribute)
Creates a new instance of DisjointCommunities.
void | Close ()
Closes the DisjointCommunities instance.
long | GetSize (long idCommunity)
Returns the number of nodes contained in the given community.
long | GetCount ()
Returns the number of communities found in the graph.
com.sparsity.sparksee.gdb.Objects | GetNodes (long idCommunity)
Returns the collection of nodes contained in the given community.
long | GetCommunity (long idNode)
Returns the disjoint community where the given node belongs to.

Detailed Description

DisjointCommunities class.

This class contains the results processed on a DisjointCommunityDetection algorithm.

These results contain information related to the communities found. We must consider that each community has a number in order to identify it. These number identifiers are values from 0 to N-1, where N is the number of different communities found.

When executing any implementation of the DisjointCommunityDetection, it is possible to indicate whether the results of the execution must be stored persistently using the class DisjointCommunityDetection setMaterializedAttribute method. In case the results are set to be materialized, users can retrieve this data whenever they want, even if the graph has been closed and opened again, just by creating a new instance of this class.

Check out the 'Algorithms' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

com.sparsity.sparksee.algorithms.DisjointCommunities.DisjointCommunities | ( | com.sparsity.sparksee.gdb.Session | session,
 |  | System.String | materializedattribute
 | ) |  |

Creates a new instance of DisjointCommunities.

This constructor method can only be called when a previous execution of any implementation of the DisjointCommunityDetection class has materialized the results in a common attribute type for all the nodes in the graph. For further information about materializing the results processed on any DisjointCommunityDetection execution see the documentation of the DisjointCommunityDetection::SetMaterializedAttribute method.

Parameters
session | [in] Session to get the graph Graph on which the information will be retrieved just by getting the values contained in the given common attribute type for all the nodes in the graph and processing them.
materializedattribute | [in] The common attribute type for all the nodes in the graph where data will be retrieved in order to process the results related to the communities found in the graph.

Member Function Documentation

void com.sparsity.sparksee.algorithms.DisjointCommunities.Close ( )

Closes the DisjointCommunities instance.

It must be called to ensure the integrity of all data.

long com.sparsity.sparksee.algorithms.DisjointCommunities.GetCommunity ( long idNode )

Returns the disjoint community where the given node belongs to.

Parameters
idNode [in] The node identifier for which the disjoint community identifier where it belongs will be returned.
Returns
The disjoint community identifier where the given node identifier belongs to.
long com.sparsity.sparksee.algorithms.DisjointCommunities.GetCount ( )

Returns the number of communities found in the graph.

Returns
The number of communities found in the graph.
com.sparsity.sparksee.gdb.Objects com.sparsity.sparksee.algorithms.DisjointCommunities.GetNodes ( long idCommunity )

Returns the collection of nodes contained in the given community.

Parameters
idCommunity The community for which the collection of nodes contained in it will be returned.
Returns
The collection of node identifiers contained in the given community.
long com.sparsity.sparksee.algorithms.DisjointCommunities.GetSize ( long idCommunity )

Returns the number of nodes contained in the given community.

Parameters
idCommunity The community for which the number of nodes contained in it will be returned.
Returns
The number of nodes contained in the given community.
boolean com.sparsity.sparksee.algorithms.DisjointCommunities.IsClosed ( )

Gets if DisjointCommunities instance has been closed or not.

See Also
Close()
Returns
TRUE if the DisjointCommunities instance has been closed, FALSE otherwise.


SparkseeNet: Member List

  • algorithms
  • DisjointCommunities
com.sparsity.sparksee.algorithms.DisjointCommunities Member List

This is the complete list of members for com.sparsity.sparksee.algorithms.DisjointCommunities, including all inherited members.

Close() | com.sparsity.sparksee.algorithms.DisjointCommunities
DisjointCommunities(com.sparsity.sparksee.gdb.Session session, System.String materializedattribute) | com.sparsity.sparksee.algorithms.DisjointCommunities
GetCommunity(long idNode) | com.sparsity.sparksee.algorithms.DisjointCommunities
GetCount() | com.sparsity.sparksee.algorithms.DisjointCommunities
GetNodes(long idCommunity) | com.sparsity.sparksee.algorithms.DisjointCommunities
GetSize(long idCommunity) | com.sparsity.sparksee.algorithms.DisjointCommunities
IsClosed() | com.sparsity.sparksee.algorithms.DisjointCommunities


SparkseeNet: com.sparsity.sparksee.algorithms.DisjointCommunityDetection Class Reference

  • algorithms
  • DisjointCommunityDetection
Public Member Functions | List of all members
com.sparsity.sparksee.algorithms.DisjointCommunityDetection Class Reference

DisjointCommunityDetection class. More...

Inheritance diagram for com.sparsity.sparksee.algorithms.DisjointCommunityDetection:
Collaboration diagram for com.sparsity.sparksee.algorithms.DisjointCommunityDetection:

Public Member Functions

void | IncludeNodes (com.sparsity.sparksee.gdb.Objects nodes)
Set additional nodes that can be used.
void | AddNodeType (int type)
Allows connectivity through nodes of the given type.
void | AddEdgeType (int type)
Allows connectivity through edges of the given type.
void | AddAllNodeTypes ()
Allows connectivity through all node types of the graph.
void | AddAllEdgeTypes ()
Allows connectivity through all edge types of the graph.
void | IncludeEdges (com.sparsity.sparksee.gdb.Objects edges)
Set additional edges that can be used.
void | ExcludeNodes (com.sparsity.sparksee.gdb.Objects nodes)
Set which nodes can't be used.
void | Run ()
Runs the algorithm in order to find the communities.
void | SetMaterializedAttribute (System.String attributeName)
Creates a new common attribute type for all node types in the graph in order to store, persistently, the results related to the disjoint communities found while executing this algorithm.
com.sparsity.sparksee.algorithms.DisjointCommunities GetCommunities ()
Returns the results generated by the execution of the algorithm.
void | ExcludeEdges (com.sparsity.sparksee.gdb.Objects edges)
Set which edges can't be used.
boolean | IsClosed ()
Gets if CommunityDetection instance has been closed or not.
void | Close ()
Closes the CommunityDetection instance.

Detailed Description

DisjointCommunityDetection class.

Any class implementing this abstract class can be used to solve a problem related to graph connectivity as finding the strongly connected components, finding the weakly connected components.

Check out the 'Algorithms' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

void com.sparsity.sparksee.algorithms.DisjointCommunityDetection.AddAllEdgeTypes ( )

Allows connectivity through all edge types of the graph.

The edges can be used in Any direction.

void com.sparsity.sparksee.algorithms.DisjointCommunityDetection.AddEdgeType ( int type )

Allows connectivity through edges of the given type.

The edges can be used in Any direction.

Parameters
type [in] Edge type.
void com.sparsity.sparksee.algorithms.DisjointCommunityDetection.AddNodeType ( int type )

Allows connectivity through nodes of the given type.

Parameters
type null
void com.sparsity.sparksee.algorithms.CommunityDetection.Close ( )
inherited

Closes the CommunityDetection instance.

It must be called to ensure the integrity of all data.

void com.sparsity.sparksee.algorithms.DisjointCommunityDetection.ExcludeEdges ( com.sparsity.sparksee.gdb.Objects edges )

Set which edges can't be used.

This will replace any previously specified set of excluded edges. Should only be used to exclude the usage of specific edges from allowed edge types because it's less efficient than not allowing an edge type.

Parameters
edges [in] A set of edge identifiers that must be kept intact until the destruction of the class.
void com.sparsity.sparksee.algorithms.DisjointCommunityDetection.ExcludeNodes ( com.sparsity.sparksee.gdb.Objects nodes )

Set which nodes can't be used.

This will replace any previously specified set of excluded nodes. Should only be used to exclude the usage of specific nodes from allowed node types because it's less efficient than not allowing a node type.

Parameters
nodes [in] A set of node identifiers that must be kept intact until the destruction of the class.
com.sparsity.sparksee.algorithms.DisjointCommunities com.sparsity.sparksee.algorithms.DisjointCommunityDetection.GetCommunities ( )

Returns the results generated by the execution of the algorithm.

These results contain information related to the disjoint communities found as the number of different components, the set of nodes contained in each component or many other data.

Returns
Returns an instance of the class DisjointCommunities which contain information related to the disjoint communities found.
void com.sparsity.sparksee.algorithms.DisjointCommunityDetection.IncludeEdges ( com.sparsity.sparksee.gdb.Objects edges )

Set additional edges that can be used.

This will replace any previously specified set of include edges. Using this optional method adds valid edges to the edges of any edge type explicitly set as a valid type. Should only be used to include specific small sets of edges because it's less efficient than just using an edge type. For any edge to be used, both nodes must be also valid.

Parameters
edges [in] A set of edge identifiers that must be kept intact until the destruction of the class.
void com.sparsity.sparksee.algorithms.DisjointCommunityDetection.IncludeNodes ( com.sparsity.sparksee.gdb.Objects nodes )

Set additional nodes that can be used.

This will replace any previously specified set of include nodes. Using this optional method adds valid nodes to the nodes of any node type explicitly set as a valid type. Should only be used to include specific small sets of nodes because it's less efficient than just using a node type.

Parameters
nodes [in] A set of node identifiers that must be kept intact until the destruction of the class.
boolean com.sparsity.sparksee.algorithms.CommunityDetection.IsClosed ( )
inherited

Gets if CommunityDetection instance has been closed or not.

See Also
Close()
Returns
TRUE if the CommunityDetection instance has been closed, FALSE otherwise.
void com.sparsity.sparksee.algorithms.DisjointCommunityDetection.Run ( )

Runs the algorithm in order to find the communities.

This method can be called only once.

void com.sparsity.sparksee.algorithms.DisjointCommunityDetection.SetMaterializedAttribute ( System.String attributeName )

Creates a new common attribute type for all node types in the graph in order to store, persistently, the results related to the disjoint communities found while executing this algorithm.

Whenever the user wants to retrieve the results, even when the graph has been closed and opened again, it is only necessary to create a new instance of the class DisjointCommunities indicating the graph and the name of the common attribute type which stores the results. This instance will have all the information related to the disjoint communities found in the moment of the execution of the algorithm that stored this data.

It is possible to run the algorithm without specifying this parameter in order to avoid materializing the results of the execution.

Parameters
attributeName [in] The name of the common attribute type for all node types in the graph which will store persistently the results generated by the execution of the algorithm.


SparkseeNet: Member List

  • algorithms
  • DisjointCommunityDetection
com.sparsity.sparksee.algorithms.DisjointCommunityDetection Member List

This is the complete list of members for com.sparsity.sparksee.algorithms.DisjointCommunityDetection, including all inherited members.

AddAllEdgeTypes() | com.sparsity.sparksee.algorithms.DisjointCommunityDetection
AddAllNodeTypes() | com.sparsity.sparksee.algorithms.DisjointCommunityDetection
AddEdgeType(int type) | com.sparsity.sparksee.algorithms.DisjointCommunityDetection
AddNodeType(int type) | com.sparsity.sparksee.algorithms.DisjointCommunityDetection
Close() | com.sparsity.sparksee.algorithms.CommunityDetection
ExcludeEdges(com.sparsity.sparksee.gdb.Objects edges) | com.sparsity.sparksee.algorithms.DisjointCommunityDetection
ExcludeNodes(com.sparsity.sparksee.gdb.Objects nodes) | com.sparsity.sparksee.algorithms.DisjointCommunityDetection
GetCommunities() | com.sparsity.sparksee.algorithms.DisjointCommunityDetection
IncludeEdges(com.sparsity.sparksee.gdb.Objects edges) | com.sparsity.sparksee.algorithms.DisjointCommunityDetection
IncludeNodes(com.sparsity.sparksee.gdb.Objects nodes) | com.sparsity.sparksee.algorithms.DisjointCommunityDetection
IsClosed() | com.sparsity.sparksee.algorithms.CommunityDetection
Run() | com.sparsity.sparksee.algorithms.DisjointCommunityDetection
SetMaterializedAttribute(System.String attributeName) | com.sparsity.sparksee.algorithms.DisjointCommunityDetection


SparkseeNet: com.sparsity.sparksee.algorithms.KOpt Class Reference

  • algorithms
  • KOpt
Public Member Functions | List of all members
com.sparsity.sparksee.algorithms.KOpt Class Reference

KOpt class. More...

Public Member Functions

KOpt (com.sparsity.sparksee.gdb.Session session, com.sparsity.sparksee.gdb.OIDList tour)
Creates a new instance.
void | AddNodeType (int type) throws System.ApplicationException
Allows for traversing nodes of the given type.
com.sparsity.sparksee.gdb.OIDList GetCurrentTour ()
Returns tour as a list of nodes.
KOpt (com.sparsity.sparksee.gdb.Session session)
Creates a new instance.
void | SetTimeLimit (long maxTime)
Limits execution time.
void | RunTwoOpt ()
Runs 2-Opt local search.
void | AddAllEdgeTypes (com.sparsity.sparksee.gdb.EdgesDirection dir)
Allows for traversing all edge types of the graph.
void | RunThreeOpt ()
Runs 3-Opt local search.
boolean | IsClosed ()
Gets if KOpt instance has been closed or not.
void | AddAllNodeTypes ()
Allows for traversing all node types of the graph.
void | SetCurrentTour (com.sparsity.sparksee.gdb.OIDList tour)
Sets current tour as a list of nodes.
void | Close ()
Closes the KOpt instance.
void | AddEdgeType (int type, com.sparsity.sparksee.gdb.EdgesDirection dir) throws System.ApplicationException
Allows for traversing edges of the given type.
void | SetEdgeWeightAttributeType (int attr) throws System.ApplicationException
Sets the attribute to use as edge weight.
void | SetMaxIterations (long maxIterations)
Sets maximum number of iterations.
double | GetCurrentCost ()
Returns tour cost.

Detailed Description

KOpt class.

Implements the 2-Opt and 3-Opt algorithms

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

com.sparsity.sparksee.algorithms.KOpt.KOpt | ( | com.sparsity.sparksee.gdb.Session | session,
 |  | com.sparsity.sparksee.gdb.OIDList | tour
 | ) |  |

Creates a new instance.

Parameters
session | [in] Session to get the graph from and perform algorithm.
tour | [in] Initial tour that needs to be improved.
com.sparsity.sparksee.algorithms.KOpt.KOpt ( com.sparsity.sparksee.gdb.Session session )

Creates a new instance.

Parameters
session [in] Session to get the graph from and perform algorithm.

Member Function Documentation

void com.sparsity.sparksee.algorithms.KOpt.AddAllEdgeTypes ( com.sparsity.sparksee.gdb.EdgesDirection dir )

Allows for traversing all edge types of the graph.

Parameters
dir [in] Edge direction.
void com.sparsity.sparksee.algorithms.KOpt.AddEdgeType | ( | int | type,
 |  | com.sparsity.sparksee.gdb.EdgesDirection | dir
 | ) |  | throws System.ApplicationException

Allows for traversing edges of the given type.

If the edge type was already added, the existing direction is overwritten

Parameters
type | [in] Edge type.
dir | [in] Edge direction.
Exceptions
System.ApplicationException null
void com.sparsity.sparksee.algorithms.KOpt.AddNodeType ( int type ) throws System.ApplicationException

Allows for traversing nodes of the given type.

sparksee::gdb::Error

Parameters
type [in] Node type.
Exceptions
System.ApplicationException null
void com.sparsity.sparksee.algorithms.KOpt.Close ( )

Closes the KOpt instance.

It must be called to ensure the integrity of all data.

boolean com.sparsity.sparksee.algorithms.KOpt.IsClosed ( )

Gets if KOpt instance has been closed or not.

See Also
Close()
Returns
TRUE if the KOpt instance has been closed, FALSE otherwise.
void com.sparsity.sparksee.algorithms.KOpt.SetCurrentTour ( com.sparsity.sparksee.gdb.OIDList tour )

Sets current tour as a list of nodes.

Parameters
tour [in] Initial tour that needs to be improved.
void com.sparsity.sparksee.algorithms.KOpt.SetEdgeWeightAttributeType ( int attr ) throws System.ApplicationException

Sets the attribute to use as edge weight.

If the multiple edge are set for traversal, this attribute must be of type GLOBAL_TYPE or EDGES_TYPE. Additionally, the attribute must be of type Double.

sparksee::gdb::Error

Parameters
attr [in] The attribute type to use as a weight. Default: InvalidAttribute
Exceptions
System.ApplicationException null
void com.sparsity.sparksee.algorithms.KOpt.SetMaxIterations ( long maxIterations )

Sets maximum number of iterations.

By default the algorithm will run until no improvement can be made in the current tour.

Parameters
maxIterations [in] Maximum number of iterations
void com.sparsity.sparksee.algorithms.KOpt.SetTimeLimit ( long maxTime )

Limits execution time.

Parameters
maxTime [in] Time limit in miliseconds


SparkseeNet: Member List

  • algorithms
  • KOpt
com.sparsity.sparksee.algorithms.KOpt Member List

This is the complete list of members for com.sparsity.sparksee.algorithms.KOpt, including all inherited members.

AddAllEdgeTypes(com.sparsity.sparksee.gdb.EdgesDirection dir) | com.sparsity.sparksee.algorithms.KOpt
AddAllNodeTypes() | com.sparsity.sparksee.algorithms.KOpt
AddEdgeType(int type, com.sparsity.sparksee.gdb.EdgesDirection dir) | com.sparsity.sparksee.algorithms.KOpt
AddNodeType(int type) | com.sparsity.sparksee.algorithms.KOpt
Close() | com.sparsity.sparksee.algorithms.KOpt
GetCurrentCost() | com.sparsity.sparksee.algorithms.KOpt
GetCurrentTour() | com.sparsity.sparksee.algorithms.KOpt
IsClosed() | com.sparsity.sparksee.algorithms.KOpt
KOpt(com.sparsity.sparksee.gdb.Session session, com.sparsity.sparksee.gdb.OIDList tour) | com.sparsity.sparksee.algorithms.KOpt
KOpt(com.sparsity.sparksee.gdb.Session session) | com.sparsity.sparksee.algorithms.KOpt
RunThreeOpt() | com.sparsity.sparksee.algorithms.KOpt
RunTwoOpt() | com.sparsity.sparksee.algorithms.KOpt
SetCurrentTour(com.sparsity.sparksee.gdb.OIDList tour) | com.sparsity.sparksee.algorithms.KOpt
SetEdgeWeightAttributeType(int attr) | com.sparsity.sparksee.algorithms.KOpt
SetMaxIterations(long maxIterations) | com.sparsity.sparksee.algorithms.KOpt
SetTimeLimit(long maxTime) | com.sparsity.sparksee.algorithms.KOpt


SparkseeNet: com.sparsity.sparksee.algorithms.PageRank Class Reference

  • algorithms
  • PageRank
Public Member Functions | List of all members
com.sparsity.sparksee.algorithms.PageRank Class Reference

PageRank class. More...

Public Member Functions

void | AddNodeType (int type) throws System.ApplicationException
Allows for traversing nodes of the given type.
void | SetStartingNode (long startNode) throws System.ApplicationException
Sets the starting node of the page rank to compute the Personalized PageRank variant.
PageRank (com.sparsity.sparksee.gdb.Session session)
Builds the PageRank.
void | SetTolerance (double tolerance)
Sets the tolerance threashold to continue computing the PageRank after each iteration.
void | SetDefaultWeight (double weight)
Sets the default weight for those cases when a given edge does not have a weight attribute set.
void | AddAllEdgeTypes (com.sparsity.sparksee.gdb.EdgesDirection dir)
Allows for traversing all edge types of the graph.
void | SetInitialPageRankValue (double startValue)
Sets the initial PageRank value.
boolean | IsClosed ()
Gets if PageRank instance has been closed or not.
void | AddAllNodeTypes ()
Allows for traversing all node types of the graph.
void | Close ()
Closes the PageRank instance.
void | AddEdgeType (int type, com.sparsity.sparksee.gdb.EdgesDirection dir) throws System.ApplicationException
Allows for traversing edges of the given type.
void | SetNumIterations (int numIterations)
Sets the number of iterations to run the PageRank for.
void | SetEdgeWeightAttributeType (int attr) throws System.ApplicationException
Sets the attribute to use as edge weight.
void | Run () throws System.ApplicationException
Runs the algorithm.
void | SetDamping (double damping)
Sets the damping value for the PageRank.
void | SetOutputAttributeType (int attr) throws System.ApplicationException
Sets the output attribute type.

Detailed Description

PageRank class.

Implements the PageRank algorithm

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

com.sparsity.sparksee.algorithms.PageRank.PageRank ( com.sparsity.sparksee.gdb.Session session )

Builds the PageRank.

Parameters
session [in] The session to use

Member Function Documentation

void com.sparsity.sparksee.algorithms.PageRank.AddAllEdgeTypes ( com.sparsity.sparksee.gdb.EdgesDirection dir )

Allows for traversing all edge types of the graph.

The direction is interpreted as in which direction an edge can be followed from a node to influence other nodes.

Parameters
dir [in] Edge direction.
void com.sparsity.sparksee.algorithms.PageRank.AddEdgeType | ( | int | type,
 |  | com.sparsity.sparksee.gdb.EdgesDirection | dir
 | ) |  | throws System.ApplicationException

Allows for traversing edges of the given type.

If the edge type was already added, the existing direction is overwritten The direction is interpreted as in which direction an edge can be followed from a node to influence other nodes.

Parameters
type | [in] Edge type.
dir | [in] Edge direction.
Exceptions
System.ApplicationException null
void com.sparsity.sparksee.algorithms.PageRank.AddNodeType ( int type ) throws System.ApplicationException

Allows for traversing nodes of the given type.

Parameters
type null
Exceptions
System.ApplicationException null
void com.sparsity.sparksee.algorithms.PageRank.Close ( )

Closes the PageRank instance.

It must be called to ensure the integrity of all data.

boolean com.sparsity.sparksee.algorithms.PageRank.IsClosed ( )

Gets if PageRank instance has been closed or not.

See Also
Close()
Returns
TRUE if the PageRank instance has been closed, FALSE otherwise.
void com.sparsity.sparksee.algorithms.PageRank.Run ( ) throws System.ApplicationException

Runs the algorithm.

sparksee::gdb::Error

Exceptions
System.ApplicationException null
void com.sparsity.sparksee.algorithms.PageRank.SetDamping ( double damping )

Sets the damping value for the PageRank.

Parameters
damping [in] The damping value. Default: 0.85
void com.sparsity.sparksee.algorithms.PageRank.SetDefaultWeight ( double weight )

Sets the default weight for those cases when a given edge does not have a weight attribute set.

Default: 0.0

Parameters
weight [in] The default weight
void com.sparsity.sparksee.algorithms.PageRank.SetEdgeWeightAttributeType ( int attr ) throws System.ApplicationException

Sets the attribute to use as edge weight.

If the multiple edge are set for traversal, this attribute must be of type GLOBAL_TYPE or EDGES_TYPE. Additionally, the attribute must be of type Double. Finally, negative weights are treated as non existing, so the default weight applies.

sparksee::gdb::Error

Parameters
attr [in] The attribute type to use as a weight. Default: InvalidAttribute
Exceptions
System.ApplicationException null
void com.sparsity.sparksee.algorithms.PageRank.SetInitialPageRankValue ( double startValue )

Sets the initial PageRank value.

If a starting node is set, this initial value is only set for the starting node and the rest of nodes are set to 0.0

Parameters
startValue [in] The initial value to set. Default: 0.0
void com.sparsity.sparksee.algorithms.PageRank.SetNumIterations ( int numIterations )

Sets the number of iterations to run the PageRank for.

Parameters
numIterations [in] The number of interations to set. Default: 20
void com.sparsity.sparksee.algorithms.PageRank.SetOutputAttributeType ( int attr ) throws System.ApplicationException

Sets the output attribute type.

If the PageRank will run on more than one node type, then the output attribute must be of type GLOBAL_TYPE or NODES_TYPE. Otherwise, it must be a valid attribute for the used node type.

Parameters
attr [in] The attribute to store the result. Default: InvalidAttribute
Exceptions
System.ApplicationException null
void com.sparsity.sparksee.algorithms.PageRank.SetStartingNode ( long startNode ) throws System.ApplicationException

Sets the starting node of the page rank to compute the Personalized PageRank variant.

sparksee::gdb::Error

Parameters
startNode null
Exceptions
System.ApplicationException null
void com.sparsity.sparksee.algorithms.PageRank.SetTolerance ( double tolerance )

Sets the tolerance threashold to continue computing the PageRank after each iteration.

If all the changes to any PPR value after an iteration are below that tolerance threshold, the algorithm finishes.

Parameters
tolerance [in] The tolerance to use normalized between 0 and 1. Default: 0.000001


SparkseeNet: Member List

  • algorithms
  • PageRank
com.sparsity.sparksee.algorithms.PageRank Member List

This is the complete list of members for com.sparsity.sparksee.algorithms.PageRank, including all inherited members.

AddAllEdgeTypes(com.sparsity.sparksee.gdb.EdgesDirection dir) | com.sparsity.sparksee.algorithms.PageRank
AddAllNodeTypes() | com.sparsity.sparksee.algorithms.PageRank
AddEdgeType(int type, com.sparsity.sparksee.gdb.EdgesDirection dir) | com.sparsity.sparksee.algorithms.PageRank
AddNodeType(int type) | com.sparsity.sparksee.algorithms.PageRank
Close() | com.sparsity.sparksee.algorithms.PageRank
IsClosed() | com.sparsity.sparksee.algorithms.PageRank
PageRank(com.sparsity.sparksee.gdb.Session session) | com.sparsity.sparksee.algorithms.PageRank
Run() | com.sparsity.sparksee.algorithms.PageRank
SetDamping(double damping) | com.sparsity.sparksee.algorithms.PageRank
SetDefaultWeight(double weight) | com.sparsity.sparksee.algorithms.PageRank
SetEdgeWeightAttributeType(int attr) | com.sparsity.sparksee.algorithms.PageRank
SetInitialPageRankValue(double startValue) | com.sparsity.sparksee.algorithms.PageRank
SetNumIterations(int numIterations) | com.sparsity.sparksee.algorithms.PageRank
SetOutputAttributeType(int attr) | com.sparsity.sparksee.algorithms.PageRank
SetStartingNode(long startNode) | com.sparsity.sparksee.algorithms.PageRank
SetTolerance(double tolerance) | com.sparsity.sparksee.algorithms.PageRank


SparkseeNet: com.sparsity.sparksee.algorithms.RandomWalk Class Reference

  • algorithms
  • RandomWalk
Public Member Functions | List of all members
com.sparsity.sparksee.algorithms.RandomWalk Class Reference

RandomWalk class. More...

Inheritance diagram for com.sparsity.sparksee.algorithms.RandomWalk:
Collaboration diagram for com.sparsity.sparksee.algorithms.RandomWalk:

Public Member Functions

void | AddNodeType (int type)
Allows for traversing nodes of the given type.
void | SetSeed (int seed)
Sets the seed of the random walk.
bool | HasNext ()
Gets if there are more objects to be traversed.
void | ExcludeNodes (com.sparsity.sparksee.gdb.Objects nodes)
Set which nodes can't be used.
long | Next ()
Gets the next object of the traversal.
int | GetCurrentDepth ()
Returns the depth of the current node.
void | SetMaximumHops (int maxhops)
Sets the maximum hops restriction.
void | Reset (long startNode)
Sets the starting node of the RandomWalk.
void | SetDefaultWeight (double weight)
Sets the default weight for those cases when a given edge does not have a weight attribute set.
void | SetInOutParameter (double val)
Sets the In-Out parameter of the RandomWalk.
void | AddAllEdgeTypes (com.sparsity.sparksee.gdb.EdgesDirection dir)
Allows for traversing all edge types of the graph.
void | AddAllNodeTypes ()
Allows for traversing all node types of the graph.
void | SetReturnParameter (double val)
Sets the return parameter of the RandomWalk.
void | AddEdgeType (int type, com.sparsity.sparksee.gdb.EdgesDirection dir)
Allows for traversing edges of the given type.
void | SetEdgeWeightAttributeType (int attr)
Sets the attribute to use as edge weight.
RandomWalk (com.sparsity.sparksee.gdb.Session session, long node)
Builds the RandomWalk.
void | ExcludeEdges (com.sparsity.sparksee.gdb.Objects edges)
Set which edges can't be used.
boolean | IsClosed ()
Gets if Traversal instance has been closed or not.
void | Close ()
Closes the Traversal instance.

Detailed Description

RandomWalk class.

Implements the RandomWalk algorithm

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

com.sparsity.sparksee.algorithms.RandomWalk.RandomWalk | ( | com.sparsity.sparksee.gdb.Session | session,
 |  | long | node
 | ) |  |

Builds the RandomWalk.

Parameters
session | [in] The session to use
node | [in] The starting node of the traversal

Member Function Documentation

void com.sparsity.sparksee.algorithms.RandomWalk.AddAllEdgeTypes ( com.sparsity.sparksee.gdb.EdgesDirection dir )

Allows for traversing all edge types of the graph.

Parameters
dir [in] Edge direction.
void com.sparsity.sparksee.algorithms.RandomWalk.AddEdgeType | ( | int | type,
 |  | com.sparsity.sparksee.gdb.EdgesDirection | dir
 | ) |  |

Allows for traversing edges of the given type.

If the edge type was already added, the existing direction is overwritten

Parameters
type | [in] Edge type.
dir | [in] Edge direction.
void com.sparsity.sparksee.algorithms.RandomWalk.AddNodeType ( int type )

Allows for traversing nodes of the given type.

Parameters
type The node type to add
void com.sparsity.sparksee.algorithms.Traversal.Close ( )
inherited

Closes the Traversal instance.

It must be called to ensure the integrity of all data.

void com.sparsity.sparksee.algorithms.RandomWalk.ExcludeEdges ( com.sparsity.sparksee.gdb.Objects edges )

Set which edges can't be used.

This will replace any previously specified set of excluded edges. Should only be used to exclude the usage of specific edges from allowed edge types because it's less efficient than not allowing an edge type.

Parameters
edges [in] A set of edge identifiers that must be kept intact until the destruction of the class.
void com.sparsity.sparksee.algorithms.RandomWalk.ExcludeNodes ( com.sparsity.sparksee.gdb.Objects nodes )

Set which nodes can't be used.

This will replace any previously specified set of excluded nodes. Should only be used to exclude the usage of specific nodes from allowed node types because it's less efficient than not allowing a node type.

Parameters
nodes [in] A set of node identifiers that must be kept intact until the destruction of the class.
int com.sparsity.sparksee.algorithms.RandomWalk.GetCurrentDepth ( )

Returns the depth of the current node.

That is, it returns the depth of the node returned in the last call to Next().

Returns
The depth of the current node.
bool com.sparsity.sparksee.algorithms.RandomWalk.HasNext ( )

Gets if there are more objects to be traversed.

Returns
TRUE if there are more objects, FALSE otherwise.
boolean com.sparsity.sparksee.algorithms.Traversal.IsClosed ( )
inherited

Gets if Traversal instance has been closed or not.

See Also
Close()
Returns
TRUE if the Traversal instance has been closed, FALSE otherwise.
long com.sparsity.sparksee.algorithms.RandomWalk.Next ( )

Gets the next object of the traversal.

Returns
A node or edge identifier.
void com.sparsity.sparksee.algorithms.RandomWalk.Reset ( long startNode )

Sets the starting node of the RandomWalk.

This method resets the RandomWalk.

sparksee::gdb::Error

Parameters
startNode null
void com.sparsity.sparksee.algorithms.RandomWalk.SetDefaultWeight ( double weight )

Sets the default weight for those cases when a given edge does not have a weight attribute set.

Default: 0.0

Parameters
weight [in] The default weight
void com.sparsity.sparksee.algorithms.RandomWalk.SetEdgeWeightAttributeType ( int attr )

Sets the attribute to use as edge weight.

If the multiple edge are set for traversal, this attribute must be of type GLOBAL_TYPE or EDGES_TYPE. Additionally, the attribute must be of type Double. Finally, negative weights are treated as non existing, so the default weight applies.

Parameters
attr [in] The attribute type to use as a weight. Default: InvalidAttribute
void com.sparsity.sparksee.algorithms.RandomWalk.SetInOutParameter ( double val )

Sets the In-Out parameter of the RandomWalk.

Parameters
val The In-Out parameter to set. Default: 1.0
void com.sparsity.sparksee.algorithms.RandomWalk.SetMaximumHops ( int maxhops )

Sets the maximum hops restriction.

All paths longer than the maximum hops restriction will be ignored.

Parameters
maxhops [in] The maximum hops restriction. It must be positive or zero. Zero, the default value, means unlimited.
void com.sparsity.sparksee.algorithms.RandomWalk.SetReturnParameter ( double val )

Sets the return parameter of the RandomWalk.

Parameters
val The return parameter to set. Default: 1.0
void com.sparsity.sparksee.algorithms.RandomWalk.SetSeed ( int seed )

Sets the seed of the random walk.

Parameters
seed The seed to generate the random numbers that drive the random walk


SparkseeNet: Member List

  • algorithms
  • RandomWalk
com.sparsity.sparksee.algorithms.RandomWalk Member List

This is the complete list of members for com.sparsity.sparksee.algorithms.RandomWalk, including all inherited members.

AddAllEdgeTypes(com.sparsity.sparksee.gdb.EdgesDirection dir) | com.sparsity.sparksee.algorithms.RandomWalk
AddAllNodeTypes() | com.sparsity.sparksee.algorithms.RandomWalk
AddEdgeType(int type, com.sparsity.sparksee.gdb.EdgesDirection dir) | com.sparsity.sparksee.algorithms.RandomWalk
AddNodeType(int type) | com.sparsity.sparksee.algorithms.RandomWalk
Close() | com.sparsity.sparksee.algorithms.Traversal
ExcludeEdges(com.sparsity.sparksee.gdb.Objects edges) | com.sparsity.sparksee.algorithms.RandomWalk
ExcludeNodes(com.sparsity.sparksee.gdb.Objects nodes) | com.sparsity.sparksee.algorithms.RandomWalk
GetCurrentDepth() | com.sparsity.sparksee.algorithms.RandomWalk
HasNext() | com.sparsity.sparksee.algorithms.RandomWalk
IsClosed() | com.sparsity.sparksee.algorithms.Traversal
Next() | com.sparsity.sparksee.algorithms.RandomWalk
RandomWalk(com.sparsity.sparksee.gdb.Session session, long node) | com.sparsity.sparksee.algorithms.RandomWalk
Reset(long startNode) | com.sparsity.sparksee.algorithms.RandomWalk
SetDefaultWeight(double weight) | com.sparsity.sparksee.algorithms.RandomWalk
SetEdgeWeightAttributeType(int attr) | com.sparsity.sparksee.algorithms.RandomWalk
SetInOutParameter(double val) | com.sparsity.sparksee.algorithms.RandomWalk
SetMaximumHops(int maxhops) | com.sparsity.sparksee.algorithms.RandomWalk
SetReturnParameter(double val) | com.sparsity.sparksee.algorithms.RandomWalk
SetSeed(int seed) | com.sparsity.sparksee.algorithms.RandomWalk


SparkseeNet: com.sparsity.sparksee.algorithms.ShortestPath Class Reference

  • algorithms
  • ShortestPath
Public Member Functions | List of all members
com.sparsity.sparksee.algorithms.ShortestPath Class Reference

ShortestPath class. More...

Inheritance diagram for com.sparsity.sparksee.algorithms.ShortestPath:

Public Member Functions

boolean | IsClosed ()
Gets if ShortestPath instance has been closed or not.
void | AddNodeType (int type)
Allows for traversing nodes of the given type.
void | AddAllNodeTypes ()
Allows for traversing all node types of the graph.
void | Close ()
Closes the ShortestPath instance.
void | Run ()
Runs the algorithm.
void | ExcludeNodes (com.sparsity.sparksee.gdb.Objects nodes)
Set which nodes can't be used.
void | AddEdgeType (int type, com.sparsity.sparksee.gdb.EdgesDirection dir)
Allows for traversing edges of the given type.
void | ExcludeEdges (com.sparsity.sparksee.gdb.Objects edges)
Set which edges can't be used.
void | SetMaximumHops (int maxhops)
Sets the maximum hops restriction.
void | AddAllEdgeTypes (com.sparsity.sparksee.gdb.EdgesDirection dir)
Allows for traversing all edge types of the graph.

Detailed Description

ShortestPath class.

Classes implementing this abstract class solve the shortest path problem in a graph.

The user must set which node and edge types can be used for the traversal.

Check out the 'Algorithms' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

void com.sparsity.sparksee.algorithms.ShortestPath.AddAllEdgeTypes ( com.sparsity.sparksee.gdb.EdgesDirection dir )

Allows for traversing all edge types of the graph.

Parameters
dir [in] Edge direction.
void com.sparsity.sparksee.algorithms.ShortestPath.AddEdgeType | ( | int | type,
 |  | com.sparsity.sparksee.gdb.EdgesDirection | dir
 | ) |  |

Allows for traversing edges of the given type.

Parameters
type | [in] Edge type.
dir | [in] Edge direction.
void com.sparsity.sparksee.algorithms.ShortestPath.AddNodeType ( int type )

Allows for traversing nodes of the given type.

Parameters
type null
void com.sparsity.sparksee.algorithms.ShortestPath.Close ( )

Closes the ShortestPath instance.

It must be called to ensure the integrity of all data.

void com.sparsity.sparksee.algorithms.ShortestPath.ExcludeEdges ( com.sparsity.sparksee.gdb.Objects edges )

Set which edges can't be used.

This will replace any previously specified set of excluded edges. Should only be used to exclude the usage of specific edges from allowed edge types because it's less efficient than not allowing an edge type.

Parameters
edges [in] A set of edge identifiers that must be kept intact until the destruction of the class.
void com.sparsity.sparksee.algorithms.ShortestPath.ExcludeNodes ( com.sparsity.sparksee.gdb.Objects nodes )

Set which nodes can't be used.

This will replace any previously specified set of excluded nodes. Should only be used to exclude the usage of specific nodes from allowed node types because it's less efficient than not allowing a node type.

Parameters
nodes [in] A set of node identifiers that must be kept intact until the destruction of the class.
boolean com.sparsity.sparksee.algorithms.ShortestPath.IsClosed ( )

Gets if ShortestPath instance has been closed or not.

See Also
Close()
Returns
TRUE if the ShortestPath instance has been closed, FALSE otherwise.
void com.sparsity.sparksee.algorithms.ShortestPath.Run ( )

Runs the algorithm.

This method can only be called once.

void com.sparsity.sparksee.algorithms.ShortestPath.SetMaximumHops ( int maxhops )

Sets the maximum hops restriction.

All paths longer than the maximum hops restriction will be ignored.

Parameters
maxhops [in] The maximum hops restriction. It must be positive or zero. Zero, the default value, means unlimited.


SparkseeNet: Member List

  • algorithms
  • ShortestPath
com.sparsity.sparksee.algorithms.ShortestPath Member List

This is the complete list of members for com.sparsity.sparksee.algorithms.ShortestPath, including all inherited members.

AddAllEdgeTypes(com.sparsity.sparksee.gdb.EdgesDirection dir) | com.sparsity.sparksee.algorithms.ShortestPath
AddAllNodeTypes() | com.sparsity.sparksee.algorithms.ShortestPath
AddEdgeType(int type, com.sparsity.sparksee.gdb.EdgesDirection dir) | com.sparsity.sparksee.algorithms.ShortestPath
AddNodeType(int type) | com.sparsity.sparksee.algorithms.ShortestPath
Close() | com.sparsity.sparksee.algorithms.ShortestPath
ExcludeEdges(com.sparsity.sparksee.gdb.Objects edges) | com.sparsity.sparksee.algorithms.ShortestPath
ExcludeNodes(com.sparsity.sparksee.gdb.Objects nodes) | com.sparsity.sparksee.algorithms.ShortestPath
IsClosed() | com.sparsity.sparksee.algorithms.ShortestPath
Run() | com.sparsity.sparksee.algorithms.ShortestPath
SetMaximumHops(int maxhops) | com.sparsity.sparksee.algorithms.ShortestPath


SparkseeNet: com.sparsity.sparksee.algorithms.SinglePairShortestPath Class Reference

  • algorithms
  • SinglePairShortestPath
Public Member Functions | List of all members
com.sparsity.sparksee.algorithms.SinglePairShortestPath Class Reference

SinglePairShortestPath class. More...

Inheritance diagram for com.sparsity.sparksee.algorithms.SinglePairShortestPath:
Collaboration diagram for com.sparsity.sparksee.algorithms.SinglePairShortestPath:

Public Member Functions

bool | Exists ()
Returns TRUE If a path exists or FALSE otherwise.
void | AddNodeType (int type)
Allows for traversing nodes of the given type.
void | Run ()
Runs the algorithm.
void | ExcludeNodes (com.sparsity.sparksee.gdb.Objects nodes)
Set which nodes can't be used.
com.sparsity.sparksee.gdb.OIDList GetPathAsEdges ()
Gets the shortest path between the source node and the destination node as an ordered set of edges.
void | SetMaximumHops (int maxhops)
Sets the maximum hops restriction.
void | AddAllEdgeTypes (com.sparsity.sparksee.gdb.EdgesDirection dir)
Allows for traversing all edge types of the graph.
void | AddAllNodeTypes ()
Allows for traversing all node types of the graph.
void | AddEdgeType (int type, com.sparsity.sparksee.gdb.EdgesDirection dir)
Allows for traversing edges of the given type.
double | GetCost ()
Gets the cost of the shortest path.
com.sparsity.sparksee.gdb.OIDList GetPathAsNodes ()
Gets the shortest path between the source node and the destination node as an ordered set of nodes.
void | ExcludeEdges (com.sparsity.sparksee.gdb.Objects edges)
Set which edges can't be used.
boolean | IsClosed ()
Gets if ShortestPath instance has been closed or not.
void | Close ()
Closes the ShortestPath instance.

Detailed Description

SinglePairShortestPath class.

Classes implementing this abstract class solve the shortest path problem in a graph from a given source node and to a given destination node.

Check out the 'Algorithms' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

void com.sparsity.sparksee.algorithms.SinglePairShortestPath.AddAllEdgeTypes ( com.sparsity.sparksee.gdb.EdgesDirection dir )

Allows for traversing all edge types of the graph.

Parameters
dir [in] Edge direction.
void com.sparsity.sparksee.algorithms.SinglePairShortestPath.AddEdgeType | ( | int | type,
 |  | com.sparsity.sparksee.gdb.EdgesDirection | dir
 | ) |  |

Allows for traversing edges of the given type.

Parameters
type | [in] Edge type.
dir | [in] Edge direction.
void com.sparsity.sparksee.algorithms.SinglePairShortestPath.AddNodeType ( int type )

Allows for traversing nodes of the given type.

Parameters
type null
void com.sparsity.sparksee.algorithms.ShortestPath.Close ( )
inherited

Closes the ShortestPath instance.

It must be called to ensure the integrity of all data.

void com.sparsity.sparksee.algorithms.SinglePairShortestPath.ExcludeEdges ( com.sparsity.sparksee.gdb.Objects edges )

Set which edges can't be used.

This will replace any previously specified set of excluded edges. Should only be used to exclude the usage of specific edges from allowed edge types because it's less efficient than not allowing an edge type.

Parameters
edges [in] A set of edge identifiers that must be kept intact until the destruction of the class.
void com.sparsity.sparksee.algorithms.SinglePairShortestPath.ExcludeNodes ( com.sparsity.sparksee.gdb.Objects nodes )

Set which nodes can't be used.

This will replace any previously specified set of excluded nodes. Should only be used to exclude the usage of specific nodes from allowed node types because it's less efficient than not allowing a node type.

Parameters
nodes [in] A set of node identifiers that must be kept intact until the destruction of the class.
double com.sparsity.sparksee.algorithms.SinglePairShortestPath.GetCost ( )

Gets the cost of the shortest path.

The cost for unweighted algorithms is the number of hops of the shortest path. For weighted algoritms, the cost is the sum of the costs of the edges of the shortest path.

Returns
The cost of the shortest path.
com.sparsity.sparksee.gdb.OIDList com.sparsity.sparksee.algorithms.SinglePairShortestPath.GetPathAsEdges ( )

Gets the shortest path between the source node and the destination node as an ordered set of edges.

Returns
Ordered set of edge identifiers.
com.sparsity.sparksee.gdb.OIDList com.sparsity.sparksee.algorithms.SinglePairShortestPath.GetPathAsNodes ( )

Gets the shortest path between the source node and the destination node as an ordered set of nodes.

Returns
Ordered set of node identifiers.
boolean com.sparsity.sparksee.algorithms.ShortestPath.IsClosed ( )
inherited

Gets if ShortestPath instance has been closed or not.

See Also
Close()
Returns
TRUE if the ShortestPath instance has been closed, FALSE otherwise.
void com.sparsity.sparksee.algorithms.SinglePairShortestPath.Run ( )

Runs the algorithm.

This method can only be called once.

void com.sparsity.sparksee.algorithms.SinglePairShortestPath.SetMaximumHops ( int maxhops )

Sets the maximum hops restriction.

All paths longer than the maximum hops restriction will be ignored.

Parameters
maxhops [in] The maximum hops restriction. It must be positive or zero. Zero, the default value, means unlimited.


SparkseeNet: Member List

  • algorithms
  • SinglePairShortestPath
com.sparsity.sparksee.algorithms.SinglePairShortestPath Member List

This is the complete list of members for com.sparsity.sparksee.algorithms.SinglePairShortestPath, including all inherited members.

AddAllEdgeTypes(com.sparsity.sparksee.gdb.EdgesDirection dir) | com.sparsity.sparksee.algorithms.SinglePairShortestPath
AddAllNodeTypes() | com.sparsity.sparksee.algorithms.SinglePairShortestPath
AddEdgeType(int type, com.sparsity.sparksee.gdb.EdgesDirection dir) | com.sparsity.sparksee.algorithms.SinglePairShortestPath
AddNodeType(int type) | com.sparsity.sparksee.algorithms.SinglePairShortestPath
Close() | com.sparsity.sparksee.algorithms.ShortestPath
ExcludeEdges(com.sparsity.sparksee.gdb.Objects edges) | com.sparsity.sparksee.algorithms.SinglePairShortestPath
ExcludeNodes(com.sparsity.sparksee.gdb.Objects nodes) | com.sparsity.sparksee.algorithms.SinglePairShortestPath
Exists() | com.sparsity.sparksee.algorithms.SinglePairShortestPath
GetCost() | com.sparsity.sparksee.algorithms.SinglePairShortestPath
GetPathAsEdges() | com.sparsity.sparksee.algorithms.SinglePairShortestPath
GetPathAsNodes() | com.sparsity.sparksee.algorithms.SinglePairShortestPath
IsClosed() | com.sparsity.sparksee.algorithms.ShortestPath
Run() | com.sparsity.sparksee.algorithms.SinglePairShortestPath
SetMaximumHops(int maxhops) | com.sparsity.sparksee.algorithms.SinglePairShortestPath


SparkseeNet: com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS Class Reference

  • algorithms
  • SinglePairShortestPathBFS
Public Member Functions | List of all members
com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS Class Reference

SinglePairShortestPathBFS class. More...

Inheritance diagram for com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS:
Collaboration diagram for com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS:

Public Member Functions

bool | Exists ()
Returns TRUE If a path exists or FALSE otherwise.
void | AddNodeType (int type)
Allows for traversing nodes of the given type.
void | ExcludeNodes (com.sparsity.sparksee.gdb.Objects nodes)
Set which nodes can't be used.
com.sparsity.sparksee.gdb.OIDList GetPathAsEdges ()
Gets the shortest path between the source node and the destination node as an ordered set of edges.
com.sparsity.sparksee.gdb.OIDList GetPathAsNodes ()
Gets the shortest path between the source node and the destination node as an ordered set of nodes.
SinglePairShortestPathBFS (com.sparsity.sparksee.gdb.Session session, long src, long dst)
Creates a new instance.
void | SetMaximumHops (int maxhops)
Sets the maximum hops restriction.
void | AddAllEdgeTypes (com.sparsity.sparksee.gdb.EdgesDirection dir)
Allows for traversing all edge types of the graph.
double | GetCost ()
Gets the cost of the shortest path.
void | AddAllNodeTypes ()
Allows for traversing all node types of the graph.
void | AddEdgeType (int type, com.sparsity.sparksee.gdb.EdgesDirection dir)
Allows for traversing edges of the given type.
void | Run ()
Executes the algorithm.
void | CheckOnlyExistence ()
Set that only the path existence must be calculated and not the path itself.
void | ExcludeEdges (com.sparsity.sparksee.gdb.Objects edges)
Set which edges can't be used.
boolean | IsClosed ()
Gets if ShortestPath instance has been closed or not.
void | Close ()
Closes the ShortestPath instance.

Detailed Description

SinglePairShortestPathBFS class.

It solves the single-pair shortest path problem using a BFS-based implementation.

It is a unweighted algorithm, that is it assumes all edges have the same cost.

Check out the 'Algorithms' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS.SinglePairShortestPathBFS | ( | com.sparsity.sparksee.gdb.Session | session,
 |  | long | src,
 |  | long | dst
 | ) |  |

Creates a new instance.

Parameters
session | [in] Session to get the graph from and perform traversal.
src | [in] Source node.
dst | [dst] Destination node.

Member Function Documentation

void com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS.AddAllEdgeTypes ( com.sparsity.sparksee.gdb.EdgesDirection dir )

Allows for traversing all edge types of the graph.

Parameters
dir [in] Edge direction.
void com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS.AddEdgeType | ( | int | type,
 |  | com.sparsity.sparksee.gdb.EdgesDirection | dir
 | ) |  |

Allows for traversing edges of the given type.

Parameters
type | [in] Edge type.
dir | [in] Edge direction.
void com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS.AddNodeType ( int type )

Allows for traversing nodes of the given type.

Parameters
type null
void com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS.CheckOnlyExistence ( )

Set that only the path existence must be calculated and not the path itself.

That method should improve the performance of the algorithm, but a call to GetPathAsNodes or GetPathAsEdges will generate an exception even if the path exists.

void com.sparsity.sparksee.algorithms.ShortestPath.Close ( )
inherited

Closes the ShortestPath instance.

It must be called to ensure the integrity of all data.

void com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS.ExcludeEdges ( com.sparsity.sparksee.gdb.Objects edges )

Set which edges can't be used.

This will replace any previously specified set of excluded edges. Should only be used to exclude the usage of specific edges from allowed edge types because it's less efficient than not allowing an edge type.

Parameters
edges [in] A set of edge identifiers that must be kept intact until the destruction of the class.
void com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS.ExcludeNodes ( com.sparsity.sparksee.gdb.Objects nodes )

Set which nodes can't be used.

This will replace any previously specified set of excluded nodes. Should only be used to exclude the usage of specific nodes from allowed node types because it's less efficient than not allowing a node type.

Parameters
nodes [in] A set of node identifiers that must be kept intact until the destruction of the class.
double com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS.GetCost ( )

Gets the cost of the shortest path.

The cost is the number of hops of the shortest path.

Returns
The cost of the shortest path.
com.sparsity.sparksee.gdb.OIDList com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS.GetPathAsEdges ( )

Gets the shortest path between the source node and the destination node as an ordered set of edges.

Returns
Ordered set of edge identifiers.
com.sparsity.sparksee.gdb.OIDList com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS.GetPathAsNodes ( )

Gets the shortest path between the source node and the destination node as an ordered set of nodes.

Returns
Ordered set of node identifiers.
boolean com.sparsity.sparksee.algorithms.ShortestPath.IsClosed ( )
inherited

Gets if ShortestPath instance has been closed or not.

See Also
Close()
Returns
TRUE if the ShortestPath instance has been closed, FALSE otherwise.
void com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS.SetMaximumHops ( int maxhops )

Sets the maximum hops restriction.

All paths longer than the maximum hops restriction will be ignored.

Parameters
maxhops [in] The maximum hops restriction. It must be positive or zero. Zero, the default value, means unlimited.


SparkseeNet: Member List

  • algorithms
  • SinglePairShortestPathBFS
com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS Member List

This is the complete list of members for com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS, including all inherited members.

AddAllEdgeTypes(com.sparsity.sparksee.gdb.EdgesDirection dir) | com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS
AddAllNodeTypes() | com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS
AddEdgeType(int type, com.sparsity.sparksee.gdb.EdgesDirection dir) | com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS
AddNodeType(int type) | com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS
CheckOnlyExistence() | com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS
Close() | com.sparsity.sparksee.algorithms.ShortestPath
ExcludeEdges(com.sparsity.sparksee.gdb.Objects edges) | com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS
ExcludeNodes(com.sparsity.sparksee.gdb.Objects nodes) | com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS
Exists() | com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS
GetCost() | com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS
GetPathAsEdges() | com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS
GetPathAsNodes() | com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS
IsClosed() | com.sparsity.sparksee.algorithms.ShortestPath
Run() | com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS
SetMaximumHops(int maxhops) | com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS
SinglePairShortestPathBFS(com.sparsity.sparksee.gdb.Session session, long src, long dst) | com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS


SparkseeNet: com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra Class Reference

  • algorithms
  • SinglePairShortestPathDijkstra
Public Member Functions | List of all members
com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra Class Reference

SinglePairShortestPathDijkstra class. More...

Inheritance diagram for com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra:
Collaboration diagram for com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra:

Public Member Functions

bool | Exists ()
Returns TRUE If a path exists or FALSE otherwise.
void | AddNodeType (int type)
Allows for traversing nodes of the given type.
void | ExcludeNodes (com.sparsity.sparksee.gdb.Objects nodes)
Set which nodes can't be used.
com.sparsity.sparksee.gdb.OIDList GetPathAsEdges ()
Gets the shortest path between the source node and the destination node as an ordered set of edges.
com.sparsity.sparksee.gdb.OIDList GetPathAsNodes ()
Gets the shortest path between the source node and the destination node as an ordered set of nodes.
void | SetUnweightedEdgeCost (double weight)
Sets the weight assigned to the unweighted edges.
void | SetMaximumHops (int maxhops)
Sets the maximum hops restriction.
void | AddAllEdgeTypes (com.sparsity.sparksee.gdb.EdgesDirection dir)
Allows for traversing all edge types of the graph.
double | GetCost ()
Gets the cost of the shortest path.
SinglePairShortestPathDijkstra (com.sparsity.sparksee.gdb.Session session, long src, long dst)
Creates a new instance.
void | AddWeightedEdgeType (int type, com.sparsity.sparksee.gdb.EdgesDirection dir, int attr)
Allows for traversing edges of the given type using the given attribute as the weight.
void | AddAllNodeTypes ()
Allows for traversing all node types of the graph.
void | AddEdgeType (int type, com.sparsity.sparksee.gdb.EdgesDirection dir)
Allows for traversing edges of the given type.
void | Run ()
Executes the algorithm.
void | ExcludeEdges (com.sparsity.sparksee.gdb.Objects edges)
Set which edges can't be used.
void | SetDynamicEdgeCostCallback (com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstraDynamicCost dynCostCalculator)
Set a class callback to dynamically calculate the cost of the edges.
boolean | IsClosed ()
Gets if ShortestPath instance has been closed or not.
void | Close ()
Closes the ShortestPath instance.

Detailed Description

SinglePairShortestPathDijkstra class.

It solves the single-pair shortest path problem using a Dijkstra-based implementation.

It is a weighted algorithm, so it takes into account the cost of the edges to compute a minimum-cost shortest path. That is, the user may set for each edge type which attribute should be used to retrieve the cost of the edge. If no attribute is given for an edge type, this will assume the edge has a fixed cost (the default is 1). Only numerical attribute can be set as weight attributes (that is Long, Integer or Double attributes are allowed).

Check out the 'Algorithms' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra.SinglePairShortestPathDijkstra | ( | com.sparsity.sparksee.gdb.Session | session,
 |  | long | src,
 |  | long | dst
 | ) |  |

Creates a new instance.

Parameters
session | [in] Session to get the graph from and perform traversal.
src | [in] Source node.
dst | [dst] Destination node.

Member Function Documentation

void com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra.AddAllEdgeTypes ( com.sparsity.sparksee.gdb.EdgesDirection dir )

Allows for traversing all edge types of the graph.

Parameters
dir [in] Edge direction.
void com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra.AddEdgeType | ( | int | type,
 |  | com.sparsity.sparksee.gdb.EdgesDirection | dir
 | ) |  |

Allows for traversing edges of the given type.

Parameters
type | [in] Edge type.
dir | [in] Edge direction.
void com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra.AddNodeType ( int type )

Allows for traversing nodes of the given type.

Parameters
type null
void com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra.AddWeightedEdgeType | ( | int | type,
 |  | com.sparsity.sparksee.gdb.EdgesDirection | dir,
 |  | int | attr
 | ) |  |

Allows for traversing edges of the given type using the given attribute as the weight.

Parameters
type | [in] Edge type.
dir | [in] Edge direction.
attr | [in] Attribute to be used as the weight. It must be a global attribute or an attribute of the given edge type.
void com.sparsity.sparksee.algorithms.ShortestPath.Close ( )
inherited

Closes the ShortestPath instance.

It must be called to ensure the integrity of all data.

void com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra.ExcludeEdges ( com.sparsity.sparksee.gdb.Objects edges )

Set which edges can't be used.

This will replace any previously specified set of excluded edges. Should only be used to exclude the usage of specific edges from allowed edge types because it's less efficient than not allowing an edge type.

Parameters
edges [in] A set of edge identifiers that must be kept intact until the destruction of the class.
void com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra.ExcludeNodes ( com.sparsity.sparksee.gdb.Objects nodes )

Set which nodes can't be used.

This will replace any previously specified set of excluded nodes. Should only be used to exclude the usage of specific nodes from allowed node types because it's less efficient than not allowing a node type.

Parameters
nodes [in] A set of node identifiers that must be kept intact until the destruction of the class.
double com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra.GetCost ( )

Gets the cost of the shortest path.

The cost is the sum of the weights of the edges in the shortest path.

Returns
The cost of the shortest path.
com.sparsity.sparksee.gdb.OIDList com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra.GetPathAsEdges ( )

Gets the shortest path between the source node and the destination node as an ordered set of edges.

Returns
Ordered set of edge identifiers.
com.sparsity.sparksee.gdb.OIDList com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra.GetPathAsNodes ( )

Gets the shortest path between the source node and the destination node as an ordered set of nodes.

Returns
Ordered set of node identifiers.
boolean com.sparsity.sparksee.algorithms.ShortestPath.IsClosed ( )
inherited

Gets if ShortestPath instance has been closed or not.

See Also
Close()
Returns
TRUE if the ShortestPath instance has been closed, FALSE otherwise.
void com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra.SetDynamicEdgeCostCallback ( com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstraDynamicCost dynCostCalculator )

Set a class callback to dynamically calculate the cost of the edges.

The callback can be set to NULL (the default) to use the normal attribute based cost weights. The given class must be kept alive by the user for as long as the algorithm is running.

Parameters
dynCostCalculator [in] Class callback to calculate the edge costs
void com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra.SetMaximumHops ( int maxhops )

Sets the maximum hops restriction.

All paths longer than the maximum hops restriction will be ignored.

Parameters
maxhops [in] The maximum hops restriction. It must be positive or zero. Zero, the default value, means unlimited.
void com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra.SetUnweightedEdgeCost ( double weight )

Sets the weight assigned to the unweighted edges.

All the edges from the types added without an explicit weight attribute will get this weight. The default weight for this edges is 1.

Parameters
weight [in] The weight value for unweighted edges.


SparkseeNet: Member List

  • algorithms
  • SinglePairShortestPathDijkstra
com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra Member List

This is the complete list of members for com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra, including all inherited members.

AddAllEdgeTypes(com.sparsity.sparksee.gdb.EdgesDirection dir) | com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra
AddAllNodeTypes() | com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra
AddEdgeType(int type, com.sparsity.sparksee.gdb.EdgesDirection dir) | com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra
AddNodeType(int type) | com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra
AddWeightedEdgeType(int type, com.sparsity.sparksee.gdb.EdgesDirection dir, int attr) | com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra
Close() | com.sparsity.sparksee.algorithms.ShortestPath
ExcludeEdges(com.sparsity.sparksee.gdb.Objects edges) | com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra
ExcludeNodes(com.sparsity.sparksee.gdb.Objects nodes) | com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra
Exists() | com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra
GetCost() | com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra
GetPathAsEdges() | com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra
GetPathAsNodes() | com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra
IsClosed() | com.sparsity.sparksee.algorithms.ShortestPath
Run() | com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra
SetDynamicEdgeCostCallback(com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstraDynamicCost dynCostCalculator) | com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra
SetMaximumHops(int maxhops) | com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra
SetUnweightedEdgeCost(double weight) | com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra
SinglePairShortestPathDijkstra(com.sparsity.sparksee.gdb.Session session, long src, long dst) | com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra


SparkseeNet: com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstraDynamicCost Class Reference

  • algorithms
  • SinglePairShortestPathDijkstraDynamicCost
Public Member Functions | List of all members
com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstraDynamicCost Class Reference

Defines how to calculate an edge weight. More...

Public Member Functions

double CalculateEdgeCost (long sourceNode, double sourceCost, int sourceLevel, long targetNode, long edge, int edgeWeightAttr)
Dynamic calculation of an edge weight.

Detailed Description

Defines how to calculate an edge weight.

This is an interface which must be implemented by the user. While the algorithm is running, one or more calls for each edge that can be in the shortest path will be issued to get the weight of the edge that could change based on the predecessor node and the current minimum path from the source.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

double com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstraDynamicCost.CalculateEdgeCost | ( | long | sourceNode,
 |  | double | sourceCost,
 |  | int | sourceLevel,
 |  | long | targetNode,
 |  | long | edge,
 |  | int | edgeWeightAttr
 | ) |  |

Dynamic calculation of an edge weight.

This method will be called several times during the algorithm execution. It can be called for the same edge multiple times because the path to the source node (and as a consequence the source weight and levels) might change while the algorithm is running. This method will have the normal default implementation that only uses the specified edge attribute to get the weight or the unweighted edge cost if the edge doesn't have the specified cost attribute. But it can be overriden in a derived user class to implement a dinamic edge weight, that may need the sourceCost and sourceLevels to calculate the weight.

Parameters
sourceNode | [in] The current node
sourceCost | [in] Current total cost up to the source node
sourceLevel | [in] Current path size up to the source node
targetNode | [in] The next node
edge | [in] The edge to the next node that this methos must weight
edgeWeightAttr | [in] The attribute that stores the edge weight or InvalidAttribute
Returns
Returns the current weight of the edge (>=0) or <0 if the edge can not be used.


SparkseeNet: Member List

  • algorithms
  • SinglePairShortestPathDijkstraDynamicCost
com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstraDynamicCost Member List

This is the complete list of members for com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstraDynamicCost, including all inherited members.

CalculateEdgeCost(long sourceNode, double sourceCost, int sourceLevel, long targetNode, long edge, int edgeWeightAttr) com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstraDynamicCost


SparkseeNet: com.sparsity.sparksee.algorithms.StrongConnectivity Class Reference

  • algorithms
  • StrongConnectivity
Public Member Functions | List of all members
com.sparsity.sparksee.algorithms.StrongConnectivity Class Reference

StrongConnectivity class. More...

Inheritance diagram for com.sparsity.sparksee.algorithms.StrongConnectivity:
Collaboration diagram for com.sparsity.sparksee.algorithms.StrongConnectivity:

Public Member Functions

void | AddAllNodeTypes ()
Allows connectivity through all node types of the graph.
void | Run ()
Runs the algorithm in order to find the connected components.
void | ExcludeNodes (com.sparsity.sparksee.gdb.Objects nodes)
Set which nodes can't be used.
void | AddEdgeType (int type, com.sparsity.sparksee.gdb.EdgesDirection dir)
Allows connectivity through edges of the given type.
void | AddNodeType (int t)
Allows connectivity through nodes of the given type.
void | SetMaterializedAttribute (System.String attributeName)
Creates a new common attribute type for all node types in the graph in order to store, persistently, the results related to the connected components found while executing this algorithm.
void | ExcludeEdges (com.sparsity.sparksee.gdb.Objects edges)
Set which edges can't be used.
void | AddAllEdgeTypes (com.sparsity.sparksee.gdb.EdgesDirection dir)
Allows connectivity through all edge types of the graph.
com.sparsity.sparksee.algorithms.ConnectedComponents GetConnectedComponents ()
Returns the results generated by the execution of the algorithm.
boolean | IsClosed ()
Gets if Connectivity instance has been closed or not.
void | Close ()
Closes the Connectivity instance.

Detailed Description

StrongConnectivity class.

Any class implementing this abstract class can be used to solve the problem of finding strongly connected components in a directed graph.

It consists in finding components where every pair (u,v) of nodes contained in it has a path from u to v using the specified direction for each edge type.

It is possible to set some restrictions after constructing a new instance of this class and before running it in order to limit the results.

After the execution, we can retrieve the results stored in an instance of the ConnectedComponents class using the GetConnectedComponents method.

Check out the 'Algorithms' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

void com.sparsity.sparksee.algorithms.StrongConnectivity.AddAllEdgeTypes ( com.sparsity.sparksee.gdb.EdgesDirection dir )

Allows connectivity through all edge types of the graph.

Parameters
dir [in] Edge direction.
void com.sparsity.sparksee.algorithms.StrongConnectivity.AddEdgeType | ( | int | type,
 |  | com.sparsity.sparksee.gdb.EdgesDirection | dir
 | ) |  |

Allows connectivity through edges of the given type.

Parameters
type | [in] Edge type.
dir | [in] Edge direction.
void com.sparsity.sparksee.algorithms.StrongConnectivity.AddNodeType ( int t )

Allows connectivity through nodes of the given type.

Parameters
t null
void com.sparsity.sparksee.algorithms.Connectivity.Close ( )
inherited

Closes the Connectivity instance.

It must be called to ensure the integrity of all data.

void com.sparsity.sparksee.algorithms.StrongConnectivity.ExcludeEdges ( com.sparsity.sparksee.gdb.Objects edges )

Set which edges can't be used.

This will replace any previously specified set of excluded edges. Should only be used to exclude the usage of specific edges from allowed edge types because it's less efficient than not allowing an edge type.

Parameters
edges [in] A set of edge identifiers that must be kept intact until the destruction of the class.
void com.sparsity.sparksee.algorithms.StrongConnectivity.ExcludeNodes ( com.sparsity.sparksee.gdb.Objects nodes )

Set which nodes can't be used.

This will replace any previously specified set of excluded nodes. Should only be used to exclude the usage of specific nodes from allowed node types because it's less efficient than not allowing a node type.

Parameters
nodes [in] A set of node identifiers that must be kept intact until the destruction of the class.
com.sparsity.sparksee.algorithms.ConnectedComponents com.sparsity.sparksee.algorithms.StrongConnectivity.GetConnectedComponents ( )

Returns the results generated by the execution of the algorithm.

These results contain information related to the connected components found as the number of different components, the set of nodes contained in each component or many other data.

Returns
Returns an instance of the class ConnectedComponents which contain information related to the connected components found.
boolean com.sparsity.sparksee.algorithms.Connectivity.IsClosed ( )
inherited

Gets if Connectivity instance has been closed or not.

See Also
Close()
Returns
TRUE if the Connectivity instance has been closed, FALSE otherwise.
void com.sparsity.sparksee.algorithms.StrongConnectivity.Run ( )

Runs the algorithm in order to find the connected components.

This method can be called only once.

void com.sparsity.sparksee.algorithms.StrongConnectivity.SetMaterializedAttribute ( System.String attributeName )

Creates a new common attribute type for all node types in the graph in order to store, persistently, the results related to the connected components found while executing this algorithm.

Whenever the user wants to retrieve the results, even when the graph has been closed and opened again, it is only necessary to create a new instance of the class ConnectedComponents indicating the graph and the name of the common attribute type which stores the results. This instance will have all the information related to the connected components found in the moment of the execution of the algorithm that stored this data.

It is possible to run the algorithm without specifying this parameter in order to avoid materializing the results of the execution.

Parameters
attributeName [in] The name of the common attribute type for all node types in the graph which will store persistently the results generated by the execution of the algorithm.


SparkseeNet: Member List

  • algorithms
  • StrongConnectivity
com.sparsity.sparksee.algorithms.StrongConnectivity Member List

This is the complete list of members for com.sparsity.sparksee.algorithms.StrongConnectivity, including all inherited members.

AddAllEdgeTypes(com.sparsity.sparksee.gdb.EdgesDirection dir) | com.sparsity.sparksee.algorithms.StrongConnectivity
AddAllNodeTypes() | com.sparsity.sparksee.algorithms.StrongConnectivity
AddEdgeType(int type, com.sparsity.sparksee.gdb.EdgesDirection dir) | com.sparsity.sparksee.algorithms.StrongConnectivity
AddNodeType(int t) | com.sparsity.sparksee.algorithms.StrongConnectivity
Close() | com.sparsity.sparksee.algorithms.Connectivity
ExcludeEdges(com.sparsity.sparksee.gdb.Objects edges) | com.sparsity.sparksee.algorithms.StrongConnectivity
ExcludeNodes(com.sparsity.sparksee.gdb.Objects nodes) | com.sparsity.sparksee.algorithms.StrongConnectivity
GetConnectedComponents() | com.sparsity.sparksee.algorithms.StrongConnectivity
IsClosed() | com.sparsity.sparksee.algorithms.Connectivity
Run() | com.sparsity.sparksee.algorithms.StrongConnectivity
SetMaterializedAttribute(System.String attributeName) | com.sparsity.sparksee.algorithms.StrongConnectivity


SparkseeNet: com.sparsity.sparksee.algorithms.StrongConnectivityGabow Class Reference

  • algorithms
  • StrongConnectivityGabow
Public Member Functions | List of all members
com.sparsity.sparksee.algorithms.StrongConnectivityGabow Class Reference

This class can be used to solve the problem of finding strongly connected components in a directed graph. More...

Inheritance diagram for com.sparsity.sparksee.algorithms.StrongConnectivityGabow:
Collaboration diagram for com.sparsity.sparksee.algorithms.StrongConnectivityGabow:

Public Member Functions

void | AddAllNodeTypes ()
Allows connectivity through all node types of the graph.
StrongConnectivityGabow (com.sparsity.sparksee.gdb.Session session)
Creates a new instance of StrongConnectivityGabow.
void | ExcludeNodes (com.sparsity.sparksee.gdb.Objects nodes)
Set which nodes can't be used.
void | AddEdgeType (int type, com.sparsity.sparksee.gdb.EdgesDirection dir)
Allows connectivity through edges of the given type.
void | Run ()
Executes the algorithm.
void | AddNodeType (int t)
Allows connectivity through nodes of the given type.
void | SetMaterializedAttribute (System.String attributeName)
Creates a new common attribute type for all node types in the graph in order to store, persistently, the results related to the connected components found while executing this algorithm.
void | ExcludeEdges (com.sparsity.sparksee.gdb.Objects edges)
Set which edges can't be used.
void | AddAllEdgeTypes (com.sparsity.sparksee.gdb.EdgesDirection dir)
Allows connectivity through all edge types of the graph.
com.sparsity.sparksee.algorithms.ConnectedComponents GetConnectedComponents ()
Returns the results generated by the execution of the algorithm.
boolean | IsClosed ()
Gets if Connectivity instance has been closed or not.
void | Close ()
Closes the Connectivity instance.

Detailed Description

This class can be used to solve the problem of finding strongly connected components in a directed graph.

It consists in finding components where every pair (u,v) of nodes contained in it has a path from u to v using the specified direction for each edge type. This implementation is based on the Gabow algorithm.

It is possible to set some restrictions after constructing a new instance of this class and before running it in order to limit the results.

After the execution, we can retrieve the results stored in an instance of the ConnectedComponents class using the GetConnectedComponents method.

Check out the 'Algorithms' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

com.sparsity.sparksee.algorithms.StrongConnectivityGabow.StrongConnectivityGabow ( com.sparsity.sparksee.gdb.Session session )

Creates a new instance of StrongConnectivityGabow.

After creating this instance is required to indicate the set of edge types and the set of node types which will be navigated through while traversing the graph in order to find the strong connected components.

Parameters
session [in] Session to get the graph from and calculate the connectivity

Member Function Documentation

void com.sparsity.sparksee.algorithms.StrongConnectivityGabow.AddAllEdgeTypes ( com.sparsity.sparksee.gdb.EdgesDirection dir )

Allows connectivity through all edge types of the graph.

Parameters
dir [in] Edge direction.
void com.sparsity.sparksee.algorithms.StrongConnectivityGabow.AddEdgeType | ( | int | type,
 |  | com.sparsity.sparksee.gdb.EdgesDirection | dir
 | ) |  |

Allows connectivity through edges of the given type.

Parameters
type | [in] Edge type.
dir | [in] Edge direction.
void com.sparsity.sparksee.algorithms.StrongConnectivityGabow.AddNodeType ( int t )

Allows connectivity through nodes of the given type.

Parameters
t null
void com.sparsity.sparksee.algorithms.Connectivity.Close ( )
inherited

Closes the Connectivity instance.

It must be called to ensure the integrity of all data.

void com.sparsity.sparksee.algorithms.StrongConnectivityGabow.ExcludeEdges ( com.sparsity.sparksee.gdb.Objects edges )

Set which edges can't be used.

This will replace any previously specified set of excluded edges. Should only be used to exclude the usage of specific edges from allowed edge types because it's less efficient than not allowing an edge type.

Parameters
edges [in] A set of edge identifiers that must be kept intact until the destruction of the class.
void com.sparsity.sparksee.algorithms.StrongConnectivityGabow.ExcludeNodes ( com.sparsity.sparksee.gdb.Objects nodes )

Set which nodes can't be used.

This will replace any previously specified set of excluded nodes. Should only be used to exclude the usage of specific nodes from allowed node types because it's less efficient than not allowing a node type.

Parameters
nodes [in] A set of node identifiers that must be kept intact until the destruction of the class.
com.sparsity.sparksee.algorithms.ConnectedComponents com.sparsity.sparksee.algorithms.StrongConnectivityGabow.GetConnectedComponents ( )

Returns the results generated by the execution of the algorithm.

These results contain information related to the connected components found as the number of different components, the set of nodes contained in each component or many other data.

Returns
Returns an instance of the class ConnectedComponents which contain information related to the connected components found.
boolean com.sparsity.sparksee.algorithms.Connectivity.IsClosed ( )
inherited

Gets if Connectivity instance has been closed or not.

See Also
Close()
Returns
TRUE if the Connectivity instance has been closed, FALSE otherwise.
void com.sparsity.sparksee.algorithms.StrongConnectivityGabow.SetMaterializedAttribute ( System.String attributeName )

Creates a new common attribute type for all node types in the graph in order to store, persistently, the results related to the connected components found while executing this algorithm.

Whenever the user wants to retrieve the results, even when the graph has been closed and opened again, it is only necessary to create a new instance of the class ConnectedComponents indicating the graph and the name of the common attribute type which stores the results. This instance will have all the information related to the connected components found in the moment of the execution of the algorithm that stored this data.

It is possible to run the algorithm without specifying this parameter in order to avoid materializing the results of the execution.

Parameters
attributeName [in] The name of the common attribute type for all node types in the graph which will store persistently the results generated by the execution of the algorithm.


SparkseeNet: Member List

  • algorithms
  • StrongConnectivityGabow
com.sparsity.sparksee.algorithms.StrongConnectivityGabow Member List

This is the complete list of members for com.sparsity.sparksee.algorithms.StrongConnectivityGabow, including all inherited members.

AddAllEdgeTypes(com.sparsity.sparksee.gdb.EdgesDirection dir) | com.sparsity.sparksee.algorithms.StrongConnectivityGabow
AddAllNodeTypes() | com.sparsity.sparksee.algorithms.StrongConnectivityGabow
AddEdgeType(int type, com.sparsity.sparksee.gdb.EdgesDirection dir) | com.sparsity.sparksee.algorithms.StrongConnectivityGabow
AddNodeType(int t) | com.sparsity.sparksee.algorithms.StrongConnectivityGabow
Close() | com.sparsity.sparksee.algorithms.Connectivity
ExcludeEdges(com.sparsity.sparksee.gdb.Objects edges) | com.sparsity.sparksee.algorithms.StrongConnectivityGabow
ExcludeNodes(com.sparsity.sparksee.gdb.Objects nodes) | com.sparsity.sparksee.algorithms.StrongConnectivityGabow
GetConnectedComponents() | com.sparsity.sparksee.algorithms.StrongConnectivityGabow
IsClosed() | com.sparsity.sparksee.algorithms.Connectivity
Run() | com.sparsity.sparksee.algorithms.StrongConnectivityGabow
SetMaterializedAttribute(System.String attributeName) | com.sparsity.sparksee.algorithms.StrongConnectivityGabow
StrongConnectivityGabow(com.sparsity.sparksee.gdb.Session session) | com.sparsity.sparksee.algorithms.StrongConnectivityGabow


SparkseeNet: com.sparsity.sparksee.algorithms.Traversal Class Reference

  • algorithms
  • Traversal
Public Member Functions | List of all members
com.sparsity.sparksee.algorithms.Traversal Class Reference

Traversal class. More...

Inheritance diagram for com.sparsity.sparksee.algorithms.Traversal:

Public Member Functions

void | AddNodeType (int type)
Allows for traversing nodes of the given type.
bool | HasNext ()
Gets if there are more objects to be traversed.
void | ExcludeNodes (com.sparsity.sparksee.gdb.Objects nodes)
Set which nodes can't be used.
void | SetMaximumHops (int maxhops)
Sets the maximum hops restriction.
void | AddAllEdgeTypes (com.sparsity.sparksee.gdb.EdgesDirection dir)
Allows for traversing all edge types of the graph.
int | GetCurrentDepth ()
Returns the depth of the current node.
boolean | IsClosed ()
Gets if Traversal instance has been closed or not.
void | AddAllNodeTypes ()
Allows for traversing all node types of the graph.
void | Close ()
Closes the Traversal instance.
void | AddEdgeType (int type, com.sparsity.sparksee.gdb.EdgesDirection dir)
Allows for traversing edges of the given type.
long | Next ()
Gets the next object of the traversal.
void | ExcludeEdges (com.sparsity.sparksee.gdb.Objects edges)
Set which edges can't be used.

Detailed Description

Traversal class.

Any class implementing this abstract class can be used to traverse a graph.

Once the instance has been created and the allowed node and edge types has been set, it can be used as an iterator, retrieving the next object identifier of the traversal until there are no more.

Check out the 'Algorithms' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

void com.sparsity.sparksee.algorithms.Traversal.AddAllEdgeTypes ( com.sparsity.sparksee.gdb.EdgesDirection dir )

Allows for traversing all edge types of the graph.

Parameters
dir [in] Edge direction.
void com.sparsity.sparksee.algorithms.Traversal.AddEdgeType | ( | int | type,
 |  | com.sparsity.sparksee.gdb.EdgesDirection | dir
 | ) |  |

Allows for traversing edges of the given type.

Parameters
type | [in] Edge type.
dir | [in] Edge direction.
void com.sparsity.sparksee.algorithms.Traversal.AddNodeType ( int type )

Allows for traversing nodes of the given type.

Parameters
type The node type to add
void com.sparsity.sparksee.algorithms.Traversal.Close ( )

Closes the Traversal instance.

It must be called to ensure the integrity of all data.

void com.sparsity.sparksee.algorithms.Traversal.ExcludeEdges ( com.sparsity.sparksee.gdb.Objects edges )

Set which edges can't be used.

This will replace any previously specified set of excluded edges. Should only be used to exclude the usage of specific edges from allowed edge types because it's less efficient than not allowing an edge type.

Parameters
edges [in] A set of edge identifiers that must be kept intact until the destruction of the class.
void com.sparsity.sparksee.algorithms.Traversal.ExcludeNodes ( com.sparsity.sparksee.gdb.Objects nodes )

Set which nodes can't be used.

This will replace any previously specified set of excluded nodes. Should only be used to exclude the usage of specific nodes from allowed node types because it's less efficient than not allowing a node type.

Parameters
nodes [in] A set of node identifiers that must be kept intact until the destruction of the class.
int com.sparsity.sparksee.algorithms.Traversal.GetCurrentDepth ( )

Returns the depth of the current node.

That is, it returns the depth of the node returned in the last call to Next().

Returns
The depth of the current node.
bool com.sparsity.sparksee.algorithms.Traversal.HasNext ( )

Gets if there are more objects to be traversed.

Returns
TRUE if there are more objects, FALSE otherwise.
boolean com.sparsity.sparksee.algorithms.Traversal.IsClosed ( )

Gets if Traversal instance has been closed or not.

See Also
Close()
Returns
TRUE if the Traversal instance has been closed, FALSE otherwise.
long com.sparsity.sparksee.algorithms.Traversal.Next ( )

Gets the next object of the traversal.

Returns
A node or edge identifier.
void com.sparsity.sparksee.algorithms.Traversal.SetMaximumHops ( int maxhops )

Sets the maximum hops restriction.

All paths longer than the maximum hops restriction will be ignored.

Parameters
maxhops [in] The maximum hops restriction. It must be positive or zero. Zero, the default value, means unlimited.


SparkseeNet: Member List

  • algorithms
  • Traversal
com.sparsity.sparksee.algorithms.Traversal Member List

This is the complete list of members for com.sparsity.sparksee.algorithms.Traversal, including all inherited members.

AddAllEdgeTypes(com.sparsity.sparksee.gdb.EdgesDirection dir) | com.sparsity.sparksee.algorithms.Traversal
AddAllNodeTypes() | com.sparsity.sparksee.algorithms.Traversal
AddEdgeType(int type, com.sparsity.sparksee.gdb.EdgesDirection dir) | com.sparsity.sparksee.algorithms.Traversal
AddNodeType(int type) | com.sparsity.sparksee.algorithms.Traversal
Close() | com.sparsity.sparksee.algorithms.Traversal
ExcludeEdges(com.sparsity.sparksee.gdb.Objects edges) | com.sparsity.sparksee.algorithms.Traversal
ExcludeNodes(com.sparsity.sparksee.gdb.Objects nodes) | com.sparsity.sparksee.algorithms.Traversal
GetCurrentDepth() | com.sparsity.sparksee.algorithms.Traversal
HasNext() | com.sparsity.sparksee.algorithms.Traversal
IsClosed() | com.sparsity.sparksee.algorithms.Traversal
Next() | com.sparsity.sparksee.algorithms.Traversal
SetMaximumHops(int maxhops) | com.sparsity.sparksee.algorithms.Traversal


SparkseeNet: com.sparsity.sparksee.algorithms.TraversalBFS Class Reference

  • algorithms
  • TraversalBFS
Public Member Functions | List of all members
com.sparsity.sparksee.algorithms.TraversalBFS Class Reference

Breadth-First Search implementation of Traversal. More...

Inheritance diagram for com.sparsity.sparksee.algorithms.TraversalBFS:
Collaboration diagram for com.sparsity.sparksee.algorithms.TraversalBFS:

Public Member Functions

TraversalBFS (com.sparsity.sparksee.gdb.Session session, long node)
Creates a new instance.
void | AddNodeType (int type)
Allows for traversing nodes of the given type.
void | AddAllNodeTypes ()
Allows for traversing all node types of the graph.
bool | HasNext ()
Gets if there are more objects to be traversed.
void | ExcludeNodes (com.sparsity.sparksee.gdb.Objects nodes)
Set which nodes can't be used.
void | AddEdgeType (int type, com.sparsity.sparksee.gdb.EdgesDirection dir)
Allows for traversing edges of the given type.
long | Next ()
Gets the next object of the traversal.
int | GetCurrentDepth ()
Returns the depth of the current node.
void | SetMaximumHops (int maxhops)
Sets the maximum hops restriction.
void | ExcludeEdges (com.sparsity.sparksee.gdb.Objects edges)
Set which edges can't be used.
void | AddAllEdgeTypes (com.sparsity.sparksee.gdb.EdgesDirection dir)
Allows for traversing all edge types of the graph.
boolean | IsClosed ()
Gets if Traversal instance has been closed or not.
void | Close ()
Closes the Traversal instance.

Detailed Description

Breadth-First Search implementation of Traversal.

Starting from a source node, it visits all its neighbors at distance 1, then all its neighbors at distance 2, and so on.

Check out the 'Algorithms' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

com.sparsity.sparksee.algorithms.TraversalBFS.TraversalBFS | ( | com.sparsity.sparksee.gdb.Session | session,
 |  | long | node
 | ) |  |

Creates a new instance.

Parameters
session | [in] Session to get the graph from and perform traversal.
node | [in] Node to start traversal from.

Member Function Documentation

void com.sparsity.sparksee.algorithms.TraversalBFS.AddAllEdgeTypes ( com.sparsity.sparksee.gdb.EdgesDirection dir )

Allows for traversing all edge types of the graph.

Parameters
dir [in] Edge direction.
void com.sparsity.sparksee.algorithms.TraversalBFS.AddEdgeType | ( | int | type,
 |  | com.sparsity.sparksee.gdb.EdgesDirection | dir
 | ) |  |

Allows for traversing edges of the given type.

Parameters
type | [in] Edge type.
dir | [in] Edge direction.
void com.sparsity.sparksee.algorithms.TraversalBFS.AddNodeType ( int type )

Allows for traversing nodes of the given type.

Parameters
type The node type to add
void com.sparsity.sparksee.algorithms.Traversal.Close ( )
inherited

Closes the Traversal instance.

It must be called to ensure the integrity of all data.

void com.sparsity.sparksee.algorithms.TraversalBFS.ExcludeEdges ( com.sparsity.sparksee.gdb.Objects edges )

Set which edges can't be used.

This will replace any previously specified set of excluded edges. Should only be used to exclude the usage of specific edges from allowed edge types because it's less efficient than not allowing an edge type.

Parameters
edges [in] A set of edge identifiers that must be kept intact until the destruction of the class.
void com.sparsity.sparksee.algorithms.TraversalBFS.ExcludeNodes ( com.sparsity.sparksee.gdb.Objects nodes )

Set which nodes can't be used.

This will replace any previously specified set of excluded nodes. Should only be used to exclude the usage of specific nodes from allowed node types because it's less efficient than not allowing a node type.

Parameters
nodes [in] A set of node identifiers that must be kept intact until the destruction of the class.
int com.sparsity.sparksee.algorithms.TraversalBFS.GetCurrentDepth ( )

Returns the depth of the current node.

That is, it returns the depth of the node returned in the last call to Next().

Returns
The depth of the current node.
bool com.sparsity.sparksee.algorithms.TraversalBFS.HasNext ( )

Gets if there are more objects to be traversed.

Returns
TRUE if there are more objects, FALSE otherwise.
boolean com.sparsity.sparksee.algorithms.Traversal.IsClosed ( )
inherited

Gets if Traversal instance has been closed or not.

See Also
Close()
Returns
TRUE if the Traversal instance has been closed, FALSE otherwise.
long com.sparsity.sparksee.algorithms.TraversalBFS.Next ( )

Gets the next object of the traversal.

Returns
A node or edge identifier.
void com.sparsity.sparksee.algorithms.TraversalBFS.SetMaximumHops ( int maxhops )

Sets the maximum hops restriction.

All paths longer than the maximum hops restriction will be ignored.

Parameters
maxhops [in] The maximum hops restriction. It must be positive or zero. Zero, the default value, means unlimited.


SparkseeNet: Member List

  • algorithms
  • TraversalBFS
com.sparsity.sparksee.algorithms.TraversalBFS Member List

This is the complete list of members for com.sparsity.sparksee.algorithms.TraversalBFS, including all inherited members.

AddAllEdgeTypes(com.sparsity.sparksee.gdb.EdgesDirection dir) | com.sparsity.sparksee.algorithms.TraversalBFS
AddAllNodeTypes() | com.sparsity.sparksee.algorithms.TraversalBFS
AddEdgeType(int type, com.sparsity.sparksee.gdb.EdgesDirection dir) | com.sparsity.sparksee.algorithms.TraversalBFS
AddNodeType(int type) | com.sparsity.sparksee.algorithms.TraversalBFS
Close() | com.sparsity.sparksee.algorithms.Traversal
ExcludeEdges(com.sparsity.sparksee.gdb.Objects edges) | com.sparsity.sparksee.algorithms.TraversalBFS
ExcludeNodes(com.sparsity.sparksee.gdb.Objects nodes) | com.sparsity.sparksee.algorithms.TraversalBFS
GetCurrentDepth() | com.sparsity.sparksee.algorithms.TraversalBFS
HasNext() | com.sparsity.sparksee.algorithms.TraversalBFS
IsClosed() | com.sparsity.sparksee.algorithms.Traversal
Next() | com.sparsity.sparksee.algorithms.TraversalBFS
SetMaximumHops(int maxhops) | com.sparsity.sparksee.algorithms.TraversalBFS
TraversalBFS(com.sparsity.sparksee.gdb.Session session, long node) | com.sparsity.sparksee.algorithms.TraversalBFS


SparkseeNet: com.sparsity.sparksee.algorithms.TraversalDFS Class Reference

  • algorithms
  • TraversalDFS
Public Member Functions | List of all members
com.sparsity.sparksee.algorithms.TraversalDFS Class Reference

Depth-First Search (DFS) implementation of Traversal. More...

Inheritance diagram for com.sparsity.sparksee.algorithms.TraversalDFS:
Collaboration diagram for com.sparsity.sparksee.algorithms.TraversalDFS:

Public Member Functions

void | AddNodeType (int type)
Allows for traversing nodes of the given type.
void | AddAllNodeTypes ()
Allows for traversing all node types of the graph.
bool | HasNext ()
Gets if there are more objects to be traversed.
void | ExcludeNodes (com.sparsity.sparksee.gdb.Objects nodes)
Set which nodes can't be used.
void | AddEdgeType (int type, com.sparsity.sparksee.gdb.EdgesDirection dir)
Allows for traversing edges of the given type.
TraversalDFS (com.sparsity.sparksee.gdb.Session session, long node)
Creates a new instance.
long | Next ()
Gets the next object of the traversal.
int | GetCurrentDepth ()
Returns the depth of the current node.
void | SetMaximumHops (int maxhops)
Sets the maximum hops restriction.
void | ExcludeEdges (com.sparsity.sparksee.gdb.Objects edges)
Set which edges can't be used.
void | AddAllEdgeTypes (com.sparsity.sparksee.gdb.EdgesDirection dir)
Allows for traversing all edge types of the graph.
boolean | IsClosed ()
Gets if Traversal instance has been closed or not.
void | Close ()
Closes the Traversal instance.

Detailed Description

Depth-First Search (DFS) implementation of Traversal.

Starting from a source or root node, it visits as far as possible along each branch before backtracking.

Check out the 'Algorithms' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

com.sparsity.sparksee.algorithms.TraversalDFS.TraversalDFS | ( | com.sparsity.sparksee.gdb.Session | session,
 |  | long | node
 | ) |  |

Creates a new instance.

Parameters
session | [in] Session to get the graph from and perform traversal.
node | [in] Node to start traversal from.

Member Function Documentation

void com.sparsity.sparksee.algorithms.TraversalDFS.AddAllEdgeTypes ( com.sparsity.sparksee.gdb.EdgesDirection dir )

Allows for traversing all edge types of the graph.

Parameters
dir [in] Edge direction.
void com.sparsity.sparksee.algorithms.TraversalDFS.AddEdgeType | ( | int | type,
 |  | com.sparsity.sparksee.gdb.EdgesDirection | dir
 | ) |  |

Allows for traversing edges of the given type.

Parameters
type | [in] Edge type.
dir | [in] Edge direction.
void com.sparsity.sparksee.algorithms.TraversalDFS.AddNodeType ( int type )

Allows for traversing nodes of the given type.

Parameters
type The node type to add
void com.sparsity.sparksee.algorithms.Traversal.Close ( )
inherited

Closes the Traversal instance.

It must be called to ensure the integrity of all data.

void com.sparsity.sparksee.algorithms.TraversalDFS.ExcludeEdges ( com.sparsity.sparksee.gdb.Objects edges )

Set which edges can't be used.

This will replace any previously specified set of excluded edges. Should only be used to exclude the usage of specific edges from allowed edge types because it's less efficient than not allowing an edge type.

Parameters
edges [in] A set of edge identifiers that must be kept intact until the destruction of the class.
void com.sparsity.sparksee.algorithms.TraversalDFS.ExcludeNodes ( com.sparsity.sparksee.gdb.Objects nodes )

Set which nodes can't be used.

This will replace any previously specified set of excluded nodes. Should only be used to exclude the usage of specific nodes from allowed node types because it's less efficient than not allowing a node type.

Parameters
nodes [in] A set of node identifiers that must be kept intact until the destruction of the class.
int com.sparsity.sparksee.algorithms.TraversalDFS.GetCurrentDepth ( )

Returns the depth of the current node.

That is, it returns the depth of the node returned in the last call to Next().

Returns
The depth of the current node.
bool com.sparsity.sparksee.algorithms.TraversalDFS.HasNext ( )

Gets if there are more objects to be traversed.

Returns
TRUE if there are more objects, FALSE otherwise.
boolean com.sparsity.sparksee.algorithms.Traversal.IsClosed ( )
inherited

Gets if Traversal instance has been closed or not.

See Also
Close()
Returns
TRUE if the Traversal instance has been closed, FALSE otherwise.
long com.sparsity.sparksee.algorithms.TraversalDFS.Next ( )

Gets the next object of the traversal.

Returns
A node or edge identifier.
void com.sparsity.sparksee.algorithms.TraversalDFS.SetMaximumHops ( int maxhops )

Sets the maximum hops restriction.

All paths longer than the maximum hops restriction will be ignored.

Parameters
maxhops [in] The maximum hops restriction. It must be positive or zero. Zero, the default value, means unlimited.


SparkseeNet: Member List

  • algorithms
  • TraversalDFS
com.sparsity.sparksee.algorithms.TraversalDFS Member List

This is the complete list of members for com.sparsity.sparksee.algorithms.TraversalDFS, including all inherited members.

AddAllEdgeTypes(com.sparsity.sparksee.gdb.EdgesDirection dir) | com.sparsity.sparksee.algorithms.TraversalDFS
AddAllNodeTypes() | com.sparsity.sparksee.algorithms.TraversalDFS
AddEdgeType(int type, com.sparsity.sparksee.gdb.EdgesDirection dir) | com.sparsity.sparksee.algorithms.TraversalDFS
AddNodeType(int type) | com.sparsity.sparksee.algorithms.TraversalDFS
Close() | com.sparsity.sparksee.algorithms.Traversal
ExcludeEdges(com.sparsity.sparksee.gdb.Objects edges) | com.sparsity.sparksee.algorithms.TraversalDFS
ExcludeNodes(com.sparsity.sparksee.gdb.Objects nodes) | com.sparsity.sparksee.algorithms.TraversalDFS
GetCurrentDepth() | com.sparsity.sparksee.algorithms.TraversalDFS
HasNext() | com.sparsity.sparksee.algorithms.TraversalDFS
IsClosed() | com.sparsity.sparksee.algorithms.Traversal
Next() | com.sparsity.sparksee.algorithms.TraversalDFS
SetMaximumHops(int maxhops) | com.sparsity.sparksee.algorithms.TraversalDFS
TraversalDFS(com.sparsity.sparksee.gdb.Session session, long node) | com.sparsity.sparksee.algorithms.TraversalDFS


SparkseeNet: com.sparsity.sparksee.algorithms.WeakConnectivity Class Reference

  • algorithms
  • WeakConnectivity
Public Member Functions | List of all members
com.sparsity.sparksee.algorithms.WeakConnectivity Class Reference

WeakConnectivity class. More...

Inheritance diagram for com.sparsity.sparksee.algorithms.WeakConnectivity:
Collaboration diagram for com.sparsity.sparksee.algorithms.WeakConnectivity:

Public Member Functions

void | AddEdgeType (int type)
Allows connectivity through edges of the given type.
void | AddAllNodeTypes ()
Allows connectivity through all node types of the graph.
void | AddAllEdgeTypes ()
Allows connectivity through all edge types of the graph.
void | Run ()
Runs the algorithm in order to find the connected components.
void | ExcludeNodes (com.sparsity.sparksee.gdb.Objects nodes)
Set which nodes can't be used.
void | AddNodeType (int t)
Allows connectivity through nodes of the given type.
void | SetMaterializedAttribute (System.String attributeName)
Creates a new common attribute type for all node types in the graph in order to store, persistently, the results related to the connected components found while executing this algorithm.
void | ExcludeEdges (com.sparsity.sparksee.gdb.Objects edges)
Set which edges can't be used.
com.sparsity.sparksee.algorithms.ConnectedComponents GetConnectedComponents ()
Returns the results generated by the execution of the algorithm.
boolean | IsClosed ()
Gets if Connectivity instance has been closed or not.
void | Close ()
Closes the Connectivity instance.

Detailed Description

WeakConnectivity class.

Any class implementing this abstract class can be used to solve the problem of finding weakly connected components in an undirected graph or in a directed graph which will be considered as an undirected one.

It consists in finding components where every pair (u,v) of nodes contained in it has a path from u to v and from v to u.

It is possible to set some restrictions after constructing a new instance of this class and before running it in order to limit the results.

After the execution, we can retrieve the results stored in an instance of the ConnectedComponents class using the getConnectedComponents method.

Check out the 'Algorithms' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

void com.sparsity.sparksee.algorithms.WeakConnectivity.AddAllEdgeTypes ( )

Allows connectivity through all edge types of the graph.

In a weak connectivity the edges can be used in Any direction.

void com.sparsity.sparksee.algorithms.WeakConnectivity.AddEdgeType ( int type )

Allows connectivity through edges of the given type.

In a weak connectivity the edges can be used in Any direction.

Parameters
type [in] Edge type.
void com.sparsity.sparksee.algorithms.WeakConnectivity.AddNodeType ( int t )

Allows connectivity through nodes of the given type.

Parameters
t null
void com.sparsity.sparksee.algorithms.Connectivity.Close ( )
inherited

Closes the Connectivity instance.

It must be called to ensure the integrity of all data.

void com.sparsity.sparksee.algorithms.WeakConnectivity.ExcludeEdges ( com.sparsity.sparksee.gdb.Objects edges )

Set which edges can't be used.

This will replace any previously specified set of excluded edges. Should only be used to exclude the usage of specific edges from allowed edge types because it's less efficient than not allowing an edge type.

Parameters
edges [in] A set of edge identifiers that must be kept intact until the destruction of the class.
void com.sparsity.sparksee.algorithms.WeakConnectivity.ExcludeNodes ( com.sparsity.sparksee.gdb.Objects nodes )

Set which nodes can't be used.

This will replace any previously specified set of excluded nodes. Should only be used to exclude the usage of specific nodes from allowed node types because it's less efficient than not allowing a node type.

Parameters
nodes [in] A set of node identifiers that must be kept intact until the destruction of the class.
com.sparsity.sparksee.algorithms.ConnectedComponents com.sparsity.sparksee.algorithms.WeakConnectivity.GetConnectedComponents ( )

Returns the results generated by the execution of the algorithm.

These results contain information related to the connected components found as the number of different components, the set of nodes contained in each component or many other data.

Returns
Returns an instance of the class ConnectedComponents which contain information related to the connected components found.
boolean com.sparsity.sparksee.algorithms.Connectivity.IsClosed ( )
inherited

Gets if Connectivity instance has been closed or not.

See Also
Close()
Returns
TRUE if the Connectivity instance has been closed, FALSE otherwise.
void com.sparsity.sparksee.algorithms.WeakConnectivity.Run ( )

Runs the algorithm in order to find the connected components.

This method can be called only once.

void com.sparsity.sparksee.algorithms.WeakConnectivity.SetMaterializedAttribute ( System.String attributeName )

Creates a new common attribute type for all node types in the graph in order to store, persistently, the results related to the connected components found while executing this algorithm.

Whenever the user wants to retrieve the results, even when the graph has been closed and opened again, it is only necessary to create a new instance of the class ConnectedComponents indicating the graph and the name of the common attribute type which stores the results. This instance will have all the information related to the connected components found in the moment of the execution of the algorithm that stored this data.

It is possible to run the algorithm without specifying this parameter in order to avoid materializing the results of the execution.

Parameters
attributeName [in] The name of the common attribute type for all node types in the graph which will store persistently the results generated by the execution of the algorithm.


SparkseeNet: Member List

  • algorithms
  • WeakConnectivity
com.sparsity.sparksee.algorithms.WeakConnectivity Member List

This is the complete list of members for com.sparsity.sparksee.algorithms.WeakConnectivity, including all inherited members.

AddAllEdgeTypes() | com.sparsity.sparksee.algorithms.WeakConnectivity
AddAllNodeTypes() | com.sparsity.sparksee.algorithms.WeakConnectivity
AddEdgeType(int type) | com.sparsity.sparksee.algorithms.WeakConnectivity
AddNodeType(int t) | com.sparsity.sparksee.algorithms.WeakConnectivity
Close() | com.sparsity.sparksee.algorithms.Connectivity
ExcludeEdges(com.sparsity.sparksee.gdb.Objects edges) | com.sparsity.sparksee.algorithms.WeakConnectivity
ExcludeNodes(com.sparsity.sparksee.gdb.Objects nodes) | com.sparsity.sparksee.algorithms.WeakConnectivity
GetConnectedComponents() | com.sparsity.sparksee.algorithms.WeakConnectivity
IsClosed() | com.sparsity.sparksee.algorithms.Connectivity
Run() | com.sparsity.sparksee.algorithms.WeakConnectivity
SetMaterializedAttribute(System.String attributeName) | com.sparsity.sparksee.algorithms.WeakConnectivity


SparkseeNet: com.sparsity.sparksee.algorithms.WeakConnectivityDFS Class Reference

  • algorithms
  • WeakConnectivityDFS
Public Member Functions | List of all members
com.sparsity.sparksee.algorithms.WeakConnectivityDFS Class Reference

WeakConnectivityDFS class. More...

Inheritance diagram for com.sparsity.sparksee.algorithms.WeakConnectivityDFS:
Collaboration diagram for com.sparsity.sparksee.algorithms.WeakConnectivityDFS:

Public Member Functions

void | AddEdgeType (int type)
Allows connectivity through edges of the given type.
void | AddAllNodeTypes ()
Allows connectivity through all node types of the graph.
void | AddAllEdgeTypes ()
Allows connectivity through all edge types of the graph.
void | ExcludeNodes (com.sparsity.sparksee.gdb.Objects nodes)
Set which nodes can't be used.
void | Run ()
Executes the algorithm.
void | AddNodeType (int t)
Allows connectivity through nodes of the given type.
void | SetMaterializedAttribute (System.String attributeName)
Creates a new common attribute type for all node types in the graph in order to store, persistently, the results related to the connected components found while executing this algorithm.
void | ExcludeEdges (com.sparsity.sparksee.gdb.Objects edges)
Set which edges can't be used.
WeakConnectivityDFS (com.sparsity.sparksee.gdb.Session session)
Creates a new instance of WeakConnectivityDFS.
com.sparsity.sparksee.algorithms.ConnectedComponents GetConnectedComponents ()
Returns the results generated by the execution of the algorithm.
boolean | IsClosed ()
Gets if Connectivity instance has been closed or not.
void | Close ()
Closes the Connectivity instance.

Detailed Description

WeakConnectivityDFS class.

This class can be used to solve the problem of finding weakly connected components in an undirected graph or in a directed graph which will be considered as an undirected one.

It consists in finding components where every pair (u,v) of nodes contained in it has a path from u to v and from v to u. This implementation is based on the Depth-First Search (DFS) algorithm.

It is possible to set some restrictions after constructing a new instance of this class and before running it in order to limit the results.

After the execution, we can retrieve the results stored in an instance of the ConnectedComponents class using the getConnectedComponents method.

Check out the 'Algorithms' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

com.sparsity.sparksee.algorithms.WeakConnectivityDFS.WeakConnectivityDFS ( com.sparsity.sparksee.gdb.Session session )

Creates a new instance of WeakConnectivityDFS.

After creating this instance is required to indicate the set of edge types and the set of node types which will be navigated through while traversing the graph in order to find the weak connected components.

Parameters
session [in] Session to get the graph from and calculate the connectivity

Member Function Documentation

void com.sparsity.sparksee.algorithms.WeakConnectivityDFS.AddAllEdgeTypes ( )

Allows connectivity through all edge types of the graph.

In a weak connectivity the edges can be used in Any direction.

void com.sparsity.sparksee.algorithms.WeakConnectivityDFS.AddEdgeType ( int type )

Allows connectivity through edges of the given type.

In a weak connectivity the edges can be used in Any direction.

Parameters
type [in] Edge type.
void com.sparsity.sparksee.algorithms.WeakConnectivityDFS.AddNodeType ( int t )

Allows connectivity through nodes of the given type.

Parameters
t null
void com.sparsity.sparksee.algorithms.Connectivity.Close ( )
inherited

Closes the Connectivity instance.

It must be called to ensure the integrity of all data.

void com.sparsity.sparksee.algorithms.WeakConnectivityDFS.ExcludeEdges ( com.sparsity.sparksee.gdb.Objects edges )

Set which edges can't be used.

This will replace any previously specified set of excluded edges. Should only be used to exclude the usage of specific edges from allowed edge types because it's less efficient than not allowing an edge type.

Parameters
edges [in] A set of edge identifiers that must be kept intact until the destruction of the class.
void com.sparsity.sparksee.algorithms.WeakConnectivityDFS.ExcludeNodes ( com.sparsity.sparksee.gdb.Objects nodes )

Set which nodes can't be used.

This will replace any previously specified set of excluded nodes. Should only be used to exclude the usage of specific nodes from allowed node types because it's less efficient than not allowing a node type.

Parameters
nodes [in] A set of node identifiers that must be kept intact until the destruction of the class.
com.sparsity.sparksee.algorithms.ConnectedComponents com.sparsity.sparksee.algorithms.WeakConnectivityDFS.GetConnectedComponents ( )

Returns the results generated by the execution of the algorithm.

These results contain information related to the connected components found as the number of different components, the set of nodes contained in each component or many other data.

Returns
Returns an instance of the class ConnectedComponents which contain information related to the connected components found.
boolean com.sparsity.sparksee.algorithms.Connectivity.IsClosed ( )
inherited

Gets if Connectivity instance has been closed or not.

See Also
Close()
Returns
TRUE if the Connectivity instance has been closed, FALSE otherwise.
void com.sparsity.sparksee.algorithms.WeakConnectivityDFS.SetMaterializedAttribute ( System.String attributeName )

Creates a new common attribute type for all node types in the graph in order to store, persistently, the results related to the connected components found while executing this algorithm.

Whenever the user wants to retrieve the results, even when the graph has been closed and opened again, it is only necessary to create a new instance of the class ConnectedComponents indicating the graph and the name of the common attribute type which stores the results. This instance will have all the information related to the connected components found in the moment of the execution of the algorithm that stored this data.

It is possible to run the algorithm without specifying this parameter in order to avoid materializing the results of the execution.

Parameters
attributeName [in] The name of the common attribute type for all node types in the graph which will store persistently the results generated by the execution of the algorithm.


SparkseeNet: Member List

  • algorithms
  • WeakConnectivityDFS
com.sparsity.sparksee.algorithms.WeakConnectivityDFS Member List

This is the complete list of members for com.sparsity.sparksee.algorithms.WeakConnectivityDFS, including all inherited members.

AddAllEdgeTypes() | com.sparsity.sparksee.algorithms.WeakConnectivityDFS
AddAllNodeTypes() | com.sparsity.sparksee.algorithms.WeakConnectivityDFS
AddEdgeType(int type) | com.sparsity.sparksee.algorithms.WeakConnectivityDFS
AddNodeType(int t) | com.sparsity.sparksee.algorithms.WeakConnectivityDFS
Close() | com.sparsity.sparksee.algorithms.Connectivity
ExcludeEdges(com.sparsity.sparksee.gdb.Objects edges) | com.sparsity.sparksee.algorithms.WeakConnectivityDFS
ExcludeNodes(com.sparsity.sparksee.gdb.Objects nodes) | com.sparsity.sparksee.algorithms.WeakConnectivityDFS
GetConnectedComponents() | com.sparsity.sparksee.algorithms.WeakConnectivityDFS
IsClosed() | com.sparsity.sparksee.algorithms.Connectivity
Run() | com.sparsity.sparksee.algorithms.WeakConnectivityDFS
SetMaterializedAttribute(System.String attributeName) | com.sparsity.sparksee.algorithms.WeakConnectivityDFS
WeakConnectivityDFS(com.sparsity.sparksee.gdb.Session session) | com.sparsity.sparksee.algorithms.WeakConnectivityDFS


SparkseeNet: com.sparsity.sparksee.gdb.Attribute Class Reference

  • gdb
  • Attribute
Public Member Functions | Static Public Attributes | List of all members
com.sparsity.sparksee.gdb.Attribute Class Reference

Attribute data class. More...

Public Member Functions

com.sparsity.sparksee.gdb.AttributeKind GetKind ()
Gets the attribute kind.
long | GetCount ()
Gets the number of non-NULL values.
bool | IsSessionAttribute ()
Check if it's a session attribute or a persistent one.
long | GetSize ()
Gets the number of different values.
int | GetTypeId ()
Gets the Sparksee type identifier.
com.sparsity.sparksee.gdb.DataType GetDataType ()
Gets the data type.
int | GetArraySize ()
Gets the number of elements in the array.
bool | IsArrayAttribute ()
Check if it's an array attribute.
int | GetId ()
Gets the Sparksee attribute identifier.
System.String | GetName ()
Gets the unique attribute name.

Static Public Attributes

static int InvalidAttribute
Invalid attribute identifier constant.

Detailed Description

Attribute data class.

It contains information about an attribute.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

int com.sparsity.sparksee.gdb.Attribute.GetArraySize ( )

Gets the number of elements in the array.

Returns
The size of the array
long com.sparsity.sparksee.gdb.Attribute.GetCount ( )

Gets the number of non-NULL values.

Returns
The number of non-NULL values.
com.sparsity.sparksee.gdb.DataType com.sparsity.sparksee.gdb.Attribute.GetDataType ( )

Gets the data type.

Returns
The DataType.
int com.sparsity.sparksee.gdb.Attribute.GetId ( )

Gets the Sparksee attribute identifier.

Returns
The Sparksee attribute identifier.
com.sparsity.sparksee.gdb.AttributeKind com.sparsity.sparksee.gdb.Attribute.GetKind ( )

Gets the attribute kind.

Returns
The AttributeKind.
System.String com.sparsity.sparksee.gdb.Attribute.GetName ( )

Gets the unique attribute name.

Returns
The unique attribute name.
long com.sparsity.sparksee.gdb.Attribute.GetSize ( )

Gets the number of different values.

Returns
The number of different values.
int com.sparsity.sparksee.gdb.Attribute.GetTypeId ( )

Gets the Sparksee type identifier.

Returns
The Sparksee type identifier.
bool com.sparsity.sparksee.gdb.Attribute.IsArrayAttribute ( )

Check if it's an array attribute.

Returns
True if it's an array attribute, or false otherwise.
bool com.sparsity.sparksee.gdb.Attribute.IsSessionAttribute ( )

Check if it's a session attribute or a persistent one.

Returns
True if it's a session attribute, or false otherwise.


SparkseeNet: Member List

  • gdb
  • Attribute
com.sparsity.sparksee.gdb.Attribute Member List

This is the complete list of members for com.sparsity.sparksee.gdb.Attribute, including all inherited members.

GetArraySize() | com.sparsity.sparksee.gdb.Attribute |
GetCount() | com.sparsity.sparksee.gdb.Attribute |
GetDataType() | com.sparsity.sparksee.gdb.Attribute |
GetId() | com.sparsity.sparksee.gdb.Attribute |
GetKind() | com.sparsity.sparksee.gdb.Attribute |
GetName() | com.sparsity.sparksee.gdb.Attribute |
GetSize() | com.sparsity.sparksee.gdb.Attribute |
GetTypeId() | com.sparsity.sparksee.gdb.Attribute |
InvalidAttribute | com.sparsity.sparksee.gdb.Attribute | static
IsArrayAttribute() | com.sparsity.sparksee.gdb.Attribute |
IsSessionAttribute() | com.sparsity.sparksee.gdb.Attribute |


SparkseeNet: com.sparsity.sparksee.gdb.AttributeList Class Reference

  • gdb
  • AttributeList
Public Member Functions | List of all members
com.sparsity.sparksee.gdb.AttributeList Class Reference

Sparksee attribute identifier list. More...

Public Member Functions

void | Clear ()
Clears the list.
AttributeList (System.Collections.Generic.ICollection< int > col)
Creates a new instance from an integer collection.
AttributeList ()
Constructor.
com.sparsity.sparksee.gdb.AttributeListIterator Iterator ()
Gets a new AttributeListIterator.
AttributeList (int[] list)
Creates a new instance from an integer array.
int | Count ()
Number of elements in the list.
void | Add (int attr)
Adds a Sparksee attribute identifier at the end of the list.

Detailed Description

Sparksee attribute identifier list.

It stores a Sparksee attribute identifier list.

Use AttributeListIterator to access all elements into this collection.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

com.sparsity.sparksee.gdb.AttributeList.AttributeList ( System.Collections.Generic.ICollection< int > col )

Creates a new instance from an integer collection.

Parameters
col Collection to initialize the instance.
com.sparsity.sparksee.gdb.AttributeList.AttributeList ( )

Constructor.

This creates an empty list.

com.sparsity.sparksee.gdb.AttributeList.AttributeList ( int[] list )

Creates a new instance from an integer array.

Parameters
list Integer array to initialize the instance.

Member Function Documentation

void com.sparsity.sparksee.gdb.AttributeList.Add ( int attr )

Adds a Sparksee attribute identifier at the end of the list.

Parameters
attr [in] Sparksee attribute identifier.
int com.sparsity.sparksee.gdb.AttributeList.Count ( )

Number of elements in the list.

Returns
Number of elements in the list.
com.sparsity.sparksee.gdb.AttributeListIterator com.sparsity.sparksee.gdb.AttributeList.Iterator ( )

Gets a new AttributeListIterator.

Returns
AttributeListIterator instance.


SparkseeNet: Member List

  • gdb
  • AttributeList
com.sparsity.sparksee.gdb.AttributeList Member List

This is the complete list of members for com.sparsity.sparksee.gdb.AttributeList, including all inherited members.

Add(int attr) | com.sparsity.sparksee.gdb.AttributeList
AttributeList(System.Collections.Generic.ICollection< int > col) | com.sparsity.sparksee.gdb.AttributeList
AttributeList() | com.sparsity.sparksee.gdb.AttributeList
AttributeList(int[] list) | com.sparsity.sparksee.gdb.AttributeList
Clear() | com.sparsity.sparksee.gdb.AttributeList
Count() | com.sparsity.sparksee.gdb.AttributeList
Iterator() | com.sparsity.sparksee.gdb.AttributeList


SparkseeNet: com.sparsity.sparksee.gdb.AttributeListIterator Class Reference

  • gdb
  • AttributeListIterator
Public Member Functions | List of all members
com.sparsity.sparksee.gdb.AttributeListIterator Class Reference

AttributeList iterator class. More...

Public Member Functions

bool | HasNext ()
Gets if there are more elements.
int | Next ()
Moves to the next element.

Detailed Description

AttributeList iterator class.

Iterator to traverse all the Sparksee attribute identifier into a AttributeList instance.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

bool com.sparsity.sparksee.gdb.AttributeListIterator.HasNext ( )

Gets if there are more elements.

Returns
TRUE if there are more elements, FALSE otherwise.
int com.sparsity.sparksee.gdb.AttributeListIterator.Next ( )

Moves to the next element.

Returns
The next element.


SparkseeNet: Member List

  • gdb
  • AttributeListIterator
com.sparsity.sparksee.gdb.AttributeListIterator Member List

This is the complete list of members for com.sparsity.sparksee.gdb.AttributeListIterator, including all inherited members.

HasNext() | com.sparsity.sparksee.gdb.AttributeListIterator
Next() | com.sparsity.sparksee.gdb.AttributeListIterator


SparkseeNet: com.sparsity.sparksee.gdb.AttributeStatistics Class Reference

  • gdb
  • AttributeStatistics
Public Member Functions | List of all members
com.sparsity.sparksee.gdb.AttributeStatistics Class Reference

Attribute statistics class. More...

Public Member Functions

com.sparsity.sparksee.gdb.Value GetMin ()
Gets the minimum existing value (BASIC statistics).
int | GetMinLengthString ()
Gets the minimum length.
double | GetVariance ()
Gets the variance.
com.sparsity.sparksee.gdb.Value GetMode ()
Gets the mode.
long | GetNull ()
Gets the number of objects NULL a Value (BASIC statistics).
long | GetDistinct ()
Gets the number of distinct values (BASIC statistics).
double | GetMean ()
Gets the mean or average.
com.sparsity.sparksee.gdb.Value GetMax ()
Gets the maximum existing value (BASIC statistics).
double | GetMedian ()
Gets the median.
long | GetTotal ()
Gets the number of objects with a non-NULL Value (BASIC statistic).
int | GetMaxLengthString ()
Gets the maximum length.
double | GetAvgLengthString ()
Gets the average length.
long | GetModeCount ()
Gets the number of objects with a Value equal to the mode.

Detailed Description

Attribute statistics class.

It contains statistic data about an attribute.

Some fields are valid just for numerical attributes and others just for string attributes. Also, some statistics are considered BASIC because computing them do not require to traverse all the different values of the attribute. For each getter method the documentation tells if the statistic is BASIC or not. See the Graph class method getAttributeStatistics or check out the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

double com.sparsity.sparksee.gdb.AttributeStatistics.GetAvgLengthString ( )

Gets the average length.

If the attribute is not an string attribute, it just returns 0.

Returns
The average length.
long com.sparsity.sparksee.gdb.AttributeStatistics.GetDistinct ( )

Gets the number of distinct values (BASIC statistics).

Returns
The number of distinct values.
com.sparsity.sparksee.gdb.Value com.sparsity.sparksee.gdb.AttributeStatistics.GetMax ( )

Gets the maximum existing value (BASIC statistics).

Returns
The maximum existing value.
int com.sparsity.sparksee.gdb.AttributeStatistics.GetMaxLengthString ( )

Gets the maximum length.

If the attribute is not an string attribute, it just returns 0.

Returns
The maximum length.
double com.sparsity.sparksee.gdb.AttributeStatistics.GetMean ( )

Gets the mean or average.

Mean or average: Sum of all Values divided by the number of observations.

It is computed just for numerical attributes.

Returns
The mean.
double com.sparsity.sparksee.gdb.AttributeStatistics.GetMedian ( )

Gets the median.

Median: Middle value that separates the higher half from the lower.

If a < b < c, then the median of the list {a, b, c} is b, and if a < b < c < d, then the median of the list {a, b, c, d} is the mean of b and c, i.e. it is (b + c)/2

It is computed just for numerical attributes.

Returns
The median.
com.sparsity.sparksee.gdb.Value com.sparsity.sparksee.gdb.AttributeStatistics.GetMin ( )

Gets the minimum existing value (BASIC statistics).

Returns
The minimum existing value.
int com.sparsity.sparksee.gdb.AttributeStatistics.GetMinLengthString ( )

Gets the minimum length.

If the attribute is not an string attribute, it just returns 0.

Returns
The minimum length.
com.sparsity.sparksee.gdb.Value com.sparsity.sparksee.gdb.AttributeStatistics.GetMode ( )

Gets the mode.

Mode: Most frequent Value.

Returns
The mode.
long com.sparsity.sparksee.gdb.AttributeStatistics.GetModeCount ( )

Gets the number of objects with a Value equal to the mode.

Returns
The number of objects with a Value equal to the mode.
long com.sparsity.sparksee.gdb.AttributeStatistics.GetNull ( )

Gets the number of objects NULL a Value (BASIC statistics).

Returns
The number of objects NULL a Value.
long com.sparsity.sparksee.gdb.AttributeStatistics.GetTotal ( )

Gets the number of objects with a non-NULL Value (BASIC statistic).

Returns
The number of objects with a non-NULL Value.
double com.sparsity.sparksee.gdb.AttributeStatistics.GetVariance ( )

Gets the variance.

It is computed just for numerical attributes.

Returns
The variance.


SparkseeNet: Member List

  • gdb
  • AttributeStatistics
com.sparsity.sparksee.gdb.AttributeStatistics Member List

This is the complete list of members for com.sparsity.sparksee.gdb.AttributeStatistics, including all inherited members.

GetAvgLengthString() | com.sparsity.sparksee.gdb.AttributeStatistics
GetDistinct() | com.sparsity.sparksee.gdb.AttributeStatistics
GetMax() | com.sparsity.sparksee.gdb.AttributeStatistics
GetMaxLengthString() | com.sparsity.sparksee.gdb.AttributeStatistics
GetMean() | com.sparsity.sparksee.gdb.AttributeStatistics
GetMedian() | com.sparsity.sparksee.gdb.AttributeStatistics
GetMin() | com.sparsity.sparksee.gdb.AttributeStatistics
GetMinLengthString() | com.sparsity.sparksee.gdb.AttributeStatistics
GetMode() | com.sparsity.sparksee.gdb.AttributeStatistics
GetModeCount() | com.sparsity.sparksee.gdb.AttributeStatistics
GetNull() | com.sparsity.sparksee.gdb.AttributeStatistics
GetTotal() | com.sparsity.sparksee.gdb.AttributeStatistics
GetVariance() | com.sparsity.sparksee.gdb.AttributeStatistics


SparkseeNet: com.sparsity.sparksee.gdb.BooleanList Class Reference

  • gdb
  • BooleanList
Public Member Functions | List of all members
com.sparsity.sparksee.gdb.BooleanList Class Reference

Boolean list. More...

Public Member Functions

BooleanList (System.Collections.Generic.ICollection< bool > col)
Creates a new instance from a boolean collection.
void | Add (bool value)
Adds a Boolean at the end of the list.
void | Clear ()
Clears the list.
com.sparsity.sparksee.gdb.BooleanListIterator Iterator ()
Gets a new BooleanListIterator.
int | Count ()
Number of elements in the list.
BooleanList (bool[] list)
Creates a new instance from a boolean array.
BooleanList ()
Constructor.

Detailed Description

Boolean list.

It stores a Boolean list.

Use BooleanListIterator to access all elements into this collection.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

com.sparsity.sparksee.gdb.BooleanList.BooleanList ( System.Collections.Generic.ICollection< bool > col )

Creates a new instance from a boolean collection.

Parameters
col Collection to initialize the instance.
com.sparsity.sparksee.gdb.BooleanList.BooleanList ( bool[] list )

Creates a new instance from a boolean array.

Parameters
list Boolean array to initialize the instance.
com.sparsity.sparksee.gdb.BooleanList.BooleanList ( )

Constructor.

This creates an empty list.

Member Function Documentation

void com.sparsity.sparksee.gdb.BooleanList.Add ( bool value )

Adds a Boolean at the end of the list.

Parameters
value [in] Boolean.
int com.sparsity.sparksee.gdb.BooleanList.Count ( )

Number of elements in the list.

Returns
Number of elements in the list.
com.sparsity.sparksee.gdb.BooleanListIterator com.sparsity.sparksee.gdb.BooleanList.Iterator ( )

Gets a new BooleanListIterator.

Returns
BooleanListIterator instance.


SparkseeNet: Member List

  • gdb
  • BooleanList
com.sparsity.sparksee.gdb.BooleanList Member List

This is the complete list of members for com.sparsity.sparksee.gdb.BooleanList, including all inherited members.

Add(bool value) | com.sparsity.sparksee.gdb.BooleanList
BooleanList(System.Collections.Generic.ICollection< bool > col) | com.sparsity.sparksee.gdb.BooleanList
BooleanList(bool[] list) | com.sparsity.sparksee.gdb.BooleanList
BooleanList() | com.sparsity.sparksee.gdb.BooleanList
Clear() | com.sparsity.sparksee.gdb.BooleanList
Count() | com.sparsity.sparksee.gdb.BooleanList
Iterator() | com.sparsity.sparksee.gdb.BooleanList


SparkseeNet: com.sparsity.sparksee.gdb.BooleanListIterator Class Reference

  • gdb
  • BooleanListIterator
Public Member Functions | List of all members
com.sparsity.sparksee.gdb.BooleanListIterator Class Reference

BooleanList iterator class. More...

Public Member Functions

bool | HasNext ()
Gets if there are more elements.
bool | Next ()
Moves to the next element.

Detailed Description

BooleanList iterator class.

Iterator to traverse all the strings into a BooleanList instance.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

bool com.sparsity.sparksee.gdb.BooleanListIterator.HasNext ( )

Gets if there are more elements.

Returns
TRUE if there are more elements, FALSE otherwise.
bool com.sparsity.sparksee.gdb.BooleanListIterator.Next ( )

Moves to the next element.

Returns
The next element.


SparkseeNet: Member List

  • gdb
  • BooleanListIterator
com.sparsity.sparksee.gdb.BooleanListIterator Member List

This is the complete list of members for com.sparsity.sparksee.gdb.BooleanListIterator, including all inherited members.

HasNext() | com.sparsity.sparksee.gdb.BooleanListIterator
Next() | com.sparsity.sparksee.gdb.BooleanListIterator


SparkseeNet: com.sparsity.sparksee.gdb.Database Class Reference

  • gdb
  • Database
Public Member Functions | List of all members
com.sparsity.sparksee.gdb.Database Class Reference

Database class. More...

Public Member Functions

System.String | GetPath ()
Gets the path of the Database.
void | DumpSchema (System.String filePath)
Dump the database schema to the given file using the Sparksee scripting format.
void | GetStatistics (com.sparsity.sparksee.gdb.DatabaseStatistics stats)
Gets Database statistics.
void | DisableRollback ()
Disables the rollback mechanism.
boolean | IsClosed ()
Gets if Database instance has been closed or not.
System.String | GetAlias ()
Gets the alias of the Database.
void | FixCurrentCacheMaxSize ()
Sets the cache maximum size to the current cache size in use.
void | Close ()
Closes the Database instance.
void | EnableRollback ()
Enables the rollback mechanism.
com.sparsity.sparksee.gdb.Session NewSession ()
Creates a new Session.
int | GetCacheMaxSize ()
Gets the cache maximum size (in MB).
void | SetCacheMaxSize (int megaBytes)
Sets the cache maximum size (in MB).
void | RedoPrecommitted (long txId)
Redo a pending precommitted transaction recovered.

Detailed Description

Database class.

All the data of the Database is stored into a persistent file which just can be created or open through a Sparksee instance.

Also, all the manipulation of a Database must be done by means of a Session which can be initiated from a Database instance.

Multiple Databases do not share the memory, that is there is no negotiation among them. In those cases, memory must be prefixed for each Database. To do that, use the SPARKSEEConfig.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

void com.sparsity.sparksee.gdb.Database.Close ( )

Closes the Database instance.

It must be called to ensure the integrity of all data.

void com.sparsity.sparksee.gdb.Database.DumpSchema ( System.String filePath )

Dump the database schema to the given file using the Sparksee scripting format.

Parameters
filePath null
System.String com.sparsity.sparksee.gdb.Database.GetAlias ( )

Gets the alias of the Database.

Returns
The alias of the Database.
int com.sparsity.sparksee.gdb.Database.GetCacheMaxSize ( )

Gets the cache maximum size (in MB).

Returns
Returns the current cache max size.
System.String com.sparsity.sparksee.gdb.Database.GetPath ( )

Gets the path of the Database.

Returns
The path of the Database.
void com.sparsity.sparksee.gdb.Database.GetStatistics ( com.sparsity.sparksee.gdb.DatabaseStatistics stats )

Gets Database statistics.

Parameters
stats [out] The DatabaseStatistics instance.
boolean com.sparsity.sparksee.gdb.Database.IsClosed ( )

Gets if Database instance has been closed or not.

See Also
Close()
Returns
TRUE if the Database instance has been closed, FALSE otherwise.
void com.sparsity.sparksee.gdb.Database.RedoPrecommitted ( long txId )

Redo a pending precommitted transaction recovered.

YOU SHOULD NOT USE THIS METHOD. This method only exists for a specific service.

Parameters
txId null
void com.sparsity.sparksee.gdb.Database.SetCacheMaxSize ( int megaBytes )

Sets the cache maximum size (in MB).

0 means unlimited which is all the physical memory of the computer minus a small margin.

Parameters
megaBytes [in] The new cache max size.


SparkseeNet: Member List

  • gdb
  • Database
com.sparsity.sparksee.gdb.Database Member List

This is the complete list of members for com.sparsity.sparksee.gdb.Database, including all inherited members.

Close() | com.sparsity.sparksee.gdb.Database
DisableRollback() | com.sparsity.sparksee.gdb.Database
DumpSchema(System.String filePath) | com.sparsity.sparksee.gdb.Database
EnableRollback() | com.sparsity.sparksee.gdb.Database
FixCurrentCacheMaxSize() | com.sparsity.sparksee.gdb.Database
GetAlias() | com.sparsity.sparksee.gdb.Database
GetCacheMaxSize() | com.sparsity.sparksee.gdb.Database
GetPath() | com.sparsity.sparksee.gdb.Database
GetStatistics(com.sparsity.sparksee.gdb.DatabaseStatistics stats) | com.sparsity.sparksee.gdb.Database
IsClosed() | com.sparsity.sparksee.gdb.Database
NewSession() | com.sparsity.sparksee.gdb.Database
RedoPrecommitted(long txId) | com.sparsity.sparksee.gdb.Database
SetCacheMaxSize(int megaBytes) | com.sparsity.sparksee.gdb.Database


SparkseeNet: com.sparsity.sparksee.gdb.DatabaseStatistics Class Reference

  • gdb
  • DatabaseStatistics
Public Member Functions | List of all members
com.sparsity.sparksee.gdb.DatabaseStatistics Class Reference

Database statistics. More...

Public Member Functions

long | GetWrite ()
Gets total written data in KBytes.
long | GetSessions ()
Gets the number of sessions.
long | GetData ()
Gets database size in KBytes.
long | GetTemp ()
Gets temporary storage file size in KBytes.
long | GetRead ()
Gets total read data in KBytes.
long | GetCache ()
Gets cache size in KBytes.

Detailed Description

Database statistics.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

long com.sparsity.sparksee.gdb.DatabaseStatistics.GetCache ( )

Gets cache size in KBytes.

Returns
Cache size in KBytes.
long com.sparsity.sparksee.gdb.DatabaseStatistics.GetData ( )

Gets database size in KBytes.

Returns
Database size in KBytes.
long com.sparsity.sparksee.gdb.DatabaseStatistics.GetRead ( )

Gets total read data in KBytes.

Returns
Total read data in KBytes.
long com.sparsity.sparksee.gdb.DatabaseStatistics.GetSessions ( )

Gets the number of sessions.

Returns
The number of sessions.
long com.sparsity.sparksee.gdb.DatabaseStatistics.GetTemp ( )

Gets temporary storage file size in KBytes.

Returns
Temporary storage file size in KBytes.
long com.sparsity.sparksee.gdb.DatabaseStatistics.GetWrite ( )

Gets total written data in KBytes.

Returns
Total read written in KBytes.


SparkseeNet: Member List

  • gdb
  • DatabaseStatistics
com.sparsity.sparksee.gdb.DatabaseStatistics Member List

This is the complete list of members for com.sparsity.sparksee.gdb.DatabaseStatistics, including all inherited members.

GetCache() | com.sparsity.sparksee.gdb.DatabaseStatistics
GetData() | com.sparsity.sparksee.gdb.DatabaseStatistics
GetRead() | com.sparsity.sparksee.gdb.DatabaseStatistics
GetSessions() | com.sparsity.sparksee.gdb.DatabaseStatistics
GetTemp() | com.sparsity.sparksee.gdb.DatabaseStatistics
GetWrite() | com.sparsity.sparksee.gdb.DatabaseStatistics


SparkseeNet: com.sparsity.sparksee.gdb.DefaultExport Class Reference

  • gdb
  • DefaultExport
Public Member Functions | List of all members
com.sparsity.sparksee.gdb.DefaultExport Class Reference

Default implementation for ExportManager class. More...

Inheritance diagram for com.sparsity.sparksee.gdb.DefaultExport:
Collaboration diagram for com.sparsity.sparksee.gdb.DefaultExport:

Public Member Functions

bool | EnableType (int type)
Default implementation of the ExportManager class method EnableType.
bool | GetEdge (long edge, com.sparsity.sparksee.gdb.EdgeExport edgeExport)
Default implementation of the ExportManager class method GetEdge.
bool | GetGraph (com.sparsity.sparksee.gdb.GraphExport graphExport)
Default implementation of the ExportManager class method GetGraph.
bool | GetEdgeType (int type, com.sparsity.sparksee.gdb.EdgeExport edgeExport)
Default implementation of the ExportManager class method GetEdgeType.
bool | GetNodeType (int type, com.sparsity.sparksee.gdb.NodeExport nodeExport)
Default implementation of the ExportManager class method GetNodeType.
void | Release ()
Default implementation of the ExportManager class method Release.
bool | GetNode (long node, com.sparsity.sparksee.gdb.NodeExport nodeExport)
Default implementation of the ExportManager class method GetNode.
void | Prepare (com.sparsity.sparksee.gdb.Graph graph)
Default implementation of the ExportManager class method Prepare.
DefaultExport ()
Creates a new instance.

Detailed Description

Default implementation for ExportManager class.

It uses the default values from GraphExport, NodeExport and EdgeExport to export all node and edge types.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

bool com.sparsity.sparksee.gdb.DefaultExport.EnableType ( int type )

Default implementation of the ExportManager class method EnableType.

This enables all node and edge types to be exported.

Parameters
type [in] The type to enable.
Returns
TRUE.
bool com.sparsity.sparksee.gdb.DefaultExport.GetEdge | ( | long | edge,
 |  | com.sparsity.sparksee.gdb.EdgeExport | edgeExport
 | ) |  |

Default implementation of the ExportManager class method GetEdge.

This sets the default EdgeExport values and sets the OID as the label. Also, it exports the edge as directed just if the edge is directed.

Parameters
edge | [in] An edge.
edgeExport | [out] The EdgeExport that will store the information.
Returns
TRUE.
bool com.sparsity.sparksee.gdb.DefaultExport.GetEdgeType | ( | int | type,
 |  | com.sparsity.sparksee.gdb.EdgeExport | edgeExport
 | ) |  |

Default implementation of the ExportManager class method GetEdgeType.

This sets de default EdgeExport values.

Parameters
type | [in] An edge type.
edgeExport | [out] The EdgeExport that will store the information.
Returns
TRUE.
bool com.sparsity.sparksee.gdb.DefaultExport.GetGraph ( com.sparsity.sparksee.gdb.GraphExport graphExport )

Default implementation of the ExportManager class method GetGraph.

This sets the default GraphExport values and "Graph" as the label.

Parameters
graphExport [out] The GraphExport that will store the information.
Returns
TRUE.
bool com.sparsity.sparksee.gdb.DefaultExport.GetNode | ( | long | node,
 |  | com.sparsity.sparksee.gdb.NodeExport | nodeExport
 | ) |  |

Default implementation of the ExportManager class method GetNode.

This sets the default NodeExport values and sets the OID as the label.

Parameters
node | [in] A node.
nodeExport | [out] The NodeExport that will store the information.
Returns
TRUE.
bool com.sparsity.sparksee.gdb.DefaultExport.GetNodeType | ( | int | type,
 |  | com.sparsity.sparksee.gdb.NodeExport | nodeExport
 | ) |  |

Default implementation of the ExportManager class method GetNodeType.

This sets de default NodeExport values.

Parameters
type | [in] A node type.
nodeExport | [out] The NodeExport that will store the information.
Returns
TRUE.
void com.sparsity.sparksee.gdb.DefaultExport.Prepare ( com.sparsity.sparksee.gdb.Graph graph )

Default implementation of the ExportManager class method Prepare.

Parameters
graph null


SparkseeNet: Member List

  • gdb
  • DefaultExport
com.sparsity.sparksee.gdb.DefaultExport Member List

This is the complete list of members for com.sparsity.sparksee.gdb.DefaultExport, including all inherited members.

DefaultExport() | com.sparsity.sparksee.gdb.DefaultExport
EnableType(int type) | com.sparsity.sparksee.gdb.DefaultExport
GetEdge(long edge, com.sparsity.sparksee.gdb.EdgeExport edgeExport) | com.sparsity.sparksee.gdb.DefaultExport
GetEdgeType(int type, com.sparsity.sparksee.gdb.EdgeExport edgeExport) | com.sparsity.sparksee.gdb.DefaultExport
GetGraph(com.sparsity.sparksee.gdb.GraphExport graphExport) | com.sparsity.sparksee.gdb.DefaultExport
GetNode(long node, com.sparsity.sparksee.gdb.NodeExport nodeExport) | com.sparsity.sparksee.gdb.DefaultExport
GetNodeType(int type, com.sparsity.sparksee.gdb.NodeExport nodeExport) | com.sparsity.sparksee.gdb.DefaultExport
Prepare(com.sparsity.sparksee.gdb.Graph graph) | com.sparsity.sparksee.gdb.DefaultExport
Release() | com.sparsity.sparksee.gdb.DefaultExport


SparkseeNet: com.sparsity.sparksee.gdb.EdgeData Class Reference

  • gdb
  • EdgeData
Public Member Functions | List of all members
com.sparsity.sparksee.gdb.EdgeData Class Reference

Edge data class. More...

Public Member Functions

long | GetHead ()
Gets the head of the edge.
long | GetTail ()
Gets the tail of the edge.
long | GetEdge ()
Gets the edge identifier.

Detailed Description

Edge data class.

It stores the tail and the head of an edge instance.

In case of undirected eges, the tail and the head are just the two ends of the edge.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

long com.sparsity.sparksee.gdb.EdgeData.GetEdge ( )

Gets the edge identifier.

Returns
The Sparksee edge identifier.
long com.sparsity.sparksee.gdb.EdgeData.GetHead ( )

Gets the head of the edge.

Returns
The Sparksee edge identifier of the head of the edge.
long com.sparsity.sparksee.gdb.EdgeData.GetTail ( )

Gets the tail of the edge.

Returns
The Sparksee edge identifier of the tail of the edge.


SparkseeNet: Member List

  • gdb
  • EdgeData
com.sparsity.sparksee.gdb.EdgeData Member List

This is the complete list of members for com.sparsity.sparksee.gdb.EdgeData, including all inherited members.

GetEdge() | com.sparsity.sparksee.gdb.EdgeData
GetHead() | com.sparsity.sparksee.gdb.EdgeData
GetTail() | com.sparsity.sparksee.gdb.EdgeData


SparkseeNet: com.sparsity.sparksee.gdb.EdgeExport Class Reference

  • gdb
  • EdgeExport
Public Member Functions | List of all members
com.sparsity.sparksee.gdb.EdgeExport Class Reference

Stores edge exporting values. More...

Public Member Functions

void | SetColorRGB (int color)
Sets the edge color.
void | SetAsDirected (bool directed)
Sets if the edge should be managed as directed.
int | GetFontSize ()
Gets the edge label font size.
void | SetDefaults ()
Sets to default values.
int | GetColorRGB ()
Gets the edge color.
int | GetLabelColorRGB ()
Gets the edge label color.
int | GetWidth ()
Gets the edge width.
void | SetLabel (System.String label)
Sets the edge label.
void | SetLabelColor (System.Drawing.Color c)
Sets the color of the label.
bool | AsDirected ()
Gets if the edge should be managed as directed.
void | SetColor (System.Drawing.Color c)
Sets the color of the edge.
EdgeExport ()
Creates a new instance.
System.String | GetLabel ()
Gets the edge label.
System.Drawing.Color | GetColor ()
Gets the color of the edge.
void | SetLabelColorRGB (int color)
Sets the edge label color.
System.Drawing.Color | GetLabelColor ()
Gets the color of the label.
void | SetWidth (int width)
Sets the edge width.
void | SetFontSize (int size)
Sets the edge label font size.

Detailed Description

Stores edge exporting values.

Some properties may be ignored depending on the exportation type.

Default values are:

Label: "" (empty string).

As directed: TRUE.

Color: 13882323 (OxD3D3D3, Light gray).

Label color: 0 (Ox000000, Black).

Width: 5px.

Font size: 10.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

bool com.sparsity.sparksee.gdb.EdgeExport.AsDirected ( )

Gets if the edge should be managed as directed.

TRUE is the default value. If TRUE, use as directed, otherwise use as undirected.

Returns
The edge direction.
int com.sparsity.sparksee.gdb.EdgeExport.GetColorRGB ( )

Gets the edge color.

Returns
The edge color.
int com.sparsity.sparksee.gdb.EdgeExport.GetFontSize ( )

Gets the edge label font size.

Returns
The edge label font size.
System.String com.sparsity.sparksee.gdb.EdgeExport.GetLabel ( )

Gets the edge label.

Returns
The edge label.
int com.sparsity.sparksee.gdb.EdgeExport.GetLabelColorRGB ( )

Gets the edge label color.

Returns
The edge label color.
int com.sparsity.sparksee.gdb.EdgeExport.GetWidth ( )

Gets the edge width.

Returns
The edge width.
void com.sparsity.sparksee.gdb.EdgeExport.SetAsDirected ( bool directed )

Sets if the edge should be managed as directed.

Parameters
directed [in] If TRUE, use as directed, otherwise use as undirected.
void com.sparsity.sparksee.gdb.EdgeExport.SetColor ( System.Drawing.Color c )

Sets the color of the edge.

Parameters
c New value.
void com.sparsity.sparksee.gdb.EdgeExport.SetColorRGB ( int color )

Sets the edge color.

Parameters
color [in] The edge color.
void com.sparsity.sparksee.gdb.EdgeExport.SetFontSize ( int size )

Sets the edge label font size.

Parameters
size [in] The edge label font size.
void com.sparsity.sparksee.gdb.EdgeExport.SetLabel ( System.String label )

Sets the edge label.

Parameters
label [in] The edge label.
void com.sparsity.sparksee.gdb.EdgeExport.SetLabelColor ( System.Drawing.Color c )

Sets the color of the label.

Parameters
c New value.
void com.sparsity.sparksee.gdb.EdgeExport.SetLabelColorRGB ( int color )

Sets the edge label color.

Parameters
color [in] The edge label color.
void com.sparsity.sparksee.gdb.EdgeExport.SetWidth ( int width )

Sets the edge width.

Parameters
width [in] The edge width.


SparkseeNet: Member List

  • gdb
  • EdgeExport
com.sparsity.sparksee.gdb.EdgeExport Member List

This is the complete list of members for com.sparsity.sparksee.gdb.EdgeExport, including all inherited members.

AsDirected() | com.sparsity.sparksee.gdb.EdgeExport
EdgeExport() | com.sparsity.sparksee.gdb.EdgeExport
GetColor() | com.sparsity.sparksee.gdb.EdgeExport
GetColorRGB() | com.sparsity.sparksee.gdb.EdgeExport
GetFontSize() | com.sparsity.sparksee.gdb.EdgeExport
GetLabel() | com.sparsity.sparksee.gdb.EdgeExport
GetLabelColor() | com.sparsity.sparksee.gdb.EdgeExport
GetLabelColorRGB() | com.sparsity.sparksee.gdb.EdgeExport
GetWidth() | com.sparsity.sparksee.gdb.EdgeExport
SetAsDirected(bool directed) | com.sparsity.sparksee.gdb.EdgeExport
SetColor(System.Drawing.Color c) | com.sparsity.sparksee.gdb.EdgeExport
SetColorRGB(int color) | com.sparsity.sparksee.gdb.EdgeExport
SetDefaults() | com.sparsity.sparksee.gdb.EdgeExport
SetFontSize(int size) | com.sparsity.sparksee.gdb.EdgeExport
SetLabel(System.String label) | com.sparsity.sparksee.gdb.EdgeExport
SetLabelColor(System.Drawing.Color c) | com.sparsity.sparksee.gdb.EdgeExport
SetLabelColorRGB(int color) | com.sparsity.sparksee.gdb.EdgeExport
SetWidth(int width) | com.sparsity.sparksee.gdb.EdgeExport


SparkseeNet: com.sparsity.sparksee.gdb.ExportManager Class Reference

  • gdb
  • ExportManager
Public Member Functions | List of all members
com.sparsity.sparksee.gdb.ExportManager Class Reference

Defines how to export a graph to an external format. More...

Inheritance diagram for com.sparsity.sparksee.gdb.ExportManager:

Public Member Functions

bool | GetNodeType (int type, com.sparsity.sparksee.gdb.NodeExport nodeExport)
Gets the default node export definition for the given node type.
bool | GetEdge (long edge, com.sparsity.sparksee.gdb.EdgeExport edgeExport)
Gets the edge export definition for the given edge.
bool | GetGraph (com.sparsity.sparksee.gdb.GraphExport graphExport)
Gets the graph export definition.
bool | GetEdgeType (int type, com.sparsity.sparksee.gdb.EdgeExport edgeExport)
Gets the default node export definition for the given edge type.
void | Prepare (com.sparsity.sparksee.gdb.Graph graph)
Prepares the graph for the export process.
bool | GetNode (long node, com.sparsity.sparksee.gdb.NodeExport nodeExport)
Gets the node export definition for the given node.
void | Release ()
Ends the export process.
bool | EnableType (int type)
Gets whether a node or edge type must be exported or not.

Detailed Description

Defines how to export a graph to an external format.

This is an interface which must be implemented by the user. While the export proces, a call for each node or edge type and node or edge object is done to get how to export that element.

It is possible to export a Graph to a diferent fortmats. Nowadays, available formats are defined in the ExportType enum.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

bool com.sparsity.sparksee.gdb.ExportManager.EnableType ( int type )

Gets whether a node or edge type must be exported or not.

Parameters
type Node or edge type identifier.
Returns
If TRUE all objects of the given type will be exported, otherwise they will not be exported.
bool com.sparsity.sparksee.gdb.ExportManager.GetEdge | ( | long | edge,
 |  | com.sparsity.sparksee.gdb.EdgeExport | edgeExport
 | ) |  |

Gets the edge export definition for the given edge.

Parameters
edge | Edge identifier.
edgeExport | [out] The EdgeExport which defines how to export given edge.
Returns
TRUE if the given EdgeExport has been updated, otherwise FALSE will be returned and the default EdgeExport for the type the edge belongs to will be used.
bool com.sparsity.sparksee.gdb.ExportManager.GetEdgeType | ( | int | type,
 |  | com.sparsity.sparksee.gdb.EdgeExport | edgeExport
 | ) |  |

Gets the default node export definition for the given edge type.

GetEdge has a higher priority than this function. That is, only if GetEdge returns FALSE, the EdgeExport of this function will be used.

Parameters
type | [in] Edge type identifier.
edgeExport | [out] The EdgeExport which defines how to export the edges of the given type.
Returns
TRUE.
bool com.sparsity.sparksee.gdb.ExportManager.GetGraph ( com.sparsity.sparksee.gdb.GraphExport graphExport )

Gets the graph export definition.

Parameters
graphExport [out] The GraphExport which defines how to export the graph.
Returns
TRUE.
bool com.sparsity.sparksee.gdb.ExportManager.GetNode | ( | long | node,
 |  | com.sparsity.sparksee.gdb.NodeExport | nodeExport
 | ) |  |

Gets the node export definition for the given node.

Parameters
node | Node identifier.
nodeExport | [out] The NodeExport which defines how to export given node.
Returns
TRUE if the given NodeExport has been updated, otherwise FALSE will be returned and the default NodeExport for the type the node belongs to will be used.
bool com.sparsity.sparksee.gdb.ExportManager.GetNodeType | ( | int | type,
 |  | com.sparsity.sparksee.gdb.NodeExport | nodeExport
 | ) |  |

Gets the default node export definition for the given node type.

GetNode has a higher priority than this function. That is, only if GetNode returns FALSE, the NodeExport of this function will be used.

Parameters
type | [in] Node type identifier.
nodeExport | [out] The NodeExport which defines how to export the nodes of the given type.
Returns
TRUE.
void com.sparsity.sparksee.gdb.ExportManager.Prepare ( com.sparsity.sparksee.gdb.Graph graph )

Prepares the graph for the export process.

It is called once before the export process.

Parameters
graph Graph to be exported.
void com.sparsity.sparksee.gdb.ExportManager.Release ( )

Ends the export process.

It is called once after the export process.


SparkseeNet: Member List

  • gdb
  • ExportManager
com.sparsity.sparksee.gdb.ExportManager Member List

This is the complete list of members for com.sparsity.sparksee.gdb.ExportManager, including all inherited members.

EnableType(int type) | com.sparsity.sparksee.gdb.ExportManager
GetEdge(long edge, com.sparsity.sparksee.gdb.EdgeExport edgeExport) | com.sparsity.sparksee.gdb.ExportManager
GetEdgeType(int type, com.sparsity.sparksee.gdb.EdgeExport edgeExport) | com.sparsity.sparksee.gdb.ExportManager
GetGraph(com.sparsity.sparksee.gdb.GraphExport graphExport) | com.sparsity.sparksee.gdb.ExportManager
GetNode(long node, com.sparsity.sparksee.gdb.NodeExport nodeExport) | com.sparsity.sparksee.gdb.ExportManager
GetNodeType(int type, com.sparsity.sparksee.gdb.NodeExport nodeExport) | com.sparsity.sparksee.gdb.ExportManager
Prepare(com.sparsity.sparksee.gdb.Graph graph) | com.sparsity.sparksee.gdb.ExportManager
Release() | com.sparsity.sparksee.gdb.ExportManager


SparkseeNet: com.sparsity.sparksee.gdb.Graph Class Reference

  • gdb
  • Graph
Public Member Functions | List of all members
com.sparsity.sparksee.gdb.Graph Class Reference

Graph class. More...

Public Member Functions

void | SetAttributeText (long oid, int attr, com.sparsity.sparksee.gdb.TextStream tstream)
Sets the writable TextStream for the given text attribute and OID.
void | EncryptedBackup (System.String file, System.String keyInHex, System.String ivInHex) throws System.IO.IOException, System.ApplicationException
Dumps all the data to a backup file.
void | DumpData (System.String file) throws System.IO.IOException, System.ApplicationException
Dumps logical data to a file.
com.sparsity.sparksee.gdb.TypeList FindTypes ()
Gets all existing Sparksee node and edge type identifiers.
com.sparsity.sparksee.gdb.KeyValues | TopK (int attribute, com.sparsity.sparksee.gdb.Condition operation, com.sparsity.sparksee.gdb.Value lower, com.sparsity.sparksee.gdb.Order order, int k, com.sparsity.sparksee.gdb.Objects restriction)
Gets a KeyValues iterator as a result of the TopK operation.
com.sparsity.sparksee.gdb.Objects | Select (int attr, com.sparsity.sparksee.gdb.Condition cond, com.sparsity.sparksee.gdb.Value value, com.sparsity.sparksee.gdb.Objects restriction)
Selects all OIDs satisfying the given condition for the given attribute.
void | RenameAttribute (int attr, System.String newName)
Renames an attribute.
long | GetAttributeIntervalCount (int attr, com.sparsity.sparksee.gdb.Value lower, bool includeLower, com.sparsity.sparksee.gdb.Value higher, bool includeHigher)
Gets how many objects have a value into the given range for the given attribute.
void | TailsAndHeads (com.sparsity.sparksee.gdb.Objects edges, com.sparsity.sparksee.gdb.Objects tails, com.sparsity.sparksee.gdb.Objects heads)
Gets all the tails and heads from the given edges collection.
com.sparsity.sparksee.gdb.ValueArray | GetArrayAttribute (long oid, int attr)
Gets the ValueArray for the given array attribute and OID or NULL if it does not exist.
long | Degree (long oid, int etype, com.sparsity.sparksee.gdb.EdgesDirection dir)
Gets the number of edges from or to the given node OID and for the given edge type.
com.sparsity.sparksee.gdb.KeyValues | TopK (int attribute, com.sparsity.sparksee.gdb.Condition operation, com.sparsity.sparksee.gdb.Value lower, com.sparsity.sparksee.gdb.Value higher, com.sparsity.sparksee.gdb.Order order, int k, com.sparsity.sparksee.gdb.Objects restriction)
Gets a KeyValues iterator as a result of the TopK operation.
void | RenameType (System.String oldName, System.String newName)
Renames a type.
void | DumpStorage (System.String file) throws System.IO.IOException, System.ApplicationException
Dumps internal storage data to a file.
com.sparsity.sparksee.gdb.Objects | Neighbors (com.sparsity.sparksee.gdb.Objects objs, int etype, com.sparsity.sparksee.gdb.EdgesDirection dir)
Selects all neighbor nodes from or to each of the node OID in the given collection and for the given edge type.
com.sparsity.sparksee.gdb.ValueArray | SetArrayAttribute (long oid, int attr, com.sparsity.sparksee.gdb.Value value)
Sets all the elements of the ValueArray for the given array attribute and OID and returns it.
com.sparsity.sparksee.gdb.AttributeList | GetAttributes (long oid)
Gets all Sparksee attribute identifiers with a non-NULL value for the given Sparksee OID.
void | SetArrayAttribute (int attr, com.sparsity.sparksee.gdb.Value value)
Sets all the values of the array of the given array attribute for all the objects of the types the attribute applies to.
com.sparsity.sparksee.gdb.AttributeStatistics | GetAttributeStatistics (int attr, bool basic)
Gets statistics from the given attribute.
long | NewNode (int type)
Creates a new node instance.
long | CountEdges ()
Gets the number of edges.
com.sparsity.sparksee.gdb.TextStream | GetAttributeText (long oid, int attr)
Gets the read-only TextStream for the given text attribute and OID.
com.sparsity.sparksee.gdb.KeyValues | TopK (int attribute, com.sparsity.sparksee.gdb.Condition operation, com.sparsity.sparksee.gdb.Value lower, com.sparsity.sparksee.gdb.Order order, int k)
Gets a KeyValues iterator as a result of the TopK operation.
com.sparsity.sparksee.gdb.TypeList FindEdgeTypes ()
Gets all existing Sparksee edge type identifiers.
com.sparsity.sparksee.gdb.Objects | Select (int attr, com.sparsity.sparksee.gdb.Condition cond, com.sparsity.sparksee.gdb.Value lower, com.sparsity.sparksee.gdb.Value higher)
Selects all OIDs satisfying the given condition for the given attribute.
void | IndexAttribute (int attr, com.sparsity.sparksee.gdb.AttributeKind kind)
Updates the index of the given attribute.
com.sparsity.sparksee.gdb.Type | GetType (int type)
Gets information about the given type.
com.sparsity.sparksee.gdb.KeyValues | TopK (int attribute, com.sparsity.sparksee.gdb.Order order, int k, com.sparsity.sparksee.gdb.Objects restriction)
Gets a KeyValues iterator as a result of the TopK operation.
int | FindAttribute (int type, System.String name)
Gets the Sparksee attribute identifier for the given type identifier and attribute name.
int | NewAttribute (int type, System.String name, com.sparsity.sparksee.gdb.DataType dt, com.sparsity.sparksee.gdb.AttributeKind kind)
Creates a new attribute.
com.sparsity.sparksee.gdb.Objects | Edges (int etype, long tail, long head)
Gets all the edges of the given type between two given nodes (tail and head).
com.sparsity.sparksee.gdb.Objects | Select (int type)
Selects all OIDs belonging to the given type.
com.sparsity.sparksee.gdb.Objects | Select (int attr, com.sparsity.sparksee.gdb.Condition cond, com.sparsity.sparksee.gdb.Value value)
Selects all OIDs satisfying the given condition for the given attribute.
void | IndexNeighbors (int edgeType, bool neighbors)
Creates or destroys the neighbors index of an edge type.
long | FindOrCreateObject (int attr, com.sparsity.sparksee.gdb.Value value)
Finds one object having the given Value for the attribute or it creates one does not exist any.
com.sparsity.sparksee.gdb.TypeList FindNodeTypes ()
Gets all existing Sparksee node type identifiers.
com.sparsity.sparksee.gdb.KeyValues | TopK (int attribute, com.sparsity.sparksee.gdb.Order order, int k)
Gets a KeyValues iterator as a result of the TopK operation.
com.sparsity.sparksee.gdb.Value | GetAttribute (long oid, int attr)
Gets the Value for the given attribute and OID.
void | RemoveAttribute (int attr)
Removes the given attribute.
void | SetAttributeDefaultValue (int attr, com.sparsity.sparksee.gdb.Value value)
Sets a default value for an attribute.
void | Backup (System.String file) throws System.IO.IOException, System.ApplicationException
Dumps all the data to a backup file.
int | NewSessionAttribute (int type, com.sparsity.sparksee.gdb.DataType dt, com.sparsity.sparksee.gdb.AttributeKind kind, com.sparsity.sparksee.gdb.Value defaultValue)
Creates a new Session attribute with a default value.
com.sparsity.sparksee.gdb.AttributeList | FindAttributes (int type)
Gets all existing Sparksee attribute identifiers for the given type identifier.
void | SetAttribute (int attr, com.sparsity.sparksee.gdb.Value value)
Sets the value of the given attribute for all the objects of the types the attribute applies to.
void | GetAttribute (long oid, int attr, com.sparsity.sparksee.gdb.Value value)
Gets the Value for the given attribute and OID.
long | CountNodes ()
Gets the number of nodes.
com.sparsity.sparksee.gdb.Objects | Neighbors (long oid, int etype, com.sparsity.sparksee.gdb.EdgesDirection dir)
Selects all neighbor nodes from or to the given node OID and for the given edge type.
int | NewArrayAttribute (int type, System.String name, com.sparsity.sparksee.gdb.DataType dt, int size)
Creates a new array attribute.
com.sparsity.sparksee.gdb.EdgeData | GetEdgeData (long edge)
Gets information about an edge.
void | SetAttribute (long oid, int attr, com.sparsity.sparksee.gdb.Value value)
Sets the Value for the given attribute and OID.
com.sparsity.sparksee.gdb.Objects | Explode (com.sparsity.sparksee.gdb.Objects objs, int etype, com.sparsity.sparksee.gdb.EdgesDirection dir)
Selects all edges from or to each of the node OID in the given collection and for the given edge type.
void | SetArrayAttributeVoid (long oid, int attr, com.sparsity.sparksee.gdb.Value value)
Sets all the elements of the ValueArray for the given array attribute and OID.
void | RenameType (int type, System.String newName)
Renames a type.
int | NewNodeType (System.String name)
Creates a new node type.
int | NewSessionAttribute (int type, com.sparsity.sparksee.gdb.DataType dt, com.sparsity.sparksee.gdb.AttributeKind kind)
Creates a new Session attribute.
com.sparsity.sparksee.gdb.Objects | Tails (com.sparsity.sparksee.gdb.Objects edges)
Gets all the tails from the given edges collection.
long | FindOrCreateEdge (int etype, long tail, long head)
Gets any of the edges of the specified type between two given nodes (tail and head).
void | Drop (long oid)
Drops the given OID.
int | NewEdgeType (System.String name, bool directed, bool neighbors)
Creates a new edge type.
com.sparsity.sparksee.gdb.Objects | Heads (com.sparsity.sparksee.gdb.Objects edges)
Gets all the heads from the given edges collection.
int | NewSessionArrayAttribute (int type, com.sparsity.sparksee.gdb.DataType dt, int size)
Creates a new Session array attribute.
long | FindEdge (int etype, long tail, long head)
Gets any of the edges of the given type between two given nodes (tail and head).
com.sparsity.sparksee.gdb.Objects | Explode (long oid, int etype, com.sparsity.sparksee.gdb.EdgesDirection dir)
Selects all edges from or to the given node OID and for the given edge type.
com.sparsity.sparksee.gdb.KeyValues | TopK (int attribute, com.sparsity.sparksee.gdb.Condition operation, com.sparsity.sparksee.gdb.Value lower, com.sparsity.sparksee.gdb.Value higher, com.sparsity.sparksee.gdb.Order order, int k)
Gets a KeyValues iterator as a result of the TopK operation.
long | FindObject (int attr, com.sparsity.sparksee.gdb.Value value)
Finds one object having the given Value for the given attribute.
void | Drop (com.sparsity.sparksee.gdb.Objects objs)
Drops all the OIDs from the given collection.
int | NewAttribute (int type, System.String name, com.sparsity.sparksee.gdb.DataType dt, com.sparsity.sparksee.gdb.AttributeKind kind, com.sparsity.sparksee.gdb.Value defaultValue)
Creates a new attribute with a default value.
int | GetObjectType (long oid)
Gets the Sparksee node or edge type identifier for the given OID.
com.sparsity.sparksee.gdb.Attribute | GetAttribute (int attr)
Gets information about the given attribute.
void | Export (System.String file, com.sparsity.sparksee.gdb.ExportType type, com.sparsity.sparksee.gdb.ExportManager em) throws System.IO.IOException
Exports the Graph.
long | NewEdge (int type, int tailAttr, com.sparsity.sparksee.gdb.Value tailV, int headAttr, com.sparsity.sparksee.gdb.Value headV)
Creates a new edge instance.
com.sparsity.sparksee.gdb.Values | GetValues (int attr)
Gets the Value collection for the given attribute.
long | GetEdgePeer (long edge, long node)
Gets the other end for the given edge.
com.sparsity.sparksee.gdb.Objects | Select (int attr, com.sparsity.sparksee.gdb.Condition cond, com.sparsity.sparksee.gdb.Value lower, com.sparsity.sparksee.gdb.Value higher, com.sparsity.sparksee.gdb.Objects restriction)
Selects all OIDs satisfying the given condition for the given attribute.
long | NewEdge (int type, long tail, long head)
Creates a new edge instance.
int | FindType (System.String name)
Gets the Sparksee type identifier for the given type name.
void | RemoveType (int type)
Removes the given type.
int | NewRestrictedEdgeType (System.String name, int tail, int head, bool neighbors)
Creates a new restricted edge type.

Detailed Description

Graph class.

Each Database has a Graph associated, which is the persistent graph which contains all data stored into the graph database and is retrieved from a Session.

Check out the 'API' and the 'SPARKSEE graph database' sections in the SPARKSEE User Manual for more details on the use of this class.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

void com.sparsity.sparksee.gdb.Graph.Backup ( System.String file ) throws System.IO.IOException, System.ApplicationException

Dumps all the data to a backup file.

See the Sparksee class Restore methods.

Parameters
file [in] Output backup file path.
Exceptions
System.IO.IOException | If the given file cannot be created.
System.ApplicationException | null
long com.sparsity.sparksee.gdb.Graph.CountEdges ( )

Gets the number of edges.

Returns
The number of edges.
long com.sparsity.sparksee.gdb.Graph.CountNodes ( )

Gets the number of nodes.

Returns
The number of nodes.
long com.sparsity.sparksee.gdb.Graph.Degree | ( | long | oid,
 |  | int | etype,
 |  | com.sparsity.sparksee.gdb.EdgesDirection | dir
 | ) |  |

Gets the number of edges from or to the given node OID and for the given edge type.

Parameters
oid | [in] Sparksee node OID.
etype | [in] Sparksee edge type identifier.
dir | [in] Direction.
Returns
The number of edges.
void com.sparsity.sparksee.gdb.Graph.Drop ( long oid )

Drops the given OID.

It also removes its egdges as well as its attribute values.

Parameters
oid [in] Sparksee OID to be removed.
void com.sparsity.sparksee.gdb.Graph.Drop ( com.sparsity.sparksee.gdb.Objects objs )

Drops all the OIDs from the given collection.

See Drop method with the single OID parameter. This performs the same operation for each object in the given set.

Parameters
objs [in] Objects collection with the OIDs to be removed.
void com.sparsity.sparksee.gdb.Graph.DumpData ( System.String file ) throws System.IO.IOException, System.ApplicationException

Dumps logical data to a file.

Parameters
file [in] Output file path.
Exceptions
System.IO.IOException | If the given file cannot be created.
System.ApplicationException | null
void com.sparsity.sparksee.gdb.Graph.DumpStorage ( System.String file ) throws System.IO.IOException, System.ApplicationException

Dumps internal storage data to a file.

Parameters
file [in] Output file path.
Exceptions
System.IO.IOException | If the given file cannot be created.
System.ApplicationException | null
com.sparsity.sparksee.gdb.Objects com.sparsity.sparksee.gdb.Graph.Edges | ( | int | etype,
 |  | long | tail,
 |  | long | head
 | ) |  |

Gets all the edges of the given type between two given nodes (tail and head).

Parameters
etype | [in] Sparksee edge type identifier.
tail | [in] Tail node identifier.
head | [in] Head node identifier.
Returns
Objects instance.
void com.sparsity.sparksee.gdb.Graph.EncryptedBackup | ( | System.String | file,
 |  | System.String | keyInHex,
 |  | System.String | ivInHex
 | ) |  | throws System.IO.IOException, System.ApplicationException

Dumps all the data to a backup file.

See the Sparksee class RestoreEncryptedBackup methods.

Parameters
file | [in] Output backup file path.
keyInHex | [In] The AES encryption Key as an hexadecimal string (8, 16 or 32 bytes).
ivInHex | [In] The AES Initialization Vector as an hexadecimal string (16 bytes).
Exceptions
System.IO.IOException | If the given file cannot be created.
System.ApplicationException | null
com.sparsity.sparksee.gdb.Objects com.sparsity.sparksee.gdb.Graph.Explode | ( | com.sparsity.sparksee.gdb.Objects | objs,
 |  | int | etype,
 |  | com.sparsity.sparksee.gdb.EdgesDirection | dir
 | ) |  |

Selects all edges from or to each of the node OID in the given collection and for the given edge type.

Parameters
objs | [in] Sparksee node OID collection.
etype | [in] Sparksee edge type identifier.
dir | [in] Direction.
Returns
Objects instance.
com.sparsity.sparksee.gdb.Objects com.sparsity.sparksee.gdb.Graph.Explode | ( | long | oid,
 |  | int | etype,
 |  | com.sparsity.sparksee.gdb.EdgesDirection | dir
 | ) |  |

Selects all edges from or to the given node OID and for the given edge type.

Parameters
oid | [in] Sparksee node OID.
etype | [in] Sparksee edge type identifier.
dir | [in] Direction.
Returns
Objects instance.
void com.sparsity.sparksee.gdb.Graph.Export | ( | System.String | file,
 |  | com.sparsity.sparksee.gdb.ExportType | type,
 |  | com.sparsity.sparksee.gdb.ExportManager | em
 | ) |  | throws System.IO.IOException

Exports the Graph.

Parameters
file | [in] Output file.
type | [in] Export type.
em | [in] Defines how to do the export for each graph object.
Exceptions
System.IO.IOException null
int com.sparsity.sparksee.gdb.Graph.FindAttribute | ( | int | type,
 |  | System.String | name
 | ) |  |

Gets the Sparksee attribute identifier for the given type identifier and attribute name.

Parameters
type | [in] Sparksee type identifier.
name | [in] Unique attribute name.
Returns
The Sparksee attribute identifier for the given type and attribute name or InvalidAttribute if there is no attribute with the given name for the given type.
com.sparsity.sparksee.gdb.AttributeList com.sparsity.sparksee.gdb.Graph.FindAttributes ( int type )

Gets all existing Sparksee attribute identifiers for the given type identifier.

Parameters
type [in] Sparksee type identifier.
Returns
Sparksee attribute identifier list.
long com.sparsity.sparksee.gdb.Graph.FindEdge | ( | int | etype,
 |  | long | tail,
 |  | long | head
 | ) |  |

Gets any of the edges of the given type between two given nodes (tail and head).

If there are more than one, then any of them will be returned. And in case there are no edge between the given tail and head, the Objects InvalidOID will be returned.

Parameters
etype | [in] Sparksee edge type identifier.
tail | [in] Tail node identifier.
head | [in] Head node identifier.
Returns
Any of the edges or the Objects InvalidOID.
com.sparsity.sparksee.gdb.TypeList com.sparsity.sparksee.gdb.Graph.FindEdgeTypes ( )

Gets all existing Sparksee edge type identifiers.

Returns
Sparksee edge type identifier list.
com.sparsity.sparksee.gdb.TypeList com.sparsity.sparksee.gdb.Graph.FindNodeTypes ( )

Gets all existing Sparksee node type identifiers.

Returns
Sparksee node type identifier list.
long com.sparsity.sparksee.gdb.Graph.FindObject | ( | int | attr,
 |  | com.sparsity.sparksee.gdb.Value | value
 | ) |  |

Finds one object having the given Value for the given attribute.

If there are more than one, then any of them will be returned. And in case there are no object having this Value, the Objects InvalidOID will be returned.

Parameters
attr | [in] Sparksee attribute identifier.
value | [in] Value.
Returns
Sparksee OID or the Objects InvalidOID.
long com.sparsity.sparksee.gdb.Graph.FindOrCreateEdge | ( | int | etype,
 |  | long | tail,
 |  | long | head
 | ) |  |

Gets any of the edges of the specified type between two given nodes (tail and head).

If it can not find any edge of this type between them it tries to create a new one.

Parameters
etype | [in] Sparksee edge type identifier.
tail | [in] Tail node identifier.
head | [in] Head node identifier.
Returns
Any of the edges or the Objects InvalidOID.
long com.sparsity.sparksee.gdb.Graph.FindOrCreateObject | ( | int | attr,
 |  | com.sparsity.sparksee.gdb.Value | value
 | ) |  |

Finds one object having the given Value for the attribute or it creates one does not exist any.

If the attribute is a node or edge attribute and at least one node/edge with that value is found, it returns one of them. But if it does not exist, then: If it's a node attribute it will create it and set the attribute. If it's an edge attribute it will return the InvalidOID.

Using this method with a global attribute will return the InvalidOID.

Parameters
attr | [in] Sparksee attribute identifier.
value | [in] Value.
Returns
Sparksee OID or the Objects InvalidOID.
int com.sparsity.sparksee.gdb.Graph.FindType ( System.String name )

Gets the Sparksee type identifier for the given type name.

Parameters
name [in] Unique type name.
Returns
The Sparksee type identifier for the given type name or the Type InvalidType if there is no type with the given name.
com.sparsity.sparksee.gdb.TypeList com.sparsity.sparksee.gdb.Graph.FindTypes ( )

Gets all existing Sparksee node and edge type identifiers.

Returns
Sparksee node and edge type identifier list.
com.sparsity.sparksee.gdb.ValueArray com.sparsity.sparksee.gdb.Graph.GetArrayAttribute | ( | long | oid,
 |  | int | attr
 | ) |  |

Gets the ValueArray for the given array attribute and OID or NULL if it does not exist.

Parameters
oid | [in] Sparksee OID.
attr | [in] Sparksee array attribute identifier.
Returns
A ValueArray. This returns a ValueArray, a NULL or throws an exception.
com.sparsity.sparksee.gdb.Value com.sparsity.sparksee.gdb.Graph.GetAttribute | ( | long | oid,
 |  | int | attr
 | ) |  |

Gets the Value for the given attribute and OID.

The other version of this call, where the Value is an output parameter instead of the return, is better because it allows the user to reuse an existing Value instance, whereas this call always creates a new Value instance to be returned.

It never returns NULL. Thus, in case the OID has a NULL value for the attribute it returns a NULL Value instance.

Parameters
oid | [in] Sparksee OID.
attr | [in] Sparksee attribute identifier.
Returns
A new Value instance having the attribute value for the given OID.
void com.sparsity.sparksee.gdb.Graph.GetAttribute | ( | long | oid,
 |  | int | attr,
 |  | com.sparsity.sparksee.gdb.Value | value
 | ) |  |

Gets the Value for the given attribute and OID.

Parameters
oid | [in] Sparksee OID.
attr | [in] Sparksee attribute identifier.
value | [in|out] Value for the given attribute and for the given OID.
com.sparsity.sparksee.gdb.Attribute com.sparsity.sparksee.gdb.Graph.GetAttribute ( int attr )

Gets information about the given attribute.

Parameters
attr [in] Sparksee attribute identifier.
Returns
The Attribute for the given Sparksee attribute identifier.
long com.sparsity.sparksee.gdb.Graph.GetAttributeIntervalCount | ( | int | attr,
 |  | com.sparsity.sparksee.gdb.Value | lower,
 |  | bool | includeLower,
 |  | com.sparsity.sparksee.gdb.Value | higher,
 |  | bool | includeHigher
 | ) |  |

Gets how many objects have a value into the given range for the given attribute.

This only works for the attributes with the AttributeKind Indexed or Unique.

Given values must belong to the same DataType than the attribute.

Parameters
attr | [in] Sparksee attribute identifier.
lower | [in] Lower bound Value of the range.
includeLower | [in] If TRUE, include lower bound Value of the range.
higher | [in] Higher bound Value of the range.
includeHigher | [in] If TRUE, include higher bound Value of the range.
Returns
Number of objects having a value into the given range.
com.sparsity.sparksee.gdb.AttributeList com.sparsity.sparksee.gdb.Graph.GetAttributes ( long oid )

Gets all Sparksee attribute identifiers with a non-NULL value for the given Sparksee OID.

Parameters
oid [in] Sparksee OID.
Returns
Sparksee attribute identifier list.
com.sparsity.sparksee.gdb.AttributeStatistics com.sparsity.sparksee.gdb.Graph.GetAttributeStatistics | ( | int | attr,
 |  | bool | basic
 | ) |  |

Gets statistics from the given attribute.

The statistics can only be obtained from Indexed or Unique attributes.

Parameters
attr | [in] Sparksee attribute identifier.
basic | [in] If FALSE all statistics are computed, if TRUE just those statistics marked as basic will be computed (see description of the AttributeStatistics class). Of course, computing just basic statistics will be faster than computing all of them.
Returns
An AttributeStatistics instace.
com.sparsity.sparksee.gdb.TextStream com.sparsity.sparksee.gdb.Graph.GetAttributeText | ( | long | oid,
 |  | int | attr
 | ) |  |

Gets the read-only TextStream for the given text attribute and OID.

Parameters
oid | [in] Sparksee OID.
attr | [in] Sparksee attribute identifier.
Returns
A TextStream. This returns a TextStream to read.
com.sparsity.sparksee.gdb.EdgeData com.sparsity.sparksee.gdb.Graph.GetEdgeData ( long edge )

Gets information about an edge.

Parameters
edge [in] Sparksee edge identifier.
Returns
An EdgeData instance.
long com.sparsity.sparksee.gdb.Graph.GetEdgePeer | ( | long | edge,
 |  | long | node
 | ) |  |

Gets the other end for the given edge.

Parameters
edge | [in] Sparksee edge identifier.
node | [in] Sparksee node identifier. It must be one of the ends of the edge.
Returns
The other end of the edge.
int com.sparsity.sparksee.gdb.Graph.GetObjectType ( long oid )

Gets the Sparksee node or edge type identifier for the given OID.

Parameters
oid [in] Sparksee OID.
Returns
Sparksee node or edge type identifier.
com.sparsity.sparksee.gdb.Type com.sparsity.sparksee.gdb.Graph.GetType ( int type )

Gets information about the given type.

Parameters
type [in] Sparksee type identifier.
Returns
The Type for the given Sparksee type identifier.
com.sparsity.sparksee.gdb.Values com.sparsity.sparksee.gdb.Graph.GetValues ( int attr )

Gets the Value collection for the given attribute.

Parameters
attr [in] Sparksee attribute identifier.
Returns
Returns a Values object.
com.sparsity.sparksee.gdb.Objects com.sparsity.sparksee.gdb.Graph.Heads ( com.sparsity.sparksee.gdb.Objects edges )

Gets all the heads from the given edges collection.

Parameters
edges [in] Sparksee edge identifier collection.
Returns
The heads collection.
void com.sparsity.sparksee.gdb.Graph.IndexAttribute | ( | int | attr,
 |  | com.sparsity.sparksee.gdb.AttributeKind | kind
 | ) |  |

Updates the index of the given attribute.

This just works if the current index of the attribute corresponds to the AttributeKind Basic and the new one is Indexed or Unique.

Parameters
attr | [in] Sparksee attribute identifier.
kind | [in] Attribute kind.
void com.sparsity.sparksee.gdb.Graph.IndexNeighbors | ( | int | edgeType,
 |  | bool | neighbors
 | ) |  |

Creates or destroys the neighbors index of an edge type.

Parameters
edgeType | [in] Sparksee Edge type identifier.
neighbors | [in] If TRUE, it indexes the neighbor nodes, otherwise it removes the index.
com.sparsity.sparksee.gdb.Objects com.sparsity.sparksee.gdb.Graph.Neighbors | ( | com.sparsity.sparksee.gdb.Objects | objs,
 |  | int | etype,
 |  | com.sparsity.sparksee.gdb.EdgesDirection | dir
 | ) |  |

Selects all neighbor nodes from or to each of the node OID in the given collection and for the given edge type.

Parameters
objs | [in] Sparksee node OID collection.
etype | [in] Sparksee edge type identifier.
dir | [in] Direction.
Returns
Objects instance.
com.sparsity.sparksee.gdb.Objects com.sparsity.sparksee.gdb.Graph.Neighbors | ( | long | oid,
 |  | int | etype,
 |  | com.sparsity.sparksee.gdb.EdgesDirection | dir
 | ) |  |

Selects all neighbor nodes from or to the given node OID and for the given edge type.

Parameters
oid | [in] Sparksee node OID.
etype | [in] Sparksee edge type identifier.
dir | [in] Direction.
Returns
Objects instance.
int com.sparsity.sparksee.gdb.Graph.NewArrayAttribute | ( | int | type,
 |  | System.String | name,
 |  | com.sparsity.sparksee.gdb.DataType | dt,
 |  | int | size
 | ) |  |

Creates a new array attribute.

Parameters
type | [in] Sparksee node or edge type identifier.
name | [in] Unique name for the new attribute.
dt | [in] Base Data type for the new array attribute elements.
size | [in] The array size.
Returns
Unique Sparksee attribute identifier.
int com.sparsity.sparksee.gdb.Graph.NewAttribute | ( | int | type,
 |  | System.String | name,
 |  | com.sparsity.sparksee.gdb.DataType | dt,
 |  | com.sparsity.sparksee.gdb.AttributeKind | kind
 | ) |  |

Creates a new attribute.

Parameters
type | [in] Sparksee node or edge type identifier.
name | [in] Unique name for the new attribute.
dt | [in] Data type for the new attribute.
kind | [in] Attribute kind.
Returns
Unique Sparksee attribute identifier.
int com.sparsity.sparksee.gdb.Graph.NewAttribute | ( | int | type,
 |  | System.String | name,
 |  | com.sparsity.sparksee.gdb.DataType | dt,
 |  | com.sparsity.sparksee.gdb.AttributeKind | kind,
 |  | com.sparsity.sparksee.gdb.Value | defaultValue
 | ) |  |

Creates a new attribute with a default value.

Parameters
type | [in] Sparksee node or edge type identifier.
name | [in] Unique name for the new attribute.
dt | [in] Data type for the new attribute.
kind | [in] Attribute kind.
defaultValue | [in] The default value to use in each new node/edge.
Returns
Unique Sparksee attribute identifier.
long com.sparsity.sparksee.gdb.Graph.NewEdge | ( | int | type,
 |  | int | tailAttr,
 |  | com.sparsity.sparksee.gdb.Value | tailV,
 |  | int | headAttr,
 |  | com.sparsity.sparksee.gdb.Value | headV
 | ) |  |

Creates a new edge instance.

The tail of the edge will be any node having the given tailV Value for the given tailAttr attribute identifier, and the head of the edge will be any node having the given headV Value for the given headAttr attribute identifier.

Parameters
type | [in] Sparksee type identifier.
tailAttr | [in] Sparksee attribute identifier.
tailV | [in] Value.
headAttr | [in] Sparksee attribute identifier.
headV | [in] Value.
Returns
Unique OID of the new edge instance.
long com.sparsity.sparksee.gdb.Graph.NewEdge | ( | int | type,
 |  | long | tail,
 |  | long | head
 | ) |  |

Creates a new edge instance.

Parameters
type | [in] Sparksee type identifier.
tail | [in] Source Sparksee OID.
head | [in] Target Sparksee OID.
Returns
Unique OID of the new edge instance.
int com.sparsity.sparksee.gdb.Graph.NewEdgeType | ( | System.String | name,
 |  | bool | directed,
 |  | bool | neighbors
 | ) |  |

Creates a new edge type.

Parameters
name | [in] Unique name for the new edge type.
directed | [in] If TRUE, this creates a directed edge type, otherwise this creates a undirected edge type.
neighbors | [in] If TRUE, this indexes neighbor nodes, otherwise not.
Returns
Unique Sparksee type identifier.
long com.sparsity.sparksee.gdb.Graph.NewNode ( int type )

Creates a new node instance.

Parameters
type [in] Sparksee type identifier.
Returns
Unique OID of the new node instance.
int com.sparsity.sparksee.gdb.Graph.NewNodeType ( System.String name )

Creates a new node type.

Parameters
name [in] Unique name for the new node type.
Returns
Unique Sparksee type identifier.
int com.sparsity.sparksee.gdb.Graph.NewRestrictedEdgeType | ( | System.String | name,
 |  | int | tail,
 |  | int | head,
 |  | bool | neighbors
 | ) |  |

Creates a new restricted edge type.

Parameters
name | [in] Unique name for the new edge type.
tail | [in] Tail Sparksee node type identifier.
head | [in] Head Sparksee node type identifier.
neighbors | [in] If TRUE, this indexes neighbor nodes, otherwise not.
Returns
Unique Sparksee type identifier.
int com.sparsity.sparksee.gdb.Graph.NewSessionArrayAttribute | ( | int | type,
 |  | com.sparsity.sparksee.gdb.DataType | dt,
 |  | int | size
 | ) |  |

Creates a new Session array attribute.

Session attributes are exclusive for the Session (just its Session can use the attribute) and are automatically removed when the Session is closed (thus, attribute data is not persistent into the database).

Since they are not persistent, they cannot be retrieved from the database, so they do not have an identifier name.

Parameters
type | [in] Sparksee node or edge type identifier.
dt | [in] Base Data type for the new array attribute elements.
size | [in] The array size.
Returns
Unique Sparksee attribute identifier.
int com.sparsity.sparksee.gdb.Graph.NewSessionAttribute | ( | int | type,
 |  | com.sparsity.sparksee.gdb.DataType | dt,
 |  | com.sparsity.sparksee.gdb.AttributeKind | kind,
 |  | com.sparsity.sparksee.gdb.Value | defaultValue
 | ) |  |

Creates a new Session attribute with a default value.

Session attributes are exclusive for the Session (just its Session can use the attribute) and are automatically removed when the Session is closed (thus, attribute data is not persistent into the database).

Since they are not persistent, they cannot be retrieved from the database, so they do not have an identifier name.

Parameters
type | [in] Sparksee node or edge type identifier.
dt | [in] Data type for the new attribute.
kind | [in] Attribute kind.
defaultValue | [in] The default value to use in each new node/edge.
Returns
Unique Sparksee attribute identifier.
int com.sparsity.sparksee.gdb.Graph.NewSessionAttribute | ( | int | type,
 |  | com.sparsity.sparksee.gdb.DataType | dt,
 |  | com.sparsity.sparksee.gdb.AttributeKind | kind
 | ) |  |

Creates a new Session attribute.

Session attributes are exclusive for the Session (just its Session can use the attribute) and are automatically removed when the Session is closed (thus, attribute data is not persistent into the database).

Since they are not persistent, they cannot be retrieved from the database, so they do not have an identifier name.

Parameters
type | [in] Sparksee node or edge type identifier.
dt | [in] Data type for the new attribute.
kind | [in] Attribute kind.
Returns
Unique Sparksee attribute identifier.
void com.sparsity.sparksee.gdb.Graph.RemoveAttribute ( int attr )

Removes the given attribute.

Parameters
attr [in] Sparksee attribute identifier.
void com.sparsity.sparksee.gdb.Graph.RemoveType ( int type )

Removes the given type.

This fails if there exist attributes defined for the type or if there exist restricted edges referencing this type.

Parameters
type [in] Sparksee type identifier.
void com.sparsity.sparksee.gdb.Graph.RenameAttribute | ( | int | attr,
 |  | System.String | newName
 | ) |  |

Renames an attribute.

The new name must be available.

Parameters
attr | [in] Sparksee attribute identifier.
newName | [in] The new name for the attribute.
void com.sparsity.sparksee.gdb.Graph.RenameType | ( | System.String | oldName,
 |  | System.String | newName
 | ) |  |

Renames a type.

The new name must be available.

Parameters
oldName | [in] The current name of the type to be renamed.
newName | [in] The new name for the type.
void com.sparsity.sparksee.gdb.Graph.RenameType | ( | int | type,
 |  | System.String | newName
 | ) |  |

Renames a type.

The new name must be available.

Parameters
type | [in] The type to be renamed.
newName | [in] The new name for the type.
com.sparsity.sparksee.gdb.Objects com.sparsity.sparksee.gdb.Graph.Select | ( | int | attr,
 |  | com.sparsity.sparksee.gdb.Condition | cond,
 |  | com.sparsity.sparksee.gdb.Value | value,
 |  | com.sparsity.sparksee.gdb.Objects | restriction
 | ) |  |

Selects all OIDs satisfying the given condition for the given attribute.

Parameters
attr | [in] Sparksee attribute identifier.
cond | [in] Condition to be satisfied.
value | [in] Value to be satisfied.
restriction | [in] Objects to limit the select in this set of objects.
Returns
Objects instance.
com.sparsity.sparksee.gdb.Objects com.sparsity.sparksee.gdb.Graph.Select | ( | int | attr,
 |  | com.sparsity.sparksee.gdb.Condition | cond,
 |  | com.sparsity.sparksee.gdb.Value | lower,
 |  | com.sparsity.sparksee.gdb.Value | higher
 | ) |  |

Selects all OIDs satisfying the given condition for the given attribute.

This allows to perform the Between operation, thus it has two Value arguments.

Parameters
attr | [in] Sparksee attribute identifier.
cond | [in] Condition to be satisfied. It must be the Between Condition.
lower | [in] Lower-bound Value to be satisfied.
higher | [in] Higher-bound Value to be satisfied.
Returns
Objects instance.
com.sparsity.sparksee.gdb.Objects com.sparsity.sparksee.gdb.Graph.Select ( int type )

Selects all OIDs belonging to the given type.

Parameters
type [in] Sparksee type identifier.
Returns
Objects instance.
com.sparsity.sparksee.gdb.Objects com.sparsity.sparksee.gdb.Graph.Select | ( | int | attr,
 |  | com.sparsity.sparksee.gdb.Condition | cond,
 |  | com.sparsity.sparksee.gdb.Value | value
 | ) |  |

Selects all OIDs satisfying the given condition for the given attribute.

Parameters
attr | [in] Sparksee attribute identifier.
cond | [in] Condition to be satisfied.
value | [in] Value to be satisfied.
Returns
Objects instance.
com.sparsity.sparksee.gdb.Objects com.sparsity.sparksee.gdb.Graph.Select | ( | int | attr,
 |  | com.sparsity.sparksee.gdb.Condition | cond,
 |  | com.sparsity.sparksee.gdb.Value | lower,
 |  | com.sparsity.sparksee.gdb.Value | higher,
 |  | com.sparsity.sparksee.gdb.Objects | restriction
 | ) |  |

Selects all OIDs satisfying the given condition for the given attribute.

This allows to perform the Between operation, thus it has two Value arguments.

Parameters
attr | [in] Sparksee attribute identifier.
cond | [in] Condition to be satisfied. It must be the Between Condition.
lower | [in] Lower-bound Value to be satisfied.
higher | [in] Higher-bound Value to be satisfied.
restriction | [in] Objects to limit the select in this set of objects.
Returns
Objects instance.
com.sparsity.sparksee.gdb.ValueArray com.sparsity.sparksee.gdb.Graph.SetArrayAttribute | ( | long | oid,
 |  | int | attr,
 |  | com.sparsity.sparksee.gdb.Value | value
 | ) |  |

Sets all the elements of the ValueArray for the given array attribute and OID and returns it.

Initializing the array with one of these SetArrayAttribute methods is the only way to create the array. But once created it can be updated using the ValueArray. And you can get it again with the GetArrayAttribute operation.

Parameters
oid | [in] Sparksee OID.
attr | [in] Sparksee array attribute identifier.
value | [in] Value for all the array elements of the given attribute and OID.
Returns
A ValueArray. This returns a ValueArray, a NULL or throws an exception.
void com.sparsity.sparksee.gdb.Graph.SetArrayAttribute | ( | int | attr,
 |  | com.sparsity.sparksee.gdb.Value | value
 | ) |  |

Sets all the values of the array of the given array attribute for all the objects of the types the attribute applies to.

Parameters
attr | [in] Sparksee array attribute identifier.
value | [in] Value for all the array elements of the arrays.
void com.sparsity.sparksee.gdb.Graph.SetArrayAttributeVoid | ( | long | oid,
 |  | int | attr,
 |  | com.sparsity.sparksee.gdb.Value | value
 | ) |  |

Sets all the elements of the ValueArray for the given array attribute and OID.

Initializing the array with one of these SetArrayAttribute methods is the only way to create the array. But once created it can be updated using the ValueArray which can be obtained using the GetArrayAttribute operation.

Parameters
oid | [in] Sparksee OID.
attr | [in] Sparksee array attribute identifier.
value | [in] Value for all the array elements of the given attribute and OID.
void com.sparsity.sparksee.gdb.Graph.SetAttribute | ( | int | attr,
 |  | com.sparsity.sparksee.gdb.Value | value
 | ) |  |

Sets the value of the given attribute for all the objects of the types the attribute applies to.

Does not work for TEXT attribute types

txThe Transaction this operation belongs to attributeThe attribute to initialize

Parameters
attr | null
value | The value to initialize the attribute to
void com.sparsity.sparksee.gdb.Graph.SetAttribute | ( | long | oid,
 |  | int | attr,
 |  | com.sparsity.sparksee.gdb.Value | value
 | ) |  |

Sets the Value for the given attribute and OID.

Parameters
oid | [in] Sparksee OID.
attr | [in] Sparksee attribute identifier.
value | [in] Value for the given attribute and for the given OID.
void com.sparsity.sparksee.gdb.Graph.SetAttributeDefaultValue | ( | int | attr,
 |  | com.sparsity.sparksee.gdb.Value | value
 | ) |  |

Sets a default value for an attribute.

The default value will be applied to all the new nodes or edges.

The given value must have the same DataType as the attribute or be a NULL value to remove the current default value.

Parameters
attr | [in] The attribute.
value | [in] The default value to use for this attribute.
void com.sparsity.sparksee.gdb.Graph.SetAttributeText | ( | long | oid,
 |  | int | attr,
 |  | com.sparsity.sparksee.gdb.TextStream | tstream
 | ) |  |

Sets the writable TextStream for the given text attribute and OID.

Parameters
oid | [in] Sparksee OID.
attr | [in] Sparksee attribute identifier.
tstream | [in] New Text value. This corresponds to a TextStream to write.
com.sparsity.sparksee.gdb.Objects com.sparsity.sparksee.gdb.Graph.Tails ( com.sparsity.sparksee.gdb.Objects edges )

Gets all the tails from the given edges collection.

Parameters
edges [in] Sparksee edge identifier collection.
Returns
The tails collection.
void com.sparsity.sparksee.gdb.Graph.TailsAndHeads | ( | com.sparsity.sparksee.gdb.Objects | edges,
 |  | com.sparsity.sparksee.gdb.Objects | tails,
 |  | com.sparsity.sparksee.gdb.Objects | heads
 | ) |  |

Gets all the tails and heads from the given edges collection.

Parameters
edges | [in] Sparksee edge identifier collection.
tails | [in|out] If not NULL, all the tails will be stored here.
heads | [in|out] If not NULL, all the heads will be stored here.
com.sparsity.sparksee.gdb.KeyValues com.sparsity.sparksee.gdb.Graph.TopK | ( | int | attribute,
 |  | com.sparsity.sparksee.gdb.Condition | operation,
 |  | com.sparsity.sparksee.gdb.Value | lower,
 |  | com.sparsity.sparksee.gdb.Order | order,
 |  | int | k,
 |  | com.sparsity.sparksee.gdb.Objects | restriction
 | ) |  |

Gets a KeyValues iterator as a result of the TopK operation.

restrictonObjects to limit the topk to this set of objects

Parameters
attribute | The attribute to perform the TopK on
operation | The operation to perform in the top k
lower | The lower bound Value to be satisfied
order | The ordering semantincs of the top-k
k | The size of the TopK
restriction | null
Returns
A KeyValues instance
com.sparsity.sparksee.gdb.KeyValues com.sparsity.sparksee.gdb.Graph.TopK | ( | int | attribute,
 |  | com.sparsity.sparksee.gdb.Condition | operation,
 |  | com.sparsity.sparksee.gdb.Value | lower,
 |  | com.sparsity.sparksee.gdb.Value | higher,
 |  | com.sparsity.sparksee.gdb.Order | order,
 |  | int | k,
 |  | com.sparsity.sparksee.gdb.Objects | restriction
 | ) |  |

Gets a KeyValues iterator as a result of the TopK operation.

restrictonObjects to limit the topk to this set of objects

Parameters
attribute | The attribute to perform the TopK on
operation | The operation to perform in the top k
lower | The lower bound Value to be satisfied
higher | The upper bound Value to be satisfied
order | The ordering semantincs of the top-k
k | The size of the TopK
restriction | null
Returns
A KeyValues instance
com.sparsity.sparksee.gdb.KeyValues com.sparsity.sparksee.gdb.Graph.TopK | ( | int | attribute,
 |  | com.sparsity.sparksee.gdb.Condition | operation,
 |  | com.sparsity.sparksee.gdb.Value | lower,
 |  | com.sparsity.sparksee.gdb.Order | order,
 |  | int | k
 | ) |  |

Gets a KeyValues iterator as a result of the TopK operation.

Parameters
attribute | The attribute to perform the TopK on
operation | The operation to perform in the top k
lower | The lower bound Value to be satisfied
order | The ordering semantincs of the top-k
k | The size of the TopK
Returns
A KeyValues instance
com.sparsity.sparksee.gdb.KeyValues com.sparsity.sparksee.gdb.Graph.TopK | ( | int | attribute,
 |  | com.sparsity.sparksee.gdb.Order | order,
 |  | int | k,
 |  | com.sparsity.sparksee.gdb.Objects | restriction
 | ) |  |

Gets a KeyValues iterator as a result of the TopK operation.

restrictonObjects to limit the topk to this set of objects

Parameters
attribute | The attribute to perform the TopK on
order | The ordering semantincs of the top-k
k | The size of the TopK
restriction | null
Returns
A KeyValues instance
com.sparsity.sparksee.gdb.KeyValues com.sparsity.sparksee.gdb.Graph.TopK | ( | int | attribute,
 |  | com.sparsity.sparksee.gdb.Order | order,
 |  | int | k
 | ) |  |

Gets a KeyValues iterator as a result of the TopK operation.

Parameters
attribute | The attribute to perform the TopK on
order | The ordering semantincs of the top-k
k | The size of the TopK
Returns
A KeyValues instance
com.sparsity.sparksee.gdb.KeyValues com.sparsity.sparksee.gdb.Graph.TopK | ( | int | attribute,
 |  | com.sparsity.sparksee.gdb.Condition | operation,
 |  | com.sparsity.sparksee.gdb.Value | lower,
 |  | com.sparsity.sparksee.gdb.Value | higher,
 |  | com.sparsity.sparksee.gdb.Order | order,
 |  | int | k
 | ) |  |

Gets a KeyValues iterator as a result of the TopK operation.

Parameters
attribute | The attribute to perform the TopK on
operation | The operation to perform in the top k
lower | The lower bound Value to be satisfied
higher | The upper bound Value to be satisfied
order | The ordering semantincs of the top-k
k | The size of the TopK
Returns
A KeyValues instance


SparkseeNet: Member List

  • gdb
  • Graph
com.sparsity.sparksee.gdb.Graph Member List

This is the complete list of members for com.sparsity.sparksee.gdb.Graph, including all inherited members.

Backup(System.String file) | com.sparsity.sparksee.gdb.Graph
CountEdges() | com.sparsity.sparksee.gdb.Graph
CountNodes() | com.sparsity.sparksee.gdb.Graph
Degree(long oid, int etype, com.sparsity.sparksee.gdb.EdgesDirection dir) | com.sparsity.sparksee.gdb.Graph
Drop(long oid) | com.sparsity.sparksee.gdb.Graph
Drop(com.sparsity.sparksee.gdb.Objects objs) | com.sparsity.sparksee.gdb.Graph
DumpData(System.String file) | com.sparsity.sparksee.gdb.Graph
DumpStorage(System.String file) | com.sparsity.sparksee.gdb.Graph
Edges(int etype, long tail, long head) | com.sparsity.sparksee.gdb.Graph
EncryptedBackup(System.String file, System.String keyInHex, System.String ivInHex) | com.sparsity.sparksee.gdb.Graph
Explode(com.sparsity.sparksee.gdb.Objects objs, int etype, com.sparsity.sparksee.gdb.EdgesDirection dir) | com.sparsity.sparksee.gdb.Graph
Explode(long oid, int etype, com.sparsity.sparksee.gdb.EdgesDirection dir) | com.sparsity.sparksee.gdb.Graph
Export(System.String file, com.sparsity.sparksee.gdb.ExportType type, com.sparsity.sparksee.gdb.ExportManager em) | com.sparsity.sparksee.gdb.Graph
FindAttribute(int type, System.String name) | com.sparsity.sparksee.gdb.Graph
FindAttributes(int type) | com.sparsity.sparksee.gdb.Graph
FindEdge(int etype, long tail, long head) | com.sparsity.sparksee.gdb.Graph
FindEdgeTypes() | com.sparsity.sparksee.gdb.Graph
FindNodeTypes() | com.sparsity.sparksee.gdb.Graph
FindObject(int attr, com.sparsity.sparksee.gdb.Value value) | com.sparsity.sparksee.gdb.Graph
FindOrCreateEdge(int etype, long tail, long head) | com.sparsity.sparksee.gdb.Graph
FindOrCreateObject(int attr, com.sparsity.sparksee.gdb.Value value) | com.sparsity.sparksee.gdb.Graph
FindType(System.String name) | com.sparsity.sparksee.gdb.Graph
FindTypes() | com.sparsity.sparksee.gdb.Graph
GetArrayAttribute(long oid, int attr) | com.sparsity.sparksee.gdb.Graph
GetAttribute(long oid, int attr) | com.sparsity.sparksee.gdb.Graph
GetAttribute(long oid, int attr, com.sparsity.sparksee.gdb.Value value) | com.sparsity.sparksee.gdb.Graph
GetAttribute(int attr) | com.sparsity.sparksee.gdb.Graph
GetAttributeIntervalCount(int attr, com.sparsity.sparksee.gdb.Value lower, bool includeLower, com.sparsity.sparksee.gdb.Value higher, bool includeHigher) | com.sparsity.sparksee.gdb.Graph
GetAttributes(long oid) | com.sparsity.sparksee.gdb.Graph
GetAttributeStatistics(int attr, bool basic) | com.sparsity.sparksee.gdb.Graph
GetAttributeText(long oid, int attr) | com.sparsity.sparksee.gdb.Graph
GetEdgeData(long edge) | com.sparsity.sparksee.gdb.Graph
GetEdgePeer(long edge, long node) | com.sparsity.sparksee.gdb.Graph
GetObjectType(long oid) | com.sparsity.sparksee.gdb.Graph
GetType(int type) | com.sparsity.sparksee.gdb.Graph
GetValues(int attr) | com.sparsity.sparksee.gdb.Graph
Heads(com.sparsity.sparksee.gdb.Objects edges) | com.sparsity.sparksee.gdb.Graph
IndexAttribute(int attr, com.sparsity.sparksee.gdb.AttributeKind kind) | com.sparsity.sparksee.gdb.Graph
IndexNeighbors(int edgeType, bool neighbors) | com.sparsity.sparksee.gdb.Graph
Neighbors(com.sparsity.sparksee.gdb.Objects objs, int etype, com.sparsity.sparksee.gdb.EdgesDirection dir) | com.sparsity.sparksee.gdb.Graph
Neighbors(long oid, int etype, com.sparsity.sparksee.gdb.EdgesDirection dir) | com.sparsity.sparksee.gdb.Graph
NewArrayAttribute(int type, System.String name, com.sparsity.sparksee.gdb.DataType dt, int size) | com.sparsity.sparksee.gdb.Graph
NewAttribute(int type, System.String name, com.sparsity.sparksee.gdb.DataType dt, com.sparsity.sparksee.gdb.AttributeKind kind) | com.sparsity.sparksee.gdb.Graph
NewAttribute(int type, System.String name, com.sparsity.sparksee.gdb.DataType dt, com.sparsity.sparksee.gdb.AttributeKind kind, com.sparsity.sparksee.gdb.Value defaultValue) | com.sparsity.sparksee.gdb.Graph
NewEdge(int type, int tailAttr, com.sparsity.sparksee.gdb.Value tailV, int headAttr, com.sparsity.sparksee.gdb.Value headV) | com.sparsity.sparksee.gdb.Graph
NewEdge(int type, long tail, long head) | com.sparsity.sparksee.gdb.Graph
NewEdgeType(System.String name, bool directed, bool neighbors) | com.sparsity.sparksee.gdb.Graph
NewNode(int type) | com.sparsity.sparksee.gdb.Graph
NewNodeType(System.String name) | com.sparsity.sparksee.gdb.Graph
NewRestrictedEdgeType(System.String name, int tail, int head, bool neighbors) | com.sparsity.sparksee.gdb.Graph
NewSessionArrayAttribute(int type, com.sparsity.sparksee.gdb.DataType dt, int size) | com.sparsity.sparksee.gdb.Graph
NewSessionAttribute(int type, com.sparsity.sparksee.gdb.DataType dt, com.sparsity.sparksee.gdb.AttributeKind kind, com.sparsity.sparksee.gdb.Value defaultValue) | com.sparsity.sparksee.gdb.Graph
NewSessionAttribute(int type, com.sparsity.sparksee.gdb.DataType dt, com.sparsity.sparksee.gdb.AttributeKind kind) | com.sparsity.sparksee.gdb.Graph
RemoveAttribute(int attr) | com.sparsity.sparksee.gdb.Graph
RemoveType(int type) | com.sparsity.sparksee.gdb.Graph
RenameAttribute(int attr, System.String newName) | com.sparsity.sparksee.gdb.Graph
RenameType(System.String oldName, System.String newName) | com.sparsity.sparksee.gdb.Graph
RenameType(int type, System.String newName) | com.sparsity.sparksee.gdb.Graph
Select(int attr, com.sparsity.sparksee.gdb.Condition cond, com.sparsity.sparksee.gdb.Value value, com.sparsity.sparksee.gdb.Objects restriction) | com.sparsity.sparksee.gdb.Graph
Select(int attr, com.sparsity.sparksee.gdb.Condition cond, com.sparsity.sparksee.gdb.Value lower, com.sparsity.sparksee.gdb.Value higher) | com.sparsity.sparksee.gdb.Graph
Select(int type) | com.sparsity.sparksee.gdb.Graph
Select(int attr, com.sparsity.sparksee.gdb.Condition cond, com.sparsity.sparksee.gdb.Value value) | com.sparsity.sparksee.gdb.Graph
Select(int attr, com.sparsity.sparksee.gdb.Condition cond, com.sparsity.sparksee.gdb.Value lower, com.sparsity.sparksee.gdb.Value higher, com.sparsity.sparksee.gdb.Objects restriction) | com.sparsity.sparksee.gdb.Graph
SetArrayAttribute(long oid, int attr, com.sparsity.sparksee.gdb.Value value) | com.sparsity.sparksee.gdb.Graph
SetArrayAttribute(int attr, com.sparsity.sparksee.gdb.Value value) | com.sparsity.sparksee.gdb.Graph
SetArrayAttributeVoid(long oid, int attr, com.sparsity.sparksee.gdb.Value value) | com.sparsity.sparksee.gdb.Graph
SetAttribute(int attr, com.sparsity.sparksee.gdb.Value value) | com.sparsity.sparksee.gdb.Graph
SetAttribute(long oid, int attr, com.sparsity.sparksee.gdb.Value value) | com.sparsity.sparksee.gdb.Graph
SetAttributeDefaultValue(int attr, com.sparsity.sparksee.gdb.Value value) | com.sparsity.sparksee.gdb.Graph
SetAttributeText(long oid, int attr, com.sparsity.sparksee.gdb.TextStream tstream) | com.sparsity.sparksee.gdb.Graph
Tails(com.sparsity.sparksee.gdb.Objects edges) | com.sparsity.sparksee.gdb.Graph
TailsAndHeads(com.sparsity.sparksee.gdb.Objects edges, com.sparsity.sparksee.gdb.Objects tails, com.sparsity.sparksee.gdb.Objects heads) | com.sparsity.sparksee.gdb.Graph
TopK(int attribute, com.sparsity.sparksee.gdb.Condition operation, com.sparsity.sparksee.gdb.Value lower, com.sparsity.sparksee.gdb.Order order, int k, com.sparsity.sparksee.gdb.Objects restriction) | com.sparsity.sparksee.gdb.Graph
TopK(int attribute, com.sparsity.sparksee.gdb.Condition operation, com.sparsity.sparksee.gdb.Value lower, com.sparsity.sparksee.gdb.Value higher, com.sparsity.sparksee.gdb.Order order, int k, com.sparsity.sparksee.gdb.Objects restriction) | com.sparsity.sparksee.gdb.Graph
TopK(int attribute, com.sparsity.sparksee.gdb.Condition operation, com.sparsity.sparksee.gdb.Value lower, com.sparsity.sparksee.gdb.Order order, int k) | com.sparsity.sparksee.gdb.Graph
TopK(int attribute, com.sparsity.sparksee.gdb.Order order, int k, com.sparsity.sparksee.gdb.Objects restriction) | com.sparsity.sparksee.gdb.Graph
TopK(int attribute, com.sparsity.sparksee.gdb.Order order, int k) | com.sparsity.sparksee.gdb.Graph
TopK(int attribute, com.sparsity.sparksee.gdb.Condition operation, com.sparsity.sparksee.gdb.Value lower, com.sparsity.sparksee.gdb.Value higher, com.sparsity.sparksee.gdb.Order order, int k) | com.sparsity.sparksee.gdb.Graph


SparkseeNet: com.sparsity.sparksee.gdb.GraphExport Class Reference

  • gdb
  • GraphExport
Public Member Functions | List of all members
com.sparsity.sparksee.gdb.GraphExport Class Reference

Stores the graph exporting values. More...

Public Member Functions

System.String | GetLabel ()
Gets the graph label.
void | SetDefaults ()
Sets to default values.
GraphExport ()
Creates a new GraphExport instance.
void | SetLabel (System.String label)
Sets the graph label.

Detailed Description

Stores the graph exporting values.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

System.String com.sparsity.sparksee.gdb.GraphExport.GetLabel ( )

Gets the graph label.

Returns
The graph label.
void com.sparsity.sparksee.gdb.GraphExport.SetLabel ( System.String label )

Sets the graph label.

Parameters
label [in] The graph label.


SparkseeNet: Member List

  • gdb
  • GraphExport
com.sparsity.sparksee.gdb.GraphExport Member List

This is the complete list of members for com.sparsity.sparksee.gdb.GraphExport, including all inherited members.

GetLabel() | com.sparsity.sparksee.gdb.GraphExport
GraphExport() | com.sparsity.sparksee.gdb.GraphExport
SetDefaults() | com.sparsity.sparksee.gdb.GraphExport
SetLabel(System.String label) | com.sparsity.sparksee.gdb.GraphExport


SparkseeNet: com.sparsity.sparksee.gdb.Int32List Class Reference

  • gdb
  • Int32List
Public Member Functions | List of all members
com.sparsity.sparksee.gdb.Int32List Class Reference

Sparksee 32-bit signed integer list. More...

Public Member Functions

void | Add (int value)
Adds an 32-bit signed integer at the end of the list.
void | Clear ()
Clears the list.
Int32List (System.Collections.Generic.ICollection< int > col)
Creates a new instance from an integer collection.
Int32List ()
Constructor.
com.sparsity.sparksee.gdb.Int32ListIterator Iterator ()
Gets a new Int32ListIterator.
Int32List (int[] list)
Creates a new instance from an integer array.
int | Count ()
Number of elements in the list.

Detailed Description

Sparksee 32-bit signed integer list.

It stores a 32-bit signed integer list.

Use Int32ListIterator to access all elements into this collection.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

com.sparsity.sparksee.gdb.Int32List.Int32List ( System.Collections.Generic.ICollection< int > col )

Creates a new instance from an integer collection.

Parameters
col Collection to initialize the instance.
com.sparsity.sparksee.gdb.Int32List.Int32List ( )

Constructor.

This creates an empty list.

com.sparsity.sparksee.gdb.Int32List.Int32List ( int[] list )

Creates a new instance from an integer array.

Parameters
list Integer array to initialize the instance.

Member Function Documentation

void com.sparsity.sparksee.gdb.Int32List.Add ( int value )

Adds an 32-bit signed integer at the end of the list.

Parameters
value [in] The integer.
int com.sparsity.sparksee.gdb.Int32List.Count ( )

Number of elements in the list.

Returns
Number of elements in the list.
com.sparsity.sparksee.gdb.Int32ListIterator com.sparsity.sparksee.gdb.Int32List.Iterator ( )

Gets a new Int32ListIterator.

Returns
Int32ListIterator instance.


SparkseeNet: Member List

  • gdb
  • Int32List
com.sparsity.sparksee.gdb.Int32List Member List

This is the complete list of members for com.sparsity.sparksee.gdb.Int32List, including all inherited members.

Add(int value) | com.sparsity.sparksee.gdb.Int32List
Clear() | com.sparsity.sparksee.gdb.Int32List
Count() | com.sparsity.sparksee.gdb.Int32List
Int32List(System.Collections.Generic.ICollection< int > col) | com.sparsity.sparksee.gdb.Int32List
Int32List() | com.sparsity.sparksee.gdb.Int32List
Int32List(int[] list) | com.sparsity.sparksee.gdb.Int32List
Iterator() | com.sparsity.sparksee.gdb.Int32List


SparkseeNet: com.sparsity.sparksee.gdb.Int32ListIterator Class Reference

  • gdb
  • Int32ListIterator
Public Member Functions | List of all members
com.sparsity.sparksee.gdb.Int32ListIterator Class Reference

Int32List iterator class. More...

Public Member Functions

bool | HasNext ()
Gets if there are more elements.
int | Next ()
Moves to the next element.

Detailed Description

Int32List iterator class.

Iterator to traverse all the integer into a Int32List instance.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

bool com.sparsity.sparksee.gdb.Int32ListIterator.HasNext ( )

Gets if there are more elements.

Returns
TRUE if there are more elements, FALSE otherwise.
int com.sparsity.sparksee.gdb.Int32ListIterator.Next ( )

Moves to the next element.

Returns
The next element.


SparkseeNet: Member List

  • gdb
  • Int32ListIterator
com.sparsity.sparksee.gdb.Int32ListIterator Member List

This is the complete list of members for com.sparsity.sparksee.gdb.Int32ListIterator, including all inherited members.

HasNext() | com.sparsity.sparksee.gdb.Int32ListIterator
Next() | com.sparsity.sparksee.gdb.Int32ListIterator


SparkseeNet: com.sparsity.sparksee.gdb.KeyValue Class Reference

  • gdb
  • KeyValue
Public Member Functions | List of all members
com.sparsity.sparksee.gdb.KeyValue Class Reference

Public Member Functions

int | CompareTo (com.sparsity.sparksee.gdb.KeyValue other)
Compares the current instance with another object of the same type.
int | CompareTo (System.Object other)
Compares the current instance with another object of the same type.
string | ToString ()
Gets a string representation of the Value.
bool | Equals (System.Object other)
Indicates whether the current object is equal to another object.

Member Function Documentation

int com.sparsity.sparksee.gdb.KeyValue.CompareTo ( com.sparsity.sparksee.gdb.KeyValue other )

Compares the current instance with another object of the same type.

Parameters
other Another Value to compare with this instance.
Returns
Less than zero, if the instance is less than other; Zero, if the instance is equal to other; and greater than zero if the instance is greater than other.
int com.sparsity.sparksee.gdb.KeyValue.CompareTo ( System.Object other )

Compares the current instance with another object of the same type.

Parameters
other An object to compare with this instance.
Returns
Less than zero, if the instance is less than other; Zero, if the instance is equal to other; and greater than zero if the instance is greater than other.
bool com.sparsity.sparksee.gdb.KeyValue.Equals ( System.Object other )

Indicates whether the current object is equal to another object.

Parameters
other An object to compare with this instance.
Returns
TRUE if the current object is equal to the other; otherwise, FALSE.


SparkseeNet: Member List

  • gdb
  • KeyValue
com.sparsity.sparksee.gdb.KeyValue Member List

This is the complete list of members for com.sparsity.sparksee.gdb.KeyValue, including all inherited members.

CompareTo(com.sparsity.sparksee.gdb.KeyValue other) | com.sparsity.sparksee.gdb.KeyValue
CompareTo(System.Object other) | com.sparsity.sparksee.gdb.KeyValue
Equals(System.Object other) | com.sparsity.sparksee.gdb.KeyValue
ToString() | com.sparsity.sparksee.gdb.KeyValue


SparkseeNet: com.sparsity.sparksee.gdb.KeyValues Class Reference

  • gdb
  • KeyValues
Public Member Functions | List of all members
com.sparsity.sparksee.gdb.KeyValues Class Reference

Value set class. More...

Public Member Functions

boolean | IsClosed ()
Gets if KeyValues instance has been closed or not.
void | Close ()
Closes the KeyValues instance.
bool | HasNext ()
Checks if the KeyValues has more KeyValue pairs.
com.sparsity.sparksee.gdb.KeyValue Next ()
Gets the next KeyValue pair.
void | Next (com.sparsity.sparksee.gdb.KeyValue kv)
Gets the next KeyValue pair.

Detailed Description

Value set class.

This is a set of Value instances, that is there is no duplicated elements.

Use a ValuesIterator to traverse all the elements into the set.

When the Values instance is closed, it closes all existing and non-closed ValuesIterator instances too.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

void com.sparsity.sparksee.gdb.KeyValues.Close ( )

Closes the KeyValues instance.

It must be called to ensure the integrity of all data.

bool com.sparsity.sparksee.gdb.KeyValues.HasNext ( )

Checks if the KeyValues has more KeyValue pairs.

Returns
Returns ture if there are more KeyValue pairs
boolean com.sparsity.sparksee.gdb.KeyValues.IsClosed ( )

Gets if KeyValues instance has been closed or not.

See Also
Close()
Returns
TRUE if the KeyValues instance has been closed, FALSE otherwise.
com.sparsity.sparksee.gdb.KeyValue com.sparsity.sparksee.gdb.KeyValues.Next ( )

Gets the next KeyValue pair.

Returns
Returns the next KeyValue pair
void com.sparsity.sparksee.gdb.KeyValues.Next ( com.sparsity.sparksee.gdb.KeyValue kv )

Gets the next KeyValue pair.

Parameters
kv Returns the next KeyValue pair


SparkseeNet: Member List

  • gdb
  • KeyValues
com.sparsity.sparksee.gdb.KeyValues Member List

This is the complete list of members for com.sparsity.sparksee.gdb.KeyValues, including all inherited members.

Close() | com.sparsity.sparksee.gdb.KeyValues
HasNext() | com.sparsity.sparksee.gdb.KeyValues
IsClosed() | com.sparsity.sparksee.gdb.KeyValues
Next() | com.sparsity.sparksee.gdb.KeyValues
Next(com.sparsity.sparksee.gdb.KeyValue kv) | com.sparsity.sparksee.gdb.KeyValues


SparkseeNet: com.sparsity.sparksee.gdb.NodeExport Class Reference

  • gdb
  • NodeExport
Public Member Functions | List of all members
com.sparsity.sparksee.gdb.NodeExport Class Reference

Stores the node exporting values. More...

Public Member Functions

com.sparsity.sparksee.gdb.NodeShape GetShape ()
Gets the node shape.
void | SetColorRGB (int color)
Sets the node color.
void | SetHeight (int height)
Sets the node height.
int | GetFontSize ()
Gets the node label font size.
void | SetDefaults ()
Sets to default values.
int | GetColorRGB ()
Gets the node color.
bool | IsFit ()
Gets whether the node size is fitted to the label or not.
int | GetLabelColorRGB ()
Gets the node label color.
int | GetWidth ()
Gets the node width.
void | SetLabel (System.String label)
Sets the node label.
void | SetLabelColor (System.Drawing.Color c)
Sets the color of the label.
void | SetColor (System.Drawing.Color c)
Sets the color of the node.
System.String | GetLabel ()
Gets the node label.
int | GetHeight ()
Gets the node height.
NodeExport ()
Creates a new instance.
System.Drawing.Color | GetColor ()
Gets the color of the node.
void | SetLabelColorRGB (int color)
Sets the node label color.
System.Drawing.Color | GetLabelColor ()
Gets the color of the label.
void | SetWidth (int width)
Gets the node width.
void | SetShape (com.sparsity.sparksee.gdb.NodeShape shape)
Sets the node shape.
void | SetFit (bool fit)
Sets the node fit property.
void | SetFontSize (int size)
Sets the node label font size.

Detailed Description

Stores the node exporting values.

When 'fit' is set to TRUE, then 'height' and 'width' will be ignored.

Some properties may be ignored depending on the exportation type.

Default values are:

Label: "" (empty string).

Shape: Box.

Color: 10863606 (0xa5c3f6).

Label color: 0 (Ox000000, Black).

Height: 25px.

Width: 25px.

Fit: TRUE.

Font size: 10.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

int com.sparsity.sparksee.gdb.NodeExport.GetColorRGB ( )

Gets the node color.

Returns
The node color.
int com.sparsity.sparksee.gdb.NodeExport.GetFontSize ( )

Gets the node label font size.

Returns
The node label font size.
int com.sparsity.sparksee.gdb.NodeExport.GetHeight ( )

Gets the node height.

Returns
The node height in pixels.
System.String com.sparsity.sparksee.gdb.NodeExport.GetLabel ( )

Gets the node label.

Returns
The node label.
int com.sparsity.sparksee.gdb.NodeExport.GetLabelColorRGB ( )

Gets the node label color.

Returns
The node label color.
com.sparsity.sparksee.gdb.NodeShape com.sparsity.sparksee.gdb.NodeExport.GetShape ( )

Gets the node shape.

Returns
The node shape.
int com.sparsity.sparksee.gdb.NodeExport.GetWidth ( )

Gets the node width.

Returns
The node width in pixels.
bool com.sparsity.sparksee.gdb.NodeExport.IsFit ( )

Gets whether the node size is fitted to the label or not.

Returns
If TRUE, then the node size is fitted to the label, otherwise the size is fixed with the values of 'height' and 'width'.
void com.sparsity.sparksee.gdb.NodeExport.SetColor ( System.Drawing.Color c )

Sets the color of the node.

Parameters
c New value.
void com.sparsity.sparksee.gdb.NodeExport.SetColorRGB ( int color )

Sets the node color.

Parameters
color The node color.
void com.sparsity.sparksee.gdb.NodeExport.SetFit ( bool fit )

Sets the node fit property.

Parameters
fit [in] If TRUE, then the node size is fitted to the label ('height' and 'width' will be ignored), otherwise the size is fixed with the values of 'height' and 'width'.
void com.sparsity.sparksee.gdb.NodeExport.SetFontSize ( int size )

Sets the node label font size.

Parameters
size [in] The node label font size.
void com.sparsity.sparksee.gdb.NodeExport.SetHeight ( int height )

Sets the node height.

Parameters
height [in] The node height in pixels.
void com.sparsity.sparksee.gdb.NodeExport.SetLabel ( System.String label )

Sets the node label.

Parameters
label [in] The node label.
void com.sparsity.sparksee.gdb.NodeExport.SetLabelColor ( System.Drawing.Color c )

Sets the color of the label.

Parameters
c New value.
void com.sparsity.sparksee.gdb.NodeExport.SetLabelColorRGB ( int color )

Sets the node label color.

Parameters
color [in] The node label color.
void com.sparsity.sparksee.gdb.NodeExport.SetShape ( com.sparsity.sparksee.gdb.NodeShape shape )

Sets the node shape.

Parameters
shape [in] The node shape.
void com.sparsity.sparksee.gdb.NodeExport.SetWidth ( int width )

Gets the node width.

Parameters
width The node width in pixels.


SparkseeNet: Member List

  • gdb
  • NodeExport
com.sparsity.sparksee.gdb.NodeExport Member List

This is the complete list of members for com.sparsity.sparksee.gdb.NodeExport, including all inherited members.

GetColor() | com.sparsity.sparksee.gdb.NodeExport
GetColorRGB() | com.sparsity.sparksee.gdb.NodeExport
GetFontSize() | com.sparsity.sparksee.gdb.NodeExport
GetHeight() | com.sparsity.sparksee.gdb.NodeExport
GetLabel() | com.sparsity.sparksee.gdb.NodeExport
GetLabelColor() | com.sparsity.sparksee.gdb.NodeExport
GetLabelColorRGB() | com.sparsity.sparksee.gdb.NodeExport
GetShape() | com.sparsity.sparksee.gdb.NodeExport
GetWidth() | com.sparsity.sparksee.gdb.NodeExport
IsFit() | com.sparsity.sparksee.gdb.NodeExport
NodeExport() | com.sparsity.sparksee.gdb.NodeExport
SetColor(System.Drawing.Color c) | com.sparsity.sparksee.gdb.NodeExport
SetColorRGB(int color) | com.sparsity.sparksee.gdb.NodeExport
SetDefaults() | com.sparsity.sparksee.gdb.NodeExport
SetFit(bool fit) | com.sparsity.sparksee.gdb.NodeExport
SetFontSize(int size) | com.sparsity.sparksee.gdb.NodeExport
SetHeight(int height) | com.sparsity.sparksee.gdb.NodeExport
SetLabel(System.String label) | com.sparsity.sparksee.gdb.NodeExport
SetLabelColor(System.Drawing.Color c) | com.sparsity.sparksee.gdb.NodeExport
SetLabelColorRGB(int color) | com.sparsity.sparksee.gdb.NodeExport
SetShape(com.sparsity.sparksee.gdb.NodeShape shape) | com.sparsity.sparksee.gdb.NodeExport
SetWidth(int width) | com.sparsity.sparksee.gdb.NodeExport


SparkseeNet: com.sparsity.sparksee.gdb.Objects Class Reference

  • gdb
  • Objects
Public Member Functions | Static Public Member Functions | Static Public Attributes | List of all members
com.sparsity.sparksee.gdb.Objects Class Reference

Object identifier set class. More...

Public Member Functions

long | Any () throws System.ApplicationException, System.ApplicationException
Gets an element from the collection.
long | Difference (com.sparsity.sparksee.gdb.Objects objs)
Performs the difference operation.
com.sparsity.sparksee.gdb.ObjectsIterator | IteratorFromElement (long e)
Gets an ObjectsIterator starting from the given element.
bool | Exists (long e)
Gets if the given element exists into the collection.
bool | Equals (com.sparsity.sparksee.gdb.Objects objs)
Checks if the given Objects contains the same information.
long | Copy (com.sparsity.sparksee.gdb.Objects objs)
Performs the copy operation.
com.sparsity.sparksee.gdb.Objects | Sample (com.sparsity.sparksee.gdb.Objects exclude, long samples)
Creates a new Objects instance which is a sample of the calling one.
boolean | IsClosed ()
Gets if Objects instance has been closed or not.
void | Close ()
Closes the Objects instance.
bool | Contains (com.sparsity.sparksee.gdb.Objects objs)
Check if this objects contains the other one.
long | Count ()
Gets the number of elements into the collection.
void | Clear ()
Clears the collection removing all its elements.
com.sparsity.sparksee.gdb.ObjectsIterator | IteratorFromIndex (long index)
Gets an ObjectsIterator skipping index elements.
bool | Remove (long e)
Removes an element from the collection.
long | Intersection (com.sparsity.sparksee.gdb.Objects objs)
Performs the intersection operation.
bool | Equals (System.Object other)
Indicates whether the current object is equal to another object.
com.sparsity.sparksee.gdb.ObjectsIterator Iterator ()
Gets an ObjectsIterator.
long | Union (com.sparsity.sparksee.gdb.Objects objs)
Performs the union operation.
bool | Add (long e)
Adds an element into the collection.
com.sparsity.sparksee.gdb.Objects Copy ()
Creates a new Objects instance as a copy of the given one.

Static Public Member Functions

static
com.sparsity.sparksee.gdb.Objects 		CombineUnion (com.sparsity.sparksee.gdb.Objects objs1, com.sparsity.sparksee.gdb.Objects objs2)
Creates a new Objects instance which is the union of the two given.
static
com.sparsity.sparksee.gdb.Objects 		CombineDifference (com.sparsity.sparksee.gdb.Objects objs1, com.sparsity.sparksee.gdb.Objects objs2)
Creates a new Objects instance which is the difference of the two given.
static
com.sparsity.sparksee.gdb.Objects 		CombineIntersection (com.sparsity.sparksee.gdb.Objects objs1, com.sparsity.sparksee.gdb.Objects objs2)
Creates a new Objects instance which is the intersection of the two given.

Static Public Attributes

static long InvalidOID
Invalid OID constant.

Detailed Description

Object identifier set class.

It stores a collection of Sparksee object identifiers as a set. As a set, there is no order and no duplicated elements.

This class should be used just to store large collections. Otherwise, it is strongly recommended to use common classes from the language API.

This class is not thread-safe.

ObjectsIterator must be used to traverse all the elements into the set.

When the Objects instance is closed, it closes all existing and non-closed ObjectsIterator instances too.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

bool com.sparsity.sparksee.gdb.Objects.Add ( long e )

Adds an element into the collection.

Parameters
e [in] Element to be added.
Returns
TRUE if the element is added, FALSE if the element was already into the collection.
long com.sparsity.sparksee.gdb.Objects.Any ( ) throws System.ApplicationException, System.ApplicationException

Gets an element from the collection.

Returns
Any element from the collection.
Exceptions
System.ApplicationException | whether the collection is empty.
System.ApplicationException | null
void com.sparsity.sparksee.gdb.Objects.Close ( )

Closes the Objects instance.

It must be called to ensure the integrity of all data.

static com.sparsity.sparksee.gdb.Objects com.sparsity.sparksee.gdb.Objects.CombineDifference | ( | com.sparsity.sparksee.gdb.Objects | objs1,
 |  | com.sparsity.sparksee.gdb.Objects | objs2
 | ) |  |
static

Creates a new Objects instance which is the difference of the two given.

Two given Objects belong to the same Session.

Parameters
objs1 | [in] Objects instance.
objs2 | [in] Objects instance.
Returns
New Objects instance.
static com.sparsity.sparksee.gdb.Objects com.sparsity.sparksee.gdb.Objects.CombineIntersection | ( | com.sparsity.sparksee.gdb.Objects | objs1,
 |  | com.sparsity.sparksee.gdb.Objects | objs2
 | ) |  |
static

Creates a new Objects instance which is the intersection of the two given.

Two given Objects belong to the same Session.

Parameters
objs1 | [in] Objects instance.
objs2 | [in] Objects instance.
Returns
New Objects instance.
static com.sparsity.sparksee.gdb.Objects com.sparsity.sparksee.gdb.Objects.CombineUnion | ( | com.sparsity.sparksee.gdb.Objects | objs1,
 |  | com.sparsity.sparksee.gdb.Objects | objs2
 | ) |  |
static

Creates a new Objects instance which is the union of the two given.

Two given Objects belong to the same Session.

Parameters
objs1 | [in] Objects instance.
objs2 | [in] Objects instance.
Returns
New Objects instance.
bool com.sparsity.sparksee.gdb.Objects.Contains ( com.sparsity.sparksee.gdb.Objects objs )

Check if this objects contains the other one.

Parameters
objs Objects collection.
Returns
True if it contains the given object.
long com.sparsity.sparksee.gdb.Objects.Copy ( com.sparsity.sparksee.gdb.Objects objs )

Performs the copy operation.

This updates the Objects calling instance and copies the given Objects instance.

Parameters
objs [in] Objects instance.
Returns
Number of elements into the collection once the operation has been executed.
com.sparsity.sparksee.gdb.Objects com.sparsity.sparksee.gdb.Objects.Copy ( )

Creates a new Objects instance as a copy of the given one.

Returns
The new Objects instance.
long com.sparsity.sparksee.gdb.Objects.Count ( )

Gets the number of elements into the collection.

Returns
The number of elements into the collection.
long com.sparsity.sparksee.gdb.Objects.Difference ( com.sparsity.sparksee.gdb.Objects objs )

Performs the difference operation.

This updates the Objects calling instance removing those existing elements at the given Objects instance.

Parameters
objs [in] Objects instance.
Returns
Number of elements into the collection once the operation has been executed.
bool com.sparsity.sparksee.gdb.Objects.Equals ( com.sparsity.sparksee.gdb.Objects objs )

Checks if the given Objects contains the same information.

Parameters
objs [in] Objects instance.
Returns
True if the objects are equal or false otherwise.
bool com.sparsity.sparksee.gdb.Objects.Equals ( System.Object other )

Indicates whether the current object is equal to another object.

Parameters
other An object to compare with this instance.
Returns
TRUE if the current object is equal to the other; otherwise, FALSE.
bool com.sparsity.sparksee.gdb.Objects.Exists ( long e )

Gets if the given element exists into the collection.

Parameters
e [in] Element.
Returns
TRUE if the element exists into the collection, FALSE otherwise.
long com.sparsity.sparksee.gdb.Objects.Intersection ( com.sparsity.sparksee.gdb.Objects objs )

Performs the intersection operation.

Updates the Objects calling instance setting those existing elements at both two collections and removing all others.

Parameters
objs [in] Objects instance.
Returns
Number of elements into the collection once the operation has been executed.
boolean com.sparsity.sparksee.gdb.Objects.IsClosed ( )

Gets if Objects instance has been closed or not.

See Also
Close()
Returns
TRUE if the Objects instance has been closed, FALSE otherwise.
com.sparsity.sparksee.gdb.ObjectsIterator com.sparsity.sparksee.gdb.Objects.Iterator ( )

Gets an ObjectsIterator.

Returns
ObjectsIterator instance.
com.sparsity.sparksee.gdb.ObjectsIterator com.sparsity.sparksee.gdb.Objects.IteratorFromElement ( long e )

Gets an ObjectsIterator starting from the given element.

Objects collection has no order, so this method is implementation-dependent. e[in] The first element to traverse in the resulting

Parameters
e [in] The first element to traverse in the resulting ObjectsIterator instance.
Returns
ObjectsIterator instance.
com.sparsity.sparksee.gdb.ObjectsIterator com.sparsity.sparksee.gdb.Objects.IteratorFromIndex ( long index )

Gets an ObjectsIterator skipping index elements.

Objects collection has no order, so this method is implementation-dependent.

Parameters
index [in] The number of elements to skip from the beginning. It must be in the range [0..Size).
Returns
ObjectsIterator instance.
bool com.sparsity.sparksee.gdb.Objects.Remove ( long e )

Removes an element from the collection.

Parameters
e [in] Element to be removed.
Returns
TRUE if the element is removed, FALSE if the element was not into the collection.
com.sparsity.sparksee.gdb.Objects com.sparsity.sparksee.gdb.Objects.Sample | ( | com.sparsity.sparksee.gdb.Objects | exclude,
 |  | long | samples
 | ) |  |

Creates a new Objects instance which is a sample of the calling one.

Parameters
exclude | [in] If not NULL, elements into this collection will be excluded from the resulting one.
samples | [in] Number of elements into the resulting collection.
Returns
Sample collection.
long com.sparsity.sparksee.gdb.Objects.Union ( com.sparsity.sparksee.gdb.Objects objs )

Performs the union operation.

This adds all existing elements of the given Objects instance to the Objects calling instance

Parameters
objs [in] Objects instance.
Returns
Number of elements into the collection once the operation has been executed.


SparkseeNet: Member List

  • gdb
  • Objects
com.sparsity.sparksee.gdb.Objects Member List

This is the complete list of members for com.sparsity.sparksee.gdb.Objects, including all inherited members.

Add(long e) | com.sparsity.sparksee.gdb.Objects |
Any() | com.sparsity.sparksee.gdb.Objects |
Clear() | com.sparsity.sparksee.gdb.Objects |
Close() | com.sparsity.sparksee.gdb.Objects |
CombineDifference(com.sparsity.sparksee.gdb.Objects objs1, com.sparsity.sparksee.gdb.Objects objs2) | com.sparsity.sparksee.gdb.Objects | static
CombineIntersection(com.sparsity.sparksee.gdb.Objects objs1, com.sparsity.sparksee.gdb.Objects objs2) | com.sparsity.sparksee.gdb.Objects | static
CombineUnion(com.sparsity.sparksee.gdb.Objects objs1, com.sparsity.sparksee.gdb.Objects objs2) | com.sparsity.sparksee.gdb.Objects | static
Contains(com.sparsity.sparksee.gdb.Objects objs) | com.sparsity.sparksee.gdb.Objects |
Copy(com.sparsity.sparksee.gdb.Objects objs) | com.sparsity.sparksee.gdb.Objects |
Copy() | com.sparsity.sparksee.gdb.Objects |
Count() | com.sparsity.sparksee.gdb.Objects |
Difference(com.sparsity.sparksee.gdb.Objects objs) | com.sparsity.sparksee.gdb.Objects |
Equals(com.sparsity.sparksee.gdb.Objects objs) | com.sparsity.sparksee.gdb.Objects |
Equals(System.Object other) | com.sparsity.sparksee.gdb.Objects |
Exists(long e) | com.sparsity.sparksee.gdb.Objects |
Intersection(com.sparsity.sparksee.gdb.Objects objs) | com.sparsity.sparksee.gdb.Objects |
InvalidOID | com.sparsity.sparksee.gdb.Objects | static
IsClosed() | com.sparsity.sparksee.gdb.Objects |
Iterator() | com.sparsity.sparksee.gdb.Objects |
IteratorFromElement(long e) | com.sparsity.sparksee.gdb.Objects |
IteratorFromIndex(long index) | com.sparsity.sparksee.gdb.Objects |
Remove(long e) | com.sparsity.sparksee.gdb.Objects |
Sample(com.sparsity.sparksee.gdb.Objects exclude, long samples) | com.sparsity.sparksee.gdb.Objects |
Union(com.sparsity.sparksee.gdb.Objects objs) | com.sparsity.sparksee.gdb.Objects |


SparkseeNet: com.sparsity.sparksee.gdb.ObjectsIterator Class Reference

  • gdb
  • ObjectsIterator
Public Member Functions | List of all members
com.sparsity.sparksee.gdb.ObjectsIterator Class Reference

ObjectsIterator class. More...

Public Member Functions

boolean | IsClosed ()
Gets if ObjectsIterator instance has been closed or not.
void | Close ()
Closes the ObjectsIterator instance.
bool | HasNext ()
Gets if there are more elements to traverse.
long | Next ()
Gets the next element to traverse.

Detailed Description

ObjectsIterator class.

Iterator to traverse all the object identifiers from an Objects instance.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

void com.sparsity.sparksee.gdb.ObjectsIterator.Close ( )

Closes the ObjectsIterator instance.

It must be called to ensure the integrity of all data.

bool com.sparsity.sparksee.gdb.ObjectsIterator.HasNext ( )

Gets if there are more elements to traverse.

Returns
TRUE if there are more elements to traverse, FALSE otherwise.
boolean com.sparsity.sparksee.gdb.ObjectsIterator.IsClosed ( )

Gets if ObjectsIterator instance has been closed or not.

See Also
Close()
Returns
TRUE if the ObjectsIterator instance has been closed, FALSE otherwise.
long com.sparsity.sparksee.gdb.ObjectsIterator.Next ( )

Gets the next element to traverse.

Returns
The next element.


SparkseeNet: Member List

  • gdb
  • ObjectsIterator
com.sparsity.sparksee.gdb.ObjectsIterator Member List

This is the complete list of members for com.sparsity.sparksee.gdb.ObjectsIterator, including all inherited members.

Close() | com.sparsity.sparksee.gdb.ObjectsIterator
HasNext() | com.sparsity.sparksee.gdb.ObjectsIterator
IsClosed() | com.sparsity.sparksee.gdb.ObjectsIterator
Next() | com.sparsity.sparksee.gdb.ObjectsIterator


SparkseeNet: com.sparsity.sparksee.gdb.OIDList Class Reference

  • gdb
  • OIDList
Public Member Functions | List of all members
com.sparsity.sparksee.gdb.OIDList Class Reference

Sparksee object identifier list. More...

Public Member Functions

OIDList (System.Collections.Generic.ICollection< long > col)
Creates a new instance from a long collection.
OIDList (long[] list)
Creates a new instance from a long array.
void | Add (long attr)
Adds a Sparksee object identifier at the end of the list.
void | Clear ()
Clears the list.
void | Set (int pos, long oid)
Sets a Sparksee object identifier at the specified position of the list.
com.sparsity.sparksee.gdb.OIDListIterator Iterator ()
Gets a new OIDListIterator.
int | Count ()
Number of elements in the list.
OIDList (int numInvalidOIDs)
Constructor.
OIDList ()
Constructor.

Detailed Description

Sparksee object identifier list.

It stores a Sparksee object identifier list.

Use OIDListIterator to access all elements into this collection.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

com.sparsity.sparksee.gdb.OIDList.OIDList ( System.Collections.Generic.ICollection< long > col )

Creates a new instance from a long collection.

Parameters
col Collection to initialize the instance.
com.sparsity.sparksee.gdb.OIDList.OIDList ( long[] list )

Creates a new instance from a long array.

Parameters
list Long array to initialize the instance.
com.sparsity.sparksee.gdb.OIDList.OIDList ( int numInvalidOIDs )

Constructor.

This creates a list with N invalid oids.

Parameters
numInvalidOIDs [in] The number of invalid oids added to the list.
com.sparsity.sparksee.gdb.OIDList.OIDList ( )

Constructor.

This creates an empty list.

Member Function Documentation

void com.sparsity.sparksee.gdb.OIDList.Add ( long attr )

Adds a Sparksee object identifier at the end of the list.

Parameters
attr [in] Sparksee object identifier.
int com.sparsity.sparksee.gdb.OIDList.Count ( )

Number of elements in the list.

Returns
Number of elements in the list.
com.sparsity.sparksee.gdb.OIDListIterator com.sparsity.sparksee.gdb.OIDList.Iterator ( )

Gets a new OIDListIterator.

Returns
OIDListIterator instance.
void com.sparsity.sparksee.gdb.OIDList.Set | ( | int | pos,
 |  | long | oid
 | ) |  |

Sets a Sparksee object identifier at the specified position of the list.

Parameters
pos | [in] List position [0..Count()-1].
oid | [in] Sparksee object identifier.


SparkseeNet: Member List

  • gdb
  • OIDList
com.sparsity.sparksee.gdb.OIDList Member List

This is the complete list of members for com.sparsity.sparksee.gdb.OIDList, including all inherited members.

Add(long attr) | com.sparsity.sparksee.gdb.OIDList
Clear() | com.sparsity.sparksee.gdb.OIDList
Count() | com.sparsity.sparksee.gdb.OIDList
Iterator() | com.sparsity.sparksee.gdb.OIDList
OIDList(System.Collections.Generic.ICollection< long > col) | com.sparsity.sparksee.gdb.OIDList
OIDList(long[] list) | com.sparsity.sparksee.gdb.OIDList
OIDList(int numInvalidOIDs) | com.sparsity.sparksee.gdb.OIDList
OIDList() | com.sparsity.sparksee.gdb.OIDList
Set(int pos, long oid) | com.sparsity.sparksee.gdb.OIDList


SparkseeNet: com.sparsity.sparksee.gdb.OIDListIterator Class Reference

  • gdb
  • OIDListIterator
Public Member Functions | List of all members
com.sparsity.sparksee.gdb.OIDListIterator Class Reference

OIDList iterator class. More...

Public Member Functions

bool | HasNext ()
Gets if there are more elements.
long | Next ()
Moves to the next element.

Detailed Description

OIDList iterator class.

Iterator to traverse all the Sparksee object identifier into a OIDList instance.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

bool com.sparsity.sparksee.gdb.OIDListIterator.HasNext ( )

Gets if there are more elements.

Returns
TRUE if there are more elements, FALSE otherwise.
long com.sparsity.sparksee.gdb.OIDListIterator.Next ( )

Moves to the next element.

Returns
The next element.


SparkseeNet: Member List

  • gdb
  • OIDListIterator
com.sparsity.sparksee.gdb.OIDListIterator Member List

This is the complete list of members for com.sparsity.sparksee.gdb.OIDListIterator, including all inherited members.

HasNext() | com.sparsity.sparksee.gdb.OIDListIterator
Next() | com.sparsity.sparksee.gdb.OIDListIterator


SparkseeNet: com.sparsity.sparksee.gdb.Platform Class Reference

  • gdb
  • Platform
Static Public Member Functions | List of all members
com.sparsity.sparksee.gdb.Platform Class Reference

Platform class. More...

Static Public Member Functions

static void GetStatistics (com.sparsity.sparksee.gdb.PlatformStatistics stats)
Gets platform data and statistics.

Detailed Description

Platform class.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

static void com.sparsity.sparksee.gdb.Platform.GetStatistics ( com.sparsity.sparksee.gdb.PlatformStatistics stats )
static

Gets platform data and statistics.

Parameters
stats [in|out] This updates the given PlatformStatistics.


SparkseeNet: Member List

  • gdb
  • Platform
com.sparsity.sparksee.gdb.Platform Member List

This is the complete list of members for com.sparsity.sparksee.gdb.Platform, including all inherited members.

GetStatistics(com.sparsity.sparksee.gdb.PlatformStatistics stats) com.sparsity.sparksee.gdb.Platform static


SparkseeNet: com.sparsity.sparksee.gdb.PlatformStatistics Class Reference

  • gdb
  • PlatformStatistics
Public Member Functions | List of all members
com.sparsity.sparksee.gdb.PlatformStatistics Class Reference

Platform data and statistics. More...

Public Member Functions

long | GetRealTime ()
Gets time in microseconds (since epoch).
long | GetAvailableMem ()
Gets avialable (free) memory size in Bytes.
long | GetTotalMem ()
Gets physical memory size in Bytes.
long | GetSystemTime ()
Gets CPU system time.
long | GetUserTime ()
Gets CPU user time.
int | GetNumCPUs ()
Gets the number of CPUs.
PlatformStatistics ()
Creates a new instance setting all values to 0.

Detailed Description

Platform data and statistics.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

long com.sparsity.sparksee.gdb.PlatformStatistics.GetAvailableMem ( )

Gets avialable (free) memory size in Bytes.

Returns
Avialable (free) memory size in Bytes.
int com.sparsity.sparksee.gdb.PlatformStatistics.GetNumCPUs ( )

Gets the number of CPUs.

Returns
The number of CPUs.
long com.sparsity.sparksee.gdb.PlatformStatistics.GetRealTime ( )

Gets time in microseconds (since epoch).

Returns
Time in microseconds (since epoch).
long com.sparsity.sparksee.gdb.PlatformStatistics.GetSystemTime ( )

Gets CPU system time.

Returns
CPU system time.
long com.sparsity.sparksee.gdb.PlatformStatistics.GetTotalMem ( )

Gets physical memory size in Bytes.

Returns
Physical memory size in Bytes.
long com.sparsity.sparksee.gdb.PlatformStatistics.GetUserTime ( )

Gets CPU user time.

Returns
CPU user time.


SparkseeNet: Member List

  • gdb
  • PlatformStatistics
com.sparsity.sparksee.gdb.PlatformStatistics Member List

This is the complete list of members for com.sparsity.sparksee.gdb.PlatformStatistics, including all inherited members.

GetAvailableMem() | com.sparsity.sparksee.gdb.PlatformStatistics
GetNumCPUs() | com.sparsity.sparksee.gdb.PlatformStatistics
GetRealTime() | com.sparsity.sparksee.gdb.PlatformStatistics
GetSystemTime() | com.sparsity.sparksee.gdb.PlatformStatistics
GetTotalMem() | com.sparsity.sparksee.gdb.PlatformStatistics
GetUserTime() | com.sparsity.sparksee.gdb.PlatformStatistics
PlatformStatistics() | com.sparsity.sparksee.gdb.PlatformStatistics


SparkseeNet: com.sparsity.sparksee.gdb.Query Class Reference

  • gdb
  • Query
Public Member Functions | List of all members
com.sparsity.sparksee.gdb.Query Class Reference

Query class. More...

Public Member Functions

void | SetDynamic (System.String name, com.sparsity.sparksee.gdb.Value value)
Sets the value for a dynamic paramater.
com.sparsity.sparksee.gdb.QueryStream | SetStream (System.String stream, com.sparsity.sparksee.gdb.QueryStream handler)
Sets a query stream handler.
com.sparsity.sparksee.gdb.ResultSet | Execute (System.String stmt, bool reiterable)
Executes the given statement.

Detailed Description

Query class.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

com.sparsity.sparksee.gdb.ResultSet com.sparsity.sparksee.gdb.Query.Execute | ( | System.String | stmt,
 |  | bool | reiterable
 | ) |  |

Executes the given statement.

Parameters
stmt | [in] Query statement.
reiterable | [in] Whether we want the resultset to be reiterable or not
Returns
A ResultSet instance with the contents of the result of the query.
void com.sparsity.sparksee.gdb.Query.SetDynamic | ( | System.String | name,
 |  | com.sparsity.sparksee.gdb.Value | value
 | ) |  |

Sets the value for a dynamic paramater.

Parameters
name | [in] Parameter name
value | [in] Parameter value
com.sparsity.sparksee.gdb.QueryStream com.sparsity.sparksee.gdb.Query.SetStream | ( | System.String | stream,
 |  | com.sparsity.sparksee.gdb.QueryStream | handler
 | ) |  |

Sets a query stream handler.

Query streams handlers are created and destroyed by the caller.

Parameters
stream | [in] The stream name
handler | [in] Query stream handler
Returns
The previous handler, or NULL if it does not exists


SparkseeNet: Member List

  • gdb
  • Query
com.sparsity.sparksee.gdb.Query Member List

This is the complete list of members for com.sparsity.sparksee.gdb.Query, including all inherited members.

Execute(System.String stmt, bool reiterable) | com.sparsity.sparksee.gdb.Query
SetDynamic(System.String name, com.sparsity.sparksee.gdb.Value value) | com.sparsity.sparksee.gdb.Query
SetStream(System.String stream, com.sparsity.sparksee.gdb.QueryStream handler) | com.sparsity.sparksee.gdb.Query


SparkseeNet: com.sparsity.sparksee.gdb.QueryContext Class Reference

  • gdb
  • QueryContext
Public Member Functions | List of all members
com.sparsity.sparksee.gdb.QueryContext Class Reference

Query context interface. More...

Public Member Functions

QueryContext ()
Default constructor.
com.sparsity.sparksee.gdb.Query NewQuery ()
Creates a new Query.

Detailed Description

Query context interface.

A QueryContext contains and manages the resources required to run a Query. A Session is one example of a QueryContext connected to a Sparksee database. The applications can implement their own contexts to run queries out of Sparksee.

Author
Sparsity Technologies http://www.sparsity-technologies.com


SparkseeNet: Member List

  • gdb
  • QueryContext
com.sparsity.sparksee.gdb.QueryContext Member List

This is the complete list of members for com.sparsity.sparksee.gdb.QueryContext, including all inherited members.

NewQuery() | com.sparsity.sparksee.gdb.QueryContext
QueryContext() | com.sparsity.sparksee.gdb.QueryContext


SparkseeNet: com.sparsity.sparksee.gdb.QueryStream Class Reference

  • gdb
  • QueryStream
Public Member Functions | List of all members
com.sparsity.sparksee.gdb.QueryStream Class Reference

Query stream interface. More...

Public Member Functions

bool | Start (com.sparsity.sparksee.gdb.ResultSetList list)
Starts the stream.
bool | Fetch (com.sparsity.sparksee.gdb.ValueList list)
Gets the next row and moves the iterator forward.
bool | Prepare (com.sparsity.sparksee.gdb.ValueList list)
Prepares the stream before it is started.

Detailed Description

Query stream interface.

A QueryStream is the interface between the application and the STREAM operator. When the operator starts inside a Query, the method is prepared with query-defined arguments. Then, if there are input operations, the STREAM operator builds the ResultSets and starts the iteration. Finally, the operator fetches rows until no more are available.

Application exceptions must be cached by the subclass that implements the interface.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

bool com.sparsity.sparksee.gdb.QueryStream.Fetch ( com.sparsity.sparksee.gdb.ValueList list )

Gets the next row and moves the iterator forward.

The end of sequence is denoted by returning TRUE with an empty row. A valid row must contain as many values (even NULL) as expected by the query.

Parameters
list [out] Storage for the new rows
Returns
TRUE if there is a row or end of sequence, FALSE on error
bool com.sparsity.sparksee.gdb.QueryStream.Prepare ( com.sparsity.sparksee.gdb.ValueList list )

Prepares the stream before it is started.

Parameters
list [in] Optional list of arguments
Returns
FALSE on error
bool com.sparsity.sparksee.gdb.QueryStream.Start ( com.sparsity.sparksee.gdb.ResultSetList list )

Starts the stream.

Parameters
list [in] Optional list of input ResultSets
Returns
FALSE on error


SparkseeNet: Member List

  • gdb
  • QueryStream
com.sparsity.sparksee.gdb.QueryStream Member List

This is the complete list of members for com.sparsity.sparksee.gdb.QueryStream, including all inherited members.

Fetch(com.sparsity.sparksee.gdb.ValueList list) | com.sparsity.sparksee.gdb.QueryStream
Prepare(com.sparsity.sparksee.gdb.ValueList list) | com.sparsity.sparksee.gdb.QueryStream
Start(com.sparsity.sparksee.gdb.ResultSetList list) | com.sparsity.sparksee.gdb.QueryStream


SparkseeNet: com.sparsity.sparksee.gdb.ResultSet Class Reference

  • gdb
  • ResultSet
Public Member Functions | List of all members
com.sparsity.sparksee.gdb.ResultSet Class Reference

ResultSet class. More...

Public Member Functions

void | Rewind ()
Positions the cursor before the first row.
void | GetColumn (int index, com.sparsity.sparksee.gdb.Value value)
Gets the value for the given column.
com.sparsity.sparksee.gdb.Value | GetColumn (int index)
Gets the value for the given column.
int | GetColumnIndex (System.String name)
Gets the column index for the given column name.
bool | Next ()
Fetches the next row.
System.String | GetJSON (int rows)
Returns rows in JSON format.
System.String | GetColumnName (int index)
Gets the name for the given column.
com.sparsity.sparksee.gdb.DataType | GetColumnDataType (int index)
Gets the datatype for the given column.
int | GetNumColumns ()
Gets the number of columns.

Detailed Description

ResultSet class.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

void com.sparsity.sparksee.gdb.ResultSet.GetColumn | ( | int | index,
 |  | com.sparsity.sparksee.gdb.Value | value
 | ) |  |

Gets the value for the given column.

QueryExceptionIf a database access error occurs.

Parameters
index | [in] Column index.
value | [in|out] Value.
com.sparsity.sparksee.gdb.Value com.sparsity.sparksee.gdb.ResultSet.GetColumn ( int index )

Gets the value for the given column.

QueryExceptionIf a database access error occurs.

Parameters
index [in] Column index.
Returns
The Value of the given column.
com.sparsity.sparksee.gdb.DataType com.sparsity.sparksee.gdb.ResultSet.GetColumnDataType ( int index )

Gets the datatype for the given column.

Parameters
index [in] Column index.
Returns
DataType for the given column.
int com.sparsity.sparksee.gdb.ResultSet.GetColumnIndex ( System.String name )

Gets the column index for the given column name.

Parameters
name [in] Column name.
Returns
Column index.
System.String com.sparsity.sparksee.gdb.ResultSet.GetColumnName ( int index )

Gets the name for the given column.

Parameters
index [in] Column index.
Returns
Column name.
System.String com.sparsity.sparksee.gdb.ResultSet.GetJSON ( int rows )

Returns rows in JSON format.

Rows are returned from the current position.

Parameters
rows [in] Maximum number of rows
Returns
JSON representation of the next <rows> rows in the resultset
int com.sparsity.sparksee.gdb.ResultSet.GetNumColumns ( )

Gets the number of columns.

Columns are in the range [0...COLUMNS).

Returns
The number of columns.
bool com.sparsity.sparksee.gdb.ResultSet.Next ( )

Fetches the next row.

A ResultSet cursor is initially positioned before the first row; the first call to the method "Next" makes the first row the current row; the second call makes the second row the current row, and so on.

QueryExceptionIf a database access error occurs.

Returns
TRUE if the next row has been successfully fetched, FALSE otherwise.


SparkseeNet: Member List

  • gdb
  • ResultSet
com.sparsity.sparksee.gdb.ResultSet Member List

This is the complete list of members for com.sparsity.sparksee.gdb.ResultSet, including all inherited members.

GetColumn(int index, com.sparsity.sparksee.gdb.Value value) | com.sparsity.sparksee.gdb.ResultSet
GetColumn(int index) | com.sparsity.sparksee.gdb.ResultSet
GetColumnDataType(int index) | com.sparsity.sparksee.gdb.ResultSet
GetColumnIndex(System.String name) | com.sparsity.sparksee.gdb.ResultSet
GetColumnName(int index) | com.sparsity.sparksee.gdb.ResultSet
GetJSON(int rows) | com.sparsity.sparksee.gdb.ResultSet
GetNumColumns() | com.sparsity.sparksee.gdb.ResultSet
Next() | com.sparsity.sparksee.gdb.ResultSet
Rewind() | com.sparsity.sparksee.gdb.ResultSet


SparkseeNet: com.sparsity.sparksee.gdb.ResultSetList Class Reference

  • gdb
  • ResultSetList
Public Member Functions | List of all members
com.sparsity.sparksee.gdb.ResultSetList Class Reference

ResultSet list. More...

Public Member Functions

ResultSetList ()
Constructor.
com.sparsity.sparksee.gdb.ResultSet | Get (int index)
Returns the ResultSet at the specified position in the list.
void | Clear ()
Clears the list.
com.sparsity.sparksee.gdb.ResultSetListIterator Iterator ()
Gets a new ResultSetListIterator.
int | Count ()
Number of elements in the list.

Detailed Description

ResultSet list.

It stores a ResultSet list.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

com.sparsity.sparksee.gdb.ResultSetList.ResultSetList ( )

Constructor.

This creates an empty list.

Member Function Documentation

int com.sparsity.sparksee.gdb.ResultSetList.Count ( )

Number of elements in the list.

Returns
Number of elements in the list.
com.sparsity.sparksee.gdb.ResultSet com.sparsity.sparksee.gdb.ResultSetList.Get ( int index )

Returns the ResultSet at the specified position in the list.

Parameters
index [in] Index of the element to return, starting at 0.
com.sparsity.sparksee.gdb.ResultSetListIterator com.sparsity.sparksee.gdb.ResultSetList.Iterator ( )

Gets a new ResultSetListIterator.

Returns
ResultSetListIterator instance.


SparkseeNet: Member List

  • gdb
  • ResultSetList
com.sparsity.sparksee.gdb.ResultSetList Member List

This is the complete list of members for com.sparsity.sparksee.gdb.ResultSetList, including all inherited members.

Clear() | com.sparsity.sparksee.gdb.ResultSetList
Count() | com.sparsity.sparksee.gdb.ResultSetList
Get(int index) | com.sparsity.sparksee.gdb.ResultSetList
Iterator() | com.sparsity.sparksee.gdb.ResultSetList
ResultSetList() | com.sparsity.sparksee.gdb.ResultSetList


SparkseeNet: com.sparsity.sparksee.gdb.ResultSetListIterator Class Reference

  • gdb
  • ResultSetListIterator
Public Member Functions | List of all members
com.sparsity.sparksee.gdb.ResultSetListIterator Class Reference

ResultSetList iterator class. More...

Public Member Functions

bool HasNext ()
Gets if there are more elements.
com.sparsity.sparksee.gdb.ResultSet Next ()
Moves to the next element.

Detailed Description

ResultSetList iterator class.

Iterator to traverse all the values into a ResultSetList instance.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

bool com.sparsity.sparksee.gdb.ResultSetListIterator.HasNext ( )

Gets if there are more elements.

Returns
TRUE if there are more elements, FALSE otherwise.
com.sparsity.sparksee.gdb.ResultSet com.sparsity.sparksee.gdb.ResultSetListIterator.Next ( )

Moves to the next element.

Returns
The next element.


SparkseeNet: Member List

  • gdb
  • ResultSetListIterator
com.sparsity.sparksee.gdb.ResultSetListIterator Member List

This is the complete list of members for com.sparsity.sparksee.gdb.ResultSetListIterator, including all inherited members.

HasNext() | com.sparsity.sparksee.gdb.ResultSetListIterator
Next() | com.sparsity.sparksee.gdb.ResultSetListIterator


SparkseeNet: com.sparsity.sparksee.gdb.Session Class Reference

  • gdb
  • Session
Public Member Functions | List of all members
com.sparsity.sparksee.gdb.Session Class Reference

Session class. More...

Public Member Functions

boolean | IsClosed ()
Gets if Session instance has been closed or not.
long | PreCommit ()
PreCommits a transaction.
void | Close ()
Closes the Session instance.
void | Rollback ()
Rollbacks a transaction.
void | BeginUpdate ()
Begins an update transaction.
long | GetInMemoryPoolCapacity ()
Gets the capacity of the in-memory pool.
void | Commit ()
Commits a transaction.
com.sparsity.sparksee.gdb.Graph GetGraph ()
Gets the Graph instance.
com.sparsity.sparksee.gdb.Query | NewQuery (com.sparsity.sparksee.gdb.QueryLanguage lang)
Creates a new Query.
void | Begin ()
Begins a transaction.
com.sparsity.sparksee.gdb.Objects NewObjects ()
Creates a new Objects instance.

Detailed Description

Session class.

A Session is a stateful period of activity of a user with the Database.

All the manipulation of a Database must be enclosed into a Session. A Session can be initiated from a Database instance and allows for getting a Graph instance which represents the persistent graph (the graph database).

Also, temporary data is associated to the Session, thus when a Session is closed, all the temporary data associated to the Session is removed too. Objects or Values instances or even session attributes are an example of temporary data.

Moreover, a Session is exclusive for a thread, thus if it is shared among threads results may be fatal or unexpected.

Check out the 'Processing' and 'Transactions' sections in the SPARKSEE User Manual for details about how Sessions work and the use of transactions.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

void com.sparsity.sparksee.gdb.Session.Close ( )

Closes the Session instance.

It must be called to ensure the integrity of all data.

com.sparsity.sparksee.gdb.Graph com.sparsity.sparksee.gdb.Session.GetGraph ( )

Gets the Graph instance.

Returns
The Graph instance.
long com.sparsity.sparksee.gdb.Session.GetInMemoryPoolCapacity ( )

Gets the capacity of the in-memory pool.

Returns
Returns the capacity of the in-memory pool
boolean com.sparsity.sparksee.gdb.Session.IsClosed ( )

Gets if Session instance has been closed or not.

See Also
Close()
Returns
TRUE if the Session instance has been closed, FALSE otherwise.
com.sparsity.sparksee.gdb.Objects com.sparsity.sparksee.gdb.Session.NewObjects ( )

Creates a new Objects instance.

Returns
The new Objects instance.
com.sparsity.sparksee.gdb.Query com.sparsity.sparksee.gdb.Session.NewQuery ( com.sparsity.sparksee.gdb.QueryLanguage lang )

Creates a new Query.

Parameters
lang The query language to create the query for
long com.sparsity.sparksee.gdb.Session.PreCommit ( )

PreCommits a transaction.

YOU SHOULD NOT USE THIS METHOD. This method exists for a specific service and it is used to force that the transaction is written in the recovery log even though it had not been committed yet (and may never be).

Returns
The transaction id. This has to be used in RedoPrecommited in case of a recovery process.


SparkseeNet: Member List

  • gdb
  • Session
com.sparsity.sparksee.gdb.Session Member List

This is the complete list of members for com.sparsity.sparksee.gdb.Session, including all inherited members.

Begin() | com.sparsity.sparksee.gdb.Session
BeginUpdate() | com.sparsity.sparksee.gdb.Session
Close() | com.sparsity.sparksee.gdb.Session
Commit() | com.sparsity.sparksee.gdb.Session
GetGraph() | com.sparsity.sparksee.gdb.Session
GetInMemoryPoolCapacity() | com.sparsity.sparksee.gdb.Session
IsClosed() | com.sparsity.sparksee.gdb.Session
NewObjects() | com.sparsity.sparksee.gdb.Session
NewQuery(com.sparsity.sparksee.gdb.QueryLanguage lang) | com.sparsity.sparksee.gdb.Session
PreCommit() | com.sparsity.sparksee.gdb.Session
Rollback() | com.sparsity.sparksee.gdb.Session


SparkseeNet: com.sparsity.sparksee.gdb.Sparksee Class Reference

  • gdb
  • Sparksee
Public Member Functions | Static Public Attributes | List of all members
com.sparsity.sparksee.gdb.Sparksee Class Reference

Sparksee class. More...

Public Member Functions

void | ResizeInMemoryPool (long newCapacity) throws System.SystemException
Resizes the in memory pool allocator.
bool | RemoveChecksums (System.String path) throws System.IO.IOException, System.ApplicationException
Converts a database WITH checksums into a database WITHOUT checksums.
com.sparsity.sparksee.gdb.Database | RestoreEncryptedBackup (System.String path, System.String backupFile, System.String keyInHex, System.String ivInHex) throws System.IO.IOException, System.ApplicationException
Restores a Database from an encrypted backup file.
bool | Decrypt (System.String path) throws System.IO.IOException, System.ApplicationException
Converts a database WITH encryption into a database WITHOUT encryption.
Sparksee (com.sparsity.sparksee.gdb.SparkseeConfig config)
Creates a new instance.
com.sparsity.sparksee.gdb.Database | Create (System.String path, System.String alias) throws System.IO.IOException, System.ApplicationException
Creates a new Database instance.
long | GetInMemoryPoolCapacity ()
Gets the capacity of the in-memory pool (in Megabytes)
com.sparsity.sparksee.gdb.Database | RestoreEncryptedBackup (System.String path, System.String backupFile, com.sparsity.sparksee.gdb.SparkseeConfig config, System.String keyInHex, System.String ivInHex) throws System.IO.IOException, System.ApplicationException
Restores a Database from an encrypted backup file.
com.sparsity.sparksee.gdb.Database | Open (System.String path, bool readOnly) throws System.IO.IOException, System.ApplicationException
Opens an existing Database instance.
bool | VerifyChecksums (System.String path) throws System.IO.IOException, System.ApplicationException
Verifies the Checksum integrity of the given image file and it's recovery log file.
boolean | IsClosed ()
Gets if Sparksee instance has been closed or not.
bool | AddChecksums (System.String path) throws System.IO.IOException, System.ApplicationException
Converts a database WITHOUT checksums into a database WITH checksums.
void | Close ()
Closes the Sparksee instance.
bool | Encrypt (System.String path) throws System.IO.IOException, System.ApplicationException
Converts a database WITHOUT encryption into an encrypted database.
com.sparsity.sparksee.gdb.Database | Open (System.String path, bool readOnly, com.sparsity.sparksee.gdb.SparkseeConfig config) throws System.IO.IOException, System.ApplicationException
Opens an existing Database instance.
com.sparsity.sparksee.gdb.Database | Restore (System.String path, System.String backupFile) throws System.IO.IOException, System.ApplicationException
Restores a Database from a backup file.
com.sparsity.sparksee.gdb.Database | Create (System.String path, System.String alias, com.sparsity.sparksee.gdb.SparkseeConfig config) throws System.IO.IOException, System.ApplicationException
Creates a new Database instance.
com.sparsity.sparksee.gdb.Database | Restore (System.String path, System.String backupFile, com.sparsity.sparksee.gdb.SparkseeConfig config) throws System.IO.IOException, System.ApplicationException
Restores a Database from a backup file.

Static Public Attributes

static System.String Version
Sparksee version.

Detailed Description

Sparksee class.

All Sparksee programs must have one single Sparksee instance to manage one or more Database instances.

This class allows for the creation of new Databases or open an existing one.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

com.sparsity.sparksee.gdb.Sparksee.Sparksee ( com.sparsity.sparksee.gdb.SparkseeConfig config )

Creates a new instance.

Parameters
config [in/out] Sparksee configuration (may be updated).

Member Function Documentation

bool com.sparsity.sparksee.gdb.Sparksee.AddChecksums ( System.String path ) throws System.IO.IOException, System.ApplicationException

Converts a database WITHOUT checksums into a database WITH checksums.

Any error found is logged. The database (and it's recovery log if present) does NOT have checksums. sparksee::gdb::FileNotFoundExceptionsparksee::gdb::Error

Parameters
path The path to the database image file
Returns
Returns true if the checksum could be added or false otherwise.
Exceptions
System.IO.IOException | null
System.ApplicationException | null
void com.sparsity.sparksee.gdb.Sparksee.Close ( )

Closes the Sparksee instance.

It must be called to ensure the integrity of all data.

com.sparsity.sparksee.gdb.Database com.sparsity.sparksee.gdb.Sparksee.Create | ( | System.String | path,
 |  | System.String | alias
 | ) |  | throws System.IO.IOException, System.ApplicationException

Creates a new Database instance.

Parameters
path | [in] Database storage file.
alias | [in] Database alias name.
Returns
A Database instance.
Exceptions
System.IO.IOException | If the given file cannot be created.
System.ApplicationException | null
com.sparsity.sparksee.gdb.Database com.sparsity.sparksee.gdb.Sparksee.Create | ( | System.String | path,
 |  | System.String | alias,
 |  | com.sparsity.sparksee.gdb.SparkseeConfig | config
 | ) |  | throws System.IO.IOException, System.ApplicationException

Creates a new Database instance.

Parameters
path | [in] Database storage file.
alias | [in] Database alias name.
config | [in] Use a specific configuration instead of the one in this Sparksee
Returns
A Database instance.
Exceptions
System.IO.IOException | If the given file cannot be created.
System.ApplicationException | null
bool com.sparsity.sparksee.gdb.Sparksee.Decrypt ( System.String path ) throws System.IO.IOException, System.ApplicationException

Converts a database WITH encryption into a database WITHOUT encryption.

Any error found is logged. The database (and it's recovery log if present) is encrypted. The current encryption had been configured using SparkseeConfig. sparksee::gdb::FileNotFoundExceptionsparksee::gdb::Error

Parameters
path The path to the database image file
Returns
Returns true if the database could be unencrypted. The errors are returned with an exception.
Exceptions
System.IO.IOException | null
System.ApplicationException | null
bool com.sparsity.sparksee.gdb.Sparksee.Encrypt ( System.String path ) throws System.IO.IOException, System.ApplicationException

Converts a database WITHOUT encryption into an encrypted database.

Any error found is logged. The database (and it's recovery log if present) does is NOT encrypted. The encryption had already been configured using SparkseeConfig. sparksee::gdb::FileNotFoundExceptionsparksee::gdb::Error

Parameters
path The path to the database image file
Returns
Returns true if the database could be encrypted. The errors are returned with an exception.
Exceptions
System.IO.IOException | null
System.ApplicationException | null
long com.sparsity.sparksee.gdb.Sparksee.GetInMemoryPoolCapacity ( )

Gets the capacity of the in-memory pool (in Megabytes)

Returns
Returns the capacity of the in memory pool
boolean com.sparsity.sparksee.gdb.Sparksee.IsClosed ( )

Gets if Sparksee instance has been closed or not.

See Also
Close()
Returns
TRUE if the Sparksee instance has been closed, FALSE otherwise.
com.sparsity.sparksee.gdb.Database com.sparsity.sparksee.gdb.Sparksee.Open | ( | System.String | path,
 |  | bool | readOnly
 | ) |  | throws System.IO.IOException, System.ApplicationException

Opens an existing Database instance.

Parameters
path | [in] Database storage file.
readOnly | [in] If TRUE, open Database in read-only mode.
Returns
A Database instance.
Exceptions
System.IO.IOException | If the given file does not exist.
System.ApplicationException | null
com.sparsity.sparksee.gdb.Database com.sparsity.sparksee.gdb.Sparksee.Open | ( | System.String | path,
 |  | bool | readOnly,
 |  | com.sparsity.sparksee.gdb.SparkseeConfig | config
 | ) |  | throws System.IO.IOException, System.ApplicationException

Opens an existing Database instance.

The provided configuration will be used for all the database settings but not for the license, which must already be properly setup in this class.

Parameters
path | [in] Database storage file.
readOnly | [in] If TRUE, open Database in read-only mode.
config | [in] Use a specific configuration instead of the one in this Sparksee
Returns
A Database instance.
Exceptions
System.IO.IOException | If the given file does not exist.
System.ApplicationException | null
bool com.sparsity.sparksee.gdb.Sparksee.RemoveChecksums ( System.String path ) throws System.IO.IOException, System.ApplicationException

Converts a database WITH checksums into a database WITHOUT checksums.

Any error found is logged. The database (and it's recovery log if present) have checksums. sparksee::gdb::FileNotFoundExceptionsparksee::gdb::Error

Parameters
path The path to the database image file
Returns
Returns true if the checksum could be removed. The errors are returned with an exception.
Exceptions
System.IO.IOException | null
System.ApplicationException | null
void com.sparsity.sparksee.gdb.Sparksee.ResizeInMemoryPool ( long newCapacity ) throws System.SystemException

Resizes the in memory pool allocator.

Parameters
newCapacity The new capacity of the in memory pool allocator
Returns
Returns true if was successful
Exceptions
System.SystemException null
com.sparsity.sparksee.gdb.Database com.sparsity.sparksee.gdb.Sparksee.Restore | ( | System.String | path,
 |  | System.String | backupFile
 | ) |  | throws System.IO.IOException, System.ApplicationException

Restores a Database from a backup file.

See the Graph class Backup method.

Parameters
path | [in] Database storage file.
backupFile | [in] The Backup file to be restored.
Returns
A Database instance.
Exceptions
System.IO.IOException | If the given file cannot be created, or the exported data file does not exists.
System.ApplicationException | null
com.sparsity.sparksee.gdb.Database com.sparsity.sparksee.gdb.Sparksee.Restore | ( | System.String | path,
 |  | System.String | backupFile,
 |  | com.sparsity.sparksee.gdb.SparkseeConfig | config
 | ) |  | throws System.IO.IOException, System.ApplicationException

Restores a Database from a backup file.

See the Graph class Backup method.

Parameters
path | [in] Database storage file.
backupFile | [in] The Backup file to be restored.
config | [in] Use a specific configuration instead of the one in this Sparksee
Returns
A Database instance.
Exceptions
System.IO.IOException | If the given file cannot be created, or the exported data file does not exists.
System.ApplicationException | null
com.sparsity.sparksee.gdb.Database com.sparsity.sparksee.gdb.Sparksee.RestoreEncryptedBackup | ( | System.String | path,
 |  | System.String | backupFile,
 |  | System.String | keyInHex,
 |  | System.String | ivInHex
 | ) |  | throws System.IO.IOException, System.ApplicationException

Restores a Database from an encrypted backup file.

See the Graph class EncryptedBackup method.

Parameters
path | [in] Database storage file.
backupFile | [in] The Backup file to be restored.
keyInHex | [In] The AES encryption Key of the backup file as an hexadecimal string (8, 16 or 32 bytes).
ivInHex | [In] The AES Initialization Vector of the backup file as an hexadecimal string (16 bytes).
Returns
A Database instance.
Exceptions
System.IO.IOException | If the given file cannot be created, or the exported data file does not exists.
System.ApplicationException | null
com.sparsity.sparksee.gdb.Database com.sparsity.sparksee.gdb.Sparksee.RestoreEncryptedBackup | ( | System.String | path,
 |  | System.String | backupFile,
 |  | com.sparsity.sparksee.gdb.SparkseeConfig | config,
 |  | System.String | keyInHex,
 |  | System.String | ivInHex
 | ) |  | throws System.IO.IOException, System.ApplicationException

Restores a Database from an encrypted backup file.

See the Graph class EncryptedBackup method.

Parameters
path | [in] Database storage file.
backupFile | [in] The Backup file to be restored.
config | [in] Use a specific configuration instead of the one in this Sparksee
keyInHex | [In] The AES encryption Key of the backup file as an hexadecimal string (8, 16 or 32 bytes).
ivInHex | [In] The AES Initialization Vector of the backup file as an hexadecimal string (16 bytes).
Returns
A Database instance.
Exceptions
System.IO.IOException | If the given file cannot be created, or the exported data file does not exists.
System.ApplicationException | null
bool com.sparsity.sparksee.gdb.Sparksee.VerifyChecksums ( System.String path ) throws System.IO.IOException, System.ApplicationException

Verifies the Checksum integrity of the given image file and it's recovery log file.

The main database file checksums are always checked.

When the recovery log file exists, the recovery log file is also checked for checksum and format errors.

When the checksums of the main file or the recovery file are incorrect, the funcion returns false, in any other error it throws an exception.

Any error found is logged as a WARNING.

sparksee::gdb::FileNotFoundExceptionsparksee::gdb::Error

Parameters
path The path to the image file
Returns
Returns true if the checksum verification succeeded. Returns false if an invalid checksum was detected.
Exceptions
System.IO.IOException | null
System.ApplicationException | null


SparkseeNet: Member List

  • gdb
  • Sparksee
com.sparsity.sparksee.gdb.Sparksee Member List

This is the complete list of members for com.sparsity.sparksee.gdb.Sparksee, including all inherited members.

AddChecksums(System.String path) | com.sparsity.sparksee.gdb.Sparksee |
Close() | com.sparsity.sparksee.gdb.Sparksee |
Create(System.String path, System.String alias) | com.sparsity.sparksee.gdb.Sparksee |
Create(System.String path, System.String alias, com.sparsity.sparksee.gdb.SparkseeConfig config) | com.sparsity.sparksee.gdb.Sparksee |
Decrypt(System.String path) | com.sparsity.sparksee.gdb.Sparksee |
Encrypt(System.String path) | com.sparsity.sparksee.gdb.Sparksee |
GetInMemoryPoolCapacity() | com.sparsity.sparksee.gdb.Sparksee |
IsClosed() | com.sparsity.sparksee.gdb.Sparksee |
Open(System.String path, bool readOnly) | com.sparsity.sparksee.gdb.Sparksee |
Open(System.String path, bool readOnly, com.sparsity.sparksee.gdb.SparkseeConfig config) | com.sparsity.sparksee.gdb.Sparksee |
RemoveChecksums(System.String path) | com.sparsity.sparksee.gdb.Sparksee |
ResizeInMemoryPool(long newCapacity) | com.sparsity.sparksee.gdb.Sparksee |
Restore(System.String path, System.String backupFile) | com.sparsity.sparksee.gdb.Sparksee |
Restore(System.String path, System.String backupFile, com.sparsity.sparksee.gdb.SparkseeConfig config) | com.sparsity.sparksee.gdb.Sparksee |
RestoreEncryptedBackup(System.String path, System.String backupFile, System.String keyInHex, System.String ivInHex) | com.sparsity.sparksee.gdb.Sparksee |
RestoreEncryptedBackup(System.String path, System.String backupFile, com.sparsity.sparksee.gdb.SparkseeConfig config, System.String keyInHex, System.String ivInHex) | com.sparsity.sparksee.gdb.Sparksee |
Sparksee(com.sparsity.sparksee.gdb.SparkseeConfig config) | com.sparsity.sparksee.gdb.Sparksee |
VerifyChecksums(System.String path) | com.sparsity.sparksee.gdb.Sparksee |
Version | com.sparsity.sparksee.gdb.Sparksee | static


SparkseeNet: com.sparsity.sparksee.gdb.SparkseeConfig Class Reference

  • gdb
  • SparkseeConfig
Public Member Functions | List of all members
com.sparsity.sparksee.gdb.SparkseeConfig Class Reference

Sparksee configuration class. More...

Public Member Functions

long | GetHighAvailabilitySynchronization ()
Gets the synchronization polling time.
int | SetLicense (System.String key)
Sets the license key.
void | SetExtentPages (int pages)
Sets the number of pages per extent.
bool | GetChecksumEnabled ()
Gets whether the storage checksum usage is enabled or disabled.
void | SetLicenseId (System.String licenseId)
Set the license identifier.
void | SetHighAvailabilityCoordinators (System.String ip)
Sets the coordinators address and port list.
int | GetExtentSize ()
Gets the size of a extent.
SparkseeConfig (System.String path)
Creates a new instance with a specific config file.
void | SetLogFile (System.String filePath)
Sets the log file.
int | DownloadLicense ()
Try to download a license key Can be used to explicitly download a license when the autodownload is disabled (LicensePreDownloadDays == -1).
void | SetLogLevel (com.sparsity.sparksee.gdb.LogLevel level)
Sets the log level.
void | SetCacheStatisticsEnabled (bool status)
Enables or disables cache statistics.
int | GetPoolPartitions ()
Gets the number of partitions in each PartitionedPool.
bool | SetAESEncryptionEnabled (int keySize)
Enables storage encryption using AES and GENARATES a key and an iv.
System.String | GetLogFile ()
Gets the log file.
void | SetCacheStatisticsSnapshotTime (long microSeconds)
Sets the cache statistics snapshot time.
bool | DownloadExpected ()
Check if a new license will be automatically downloaded with the current settings.
long | GetRecoveryCheckpointTime ()
Gets the delay time (in microseconds) between automatic checkpoints.
bool | GetCacheStatisticsEnabled ()
Gets whether cache statistics are enabled or disabled.
int | GetPoolPersistentMaxSize ()
Gets the maximum size for the persistent pool in number of frames.
System.String | GetSparkseeConfigFile ()
Gets the config file path.
void | SetPoolPersistentMaxSize (int frames)
Sets the maximum size for the persistent pool in number of frames.
System.String | GetRecoveryLogFile ()
Gets the recovery log file.
void | SetHighAvailabilityMasterHistory (long filePath)
Sets the master's history log.
SparkseeConfig ()
Creates a new instance.
void | SetCacheStatisticsFile (System.String filePath)
Sets the cache statistics log file.
System.String | GetHighAvailabilityCoordinators ()
Gets the coordinators address and port list.
System.String | GetTmpFolder ()
Gets the temporary folder used for temporary staging.
void | SetCallStackDump (bool status)
Sets whether the signals will be captured to dump the call stack or not.
void | SetPoolFrameSize (int extents)
Sets the size of a pool frame in number of extents.
System.String | GetCacheStatisticsFile ()
Gets the cache statistics log file.
long | GetCacheStatisticsSnapshotTime ()
Gets the cache statistics snapshot time in microseconds.
int | GetPoolTemporaryMaxSize ()
Gets the maximum size for the temporary pool in number of frames.
void | SetRecoveryEnabled (bool status)
Enables or disables the recovery.
System.String | GetLicense ()
Gets the license key.
int | GetLicensePreDownloadDays ()
Get the number of days before expiration when a new license will be downloaded.
void | SetPoolTemporaryMinSize (int frames)
Sets the minimum size for the temporary pool in number of frames.
bool | SaveAll ()
Save all the current configuration settings in the specified config file.
System.String | GetHighAvailabilityIP ()
Gets the IP address and port of the instance.
void | SetTmpEnabled (bool enabled)
Sets whether to use temporary storage for computations or not.
com.sparsity.sparksee.gdb.LogLevel GetLogLevel ()
Gets the log level.
void | SetHighAvailabilitySynchronization (long microSeconds)
Sets the synchronization polling time.
void | SetCacheMaxSize (int megaBytes)
Sets the maximum size for the cache (all pools) in MB.
int | GetPoolPersistentMinSize ()
Gets the minimum size for the persistent pool in number of frames.
void | SetHighAvailabilityEnabled (bool status)
Enables or disables high availability mode.
bool | SetAESEncryptionEnabled (System.String keyInHex, System.String ivInHex)
Enables storage encryption using AES with the given key and iv.
System.String | GetLicenseId ()
Gets the license identifier.
void | SetClientId (System.String clientId)
Set the client identifier.
System.String | GetClientId ()
Gets the client identifier.
void | SetEncryptionDisabled ()
Disables storage encryption.
void | SetRecoveryCacheMaxSize (int extents)
Sets the maximum size for the recovery log cache in extents.
void | SetInMemAllocSize (long size)
Sets the in-memory allocator size.
long | GetInMemAllocSize ()
Gets the in-memory allocator size.
System.String | GetAESIV ()
Get the AES initialization vector in a hexadecimal encoded string.
bool | GetEncryptionEnabled ()
Gets whether the storage encryption is enabled or disabled.
void | SetHighAvailabilityIP (System.String ip)
Sets the IP address and port of the instance.
void | SetExtentSize (int kBytes)
Sets the size of the extents in KB.
bool | Save ()
Save the current configuration in the specified config file.
void | SetRollbackEnabled (bool status)
Enables or disables the rollback.
void | SetPoolPartitions (int pools)
Sets the number of pools in each PartitionedPool.
int | GetExtentPages ()
Gets the number of pages per extent.
void | SetPoolTemporaryMaxSize (int frames)
Sets the maximum size for the temporary pool in number of frames.
bool | GetHighAvailabilityEnabled ()
Gets whether high availability mode is enabled or disabled.
bool | GetRecoveryEnabled ()
Gets whether the recovery is enabled or disabled.
void | SetPoolPersistentMinSize (int frames)
Sets the minimum size for the persistent pool in number of frames.
System.String | GetAESKey ()
Get the AES encryption key in a hexadecimal encoded string.
int | GetCacheMaxSize ()
Gets the maximum size for the cache (all pools) in MB.
int | GetPoolFrameSize ()
Gets the size of a pool frame in number of extents.
void | SetSparkseeConfigFile (System.String path)
Sets the config file path.
bool | GetRollbackEnabled ()
Gets whether the rollback is enabled or disabled.
SparkseeConfig (System.String path, System.String clientId, System.String licenseId)
Creates a new instance with a specific config file and IDs.
bool | GetCallStackDump ()
Gets whether the signals will be captured to dump the call stack or not.
System.String | GetDownloadStatus ()
Gets a message with the license download result.
void | SetLicensePreDownloadDays (int days)
Start trying to automatically download a new license at the specified number of days before expiration.
System.String | GetLicenseRequest ()
Get information useful to manually request a license.
void | SetChecksumEnabled (bool status)
Enables or disables the storage checksum usage.
int | GetPoolTemporaryMinSize ()
Gets the minimum size for the temporary pool in number of frames.
void | SetRecoveryCheckpointTime (long microSeconds)
Sets the delay time (in microseconds) between automatic checkpoints.
bool | GetTmpEnabled ()
Gets whether using temporary storage for computations is enabled.
int | GetRecoveryCacheMaxSize ()
Gets the maximum size for the recovery log cache in extents.
long | GetHighAvailabilityMasterHistory ()
Gets the master's history log.
void | SetTmpFolder (System.String tmpFolder)
Sets the temporary folder used for temporary staging.
void | SetRecoveryLogFile (System.String filePath)
Sets the recovery log file.

Detailed Description

Sparksee configuration class.

If not specified, 0 means unlimited which is the maximum available. For the pools that's the total cache size. For the cache unlimited means nearly all the physical memory of the computer.

For each field, there is a default value. This value can be overrided with values from a properties file (see SparkseeProperties class). Also, this settings can be overrided calling a specific setter.

For each field, it is shown its default value and the property to override this value:

Extent size: 4KB ('sparksee.storage.extentsize' at SparkseeProperties).

Pages per extent: 1 page ('sparksee.storage.extentpages' at SparkseeProperties).

Checksums enabled: true ('sparksee.storage.checksum' at SparkseeProperties).

Pool frame size: 1 extent ('sparksee.io.pool.frame.size' at SparkseeProperties).

Minimum size for the persistent pool: 64 frames ('sparksee.io.pool.persistent.minsize' at SparkseeProperties).

Maximum size for the persistent pool: 0 frames ('sparksee.io.pool.persistent.maxsize' at SparkseeProperties).

Minimum size for the temporary pool: 16 frames ('sparksee.io.pool.temporal.minsize' at SparkseeProperties).

Maximum size for the temporary pool: 0 frames ('sparksee.io.pool.temporal.maxsize' at SparkseeProperties).

Number of pools in the pool cluster: 0 pools ('sparksee.io.pool.clustersize' at SparkseeProperties). 0 or 1 means the clustering is disabled.

Maximum size for the cache (all pools): 0 MB ('sparksee.io.cache.maxsize' at SparkseeProperties).

License code: "" ('sparksee.license' at SparkseeProperties). No license code means evaluation license.

Log level: Info ('sparksee.log.level' at SparkseeProperties).

Log file: "sparksee.log" ('sparksee.log.file' at SparkseeProperties).

Cache statistics: false (disabled) ('sparksee.cache.statistics' at SparkseeProperties).

Cache statistics log file: "statistics.log" ('sparksee.cache.statisticsFile' at SparkseeProperties).

Cache statistics snapshot time: 1000 msecs [TimeUnit] ('sparksee.cache.statisticsSnapshotTime' at SparkseeProperties).

Recovery enabled: false ('sparksee.io.recovery' at SparkseeProperties).

Recovery log file: "" ('sparksee.io.recovery.logfile' at SparkseeProperties).

Recovery cache max size: 1MB ('sparksee.io.recovery.cachesize' at SparkseeProperties).

Recovery checkpoint time: 60 seconds [TimeUnit] ('sparksee.io.recovery.checkpointTime' at SparkseeProperties).

High-availability: false (disabled) ('sparksee.ha' at SparkseeProperties).

High-availability coordinators: "" ('sparksee.ha.coordinators' at SparkseeProperties).

High-availability IP: "" ('sparksee.ha.ip' at SparkseeProperties).

High-availability sync polling: 0 (disabled) [TimeUnit] ('sparksee.ha.sync' at SparkseeProperties).

High-availability master history: 1D (1 day) [TimeUnit] ('sparksee.ha.master.history' at SparkseeProperties).

Use of TimeUnit:

Those variables using TimeUnit allow for:

<X>[D|H|M|S|s|m|u]

where <X> is a number followed by an optional character which represents the unit: D for days, H for hours, M for minutes, S or s for seconds, m for milliseconds and u for microseconds. If no unit character is given, seconds are assumed.

Capture abort signals to dump the call stack ('sparksee.callstackdump' at SparkseeProperties) is enabled by default on most platforms.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

com.sparsity.sparksee.gdb.SparkseeConfig.SparkseeConfig ( System.String path )

Creates a new instance with a specific config file.

The config file will be loaded using the global properties class and the file may be automatically overwritten with the config changes. If the file doesn't exists, it will be created.

Parameters
path [in] File path to the config file.
com.sparsity.sparksee.gdb.SparkseeConfig.SparkseeConfig ( )

Creates a new instance.

Values are set with default values.

com.sparsity.sparksee.gdb.SparkseeConfig.SparkseeConfig | ( | System.String | path,
 |  | System.String | clientId,
 |  | System.String | licenseId
 | ) |  |

Creates a new instance with a specific config file and IDs.

The config file will be loaded using the global properties class and the file may be automatically overwritten with the config changes. If the config file already exists, the client and license ids should have the same values as the given arguments. If the file doesn't exists, it will be created.

Parameters
path | [in] File path to the config file.
clientId | [in] The client identifier.
licenseId | [in] The license identifier.

Member Function Documentation

int com.sparsity.sparksee.gdb.SparkseeConfig.DownloadLicense ( )

Try to download a license key Can be used to explicitly download a license when the autodownload is disabled (LicensePreDownloadDays == -1).

Returns
Returns -1 if a valid license key couldn't be downloaded, 0 if the same license was downloaded or 1 if a different license is downloaded.
System.String com.sparsity.sparksee.gdb.SparkseeConfig.GetAESIV ( )

Get the AES initialization vector in a hexadecimal encoded string.

Returns
The AES initialization vector as an hexadecimal string.
System.String com.sparsity.sparksee.gdb.SparkseeConfig.GetAESKey ( )

Get the AES encryption key in a hexadecimal encoded string.

Returns
The AES encryption Key as an hexadecimal string.
int com.sparsity.sparksee.gdb.SparkseeConfig.GetCacheMaxSize ( )

Gets the maximum size for the cache (all pools) in MB.

Returns
The maximum size for the cache (all pools) in MB.
bool com.sparsity.sparksee.gdb.SparkseeConfig.GetCacheStatisticsEnabled ( )

Gets whether cache statistics are enabled or disabled.

Returns
TRUE if cache statistics are enabled, FALSE otherwise.
System.String com.sparsity.sparksee.gdb.SparkseeConfig.GetCacheStatisticsFile ( )

Gets the cache statistics log file.

Useless if cache statistics are disabled.

Returns
The cache statistics log file.
long com.sparsity.sparksee.gdb.SparkseeConfig.GetCacheStatisticsSnapshotTime ( )

Gets the cache statistics snapshot time in microseconds.

Useless if cache statistics are disabled.

Returns
The cache statistics snapshot time in microseconds.
bool com.sparsity.sparksee.gdb.SparkseeConfig.GetCallStackDump ( )

Gets whether the signals will be captured to dump the call stack or not.

Returns
TRUE if the signals must be captured, FALSE otherwise.
bool com.sparsity.sparksee.gdb.SparkseeConfig.GetChecksumEnabled ( )

Gets whether the storage checksum usage is enabled or disabled.

Returns
TRUE if the checksum is enabled, FALSE otherwise.
System.String com.sparsity.sparksee.gdb.SparkseeConfig.GetClientId ( )

Gets the client identifier.

Returns
The client identifier.
System.String com.sparsity.sparksee.gdb.SparkseeConfig.GetDownloadStatus ( )

Gets a message with the license download result.

It can be used when the DownloadLicense call failed.

Returns
The log download result.
bool com.sparsity.sparksee.gdb.SparkseeConfig.GetEncryptionEnabled ( )

Gets whether the storage encryption is enabled or disabled.

Returns
TRUE if the encryption is enabled, FALSE otherwise.
int com.sparsity.sparksee.gdb.SparkseeConfig.GetExtentPages ( )

Gets the number of pages per extent.

Returns
The number of pages per extent.
int com.sparsity.sparksee.gdb.SparkseeConfig.GetExtentSize ( )

Gets the size of a extent.

Returns
The size of a extent in KB.
System.String com.sparsity.sparksee.gdb.SparkseeConfig.GetHighAvailabilityCoordinators ( )

Gets the coordinators address and port list.

Returns
The coordinators address and port list.
bool com.sparsity.sparksee.gdb.SparkseeConfig.GetHighAvailabilityEnabled ( )

Gets whether high availability mode is enabled or disabled.

Returns
TRUE if high availability mode is enabled, FALSE otherwise.
System.String com.sparsity.sparksee.gdb.SparkseeConfig.GetHighAvailabilityIP ( )

Gets the IP address and port of the instance.

Returns
The IP address and port of the instance.
long com.sparsity.sparksee.gdb.SparkseeConfig.GetHighAvailabilityMasterHistory ( )

Gets the master's history log.

Returns
The master's history log.
long com.sparsity.sparksee.gdb.SparkseeConfig.GetHighAvailabilitySynchronization ( )

Gets the synchronization polling time.

Returns
The Synchronization polling time.
long com.sparsity.sparksee.gdb.SparkseeConfig.GetInMemAllocSize ( )

Gets the in-memory allocator size.

Returns
Returns the in-memory allocator size
System.String com.sparsity.sparksee.gdb.SparkseeConfig.GetLicense ( )

Gets the license key.

Returns
The license key.
System.String com.sparsity.sparksee.gdb.SparkseeConfig.GetLicenseId ( )

Gets the license identifier.

Returns
The license identifier.
int com.sparsity.sparksee.gdb.SparkseeConfig.GetLicensePreDownloadDays ( )

Get the number of days before expiration when a new license will be downloaded.

Returns
Returns the number of days or -1 if it will never be automatically downloaded.
System.String com.sparsity.sparksee.gdb.SparkseeConfig.GetLogFile ( )

Gets the log file.

Returns
The log file.
com.sparsity.sparksee.gdb.LogLevel com.sparsity.sparksee.gdb.SparkseeConfig.GetLogLevel ( )

Gets the log level.

Returns
The LogLevel.
int com.sparsity.sparksee.gdb.SparkseeConfig.GetPoolFrameSize ( )

Gets the size of a pool frame in number of extents.

Returns
The size of a pool frame in number of extents.
int com.sparsity.sparksee.gdb.SparkseeConfig.GetPoolPartitions ( )

Gets the number of partitions in each PartitionedPool.

Returns
The number of partitions in each PartitionedPool.
int com.sparsity.sparksee.gdb.SparkseeConfig.GetPoolPersistentMaxSize ( )

Gets the maximum size for the persistent pool in number of frames.

Returns
The maximum size for the persistent pool in number of frames.
int com.sparsity.sparksee.gdb.SparkseeConfig.GetPoolPersistentMinSize ( )

Gets the minimum size for the persistent pool in number of frames.

Returns
The minimum size for the persistent pool in number of frames.
int com.sparsity.sparksee.gdb.SparkseeConfig.GetPoolTemporaryMaxSize ( )

Gets the maximum size for the temporary pool in number of frames.

Returns
The maximum size for the temporary pool in number of frames.
int com.sparsity.sparksee.gdb.SparkseeConfig.GetPoolTemporaryMinSize ( )

Gets the minimum size for the temporary pool in number of frames.

Returns
The minimum size for the temporary pool in number of frames.
int com.sparsity.sparksee.gdb.SparkseeConfig.GetRecoveryCacheMaxSize ( )

Gets the maximum size for the recovery log cache in extents.

Returns
The maximum size for the recovery log cache in extents.
long com.sparsity.sparksee.gdb.SparkseeConfig.GetRecoveryCheckpointTime ( )

Gets the delay time (in microseconds) between automatic checkpoints.

Returns
The delay time (in microseconds) between automatic checkpoints.
bool com.sparsity.sparksee.gdb.SparkseeConfig.GetRecoveryEnabled ( )

Gets whether the recovery is enabled or disabled.

Returns
TRUE if the recovery is enabled, FALSE otherwise.
System.String com.sparsity.sparksee.gdb.SparkseeConfig.GetRecoveryLogFile ( )

Gets the recovery log file.

Returns
The recovery log file.
bool com.sparsity.sparksee.gdb.SparkseeConfig.GetRollbackEnabled ( )

Gets whether the rollback is enabled or disabled.

Returns
TRUE if the rollback is enabled, FALSE otherwise.
System.String com.sparsity.sparksee.gdb.SparkseeConfig.GetSparkseeConfigFile ( )

Gets the config file path.

Returns
Returns the configured path or an empty string
bool com.sparsity.sparksee.gdb.SparkseeConfig.GetTmpEnabled ( )

Gets whether using temporary storage for computations is enabled.

Returns
True if enabled
System.String com.sparsity.sparksee.gdb.SparkseeConfig.GetTmpFolder ( )

Gets the temporary folder used for temporary staging.

Returns
The temporary folder path
bool com.sparsity.sparksee.gdb.SparkseeConfig.Save ( )

Save the current configuration in the specified config file.

It will try to save the current configuration only if a config file was specified. This method will be automatically used when a Sparksee class downloads a new License.

Returns
Returns true if the config file is successfully written or false otherwise.
bool com.sparsity.sparksee.gdb.SparkseeConfig.SaveAll ( )

Save all the current configuration settings in the specified config file.

It will try to save the current configuration only if a config file was specified. The saved config file WILL CONATAIN all the modified settings including the secret ENCRYPTION KEYS. You should usually just use the Save method instead.

Returns
Returns true if the config file is successfully written or false otherwise.
bool com.sparsity.sparksee.gdb.SparkseeConfig.SetAESEncryptionEnabled ( int keySize )

Enables storage encryption using AES and GENARATES a key and an iv.

YOU MUST GET AND KEEP SAFE THE GENERATED KEY AND IV! The key and initialization vector will not be saved in the config file.

Parameters
keySize [In] The key size in bytes (8, 16 or 32).
Returns
Returns true if the encryption had been enabled.
bool com.sparsity.sparksee.gdb.SparkseeConfig.SetAESEncryptionEnabled | ( | System.String | keyInHex,
 |  | System.String | ivInHex
 | ) |  |

Enables storage encryption using AES with the given key and iv.

The key and initialization vector will not be saved in the config file.

Parameters
keyInHex | [In] The AES encryption Key as an hexadecimal string (8, 16 or 32 bytes).
ivInHex | [In] The AES Initialization Vector as an hexadecimal string (16 bytes).
Returns
Returns true if the encryption had been enabled with the given arguments or false otherwise.
void com.sparsity.sparksee.gdb.SparkseeConfig.SetCacheMaxSize ( int megaBytes )

Sets the maximum size for the cache (all pools) in MB.

Parameters
megaBytes [in] The maximum size for the cache (all pools) in MB. It must be non-negative.
void com.sparsity.sparksee.gdb.SparkseeConfig.SetCacheStatisticsEnabled ( bool status )

Enables or disables cache statistics.

Parameters
status [in] If TRUE this enables cache statistics, if FALSE this disables cache statistics.
void com.sparsity.sparksee.gdb.SparkseeConfig.SetCacheStatisticsFile ( System.String filePath )

Sets the cache statistics log file.

Useless if cache statistics are disabled.

Parameters
filePath [in] The cache statistics log file.
void com.sparsity.sparksee.gdb.SparkseeConfig.SetCacheStatisticsSnapshotTime ( long microSeconds )

Sets the cache statistics snapshot time.

Useless if cache statistics are disabled.

Parameters
microSeconds [in] The cache statistics snapshot time in microseconds.
void com.sparsity.sparksee.gdb.SparkseeConfig.SetCallStackDump ( bool status )

Sets whether the signals will be captured to dump the call stack or not.

Parameters
status [in] If TRUE signals must be captured.
void com.sparsity.sparksee.gdb.SparkseeConfig.SetChecksumEnabled ( bool status )

Enables or disables the storage checksum usage.

Parameters
status [in] If TRUE this enables the checksum, if FALSE then disables it.
void com.sparsity.sparksee.gdb.SparkseeConfig.SetClientId ( System.String clientId )

Set the client identifier.

If you don't have a client identifier, you may want to register at http://sparsity-technologies.com/#sparksee

Parameters
clientId [in] The client identifier.
void com.sparsity.sparksee.gdb.SparkseeConfig.SetExtentPages ( int pages )

Sets the number of pages per extent.

Parameters
pages [in] The number of pages. It must be at least 1 page and the page size must be greater than or equal to 4KB.
void com.sparsity.sparksee.gdb.SparkseeConfig.SetExtentSize ( int kBytes )

Sets the size of the extents in KB.

Parameters
kBytes [in] The size of an extent in KB. An extent can have a size between 4KB and 64KB, and it must be a power of 2.
void com.sparsity.sparksee.gdb.SparkseeConfig.SetHighAvailabilityCoordinators ( System.String ip )

Sets the coordinators address and port list.

Parameters
ip [in] The coordinators address and port list.
void com.sparsity.sparksee.gdb.SparkseeConfig.SetHighAvailabilityEnabled ( bool status )

Enables or disables high availability mode.

Parameters
status [in] If TRUE this enables high availability mode, if FALSE this disables high availability mode.
void com.sparsity.sparksee.gdb.SparkseeConfig.SetHighAvailabilityIP ( System.String ip )

Sets the IP address and port of the instance.

Parameters
ip [in] The IP address and port of the instance.
void com.sparsity.sparksee.gdb.SparkseeConfig.SetHighAvailabilityMasterHistory ( long filePath )

Sets the master's history log.

Parameters
filePath [in] The master's history log.
void com.sparsity.sparksee.gdb.SparkseeConfig.SetHighAvailabilitySynchronization ( long microSeconds )

Sets the synchronization polling time.

Parameters
microSeconds [in] The synchronization polling time.
void com.sparsity.sparksee.gdb.SparkseeConfig.SetInMemAllocSize ( long size )

Sets the in-memory allocator size.

Parameters
size The size to set the in-memory allocator to
int com.sparsity.sparksee.gdb.SparkseeConfig.SetLicense ( System.String key )

Sets the license key.

Parameters
key [in] The license key. Returns -1 if the new key can't be used, 0 if it's the same license or 1 if the new license is applied.
void com.sparsity.sparksee.gdb.SparkseeConfig.SetLicenseId ( System.String licenseId )

Set the license identifier.

If you don't have a license identifier, you may want to register at http://sparsity-technologies.com/#sparksee

Parameters
licenseId [in] The license identifier.
void com.sparsity.sparksee.gdb.SparkseeConfig.SetLicensePreDownloadDays ( int days )

Start trying to automatically download a new license at the specified number of days before expiration.

Parameters
days [in] Number of days before expiration or -1 if the license should never be downloaded.
void com.sparsity.sparksee.gdb.SparkseeConfig.SetLogFile ( System.String filePath )

Sets the log file.

Parameters
filePath [in] The log file.
void com.sparsity.sparksee.gdb.SparkseeConfig.SetLogLevel ( com.sparsity.sparksee.gdb.LogLevel level )

Sets the log level.

Parameters
level [in] The LogLevel.
void com.sparsity.sparksee.gdb.SparkseeConfig.SetPoolFrameSize ( int extents )

Sets the size of a pool frame in number of extents.

Parameters
extents [in] The size of a pool frame in number of extents. It must be non-negative.
void com.sparsity.sparksee.gdb.SparkseeConfig.SetPoolPartitions ( int pools )

Sets the number of pools in each PartitionedPool.

Parameters
pools [in] The number of pools in each PartitionedPool. It must be non-negative.
void com.sparsity.sparksee.gdb.SparkseeConfig.SetPoolPersistentMaxSize ( int frames )

Sets the maximum size for the persistent pool in number of frames.

Parameters
frames [in] The maximum size for the persistent pool in number of frames. It must be non-negative.
void com.sparsity.sparksee.gdb.SparkseeConfig.SetPoolPersistentMinSize ( int frames )

Sets the minimum size for the persistent pool in number of frames.

Parameters
frames [in] The minimum size for the persistent pool in number of frames. It must be non-negative.
void com.sparsity.sparksee.gdb.SparkseeConfig.SetPoolTemporaryMaxSize ( int frames )

Sets the maximum size for the temporary pool in number of frames.

Parameters
frames [in] The maximum size for the temporary pool in number of frames. It must be non-negative.
void com.sparsity.sparksee.gdb.SparkseeConfig.SetPoolTemporaryMinSize ( int frames )

Sets the minimum size for the temporary pool in number of frames.

Parameters
frames [in] The minimum size for the temporary pool in number of frames. It must be non-negative.
void com.sparsity.sparksee.gdb.SparkseeConfig.SetRecoveryCacheMaxSize ( int extents )

Sets the maximum size for the recovery log cache in extents.

Parameters
extents [in] The maximum size for the recovery log cache in extents. A 0 sets the default value (extents up to 1MB).
void com.sparsity.sparksee.gdb.SparkseeConfig.SetRecoveryCheckpointTime ( long microSeconds )

Sets the delay time (in microseconds) between automatic checkpoints.

Parameters
microSeconds [in] The delay time (in microseconds) between automatic checkpoints. A 0 forces a checkpoint after each commited transaction.
void com.sparsity.sparksee.gdb.SparkseeConfig.SetRecoveryEnabled ( bool status )

Enables or disables the recovery.

Parameters
status [in] If TRUE this enables the recovery, if FALSE then disables it.
void com.sparsity.sparksee.gdb.SparkseeConfig.SetRecoveryLogFile ( System.String filePath )

Sets the recovery log file.

Parameters
filePath [in] The recovery log file. Left it empty for the default log file (same as <database_file_name>.log)
void com.sparsity.sparksee.gdb.SparkseeConfig.SetRollbackEnabled ( bool status )

Enables or disables the rollback.

Parameters
status [in] If TRUE this enables the rollback, if FALSE then disables it.
void com.sparsity.sparksee.gdb.SparkseeConfig.SetSparkseeConfigFile ( System.String path )

Sets the config file path.

The file is not loaded in this operation, see the constructor options if you need to load the file. The config file may be automatically overwritten with the config changes. If the file doesn't exists, it will be created.

Parameters
path [in] File path to the config file.
void com.sparsity.sparksee.gdb.SparkseeConfig.SetTmpEnabled ( bool enabled )

Sets whether to use temporary storage for computations or not.

Parameters
enabled True to use temporary storage for computation
void com.sparsity.sparksee.gdb.SparkseeConfig.SetTmpFolder ( System.String tmpFolder )

Sets the temporary folder used for temporary staging.

Parameters
tmpFolder The temporary folder to set


SparkseeNet: Member List

  • gdb
  • SparkseeConfig
com.sparsity.sparksee.gdb.SparkseeConfig Member List

This is the complete list of members for com.sparsity.sparksee.gdb.SparkseeConfig, including all inherited members.

DownloadExpected() | com.sparsity.sparksee.gdb.SparkseeConfig
DownloadLicense() | com.sparsity.sparksee.gdb.SparkseeConfig
GetAESIV() | com.sparsity.sparksee.gdb.SparkseeConfig
GetAESKey() | com.sparsity.sparksee.gdb.SparkseeConfig
GetCacheMaxSize() | com.sparsity.sparksee.gdb.SparkseeConfig
GetCacheStatisticsEnabled() | com.sparsity.sparksee.gdb.SparkseeConfig
GetCacheStatisticsFile() | com.sparsity.sparksee.gdb.SparkseeConfig
GetCacheStatisticsSnapshotTime() | com.sparsity.sparksee.gdb.SparkseeConfig
GetCallStackDump() | com.sparsity.sparksee.gdb.SparkseeConfig
GetChecksumEnabled() | com.sparsity.sparksee.gdb.SparkseeConfig
GetClientId() | com.sparsity.sparksee.gdb.SparkseeConfig
GetDownloadStatus() | com.sparsity.sparksee.gdb.SparkseeConfig
GetEncryptionEnabled() | com.sparsity.sparksee.gdb.SparkseeConfig
GetExtentPages() | com.sparsity.sparksee.gdb.SparkseeConfig
GetExtentSize() | com.sparsity.sparksee.gdb.SparkseeConfig
GetHighAvailabilityCoordinators() | com.sparsity.sparksee.gdb.SparkseeConfig
GetHighAvailabilityEnabled() | com.sparsity.sparksee.gdb.SparkseeConfig
GetHighAvailabilityIP() | com.sparsity.sparksee.gdb.SparkseeConfig
GetHighAvailabilityMasterHistory() | com.sparsity.sparksee.gdb.SparkseeConfig
GetHighAvailabilitySynchronization() | com.sparsity.sparksee.gdb.SparkseeConfig
GetInMemAllocSize() | com.sparsity.sparksee.gdb.SparkseeConfig
GetLicense() | com.sparsity.sparksee.gdb.SparkseeConfig
GetLicenseId() | com.sparsity.sparksee.gdb.SparkseeConfig
GetLicensePreDownloadDays() | com.sparsity.sparksee.gdb.SparkseeConfig
GetLicenseRequest() | com.sparsity.sparksee.gdb.SparkseeConfig
GetLogFile() | com.sparsity.sparksee.gdb.SparkseeConfig
GetLogLevel() | com.sparsity.sparksee.gdb.SparkseeConfig
GetPoolFrameSize() | com.sparsity.sparksee.gdb.SparkseeConfig
GetPoolPartitions() | com.sparsity.sparksee.gdb.SparkseeConfig
GetPoolPersistentMaxSize() | com.sparsity.sparksee.gdb.SparkseeConfig
GetPoolPersistentMinSize() | com.sparsity.sparksee.gdb.SparkseeConfig
GetPoolTemporaryMaxSize() | com.sparsity.sparksee.gdb.SparkseeConfig
GetPoolTemporaryMinSize() | com.sparsity.sparksee.gdb.SparkseeConfig
GetRecoveryCacheMaxSize() | com.sparsity.sparksee.gdb.SparkseeConfig
GetRecoveryCheckpointTime() | com.sparsity.sparksee.gdb.SparkseeConfig
GetRecoveryEnabled() | com.sparsity.sparksee.gdb.SparkseeConfig
GetRecoveryLogFile() | com.sparsity.sparksee.gdb.SparkseeConfig
GetRollbackEnabled() | com.sparsity.sparksee.gdb.SparkseeConfig
GetSparkseeConfigFile() | com.sparsity.sparksee.gdb.SparkseeConfig
GetTmpEnabled() | com.sparsity.sparksee.gdb.SparkseeConfig
GetTmpFolder() | com.sparsity.sparksee.gdb.SparkseeConfig
Save() | com.sparsity.sparksee.gdb.SparkseeConfig
SaveAll() | com.sparsity.sparksee.gdb.SparkseeConfig
SetAESEncryptionEnabled(int keySize) | com.sparsity.sparksee.gdb.SparkseeConfig
SetAESEncryptionEnabled(System.String keyInHex, System.String ivInHex) | com.sparsity.sparksee.gdb.SparkseeConfig
SetCacheMaxSize(int megaBytes) | com.sparsity.sparksee.gdb.SparkseeConfig
SetCacheStatisticsEnabled(bool status) | com.sparsity.sparksee.gdb.SparkseeConfig
SetCacheStatisticsFile(System.String filePath) | com.sparsity.sparksee.gdb.SparkseeConfig
SetCacheStatisticsSnapshotTime(long microSeconds) | com.sparsity.sparksee.gdb.SparkseeConfig
SetCallStackDump(bool status) | com.sparsity.sparksee.gdb.SparkseeConfig
SetChecksumEnabled(bool status) | com.sparsity.sparksee.gdb.SparkseeConfig
SetClientId(System.String clientId) | com.sparsity.sparksee.gdb.SparkseeConfig
SetEncryptionDisabled() | com.sparsity.sparksee.gdb.SparkseeConfig
SetExtentPages(int pages) | com.sparsity.sparksee.gdb.SparkseeConfig
SetExtentSize(int kBytes) | com.sparsity.sparksee.gdb.SparkseeConfig
SetHighAvailabilityCoordinators(System.String ip) | com.sparsity.sparksee.gdb.SparkseeConfig
SetHighAvailabilityEnabled(bool status) | com.sparsity.sparksee.gdb.SparkseeConfig
SetHighAvailabilityIP(System.String ip) | com.sparsity.sparksee.gdb.SparkseeConfig
SetHighAvailabilityMasterHistory(long filePath) | com.sparsity.sparksee.gdb.SparkseeConfig
SetHighAvailabilitySynchronization(long microSeconds) | com.sparsity.sparksee.gdb.SparkseeConfig
SetInMemAllocSize(long size) | com.sparsity.sparksee.gdb.SparkseeConfig
SetLicense(System.String key) | com.sparsity.sparksee.gdb.SparkseeConfig
SetLicenseId(System.String licenseId) | com.sparsity.sparksee.gdb.SparkseeConfig
SetLicensePreDownloadDays(int days) | com.sparsity.sparksee.gdb.SparkseeConfig
SetLogFile(System.String filePath) | com.sparsity.sparksee.gdb.SparkseeConfig
SetLogLevel(com.sparsity.sparksee.gdb.LogLevel level) | com.sparsity.sparksee.gdb.SparkseeConfig
SetPoolFrameSize(int extents) | com.sparsity.sparksee.gdb.SparkseeConfig
SetPoolPartitions(int pools) | com.sparsity.sparksee.gdb.SparkseeConfig
SetPoolPersistentMaxSize(int frames) | com.sparsity.sparksee.gdb.SparkseeConfig
SetPoolPersistentMinSize(int frames) | com.sparsity.sparksee.gdb.SparkseeConfig
SetPoolTemporaryMaxSize(int frames) | com.sparsity.sparksee.gdb.SparkseeConfig
SetPoolTemporaryMinSize(int frames) | com.sparsity.sparksee.gdb.SparkseeConfig
SetRecoveryCacheMaxSize(int extents) | com.sparsity.sparksee.gdb.SparkseeConfig
SetRecoveryCheckpointTime(long microSeconds) | com.sparsity.sparksee.gdb.SparkseeConfig
SetRecoveryEnabled(bool status) | com.sparsity.sparksee.gdb.SparkseeConfig
SetRecoveryLogFile(System.String filePath) | com.sparsity.sparksee.gdb.SparkseeConfig
SetRollbackEnabled(bool status) | com.sparsity.sparksee.gdb.SparkseeConfig
SetSparkseeConfigFile(System.String path) | com.sparsity.sparksee.gdb.SparkseeConfig
SetTmpEnabled(bool enabled) | com.sparsity.sparksee.gdb.SparkseeConfig
SetTmpFolder(System.String tmpFolder) | com.sparsity.sparksee.gdb.SparkseeConfig
SparkseeConfig(System.String path) | com.sparsity.sparksee.gdb.SparkseeConfig
SparkseeConfig() | com.sparsity.sparksee.gdb.SparkseeConfig
SparkseeConfig(System.String path, System.String clientId, System.String licenseId) | com.sparsity.sparksee.gdb.SparkseeConfig


SparkseeNet: com.sparsity.sparksee.gdb.SparkseeProperties Class Reference

  • gdb
  • SparkseeProperties
Static Public Member Functions | List of all members
com.sparsity.sparksee.gdb.SparkseeProperties Class Reference

Sparksee properties file. More...

Static Public Member Functions

static void | SetHI (System.String value)
YOU SHOULD NOT USE THIS METHOD.
static System.String | Get (System.String key, System.String def)
Gets a property.
static long | GetTimeUnit (System.String key, long def)
Gets a property as a time unit.
static void | Clear ()
Remove all the properties.
static bool | GetBoolean (System.String key, bool def)
Gets a property as a boolean.
static void | Load (System.String path)
Loads properties from the given file path.
static int | GetInteger (System.String key, int def)
Gets a property as an integer.

Detailed Description

Sparksee properties file.

This class is implemented as a singleton, so all public methods are static.

It allows for getting the property values stored in a properties file. A properties file is a file where there is one line per property. A property is defined by a key and a value as follows: key=value

By default, this loads properties from the file './sparksee.cfg'. The user may choose to load a different file by calling the method Load().

If the default properties file or the one loaded by the user do not exist, then this behaves as loading an empty properties file.

Member Function Documentation

static System.String com.sparsity.sparksee.gdb.SparkseeProperties.Get | ( | System.String | key,
 |  | System.String | def
 | ) |  |
static

Gets a property.

Parameters
key | [in] The name of the property to lookup.
def | [in] Default value to be returned in case there is no property with the name key.
Returns
The value of the property, or def if the key is not found.
static bool com.sparsity.sparksee.gdb.SparkseeProperties.GetBoolean | ( | System.String | key,
 |  | bool | def
 | ) |  |
static

Gets a property as a boolean.

Parameters
key | [in] The name of the property to lookup.
def | [in] Default value to be returned in case there is no property with the name key.
Returns
The property value, or def if the key is not found or in case of error.
static int com.sparsity.sparksee.gdb.SparkseeProperties.GetInteger | ( | System.String | key,
 |  | int | def
 | ) |  |
static

Gets a property as an integer.

Parameters
key | [in] The name of the property to lookup.
def | [in] Default value to be returned in case there is no property with the name key.
Returns
The property value, or def if the key is not found or in case of error.
static long com.sparsity.sparksee.gdb.SparkseeProperties.GetTimeUnit | ( | System.String | key,
 |  | long | def
 | ) |  |
static

Gets a property as a time unit.

A time unit is a string representation of a time duration with a time unit such as '10s' or '3H'.

Valid format for the string representation: Blanks at the begining or at the end are ignored. No blanks are allowed between the time duration and the unit time.

Allowed time units: 'D' for days, 'H' for hours, 'M' for minutes, 'S' o 's' for seconds, 'm' for milliseconds and 'u' for microseconds.

There is a special case: If no time unit is given, seconds is the default. So, '10' means 10 seconds.

Parameters
key | [in] The name of the property to lookup.
def | [in] The default value (in microseconds) to be returned in case there is no property with the name key.
Returns
The time duration in microseconds, or def if the key is not found or in case of error.
static void com.sparsity.sparksee.gdb.SparkseeProperties.Load ( System.String path )
static

Loads properties from the given file path.

Parameters
path [in] File path to load properties from.
static void com.sparsity.sparksee.gdb.SparkseeProperties.SetHI ( System.String value )
static

YOU SHOULD NOT USE THIS METHOD.

This method exists only for a specific service.

Parameters
value null


SparkseeNet: Member List

  • gdb
  • SparkseeProperties
com.sparsity.sparksee.gdb.SparkseeProperties Member List

This is the complete list of members for com.sparsity.sparksee.gdb.SparkseeProperties, including all inherited members.

Clear() | com.sparsity.sparksee.gdb.SparkseeProperties | static
Get(System.String key, System.String def) | com.sparsity.sparksee.gdb.SparkseeProperties | static
GetBoolean(System.String key, bool def) | com.sparsity.sparksee.gdb.SparkseeProperties | static
GetInteger(System.String key, int def) | com.sparsity.sparksee.gdb.SparkseeProperties | static
GetTimeUnit(System.String key, long def) | com.sparsity.sparksee.gdb.SparkseeProperties | static
Load(System.String path) | com.sparsity.sparksee.gdb.SparkseeProperties | static
SetHI(System.String value) | com.sparsity.sparksee.gdb.SparkseeProperties | static


SparkseeNet: com.sparsity.sparksee.gdb.StringList Class Reference

  • gdb
  • StringList
Public Member Functions | List of all members
com.sparsity.sparksee.gdb.StringList Class Reference

String list. More...

Public Member Functions

void | Clear ()
Clears the list.
StringList ()
Constructor.
StringList (string[] list)
Creates a new instance from an string array.
StringList (System.Collections.Generic.ICollection< string > col)
Creates a new instance from an string collection.
com.sparsity.sparksee.gdb.StringListIterator Iterator ()
Gets a new StringListIterator.
int | Count ()
Number of elements in the list.
void | Add (System.String str)
Adds a String at the end of the list.
StringList (System.String[] v)
Constructor.

Detailed Description

String list.

It stores a String (unicode) list.

Use StringListIterator to access all elements into this collection.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

com.sparsity.sparksee.gdb.StringList.StringList ( )

Constructor.

This creates an empty list.

com.sparsity.sparksee.gdb.StringList.StringList ( string[] list )

Creates a new instance from an string array.

Parameters
list String array to initialize the instance.
com.sparsity.sparksee.gdb.StringList.StringList ( System.Collections.Generic.ICollection< string > col )

Creates a new instance from an string collection.

Parameters
col Collection to initialize the instance.
com.sparsity.sparksee.gdb.StringList.StringList ( System.String[] v )

Constructor.

Parameters
v [in] Vector.

Member Function Documentation

void com.sparsity.sparksee.gdb.StringList.Add ( System.String str )

Adds a String at the end of the list.

Parameters
str [in] String.
int com.sparsity.sparksee.gdb.StringList.Count ( )

Number of elements in the list.

Returns
Number of elements in the list.
com.sparsity.sparksee.gdb.StringListIterator com.sparsity.sparksee.gdb.StringList.Iterator ( )

Gets a new StringListIterator.

Returns
StringListIterator instance.


SparkseeNet: Member List

  • gdb
  • StringList
com.sparsity.sparksee.gdb.StringList Member List

This is the complete list of members for com.sparsity.sparksee.gdb.StringList, including all inherited members.

Add(System.String str) | com.sparsity.sparksee.gdb.StringList
Clear() | com.sparsity.sparksee.gdb.StringList
Count() | com.sparsity.sparksee.gdb.StringList
Iterator() | com.sparsity.sparksee.gdb.StringList
StringList() | com.sparsity.sparksee.gdb.StringList
StringList(string[] list) | com.sparsity.sparksee.gdb.StringList
StringList(System.Collections.Generic.ICollection< string > col) | com.sparsity.sparksee.gdb.StringList
StringList(System.String[] v) | com.sparsity.sparksee.gdb.StringList


SparkseeNet: com.sparsity.sparksee.gdb.StringListIterator Class Reference

  • gdb
  • StringListIterator
Public Member Functions | List of all members
com.sparsity.sparksee.gdb.StringListIterator Class Reference

StringList iterator class. More...

Public Member Functions

bool | HasNext ()
Gets if there are more elements.
System.String | Next ()
Moves to the next element.

Detailed Description

StringList iterator class.

Iterator to traverse all the strings into a StringList instance.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

bool com.sparsity.sparksee.gdb.StringListIterator.HasNext ( )

Gets if there are more elements.

Returns
TRUE if there are more elements, FALSE otherwise.
System.String com.sparsity.sparksee.gdb.StringListIterator.Next ( )

Moves to the next element.

Returns
The next element.


SparkseeNet: Member List

  • gdb
  • StringListIterator
com.sparsity.sparksee.gdb.StringListIterator Member List

This is the complete list of members for com.sparsity.sparksee.gdb.StringListIterator, including all inherited members.

HasNext() | com.sparsity.sparksee.gdb.StringListIterator
Next() | com.sparsity.sparksee.gdb.StringListIterator


SparkseeNet: com.sparsity.sparksee.gdb.TextStream Class Reference

  • gdb
  • TextStream
Public Member Functions | List of all members
com.sparsity.sparksee.gdb.TextStream Class Reference

TextStream class. More...

Public Member Functions

int | Read (char[] dataOUT, int length)
Read data from the stream.
bool | IsNull ()
Returns TRUE if the stream is not available.
void | Write (char[] dataIN, int length)
Write data to the stream.
TextStream (bool append)
Creates a new instance.
void | Close ()
Closes the stream.

Detailed Description

TextStream class.

It allows for reading and writting Text attribute values.

It is very important to close the stream once no more reading or writting operations will be performed to ensure data is successfully stored.

Whereas string attributes are set and got using the Value class, text attributes are operated using a stream pattern.

Use of TextStream for writing: (i) Create a TextStream instance and (ii) set the stream for a text attribute of a node or edge instance with the graph SetAttributeText method. Once the set attribute text has been done, (iii) perform as many write operations as you need to the TextStream instance. Lastly, (iv) exeucte Close to flush and close the stream.

Use of TextStream for reading: (i) Get the stream of a text attribute of a node or edge instance with the GetAttributeText graph method. Once you have the TextStream instance, (ii) you can execute Read operations to read from the stream. (iii) The end of the stream is reached when Read returns 0. Finally, (iv) execute Close to close stream resources.

Check out the 'Attributes and values' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

com.sparsity.sparksee.gdb.TextStream.TextStream ( bool append )

Creates a new instance.

A TextStream only can be created by the user to write data.

Parameters
append [in] If TRUE, the it is created in append mode to write from the end of the stream, otherwise it is created to write from the begining of the stream.

Member Function Documentation

void com.sparsity.sparksee.gdb.TextStream.Close ( )

Closes the stream.

Once the Stream is closed, it cannot be used again.

Closing the stream is mandatory when the stream is not null and strongly recommended when it's null to avoid deallocation problems in some platforms.

bool com.sparsity.sparksee.gdb.TextStream.IsNull ( )

Returns TRUE if the stream is not available.

It returns for reading or writing data.

Returns
FALSE if the stream is ready
int com.sparsity.sparksee.gdb.TextStream.Read | ( | char[] | dataOUT,
 |  | int | length
 | ) |  |

Read data from the stream.

Parameters
dataOUT | [out] Buffer to read data to. It must be allocated by the user.
length | [in] Length of the given data buffer. It must be > 0.
Returns
Amount of read data (<= length). If 0, there is no more data to be read from the stream.
void com.sparsity.sparksee.gdb.TextStream.Write | ( | char[] | dataIN,
 |  | int | length
 | ) |  |

Write data to the stream.

Parameters
dataIN | [in] Buffer to write data from.
length | [in] Length of the data buffer. It must be > 0.


SparkseeNet: Member List

  • gdb
  • TextStream
com.sparsity.sparksee.gdb.TextStream Member List

This is the complete list of members for com.sparsity.sparksee.gdb.TextStream, including all inherited members.

Close() | com.sparsity.sparksee.gdb.TextStream
IsNull() | com.sparsity.sparksee.gdb.TextStream
Read(char[] dataOUT, int length) | com.sparsity.sparksee.gdb.TextStream
TextStream(bool append) | com.sparsity.sparksee.gdb.TextStream
Write(char[] dataIN, int length) | com.sparsity.sparksee.gdb.TextStream


SparkseeNet: com.sparsity.sparksee.gdb.Type Class Reference

  • gdb
  • Type
Public Member Functions | Static Public Attributes | List of all members
com.sparsity.sparksee.gdb.Type Class Reference

Type data class. More...

Public Member Functions

int | GetRestrictedFrom ()
Gets the tail or source type identifier for restricted edge types.
bool | GetAreNeighborsIndexed ()
Gets if this is an edge type with neighbors index.
com.sparsity.sparksee.gdb.ObjectType GetObjectType ()
Gets the object type.
int | GetRestrictedTo ()
Gets the head or target type identifier for restricted edge types.
bool | GetIsRestricted ()
Gets if this is a restricted edge type.
long | GetNumObjects ()
Gets the number of objects belonging to the type.
int | GetId ()
Gets the Sparksee type identifier.
bool | GetIsDirected ()
Gets if this is a directed edge type.
System.String | GetName ()
Gets the unique type name.

Static Public Attributes

static int | EdgesType
Identifier for all edgeType attributes.
static int | GlobalType
Global type identifier.
static int | InvalidType
Invalid type identifier.
static int | NodesType
Identifier for all nodeType attributes.

Detailed Description

Type data class.

It contains information about a node or edge type.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

bool com.sparsity.sparksee.gdb.Type.GetAreNeighborsIndexed ( )

Gets if this is an edge type with neighbors index.

Returns
TRUE for edges types with neighbors index, FALSE otherwise.
int com.sparsity.sparksee.gdb.Type.GetId ( )

Gets the Sparksee type identifier.

Returns
The Sparksee type identifier.
bool com.sparsity.sparksee.gdb.Type.GetIsDirected ( )

Gets if this is a directed edge type.

Returns
TRUE for directed edge types, FALSE otherwise.
bool com.sparsity.sparksee.gdb.Type.GetIsRestricted ( )

Gets if this is a restricted edge type.

Returns
TRUE for restricted edge types, FALSE otherwise.
System.String com.sparsity.sparksee.gdb.Type.GetName ( )

Gets the unique type name.

Returns
The unique type name.
long com.sparsity.sparksee.gdb.Type.GetNumObjects ( )

Gets the number of objects belonging to the type.

Returns
The number of objects belonging to the type.
com.sparsity.sparksee.gdb.ObjectType com.sparsity.sparksee.gdb.Type.GetObjectType ( )

Gets the object type.

Returns
The object type.
int com.sparsity.sparksee.gdb.Type.GetRestrictedFrom ( )

Gets the tail or source type identifier for restricted edge types.

Returns
For restricted edge types, the tail or source type identifier, the Type InvalidType otherwise.
int com.sparsity.sparksee.gdb.Type.GetRestrictedTo ( )

Gets the head or target type identifier for restricted edge types.

Returns
For restricted edge types, the head or target type identifier, the Type InvalidType otherwise.


SparkseeNet: Member List

  • gdb
  • Type
com.sparsity.sparksee.gdb.Type Member List

This is the complete list of members for com.sparsity.sparksee.gdb.Type, including all inherited members.

EdgesType | com.sparsity.sparksee.gdb.Type | static
GetAreNeighborsIndexed() | com.sparsity.sparksee.gdb.Type |
GetId() | com.sparsity.sparksee.gdb.Type |
GetIsDirected() | com.sparsity.sparksee.gdb.Type |
GetIsRestricted() | com.sparsity.sparksee.gdb.Type |
GetName() | com.sparsity.sparksee.gdb.Type |
GetNumObjects() | com.sparsity.sparksee.gdb.Type |
GetObjectType() | com.sparsity.sparksee.gdb.Type |
GetRestrictedFrom() | com.sparsity.sparksee.gdb.Type |
GetRestrictedTo() | com.sparsity.sparksee.gdb.Type |
GlobalType | com.sparsity.sparksee.gdb.Type | static
InvalidType | com.sparsity.sparksee.gdb.Type | static
NodesType | com.sparsity.sparksee.gdb.Type | static


SparkseeNet: com.sparsity.sparksee.gdb.TypeList Class Reference

  • gdb
  • TypeList
Public Member Functions | List of all members
com.sparsity.sparksee.gdb.TypeList Class Reference

Sparksee type identifier list. More...

Public Member Functions

TypeList (int[] list)
Creates a new instance from an integer array.
void | Add (int type)
Adds a Sparksee type identifier at the end of the list.
void | Clear ()
Clears the list.
TypeList (System.Collections.Generic.ICollection< int > col)
Creates a new instance from an integer collection.
com.sparsity.sparksee.gdb.TypeListIterator Iterator ()
Gets a new TypeListIterator.
TypeList ()
Constructor.
int | Count ()
Number of elements in the list.

Detailed Description

Sparksee type identifier list.

It stores a Sparksee node or edge type identifier list.

Use TypeListIterator to access all elements into this collection.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

com.sparsity.sparksee.gdb.TypeList.TypeList ( int[] list )

Creates a new instance from an integer array.

Parameters
list Integer array to initialize the instance.
com.sparsity.sparksee.gdb.TypeList.TypeList ( System.Collections.Generic.ICollection< int > col )

Creates a new instance from an integer collection.

Parameters
col Collection to initialize the instance.
com.sparsity.sparksee.gdb.TypeList.TypeList ( )

Constructor.

This creates an empty list.

Member Function Documentation

void com.sparsity.sparksee.gdb.TypeList.Add ( int type )

Adds a Sparksee type identifier at the end of the list.

Parameters
type [in] Sparksee type identifier.
int com.sparsity.sparksee.gdb.TypeList.Count ( )

Number of elements in the list.

Returns
Number of elements in the list.
com.sparsity.sparksee.gdb.TypeListIterator com.sparsity.sparksee.gdb.TypeList.Iterator ( )

Gets a new TypeListIterator.

Returns
TypeListIterator instance.


SparkseeNet: Member List

  • gdb
  • TypeList
com.sparsity.sparksee.gdb.TypeList Member List

This is the complete list of members for com.sparsity.sparksee.gdb.TypeList, including all inherited members.

Add(int type) | com.sparsity.sparksee.gdb.TypeList
Clear() | com.sparsity.sparksee.gdb.TypeList
Count() | com.sparsity.sparksee.gdb.TypeList
Iterator() | com.sparsity.sparksee.gdb.TypeList
TypeList(int[] list) | com.sparsity.sparksee.gdb.TypeList
TypeList(System.Collections.Generic.ICollection< int > col) | com.sparsity.sparksee.gdb.TypeList
TypeList() | com.sparsity.sparksee.gdb.TypeList


SparkseeNet: com.sparsity.sparksee.gdb.TypeListIterator Class Reference

  • gdb
  • TypeListIterator
Public Member Functions | List of all members
com.sparsity.sparksee.gdb.TypeListIterator Class Reference

TypeList iterator class. More...

Public Member Functions

bool | HasNext ()
Gets if there are more elements.
int | Next ()
Moves to the next element.

Detailed Description

TypeList iterator class.

Iterator to traverse all the Sparksee node or edge type identifiers into a TypeList instance.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

bool com.sparsity.sparksee.gdb.TypeListIterator.HasNext ( )

Gets if there are more elements.

Returns
TRUE if there are more elements, FALSE otherwise.
int com.sparsity.sparksee.gdb.TypeListIterator.Next ( )

Moves to the next element.

Returns
The next element.


SparkseeNet: Member List

  • gdb
  • TypeListIterator
com.sparsity.sparksee.gdb.TypeListIterator Member List

This is the complete list of members for com.sparsity.sparksee.gdb.TypeListIterator, including all inherited members.

HasNext() | com.sparsity.sparksee.gdb.TypeListIterator
Next() | com.sparsity.sparksee.gdb.TypeListIterator


SparkseeNet: com.sparsity.sparksee.gdb.Value Class Reference

  • gdb
  • Value
Public Member Functions | Static Public Attributes | List of all members
com.sparsity.sparksee.gdb.Value Class Reference

Value class. More...

Public Member Functions

void | SetLongVoid (long value)
Sets the Value.
System.DateTime | GetTimestampAsDateTime ()
Gets the Value as a DateTime instance.
long | GetOID ()
Gets OID Value.
com.sparsity.sparksee.gdb.Value | SetBoolean (bool value)
Sets the Value.
Value (com.sparsity.sparksee.gdb.Value value)
Copy constructor.
bool | GetBoolean ()
Gets Boolean Value.
int | CompareTo (com.sparsity.sparksee.gdb.Value other)
Compares the current instance with another object of the same type.
void | SetNullVoid ()
Sets the Value to NULL.
void | SetTimestampVoid (long value)
Sets the Value.
void | SetStringVoid (System.String value)
Sets the Value.
Value ()
Creates a new instance.
void | SetIntegerVoid (int value)
Sets the Value.
string | ToString ()
Gets a string representation of the Value.
com.sparsity.sparksee.gdb.Value | SetDouble (double value)
Sets the Value.
com.sparsity.sparksee.gdb.Value | Set (com.sparsity.sparksee.gdb.Value value)
Sets the Value.
com.sparsity.sparksee.gdb.DataType GetDataType ()
Gets the DataType.
com.sparsity.sparksee.gdb.Value | SetOID (long value)
Sets the Value.
System.String | GetString ()
Gets String Value.
void | SetDoubleVoid (double value)
Sets the Value.
bool | Equals (com.sparsity.sparksee.gdb.Value value)
Compares with the given Value.
bool | IsNull ()
Gets if this is a NULL Value.
void | SetVoid (com.sparsity.sparksee.gdb.Value value)
Sets the Value.
void | SetTimestampVoid (int year, int month, int day, int hour, int minutes, int seconds, int millisecs)
Sets the Value.
void | SetOIDVoid (long value)
Sets the OID Value.
com.sparsity.sparksee.gdb.Value | SetString (string value)
Sets the Value.
double | GetDouble ()
Gets Double Value.
com.sparsity.sparksee.gdb.Value | SetLong (long value)
Sets the Value.
com.sparsity.sparksee.gdb.Value | SetTimestamp (System.DateTime dt)
Sets the Value.
int | Compare (com.sparsity.sparksee.gdb.Value value)
Compares with the given Value.
long | GetLong ()
Gets Long Value.
void | SetBooleanVoid (bool value)
Sets the Value.
com.sparsity.sparksee.gdb.Value | SetInteger (int value)
Sets the Value.
int | CompareTo (System.Object other)
Compares the current instance with another object of the same type.
com.sparsity.sparksee.gdb.Value SetNull ()
Sets the Value to NULL.
long | GetTimestamp ()
Gets Timestamp Value.
com.sparsity.sparksee.gdb.Value | SetTimestamp (int year, int month, int day, int hour, int minutes, int seconds, int millisec)
Sets the Value.
bool | Equals (System.Object other)
Indicates whether the current object is equal to another object.
int | GetInteger ()
Gets Integer Value.

Static Public Attributes

static int MaxLengthString
Maximum number of characters allowed for a String.

Detailed Description

Value class.

It is a container which stores a value and its data type (domain). A Value can be NULL.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

com.sparsity.sparksee.gdb.Value.Value ( com.sparsity.sparksee.gdb.Value value )

Copy constructor.

Parameters
value [in] Value to be copied.
com.sparsity.sparksee.gdb.Value.Value ( )

Creates a new instance.

It creates a NULL Value.

Member Function Documentation

int com.sparsity.sparksee.gdb.Value.Compare ( com.sparsity.sparksee.gdb.Value value )

Compares with the given Value.

It does not work if the given Value objects does not have the same DataType.

Parameters
value Given value to compare to.
Returns
0 if this Value is equal to the given one; a value less than 0 if this Value is less than the given one; and a value greater than 0 if this Value is greater than the given one.
int com.sparsity.sparksee.gdb.Value.CompareTo ( com.sparsity.sparksee.gdb.Value other )

Compares the current instance with another object of the same type.

Parameters
other Another Value to compare with this instance.
Returns
Less than zero, if the instance is less than other; Zero, if the instance is equal to other; and greater than zero if the instance is greater than other.
int com.sparsity.sparksee.gdb.Value.CompareTo ( System.Object other )

Compares the current instance with another object of the same type.

Parameters
other An object to compare with this instance.
Returns
Less than zero, if the instance is less than other; Zero, if the instance is equal to other; and greater than zero if the instance is greater than other.
bool com.sparsity.sparksee.gdb.Value.Equals ( com.sparsity.sparksee.gdb.Value value )

Compares with the given Value.

It does not work if the given Value objects does not have the same DataType.

Parameters
value Given value to compare to.
Returns
TRUE if this Value is equal to the given one; FALSE otherwise.
bool com.sparsity.sparksee.gdb.Value.Equals ( System.Object other )

Indicates whether the current object is equal to another object.

Parameters
other An object to compare with this instance.
Returns
TRUE if the current object is equal to the other; otherwise, FALSE.
bool com.sparsity.sparksee.gdb.Value.GetBoolean ( )

Gets Boolean Value.

This must be a non-NULL Boolean Value.

Returns
The Boolean Value.
com.sparsity.sparksee.gdb.DataType com.sparsity.sparksee.gdb.Value.GetDataType ( )

Gets the DataType.

Value cannot be NULL.

Returns
The DataType.
double com.sparsity.sparksee.gdb.Value.GetDouble ( )

Gets Double Value.

This must be a non-NULL Double Value.

Returns
The Double Value.
int com.sparsity.sparksee.gdb.Value.GetInteger ( )

Gets Integer Value.

This must be a non-NULL Integer Value.

Returns
The Integer Value.
long com.sparsity.sparksee.gdb.Value.GetLong ( )

Gets Long Value.

This must be a non-NULL Long Value.

Returns
The Long Value.
long com.sparsity.sparksee.gdb.Value.GetOID ( )

Gets OID Value.

This must be an non-NULL OID Value.

Returns
The OID Value.
System.String com.sparsity.sparksee.gdb.Value.GetString ( )

Gets String Value.

This must be a non-NULL String Value.

Returns
The String Value.
long com.sparsity.sparksee.gdb.Value.GetTimestamp ( )

Gets Timestamp Value.

This must be a non-NULL Timestamp Value.

Returns
The Timestamp Value.
System.DateTime com.sparsity.sparksee.gdb.Value.GetTimestampAsDateTime ( )

Gets the Value as a DateTime instance.

Returns
The returning DateTime instance.
bool com.sparsity.sparksee.gdb.Value.IsNull ( )

Gets if this is a NULL Value.

Returns
TRUE if this is a NULL Value, FALSE otherwise.
com.sparsity.sparksee.gdb.Value com.sparsity.sparksee.gdb.Value.Set ( com.sparsity.sparksee.gdb.Value value )

Sets the Value.

Parameters
value New value.
Returns
The calling instance.
com.sparsity.sparksee.gdb.Value com.sparsity.sparksee.gdb.Value.SetBoolean ( bool value )

Sets the Value.

Parameters
value New value.
Returns
The calling instance.
void com.sparsity.sparksee.gdb.Value.SetBooleanVoid ( bool value )

Sets the Value.

Parameters
value [in] New Boolean value.
com.sparsity.sparksee.gdb.Value com.sparsity.sparksee.gdb.Value.SetDouble ( double value )

Sets the Value.

Parameters
value New value.
Returns
The calling instance.
void com.sparsity.sparksee.gdb.Value.SetDoubleVoid ( double value )

Sets the Value.

Parameters
value [in] New Double value.
com.sparsity.sparksee.gdb.Value com.sparsity.sparksee.gdb.Value.SetInteger ( int value )

Sets the Value.

Parameters
value New value.
Returns
The calling instance.
void com.sparsity.sparksee.gdb.Value.SetIntegerVoid ( int value )

Sets the Value.

Parameters
value [in] New Integer value.
com.sparsity.sparksee.gdb.Value com.sparsity.sparksee.gdb.Value.SetLong ( long value )

Sets the Value.

Parameters
value New value.
Returns
The calling instance.
void com.sparsity.sparksee.gdb.Value.SetLongVoid ( long value )

Sets the Value.

Parameters
value [in] New Long value.
com.sparsity.sparksee.gdb.Value com.sparsity.sparksee.gdb.Value.SetNull ( )

Sets the Value to NULL.

Returns
The calling instance.
com.sparsity.sparksee.gdb.Value com.sparsity.sparksee.gdb.Value.SetOID ( long value )

Sets the Value.

Parameters
value New value.
Returns
The calling instance.
void com.sparsity.sparksee.gdb.Value.SetOIDVoid ( long value )

Sets the OID Value.

Parameters
value [in] New OID value.
com.sparsity.sparksee.gdb.Value com.sparsity.sparksee.gdb.Value.SetString ( string value )

Sets the Value.

Parameters
value New value.
Returns
The calling instance.
void com.sparsity.sparksee.gdb.Value.SetStringVoid ( System.String value )

Sets the Value.

Parameters
value [in] New String value.
com.sparsity.sparksee.gdb.Value com.sparsity.sparksee.gdb.Value.SetTimestamp ( System.DateTime dt )

Sets the Value.

Parameters
dt New value.
Returns
The calling instance.
com.sparsity.sparksee.gdb.Value com.sparsity.sparksee.gdb.Value.SetTimestamp | ( | int | year,
 |  | int | month,
 |  | int | day,
 |  | int | hour,
 |  | int | minutes,
 |  | int | seconds,
 |  | int | millisec
 | ) |  |

Sets the Value.

Parameters
year | The year (>=1970).
month | The month ([1..12]).
day | The day of the month ([1..31]).
hour | The hour ([0..23]).
minutes | The minutes ([0..59]).
seconds | The seconds ([0..59]).
millisec | The milliseconds ([0..999]).
Returns
The calling instance.
void com.sparsity.sparksee.gdb.Value.SetTimestampVoid ( long value )

Sets the Value.

Parameters
value [in] New Timestamp value.
void com.sparsity.sparksee.gdb.Value.SetTimestampVoid | ( | int | year,
 |  | int | month,
 |  | int | day,
 |  | int | hour,
 |  | int | minutes,
 |  | int | seconds,
 |  | int | millisecs
 | ) |  |

Sets the Value.

Parameters
year | [in] The year (>=1970).
month | [in] The month ([1..12]).
day | [in] The of the month ([1..31]).
hour | [in] The hour ([0..23]).
minutes | [in] The minutes ([0..59]).
seconds | [in] The seconds ([0..59]).
millisecs | [in] The milliseconds ([0..999]).
void com.sparsity.sparksee.gdb.Value.SetVoid ( com.sparsity.sparksee.gdb.Value value )

Sets the Value.

Parameters
value [in] New value.


SparkseeNet: Member List

  • gdb
  • Value
com.sparsity.sparksee.gdb.Value Member List

This is the complete list of members for com.sparsity.sparksee.gdb.Value, including all inherited members.

Compare(com.sparsity.sparksee.gdb.Value value) | com.sparsity.sparksee.gdb.Value |
CompareTo(com.sparsity.sparksee.gdb.Value other) | com.sparsity.sparksee.gdb.Value |
CompareTo(System.Object other) | com.sparsity.sparksee.gdb.Value |
Equals(com.sparsity.sparksee.gdb.Value value) | com.sparsity.sparksee.gdb.Value |
Equals(System.Object other) | com.sparsity.sparksee.gdb.Value |
GetBoolean() | com.sparsity.sparksee.gdb.Value |
GetDataType() | com.sparsity.sparksee.gdb.Value |
GetDouble() | com.sparsity.sparksee.gdb.Value |
GetInteger() | com.sparsity.sparksee.gdb.Value |
GetLong() | com.sparsity.sparksee.gdb.Value |
GetOID() | com.sparsity.sparksee.gdb.Value |
GetString() | com.sparsity.sparksee.gdb.Value |
GetTimestamp() | com.sparsity.sparksee.gdb.Value |
GetTimestampAsDateTime() | com.sparsity.sparksee.gdb.Value |
IsNull() | com.sparsity.sparksee.gdb.Value |
MaxLengthString | com.sparsity.sparksee.gdb.Value | static
Set(com.sparsity.sparksee.gdb.Value value) | com.sparsity.sparksee.gdb.Value |
SetBoolean(bool value) | com.sparsity.sparksee.gdb.Value |
SetBooleanVoid(bool value) | com.sparsity.sparksee.gdb.Value |
SetDouble(double value) | com.sparsity.sparksee.gdb.Value |
SetDoubleVoid(double value) | com.sparsity.sparksee.gdb.Value |
SetInteger(int value) | com.sparsity.sparksee.gdb.Value |
SetIntegerVoid(int value) | com.sparsity.sparksee.gdb.Value |
SetLong(long value) | com.sparsity.sparksee.gdb.Value |
SetLongVoid(long value) | com.sparsity.sparksee.gdb.Value |
SetNull() | com.sparsity.sparksee.gdb.Value |
SetNullVoid() | com.sparsity.sparksee.gdb.Value |
SetOID(long value) | com.sparsity.sparksee.gdb.Value |
SetOIDVoid(long value) | com.sparsity.sparksee.gdb.Value |
SetString(string value) | com.sparsity.sparksee.gdb.Value |
SetStringVoid(System.String value) | com.sparsity.sparksee.gdb.Value |
SetTimestamp(System.DateTime dt) | com.sparsity.sparksee.gdb.Value |
SetTimestamp(int year, int month, int day, int hour, int minutes, int seconds, int millisec) | com.sparsity.sparksee.gdb.Value |
SetTimestampVoid(long value) | com.sparsity.sparksee.gdb.Value |
SetTimestampVoid(int year, int month, int day, int hour, int minutes, int seconds, int millisecs) | com.sparsity.sparksee.gdb.Value |
SetVoid(com.sparsity.sparksee.gdb.Value value) | com.sparsity.sparksee.gdb.Value |
ToString() | com.sparsity.sparksee.gdb.Value |
Value(com.sparsity.sparksee.gdb.Value value) | com.sparsity.sparksee.gdb.Value |
Value() | com.sparsity.sparksee.gdb.Value |


SparkseeNet: com.sparsity.sparksee.gdb.ValueArray Class Reference

  • gdb
  • ValueArray
Public Member Functions | List of all members
com.sparsity.sparksee.gdb.ValueArray Class Reference

ValueArray class. More...

Public Member Functions

long[] | GetOID (int index, int size)
Get a subset of the Values from this long array.
long[] | GetLong ()
Get all the Values from this long array.
void | SetBoolean (int index, bool[] values) throws System.ApplicationException, System.ArgumentException, System.ApplicationException
Set a subset of the values of this bool array.
bool[] | GetBoolean (int index, int size)
Get a subset of the Values from this boolean array.
void | SetDouble (int index, double[] values) throws System.ApplicationException, System.ArgumentException, System.ApplicationException
Set a subset of the values of this double array.
void | SetInteger (int[] values) throws System.ApplicationException, System.ApplicationException
Set all the values of this int array.
double[] | GetDouble ()
Get all the Values from this double array.
long[] | GetTimestamp ()
Get all the Values from this timestamp array.
bool[] | GetBoolean ()
Get all the Values from this boolean array.
boolean | IsClosed ()
Gets if ValueArray instance has been closed or not.
void | SetTimestamp (long[] values) throws System.ApplicationException, System.ApplicationException
Set all the values of this timestamp array.
void | Set (int index, com.sparsity.sparksee.gdb.Value value) throws System.ApplicationException, System.ArgumentException
Set a Value to a specific array position.
void | Close ()
Closes the ValueArray instance.
void | SetLong (long[] values) throws System.ApplicationException, System.ApplicationException
Set all the values of this long array.
int[] | GetInteger (int index, int size)
Get a subset of the Values from this int array.
void | SetLong (int index, long[] values) throws System.ApplicationException, System.ArgumentException, System.ApplicationException
Set a subset of the values of this long array.
long[] | GetTimestamp (int index, int size)
Get a subset of the Values from this timestamp array.
void | SetDouble (double[] values) throws System.ApplicationException, System.ApplicationException
Set all the values of this double array.
void | SetOID (long[] values) throws System.ApplicationException, System.ApplicationException
Set all the values of this oid array.
void | SetTimestamp (int index, long[] values) throws System.ApplicationException, System.ArgumentException, System.ApplicationException
Set a subset of the values of this timestamp array.
long[] | GetLong (int index, int size)
Get a subset of the Values from this long array.
void | MakeNull () throws System.ApplicationException
Sets the attribute array to Null.
void | SetBoolean (bool[] values) throws System.ApplicationException, System.ApplicationException
Set all the values of this bool array.
long[] | GetOID ()
Get all the Values from this OID array.
double[] | GetDouble (int index, int size)
Get a subset of the Values from this double array.
int[] | GetInteger ()
Get all the Values from this int array.
int | Size ()
Returns the array size.
void | Set (com.sparsity.sparksee.gdb.Value value) throws System.ApplicationException, System.ArgumentException
Set a Value to the whole array.
void | SetOID (int index, long[] values) throws System.ApplicationException, System.ArgumentException, System.ApplicationException
Set a subset of the values of this oid array.
void | Get (int index, com.sparsity.sparksee.gdb.Value value) throws System.ApplicationException, System.ArgumentException
Get a Value from the array.
void | SetInteger (int index, int[] values) throws System.ApplicationException, System.ArgumentException, System.ApplicationException
Set a subset of the values of this int array.

Detailed Description

ValueArray class.

It allows for getting and setting ValueArray attribute values.

It is very important to close the ValueArray once no more get or set operations will be performed.

Creation of a new ValueArray: (i) Set all the ValueArray elements using Graph::SetAttributeArray (ii) perform as many get/set operations as you need to the ValueArray instance. Lastly, (iii) Close the ValueArray

Use of an existing ValueArray: (i) Get a ValueArray instance using Graph::GetAttributeArray (ii) perform as many get/set operations as you need to the ValueArray instance. Lastly, (iii) Close the ValueArray

Check out the 'Attributes and values' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

void com.sparsity.sparksee.gdb.ValueArray.Close ( )

Closes the ValueArray instance.

It must be called to ensure the integrity of all data.

void com.sparsity.sparksee.gdb.ValueArray.Get | ( | int | index,
 |  | com.sparsity.sparksee.gdb.Value | value
 | ) |  | throws System.ApplicationException, System.ArgumentException

Get a Value from the array.

AppErrorIf the ValueArray is not available

Parameters
index | [in] Position of the element to get [0..N-1]
value | [out] Value to get the array element
Exceptions
System.ApplicationException | null
System.ArgumentException | If the index is out of range or the Value not valid
bool [] com.sparsity.sparksee.gdb.ValueArray.GetBoolean | ( | int | index,
 |  | int | size
 | ) |  |

Get a subset of the Values from this boolean array.

Parameters
index | Position of the first element to get [0..N-1]
size | Number of elements to get [1..N]
Returns
Returns all the requested values
bool [] com.sparsity.sparksee.gdb.ValueArray.GetBoolean ( )

Get all the Values from this boolean array.

Returns
Returns all the values
double [] com.sparsity.sparksee.gdb.ValueArray.GetDouble ( )

Get all the Values from this double array.

Returns
Returns all the values
double [] com.sparsity.sparksee.gdb.ValueArray.GetDouble | ( | int | index,
 |  | int | size
 | ) |  |

Get a subset of the Values from this double array.

Parameters
index | Position of the first element to get [0..N-1]
size | Number of elements to get [1..N]
Returns
Returns all the requested values
int [] com.sparsity.sparksee.gdb.ValueArray.GetInteger | ( | int | index,
 |  | int | size
 | ) |  |

Get a subset of the Values from this int array.

Parameters
index | Position of the first element to get [0..N-1]
size | Number of elements to get [1..N]
Returns
Returns all the requested values
int [] com.sparsity.sparksee.gdb.ValueArray.GetInteger ( )

Get all the Values from this int array.

Returns
Returns all the values
long [] com.sparsity.sparksee.gdb.ValueArray.GetLong ( )

Get all the Values from this long array.

Returns
Returns all the values
long [] com.sparsity.sparksee.gdb.ValueArray.GetLong | ( | int | index,
 |  | int | size
 | ) |  |

Get a subset of the Values from this long array.

Parameters
index | Position of the first element to get [0..N-1]
size | Number of elements to get [1..N]
Returns
Returns all the requested values
long [] com.sparsity.sparksee.gdb.ValueArray.GetOID | ( | int | index,
 |  | int | size
 | ) |  |

Get a subset of the Values from this long array.

Parameters
index | Position of the first element to get [0..N-1]
size | Number of elements to get [1..N]
Returns
Returns all the requested values
long [] com.sparsity.sparksee.gdb.ValueArray.GetOID ( )

Get all the Values from this OID array.

Returns
Returns all the values
long [] com.sparsity.sparksee.gdb.ValueArray.GetTimestamp ( )

Get all the Values from this timestamp array.

Returns
Returns all the values
long [] com.sparsity.sparksee.gdb.ValueArray.GetTimestamp | ( | int | index,
 |  | int | size
 | ) |  |

Get a subset of the Values from this timestamp array.

Parameters
index | Position of the first element to get [0..N-1]
size | Number of elements to get [1..N]
Returns
Returns all the requested values
boolean com.sparsity.sparksee.gdb.ValueArray.IsClosed ( )

Gets if ValueArray instance has been closed or not.

See Also
Close()
Returns
TRUE if the ValueArray instance has been closed, FALSE otherwise.
void com.sparsity.sparksee.gdb.ValueArray.MakeNull ( ) throws System.ApplicationException

Sets the attribute array to Null.

The ValueArray can not be used after this call.

Exceptions
System.ApplicationException null
void com.sparsity.sparksee.gdb.ValueArray.Set | ( | int | index,
 |  | com.sparsity.sparksee.gdb.Value | value
 | ) |  | throws System.ApplicationException, System.ArgumentException

Set a Value to a specific array position.

AppErrorIf the ValueArray is not available

Parameters
index | [in] Position of the element to set [0..N-1]
value | [in] Value to set in the array element
Exceptions
System.ApplicationException | null
System.ArgumentException | If the index is out of range or the Value not valid
void com.sparsity.sparksee.gdb.ValueArray.Set ( com.sparsity.sparksee.gdb.Value value ) throws System.ApplicationException, System.ArgumentException

Set a Value to the whole array.

AppErrorIf the ValueArray is not available

Parameters
value [in] Value to set in all the array elements
Exceptions
System.ApplicationException | null
System.ArgumentException | If the Value is not valid
void com.sparsity.sparksee.gdb.ValueArray.SetBoolean | ( | int | index,
 |  | bool[] | values
 | ) |  | throws System.ApplicationException, System.ArgumentException, System.ApplicationException

Set a subset of the values of this bool array.

UnsupportedOperationErrorIf array DataType is not bool AppErrorIf the ValueArray is not available

Parameters
index | [in] Position of the first element to set [0..N-1]
values | The values to set
Exceptions
System.ApplicationException | null
System.ArgumentException | If the index or size is out of range
System.ApplicationException | null
void com.sparsity.sparksee.gdb.ValueArray.SetBoolean ( bool[] values ) throws System.ApplicationException, System.ApplicationException

Set all the values of this bool array.

AppErrorIf the ValueArray is not available

Parameters
values All the values to set
Exceptions
System.ApplicationException | If array DataType is not bool
System.ApplicationException | null
void com.sparsity.sparksee.gdb.ValueArray.SetDouble | ( | int | index,
 |  | double[] | values
 | ) |  | throws System.ApplicationException, System.ArgumentException, System.ApplicationException

Set a subset of the values of this double array.

UnsupportedOperationErrorIf array DataType is not Double AppErrorIf the ValueArray is not available

Parameters
index | [in] Position of the first element to set [0..N-1]
values | The values to set
Exceptions
System.ApplicationException | null
System.ArgumentException | If the index or size is out of range
System.ApplicationException | null
void com.sparsity.sparksee.gdb.ValueArray.SetDouble ( double[] values ) throws System.ApplicationException, System.ApplicationException

Set all the values of this double array.

AppErrorIf the ValueArray is not available

Parameters
values All the values to set
Exceptions
System.ApplicationException | If array DataType is not Double
System.ApplicationException | null
void com.sparsity.sparksee.gdb.ValueArray.SetInteger ( int[] values ) throws System.ApplicationException, System.ApplicationException

Set all the values of this int array.

AppErrorIf the ValueArray is not available

Parameters
values All the values to set
Exceptions
System.ApplicationException | If array DataType is not int
System.ApplicationException | null
void com.sparsity.sparksee.gdb.ValueArray.SetInteger | ( | int | index,
 |  | int[] | values
 | ) |  | throws System.ApplicationException, System.ArgumentException, System.ApplicationException

Set a subset of the values of this int array.

UnsupportedOperationErrorIf array DataType is not int AppErrorIf the ValueArray is not available

Parameters
index | [in] Position of the first element to set [0..N-1]
values | The values to set
Exceptions
System.ApplicationException | null
System.ArgumentException | If the index or size is out of range
System.ApplicationException | null
void com.sparsity.sparksee.gdb.ValueArray.SetLong ( long[] values ) throws System.ApplicationException, System.ApplicationException

Set all the values of this long array.

AppErrorIf the ValueArray is not available

Parameters
values All the values to set
Exceptions
System.ApplicationException | If array DataType is not long
System.ApplicationException | null
void com.sparsity.sparksee.gdb.ValueArray.SetLong | ( | int | index,
 |  | long[] | values
 | ) |  | throws System.ApplicationException, System.ArgumentException, System.ApplicationException

Set a subset of the values of this long array.

UnsupportedOperationErrorIf array DataType is not long AppErrorIf the ValueArray is not available

Parameters
index | [in] Position of the first element to set [0..N-1]
values | The values to set
Exceptions
System.ApplicationException | null
System.ArgumentException | If the index or size is out of range
System.ApplicationException | null
void com.sparsity.sparksee.gdb.ValueArray.SetOID ( long[] values ) throws System.ApplicationException, System.ApplicationException

Set all the values of this oid array.

AppErrorIf the ValueArray is not available

Parameters
values All the values to set
Exceptions
System.ApplicationException | If array DataType is not oid
System.ApplicationException | null
void com.sparsity.sparksee.gdb.ValueArray.SetOID | ( | int | index,
 |  | long[] | values
 | ) |  | throws System.ApplicationException, System.ArgumentException, System.ApplicationException

Set a subset of the values of this oid array.

UnsupportedOperationErrorIf array DataType is not oid AppErrorIf the ValueArray is not available

Parameters
index | [in] Position of the first element to set [0..N-1]
values | The values to set
Exceptions
System.ApplicationException | null
System.ArgumentException | If the index or size is out of range
System.ApplicationException | null
void com.sparsity.sparksee.gdb.ValueArray.SetTimestamp ( long[] values ) throws System.ApplicationException, System.ApplicationException

Set all the values of this timestamp array.

AppErrorIf the ValueArray is not available

Parameters
values All the values to set
Exceptions
System.ApplicationException | If array DataType is not timestamp
System.ApplicationException | null
void com.sparsity.sparksee.gdb.ValueArray.SetTimestamp | ( | int | index,
 |  | long[] | values
 | ) |  | throws System.ApplicationException, System.ArgumentException, System.ApplicationException

Set a subset of the values of this timestamp array.

UnsupportedOperationErrorIf array DataType is not timestamp AppErrorIf the ValueArray is not available

Parameters
index | [in] Position of the first element to set [0..N-1]
values | The values to set
Exceptions
System.ApplicationException | null
System.ArgumentException | If the index or size is out of range
System.ApplicationException | null


SparkseeNet: Member List

  • gdb
  • ValueArray
com.sparsity.sparksee.gdb.ValueArray Member List

This is the complete list of members for com.sparsity.sparksee.gdb.ValueArray, including all inherited members.

Close() | com.sparsity.sparksee.gdb.ValueArray
Get(int index, com.sparsity.sparksee.gdb.Value value) | com.sparsity.sparksee.gdb.ValueArray
GetBoolean(int index, int size) | com.sparsity.sparksee.gdb.ValueArray
GetBoolean() | com.sparsity.sparksee.gdb.ValueArray
GetDouble() | com.sparsity.sparksee.gdb.ValueArray
GetDouble(int index, int size) | com.sparsity.sparksee.gdb.ValueArray
GetInteger(int index, int size) | com.sparsity.sparksee.gdb.ValueArray
GetInteger() | com.sparsity.sparksee.gdb.ValueArray
GetLong() | com.sparsity.sparksee.gdb.ValueArray
GetLong(int index, int size) | com.sparsity.sparksee.gdb.ValueArray
GetOID(int index, int size) | com.sparsity.sparksee.gdb.ValueArray
GetOID() | com.sparsity.sparksee.gdb.ValueArray
GetTimestamp() | com.sparsity.sparksee.gdb.ValueArray
GetTimestamp(int index, int size) | com.sparsity.sparksee.gdb.ValueArray
IsClosed() | com.sparsity.sparksee.gdb.ValueArray
MakeNull() | com.sparsity.sparksee.gdb.ValueArray
Set(int index, com.sparsity.sparksee.gdb.Value value) | com.sparsity.sparksee.gdb.ValueArray
Set(com.sparsity.sparksee.gdb.Value value) | com.sparsity.sparksee.gdb.ValueArray
SetBoolean(int index, bool[] values) | com.sparsity.sparksee.gdb.ValueArray
SetBoolean(bool[] values) | com.sparsity.sparksee.gdb.ValueArray
SetDouble(int index, double[] values) | com.sparsity.sparksee.gdb.ValueArray
SetDouble(double[] values) | com.sparsity.sparksee.gdb.ValueArray
SetInteger(int[] values) | com.sparsity.sparksee.gdb.ValueArray
SetInteger(int index, int[] values) | com.sparsity.sparksee.gdb.ValueArray
SetLong(long[] values) | com.sparsity.sparksee.gdb.ValueArray
SetLong(int index, long[] values) | com.sparsity.sparksee.gdb.ValueArray
SetOID(long[] values) | com.sparsity.sparksee.gdb.ValueArray
SetOID(int index, long[] values) | com.sparsity.sparksee.gdb.ValueArray
SetTimestamp(long[] values) | com.sparsity.sparksee.gdb.ValueArray
SetTimestamp(int index, long[] values) | com.sparsity.sparksee.gdb.ValueArray
Size() | com.sparsity.sparksee.gdb.ValueArray


SparkseeNet: com.sparsity.sparksee.gdb.ValueList Class Reference

  • gdb
  • ValueList
Public Member Functions | List of all members
com.sparsity.sparksee.gdb.ValueList Class Reference

Value list. More...

Public Member Functions

ValueList ()
Constructor.
com.sparsity.sparksee.gdb.Value | Get (int index)
Returns the Value at the specified position in the list.
void | Clear ()
Clears the list.
void | Add (com.sparsity.sparksee.gdb.Value value)
Adds a value to the end of the list.
com.sparsity.sparksee.gdb.ValueListIterator Iterator ()
Gets a new ValueListIterator.
int | Count ()
Number of elements in the list.

Detailed Description

Value list.

It stores a Value list.

Use ValueListIterator to access all elements into this collection.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

com.sparsity.sparksee.gdb.ValueList.ValueList ( )

Constructor.

This creates an empty list.

Member Function Documentation

void com.sparsity.sparksee.gdb.ValueList.Add ( com.sparsity.sparksee.gdb.Value value )

Adds a value to the end of the list.

Parameters
value [in] The value to add
int com.sparsity.sparksee.gdb.ValueList.Count ( )

Number of elements in the list.

Returns
Number of elements in the list.
com.sparsity.sparksee.gdb.Value com.sparsity.sparksee.gdb.ValueList.Get ( int index )

Returns the Value at the specified position in the list.

Parameters
index [in] Index of the element to return, starting at 0.
com.sparsity.sparksee.gdb.ValueListIterator com.sparsity.sparksee.gdb.ValueList.Iterator ( )

Gets a new ValueListIterator.

Returns
ValueListIterator instance.


SparkseeNet: Member List

  • gdb
  • ValueList
com.sparsity.sparksee.gdb.ValueList Member List

This is the complete list of members for com.sparsity.sparksee.gdb.ValueList, including all inherited members.

Add(com.sparsity.sparksee.gdb.Value value) | com.sparsity.sparksee.gdb.ValueList
Clear() | com.sparsity.sparksee.gdb.ValueList
Count() | com.sparsity.sparksee.gdb.ValueList
Get(int index) | com.sparsity.sparksee.gdb.ValueList
Iterator() | com.sparsity.sparksee.gdb.ValueList
ValueList() | com.sparsity.sparksee.gdb.ValueList


SparkseeNet: com.sparsity.sparksee.gdb.ValueListIterator Class Reference

  • gdb
  • ValueListIterator
Public Member Functions | List of all members
com.sparsity.sparksee.gdb.ValueListIterator Class Reference

ValueList iterator class. More...

Public Member Functions

bool HasNext ()
Gets if there are more elements.
com.sparsity.sparksee.gdb.Value Next ()
Moves to the next element.

Detailed Description

ValueList iterator class.

Iterator to traverse all the values into a ValueList instance.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

bool com.sparsity.sparksee.gdb.ValueListIterator.HasNext ( )

Gets if there are more elements.

Returns
TRUE if there are more elements, FALSE otherwise.
com.sparsity.sparksee.gdb.Value com.sparsity.sparksee.gdb.ValueListIterator.Next ( )

Moves to the next element.

Returns
The next element.


SparkseeNet: Member List

  • gdb
  • ValueListIterator
com.sparsity.sparksee.gdb.ValueListIterator Member List

This is the complete list of members for com.sparsity.sparksee.gdb.ValueListIterator, including all inherited members.

HasNext() | com.sparsity.sparksee.gdb.ValueListIterator
Next() | com.sparsity.sparksee.gdb.ValueListIterator


SparkseeNet: com.sparsity.sparksee.gdb.Values Class Reference

  • gdb
  • Values
Public Member Functions | List of all members
com.sparsity.sparksee.gdb.Values Class Reference

Value set class. More...

Public Member Functions

boolean | IsClosed ()
Gets if Values instance has been closed or not.
void | Close ()
Closes the Values instance.
long | Count ()
Gets the number of elements into the collection.
com.sparsity.sparksee.gdb.ValuesIterator | Iterator (com.sparsity.sparksee.gdb.Order order)
Gets a ValuesIterator.

Detailed Description

Value set class.

This is a set of Value instances, that is there is no duplicated elements.

Use a ValuesIterator to traverse all the elements into the set.

When the Values instance is closed, it closes all existing and non-closed ValuesIterator instances too.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

void com.sparsity.sparksee.gdb.Values.Close ( )

Closes the Values instance.

It must be called to ensure the integrity of all data.

long com.sparsity.sparksee.gdb.Values.Count ( )

Gets the number of elements into the collection.

Returns
The number of elements into the collection.
boolean com.sparsity.sparksee.gdb.Values.IsClosed ( )

Gets if Values instance has been closed or not.

See Also
Close()
Returns
TRUE if the Values instance has been closed, FALSE otherwise.
com.sparsity.sparksee.gdb.ValuesIterator com.sparsity.sparksee.gdb.Values.Iterator ( com.sparsity.sparksee.gdb.Order order )

Gets a ValuesIterator.

Parameters
order [in] Ascending or descending order.
Returns
ValuesIterator instance.


SparkseeNet: Member List

  • gdb
  • Values
com.sparsity.sparksee.gdb.Values Member List

This is the complete list of members for com.sparsity.sparksee.gdb.Values, including all inherited members.

Close() | com.sparsity.sparksee.gdb.Values
Count() | com.sparsity.sparksee.gdb.Values
IsClosed() | com.sparsity.sparksee.gdb.Values
Iterator(com.sparsity.sparksee.gdb.Order order) | com.sparsity.sparksee.gdb.Values


SparkseeNet: com.sparsity.sparksee.gdb.ValuesIterator Class Reference

  • gdb
  • ValuesIterator
Public Member Functions | List of all members
com.sparsity.sparksee.gdb.ValuesIterator Class Reference

Values iterator class. More...

Public Member Functions

boolean | IsClosed ()
Gets if ValuesIterator instance has been closed or not.
void | Close ()
Closes the ValuesIterator instance.
bool | HasNext ()
Gets if there are more elements to traverse.
com.sparsity.sparksee.gdb.Value Next ()
Gets the next element to traverse.

Detailed Description

Values iterator class.

It allows for traversing all the elements into a Values instance.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

void com.sparsity.sparksee.gdb.ValuesIterator.Close ( )

Closes the ValuesIterator instance.

It must be called to ensure the integrity of all data.

bool com.sparsity.sparksee.gdb.ValuesIterator.HasNext ( )

Gets if there are more elements to traverse.

Returns
TRUE if there are more elements to traverse, FALSE otherwise.
boolean com.sparsity.sparksee.gdb.ValuesIterator.IsClosed ( )

Gets if ValuesIterator instance has been closed or not.

See Also
Close()
Returns
TRUE if the ValuesIterator instance has been closed, FALSE otherwise.
com.sparsity.sparksee.gdb.Value com.sparsity.sparksee.gdb.ValuesIterator.Next ( )

Gets the next element to traverse.

Returns
The next element.


SparkseeNet: Member List

  • gdb
  • ValuesIterator
com.sparsity.sparksee.gdb.ValuesIterator Member List

This is the complete list of members for com.sparsity.sparksee.gdb.ValuesIterator, including all inherited members.

Close() | com.sparsity.sparksee.gdb.ValuesIterator
HasNext() | com.sparsity.sparksee.gdb.ValuesIterator
IsClosed() | com.sparsity.sparksee.gdb.ValuesIterator
Next() | com.sparsity.sparksee.gdb.ValuesIterator


SparkseeNet: com.sparsity.sparksee.io.CSVLoader Class Reference

  • io
  • CSVLoader
Static Public Member Functions | List of all members
com.sparsity.sparksee.io.CSVLoader Class Reference

Static Public Member Functions

static void | LoadEdges (com.sparsity.sparksee.gdb.Graph graph, System.String fileName, System.String edgeType, System.String tailNodeType, System.String headNodeType, int tail, int head, System.String separator, bool directed, bool header, com.sparsity.sparksee.gdb.MissingEndpoint onMissingTail, com.sparsity.sparksee.gdb.MissingEndpoint onMissingHead, int[] columns, System.String[] attrNames, com.sparsity.sparksee.gdb.DataType[] dataTypes, com.sparsity.sparksee.gdb.AttributeKind[] attrKinds)
Loads edges from a CSV file.
static void | LoadNodes (com.sparsity.sparksee.gdb.Graph graph, System.String fileName, System.String nodeType, System.String separator, bool header, int[] columns, System.String[] attrNames, com.sparsity.sparksee.gdb.DataType[] dataTypes, com.sparsity.sparksee.gdb.AttributeKind[] attrKinds)
Loads nodes from a CSV file.

Member Function Documentation

static void com.sparsity.sparksee.io.CSVLoader.LoadEdges | ( | com.sparsity.sparksee.gdb.Graph | graph,
 |  | System.String | fileName,
 |  | System.String | edgeType,
 |  | System.String | tailNodeType,
 |  | System.String | headNodeType,
 |  | int | tail,
 |  | int | head,
 |  | System.String | separator,
 |  | bool | directed,
 |  | bool | header,
 |  | com.sparsity.sparksee.gdb.MissingEndpoint | onMissingTail,
 |  | com.sparsity.sparksee.gdb.MissingEndpoint | onMissingHead,
 |  | int[] | columns,
 |  | System.String[] | attrNames,
 |  | com.sparsity.sparksee.gdb.DataType[] | dataTypes,
 |  | com.sparsity.sparksee.gdb.AttributeKind[] | attrKinds
 | ) |  |
static

Loads edges from a CSV file.

nodeType[in] The type of the edge to load. If it does not exist, it creates it

Parameters
graph | [in] The graph to load the edges into
fileName | [in] The name of the file
edgeType | null
tailNodeType | [in] The type of the tail nodes. If it does not exist and onMissingTail is set to "Create", it creates it. Otherwise, an exception is thrown
headNodeType | [in] The type of the head nodes. It it does not exist and onMissingHead is set to "Create", it creates it. Otherwise, an exception is thrown
tail | [in] The tail column index. Default: 0
head | [in] The head column index. Default: 1
separator | [in] The column separator. Default: ","
directed | [in] True if this edge is directed or not. False otherwise. Default: True
header | [in] True if the CSV contains a header. False otherwise. Default: True
onMissingTail | [in] The policy to follow when a tail is missing. Default: "IsError"
onMissingHead | [in] The policy to follow when a head is missing. Default: "IsError"
columns | [in] The list of columns to load. tail and head columns must be in this list if this list is specified. If the list is empty, all columns are loaded. Default: empty
attrNames | [in] The attribute names. If this list is empty and hasHeader is set to true, the header values are used as attribute names. Default: empty
dataTypes | [in] The dataTypes of the attributes if this do not already exist. If this list is empty, the method tries to infer the data type from the first non-header row. Default: empty
attrKinds | [in] The attributeKinds of the attributes if these do not already exist. If this list is empty, the attributeKind of the created attributes are set to Basic. Default: empty
static void com.sparsity.sparksee.io.CSVLoader.LoadNodes | ( | com.sparsity.sparksee.gdb.Graph | graph,
 |  | System.String | fileName,
 |  | System.String | nodeType,
 |  | System.String | separator,
 |  | bool | header,
 |  | int[] | columns,
 |  | System.String[] | attrNames,
 |  | com.sparsity.sparksee.gdb.DataType[] | dataTypes,
 |  | com.sparsity.sparksee.gdb.AttributeKind[] | attrKinds
 | ) |  |
static

Loads nodes from a CSV file.

Parameters
graph | [in] The graph to load the nodes into
fileName | [in] The name of the file
nodeType | [in] The type of the node to load. If it does not exist, it creates it
separator | [in] The separator of the CSV file. Default: ","
header | [in] True if the CSV contains a header. False otherwise. Default: True
columns | [in] The list of columns to load. tail and head columns mus be in this list if this list is specified. Default: all columns
attrNames | [in] The attribute names. If this list is empty and hasHeader is set to true, the header values are used as attribute names. Default: empty
dataTypes | [in] The dataTypes of the attributes if this do not already exist. Default: empty If this list is empty, the method tries to infer the data type from the first non-header row
attrKinds | [in] The attributeKinds of the attributes if these do not already exist. Default: empty If this list is empty, the attributeKind of the created attributes are set to Basic. Default: empty


SparkseeNet: Member List

  • io
  • CSVLoader
com.sparsity.sparksee.io.CSVLoader Member List

This is the complete list of members for com.sparsity.sparksee.io.CSVLoader, including all inherited members.

LoadEdges(com.sparsity.sparksee.gdb.Graph graph, System.String fileName, System.String edgeType, System.String tailNodeType, System.String headNodeType, int tail, int head, System.String separator, bool directed, bool header, com.sparsity.sparksee.gdb.MissingEndpoint onMissingTail, com.sparsity.sparksee.gdb.MissingEndpoint onMissingHead, int[] columns, System.String[] attrNames, com.sparsity.sparksee.gdb.DataType[] dataTypes, com.sparsity.sparksee.gdb.AttributeKind[] attrKinds) | com.sparsity.sparksee.io.CSVLoader | static
LoadNodes(com.sparsity.sparksee.gdb.Graph graph, System.String fileName, System.String nodeType, System.String separator, bool header, int[] columns, System.String[] attrNames, com.sparsity.sparksee.gdb.DataType[] dataTypes, com.sparsity.sparksee.gdb.AttributeKind[] attrKinds) | com.sparsity.sparksee.io.CSVLoader | static


SparkseeNet: com.sparsity.sparksee.io.CSVReader Class Reference

  • io
  • CSVReader
Public Member Functions | List of all members
com.sparsity.sparksee.io.CSVReader Class Reference

CSVReader interface. More...

Inheritance diagram for com.sparsity.sparksee.io.CSVReader:
Collaboration diagram for com.sparsity.sparksee.io.CSVReader:

Public Member Functions

bool | Reset () throws System.IO.IOException
Moves the reader to the beginning.
void | Close () throws System.IO.IOException
Closes the reader.
void | SetNumLines (int numLines)
Used to limit the number of lines that will be read.
void | SetMultilines (int numExtralines)
Allows the use of fields with more than one line.
void | SetSeparator (System.String sep) throws System.ApplicationException
Sets the character used to separate fields in the file.
void | SetQuotes (System.String quotes) throws System.ApplicationException
Sets the character used to quote fields.
void | Open (System.String filePath) throws System.IO.IOException
Opens the source file path.
void | SetSingleLine ()
Only allows single line fields.
bool | Read (com.sparsity.sparksee.gdb.StringList row) throws System.IO.IOException
Reads the next row as a string array.
void | SetStartLine (int startLine)
Sets the number of lines to be skiped from the beginning.
void | SetLocale (System.String localeStr)
Sets the locale that will be used to read the file.
int | GetRow () throws System.IO.IOException
The row number for the current row.
CSVReader ()
Constructs CSVReader.

Detailed Description

CSVReader interface.

A very simple CSV reader.

It works as any other RowReader, but open must be called once before the first read operation.

Using the format RFC 4180.

Except: leading and trailing spaces, adjacent to CSV separator character, are trimmed.

You can use your own separators and quote characters. By default the separator is the comma (,) and the quote character is the double quotes (").

Fields with multiple lines can be allowed (and the maximum lines specified), but the default is a single line.

The locale string can be used to set the language, country and the file encoding. The format must be "[language_territory][.codeset]". But only the file encoding is being used in the current version.

The languages supported are: "en_US", "es_ES" and "ca_ES".

The file encodings supported are: "utf8" and "iso88591".

For example:

To don't change the default locales, use an empty string: "".

To read a file in utf8 with the default language settings use ".utf8".

To read a file in iso88591 with English language use: "en_US.iso88591".

Check out the 'Data import' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

void com.sparsity.sparksee.io.CSVReader.Close ( ) throws System.IO.IOException

Closes the reader.

Exceptions
System.IO.IOException If the close fails.
int com.sparsity.sparksee.io.CSVReader.GetRow ( ) throws System.IO.IOException

The row number for the current row.

Returns
The current row number; 0 if there is no current row.
Exceptions
System.IO.IOException If it fails.
void com.sparsity.sparksee.io.CSVReader.Open ( System.String filePath ) throws System.IO.IOException

Opens the source file path.

File can be optionally compressed in GZIP format.

Parameters
filePath [in] CSV file path.
Exceptions
System.IO.IOException If bad things happen opening the file.
bool com.sparsity.sparksee.io.CSVReader.Read ( com.sparsity.sparksee.gdb.StringList row ) throws System.IO.IOException

Reads the next row as a string array.

Parameters
row [out] A string list with each comma-separated element as a separate entry.
Returns
Returns true if a row had been read or false otherwise.
Exceptions
System.IO.IOException If bad things happen during the read.
bool com.sparsity.sparksee.io.CSVReader.Reset ( ) throws System.IO.IOException

Moves the reader to the beginning.

Restarts the reader.

Returns
true if the reader can be restarted, false otherwise.
Exceptions
System.IO.IOException If bad things happen during the restart.
void com.sparsity.sparksee.io.CSVReader.SetLocale ( System.String localeStr )

Sets the locale that will be used to read the file.

Parameters
localeStr [in] The locale string for the file encoding.
void com.sparsity.sparksee.io.CSVReader.SetMultilines ( int numExtralines )

Allows the use of fields with more than one line.

Parameters
numExtralines [in] Maximum number of extra lines for each column (0==unlimited, N==N+1 total rows).
void com.sparsity.sparksee.io.CSVReader.SetNumLines ( int numLines )

Used to limit the number of lines that will be read.

Parameters
numLines [in] The maximum number of lines to read (0 == unlimited)
void com.sparsity.sparksee.io.CSVReader.SetQuotes ( System.String quotes ) throws System.ApplicationException

Sets the character used to quote fields.

Parameters
quotes [in] Quote character.
Exceptions
System.ApplicationException null
void com.sparsity.sparksee.io.CSVReader.SetSeparator ( System.String sep ) throws System.ApplicationException

Sets the character used to separate fields in the file.

Parameters
sep [in] Separator character.
Exceptions
System.ApplicationException null
void com.sparsity.sparksee.io.CSVReader.SetStartLine ( int startLine )

Sets the number of lines to be skiped from the beginning.

Parameters
startLine [in] The line number to skip for start reading


SparkseeNet: Member List

  • io
  • CSVReader
com.sparsity.sparksee.io.CSVReader Member List

This is the complete list of members for com.sparsity.sparksee.io.CSVReader, including all inherited members.

Close() | com.sparsity.sparksee.io.CSVReader
CSVReader() | com.sparsity.sparksee.io.CSVReader
GetRow() | com.sparsity.sparksee.io.CSVReader
Open(System.String filePath) | com.sparsity.sparksee.io.CSVReader
Read(com.sparsity.sparksee.gdb.StringList row) | com.sparsity.sparksee.io.CSVReader
Reset() | com.sparsity.sparksee.io.CSVReader
SetLocale(System.String localeStr) | com.sparsity.sparksee.io.CSVReader
SetMultilines(int numExtralines) | com.sparsity.sparksee.io.CSVReader
SetNumLines(int numLines) | com.sparsity.sparksee.io.CSVReader
SetQuotes(System.String quotes) | com.sparsity.sparksee.io.CSVReader
SetSeparator(System.String sep) | com.sparsity.sparksee.io.CSVReader
SetSingleLine() | com.sparsity.sparksee.io.CSVReader
SetStartLine(int startLine) | com.sparsity.sparksee.io.CSVReader


SparkseeNet: com.sparsity.sparksee.io.CSVWriter Class Reference

  • io
  • CSVWriter
Public Member Functions | List of all members
com.sparsity.sparksee.io.CSVWriter Class Reference

CSVWriter interface. More...

Inheritance diagram for com.sparsity.sparksee.io.CSVWriter:
Collaboration diagram for com.sparsity.sparksee.io.CSVWriter:

Public Member Functions

void | SetAutoQuotes (bool autoquotes)
Sets on/off the automatic quote mode.
void | SetSeparator (System.String sep) throws System.ApplicationException
Sets the character used to separate fields in the file.
void | SetQuotes (System.String quotes) throws System.ApplicationException
Sets the character used to quote fields.
void | SetLocale (System.String localeStr)
Sets the locale that will be used to write the file.
void | Write (com.sparsity.sparksee.gdb.StringList row) throws System.IO.IOException, System.ApplicationException
Writes the next row.
void | SetForcedQuotes (com.sparsity.sparksee.gdb.BooleanList forcequotes)
Disables the automatic quote mode and forces to be quoted those positions set to TRUE in the given vector.
void | Close () throws System.IO.IOException, System.ApplicationException
Closes the writer.
CSVWriter ()
Creates a new instance.
void | Open (System.String f) throws System.IO.IOException
Opens the output file path.

Detailed Description

CSVWriter interface.

A very simple CSV writer implementing RowWriter.

It works as any other RowWriter, but open must be called once before the first write operation.

It uses the format RFC 4180: http://tools.ietf.org/html/rfc4180

You can use your own separators and quote characters. By default the separator is the comma (,) and the quote character is the double quotes (") and autoquote is enabled.

See the CSVReader locale documentation or the SPARKSEE User Manual.

Check out the 'Data export' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

void com.sparsity.sparksee.io.CSVWriter.Close ( ) throws System.IO.IOException, System.ApplicationException

Closes the writer.

Exceptions
System.IO.IOException | If the close fails.
System.ApplicationException | null
void com.sparsity.sparksee.io.CSVWriter.Open ( System.String f ) throws System.IO.IOException

Opens the output file path.

Parameters
f [in] Output file path.
Exceptions
System.IO.IOException If bad things happen opening the file.
void com.sparsity.sparksee.io.CSVWriter.SetAutoQuotes ( bool autoquotes )

Sets on/off the automatic quote mode.

If there are forced quotes, setting autoquotes on will clear them. If the autoquotes is set to off and no forced quotes are provided, there will not be any quote.

Parameters
autoquotes [in] If TRUE it enables the automatic quote mode, if FALSE it disables it.
void com.sparsity.sparksee.io.CSVWriter.SetForcedQuotes ( com.sparsity.sparksee.gdb.BooleanList forcequotes )

Disables the automatic quote mode and forces to be quoted those positions set to TRUE in the given vector.

Parameters
forcequotes [in] A booleanList with the position for each column that must be quoted set to true.
void com.sparsity.sparksee.io.CSVWriter.SetLocale ( System.String localeStr )

Sets the locale that will be used to write the file.

Parameters
localeStr [in] The locale string for the file encoding.
void com.sparsity.sparksee.io.CSVWriter.SetQuotes ( System.String quotes ) throws System.ApplicationException

Sets the character used to quote fields.

Parameters
quotes [in] Quote character.
Exceptions
System.ApplicationException null
void com.sparsity.sparksee.io.CSVWriter.SetSeparator ( System.String sep ) throws System.ApplicationException

Sets the character used to separate fields in the file.

Parameters
sep [in] Separator character.
Exceptions
System.ApplicationException null
void com.sparsity.sparksee.io.CSVWriter.Write ( com.sparsity.sparksee.gdb.StringList row ) throws System.IO.IOException, System.ApplicationException

Writes the next row.

Parameters
row [in] Row of data.
Exceptions
System.IO.IOException | If bad things happen during the write.
System.ApplicationException | null


SparkseeNet: Member List

  • io
  • CSVWriter
com.sparsity.sparksee.io.CSVWriter Member List

This is the complete list of members for com.sparsity.sparksee.io.CSVWriter, including all inherited members.

Close() | com.sparsity.sparksee.io.CSVWriter
CSVWriter() | com.sparsity.sparksee.io.CSVWriter
Open(System.String f) | com.sparsity.sparksee.io.CSVWriter
SetAutoQuotes(bool autoquotes) | com.sparsity.sparksee.io.CSVWriter
SetForcedQuotes(com.sparsity.sparksee.gdb.BooleanList forcequotes) | com.sparsity.sparksee.io.CSVWriter
SetLocale(System.String localeStr) | com.sparsity.sparksee.io.CSVWriter
SetQuotes(System.String quotes) | com.sparsity.sparksee.io.CSVWriter
SetSeparator(System.String sep) | com.sparsity.sparksee.io.CSVWriter
Write(com.sparsity.sparksee.gdb.StringList row) | com.sparsity.sparksee.io.CSVWriter


SparkseeNet: com.sparsity.sparksee.io.EdgeTypeExporter Class Reference

  • io
  • EdgeTypeExporter
Public Member Functions | List of all members
com.sparsity.sparksee.io.EdgeTypeExporter Class Reference

EdgeTypeExporter class. More...

Inheritance diagram for com.sparsity.sparksee.io.EdgeTypeExporter:
Collaboration diagram for com.sparsity.sparksee.io.EdgeTypeExporter:

Public Member Functions

void | SetTailAttribute (int attr)
Sets the attribute that will be used to get the value to be dumped for the tail of the edge.
void | SetFrequency (int freq)
Sets the frequency of listener notification.
void | SetHeadAttribute (int attr)
Sets the attribute that will be used to get the value to be dumped for the head of the edge.
void | SetType (int type)
Sets the type to be exported.
void | SetTailPosition (int pos)
Sets the position (index column) of the tail attribute in the exported data.
EdgeTypeExporter (com.sparsity.sparksee.io.RowWriter rowWriter, com.sparsity.sparksee.gdb.Graph graph, int type, com.sparsity.sparksee.gdb.AttributeList attrs, int hPos, int tPos, int hAttr, int tAttr)
Creates a new instance.
void | SetRowWriter (com.sparsity.sparksee.io.RowWriter rw)
Sets the output data destination.
void | Register (com.sparsity.sparksee.io.TypeExporterListener tel)
Registers a new listener.
void | Run () throws System.IO.IOException, System.ApplicationException
See the TypeExporter class Run method.
EdgeTypeExporter ()
Creates a new instance.
void | SetGraph (com.sparsity.sparksee.gdb.Graph graph)
Sets the graph that will be exported.
void | SetHeader (bool header)
Sets the presence of a header row.
void | SetHeadPosition (int pos)
Sets the position (index column) of the head attribute in the exported data.
void | SetAttributes (com.sparsity.sparksee.gdb.AttributeList attrs)
Sets the list of Attributes.

Detailed Description

EdgeTypeExporter class.

Specific TypeExporter implementation for edge types.

Check out the 'Data export' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

com.sparsity.sparksee.io.EdgeTypeExporter.EdgeTypeExporter | ( | com.sparsity.sparksee.io.RowWriter | rowWriter,
 |  | com.sparsity.sparksee.gdb.Graph | graph,
 |  | int | type,
 |  | com.sparsity.sparksee.gdb.AttributeList | attrs,
 |  | int | hPos,
 |  | int | tPos,
 |  | int | hAttr,
 |  | int | tAttr
 | ) |  |

Creates a new instance.

Parameters
rowWriter | [in] Output RowWriter.
graph | [in] Graph.
type | [in] Type identifier.
attrs | [in] Attribute identifiers to be exported.
hPos | [in] The position (index column) for the head value.
tPos | [in] The position (index column) for the tail value.
hAttr | [in] The attribute identifier to get the value to be dumped for the head.
tAttr | [in] The attribute identifier to get the value to be dumped for the tail.

Member Function Documentation

void com.sparsity.sparksee.io.EdgeTypeExporter.Register ( com.sparsity.sparksee.io.TypeExporterListener tel )

Registers a new listener.

Parameters
tel [in] TypeExporterListener to be registered.
void com.sparsity.sparksee.io.EdgeTypeExporter.Run ( ) throws System.IO.IOException, System.ApplicationException

See the TypeExporter class Run method.

Exceptions
System.IO.IOException | null
System.ApplicationException | null
void com.sparsity.sparksee.io.EdgeTypeExporter.SetAttributes ( com.sparsity.sparksee.gdb.AttributeList attrs )

Sets the list of Attributes.

Parameters
attrs [in] Attribute identifiers to be exported
void com.sparsity.sparksee.io.EdgeTypeExporter.SetFrequency ( int freq )

Sets the frequency of listener notification.

Parameters
freq [in] Frequency in number of rows managed to notify progress to all listeners
void com.sparsity.sparksee.io.EdgeTypeExporter.SetGraph ( com.sparsity.sparksee.gdb.Graph graph )

Sets the graph that will be exported.

Parameters
graph [in] Graph.
void com.sparsity.sparksee.io.EdgeTypeExporter.SetHeadAttribute ( int attr )

Sets the attribute that will be used to get the value to be dumped for the head of the edge.

Parameters
attr [in] Head Attribute
void com.sparsity.sparksee.io.EdgeTypeExporter.SetHeader ( bool header )

Sets the presence of a header row.

Parameters
header [in] If TRUE, a header row is dumped with the name of the attributes.
void com.sparsity.sparksee.io.EdgeTypeExporter.SetHeadPosition ( int pos )

Sets the position (index column) of the head attribute in the exported data.

Parameters
pos [in] Head position
void com.sparsity.sparksee.io.EdgeTypeExporter.SetRowWriter ( com.sparsity.sparksee.io.RowWriter rw )

Sets the output data destination.

Parameters
rw [in] Input RowWriter.
void com.sparsity.sparksee.io.EdgeTypeExporter.SetTailAttribute ( int attr )

Sets the attribute that will be used to get the value to be dumped for the tail of the edge.

Parameters
attr [in] Tail Attribute
void com.sparsity.sparksee.io.EdgeTypeExporter.SetTailPosition ( int pos )

Sets the position (index column) of the tail attribute in the exported data.

Parameters
pos [in] Tail position
void com.sparsity.sparksee.io.EdgeTypeExporter.SetType ( int type )

Sets the type to be exported.

Parameters
type [in] Type identifier.


SparkseeNet: Member List

  • io
  • EdgeTypeExporter
com.sparsity.sparksee.io.EdgeTypeExporter Member List

This is the complete list of members for com.sparsity.sparksee.io.EdgeTypeExporter, including all inherited members.

EdgeTypeExporter(com.sparsity.sparksee.io.RowWriter rowWriter, com.sparsity.sparksee.gdb.Graph graph, int type, com.sparsity.sparksee.gdb.AttributeList attrs, int hPos, int tPos, int hAttr, int tAttr) | com.sparsity.sparksee.io.EdgeTypeExporter
EdgeTypeExporter() | com.sparsity.sparksee.io.EdgeTypeExporter
Register(com.sparsity.sparksee.io.TypeExporterListener tel) | com.sparsity.sparksee.io.EdgeTypeExporter
Run() | com.sparsity.sparksee.io.EdgeTypeExporter
SetAttributes(com.sparsity.sparksee.gdb.AttributeList attrs) | com.sparsity.sparksee.io.EdgeTypeExporter
SetFrequency(int freq) | com.sparsity.sparksee.io.EdgeTypeExporter
SetGraph(com.sparsity.sparksee.gdb.Graph graph) | com.sparsity.sparksee.io.EdgeTypeExporter
SetHeadAttribute(int attr) | com.sparsity.sparksee.io.EdgeTypeExporter
SetHeader(bool header) | com.sparsity.sparksee.io.EdgeTypeExporter
SetHeadPosition(int pos) | com.sparsity.sparksee.io.EdgeTypeExporter
SetRowWriter(com.sparsity.sparksee.io.RowWriter rw) | com.sparsity.sparksee.io.EdgeTypeExporter
SetTailAttribute(int attr) | com.sparsity.sparksee.io.EdgeTypeExporter
SetTailPosition(int pos) | com.sparsity.sparksee.io.EdgeTypeExporter
SetType(int type) | com.sparsity.sparksee.io.EdgeTypeExporter


SparkseeNet: com.sparsity.sparksee.io.EdgeTypeLoader Class Reference

  • io
  • EdgeTypeLoader
Public Member Functions | List of all members
com.sparsity.sparksee.io.EdgeTypeLoader Class Reference

EdgeTypeLoader class. More...

Inheritance diagram for com.sparsity.sparksee.io.EdgeTypeLoader:
Collaboration diagram for com.sparsity.sparksee.io.EdgeTypeLoader:

Public Member Functions

void | SetTailAttribute (int attr)
Sets the attribute that will be used to find the tail of the edge.
void | SetFrequency (int freq)
Sets the frequency of listener notification.
void | SetLogOff ()
Truns off all the error reporting.
void | SetTailMEP (com.sparsity.sparksee.gdb.MissingEndpoint mep)
Sets the flag to create missing tail nodes when loading nodes or edges.
void | SetHeadMEP (com.sparsity.sparksee.gdb.MissingEndpoint mep)
Sets the flag to create missing head nodes when loading nodes or edges.
void | SetLogError (System.String path) throws System.IO.IOException
Sets a log error file.
void | SetHeadAttribute (int attr)
Sets the attribute that will be used to find the head of the edge.
void | SetType (int type)
Sets the type to be loaded.
void | RunTwoPhases () throws System.IO.IOException, System.ApplicationException
See the TypeLoader class RunTwoPhases method.
void | SetTailPosition (int pos)
Sets the position of the tail attribute in the source data.
void | SetRowReader (com.sparsity.sparksee.io.RowReader rr)
Sets the input data source.
void | SetAttributePositions (com.sparsity.sparksee.gdb.Int32List attrsPos)
Sets the list of attribute positions.
void | Register (com.sparsity.sparksee.io.TypeLoaderListener tel)
Registers a new listener.
void | SetLocale (System.String localeStr)
Sets the locale that will be used to read the data.
void | Run () throws System.IO.IOException, System.ApplicationException
See the TypeLoader class Run method.
void | SetGraph (com.sparsity.sparksee.gdb.Graph graph)
Sets the graph where the data will be loaded.
EdgeTypeLoader (com.sparsity.sparksee.io.RowReader rowReader, com.sparsity.sparksee.gdb.Graph graph, int type, com.sparsity.sparksee.gdb.AttributeList attrs, com.sparsity.sparksee.gdb.Int32List attrsPos, int hPos, int tPos, int hAttr, int tAttr, com.sparsity.sparksee.gdb.MissingEndpoint headMEP, com.sparsity.sparksee.gdb.MissingEndpoint tailMEP)
Creates a new instance.
void | RunNPhases (int partitions) throws System.IO.IOException, System.ApplicationException
See the TypeLoader class RunNPhases method.
EdgeTypeLoader ()
Creates a new instance.
void | SetTimestampFormat (System.String timestampFormat)
Sets a specific timestamp format.
void | SetHeadPosition (int pos)
Sets the position of the head attribute in the source data.
void | SetAttributes (com.sparsity.sparksee.gdb.AttributeList attrs)
Sets the list of Attributes.

Detailed Description

EdgeTypeLoader class.

Specific TypeLoader implementation for edge types.

Check out the 'Data import' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

com.sparsity.sparksee.io.EdgeTypeLoader.EdgeTypeLoader | ( | com.sparsity.sparksee.io.RowReader | rowReader,
 |  | com.sparsity.sparksee.gdb.Graph | graph,
 |  | int | type,
 |  | com.sparsity.sparksee.gdb.AttributeList | attrs,
 |  | com.sparsity.sparksee.gdb.Int32List | attrsPos,
 |  | int | hPos,
 |  | int | tPos,
 |  | int | hAttr,
 |  | int | tAttr,
 |  | com.sparsity.sparksee.gdb.MissingEndpoint | headMEP,
 |  | com.sparsity.sparksee.gdb.MissingEndpoint | tailMEP
 | ) |  |

Creates a new instance.

Parameters
rowReader | [in] Input RowReader.
graph | [in] Graph.
type | [in] Type identifier.
attrs | [in] Attribute identifiers to be loaded.
attrsPos | [in] Attribute positions (column index >=0). to all listeners.
hPos | [in] The position (index column) for the head value.
tPos | [in] The position (index column) for the tail value.
hAttr | [in] The attribute identifier for the head.
tAttr | [in] The attribute identifier for the tail.
headMEP | [in] The MissingEndpoint policy for the head nodes
tailMEP | [in] The MissingEndpoint policy for the tail nodes

Member Function Documentation

void com.sparsity.sparksee.io.EdgeTypeLoader.Register ( com.sparsity.sparksee.io.TypeLoaderListener tel )

Registers a new listener.

Parameters
tel TypeLoaderListener to be registered.
void com.sparsity.sparksee.io.EdgeTypeLoader.Run ( ) throws System.IO.IOException, System.ApplicationException

See the TypeLoader class Run method.

Exceptions
System.IO.IOException | null
System.ApplicationException | null
void com.sparsity.sparksee.io.EdgeTypeLoader.RunNPhases ( int partitions ) throws System.IO.IOException, System.ApplicationException

See the TypeLoader class RunNPhases method.

Parameters
partitions null
Exceptions
System.IO.IOException | null
System.ApplicationException | null
void com.sparsity.sparksee.io.EdgeTypeLoader.RunTwoPhases ( ) throws System.IO.IOException, System.ApplicationException

See the TypeLoader class RunTwoPhases method.

Exceptions
System.IO.IOException | null
System.ApplicationException | null
void com.sparsity.sparksee.io.EdgeTypeLoader.SetAttributePositions ( com.sparsity.sparksee.gdb.Int32List attrsPos )

Sets the list of attribute positions.

Parameters
attrsPos [in] Attribute positions (column index >=0).
void com.sparsity.sparksee.io.EdgeTypeLoader.SetAttributes ( com.sparsity.sparksee.gdb.AttributeList attrs )

Sets the list of Attributes.

Parameters
attrs [in] Attribute identifiers to be loaded
void com.sparsity.sparksee.io.EdgeTypeLoader.SetFrequency ( int freq )

Sets the frequency of listener notification.

Parameters
freq [in] Frequency in number of rows managed to notify progress to all listeners
void com.sparsity.sparksee.io.EdgeTypeLoader.SetGraph ( com.sparsity.sparksee.gdb.Graph graph )

Sets the graph where the data will be loaded.

Parameters
graph [in] Graph.
void com.sparsity.sparksee.io.EdgeTypeLoader.SetHeadAttribute ( int attr )

Sets the attribute that will be used to find the head of the edge.

This method is protected because only the Edge loaders should have it.

Parameters
attr [in] Head Attribute
void com.sparsity.sparksee.io.EdgeTypeLoader.SetHeadMEP ( com.sparsity.sparksee.gdb.MissingEndpoint mep )

Sets the flag to create missing head nodes when loading nodes or edges.

flagTrue if the nodes need to be created. False otherwise

Parameters
mep null
void com.sparsity.sparksee.io.EdgeTypeLoader.SetHeadPosition ( int pos )

Sets the position of the head attribute in the source data.

This method is protected because only the Edge loaders should have it.

Parameters
pos [in] Head position
void com.sparsity.sparksee.io.EdgeTypeLoader.SetLocale ( System.String localeStr )

Sets the locale that will be used to read the data.

It should match the locale used in the rowreader.

Parameters
localeStr [in] The locale string for the read data. See CSVReader.
void com.sparsity.sparksee.io.EdgeTypeLoader.SetLogError ( System.String path ) throws System.IO.IOException

Sets a log error file.

By default errors are thrown as a exception and the load process ends. If a log file is set, errors are logged there and the load process does not stop.

Parameters
path [in] The path to the error log file.
Exceptions
System.IO.IOException If bad things happen opening the file.
void com.sparsity.sparksee.io.EdgeTypeLoader.SetLogOff ( )

Truns off all the error reporting.

The log file will not be created and no exceptions for invalid data will be thrown. If you just want to turn off the logs, but abort at the first error what you should do is not call this method and not set a logError file.

void com.sparsity.sparksee.io.EdgeTypeLoader.SetRowReader ( com.sparsity.sparksee.io.RowReader rr )

Sets the input data source.

Parameters
rr [in] Input RowReader.
void com.sparsity.sparksee.io.EdgeTypeLoader.SetTailAttribute ( int attr )

Sets the attribute that will be used to find the tail of the edge.

This method is protected because only the Edge loaders should have it.

Parameters
attr [in] Tail Attribute
void com.sparsity.sparksee.io.EdgeTypeLoader.SetTailMEP ( com.sparsity.sparksee.gdb.MissingEndpoint mep )

Sets the flag to create missing tail nodes when loading nodes or edges.

flagTrue if the nodes need to be created. False otherwise

Parameters
mep null
void com.sparsity.sparksee.io.EdgeTypeLoader.SetTailPosition ( int pos )

Sets the position of the tail attribute in the source data.

This method is protected because only the Edge loaders should have it.

Parameters
pos [in] Tail position
void com.sparsity.sparksee.io.EdgeTypeLoader.SetTimestampFormat ( System.String timestampFormat )

Sets a specific timestamp format.

Parameters
timestampFormat [in] A string with the timestamp format definition.
void com.sparsity.sparksee.io.EdgeTypeLoader.SetType ( int type )

Sets the type to be loaded.

Parameters
type [in] Type identifier.


SparkseeNet: Member List

  • io
  • EdgeTypeLoader
com.sparsity.sparksee.io.EdgeTypeLoader Member List

This is the complete list of members for com.sparsity.sparksee.io.EdgeTypeLoader, including all inherited members.

EdgeTypeLoader(com.sparsity.sparksee.io.RowReader rowReader, com.sparsity.sparksee.gdb.Graph graph, int type, com.sparsity.sparksee.gdb.AttributeList attrs, com.sparsity.sparksee.gdb.Int32List attrsPos, int hPos, int tPos, int hAttr, int tAttr, com.sparsity.sparksee.gdb.MissingEndpoint headMEP, com.sparsity.sparksee.gdb.MissingEndpoint tailMEP) | com.sparsity.sparksee.io.EdgeTypeLoader
EdgeTypeLoader() | com.sparsity.sparksee.io.EdgeTypeLoader
Register(com.sparsity.sparksee.io.TypeLoaderListener tel) | com.sparsity.sparksee.io.EdgeTypeLoader
Run() | com.sparsity.sparksee.io.EdgeTypeLoader
RunNPhases(int partitions) | com.sparsity.sparksee.io.EdgeTypeLoader
RunTwoPhases() | com.sparsity.sparksee.io.EdgeTypeLoader
SetAttributePositions(com.sparsity.sparksee.gdb.Int32List attrsPos) | com.sparsity.sparksee.io.EdgeTypeLoader
SetAttributes(com.sparsity.sparksee.gdb.AttributeList attrs) | com.sparsity.sparksee.io.EdgeTypeLoader
SetFrequency(int freq) | com.sparsity.sparksee.io.EdgeTypeLoader
SetGraph(com.sparsity.sparksee.gdb.Graph graph) | com.sparsity.sparksee.io.EdgeTypeLoader
SetHeadAttribute(int attr) | com.sparsity.sparksee.io.EdgeTypeLoader
SetHeadMEP(com.sparsity.sparksee.gdb.MissingEndpoint mep) | com.sparsity.sparksee.io.EdgeTypeLoader
SetHeadPosition(int pos) | com.sparsity.sparksee.io.EdgeTypeLoader
SetLocale(System.String localeStr) | com.sparsity.sparksee.io.EdgeTypeLoader
SetLogError(System.String path) | com.sparsity.sparksee.io.EdgeTypeLoader
SetLogOff() | com.sparsity.sparksee.io.EdgeTypeLoader
SetRowReader(com.sparsity.sparksee.io.RowReader rr) | com.sparsity.sparksee.io.EdgeTypeLoader
SetTailAttribute(int attr) | com.sparsity.sparksee.io.EdgeTypeLoader
SetTailMEP(com.sparsity.sparksee.gdb.MissingEndpoint mep) | com.sparsity.sparksee.io.EdgeTypeLoader
SetTailPosition(int pos) | com.sparsity.sparksee.io.EdgeTypeLoader
SetTimestampFormat(System.String timestampFormat) | com.sparsity.sparksee.io.EdgeTypeLoader
SetType(int type) | com.sparsity.sparksee.io.EdgeTypeLoader


SparkseeNet: com.sparsity.sparksee.io.NodeTypeExporter Class Reference

  • io
  • NodeTypeExporter
Public Member Functions | List of all members
com.sparsity.sparksee.io.NodeTypeExporter Class Reference

NodeTypeExporter class. More...

Inheritance diagram for com.sparsity.sparksee.io.NodeTypeExporter:
Collaboration diagram for com.sparsity.sparksee.io.NodeTypeExporter:

Public Member Functions

NodeTypeExporter (com.sparsity.sparksee.io.RowWriter rowWriter, com.sparsity.sparksee.gdb.Graph graph, int type, com.sparsity.sparksee.gdb.AttributeList attrs)
Creates a new instance.
void | SetRowWriter (com.sparsity.sparksee.io.RowWriter rw)
Sets the output data destination.
void | SetFrequency (int freq)
Sets the frequency of listener notification.
void | Register (com.sparsity.sparksee.io.TypeExporterListener tel)
Registers a new listener.
void | Run () throws System.IO.IOException, System.ApplicationException
See the TypeExporter class Run method.
void | SetGraph (com.sparsity.sparksee.gdb.Graph graph)
Sets the graph that will be exported.
void | SetHeader (bool header)
Sets the presence of a header row.
void | SetType (int type)
Sets the type to be exported.
NodeTypeExporter ()
Creates a new instance.
void | SetAttributes (com.sparsity.sparksee.gdb.AttributeList attrs)
Sets the list of Attributes.

Detailed Description

NodeTypeExporter class.

Specific TypeExporter implementation for node types.

Check out the 'Data export' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

com.sparsity.sparksee.io.NodeTypeExporter.NodeTypeExporter | ( | com.sparsity.sparksee.io.RowWriter | rowWriter,
 |  | com.sparsity.sparksee.gdb.Graph | graph,
 |  | int | type,
 |  | com.sparsity.sparksee.gdb.AttributeList | attrs
 | ) |  |

Creates a new instance.

Parameters
rowWriter | [in] Output RowWriter.
graph | [in] Graph.
type | [in] Type identifier.
attrs | [in] Attribute identifiers to be exported.

Member Function Documentation

void com.sparsity.sparksee.io.NodeTypeExporter.Register ( com.sparsity.sparksee.io.TypeExporterListener tel )

Registers a new listener.

Parameters
tel [in] TypeExporterListener to be registered.
void com.sparsity.sparksee.io.NodeTypeExporter.Run ( ) throws System.IO.IOException, System.ApplicationException

See the TypeExporter class Run method.

Exceptions
System.IO.IOException | null
System.ApplicationException | null
void com.sparsity.sparksee.io.NodeTypeExporter.SetAttributes ( com.sparsity.sparksee.gdb.AttributeList attrs )

Sets the list of Attributes.

Parameters
attrs [in] Attribute identifiers to be exported
void com.sparsity.sparksee.io.NodeTypeExporter.SetFrequency ( int freq )

Sets the frequency of listener notification.

Parameters
freq [in] Frequency in number of rows managed to notify progress to all listeners
void com.sparsity.sparksee.io.NodeTypeExporter.SetGraph ( com.sparsity.sparksee.gdb.Graph graph )

Sets the graph that will be exported.

Parameters
graph [in] Graph.
void com.sparsity.sparksee.io.NodeTypeExporter.SetHeader ( bool header )

Sets the presence of a header row.

Parameters
header [in] If TRUE, a header row is dumped with the name of the attributes.
void com.sparsity.sparksee.io.NodeTypeExporter.SetRowWriter ( com.sparsity.sparksee.io.RowWriter rw )

Sets the output data destination.

Parameters
rw [in] Input RowWriter.
void com.sparsity.sparksee.io.NodeTypeExporter.SetType ( int type )

Sets the type to be exported.

Parameters
type [in] Type identifier.


SparkseeNet: Member List

  • io
  • NodeTypeExporter
com.sparsity.sparksee.io.NodeTypeExporter Member List

This is the complete list of members for com.sparsity.sparksee.io.NodeTypeExporter, including all inherited members.

NodeTypeExporter(com.sparsity.sparksee.io.RowWriter rowWriter, com.sparsity.sparksee.gdb.Graph graph, int type, com.sparsity.sparksee.gdb.AttributeList attrs) | com.sparsity.sparksee.io.NodeTypeExporter
NodeTypeExporter() | com.sparsity.sparksee.io.NodeTypeExporter
Register(com.sparsity.sparksee.io.TypeExporterListener tel) | com.sparsity.sparksee.io.NodeTypeExporter
Run() | com.sparsity.sparksee.io.NodeTypeExporter
SetAttributes(com.sparsity.sparksee.gdb.AttributeList attrs) | com.sparsity.sparksee.io.NodeTypeExporter
SetFrequency(int freq) | com.sparsity.sparksee.io.NodeTypeExporter
SetGraph(com.sparsity.sparksee.gdb.Graph graph) | com.sparsity.sparksee.io.NodeTypeExporter
SetHeader(bool header) | com.sparsity.sparksee.io.NodeTypeExporter
SetRowWriter(com.sparsity.sparksee.io.RowWriter rw) | com.sparsity.sparksee.io.NodeTypeExporter
SetType(int type) | com.sparsity.sparksee.io.NodeTypeExporter


SparkseeNet: com.sparsity.sparksee.io.NodeTypeLoader Class Reference

  • io
  • NodeTypeLoader
Public Member Functions | List of all members
com.sparsity.sparksee.io.NodeTypeLoader Class Reference

NodeTypeLoader class. More...

Inheritance diagram for com.sparsity.sparksee.io.NodeTypeLoader:
Collaboration diagram for com.sparsity.sparksee.io.NodeTypeLoader:

Public Member Functions

void | SetFrequency (int freq)
Sets the frequency of listener notification.
void | SetLogOff ()
Truns off all the error reporting.
void | SetLogError (System.String path) throws System.IO.IOException
Sets a log error file.
void | SetType (int type)
Sets the type to be loaded.
NodeTypeLoader (com.sparsity.sparksee.io.RowReader rowReader, com.sparsity.sparksee.gdb.Graph graph, int type, com.sparsity.sparksee.gdb.AttributeList attrs, com.sparsity.sparksee.gdb.Int32List attrsPos)
Creates a new instance.
void | RunTwoPhases () throws System.IO.IOException, System.ApplicationException
See the TypeLoader class RunTwoPhases method.
void | SetRowReader (com.sparsity.sparksee.io.RowReader rr)
Sets the input data source.
NodeTypeLoader ()
Creates a new instance.
void | SetAttributePositions (com.sparsity.sparksee.gdb.Int32List attrsPos)
Sets the list of attribute positions.
void | Register (com.sparsity.sparksee.io.TypeLoaderListener tel)
Registers a new listener.
void | SetLocale (System.String localeStr)
Sets the locale that will be used to read the data.
void | Run () throws System.IO.IOException, System.ApplicationException
See the TypeLoader class Run method.
void | SetGraph (com.sparsity.sparksee.gdb.Graph graph)
Sets the graph where the data will be loaded.
void | RunNPhases (int partitions) throws System.IO.IOException, System.ApplicationException
See the TypeLoader class RunNPhases method.
void | SetTimestampFormat (System.String timestampFormat)
Sets a specific timestamp format.
void | SetAttributes (com.sparsity.sparksee.gdb.AttributeList attrs)
Sets the list of Attributes.

Detailed Description

NodeTypeLoader class.

Specific TypeLoader implementation for node types.

Check out the 'Data import' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Constructor & Destructor Documentation

com.sparsity.sparksee.io.NodeTypeLoader.NodeTypeLoader | ( | com.sparsity.sparksee.io.RowReader | rowReader,
 |  | com.sparsity.sparksee.gdb.Graph | graph,
 |  | int | type,
 |  | com.sparsity.sparksee.gdb.AttributeList | attrs,
 |  | com.sparsity.sparksee.gdb.Int32List | attrsPos
 | ) |  |

Creates a new instance.

Parameters
rowReader | [in] Input RowReader.
graph | [in] Graph.
type | [in] Type identifier.
attrs | [in] Attribute identifiers to be loaded.
attrsPos | [in] Attribute positions (column index >=0).

Member Function Documentation

void com.sparsity.sparksee.io.NodeTypeLoader.Register ( com.sparsity.sparksee.io.TypeLoaderListener tel )

Registers a new listener.

Parameters
tel TypeLoaderListener to be registered.
void com.sparsity.sparksee.io.NodeTypeLoader.Run ( ) throws System.IO.IOException, System.ApplicationException

See the TypeLoader class Run method.

Exceptions
System.IO.IOException | null
System.ApplicationException | null
void com.sparsity.sparksee.io.NodeTypeLoader.RunNPhases ( int partitions ) throws System.IO.IOException, System.ApplicationException

See the TypeLoader class RunNPhases method.

Parameters
partitions null
Exceptions
System.IO.IOException | null
System.ApplicationException | null
void com.sparsity.sparksee.io.NodeTypeLoader.RunTwoPhases ( ) throws System.IO.IOException, System.ApplicationException

See the TypeLoader class RunTwoPhases method.

Exceptions
System.IO.IOException | null
System.ApplicationException | null
void com.sparsity.sparksee.io.NodeTypeLoader.SetAttributePositions ( com.sparsity.sparksee.gdb.Int32List attrsPos )

Sets the list of attribute positions.

Parameters
attrsPos [in] Attribute positions (column index >=0).
void com.sparsity.sparksee.io.NodeTypeLoader.SetAttributes ( com.sparsity.sparksee.gdb.AttributeList attrs )

Sets the list of Attributes.

Parameters
attrs [in] Attribute identifiers to be loaded
void com.sparsity.sparksee.io.NodeTypeLoader.SetFrequency ( int freq )

Sets the frequency of listener notification.

Parameters
freq [in] Frequency in number of rows managed to notify progress to all listeners
void com.sparsity.sparksee.io.NodeTypeLoader.SetGraph ( com.sparsity.sparksee.gdb.Graph graph )

Sets the graph where the data will be loaded.

Parameters
graph [in] Graph.
void com.sparsity.sparksee.io.NodeTypeLoader.SetLocale ( System.String localeStr )

Sets the locale that will be used to read the data.

It should match the locale used in the rowreader.

Parameters
localeStr [in] The locale string for the read data. See CSVReader.
void com.sparsity.sparksee.io.NodeTypeLoader.SetLogError ( System.String path ) throws System.IO.IOException

Sets a log error file.

By default errors are thrown as a exception and the load process ends. If a log file is set, errors are logged there and the load process does not stop.

Parameters
path [in] The path to the error log file.
Exceptions
System.IO.IOException If bad things happen opening the file.
void com.sparsity.sparksee.io.NodeTypeLoader.SetLogOff ( )

Truns off all the error reporting.

The log file will not be created and no exceptions for invalid data will be thrown. If you just want to turn off the logs, but abort at the first error what you should do is not call this method and not set a logError file.

void com.sparsity.sparksee.io.NodeTypeLoader.SetRowReader ( com.sparsity.sparksee.io.RowReader rr )

Sets the input data source.

Parameters
rr [in] Input RowReader.
void com.sparsity.sparksee.io.NodeTypeLoader.SetTimestampFormat ( System.String timestampFormat )

Sets a specific timestamp format.

Parameters
timestampFormat [in] A string with the timestamp format definition.
void com.sparsity.sparksee.io.NodeTypeLoader.SetType ( int type )

Sets the type to be loaded.

Parameters
type [in] Type identifier.


SparkseeNet: Member List

  • io
  • NodeTypeLoader
com.sparsity.sparksee.io.NodeTypeLoader Member List

This is the complete list of members for com.sparsity.sparksee.io.NodeTypeLoader, including all inherited members.

NodeTypeLoader(com.sparsity.sparksee.io.RowReader rowReader, com.sparsity.sparksee.gdb.Graph graph, int type, com.sparsity.sparksee.gdb.AttributeList attrs, com.sparsity.sparksee.gdb.Int32List attrsPos) | com.sparsity.sparksee.io.NodeTypeLoader
NodeTypeLoader() | com.sparsity.sparksee.io.NodeTypeLoader
Register(com.sparsity.sparksee.io.TypeLoaderListener tel) | com.sparsity.sparksee.io.NodeTypeLoader
Run() | com.sparsity.sparksee.io.NodeTypeLoader
RunNPhases(int partitions) | com.sparsity.sparksee.io.NodeTypeLoader
RunTwoPhases() | com.sparsity.sparksee.io.NodeTypeLoader
SetAttributePositions(com.sparsity.sparksee.gdb.Int32List attrsPos) | com.sparsity.sparksee.io.NodeTypeLoader
SetAttributes(com.sparsity.sparksee.gdb.AttributeList attrs) | com.sparsity.sparksee.io.NodeTypeLoader
SetFrequency(int freq) | com.sparsity.sparksee.io.NodeTypeLoader
SetGraph(com.sparsity.sparksee.gdb.Graph graph) | com.sparsity.sparksee.io.NodeTypeLoader
SetLocale(System.String localeStr) | com.sparsity.sparksee.io.NodeTypeLoader
SetLogError(System.String path) | com.sparsity.sparksee.io.NodeTypeLoader
SetLogOff() | com.sparsity.sparksee.io.NodeTypeLoader
SetRowReader(com.sparsity.sparksee.io.RowReader rr) | com.sparsity.sparksee.io.NodeTypeLoader
SetTimestampFormat(System.String timestampFormat) | com.sparsity.sparksee.io.NodeTypeLoader
SetType(int type) | com.sparsity.sparksee.io.NodeTypeLoader


SparkseeNet: com.sparsity.sparksee.io.RowReader Class Reference

  • io
  • RowReader
Public Member Functions | List of all members
com.sparsity.sparksee.io.RowReader Class Reference

RowReader interface. More...

Inheritance diagram for com.sparsity.sparksee.io.RowReader:

Public Member Functions

void | Close () throws System.IO.IOException
Closes the reader.
int | GetRow () throws System.IO.IOException
The row number for the current row.
bool | Reset () throws System.IO.IOException
Moves the reader to the beginning.
bool | Read (com.sparsity.sparksee.gdb.StringList row) throws System.IO.IOException
Reads the next row as a string array.

Detailed Description

RowReader interface.

Common interface for those readers which get the data as an string array.

It works as follows: perform as many read operations as necessary and call close once at the end. Once close is called no more read operations can be executed.

Check out the 'Data import' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

void com.sparsity.sparksee.io.RowReader.Close ( ) throws System.IO.IOException

Closes the reader.

Exceptions
System.IO.IOException If the close fails.
int com.sparsity.sparksee.io.RowReader.GetRow ( ) throws System.IO.IOException

The row number for the current row.

Returns
The current row number; 0 if there is no current row.
Exceptions
System.IO.IOException If it fails.
bool com.sparsity.sparksee.io.RowReader.Read ( com.sparsity.sparksee.gdb.StringList row ) throws System.IO.IOException

Reads the next row as a string array.

Parameters
row [out] A string list with each comma-separated element as a separate entry.
Returns
Returns true if a row had been read or false otherwise.
Exceptions
System.IO.IOException If bad things happen during the read.
bool com.sparsity.sparksee.io.RowReader.Reset ( ) throws System.IO.IOException

Moves the reader to the beginning.

Restarts the reader.

Returns
true if the reader can be restarted, false otherwise.
Exceptions
System.IO.IOException If bad things happen during the restart.


SparkseeNet: Member List

  • io
  • RowReader
com.sparsity.sparksee.io.RowReader Member List

This is the complete list of members for com.sparsity.sparksee.io.RowReader, including all inherited members.

Close() | com.sparsity.sparksee.io.RowReader
GetRow() | com.sparsity.sparksee.io.RowReader
Read(com.sparsity.sparksee.gdb.StringList row) | com.sparsity.sparksee.io.RowReader
Reset() | com.sparsity.sparksee.io.RowReader


SparkseeNet: com.sparsity.sparksee.io.RowWriter Class Reference

  • io
  • RowWriter
Public Member Functions | List of all members
com.sparsity.sparksee.io.RowWriter Class Reference

RowWriter interface. More...

Inheritance diagram for com.sparsity.sparksee.io.RowWriter:

Public Member Functions

void | Write (com.sparsity.sparksee.gdb.StringList row) throws System.IO.IOException, System.ApplicationException
Writes the next row.
void | Close () throws System.IO.IOException, System.ApplicationException
Closes the writer.

Detailed Description

RowWriter interface.

Common interface for those writers which dump the data from an string array.

It works as follows: perform as many write operations as necessary and call close once at the end. Once close is called no more write operations can be executed.

Check out the 'Data export' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

void com.sparsity.sparksee.io.RowWriter.Close ( ) throws System.IO.IOException, System.ApplicationException

Closes the writer.

Exceptions
System.IO.IOException | If the close fails.
System.ApplicationException | null
void com.sparsity.sparksee.io.RowWriter.Write ( com.sparsity.sparksee.gdb.StringList row ) throws System.IO.IOException, System.ApplicationException

Writes the next row.

Parameters
row [in] Row of data.
Exceptions
System.IO.IOException | If bad things happen during the write.
System.ApplicationException | null


SparkseeNet: Member List

  • io
  • RowWriter
com.sparsity.sparksee.io.RowWriter Member List

This is the complete list of members for com.sparsity.sparksee.io.RowWriter, including all inherited members.

Close() | com.sparsity.sparksee.io.RowWriter
Write(com.sparsity.sparksee.gdb.StringList row) | com.sparsity.sparksee.io.RowWriter


SparkseeNet: com.sparsity.sparksee.io.TypeExporter Class Reference

  • io
  • TypeExporter
Public Member Functions | List of all members
com.sparsity.sparksee.io.TypeExporter Class Reference

Base TypeExporter class. More...

Inheritance diagram for com.sparsity.sparksee.io.TypeExporter:

Public Member Functions

void | SetRowWriter (com.sparsity.sparksee.io.RowWriter rw)
Sets the output data destination.
void | SetFrequency (int freq)
Sets the frequency of listener notification.
void | Run () throws System.IO.IOException, System.ApplicationException
Runs export process.
void | Register (com.sparsity.sparksee.io.TypeExporterListener tel)
Registers a new listener.
void | SetGraph (com.sparsity.sparksee.gdb.Graph graph)
Sets the graph that will be exported.
void | SetHeader (bool header)
Sets the presence of a header row.
void | SetType (int type)
Sets the type to be exported.
void | SetAttributes (com.sparsity.sparksee.gdb.AttributeList attrs)
Sets the list of Attributes.

Detailed Description

Base TypeExporter class.

Base class to export a node or edge type from a graph using a RowWriter.

TypeExporterListener can be registered to receive information about the progress of the export process by means of TypeExporterEvent. The default frequency of notification to listeners is 100000.

By default no header row is created.

Check out the 'Data export' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

void com.sparsity.sparksee.io.TypeExporter.Register ( com.sparsity.sparksee.io.TypeExporterListener tel )

Registers a new listener.

Parameters
tel [in] TypeExporterListener to be registered.
void com.sparsity.sparksee.io.TypeExporter.Run ( ) throws System.IO.IOException, System.ApplicationException

Runs export process.

Exceptions
System.IO.IOException | If bad things happen writing to the RowWriter.
System.ApplicationException | null
void com.sparsity.sparksee.io.TypeExporter.SetAttributes ( com.sparsity.sparksee.gdb.AttributeList attrs )

Sets the list of Attributes.

Parameters
attrs [in] Attribute identifiers to be exported
void com.sparsity.sparksee.io.TypeExporter.SetFrequency ( int freq )

Sets the frequency of listener notification.

Parameters
freq [in] Frequency in number of rows managed to notify progress to all listeners
void com.sparsity.sparksee.io.TypeExporter.SetGraph ( com.sparsity.sparksee.gdb.Graph graph )

Sets the graph that will be exported.

Parameters
graph [in] Graph.
void com.sparsity.sparksee.io.TypeExporter.SetHeader ( bool header )

Sets the presence of a header row.

Parameters
header [in] If TRUE, a header row is dumped with the name of the attributes.
void com.sparsity.sparksee.io.TypeExporter.SetRowWriter ( com.sparsity.sparksee.io.RowWriter rw )

Sets the output data destination.

Parameters
rw [in] Input RowWriter.
void com.sparsity.sparksee.io.TypeExporter.SetType ( int type )

Sets the type to be exported.

Parameters
type [in] Type identifier.


SparkseeNet: Member List

  • io
  • TypeExporter
com.sparsity.sparksee.io.TypeExporter Member List

This is the complete list of members for com.sparsity.sparksee.io.TypeExporter, including all inherited members.

Register(com.sparsity.sparksee.io.TypeExporterListener tel) | com.sparsity.sparksee.io.TypeExporter
Run() | com.sparsity.sparksee.io.TypeExporter
SetAttributes(com.sparsity.sparksee.gdb.AttributeList attrs) | com.sparsity.sparksee.io.TypeExporter
SetFrequency(int freq) | com.sparsity.sparksee.io.TypeExporter
SetGraph(com.sparsity.sparksee.gdb.Graph graph) | com.sparsity.sparksee.io.TypeExporter
SetHeader(bool header) | com.sparsity.sparksee.io.TypeExporter
SetRowWriter(com.sparsity.sparksee.io.RowWriter rw) | com.sparsity.sparksee.io.TypeExporter
SetType(int type) | com.sparsity.sparksee.io.TypeExporter


SparkseeNet: com.sparsity.sparksee.io.TypeExporterEvent Class Reference

  • io
  • TypeExporterEvent
Public Member Functions | List of all members
com.sparsity.sparksee.io.TypeExporterEvent Class Reference

Provides information about the progress of an TypeExproter instance. More...

Public Member Functions

long | GetCount ()
Gets the current number of objects exported.
bool | IsLast ()
Gets if this is the last event or not.
int | GetTypeId ()
Gets the type identifier.
long | GetTotal ()
Gets the total number of objects exported.

Detailed Description

Provides information about the progress of an TypeExproter instance.

Check out the 'Data export' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

long com.sparsity.sparksee.io.TypeExporterEvent.GetCount ( )

Gets the current number of objects exported.

Returns
The current number of objects exported.
long com.sparsity.sparksee.io.TypeExporterEvent.GetTotal ( )

Gets the total number of objects exported.

Returns
The total number of objects exported.
int com.sparsity.sparksee.io.TypeExporterEvent.GetTypeId ( )

Gets the type identifier.

Returns
The type identifier.
bool com.sparsity.sparksee.io.TypeExporterEvent.IsLast ( )

Gets if this is the last event or not.

Returns
TRUE if this is the last event, FALSE otherwise.


SparkseeNet: Member List

  • io
  • TypeExporterEvent
com.sparsity.sparksee.io.TypeExporterEvent Member List

This is the complete list of members for com.sparsity.sparksee.io.TypeExporterEvent, including all inherited members.

GetCount() | com.sparsity.sparksee.io.TypeExporterEvent
GetTotal() | com.sparsity.sparksee.io.TypeExporterEvent
GetTypeId() | com.sparsity.sparksee.io.TypeExporterEvent
IsLast() | com.sparsity.sparksee.io.TypeExporterEvent


SparkseeNet: com.sparsity.sparksee.io.TypeExporterListener Class Reference

  • io
  • TypeExporterListener
Public Member Functions | List of all members
com.sparsity.sparksee.io.TypeExporterListener Class Reference

Interface to be implemented to receive TypeExporterEvent events from a TypeExporter. More...

Public Member Functions

void NotifyEvent (com.sparsity.sparksee.io.TypeExporterEvent tee)
Method to be notified from a TypeExporter.

Detailed Description

Interface to be implemented to receive TypeExporterEvent events from a TypeExporter.

Check out the 'Data export' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

void com.sparsity.sparksee.io.TypeExporterListener.NotifyEvent ( com.sparsity.sparksee.io.TypeExporterEvent tee )

Method to be notified from a TypeExporter.

Parameters
tee [in] Notified event.


SparkseeNet: Member List

  • io
  • TypeExporterListener
com.sparsity.sparksee.io.TypeExporterListener Member List

This is the complete list of members for com.sparsity.sparksee.io.TypeExporterListener, including all inherited members.

NotifyEvent(com.sparsity.sparksee.io.TypeExporterEvent tee) com.sparsity.sparksee.io.TypeExporterListener


SparkseeNet: com.sparsity.sparksee.io.TypeLoader Class Reference

  • io
  • TypeLoader
Public Member Functions | List of all members
com.sparsity.sparksee.io.TypeLoader Class Reference

Base TypeLoader class. More...

Inheritance diagram for com.sparsity.sparksee.io.TypeLoader:

Public Member Functions

void | RunTwoPhases () throws System.IO.IOException, System.ApplicationException
Run the loader for two phases loading.
void | RunNPhases (int partitions) throws System.IO.IOException, System.ApplicationException
Run the loader for N phases loading.
void | SetFrequency (int freq)
Sets the frequency of listener notification.
void | SetLogOff ()
Truns off all the error reporting.
void | Run () throws System.IO.IOException, System.ApplicationException
Run the loader.
void | SetLogError (System.String path) throws System.IO.IOException
Sets a log error file.
void | SetType (int type)
Sets the type to be loaded.
void | SetRowReader (com.sparsity.sparksee.io.RowReader rr)
Sets the input data source.
void | SetAttributePositions (com.sparsity.sparksee.gdb.Int32List attrsPos)
Sets the list of attribute positions.
void | Register (com.sparsity.sparksee.io.TypeLoaderListener tel)
Registers a new listener.
void | SetLocale (System.String localeStr)
Sets the locale that will be used to read the data.
void | SetGraph (com.sparsity.sparksee.gdb.Graph graph)
Sets the graph where the data will be loaded.
void | SetTimestampFormat (System.String timestampFormat)
Sets a specific timestamp format.
void | SetAttributes (com.sparsity.sparksee.gdb.AttributeList attrs)
Sets the list of Attributes.

Detailed Description

Base TypeLoader class.

Base class to load a node or edge type from a graph using a RowReader.

TypeLoaderListener can be registered to receive information about the progress of the load process by means of TypeLoaderEvent. The default frequency of notification to listeners is 100000.

Check out the 'Data import' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

void com.sparsity.sparksee.io.TypeLoader.Register ( com.sparsity.sparksee.io.TypeLoaderListener tel )

Registers a new listener.

Parameters
tel TypeLoaderListener to be registered.
void com.sparsity.sparksee.io.TypeLoader.Run ( ) throws System.IO.IOException, System.ApplicationException

Run the loader.

Exceptions
System.IO.IOException | null
System.ApplicationException | null
void com.sparsity.sparksee.io.TypeLoader.RunNPhases ( int partitions ) throws System.IO.IOException, System.ApplicationException

Run the loader for N phases loading.

Firstly load all objects (and create them if necessary) and secondly loads all the attributes. But in this case, attributes are loaded one by one. This way, if there are three attributes, then 4 traverses are necessary.

Working on this mode it is necessary to build a temporary file.

Parameters
partitions [in] Number of horizontal partitions to perform the load.
Exceptions
System.IO.IOException | null
System.ApplicationException | null
void com.sparsity.sparksee.io.TypeLoader.RunTwoPhases ( ) throws System.IO.IOException, System.ApplicationException

Run the loader for two phases loading.

Firstly load all objects (and create them if necessary) and secondly loads all the attributes.

Working on this mode it is necessary to build a temporary file.

Exceptions
System.IO.IOException | null
System.ApplicationException | null
void com.sparsity.sparksee.io.TypeLoader.SetAttributePositions ( com.sparsity.sparksee.gdb.Int32List attrsPos )

Sets the list of attribute positions.

Parameters
attrsPos [in] Attribute positions (column index >=0).
void com.sparsity.sparksee.io.TypeLoader.SetAttributes ( com.sparsity.sparksee.gdb.AttributeList attrs )

Sets the list of Attributes.

Parameters
attrs [in] Attribute identifiers to be loaded
void com.sparsity.sparksee.io.TypeLoader.SetFrequency ( int freq )

Sets the frequency of listener notification.

Parameters
freq [in] Frequency in number of rows managed to notify progress to all listeners
void com.sparsity.sparksee.io.TypeLoader.SetGraph ( com.sparsity.sparksee.gdb.Graph graph )

Sets the graph where the data will be loaded.

Parameters
graph [in] Graph.
void com.sparsity.sparksee.io.TypeLoader.SetLocale ( System.String localeStr )

Sets the locale that will be used to read the data.

It should match the locale used in the rowreader.

Parameters
localeStr [in] The locale string for the read data. See CSVReader.
void com.sparsity.sparksee.io.TypeLoader.SetLogError ( System.String path ) throws System.IO.IOException

Sets a log error file.

By default errors are thrown as a exception and the load process ends. If a log file is set, errors are logged there and the load process does not stop.

Parameters
path [in] The path to the error log file.
Exceptions
System.IO.IOException If bad things happen opening the file.
void com.sparsity.sparksee.io.TypeLoader.SetLogOff ( )

Truns off all the error reporting.

The log file will not be created and no exceptions for invalid data will be thrown. If you just want to turn off the logs, but abort at the first error what you should do is not call this method and not set a logError file.

void com.sparsity.sparksee.io.TypeLoader.SetRowReader ( com.sparsity.sparksee.io.RowReader rr )

Sets the input data source.

Parameters
rr [in] Input RowReader.
void com.sparsity.sparksee.io.TypeLoader.SetTimestampFormat ( System.String timestampFormat )

Sets a specific timestamp format.

Parameters
timestampFormat [in] A string with the timestamp format definition.
void com.sparsity.sparksee.io.TypeLoader.SetType ( int type )

Sets the type to be loaded.

Parameters
type [in] Type identifier.


SparkseeNet: Member List

  • io
  • TypeLoader
com.sparsity.sparksee.io.TypeLoader Member List

This is the complete list of members for com.sparsity.sparksee.io.TypeLoader, including all inherited members.

Register(com.sparsity.sparksee.io.TypeLoaderListener tel) | com.sparsity.sparksee.io.TypeLoader
Run() | com.sparsity.sparksee.io.TypeLoader
RunNPhases(int partitions) | com.sparsity.sparksee.io.TypeLoader
RunTwoPhases() | com.sparsity.sparksee.io.TypeLoader
SetAttributePositions(com.sparsity.sparksee.gdb.Int32List attrsPos) | com.sparsity.sparksee.io.TypeLoader
SetAttributes(com.sparsity.sparksee.gdb.AttributeList attrs) | com.sparsity.sparksee.io.TypeLoader
SetFrequency(int freq) | com.sparsity.sparksee.io.TypeLoader
SetGraph(com.sparsity.sparksee.gdb.Graph graph) | com.sparsity.sparksee.io.TypeLoader
SetLocale(System.String localeStr) | com.sparsity.sparksee.io.TypeLoader
SetLogError(System.String path) | com.sparsity.sparksee.io.TypeLoader
SetLogOff() | com.sparsity.sparksee.io.TypeLoader
SetRowReader(com.sparsity.sparksee.io.RowReader rr) | com.sparsity.sparksee.io.TypeLoader
SetTimestampFormat(System.String timestampFormat) | com.sparsity.sparksee.io.TypeLoader
SetType(int type) | com.sparsity.sparksee.io.TypeLoader


SparkseeNet: com.sparsity.sparksee.io.TypeLoaderEvent Class Reference

  • io
  • TypeLoaderEvent
Public Member Functions | List of all members
com.sparsity.sparksee.io.TypeLoaderEvent Class Reference

Provides information about the progress of a TypeLoader instance. More...

Public Member Functions

int | GetTotalPhases ()
Gets the total number of phases.
long | GetCount ()
Gets the current number of objects created.
int | GetTotalPartitionSteps ()
Gets the total number of steps in the current partition.
bool | IsLast ()
Gets if this is the last event or not.
int | GetPartition ()
Gets the current partition.
int | GetTypeId ()
Gets the type identifier.
int | GetTotalPartitions ()
Gets the total number of partitions.
int | GetPhase ()
Gets the current phase.

Detailed Description

Provides information about the progress of a TypeLoader instance.

Check out the 'Data import' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

long com.sparsity.sparksee.io.TypeLoaderEvent.GetCount ( )

Gets the current number of objects created.

Returns
The current number of objects created.
int com.sparsity.sparksee.io.TypeLoaderEvent.GetPartition ( )

Gets the current partition.

Returns
The current partition.
int com.sparsity.sparksee.io.TypeLoaderEvent.GetPhase ( )

Gets the current phase.

Returns
The current phase.
int com.sparsity.sparksee.io.TypeLoaderEvent.GetTotalPartitions ( )

Gets the total number of partitions.

Returns
The total number of partitions.
int com.sparsity.sparksee.io.TypeLoaderEvent.GetTotalPartitionSteps ( )

Gets the total number of steps in the current partition.

Returns
The total number steps in the current partition.
int com.sparsity.sparksee.io.TypeLoaderEvent.GetTotalPhases ( )

Gets the total number of phases.

Returns
The total number of phases.
int com.sparsity.sparksee.io.TypeLoaderEvent.GetTypeId ( )

Gets the type identifier.

Returns
The type identifier.
bool com.sparsity.sparksee.io.TypeLoaderEvent.IsLast ( )

Gets if this is the last event or not.

Returns
TRUE if this is the last event, FALSE otherwise.


SparkseeNet: Member List

  • io
  • TypeLoaderEvent
com.sparsity.sparksee.io.TypeLoaderEvent Member List

This is the complete list of members for com.sparsity.sparksee.io.TypeLoaderEvent, including all inherited members.

GetCount() | com.sparsity.sparksee.io.TypeLoaderEvent
GetPartition() | com.sparsity.sparksee.io.TypeLoaderEvent
GetPhase() | com.sparsity.sparksee.io.TypeLoaderEvent
GetTotalPartitions() | com.sparsity.sparksee.io.TypeLoaderEvent
GetTotalPartitionSteps() | com.sparsity.sparksee.io.TypeLoaderEvent
GetTotalPhases() | com.sparsity.sparksee.io.TypeLoaderEvent
GetTypeId() | com.sparsity.sparksee.io.TypeLoaderEvent
IsLast() | com.sparsity.sparksee.io.TypeLoaderEvent


SparkseeNet: com.sparsity.sparksee.io.TypeLoaderListener Class Reference

  • io
  • TypeLoaderListener
Public Member Functions | List of all members
com.sparsity.sparksee.io.TypeLoaderListener Class Reference

Interface to be implemented to receive TypeLoaderEvent events from a TypeLoader. More...

Public Member Functions

void NotifyEvent (com.sparsity.sparksee.io.TypeLoaderEvent ev)
Method to receive events from a Loader.

Detailed Description

Interface to be implemented to receive TypeLoaderEvent events from a TypeLoader.

Check out the 'Data import' section in the SPARKSEE User Manual for more details on this.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

void com.sparsity.sparksee.io.TypeLoaderListener.NotifyEvent ( com.sparsity.sparksee.io.TypeLoaderEvent ev )

Method to receive events from a Loader.

Parameters
ev Loader.LoaderEvent with information from a running Loader.


SparkseeNet: Member List

  • io
  • TypeLoaderListener
com.sparsity.sparksee.io.TypeLoaderListener Member List

This is the complete list of members for com.sparsity.sparksee.io.TypeLoaderListener, including all inherited members.

NotifyEvent(com.sparsity.sparksee.io.TypeLoaderEvent ev) com.sparsity.sparksee.io.TypeLoaderListener


SparkseeNet: com.sparsity.sparksee.script.ScriptParser Class Reference

  • script
  • ScriptParser
Public Member Functions | Static Public Member Functions | List of all members
com.sparsity.sparksee.script.ScriptParser Class Reference

ScriptParser. More...

Public Member Functions

bool | Parse (System.String path, bool execute, System.String localeStr) throws System.IO.IOException
Parses the given input file.
void | SetErrorLog (System.String path) throws System.IO.IOException
Sets the error log.
ScriptParser ()
Constructor.
void | SetOutputLog (System.String path) throws System.IO.IOException
Sets the output log.

Static Public Member Functions

static void | Main ()
Executes ScriptParser for the given file path.
static void | GenerateSchemaScript (System.String path, com.sparsity.sparksee.gdb.Database db) throws System.IO.IOException
Writes an script with the schema definition for the given database.

Detailed Description

ScriptParser.

The ScriptParser can create schemas and load data from a set of commands in a sparksee script.

A SPARKSEE script contains an ordered list of commands. ScriptParser will execute each one of them in order. Commands may create schemas, define nodes and edges, and load data into a previous defined SPARKSEE schema.

Check out the 'Scripting' chapter in the SPARKSEE User Manual for a comprehensive explanation on the grammar of the SPARKSEE commands and how they work.

Author
Sparsity Technologies http://www.sparsity-technologies.com

Member Function Documentation

static void com.sparsity.sparksee.script.ScriptParser.GenerateSchemaScript | ( | System.String | path,
 |  | com.sparsity.sparksee.gdb.Database | db
 | ) |  | throws System.IO.IOException
 static

Writes an script with the schema definition for the given database.

Parameters
path | [in] Filename of the script to be writen.
db | [in] Database.
Exceptions
System.IO.IOException If bad things happen opening or writing the file.
static void com.sparsity.sparksee.script.ScriptParser.Main ( )
static

Executes ScriptParser for the given file path.

One argument is required, a file path which contains the script to be parsed.

A second argument may be given, a boolean to set if the script must be executed or just parsed.If not given, the script will be executed.

bool com.sparsity.sparksee.script.ScriptParser.Parse | ( | System.String | path,
 |  | bool | execute,
 |  | System.String | localeStr
 | ) |  | throws System.IO.IOException

Parses the given input file.

Parameters
path | [in] Input file path.
execute | [in] If TRUE the script is executed, if FALSE it is just parsed.
localeStr | [in] The locale string for reading the input file. See CSVReader.
Returns
TRUE if ok, FALSE in case of error.
Exceptions
System.IO.IOException If bad things happen opening the file.
void com.sparsity.sparksee.script.ScriptParser.SetErrorLog ( System.String path ) throws System.IO.IOException

Sets the error log.

If not set, error log corresponds to standard error output.

Parameters
path [in] Path of the error log.
Exceptions
System.IO.IOException If bad things happen opening the file.
void com.sparsity.sparksee.script.ScriptParser.SetOutputLog ( System.String path ) throws System.IO.IOException

Sets the output log.

If not set, output log corresponds to standard output.

Parameters
path [in] Path of the output log.
Exceptions
System.IO.IOException If bad things happen opening the file.


SparkseeNet: Member List

  • script
  • ScriptParser
com.sparsity.sparksee.script.ScriptParser Member List

This is the complete list of members for com.sparsity.sparksee.script.ScriptParser, including all inherited members.

GenerateSchemaScript(System.String path, com.sparsity.sparksee.gdb.Database db) | com.sparsity.sparksee.script.ScriptParser | static
Main() | com.sparsity.sparksee.script.ScriptParser | static
Parse(System.String path, bool execute, System.String localeStr) | com.sparsity.sparksee.script.ScriptParser |
ScriptParser() | com.sparsity.sparksee.script.ScriptParser |
SetErrorLog(System.String path) | com.sparsity.sparksee.script.ScriptParser |
SetOutputLog(System.String path) | com.sparsity.sparksee.script.ScriptParser |


SparkseeNet: Class Index

Class Index
A | B | C | D | E | G | I | K | N | O | P | Q | R | S | T | V | W
A
DefaultExport (com.sparsity.sparksee.gdb) NodeTypeExporter (com.sparsity.sparksee.io) RowReader (com.sparsity.sparksee.io) Type (com.sparsity.sparksee.gdb)
DisjointCommunities (com.sparsity.sparksee.algorithms) NodeTypeLoader (com.sparsity.sparksee.io) RowWriter (com.sparsity.sparksee.io) TypeExporter (com.sparsity.sparksee.io)
Attribute (com.sparsity.sparksee.gdb) DisjointCommunityDetection (com.sparsity.sparksee.algorithms)
O
S
TypeExporterEvent (com.sparsity.sparksee.io)
AttributeList (com.sparsity.sparksee.gdb)
E
TypeExporterListener (com.sparsity.sparksee.io)
AttributeListIterator (com.sparsity.sparksee.gdb) Objects (com.sparsity.sparksee.gdb) ScriptParser (com.sparsity.sparksee.script) TypeList (com.sparsity.sparksee.gdb)
AttributeStatistics (com.sparsity.sparksee.gdb) EdgeData (com.sparsity.sparksee.gdb) ObjectsIterator (com.sparsity.sparksee.gdb) Session (com.sparsity.sparksee.gdb) TypeListIterator (com.sparsity.sparksee.gdb)
B
EdgeExport (com.sparsity.sparksee.gdb) OIDList (com.sparsity.sparksee.gdb) ShortestPath (com.sparsity.sparksee.algorithms) TypeLoader (com.sparsity.sparksee.io)
EdgeTypeExporter (com.sparsity.sparksee.io) OIDListIterator (com.sparsity.sparksee.gdb) SinglePairShortestPath (com.sparsity.sparksee.algorithms) TypeLoaderEvent (com.sparsity.sparksee.io)
BooleanList (com.sparsity.sparksee.gdb) EdgeTypeLoader (com.sparsity.sparksee.io)
P
SinglePairShortestPathBFS (com.sparsity.sparksee.algorithms) TypeLoaderListener (com.sparsity.sparksee.io)
BooleanListIterator (com.sparsity.sparksee.gdb) ExportManager (com.sparsity.sparksee.gdb) SinglePairShortestPathDijkstra (com.sparsity.sparksee.algorithms)
V
C
G
PageRank (com.sparsity.sparksee.algorithms) SinglePairShortestPathDijkstraDynamicCost (com.sparsity.sparksee.algorithms)
Platform (com.sparsity.sparksee.gdb) Sparksee (com.sparsity.sparksee.gdb) Value (com.sparsity.sparksee.gdb)
CommunitiesSCD (com.sparsity.sparksee.algorithms) Graph (com.sparsity.sparksee.gdb) PlatformStatistics (com.sparsity.sparksee.gdb) SparkseeConfig (com.sparsity.sparksee.gdb) ValueArray (com.sparsity.sparksee.gdb)
CommunityDetection (com.sparsity.sparksee.algorithms) GraphExport (com.sparsity.sparksee.gdb)
Q
SparkseeProperties (com.sparsity.sparksee.gdb) ValueList (com.sparsity.sparksee.gdb)
ConnectedComponents (com.sparsity.sparksee.algorithms)
I
StringList (com.sparsity.sparksee.gdb) ValueListIterator (com.sparsity.sparksee.gdb)
Connectivity (com.sparsity.sparksee.algorithms) Query (com.sparsity.sparksee.gdb) StringListIterator (com.sparsity.sparksee.gdb) Values (com.sparsity.sparksee.gdb)
Context (com.sparsity.sparksee.algorithms) Int32List (com.sparsity.sparksee.gdb) QueryContext (com.sparsity.sparksee.gdb) StrongConnectivity (com.sparsity.sparksee.algorithms) ValuesIterator (com.sparsity.sparksee.gdb)
CSVLoader (com.sparsity.sparksee.io) Int32ListIterator (com.sparsity.sparksee.gdb) QueryStream (com.sparsity.sparksee.gdb) StrongConnectivityGabow (com.sparsity.sparksee.algorithms)
W
CSVReader (com.sparsity.sparksee.io)
K
R
T
CSVWriter (com.sparsity.sparksee.io) WeakConnectivity (com.sparsity.sparksee.algorithms)
D
KeyValue (com.sparsity.sparksee.gdb) RandomWalk (com.sparsity.sparksee.algorithms) TextStream (com.sparsity.sparksee.gdb) WeakConnectivityDFS (com.sparsity.sparksee.algorithms)
KeyValues (com.sparsity.sparksee.gdb) ResultSet (com.sparsity.sparksee.gdb) Traversal (com.sparsity.sparksee.algorithms)
Database (com.sparsity.sparksee.gdb) KOpt (com.sparsity.sparksee.algorithms) ResultSetList (com.sparsity.sparksee.gdb) TraversalBFS (com.sparsity.sparksee.algorithms)
DatabaseStatistics (com.sparsity.sparksee.gdb)
N
ResultSetListIterator (com.sparsity.sparksee.gdb) TraversalDFS (com.sparsity.sparksee.algorithms)
NodeExport (com.sparsity.sparksee.gdb)
A | B | C | D | E | G | I | K | N | O | P | Q | R | S | T | V | W


SparkseeNet: Class Hierarchy

Class Hierarchy

Go to the graphical class hierarchy

This inheritance list is sorted roughly, but not completely, alphabetically:
[detail level 123]
o C com.sparsity.sparksee.gdb.Attribute | Attribute data class
o C com.sparsity.sparksee.gdb.AttributeList | Sparksee attribute identifier list
o C com.sparsity.sparksee.gdb.AttributeListIterator | AttributeList iterator class
o C com.sparsity.sparksee.gdb.AttributeStatistics | Attribute statistics class
o C com.sparsity.sparksee.gdb.BooleanList | Boolean list
o C com.sparsity.sparksee.gdb.BooleanListIterator | BooleanList iterator class
o C com.sparsity.sparksee.algorithms.CommunityDetection | CommunityDetection class
| \ C com.sparsity.sparksee.algorithms.DisjointCommunityDetection | DisjointCommunityDetection class
| \ C com.sparsity.sparksee.algorithms.CommunitiesSCD | CommunitiesSCD class
o C com.sparsity.sparksee.algorithms.ConnectedComponents | ConnectedComponents class
o C com.sparsity.sparksee.algorithms.Connectivity | Connectivity class
| o C com.sparsity.sparksee.algorithms.StrongConnectivity | StrongConnectivity class
| | \ C com.sparsity.sparksee.algorithms.StrongConnectivityGabow | This class can be used to solve the problem of finding strongly connected components in a directed graph
| \ C com.sparsity.sparksee.algorithms.WeakConnectivity | WeakConnectivity class
| \ C com.sparsity.sparksee.algorithms.WeakConnectivityDFS | WeakConnectivityDFS class
o C com.sparsity.sparksee.algorithms.Context | Context class
o C com.sparsity.sparksee.io.CSVLoader |
o C com.sparsity.sparksee.gdb.Database | Database class
o C com.sparsity.sparksee.gdb.DatabaseStatistics | Database statistics
o C com.sparsity.sparksee.algorithms.DisjointCommunities | DisjointCommunities class
o C com.sparsity.sparksee.gdb.EdgeData | Edge data class
o C com.sparsity.sparksee.gdb.EdgeExport | Stores edge exporting values
o C com.sparsity.sparksee.gdb.ExportManager | Defines how to export a graph to an external format
| \ C com.sparsity.sparksee.gdb.DefaultExport | Default implementation for ExportManager class
o C com.sparsity.sparksee.gdb.Graph | Graph class
o C com.sparsity.sparksee.gdb.GraphExport | Stores the graph exporting values
o C com.sparsity.sparksee.gdb.Int32List | Sparksee 32-bit signed integer list
o C com.sparsity.sparksee.gdb.Int32ListIterator | Int32List iterator class
o C com.sparsity.sparksee.gdb.KeyValue |
o C com.sparsity.sparksee.gdb.KeyValues | Value set class
o C com.sparsity.sparksee.algorithms.KOpt | KOpt class
o C com.sparsity.sparksee.gdb.NodeExport | Stores the node exporting values
o C com.sparsity.sparksee.gdb.Objects | Object identifier set class
o C com.sparsity.sparksee.gdb.ObjectsIterator | ObjectsIterator class
o C com.sparsity.sparksee.gdb.OIDList | Sparksee object identifier list
o C com.sparsity.sparksee.gdb.OIDListIterator | OIDList iterator class
o C com.sparsity.sparksee.algorithms.PageRank | PageRank class
o C com.sparsity.sparksee.gdb.Platform | Platform class
o C com.sparsity.sparksee.gdb.PlatformStatistics | Platform data and statistics
o C com.sparsity.sparksee.gdb.Query | Query class
o C com.sparsity.sparksee.gdb.QueryContext | Query context interface
o C com.sparsity.sparksee.gdb.QueryStream | Query stream interface
o C com.sparsity.sparksee.gdb.ResultSet | ResultSet class
o C com.sparsity.sparksee.gdb.ResultSetList | ResultSet list
o C com.sparsity.sparksee.gdb.ResultSetListIterator | ResultSetList iterator class
o C com.sparsity.sparksee.io.RowReader | RowReader interface
| \ C com.sparsity.sparksee.io.CSVReader | CSVReader interface
o C com.sparsity.sparksee.io.RowWriter | RowWriter interface
| \ C com.sparsity.sparksee.io.CSVWriter | CSVWriter interface
o C com.sparsity.sparksee.script.ScriptParser | ScriptParser
o C com.sparsity.sparksee.gdb.Session | Session class
o C com.sparsity.sparksee.algorithms.ShortestPath | ShortestPath class
| \ C com.sparsity.sparksee.algorithms.SinglePairShortestPath | SinglePairShortestPath class
| o C com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS | SinglePairShortestPathBFS class
| \ C com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra | SinglePairShortestPathDijkstra class
o C com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstraDynamicCost | Defines how to calculate an edge weight
o C com.sparsity.sparksee.gdb.Sparksee | Sparksee class
o C com.sparsity.sparksee.gdb.SparkseeConfig | Sparksee configuration class
o C com.sparsity.sparksee.gdb.SparkseeProperties | Sparksee properties file
o C com.sparsity.sparksee.gdb.StringList | String list
o C com.sparsity.sparksee.gdb.StringListIterator | StringList iterator class
o C com.sparsity.sparksee.gdb.TextStream | TextStream class
o C com.sparsity.sparksee.algorithms.Traversal | Traversal class
| o C com.sparsity.sparksee.algorithms.RandomWalk | RandomWalk class
| o C com.sparsity.sparksee.algorithms.TraversalBFS | Breadth-First Search implementation of Traversal
| \ C com.sparsity.sparksee.algorithms.TraversalDFS | Depth-First Search (DFS) implementation of Traversal
o C com.sparsity.sparksee.gdb.Type | Type data class
o C com.sparsity.sparksee.io.TypeExporter | Base TypeExporter class
| o C com.sparsity.sparksee.io.EdgeTypeExporter | EdgeTypeExporter class
| \ C com.sparsity.sparksee.io.NodeTypeExporter | NodeTypeExporter class
o C com.sparsity.sparksee.io.TypeExporterEvent | Provides information about the progress of an TypeExproter instance
o C com.sparsity.sparksee.io.TypeExporterListener | Interface to be implemented to receive TypeExporterEvent events from a TypeExporter
o C com.sparsity.sparksee.gdb.TypeList | Sparksee type identifier list
o C com.sparsity.sparksee.gdb.TypeListIterator | TypeList iterator class
o C com.sparsity.sparksee.io.TypeLoader | Base TypeLoader class
| o C com.sparsity.sparksee.io.EdgeTypeLoader | EdgeTypeLoader class
| \ C com.sparsity.sparksee.io.NodeTypeLoader | NodeTypeLoader class
o C com.sparsity.sparksee.io.TypeLoaderEvent | Provides information about the progress of a TypeLoader instance
o C com.sparsity.sparksee.io.TypeLoaderListener | Interface to be implemented to receive TypeLoaderEvent events from a TypeLoader
o C com.sparsity.sparksee.gdb.Value | Value class
o C com.sparsity.sparksee.gdb.ValueArray | ValueArray class
o C com.sparsity.sparksee.gdb.ValueList | Value list
o C com.sparsity.sparksee.gdb.ValueListIterator | ValueList iterator class
o C com.sparsity.sparksee.gdb.Values | Value set class
\ C com.sparsity.sparksee.gdb.ValuesIterator | Values iterator class


SparkseeNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- a -

  • Add() : com.sparsity.sparksee.gdb.AttributeList , com.sparsity.sparksee.gdb.BooleanList , com.sparsity.sparksee.gdb.Objects , com.sparsity.sparksee.gdb.ValueList , com.sparsity.sparksee.gdb.OIDList , com.sparsity.sparksee.gdb.Int32List , com.sparsity.sparksee.gdb.StringList , com.sparsity.sparksee.gdb.TypeList
  • AddAllEdgeTypes() : com.sparsity.sparksee.algorithms.SinglePairShortestPath , com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS , com.sparsity.sparksee.algorithms.CommunitiesSCD , com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra , com.sparsity.sparksee.algorithms.StrongConnectivity , com.sparsity.sparksee.algorithms.Context , com.sparsity.sparksee.algorithms.StrongConnectivityGabow , com.sparsity.sparksee.algorithms.Traversal , com.sparsity.sparksee.algorithms.DisjointCommunityDetection , com.sparsity.sparksee.algorithms.TraversalBFS , com.sparsity.sparksee.algorithms.TraversalDFS , com.sparsity.sparksee.algorithms.KOpt , com.sparsity.sparksee.algorithms.WeakConnectivity , com.sparsity.sparksee.algorithms.WeakConnectivityDFS , com.sparsity.sparksee.algorithms.PageRank , com.sparsity.sparksee.algorithms.RandomWalk , com.sparsity.sparksee.algorithms.ShortestPath
  • AddAllNodeTypes() : com.sparsity.sparksee.algorithms.PageRank , com.sparsity.sparksee.algorithms.RandomWalk , com.sparsity.sparksee.algorithms.ShortestPath , com.sparsity.sparksee.algorithms.SinglePairShortestPath , com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS , com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra , com.sparsity.sparksee.algorithms.StrongConnectivity , com.sparsity.sparksee.algorithms.StrongConnectivityGabow , com.sparsity.sparksee.algorithms.Traversal , com.sparsity.sparksee.algorithms.TraversalBFS , com.sparsity.sparksee.algorithms.TraversalDFS , com.sparsity.sparksee.algorithms.WeakConnectivity , com.sparsity.sparksee.algorithms.WeakConnectivityDFS , com.sparsity.sparksee.algorithms.CommunitiesSCD , com.sparsity.sparksee.algorithms.CommunityDetection , com.sparsity.sparksee.algorithms.Connectivity , com.sparsity.sparksee.algorithms.Context , com.sparsity.sparksee.algorithms.DisjointCommunityDetection , com.sparsity.sparksee.algorithms.KOpt
  • AddChecksums() : com.sparsity.sparksee.gdb.Sparksee
  • AddEdgeType() : com.sparsity.sparksee.algorithms.StrongConnectivityGabow , com.sparsity.sparksee.algorithms.WeakConnectivityDFS , com.sparsity.sparksee.algorithms.WeakConnectivity , com.sparsity.sparksee.algorithms.TraversalBFS , com.sparsity.sparksee.algorithms.RandomWalk , com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra , com.sparsity.sparksee.algorithms.CommunitiesSCD , com.sparsity.sparksee.algorithms.Context , com.sparsity.sparksee.algorithms.DisjointCommunityDetection , com.sparsity.sparksee.algorithms.KOpt , com.sparsity.sparksee.algorithms.PageRank , com.sparsity.sparksee.algorithms.ShortestPath , com.sparsity.sparksee.algorithms.SinglePairShortestPath , com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS , com.sparsity.sparksee.algorithms.StrongConnectivity , com.sparsity.sparksee.algorithms.Traversal , com.sparsity.sparksee.algorithms.TraversalDFS
  • AddNodeType() : com.sparsity.sparksee.algorithms.SinglePairShortestPath , com.sparsity.sparksee.algorithms.StrongConnectivity , com.sparsity.sparksee.algorithms.Traversal , com.sparsity.sparksee.algorithms.CommunityDetection , com.sparsity.sparksee.algorithms.CommunitiesSCD , com.sparsity.sparksee.algorithms.DisjointCommunityDetection , com.sparsity.sparksee.algorithms.ShortestPath , com.sparsity.sparksee.algorithms.StrongConnectivityGabow , com.sparsity.sparksee.algorithms.Connectivity , com.sparsity.sparksee.algorithms.TraversalDFS , com.sparsity.sparksee.algorithms.TraversalBFS , com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS , com.sparsity.sparksee.algorithms.WeakConnectivity , com.sparsity.sparksee.algorithms.KOpt , com.sparsity.sparksee.algorithms.WeakConnectivityDFS , com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra , com.sparsity.sparksee.algorithms.Context , com.sparsity.sparksee.algorithms.RandomWalk , com.sparsity.sparksee.algorithms.PageRank
  • AddWeightedEdgeType() : com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra
  • Any() : com.sparsity.sparksee.gdb.Objects
  • AsDirected() : com.sparsity.sparksee.gdb.EdgeExport
  • AttributeList() : com.sparsity.sparksee.gdb.AttributeList


SparkseeNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- b -

  • Backup() : com.sparsity.sparksee.gdb.Graph
  • Begin() : com.sparsity.sparksee.gdb.Session
  • BeginUpdate() : com.sparsity.sparksee.gdb.Session
  • BooleanList() : com.sparsity.sparksee.gdb.BooleanList


SparkseeNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- c -

  • CalculateEdgeCost() : com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstraDynamicCost
  • CheckOnlyExistence() : com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS
  • Clear() : com.sparsity.sparksee.gdb.BooleanList , com.sparsity.sparksee.gdb.ResultSetList , com.sparsity.sparksee.gdb.SparkseeProperties , com.sparsity.sparksee.gdb.Int32List , com.sparsity.sparksee.gdb.StringList , com.sparsity.sparksee.gdb.TypeList , com.sparsity.sparksee.gdb.AttributeList , com.sparsity.sparksee.gdb.Objects , com.sparsity.sparksee.gdb.ValueList , com.sparsity.sparksee.gdb.OIDList
  • Close() : com.sparsity.sparksee.algorithms.Context , com.sparsity.sparksee.algorithms.Traversal , com.sparsity.sparksee.gdb.ValueArray , com.sparsity.sparksee.io.CSVReader , com.sparsity.sparksee.gdb.Values , com.sparsity.sparksee.gdb.ValuesIterator , com.sparsity.sparksee.io.CSVWriter , com.sparsity.sparksee.gdb.Database , com.sparsity.sparksee.algorithms.DisjointCommunities , com.sparsity.sparksee.gdb.KeyValues , com.sparsity.sparksee.algorithms.KOpt , com.sparsity.sparksee.gdb.Objects , com.sparsity.sparksee.gdb.ObjectsIterator , com.sparsity.sparksee.algorithms.PageRank , com.sparsity.sparksee.algorithms.CommunityDetection , com.sparsity.sparksee.io.RowReader , com.sparsity.sparksee.io.RowWriter , com.sparsity.sparksee.algorithms.ConnectedComponents , com.sparsity.sparksee.gdb.Session , com.sparsity.sparksee.algorithms.ShortestPath , com.sparsity.sparksee.algorithms.Connectivity , com.sparsity.sparksee.gdb.Sparksee , com.sparsity.sparksee.gdb.TextStream
  • CombineDifference() : com.sparsity.sparksee.gdb.Objects
  • CombineIntersection() : com.sparsity.sparksee.gdb.Objects
  • CombineUnion() : com.sparsity.sparksee.gdb.Objects
  • Commit() : com.sparsity.sparksee.gdb.Session
  • CommunitiesSCD() : com.sparsity.sparksee.algorithms.CommunitiesSCD
  • Compare() : com.sparsity.sparksee.gdb.Value
  • CompareTo() : com.sparsity.sparksee.gdb.KeyValue , com.sparsity.sparksee.gdb.Value , com.sparsity.sparksee.gdb.KeyValue
  • Compute() : com.sparsity.sparksee.algorithms.Context
  • ConnectedComponents() : com.sparsity.sparksee.algorithms.ConnectedComponents
  • Contains() : com.sparsity.sparksee.gdb.Objects
  • Context() : com.sparsity.sparksee.algorithms.Context
  • Copy() : com.sparsity.sparksee.gdb.Objects
  • Count() : com.sparsity.sparksee.gdb.BooleanList , com.sparsity.sparksee.gdb.Values , com.sparsity.sparksee.gdb.ResultSetList , com.sparsity.sparksee.gdb.Int32List , com.sparsity.sparksee.gdb.OIDList , com.sparsity.sparksee.gdb.Objects , com.sparsity.sparksee.gdb.AttributeList , com.sparsity.sparksee.gdb.TypeList , com.sparsity.sparksee.gdb.ValueList , com.sparsity.sparksee.gdb.StringList
  • CountEdges() : com.sparsity.sparksee.gdb.Graph
  • CountNodes() : com.sparsity.sparksee.gdb.Graph
  • Create() : com.sparsity.sparksee.gdb.Sparksee
  • CSVReader() : com.sparsity.sparksee.io.CSVReader
  • CSVWriter() : com.sparsity.sparksee.io.CSVWriter


SparkseeNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- d -

  • Decrypt() : com.sparsity.sparksee.gdb.Sparksee
  • DefaultExport() : com.sparsity.sparksee.gdb.DefaultExport
  • Degree() : com.sparsity.sparksee.gdb.Graph
  • Difference() : com.sparsity.sparksee.gdb.Objects
  • DisableRollback() : com.sparsity.sparksee.gdb.Database
  • DisjointCommunities() : com.sparsity.sparksee.algorithms.DisjointCommunities
  • DownloadExpected() : com.sparsity.sparksee.gdb.SparkseeConfig
  • DownloadLicense() : com.sparsity.sparksee.gdb.SparkseeConfig
  • Drop() : com.sparsity.sparksee.gdb.Graph
  • DumpData() : com.sparsity.sparksee.gdb.Graph
  • DumpSchema() : com.sparsity.sparksee.gdb.Database
  • DumpStorage() : com.sparsity.sparksee.gdb.Graph


SparkseeNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- e -

  • EdgeExport() : com.sparsity.sparksee.gdb.EdgeExport
  • Edges() : com.sparsity.sparksee.gdb.Graph
  • EdgesType : com.sparsity.sparksee.gdb.Type
  • EdgeTypeExporter() : com.sparsity.sparksee.io.EdgeTypeExporter
  • EdgeTypeLoader() : com.sparsity.sparksee.io.EdgeTypeLoader
  • EnableRollback() : com.sparsity.sparksee.gdb.Database
  • EnableType() : com.sparsity.sparksee.gdb.DefaultExport , com.sparsity.sparksee.gdb.ExportManager
  • Encrypt() : com.sparsity.sparksee.gdb.Sparksee
  • EncryptedBackup() : com.sparsity.sparksee.gdb.Graph
  • Equals() : com.sparsity.sparksee.gdb.Value , com.sparsity.sparksee.gdb.KeyValue , com.sparsity.sparksee.gdb.Objects
  • ExcludeEdges() : com.sparsity.sparksee.algorithms.TraversalDFS , com.sparsity.sparksee.algorithms.WeakConnectivity , com.sparsity.sparksee.algorithms.WeakConnectivityDFS , com.sparsity.sparksee.algorithms.CommunitiesSCD , com.sparsity.sparksee.algorithms.CommunityDetection , com.sparsity.sparksee.algorithms.Connectivity , com.sparsity.sparksee.algorithms.Context , com.sparsity.sparksee.algorithms.DisjointCommunityDetection , com.sparsity.sparksee.algorithms.RandomWalk , com.sparsity.sparksee.algorithms.ShortestPath , com.sparsity.sparksee.algorithms.SinglePairShortestPath , com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS , com.sparsity.sparksee.algorithms.TraversalBFS , com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra , com.sparsity.sparksee.algorithms.StrongConnectivity , com.sparsity.sparksee.algorithms.StrongConnectivityGabow , com.sparsity.sparksee.algorithms.Traversal
  • ExcludeNodes() : com.sparsity.sparksee.algorithms.CommunitiesSCD , com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS , com.sparsity.sparksee.algorithms.WeakConnectivity , com.sparsity.sparksee.algorithms.Context , com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra , com.sparsity.sparksee.algorithms.WeakConnectivityDFS , com.sparsity.sparksee.algorithms.Traversal , com.sparsity.sparksee.algorithms.ShortestPath , com.sparsity.sparksee.algorithms.CommunityDetection , com.sparsity.sparksee.algorithms.SinglePairShortestPath , com.sparsity.sparksee.algorithms.DisjointCommunityDetection , com.sparsity.sparksee.algorithms.StrongConnectivity , com.sparsity.sparksee.algorithms.RandomWalk , com.sparsity.sparksee.algorithms.Connectivity , com.sparsity.sparksee.algorithms.TraversalBFS , com.sparsity.sparksee.algorithms.TraversalDFS , com.sparsity.sparksee.algorithms.StrongConnectivityGabow
  • Execute() : com.sparsity.sparksee.gdb.Query
  • Exists() : com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra , com.sparsity.sparksee.algorithms.SinglePairShortestPath , com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS , com.sparsity.sparksee.gdb.Objects
  • Explode() : com.sparsity.sparksee.gdb.Graph
  • Export() : com.sparsity.sparksee.gdb.Graph


SparkseeNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- f -

  • Fetch() : com.sparsity.sparksee.gdb.QueryStream
  • FindAttribute() : com.sparsity.sparksee.gdb.Graph
  • FindAttributes() : com.sparsity.sparksee.gdb.Graph
  • FindEdge() : com.sparsity.sparksee.gdb.Graph
  • FindEdgeTypes() : com.sparsity.sparksee.gdb.Graph
  • FindNodeTypes() : com.sparsity.sparksee.gdb.Graph
  • FindObject() : com.sparsity.sparksee.gdb.Graph
  • FindOrCreateEdge() : com.sparsity.sparksee.gdb.Graph
  • FindOrCreateObject() : com.sparsity.sparksee.gdb.Graph
  • FindType() : com.sparsity.sparksee.gdb.Graph
  • FindTypes() : com.sparsity.sparksee.gdb.Graph
  • FixCurrentCacheMaxSize() : com.sparsity.sparksee.gdb.Database


SparkseeNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- g -

  • GenerateSchemaScript() : com.sparsity.sparksee.script.ScriptParser
  • Get() : com.sparsity.sparksee.gdb.ResultSetList , com.sparsity.sparksee.gdb.ValueArray , com.sparsity.sparksee.gdb.ValueList , com.sparsity.sparksee.gdb.SparkseeProperties
  • GetAESIV() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetAESKey() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetAlias() : com.sparsity.sparksee.gdb.Database
  • GetAreNeighborsIndexed() : com.sparsity.sparksee.gdb.Type
  • GetArrayAttribute() : com.sparsity.sparksee.gdb.Graph
  • GetArraySize() : com.sparsity.sparksee.gdb.Attribute
  • GetAttribute() : com.sparsity.sparksee.gdb.Graph
  • GetAttributeIntervalCount() : com.sparsity.sparksee.gdb.Graph
  • GetAttributes() : com.sparsity.sparksee.gdb.Graph
  • GetAttributeStatistics() : com.sparsity.sparksee.gdb.Graph
  • GetAttributeText() : com.sparsity.sparksee.gdb.Graph
  • GetAvailableMem() : com.sparsity.sparksee.gdb.PlatformStatistics
  • GetAvgLengthString() : com.sparsity.sparksee.gdb.AttributeStatistics
  • GetBoolean() : com.sparsity.sparksee.gdb.SparkseeProperties , com.sparsity.sparksee.gdb.Value , com.sparsity.sparksee.gdb.ValueArray
  • GetCache() : com.sparsity.sparksee.gdb.DatabaseStatistics
  • GetCacheMaxSize() : com.sparsity.sparksee.gdb.Database , com.sparsity.sparksee.gdb.SparkseeConfig
  • GetCacheStatisticsEnabled() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetCacheStatisticsFile() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetCacheStatisticsSnapshotTime() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetCallStackDump() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetChecksumEnabled() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetClientId() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetColor() : com.sparsity.sparksee.gdb.EdgeExport , com.sparsity.sparksee.gdb.NodeExport
  • GetColorRGB() : com.sparsity.sparksee.gdb.EdgeExport , com.sparsity.sparksee.gdb.NodeExport
  • GetColumn() : com.sparsity.sparksee.gdb.ResultSet
  • GetColumnDataType() : com.sparsity.sparksee.gdb.ResultSet
  • GetColumnIndex() : com.sparsity.sparksee.gdb.ResultSet
  • GetColumnName() : com.sparsity.sparksee.gdb.ResultSet
  • GetCommunities() : com.sparsity.sparksee.algorithms.CommunitiesSCD , com.sparsity.sparksee.algorithms.DisjointCommunityDetection
  • GetCommunity() : com.sparsity.sparksee.algorithms.DisjointCommunities
  • GetConnectedComponent() : com.sparsity.sparksee.algorithms.ConnectedComponents
  • GetConnectedComponents() : com.sparsity.sparksee.algorithms.Connectivity , com.sparsity.sparksee.algorithms.StrongConnectivity , com.sparsity.sparksee.algorithms.StrongConnectivityGabow , com.sparsity.sparksee.algorithms.WeakConnectivity , com.sparsity.sparksee.algorithms.WeakConnectivityDFS
  • GetCost() : com.sparsity.sparksee.algorithms.SinglePairShortestPath , com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS , com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra
  • GetCount() : com.sparsity.sparksee.gdb.Attribute , com.sparsity.sparksee.algorithms.ConnectedComponents , com.sparsity.sparksee.algorithms.DisjointCommunities , com.sparsity.sparksee.io.TypeExporterEvent , com.sparsity.sparksee.io.TypeLoaderEvent
  • GetCurrentCost() : com.sparsity.sparksee.algorithms.KOpt
  • GetCurrentDepth() : com.sparsity.sparksee.algorithms.TraversalDFS , com.sparsity.sparksee.algorithms.RandomWalk , com.sparsity.sparksee.algorithms.Traversal , com.sparsity.sparksee.algorithms.TraversalBFS
  • GetCurrentTour() : com.sparsity.sparksee.algorithms.KOpt
  • GetData() : com.sparsity.sparksee.gdb.DatabaseStatistics
  • GetDataType() : com.sparsity.sparksee.gdb.Attribute , com.sparsity.sparksee.gdb.Value
  • GetDistinct() : com.sparsity.sparksee.gdb.AttributeStatistics
  • GetDouble() : com.sparsity.sparksee.gdb.Value , com.sparsity.sparksee.gdb.ValueArray
  • GetDownloadStatus() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetEdge() : com.sparsity.sparksee.gdb.DefaultExport , com.sparsity.sparksee.gdb.EdgeData , com.sparsity.sparksee.gdb.ExportManager
  • GetEdgeData() : com.sparsity.sparksee.gdb.Graph
  • GetEdgePeer() : com.sparsity.sparksee.gdb.Graph
  • GetEdgeType() : com.sparsity.sparksee.gdb.DefaultExport , com.sparsity.sparksee.gdb.ExportManager
  • GetEncryptionEnabled() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetExtentPages() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetExtentSize() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetFontSize() : com.sparsity.sparksee.gdb.EdgeExport , com.sparsity.sparksee.gdb.NodeExport
  • GetGraph() : com.sparsity.sparksee.gdb.DefaultExport , com.sparsity.sparksee.gdb.ExportManager , com.sparsity.sparksee.gdb.Session
  • GetHead() : com.sparsity.sparksee.gdb.EdgeData
  • GetHeight() : com.sparsity.sparksee.gdb.NodeExport
  • GetHighAvailabilityCoordinators() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetHighAvailabilityEnabled() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetHighAvailabilityIP() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetHighAvailabilityMasterHistory() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetHighAvailabilitySynchronization() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetId() : com.sparsity.sparksee.gdb.Attribute , com.sparsity.sparksee.gdb.Type
  • GetInMemAllocSize() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetInMemoryPoolCapacity() : com.sparsity.sparksee.gdb.Session , com.sparsity.sparksee.gdb.Sparksee
  • GetInteger() : com.sparsity.sparksee.gdb.SparkseeProperties , com.sparsity.sparksee.gdb.Value , com.sparsity.sparksee.gdb.ValueArray
  • GetIsDirected() : com.sparsity.sparksee.gdb.Type
  • GetIsRestricted() : com.sparsity.sparksee.gdb.Type
  • GetJSON() : com.sparsity.sparksee.gdb.ResultSet
  • GetKind() : com.sparsity.sparksee.gdb.Attribute
  • GetLabel() : com.sparsity.sparksee.gdb.NodeExport , com.sparsity.sparksee.gdb.EdgeExport , com.sparsity.sparksee.gdb.GraphExport
  • GetLabelColor() : com.sparsity.sparksee.gdb.EdgeExport , com.sparsity.sparksee.gdb.NodeExport
  • GetLabelColorRGB() : com.sparsity.sparksee.gdb.EdgeExport , com.sparsity.sparksee.gdb.NodeExport
  • GetLicense() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetLicenseId() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetLicensePreDownloadDays() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetLicenseRequest() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetLogFile() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetLogLevel() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetLong() : com.sparsity.sparksee.gdb.ValueArray , com.sparsity.sparksee.gdb.Value , com.sparsity.sparksee.gdb.ValueArray
  • GetMax() : com.sparsity.sparksee.gdb.AttributeStatistics
  • GetMaxLengthString() : com.sparsity.sparksee.gdb.AttributeStatistics
  • GetMean() : com.sparsity.sparksee.gdb.AttributeStatistics
  • GetMedian() : com.sparsity.sparksee.gdb.AttributeStatistics
  • GetMin() : com.sparsity.sparksee.gdb.AttributeStatistics
  • GetMinLengthString() : com.sparsity.sparksee.gdb.AttributeStatistics
  • GetMode() : com.sparsity.sparksee.gdb.AttributeStatistics
  • GetModeCount() : com.sparsity.sparksee.gdb.AttributeStatistics
  • GetName() : com.sparsity.sparksee.gdb.Attribute , com.sparsity.sparksee.gdb.Type
  • GetNode() : com.sparsity.sparksee.gdb.ExportManager , com.sparsity.sparksee.gdb.DefaultExport
  • GetNodes() : com.sparsity.sparksee.algorithms.ConnectedComponents , com.sparsity.sparksee.algorithms.DisjointCommunities
  • GetNodeType() : com.sparsity.sparksee.gdb.ExportManager , com.sparsity.sparksee.gdb.DefaultExport
  • GetNull() : com.sparsity.sparksee.gdb.AttributeStatistics
  • GetNumColumns() : com.sparsity.sparksee.gdb.ResultSet
  • GetNumCPUs() : com.sparsity.sparksee.gdb.PlatformStatistics
  • GetNumObjects() : com.sparsity.sparksee.gdb.Type
  • GetObjectType() : com.sparsity.sparksee.gdb.Type , com.sparsity.sparksee.gdb.Graph
  • GetOID() : com.sparsity.sparksee.gdb.ValueArray , com.sparsity.sparksee.gdb.Value
  • GetPartition() : com.sparsity.sparksee.io.TypeLoaderEvent
  • GetPath() : com.sparsity.sparksee.gdb.Database
  • GetPathAsEdges() : com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS , com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra , com.sparsity.sparksee.algorithms.SinglePairShortestPath
  • GetPathAsNodes() : com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS , com.sparsity.sparksee.algorithms.SinglePairShortestPath , com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra
  • GetPhase() : com.sparsity.sparksee.io.TypeLoaderEvent
  • GetPoolFrameSize() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetPoolPartitions() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetPoolPersistentMaxSize() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetPoolPersistentMinSize() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetPoolTemporaryMaxSize() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetPoolTemporaryMinSize() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetRead() : com.sparsity.sparksee.gdb.DatabaseStatistics
  • GetRealTime() : com.sparsity.sparksee.gdb.PlatformStatistics
  • GetRecoveryCacheMaxSize() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetRecoveryCheckpointTime() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetRecoveryEnabled() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetRecoveryLogFile() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetRestrictedFrom() : com.sparsity.sparksee.gdb.Type
  • GetRestrictedTo() : com.sparsity.sparksee.gdb.Type
  • GetRollbackEnabled() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetRow() : com.sparsity.sparksee.io.RowReader , com.sparsity.sparksee.io.CSVReader
  • GetSessions() : com.sparsity.sparksee.gdb.DatabaseStatistics
  • GetShape() : com.sparsity.sparksee.gdb.NodeExport
  • GetSize() : com.sparsity.sparksee.algorithms.DisjointCommunities , com.sparsity.sparksee.algorithms.ConnectedComponents , com.sparsity.sparksee.gdb.Attribute
  • GetSparkseeConfigFile() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetStatistics() : com.sparsity.sparksee.gdb.Database , com.sparsity.sparksee.gdb.Platform
  • GetString() : com.sparsity.sparksee.gdb.Value
  • GetSystemTime() : com.sparsity.sparksee.gdb.PlatformStatistics
  • GetTail() : com.sparsity.sparksee.gdb.EdgeData
  • GetTemp() : com.sparsity.sparksee.gdb.DatabaseStatistics
  • GetTimestamp() : com.sparsity.sparksee.gdb.ValueArray , com.sparsity.sparksee.gdb.Value
  • GetTimestampAsDateTime() : com.sparsity.sparksee.gdb.Value
  • GetTimeUnit() : com.sparsity.sparksee.gdb.SparkseeProperties
  • GetTmpEnabled() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetTmpFolder() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetTotal() : com.sparsity.sparksee.io.TypeExporterEvent , com.sparsity.sparksee.gdb.AttributeStatistics
  • GetTotalMem() : com.sparsity.sparksee.gdb.PlatformStatistics
  • GetTotalPartitions() : com.sparsity.sparksee.io.TypeLoaderEvent
  • GetTotalPartitionSteps() : com.sparsity.sparksee.io.TypeLoaderEvent
  • GetTotalPhases() : com.sparsity.sparksee.io.TypeLoaderEvent
  • GetType() : com.sparsity.sparksee.gdb.Graph
  • GetTypeId() : com.sparsity.sparksee.io.TypeExporterEvent , com.sparsity.sparksee.io.TypeLoaderEvent , com.sparsity.sparksee.gdb.Attribute
  • GetUserTime() : com.sparsity.sparksee.gdb.PlatformStatistics
  • GetValues() : com.sparsity.sparksee.gdb.Graph
  • GetVariance() : com.sparsity.sparksee.gdb.AttributeStatistics
  • GetWidth() : com.sparsity.sparksee.gdb.NodeExport , com.sparsity.sparksee.gdb.EdgeExport
  • GetWrite() : com.sparsity.sparksee.gdb.DatabaseStatistics
  • GlobalType : com.sparsity.sparksee.gdb.Type
  • GraphExport() : com.sparsity.sparksee.gdb.GraphExport


SparkseeNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- h -

  • HasNext() : com.sparsity.sparksee.gdb.AttributeListIterator , com.sparsity.sparksee.gdb.BooleanListIterator , com.sparsity.sparksee.gdb.ValuesIterator , com.sparsity.sparksee.gdb.ValueListIterator , com.sparsity.sparksee.gdb.TypeListIterator , com.sparsity.sparksee.algorithms.TraversalDFS , com.sparsity.sparksee.algorithms.TraversalBFS , com.sparsity.sparksee.algorithms.Traversal , com.sparsity.sparksee.gdb.StringListIterator , com.sparsity.sparksee.gdb.KeyValues , com.sparsity.sparksee.algorithms.RandomWalk , com.sparsity.sparksee.gdb.OIDListIterator , com.sparsity.sparksee.gdb.ObjectsIterator , com.sparsity.sparksee.gdb.ResultSetListIterator , com.sparsity.sparksee.gdb.Int32ListIterator
  • Heads() : com.sparsity.sparksee.gdb.Graph


SparkseeNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- i -

  • IncludeEdges() : com.sparsity.sparksee.algorithms.CommunitiesSCD , com.sparsity.sparksee.algorithms.CommunityDetection , com.sparsity.sparksee.algorithms.DisjointCommunityDetection
  • IncludeNodes() : com.sparsity.sparksee.algorithms.CommunitiesSCD , com.sparsity.sparksee.algorithms.CommunityDetection , com.sparsity.sparksee.algorithms.DisjointCommunityDetection
  • IndexAttribute() : com.sparsity.sparksee.gdb.Graph
  • IndexNeighbors() : com.sparsity.sparksee.gdb.Graph
  • Int32List() : com.sparsity.sparksee.gdb.Int32List
  • Intersection() : com.sparsity.sparksee.gdb.Objects
  • InvalidAttribute : com.sparsity.sparksee.gdb.Attribute
  • InvalidOID : com.sparsity.sparksee.gdb.Objects
  • InvalidType : com.sparsity.sparksee.gdb.Type
  • IsArrayAttribute() : com.sparsity.sparksee.gdb.Attribute
  • IsClosed() : com.sparsity.sparksee.gdb.ValueArray , com.sparsity.sparksee.gdb.Values , com.sparsity.sparksee.algorithms.CommunityDetection , com.sparsity.sparksee.gdb.ValuesIterator , com.sparsity.sparksee.algorithms.ConnectedComponents , com.sparsity.sparksee.algorithms.Connectivity , com.sparsity.sparksee.algorithms.Traversal , com.sparsity.sparksee.algorithms.Context , com.sparsity.sparksee.gdb.Database , com.sparsity.sparksee.algorithms.DisjointCommunities , com.sparsity.sparksee.algorithms.PageRank , com.sparsity.sparksee.gdb.KeyValues , com.sparsity.sparksee.algorithms.KOpt , com.sparsity.sparksee.gdb.Objects , com.sparsity.sparksee.gdb.ObjectsIterator , com.sparsity.sparksee.gdb.Session , com.sparsity.sparksee.algorithms.ShortestPath , com.sparsity.sparksee.gdb.Sparksee
  • IsFit() : com.sparsity.sparksee.gdb.NodeExport
  • IsLast() : com.sparsity.sparksee.io.TypeLoaderEvent , com.sparsity.sparksee.io.TypeExporterEvent
  • IsNull() : com.sparsity.sparksee.gdb.TextStream , com.sparsity.sparksee.gdb.Value
  • IsSessionAttribute() : com.sparsity.sparksee.gdb.Attribute
  • Iterator() : com.sparsity.sparksee.gdb.BooleanList , com.sparsity.sparksee.gdb.ResultSetList , com.sparsity.sparksee.gdb.Values , com.sparsity.sparksee.gdb.Objects , com.sparsity.sparksee.gdb.StringList , com.sparsity.sparksee.gdb.ValueList , com.sparsity.sparksee.gdb.AttributeList , com.sparsity.sparksee.gdb.TypeList , com.sparsity.sparksee.gdb.Int32List , com.sparsity.sparksee.gdb.OIDList
  • IteratorFromElement() : com.sparsity.sparksee.gdb.Objects
  • IteratorFromIndex() : com.sparsity.sparksee.gdb.Objects


SparkseeNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- k -

  • KOpt() : com.sparsity.sparksee.algorithms.KOpt


SparkseeNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- l -

  • Load() : com.sparsity.sparksee.gdb.SparkseeProperties
  • LoadEdges() : com.sparsity.sparksee.io.CSVLoader
  • LoadNodes() : com.sparsity.sparksee.io.CSVLoader


SparkseeNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- m -

  • Main() : com.sparsity.sparksee.script.ScriptParser
  • MakeNull() : com.sparsity.sparksee.gdb.ValueArray
  • MaxLengthString : com.sparsity.sparksee.gdb.Value


SparkseeNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- n -

  • Neighbors() : com.sparsity.sparksee.gdb.Graph
  • NewArrayAttribute() : com.sparsity.sparksee.gdb.Graph
  • NewAttribute() : com.sparsity.sparksee.gdb.Graph
  • NewEdge() : com.sparsity.sparksee.gdb.Graph
  • NewEdgeType() : com.sparsity.sparksee.gdb.Graph
  • NewNode() : com.sparsity.sparksee.gdb.Graph
  • NewNodeType() : com.sparsity.sparksee.gdb.Graph
  • NewObjects() : com.sparsity.sparksee.gdb.Session
  • NewQuery() : com.sparsity.sparksee.gdb.QueryContext , com.sparsity.sparksee.gdb.Session
  • NewRestrictedEdgeType() : com.sparsity.sparksee.gdb.Graph
  • NewSession() : com.sparsity.sparksee.gdb.Database
  • NewSessionArrayAttribute() : com.sparsity.sparksee.gdb.Graph
  • NewSessionAttribute() : com.sparsity.sparksee.gdb.Graph
  • Next() : com.sparsity.sparksee.gdb.ResultSet , com.sparsity.sparksee.algorithms.TraversalDFS , com.sparsity.sparksee.gdb.TypeListIterator , com.sparsity.sparksee.gdb.KeyValues , com.sparsity.sparksee.gdb.ValueListIterator , com.sparsity.sparksee.gdb.Int32ListIterator , com.sparsity.sparksee.gdb.StringListIterator , com.sparsity.sparksee.gdb.AttributeListIterator , com.sparsity.sparksee.gdb.ValuesIterator , com.sparsity.sparksee.gdb.BooleanListIterator , com.sparsity.sparksee.gdb.KeyValues , com.sparsity.sparksee.algorithms.Traversal , com.sparsity.sparksee.gdb.ResultSetListIterator , com.sparsity.sparksee.algorithms.RandomWalk , com.sparsity.sparksee.gdb.ObjectsIterator , com.sparsity.sparksee.gdb.OIDListIterator , com.sparsity.sparksee.algorithms.TraversalBFS
  • NodeExport() : com.sparsity.sparksee.gdb.NodeExport
  • NodesType : com.sparsity.sparksee.gdb.Type
  • NodeTypeExporter() : com.sparsity.sparksee.io.NodeTypeExporter
  • NodeTypeLoader() : com.sparsity.sparksee.io.NodeTypeLoader
  • NotifyEvent() : com.sparsity.sparksee.io.TypeExporterListener , com.sparsity.sparksee.io.TypeLoaderListener


SparkseeNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- o -

  • OIDList() : com.sparsity.sparksee.gdb.OIDList
  • Open() : com.sparsity.sparksee.io.CSVReader , com.sparsity.sparksee.gdb.Sparksee , com.sparsity.sparksee.io.CSVWriter , com.sparsity.sparksee.gdb.Sparksee


SparkseeNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- p -

  • PageRank() : com.sparsity.sparksee.algorithms.PageRank
  • Parse() : com.sparsity.sparksee.script.ScriptParser
  • PlatformStatistics() : com.sparsity.sparksee.gdb.PlatformStatistics
  • PreCommit() : com.sparsity.sparksee.gdb.Session
  • Prepare() : com.sparsity.sparksee.gdb.QueryStream , com.sparsity.sparksee.gdb.ExportManager , com.sparsity.sparksee.gdb.DefaultExport


SparkseeNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- q -

  • QueryContext() : com.sparsity.sparksee.gdb.QueryContext


SparkseeNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- r -

  • RandomWalk() : com.sparsity.sparksee.algorithms.RandomWalk
  • Read() : com.sparsity.sparksee.io.CSVReader , com.sparsity.sparksee.gdb.TextStream , com.sparsity.sparksee.io.RowReader
  • RedoPrecommitted() : com.sparsity.sparksee.gdb.Database
  • Register() : com.sparsity.sparksee.io.NodeTypeExporter , com.sparsity.sparksee.io.NodeTypeLoader , com.sparsity.sparksee.io.TypeExporter , com.sparsity.sparksee.io.TypeLoader , com.sparsity.sparksee.io.EdgeTypeExporter , com.sparsity.sparksee.io.EdgeTypeLoader
  • Release() : com.sparsity.sparksee.gdb.DefaultExport , com.sparsity.sparksee.gdb.ExportManager
  • Remove() : com.sparsity.sparksee.gdb.Objects
  • RemoveAttribute() : com.sparsity.sparksee.gdb.Graph
  • RemoveChecksums() : com.sparsity.sparksee.gdb.Sparksee
  • RemoveType() : com.sparsity.sparksee.gdb.Graph
  • RenameAttribute() : com.sparsity.sparksee.gdb.Graph
  • RenameType() : com.sparsity.sparksee.gdb.Graph
  • Reset() : com.sparsity.sparksee.io.CSVReader , com.sparsity.sparksee.algorithms.RandomWalk , com.sparsity.sparksee.io.RowReader
  • ResizeInMemoryPool() : com.sparsity.sparksee.gdb.Sparksee
  • Restore() : com.sparsity.sparksee.gdb.Sparksee
  • RestoreEncryptedBackup() : com.sparsity.sparksee.gdb.Sparksee
  • ResultSetList() : com.sparsity.sparksee.gdb.ResultSetList
  • Rewind() : com.sparsity.sparksee.gdb.ResultSet
  • Rollback() : com.sparsity.sparksee.gdb.Session
  • Run() : com.sparsity.sparksee.io.EdgeTypeLoader , com.sparsity.sparksee.algorithms.CommunitiesSCD , com.sparsity.sparksee.algorithms.WeakConnectivity , com.sparsity.sparksee.algorithms.CommunityDetection , com.sparsity.sparksee.algorithms.Connectivity , com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS , com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra , com.sparsity.sparksee.algorithms.SinglePairShortestPath , com.sparsity.sparksee.io.EdgeTypeExporter , com.sparsity.sparksee.io.NodeTypeExporter , com.sparsity.sparksee.algorithms.ShortestPath , com.sparsity.sparksee.algorithms.PageRank , com.sparsity.sparksee.io.NodeTypeLoader , com.sparsity.sparksee.io.TypeExporter , com.sparsity.sparksee.algorithms.StrongConnectivityGabow , com.sparsity.sparksee.algorithms.DisjointCommunityDetection , com.sparsity.sparksee.algorithms.StrongConnectivity , com.sparsity.sparksee.io.TypeLoader , com.sparsity.sparksee.algorithms.WeakConnectivityDFS
  • RunNPhases() : com.sparsity.sparksee.io.TypeLoader , com.sparsity.sparksee.io.NodeTypeLoader , com.sparsity.sparksee.io.EdgeTypeLoader
  • RunThreeOpt() : com.sparsity.sparksee.algorithms.KOpt
  • RunTwoOpt() : com.sparsity.sparksee.algorithms.KOpt
  • RunTwoPhases() : com.sparsity.sparksee.io.EdgeTypeLoader , com.sparsity.sparksee.io.TypeLoader , com.sparsity.sparksee.io.NodeTypeLoader


SparkseeNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- s -

  • Sample() : com.sparsity.sparksee.gdb.Objects
  • Save() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SaveAll() : com.sparsity.sparksee.gdb.SparkseeConfig
  • ScriptParser() : com.sparsity.sparksee.script.ScriptParser
  • Select() : com.sparsity.sparksee.gdb.Graph
  • Set() : com.sparsity.sparksee.gdb.OIDList , com.sparsity.sparksee.gdb.Value , com.sparsity.sparksee.gdb.ValueArray
  • SetAESEncryptionEnabled() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetArrayAttribute() : com.sparsity.sparksee.gdb.Graph
  • SetArrayAttributeVoid() : com.sparsity.sparksee.gdb.Graph
  • SetAsDirected() : com.sparsity.sparksee.gdb.EdgeExport
  • SetAttribute() : com.sparsity.sparksee.gdb.Graph
  • SetAttributeDefaultValue() : com.sparsity.sparksee.gdb.Graph
  • SetAttributePositions() : com.sparsity.sparksee.io.EdgeTypeLoader , com.sparsity.sparksee.io.NodeTypeLoader , com.sparsity.sparksee.io.TypeLoader
  • SetAttributes() : com.sparsity.sparksee.io.EdgeTypeExporter , com.sparsity.sparksee.io.EdgeTypeLoader , com.sparsity.sparksee.io.NodeTypeExporter , com.sparsity.sparksee.io.NodeTypeLoader , com.sparsity.sparksee.io.TypeExporter , com.sparsity.sparksee.io.TypeLoader
  • SetAttributeText() : com.sparsity.sparksee.gdb.Graph
  • SetAutoQuotes() : com.sparsity.sparksee.io.CSVWriter
  • SetBoolean() : com.sparsity.sparksee.gdb.Value , com.sparsity.sparksee.gdb.ValueArray
  • SetBooleanVoid() : com.sparsity.sparksee.gdb.Value
  • SetCacheMaxSize() : com.sparsity.sparksee.gdb.Database , com.sparsity.sparksee.gdb.SparkseeConfig
  • SetCacheStatisticsEnabled() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetCacheStatisticsFile() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetCacheStatisticsSnapshotTime() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetCallStackDump() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetChecksumEnabled() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetClientId() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetColor() : com.sparsity.sparksee.gdb.EdgeExport , com.sparsity.sparksee.gdb.NodeExport
  • SetColorRGB() : com.sparsity.sparksee.gdb.EdgeExport , com.sparsity.sparksee.gdb.NodeExport
  • SetCurrentTour() : com.sparsity.sparksee.algorithms.KOpt
  • SetDamping() : com.sparsity.sparksee.algorithms.PageRank
  • SetDefaults() : com.sparsity.sparksee.gdb.EdgeExport , com.sparsity.sparksee.gdb.GraphExport , com.sparsity.sparksee.gdb.NodeExport
  • SetDefaultWeight() : com.sparsity.sparksee.algorithms.PageRank , com.sparsity.sparksee.algorithms.RandomWalk
  • SetDouble() : com.sparsity.sparksee.gdb.Value , com.sparsity.sparksee.gdb.ValueArray
  • SetDoubleVoid() : com.sparsity.sparksee.gdb.Value
  • SetDynamic() : com.sparsity.sparksee.gdb.Query
  • SetDynamicEdgeCostCallback() : com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra
  • SetEdgeWeightAttributeType() : com.sparsity.sparksee.algorithms.PageRank , com.sparsity.sparksee.algorithms.RandomWalk , com.sparsity.sparksee.algorithms.KOpt
  • SetEncryptionDisabled() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetErrorLog() : com.sparsity.sparksee.script.ScriptParser
  • SetExtentPages() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetExtentSize() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetFit() : com.sparsity.sparksee.gdb.NodeExport
  • SetFontSize() : com.sparsity.sparksee.gdb.EdgeExport , com.sparsity.sparksee.gdb.NodeExport
  • SetForcedQuotes() : com.sparsity.sparksee.io.CSVWriter
  • SetFrequency() : com.sparsity.sparksee.io.EdgeTypeExporter , com.sparsity.sparksee.io.EdgeTypeLoader , com.sparsity.sparksee.io.NodeTypeExporter , com.sparsity.sparksee.io.NodeTypeLoader , com.sparsity.sparksee.io.TypeExporter , com.sparsity.sparksee.io.TypeLoader
  • SetGraph() : com.sparsity.sparksee.io.EdgeTypeExporter , com.sparsity.sparksee.io.EdgeTypeLoader , com.sparsity.sparksee.io.NodeTypeExporter , com.sparsity.sparksee.io.NodeTypeLoader , com.sparsity.sparksee.io.TypeExporter , com.sparsity.sparksee.io.TypeLoader
  • SetHeadAttribute() : com.sparsity.sparksee.io.EdgeTypeExporter , com.sparsity.sparksee.io.EdgeTypeLoader
  • SetHeader() : com.sparsity.sparksee.io.EdgeTypeExporter , com.sparsity.sparksee.io.NodeTypeExporter , com.sparsity.sparksee.io.TypeExporter
  • SetHeadMEP() : com.sparsity.sparksee.io.EdgeTypeLoader
  • SetHeadPosition() : com.sparsity.sparksee.io.EdgeTypeExporter , com.sparsity.sparksee.io.EdgeTypeLoader
  • SetHeight() : com.sparsity.sparksee.gdb.NodeExport
  • SetHI() : com.sparsity.sparksee.gdb.SparkseeProperties
  • SetHighAvailabilityCoordinators() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetHighAvailabilityEnabled() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetHighAvailabilityIP() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetHighAvailabilityMasterHistory() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetHighAvailabilitySynchronization() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetInitialPageRankValue() : com.sparsity.sparksee.algorithms.PageRank
  • SetInMemAllocSize() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetInOutParameter() : com.sparsity.sparksee.algorithms.RandomWalk
  • SetInteger() : com.sparsity.sparksee.gdb.Value , com.sparsity.sparksee.gdb.ValueArray
  • SetIntegerVoid() : com.sparsity.sparksee.gdb.Value
  • SetLabel() : com.sparsity.sparksee.gdb.EdgeExport , com.sparsity.sparksee.gdb.GraphExport , com.sparsity.sparksee.gdb.NodeExport
  • SetLabelColor() : com.sparsity.sparksee.gdb.EdgeExport , com.sparsity.sparksee.gdb.NodeExport
  • SetLabelColorRGB() : com.sparsity.sparksee.gdb.EdgeExport , com.sparsity.sparksee.gdb.NodeExport
  • SetLicense() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetLicenseId() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetLicensePreDownloadDays() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetLocale() : com.sparsity.sparksee.io.CSVReader , com.sparsity.sparksee.io.CSVWriter , com.sparsity.sparksee.io.EdgeTypeLoader , com.sparsity.sparksee.io.NodeTypeLoader , com.sparsity.sparksee.io.TypeLoader
  • SetLogError() : com.sparsity.sparksee.io.EdgeTypeLoader , com.sparsity.sparksee.io.NodeTypeLoader , com.sparsity.sparksee.io.TypeLoader
  • SetLogFile() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetLogLevel() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetLogOff() : com.sparsity.sparksee.io.EdgeTypeLoader , com.sparsity.sparksee.io.NodeTypeLoader , com.sparsity.sparksee.io.TypeLoader
  • SetLong() : com.sparsity.sparksee.gdb.Value , com.sparsity.sparksee.gdb.ValueArray
  • SetLongVoid() : com.sparsity.sparksee.gdb.Value
  • SetLookAhead() : com.sparsity.sparksee.algorithms.CommunitiesSCD
  • SetMaterializedAttribute() : com.sparsity.sparksee.algorithms.CommunitiesSCD , com.sparsity.sparksee.algorithms.Connectivity , com.sparsity.sparksee.algorithms.DisjointCommunityDetection , com.sparsity.sparksee.algorithms.StrongConnectivityGabow , com.sparsity.sparksee.algorithms.WeakConnectivity , com.sparsity.sparksee.algorithms.WeakConnectivityDFS , com.sparsity.sparksee.algorithms.StrongConnectivity
  • SetMaximumHops() : com.sparsity.sparksee.algorithms.RandomWalk , com.sparsity.sparksee.algorithms.ShortestPath , com.sparsity.sparksee.algorithms.SinglePairShortestPath , com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS , com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra , com.sparsity.sparksee.algorithms.Traversal , com.sparsity.sparksee.algorithms.TraversalBFS , com.sparsity.sparksee.algorithms.Context , com.sparsity.sparksee.algorithms.TraversalDFS
  • SetMaxIterations() : com.sparsity.sparksee.algorithms.KOpt
  • SetMultilines() : com.sparsity.sparksee.io.CSVReader
  • SetNull() : com.sparsity.sparksee.gdb.Value
  • SetNullVoid() : com.sparsity.sparksee.gdb.Value
  • SetNumIterations() : com.sparsity.sparksee.algorithms.PageRank
  • SetNumLines() : com.sparsity.sparksee.io.CSVReader
  • SetOID() : com.sparsity.sparksee.gdb.ValueArray , com.sparsity.sparksee.gdb.Value , com.sparsity.sparksee.gdb.ValueArray
  • SetOIDVoid() : com.sparsity.sparksee.gdb.Value
  • SetOutputAttributeType() : com.sparsity.sparksee.algorithms.PageRank
  • SetOutputLog() : com.sparsity.sparksee.script.ScriptParser
  • SetPoolFrameSize() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetPoolPartitions() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetPoolPersistentMaxSize() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetPoolPersistentMinSize() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetPoolTemporaryMaxSize() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetPoolTemporaryMinSize() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetQuotes() : com.sparsity.sparksee.io.CSVWriter , com.sparsity.sparksee.io.CSVReader
  • SetRecoveryCacheMaxSize() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetRecoveryCheckpointTime() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetRecoveryEnabled() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetRecoveryLogFile() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetReturnParameter() : com.sparsity.sparksee.algorithms.RandomWalk
  • SetRollbackEnabled() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetRowReader() : com.sparsity.sparksee.io.EdgeTypeLoader , com.sparsity.sparksee.io.TypeLoader , com.sparsity.sparksee.io.NodeTypeLoader
  • SetRowWriter() : com.sparsity.sparksee.io.TypeExporter , com.sparsity.sparksee.io.EdgeTypeExporter , com.sparsity.sparksee.io.NodeTypeExporter
  • SetSeed() : com.sparsity.sparksee.algorithms.RandomWalk
  • SetSeparator() : com.sparsity.sparksee.io.CSVWriter , com.sparsity.sparksee.io.CSVReader
  • SetShape() : com.sparsity.sparksee.gdb.NodeExport
  • SetSingleLine() : com.sparsity.sparksee.io.CSVReader
  • SetSparkseeConfigFile() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetStartingNode() : com.sparsity.sparksee.algorithms.PageRank
  • SetStartLine() : com.sparsity.sparksee.io.CSVReader
  • SetStream() : com.sparsity.sparksee.gdb.Query
  • SetString() : com.sparsity.sparksee.gdb.Value
  • SetStringVoid() : com.sparsity.sparksee.gdb.Value
  • SetTailAttribute() : com.sparsity.sparksee.io.EdgeTypeLoader , com.sparsity.sparksee.io.EdgeTypeExporter
  • SetTailMEP() : com.sparsity.sparksee.io.EdgeTypeLoader
  • SetTailPosition() : com.sparsity.sparksee.io.EdgeTypeLoader , com.sparsity.sparksee.io.EdgeTypeExporter
  • SetTimeLimit() : com.sparsity.sparksee.algorithms.KOpt
  • SetTimestamp() : com.sparsity.sparksee.gdb.Value , com.sparsity.sparksee.gdb.ValueArray , com.sparsity.sparksee.gdb.Value , com.sparsity.sparksee.gdb.ValueArray
  • SetTimestampFormat() : com.sparsity.sparksee.io.EdgeTypeLoader , com.sparsity.sparksee.io.NodeTypeLoader , com.sparsity.sparksee.io.TypeLoader
  • SetTimestampVoid() : com.sparsity.sparksee.gdb.Value
  • SetTmpEnabled() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetTmpFolder() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetTolerance() : com.sparsity.sparksee.algorithms.PageRank
  • SetType() : com.sparsity.sparksee.io.EdgeTypeExporter , com.sparsity.sparksee.io.NodeTypeExporter , com.sparsity.sparksee.io.TypeLoader , com.sparsity.sparksee.io.EdgeTypeLoader , com.sparsity.sparksee.io.TypeExporter , com.sparsity.sparksee.io.NodeTypeLoader
  • SetUnweightedEdgeCost() : com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra
  • SetVoid() : com.sparsity.sparksee.gdb.Value
  • SetWidth() : com.sparsity.sparksee.gdb.NodeExport , com.sparsity.sparksee.gdb.EdgeExport
  • SinglePairShortestPathBFS() : com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS
  • SinglePairShortestPathDijkstra() : com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra
  • Size() : com.sparsity.sparksee.gdb.ValueArray
  • Sparksee() : com.sparsity.sparksee.gdb.Sparksee
  • SparkseeConfig() : com.sparsity.sparksee.gdb.SparkseeConfig
  • Start() : com.sparsity.sparksee.gdb.QueryStream
  • StringList() : com.sparsity.sparksee.gdb.StringList
  • StrongConnectivityGabow() : com.sparsity.sparksee.algorithms.StrongConnectivityGabow


SparkseeNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- t -

  • Tails() : com.sparsity.sparksee.gdb.Graph
  • TailsAndHeads() : com.sparsity.sparksee.gdb.Graph
  • TextStream() : com.sparsity.sparksee.gdb.TextStream
  • TopK() : com.sparsity.sparksee.gdb.Graph
  • ToString() : com.sparsity.sparksee.gdb.Value , com.sparsity.sparksee.gdb.KeyValue
  • TraversalBFS() : com.sparsity.sparksee.algorithms.TraversalBFS
  • TraversalDFS() : com.sparsity.sparksee.algorithms.TraversalDFS
  • TypeList() : com.sparsity.sparksee.gdb.TypeList


SparkseeNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- u -

  • Union() : com.sparsity.sparksee.gdb.Objects


SparkseeNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- v -

  • Value() : com.sparsity.sparksee.gdb.Value
  • ValueList() : com.sparsity.sparksee.gdb.ValueList
  • VerifyChecksums() : com.sparsity.sparksee.gdb.Sparksee
  • Version : com.sparsity.sparksee.gdb.Sparksee


SparkseeNet: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented class members with links to the class documentation for each member:

- w -

  • WeakConnectivityDFS() : com.sparsity.sparksee.algorithms.WeakConnectivityDFS
  • Write() : com.sparsity.sparksee.gdb.TextStream , com.sparsity.sparksee.io.RowWriter , com.sparsity.sparksee.io.CSVWriter
Generated on Thu Feb 24 2022 11:05:33 for SparkseeNet by doxygen 1.8.2


SparkseeNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- a -

  • Add() : com.sparsity.sparksee.gdb.AttributeList , com.sparsity.sparksee.gdb.BooleanList , com.sparsity.sparksee.gdb.Objects , com.sparsity.sparksee.gdb.ValueList , com.sparsity.sparksee.gdb.OIDList , com.sparsity.sparksee.gdb.Int32List , com.sparsity.sparksee.gdb.StringList , com.sparsity.sparksee.gdb.TypeList
  • AddAllEdgeTypes() : com.sparsity.sparksee.algorithms.SinglePairShortestPath , com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS , com.sparsity.sparksee.algorithms.CommunitiesSCD , com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra , com.sparsity.sparksee.algorithms.StrongConnectivity , com.sparsity.sparksee.algorithms.Context , com.sparsity.sparksee.algorithms.StrongConnectivityGabow , com.sparsity.sparksee.algorithms.Traversal , com.sparsity.sparksee.algorithms.DisjointCommunityDetection , com.sparsity.sparksee.algorithms.TraversalBFS , com.sparsity.sparksee.algorithms.TraversalDFS , com.sparsity.sparksee.algorithms.KOpt , com.sparsity.sparksee.algorithms.WeakConnectivity , com.sparsity.sparksee.algorithms.WeakConnectivityDFS , com.sparsity.sparksee.algorithms.PageRank , com.sparsity.sparksee.algorithms.RandomWalk , com.sparsity.sparksee.algorithms.ShortestPath
  • AddAllNodeTypes() : com.sparsity.sparksee.algorithms.PageRank , com.sparsity.sparksee.algorithms.RandomWalk , com.sparsity.sparksee.algorithms.ShortestPath , com.sparsity.sparksee.algorithms.SinglePairShortestPath , com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS , com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra , com.sparsity.sparksee.algorithms.StrongConnectivity , com.sparsity.sparksee.algorithms.StrongConnectivityGabow , com.sparsity.sparksee.algorithms.Traversal , com.sparsity.sparksee.algorithms.TraversalBFS , com.sparsity.sparksee.algorithms.TraversalDFS , com.sparsity.sparksee.algorithms.WeakConnectivity , com.sparsity.sparksee.algorithms.WeakConnectivityDFS , com.sparsity.sparksee.algorithms.CommunitiesSCD , com.sparsity.sparksee.algorithms.CommunityDetection , com.sparsity.sparksee.algorithms.Connectivity , com.sparsity.sparksee.algorithms.Context , com.sparsity.sparksee.algorithms.DisjointCommunityDetection , com.sparsity.sparksee.algorithms.KOpt
  • AddChecksums() : com.sparsity.sparksee.gdb.Sparksee
  • AddEdgeType() : com.sparsity.sparksee.algorithms.StrongConnectivityGabow , com.sparsity.sparksee.algorithms.WeakConnectivityDFS , com.sparsity.sparksee.algorithms.WeakConnectivity , com.sparsity.sparksee.algorithms.TraversalBFS , com.sparsity.sparksee.algorithms.RandomWalk , com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra , com.sparsity.sparksee.algorithms.CommunitiesSCD , com.sparsity.sparksee.algorithms.Context , com.sparsity.sparksee.algorithms.DisjointCommunityDetection , com.sparsity.sparksee.algorithms.KOpt , com.sparsity.sparksee.algorithms.PageRank , com.sparsity.sparksee.algorithms.ShortestPath , com.sparsity.sparksee.algorithms.SinglePairShortestPath , com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS , com.sparsity.sparksee.algorithms.StrongConnectivity , com.sparsity.sparksee.algorithms.Traversal , com.sparsity.sparksee.algorithms.TraversalDFS
  • AddNodeType() : com.sparsity.sparksee.algorithms.SinglePairShortestPath , com.sparsity.sparksee.algorithms.StrongConnectivity , com.sparsity.sparksee.algorithms.Traversal , com.sparsity.sparksee.algorithms.CommunityDetection , com.sparsity.sparksee.algorithms.CommunitiesSCD , com.sparsity.sparksee.algorithms.DisjointCommunityDetection , com.sparsity.sparksee.algorithms.ShortestPath , com.sparsity.sparksee.algorithms.StrongConnectivityGabow , com.sparsity.sparksee.algorithms.Connectivity , com.sparsity.sparksee.algorithms.TraversalDFS , com.sparsity.sparksee.algorithms.TraversalBFS , com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS , com.sparsity.sparksee.algorithms.WeakConnectivity , com.sparsity.sparksee.algorithms.KOpt , com.sparsity.sparksee.algorithms.WeakConnectivityDFS , com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra , com.sparsity.sparksee.algorithms.Context , com.sparsity.sparksee.algorithms.RandomWalk , com.sparsity.sparksee.algorithms.PageRank
  • AddWeightedEdgeType() : com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra
  • Any() : com.sparsity.sparksee.gdb.Objects
  • AsDirected() : com.sparsity.sparksee.gdb.EdgeExport
  • AttributeList() : com.sparsity.sparksee.gdb.AttributeList
Generated on Thu Feb 24 2022 11:05:33 for SparkseeNet by doxygen 1.8.2


SparkseeNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- b -

  • Backup() : com.sparsity.sparksee.gdb.Graph
  • Begin() : com.sparsity.sparksee.gdb.Session
  • BeginUpdate() : com.sparsity.sparksee.gdb.Session
  • BooleanList() : com.sparsity.sparksee.gdb.BooleanList
Generated on Thu Feb 24 2022 11:05:33 for SparkseeNet by doxygen 1.8.2


SparkseeNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- c -

  • CalculateEdgeCost() : com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstraDynamicCost
  • CheckOnlyExistence() : com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS
  • Clear() : com.sparsity.sparksee.gdb.BooleanList , com.sparsity.sparksee.gdb.ResultSetList , com.sparsity.sparksee.gdb.SparkseeProperties , com.sparsity.sparksee.gdb.Int32List , com.sparsity.sparksee.gdb.StringList , com.sparsity.sparksee.gdb.TypeList , com.sparsity.sparksee.gdb.AttributeList , com.sparsity.sparksee.gdb.Objects , com.sparsity.sparksee.gdb.ValueList , com.sparsity.sparksee.gdb.OIDList
  • Close() : com.sparsity.sparksee.algorithms.Context , com.sparsity.sparksee.algorithms.Traversal , com.sparsity.sparksee.gdb.ValueArray , com.sparsity.sparksee.io.CSVReader , com.sparsity.sparksee.gdb.Values , com.sparsity.sparksee.gdb.ValuesIterator , com.sparsity.sparksee.io.CSVWriter , com.sparsity.sparksee.gdb.Database , com.sparsity.sparksee.algorithms.DisjointCommunities , com.sparsity.sparksee.gdb.KeyValues , com.sparsity.sparksee.algorithms.KOpt , com.sparsity.sparksee.gdb.Objects , com.sparsity.sparksee.gdb.ObjectsIterator , com.sparsity.sparksee.algorithms.PageRank , com.sparsity.sparksee.algorithms.CommunityDetection , com.sparsity.sparksee.io.RowReader , com.sparsity.sparksee.io.RowWriter , com.sparsity.sparksee.algorithms.ConnectedComponents , com.sparsity.sparksee.gdb.Session , com.sparsity.sparksee.algorithms.ShortestPath , com.sparsity.sparksee.algorithms.Connectivity , com.sparsity.sparksee.gdb.Sparksee , com.sparsity.sparksee.gdb.TextStream
  • CombineDifference() : com.sparsity.sparksee.gdb.Objects
  • CombineIntersection() : com.sparsity.sparksee.gdb.Objects
  • CombineUnion() : com.sparsity.sparksee.gdb.Objects
  • Commit() : com.sparsity.sparksee.gdb.Session
  • CommunitiesSCD() : com.sparsity.sparksee.algorithms.CommunitiesSCD
  • Compare() : com.sparsity.sparksee.gdb.Value
  • CompareTo() : com.sparsity.sparksee.gdb.KeyValue , com.sparsity.sparksee.gdb.Value , com.sparsity.sparksee.gdb.KeyValue
  • Compute() : com.sparsity.sparksee.algorithms.Context
  • ConnectedComponents() : com.sparsity.sparksee.algorithms.ConnectedComponents
  • Contains() : com.sparsity.sparksee.gdb.Objects
  • Context() : com.sparsity.sparksee.algorithms.Context
  • Copy() : com.sparsity.sparksee.gdb.Objects
  • Count() : com.sparsity.sparksee.gdb.BooleanList , com.sparsity.sparksee.gdb.Values , com.sparsity.sparksee.gdb.ResultSetList , com.sparsity.sparksee.gdb.Int32List , com.sparsity.sparksee.gdb.OIDList , com.sparsity.sparksee.gdb.Objects , com.sparsity.sparksee.gdb.AttributeList , com.sparsity.sparksee.gdb.TypeList , com.sparsity.sparksee.gdb.ValueList , com.sparsity.sparksee.gdb.StringList
  • CountEdges() : com.sparsity.sparksee.gdb.Graph
  • CountNodes() : com.sparsity.sparksee.gdb.Graph
  • Create() : com.sparsity.sparksee.gdb.Sparksee
  • CSVReader() : com.sparsity.sparksee.io.CSVReader
  • CSVWriter() : com.sparsity.sparksee.io.CSVWriter
Generated on Thu Feb 24 2022 11:05:33 for SparkseeNet by doxygen 1.8.2


SparkseeNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- d -

  • Decrypt() : com.sparsity.sparksee.gdb.Sparksee
  • DefaultExport() : com.sparsity.sparksee.gdb.DefaultExport
  • Degree() : com.sparsity.sparksee.gdb.Graph
  • Difference() : com.sparsity.sparksee.gdb.Objects
  • DisableRollback() : com.sparsity.sparksee.gdb.Database
  • DisjointCommunities() : com.sparsity.sparksee.algorithms.DisjointCommunities
  • DownloadExpected() : com.sparsity.sparksee.gdb.SparkseeConfig
  • DownloadLicense() : com.sparsity.sparksee.gdb.SparkseeConfig
  • Drop() : com.sparsity.sparksee.gdb.Graph
  • DumpData() : com.sparsity.sparksee.gdb.Graph
  • DumpSchema() : com.sparsity.sparksee.gdb.Database
  • DumpStorage() : com.sparsity.sparksee.gdb.Graph
Generated on Thu Feb 24 2022 11:05:33 for SparkseeNet by doxygen 1.8.2


SparkseeNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- e -

  • EdgeExport() : com.sparsity.sparksee.gdb.EdgeExport
  • Edges() : com.sparsity.sparksee.gdb.Graph
  • EdgeTypeExporter() : com.sparsity.sparksee.io.EdgeTypeExporter
  • EdgeTypeLoader() : com.sparsity.sparksee.io.EdgeTypeLoader
  • EnableRollback() : com.sparsity.sparksee.gdb.Database
  • EnableType() : com.sparsity.sparksee.gdb.DefaultExport , com.sparsity.sparksee.gdb.ExportManager
  • Encrypt() : com.sparsity.sparksee.gdb.Sparksee
  • EncryptedBackup() : com.sparsity.sparksee.gdb.Graph
  • Equals() : com.sparsity.sparksee.gdb.Value , com.sparsity.sparksee.gdb.KeyValue , com.sparsity.sparksee.gdb.Objects , com.sparsity.sparksee.gdb.Value
  • ExcludeEdges() : com.sparsity.sparksee.algorithms.WeakConnectivity , com.sparsity.sparksee.algorithms.WeakConnectivityDFS , com.sparsity.sparksee.algorithms.CommunitiesSCD , com.sparsity.sparksee.algorithms.CommunityDetection , com.sparsity.sparksee.algorithms.Connectivity , com.sparsity.sparksee.algorithms.Context , com.sparsity.sparksee.algorithms.DisjointCommunityDetection , com.sparsity.sparksee.algorithms.RandomWalk , com.sparsity.sparksee.algorithms.ShortestPath , com.sparsity.sparksee.algorithms.SinglePairShortestPath , com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS , com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra , com.sparsity.sparksee.algorithms.TraversalDFS , com.sparsity.sparksee.algorithms.StrongConnectivity , com.sparsity.sparksee.algorithms.StrongConnectivityGabow , com.sparsity.sparksee.algorithms.Traversal , com.sparsity.sparksee.algorithms.TraversalBFS
  • ExcludeNodes() : com.sparsity.sparksee.algorithms.CommunityDetection , com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra , com.sparsity.sparksee.algorithms.WeakConnectivity , com.sparsity.sparksee.algorithms.DisjointCommunityDetection , com.sparsity.sparksee.algorithms.StrongConnectivity , com.sparsity.sparksee.algorithms.WeakConnectivityDFS , com.sparsity.sparksee.algorithms.CommunitiesSCD , com.sparsity.sparksee.algorithms.SinglePairShortestPath , com.sparsity.sparksee.algorithms.Connectivity , com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS , com.sparsity.sparksee.algorithms.RandomWalk , com.sparsity.sparksee.algorithms.StrongConnectivityGabow , com.sparsity.sparksee.algorithms.ShortestPath , com.sparsity.sparksee.algorithms.Context , com.sparsity.sparksee.algorithms.TraversalDFS , com.sparsity.sparksee.algorithms.TraversalBFS , com.sparsity.sparksee.algorithms.Traversal
  • Execute() : com.sparsity.sparksee.gdb.Query
  • Exists() : com.sparsity.sparksee.algorithms.SinglePairShortestPath , com.sparsity.sparksee.gdb.Objects , com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS , com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra
  • Explode() : com.sparsity.sparksee.gdb.Graph
  • Export() : com.sparsity.sparksee.gdb.Graph
Generated on Thu Feb 24 2022 11:05:33 for SparkseeNet by doxygen 1.8.2


SparkseeNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- f -

  • Fetch() : com.sparsity.sparksee.gdb.QueryStream
  • FindAttribute() : com.sparsity.sparksee.gdb.Graph
  • FindAttributes() : com.sparsity.sparksee.gdb.Graph
  • FindEdge() : com.sparsity.sparksee.gdb.Graph
  • FindEdgeTypes() : com.sparsity.sparksee.gdb.Graph
  • FindNodeTypes() : com.sparsity.sparksee.gdb.Graph
  • FindObject() : com.sparsity.sparksee.gdb.Graph
  • FindOrCreateEdge() : com.sparsity.sparksee.gdb.Graph
  • FindOrCreateObject() : com.sparsity.sparksee.gdb.Graph
  • FindType() : com.sparsity.sparksee.gdb.Graph
  • FindTypes() : com.sparsity.sparksee.gdb.Graph
  • FixCurrentCacheMaxSize() : com.sparsity.sparksee.gdb.Database
Generated on Thu Feb 24 2022 11:05:33 for SparkseeNet by doxygen 1.8.2


SparkseeNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- g -

  • GenerateSchemaScript() : com.sparsity.sparksee.script.ScriptParser
  • Get() : com.sparsity.sparksee.gdb.ResultSetList , com.sparsity.sparksee.gdb.ValueArray , com.sparsity.sparksee.gdb.ValueList , com.sparsity.sparksee.gdb.SparkseeProperties
  • GetAESIV() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetAESKey() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetAlias() : com.sparsity.sparksee.gdb.Database
  • GetAreNeighborsIndexed() : com.sparsity.sparksee.gdb.Type
  • GetArrayAttribute() : com.sparsity.sparksee.gdb.Graph
  • GetArraySize() : com.sparsity.sparksee.gdb.Attribute
  • GetAttribute() : com.sparsity.sparksee.gdb.Graph
  • GetAttributeIntervalCount() : com.sparsity.sparksee.gdb.Graph
  • GetAttributes() : com.sparsity.sparksee.gdb.Graph
  • GetAttributeStatistics() : com.sparsity.sparksee.gdb.Graph
  • GetAttributeText() : com.sparsity.sparksee.gdb.Graph
  • GetAvailableMem() : com.sparsity.sparksee.gdb.PlatformStatistics
  • GetAvgLengthString() : com.sparsity.sparksee.gdb.AttributeStatistics
  • GetBoolean() : com.sparsity.sparksee.gdb.SparkseeProperties , com.sparsity.sparksee.gdb.Value , com.sparsity.sparksee.gdb.ValueArray
  • GetCache() : com.sparsity.sparksee.gdb.DatabaseStatistics
  • GetCacheMaxSize() : com.sparsity.sparksee.gdb.Database , com.sparsity.sparksee.gdb.SparkseeConfig
  • GetCacheStatisticsEnabled() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetCacheStatisticsFile() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetCacheStatisticsSnapshotTime() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetCallStackDump() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetChecksumEnabled() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetClientId() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetColor() : com.sparsity.sparksee.gdb.EdgeExport , com.sparsity.sparksee.gdb.NodeExport
  • GetColorRGB() : com.sparsity.sparksee.gdb.EdgeExport , com.sparsity.sparksee.gdb.NodeExport
  • GetColumn() : com.sparsity.sparksee.gdb.ResultSet
  • GetColumnDataType() : com.sparsity.sparksee.gdb.ResultSet
  • GetColumnIndex() : com.sparsity.sparksee.gdb.ResultSet
  • GetColumnName() : com.sparsity.sparksee.gdb.ResultSet
  • GetCommunities() : com.sparsity.sparksee.algorithms.CommunitiesSCD , com.sparsity.sparksee.algorithms.DisjointCommunityDetection
  • GetCommunity() : com.sparsity.sparksee.algorithms.DisjointCommunities
  • GetConnectedComponent() : com.sparsity.sparksee.algorithms.ConnectedComponents
  • GetConnectedComponents() : com.sparsity.sparksee.algorithms.Connectivity , com.sparsity.sparksee.algorithms.StrongConnectivity , com.sparsity.sparksee.algorithms.StrongConnectivityGabow , com.sparsity.sparksee.algorithms.WeakConnectivity , com.sparsity.sparksee.algorithms.WeakConnectivityDFS
  • GetCost() : com.sparsity.sparksee.algorithms.SinglePairShortestPath , com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS , com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra
  • GetCount() : com.sparsity.sparksee.gdb.Attribute , com.sparsity.sparksee.algorithms.ConnectedComponents , com.sparsity.sparksee.algorithms.DisjointCommunities , com.sparsity.sparksee.io.TypeExporterEvent , com.sparsity.sparksee.io.TypeLoaderEvent
  • GetCurrentCost() : com.sparsity.sparksee.algorithms.KOpt
  • GetCurrentDepth() : com.sparsity.sparksee.algorithms.TraversalDFS , com.sparsity.sparksee.algorithms.RandomWalk , com.sparsity.sparksee.algorithms.Traversal , com.sparsity.sparksee.algorithms.TraversalBFS
  • GetCurrentTour() : com.sparsity.sparksee.algorithms.KOpt
  • GetData() : com.sparsity.sparksee.gdb.DatabaseStatistics
  • GetDataType() : com.sparsity.sparksee.gdb.Attribute , com.sparsity.sparksee.gdb.Value
  • GetDistinct() : com.sparsity.sparksee.gdb.AttributeStatistics
  • GetDouble() : com.sparsity.sparksee.gdb.Value , com.sparsity.sparksee.gdb.ValueArray
  • GetDownloadStatus() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetEdge() : com.sparsity.sparksee.gdb.DefaultExport , com.sparsity.sparksee.gdb.EdgeData , com.sparsity.sparksee.gdb.ExportManager
  • GetEdgeData() : com.sparsity.sparksee.gdb.Graph
  • GetEdgePeer() : com.sparsity.sparksee.gdb.Graph
  • GetEdgeType() : com.sparsity.sparksee.gdb.DefaultExport , com.sparsity.sparksee.gdb.ExportManager
  • GetEncryptionEnabled() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetExtentPages() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetExtentSize() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetFontSize() : com.sparsity.sparksee.gdb.EdgeExport , com.sparsity.sparksee.gdb.NodeExport
  • GetGraph() : com.sparsity.sparksee.gdb.DefaultExport , com.sparsity.sparksee.gdb.ExportManager , com.sparsity.sparksee.gdb.Session
  • GetHead() : com.sparsity.sparksee.gdb.EdgeData
  • GetHeight() : com.sparsity.sparksee.gdb.NodeExport
  • GetHighAvailabilityCoordinators() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetHighAvailabilityEnabled() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetHighAvailabilityIP() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetHighAvailabilityMasterHistory() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetHighAvailabilitySynchronization() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetId() : com.sparsity.sparksee.gdb.Attribute , com.sparsity.sparksee.gdb.Type
  • GetInMemAllocSize() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetInMemoryPoolCapacity() : com.sparsity.sparksee.gdb.Session , com.sparsity.sparksee.gdb.Sparksee
  • GetInteger() : com.sparsity.sparksee.gdb.SparkseeProperties , com.sparsity.sparksee.gdb.Value , com.sparsity.sparksee.gdb.ValueArray
  • GetIsDirected() : com.sparsity.sparksee.gdb.Type
  • GetIsRestricted() : com.sparsity.sparksee.gdb.Type
  • GetJSON() : com.sparsity.sparksee.gdb.ResultSet
  • GetKind() : com.sparsity.sparksee.gdb.Attribute
  • GetLabel() : com.sparsity.sparksee.gdb.NodeExport , com.sparsity.sparksee.gdb.EdgeExport , com.sparsity.sparksee.gdb.GraphExport
  • GetLabelColor() : com.sparsity.sparksee.gdb.EdgeExport , com.sparsity.sparksee.gdb.NodeExport
  • GetLabelColorRGB() : com.sparsity.sparksee.gdb.EdgeExport , com.sparsity.sparksee.gdb.NodeExport
  • GetLicense() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetLicenseId() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetLicensePreDownloadDays() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetLicenseRequest() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetLogFile() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetLogLevel() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetLong() : com.sparsity.sparksee.gdb.ValueArray , com.sparsity.sparksee.gdb.Value , com.sparsity.sparksee.gdb.ValueArray
  • GetMax() : com.sparsity.sparksee.gdb.AttributeStatistics
  • GetMaxLengthString() : com.sparsity.sparksee.gdb.AttributeStatistics
  • GetMean() : com.sparsity.sparksee.gdb.AttributeStatistics
  • GetMedian() : com.sparsity.sparksee.gdb.AttributeStatistics
  • GetMin() : com.sparsity.sparksee.gdb.AttributeStatistics
  • GetMinLengthString() : com.sparsity.sparksee.gdb.AttributeStatistics
  • GetMode() : com.sparsity.sparksee.gdb.AttributeStatistics
  • GetModeCount() : com.sparsity.sparksee.gdb.AttributeStatistics
  • GetName() : com.sparsity.sparksee.gdb.Attribute , com.sparsity.sparksee.gdb.Type
  • GetNode() : com.sparsity.sparksee.gdb.DefaultExport , com.sparsity.sparksee.gdb.ExportManager
  • GetNodes() : com.sparsity.sparksee.algorithms.ConnectedComponents , com.sparsity.sparksee.algorithms.DisjointCommunities
  • GetNodeType() : com.sparsity.sparksee.gdb.ExportManager , com.sparsity.sparksee.gdb.DefaultExport
  • GetNull() : com.sparsity.sparksee.gdb.AttributeStatistics
  • GetNumColumns() : com.sparsity.sparksee.gdb.ResultSet
  • GetNumCPUs() : com.sparsity.sparksee.gdb.PlatformStatistics
  • GetNumObjects() : com.sparsity.sparksee.gdb.Type
  • GetObjectType() : com.sparsity.sparksee.gdb.Type , com.sparsity.sparksee.gdb.Graph
  • GetOID() : com.sparsity.sparksee.gdb.Value , com.sparsity.sparksee.gdb.ValueArray
  • GetPartition() : com.sparsity.sparksee.io.TypeLoaderEvent
  • GetPath() : com.sparsity.sparksee.gdb.Database
  • GetPathAsEdges() : com.sparsity.sparksee.algorithms.SinglePairShortestPath , com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra , com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS
  • GetPathAsNodes() : com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS , com.sparsity.sparksee.algorithms.SinglePairShortestPath , com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra
  • GetPhase() : com.sparsity.sparksee.io.TypeLoaderEvent
  • GetPoolFrameSize() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetPoolPartitions() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetPoolPersistentMaxSize() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetPoolPersistentMinSize() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetPoolTemporaryMaxSize() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetPoolTemporaryMinSize() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetRead() : com.sparsity.sparksee.gdb.DatabaseStatistics
  • GetRealTime() : com.sparsity.sparksee.gdb.PlatformStatistics
  • GetRecoveryCacheMaxSize() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetRecoveryCheckpointTime() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetRecoveryEnabled() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetRecoveryLogFile() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetRestrictedFrom() : com.sparsity.sparksee.gdb.Type
  • GetRestrictedTo() : com.sparsity.sparksee.gdb.Type
  • GetRollbackEnabled() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetRow() : com.sparsity.sparksee.io.RowReader , com.sparsity.sparksee.io.CSVReader
  • GetSessions() : com.sparsity.sparksee.gdb.DatabaseStatistics
  • GetShape() : com.sparsity.sparksee.gdb.NodeExport
  • GetSize() : com.sparsity.sparksee.algorithms.ConnectedComponents , com.sparsity.sparksee.gdb.Attribute , com.sparsity.sparksee.algorithms.DisjointCommunities
  • GetSparkseeConfigFile() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetStatistics() : com.sparsity.sparksee.gdb.Platform , com.sparsity.sparksee.gdb.Database
  • GetString() : com.sparsity.sparksee.gdb.Value
  • GetSystemTime() : com.sparsity.sparksee.gdb.PlatformStatistics
  • GetTail() : com.sparsity.sparksee.gdb.EdgeData
  • GetTemp() : com.sparsity.sparksee.gdb.DatabaseStatistics
  • GetTimestamp() : com.sparsity.sparksee.gdb.ValueArray , com.sparsity.sparksee.gdb.Value , com.sparsity.sparksee.gdb.ValueArray
  • GetTimestampAsDateTime() : com.sparsity.sparksee.gdb.Value
  • GetTimeUnit() : com.sparsity.sparksee.gdb.SparkseeProperties
  • GetTmpEnabled() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetTmpFolder() : com.sparsity.sparksee.gdb.SparkseeConfig
  • GetTotal() : com.sparsity.sparksee.gdb.AttributeStatistics , com.sparsity.sparksee.io.TypeExporterEvent
  • GetTotalMem() : com.sparsity.sparksee.gdb.PlatformStatistics
  • GetTotalPartitions() : com.sparsity.sparksee.io.TypeLoaderEvent
  • GetTotalPartitionSteps() : com.sparsity.sparksee.io.TypeLoaderEvent
  • GetTotalPhases() : com.sparsity.sparksee.io.TypeLoaderEvent
  • GetType() : com.sparsity.sparksee.gdb.Graph
  • GetTypeId() : com.sparsity.sparksee.gdb.Attribute , com.sparsity.sparksee.io.TypeLoaderEvent , com.sparsity.sparksee.io.TypeExporterEvent
  • GetUserTime() : com.sparsity.sparksee.gdb.PlatformStatistics
  • GetValues() : com.sparsity.sparksee.gdb.Graph
  • GetVariance() : com.sparsity.sparksee.gdb.AttributeStatistics
  • GetWidth() : com.sparsity.sparksee.gdb.EdgeExport , com.sparsity.sparksee.gdb.NodeExport
  • GetWrite() : com.sparsity.sparksee.gdb.DatabaseStatistics
  • GraphExport() : com.sparsity.sparksee.gdb.GraphExport
Generated on Thu Feb 24 2022 11:05:33 for SparkseeNet by doxygen 1.8.2


SparkseeNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- h -

  • HasNext() : com.sparsity.sparksee.gdb.AttributeListIterator , com.sparsity.sparksee.gdb.BooleanListIterator , com.sparsity.sparksee.gdb.ValuesIterator , com.sparsity.sparksee.gdb.ValueListIterator , com.sparsity.sparksee.gdb.TypeListIterator , com.sparsity.sparksee.algorithms.TraversalDFS , com.sparsity.sparksee.algorithms.TraversalBFS , com.sparsity.sparksee.algorithms.Traversal , com.sparsity.sparksee.gdb.StringListIterator , com.sparsity.sparksee.gdb.KeyValues , com.sparsity.sparksee.algorithms.RandomWalk , com.sparsity.sparksee.gdb.OIDListIterator , com.sparsity.sparksee.gdb.ObjectsIterator , com.sparsity.sparksee.gdb.ResultSetListIterator , com.sparsity.sparksee.gdb.Int32ListIterator
  • Heads() : com.sparsity.sparksee.gdb.Graph
Generated on Thu Feb 24 2022 11:05:33 for SparkseeNet by doxygen 1.8.2


SparkseeNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- i -

  • IncludeEdges() : com.sparsity.sparksee.algorithms.CommunitiesSCD , com.sparsity.sparksee.algorithms.CommunityDetection , com.sparsity.sparksee.algorithms.DisjointCommunityDetection
  • IncludeNodes() : com.sparsity.sparksee.algorithms.CommunitiesSCD , com.sparsity.sparksee.algorithms.CommunityDetection , com.sparsity.sparksee.algorithms.DisjointCommunityDetection
  • IndexAttribute() : com.sparsity.sparksee.gdb.Graph
  • IndexNeighbors() : com.sparsity.sparksee.gdb.Graph
  • Int32List() : com.sparsity.sparksee.gdb.Int32List
  • Intersection() : com.sparsity.sparksee.gdb.Objects
  • IsArrayAttribute() : com.sparsity.sparksee.gdb.Attribute
  • IsClosed() : com.sparsity.sparksee.algorithms.Connectivity , com.sparsity.sparksee.algorithms.Context , com.sparsity.sparksee.gdb.Database , com.sparsity.sparksee.algorithms.DisjointCommunities , com.sparsity.sparksee.gdb.KeyValues , com.sparsity.sparksee.algorithms.KOpt , com.sparsity.sparksee.gdb.ValuesIterator , com.sparsity.sparksee.gdb.Values , com.sparsity.sparksee.gdb.ValueArray , com.sparsity.sparksee.gdb.Objects , com.sparsity.sparksee.gdb.Sparksee , com.sparsity.sparksee.gdb.ObjectsIterator , com.sparsity.sparksee.algorithms.PageRank , com.sparsity.sparksee.gdb.Session , com.sparsity.sparksee.algorithms.ShortestPath , com.sparsity.sparksee.algorithms.CommunityDetection , com.sparsity.sparksee.algorithms.Traversal , com.sparsity.sparksee.algorithms.ConnectedComponents
  • IsFit() : com.sparsity.sparksee.gdb.NodeExport
  • IsLast() : com.sparsity.sparksee.io.TypeExporterEvent , com.sparsity.sparksee.io.TypeLoaderEvent
  • IsNull() : com.sparsity.sparksee.gdb.TextStream , com.sparsity.sparksee.gdb.Value
  • IsSessionAttribute() : com.sparsity.sparksee.gdb.Attribute
  • Iterator() : com.sparsity.sparksee.gdb.BooleanList , com.sparsity.sparksee.gdb.Int32List , com.sparsity.sparksee.gdb.OIDList , com.sparsity.sparksee.gdb.ResultSetList , com.sparsity.sparksee.gdb.ValueList , com.sparsity.sparksee.gdb.StringList , com.sparsity.sparksee.gdb.Objects , com.sparsity.sparksee.gdb.AttributeList , com.sparsity.sparksee.gdb.TypeList , com.sparsity.sparksee.gdb.Values
  • IteratorFromElement() : com.sparsity.sparksee.gdb.Objects
  • IteratorFromIndex() : com.sparsity.sparksee.gdb.Objects
Generated on Thu Feb 24 2022 11:05:33 for SparkseeNet by doxygen 1.8.2


SparkseeNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- k -

  • KOpt() : com.sparsity.sparksee.algorithms.KOpt
Generated on Thu Feb 24 2022 11:05:33 for SparkseeNet by doxygen 1.8.2


SparkseeNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- l -

  • Load() : com.sparsity.sparksee.gdb.SparkseeProperties
  • LoadEdges() : com.sparsity.sparksee.io.CSVLoader
  • LoadNodes() : com.sparsity.sparksee.io.CSVLoader
Generated on Thu Feb 24 2022 11:05:33 for SparkseeNet by doxygen 1.8.2


SparkseeNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- m -

  • Main() : com.sparsity.sparksee.script.ScriptParser
  • MakeNull() : com.sparsity.sparksee.gdb.ValueArray
Generated on Thu Feb 24 2022 11:05:33 for SparkseeNet by doxygen 1.8.2


SparkseeNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- n -

  • Neighbors() : com.sparsity.sparksee.gdb.Graph
  • NewArrayAttribute() : com.sparsity.sparksee.gdb.Graph
  • NewAttribute() : com.sparsity.sparksee.gdb.Graph
  • NewEdge() : com.sparsity.sparksee.gdb.Graph
  • NewEdgeType() : com.sparsity.sparksee.gdb.Graph
  • NewNode() : com.sparsity.sparksee.gdb.Graph
  • NewNodeType() : com.sparsity.sparksee.gdb.Graph
  • NewObjects() : com.sparsity.sparksee.gdb.Session
  • NewQuery() : com.sparsity.sparksee.gdb.QueryContext , com.sparsity.sparksee.gdb.Session
  • NewRestrictedEdgeType() : com.sparsity.sparksee.gdb.Graph
  • NewSession() : com.sparsity.sparksee.gdb.Database
  • NewSessionArrayAttribute() : com.sparsity.sparksee.gdb.Graph
  • NewSessionAttribute() : com.sparsity.sparksee.gdb.Graph
  • Next() : com.sparsity.sparksee.gdb.ResultSet , com.sparsity.sparksee.gdb.TypeListIterator , com.sparsity.sparksee.gdb.KeyValues , com.sparsity.sparksee.algorithms.TraversalDFS , com.sparsity.sparksee.gdb.ValueListIterator , com.sparsity.sparksee.gdb.AttributeListIterator , com.sparsity.sparksee.gdb.BooleanListIterator , com.sparsity.sparksee.gdb.Int32ListIterator , com.sparsity.sparksee.gdb.ValuesIterator , com.sparsity.sparksee.algorithms.TraversalBFS , com.sparsity.sparksee.gdb.ResultSetListIterator , com.sparsity.sparksee.algorithms.RandomWalk , com.sparsity.sparksee.gdb.OIDListIterator , com.sparsity.sparksee.gdb.StringListIterator , com.sparsity.sparksee.gdb.ObjectsIterator , com.sparsity.sparksee.algorithms.Traversal
  • NodeExport() : com.sparsity.sparksee.gdb.NodeExport
  • NodeTypeExporter() : com.sparsity.sparksee.io.NodeTypeExporter
  • NodeTypeLoader() : com.sparsity.sparksee.io.NodeTypeLoader
  • NotifyEvent() : com.sparsity.sparksee.io.TypeExporterListener , com.sparsity.sparksee.io.TypeLoaderListener
Generated on Thu Feb 24 2022 11:05:33 for SparkseeNet by doxygen 1.8.2


SparkseeNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- o -

  • OIDList() : com.sparsity.sparksee.gdb.OIDList
  • Open() : com.sparsity.sparksee.io.CSVReader , com.sparsity.sparksee.gdb.Sparksee , com.sparsity.sparksee.io.CSVWriter , com.sparsity.sparksee.gdb.Sparksee
Generated on Thu Feb 24 2022 11:05:33 for SparkseeNet by doxygen 1.8.2


SparkseeNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- p -

  • PageRank() : com.sparsity.sparksee.algorithms.PageRank
  • Parse() : com.sparsity.sparksee.script.ScriptParser
  • PlatformStatistics() : com.sparsity.sparksee.gdb.PlatformStatistics
  • PreCommit() : com.sparsity.sparksee.gdb.Session
  • Prepare() : com.sparsity.sparksee.gdb.QueryStream , com.sparsity.sparksee.gdb.ExportManager , com.sparsity.sparksee.gdb.DefaultExport
Generated on Thu Feb 24 2022 11:05:33 for SparkseeNet by doxygen 1.8.2


SparkseeNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- q -

  • QueryContext() : com.sparsity.sparksee.gdb.QueryContext
Generated on Thu Feb 24 2022 11:05:33 for SparkseeNet by doxygen 1.8.2


SparkseeNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- r -

  • RandomWalk() : com.sparsity.sparksee.algorithms.RandomWalk
  • Read() : com.sparsity.sparksee.io.CSVReader , com.sparsity.sparksee.gdb.TextStream , com.sparsity.sparksee.io.RowReader
  • RedoPrecommitted() : com.sparsity.sparksee.gdb.Database
  • Register() : com.sparsity.sparksee.io.NodeTypeExporter , com.sparsity.sparksee.io.NodeTypeLoader , com.sparsity.sparksee.io.TypeExporter , com.sparsity.sparksee.io.TypeLoader , com.sparsity.sparksee.io.EdgeTypeExporter , com.sparsity.sparksee.io.EdgeTypeLoader
  • Release() : com.sparsity.sparksee.gdb.DefaultExport , com.sparsity.sparksee.gdb.ExportManager
  • Remove() : com.sparsity.sparksee.gdb.Objects
  • RemoveAttribute() : com.sparsity.sparksee.gdb.Graph
  • RemoveChecksums() : com.sparsity.sparksee.gdb.Sparksee
  • RemoveType() : com.sparsity.sparksee.gdb.Graph
  • RenameAttribute() : com.sparsity.sparksee.gdb.Graph
  • RenameType() : com.sparsity.sparksee.gdb.Graph
  • Reset() : com.sparsity.sparksee.io.CSVReader , com.sparsity.sparksee.algorithms.RandomWalk , com.sparsity.sparksee.io.RowReader
  • ResizeInMemoryPool() : com.sparsity.sparksee.gdb.Sparksee
  • Restore() : com.sparsity.sparksee.gdb.Sparksee
  • RestoreEncryptedBackup() : com.sparsity.sparksee.gdb.Sparksee
  • ResultSetList() : com.sparsity.sparksee.gdb.ResultSetList
  • Rewind() : com.sparsity.sparksee.gdb.ResultSet
  • Rollback() : com.sparsity.sparksee.gdb.Session
  • Run() : com.sparsity.sparksee.io.EdgeTypeLoader , com.sparsity.sparksee.algorithms.CommunitiesSCD , com.sparsity.sparksee.algorithms.WeakConnectivity , com.sparsity.sparksee.algorithms.CommunityDetection , com.sparsity.sparksee.algorithms.Connectivity , com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS , com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra , com.sparsity.sparksee.algorithms.SinglePairShortestPath , com.sparsity.sparksee.io.EdgeTypeExporter , com.sparsity.sparksee.io.NodeTypeExporter , com.sparsity.sparksee.algorithms.ShortestPath , com.sparsity.sparksee.algorithms.PageRank , com.sparsity.sparksee.io.NodeTypeLoader , com.sparsity.sparksee.io.TypeExporter , com.sparsity.sparksee.algorithms.StrongConnectivityGabow , com.sparsity.sparksee.algorithms.DisjointCommunityDetection , com.sparsity.sparksee.algorithms.StrongConnectivity , com.sparsity.sparksee.io.TypeLoader , com.sparsity.sparksee.algorithms.WeakConnectivityDFS
  • RunNPhases() : com.sparsity.sparksee.io.TypeLoader , com.sparsity.sparksee.io.NodeTypeLoader , com.sparsity.sparksee.io.EdgeTypeLoader
  • RunThreeOpt() : com.sparsity.sparksee.algorithms.KOpt
  • RunTwoOpt() : com.sparsity.sparksee.algorithms.KOpt
  • RunTwoPhases() : com.sparsity.sparksee.io.EdgeTypeLoader , com.sparsity.sparksee.io.TypeLoader , com.sparsity.sparksee.io.NodeTypeLoader
Generated on Thu Feb 24 2022 11:05:33 for SparkseeNet by doxygen 1.8.2


SparkseeNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- s -

  • Sample() : com.sparsity.sparksee.gdb.Objects
  • Save() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SaveAll() : com.sparsity.sparksee.gdb.SparkseeConfig
  • ScriptParser() : com.sparsity.sparksee.script.ScriptParser
  • Select() : com.sparsity.sparksee.gdb.Graph
  • Set() : com.sparsity.sparksee.gdb.OIDList , com.sparsity.sparksee.gdb.Value , com.sparsity.sparksee.gdb.ValueArray
  • SetAESEncryptionEnabled() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetArrayAttribute() : com.sparsity.sparksee.gdb.Graph
  • SetArrayAttributeVoid() : com.sparsity.sparksee.gdb.Graph
  • SetAsDirected() : com.sparsity.sparksee.gdb.EdgeExport
  • SetAttribute() : com.sparsity.sparksee.gdb.Graph
  • SetAttributeDefaultValue() : com.sparsity.sparksee.gdb.Graph
  • SetAttributePositions() : com.sparsity.sparksee.io.EdgeTypeLoader , com.sparsity.sparksee.io.NodeTypeLoader , com.sparsity.sparksee.io.TypeLoader
  • SetAttributes() : com.sparsity.sparksee.io.EdgeTypeExporter , com.sparsity.sparksee.io.EdgeTypeLoader , com.sparsity.sparksee.io.NodeTypeExporter , com.sparsity.sparksee.io.NodeTypeLoader , com.sparsity.sparksee.io.TypeExporter , com.sparsity.sparksee.io.TypeLoader
  • SetAttributeText() : com.sparsity.sparksee.gdb.Graph
  • SetAutoQuotes() : com.sparsity.sparksee.io.CSVWriter
  • SetBoolean() : com.sparsity.sparksee.gdb.Value , com.sparsity.sparksee.gdb.ValueArray
  • SetBooleanVoid() : com.sparsity.sparksee.gdb.Value
  • SetCacheMaxSize() : com.sparsity.sparksee.gdb.Database , com.sparsity.sparksee.gdb.SparkseeConfig
  • SetCacheStatisticsEnabled() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetCacheStatisticsFile() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetCacheStatisticsSnapshotTime() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetCallStackDump() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetChecksumEnabled() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetClientId() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetColor() : com.sparsity.sparksee.gdb.EdgeExport , com.sparsity.sparksee.gdb.NodeExport
  • SetColorRGB() : com.sparsity.sparksee.gdb.EdgeExport , com.sparsity.sparksee.gdb.NodeExport
  • SetCurrentTour() : com.sparsity.sparksee.algorithms.KOpt
  • SetDamping() : com.sparsity.sparksee.algorithms.PageRank
  • SetDefaults() : com.sparsity.sparksee.gdb.EdgeExport , com.sparsity.sparksee.gdb.GraphExport , com.sparsity.sparksee.gdb.NodeExport
  • SetDefaultWeight() : com.sparsity.sparksee.algorithms.PageRank , com.sparsity.sparksee.algorithms.RandomWalk
  • SetDouble() : com.sparsity.sparksee.gdb.Value , com.sparsity.sparksee.gdb.ValueArray
  • SetDoubleVoid() : com.sparsity.sparksee.gdb.Value
  • SetDynamic() : com.sparsity.sparksee.gdb.Query
  • SetDynamicEdgeCostCallback() : com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra
  • SetEdgeWeightAttributeType() : com.sparsity.sparksee.algorithms.PageRank , com.sparsity.sparksee.algorithms.RandomWalk , com.sparsity.sparksee.algorithms.KOpt
  • SetEncryptionDisabled() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetErrorLog() : com.sparsity.sparksee.script.ScriptParser
  • SetExtentPages() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetExtentSize() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetFit() : com.sparsity.sparksee.gdb.NodeExport
  • SetFontSize() : com.sparsity.sparksee.gdb.EdgeExport , com.sparsity.sparksee.gdb.NodeExport
  • SetForcedQuotes() : com.sparsity.sparksee.io.CSVWriter
  • SetFrequency() : com.sparsity.sparksee.io.EdgeTypeExporter , com.sparsity.sparksee.io.EdgeTypeLoader , com.sparsity.sparksee.io.NodeTypeExporter , com.sparsity.sparksee.io.NodeTypeLoader , com.sparsity.sparksee.io.TypeExporter , com.sparsity.sparksee.io.TypeLoader
  • SetGraph() : com.sparsity.sparksee.io.EdgeTypeExporter , com.sparsity.sparksee.io.EdgeTypeLoader , com.sparsity.sparksee.io.NodeTypeExporter , com.sparsity.sparksee.io.NodeTypeLoader , com.sparsity.sparksee.io.TypeExporter , com.sparsity.sparksee.io.TypeLoader
  • SetHeadAttribute() : com.sparsity.sparksee.io.EdgeTypeExporter , com.sparsity.sparksee.io.EdgeTypeLoader
  • SetHeader() : com.sparsity.sparksee.io.EdgeTypeExporter , com.sparsity.sparksee.io.NodeTypeExporter , com.sparsity.sparksee.io.TypeExporter
  • SetHeadMEP() : com.sparsity.sparksee.io.EdgeTypeLoader
  • SetHeadPosition() : com.sparsity.sparksee.io.EdgeTypeExporter , com.sparsity.sparksee.io.EdgeTypeLoader
  • SetHeight() : com.sparsity.sparksee.gdb.NodeExport
  • SetHI() : com.sparsity.sparksee.gdb.SparkseeProperties
  • SetHighAvailabilityCoordinators() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetHighAvailabilityEnabled() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetHighAvailabilityIP() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetHighAvailabilityMasterHistory() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetHighAvailabilitySynchronization() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetInitialPageRankValue() : com.sparsity.sparksee.algorithms.PageRank
  • SetInMemAllocSize() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetInOutParameter() : com.sparsity.sparksee.algorithms.RandomWalk
  • SetInteger() : com.sparsity.sparksee.gdb.Value , com.sparsity.sparksee.gdb.ValueArray
  • SetIntegerVoid() : com.sparsity.sparksee.gdb.Value
  • SetLabel() : com.sparsity.sparksee.gdb.EdgeExport , com.sparsity.sparksee.gdb.GraphExport , com.sparsity.sparksee.gdb.NodeExport
  • SetLabelColor() : com.sparsity.sparksee.gdb.EdgeExport , com.sparsity.sparksee.gdb.NodeExport
  • SetLabelColorRGB() : com.sparsity.sparksee.gdb.EdgeExport , com.sparsity.sparksee.gdb.NodeExport
  • SetLicense() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetLicenseId() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetLicensePreDownloadDays() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetLocale() : com.sparsity.sparksee.io.CSVReader , com.sparsity.sparksee.io.CSVWriter , com.sparsity.sparksee.io.EdgeTypeLoader , com.sparsity.sparksee.io.NodeTypeLoader , com.sparsity.sparksee.io.TypeLoader
  • SetLogError() : com.sparsity.sparksee.io.EdgeTypeLoader , com.sparsity.sparksee.io.NodeTypeLoader , com.sparsity.sparksee.io.TypeLoader
  • SetLogFile() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetLogLevel() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetLogOff() : com.sparsity.sparksee.io.EdgeTypeLoader , com.sparsity.sparksee.io.NodeTypeLoader , com.sparsity.sparksee.io.TypeLoader
  • SetLong() : com.sparsity.sparksee.gdb.Value , com.sparsity.sparksee.gdb.ValueArray
  • SetLongVoid() : com.sparsity.sparksee.gdb.Value
  • SetLookAhead() : com.sparsity.sparksee.algorithms.CommunitiesSCD
  • SetMaterializedAttribute() : com.sparsity.sparksee.algorithms.CommunitiesSCD , com.sparsity.sparksee.algorithms.Connectivity , com.sparsity.sparksee.algorithms.DisjointCommunityDetection , com.sparsity.sparksee.algorithms.StrongConnectivityGabow , com.sparsity.sparksee.algorithms.WeakConnectivity , com.sparsity.sparksee.algorithms.WeakConnectivityDFS , com.sparsity.sparksee.algorithms.StrongConnectivity
  • SetMaximumHops() : com.sparsity.sparksee.algorithms.RandomWalk , com.sparsity.sparksee.algorithms.ShortestPath , com.sparsity.sparksee.algorithms.SinglePairShortestPath , com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS , com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra , com.sparsity.sparksee.algorithms.Traversal , com.sparsity.sparksee.algorithms.TraversalBFS , com.sparsity.sparksee.algorithms.Context , com.sparsity.sparksee.algorithms.TraversalDFS
  • SetMaxIterations() : com.sparsity.sparksee.algorithms.KOpt
  • SetMultilines() : com.sparsity.sparksee.io.CSVReader
  • SetNull() : com.sparsity.sparksee.gdb.Value
  • SetNullVoid() : com.sparsity.sparksee.gdb.Value
  • SetNumIterations() : com.sparsity.sparksee.algorithms.PageRank
  • SetNumLines() : com.sparsity.sparksee.io.CSVReader
  • SetOID() : com.sparsity.sparksee.gdb.ValueArray , com.sparsity.sparksee.gdb.Value , com.sparsity.sparksee.gdb.ValueArray
  • SetOIDVoid() : com.sparsity.sparksee.gdb.Value
  • SetOutputAttributeType() : com.sparsity.sparksee.algorithms.PageRank
  • SetOutputLog() : com.sparsity.sparksee.script.ScriptParser
  • SetPoolFrameSize() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetPoolPartitions() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetPoolPersistentMaxSize() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetPoolPersistentMinSize() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetPoolTemporaryMaxSize() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetPoolTemporaryMinSize() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetQuotes() : com.sparsity.sparksee.io.CSVWriter , com.sparsity.sparksee.io.CSVReader
  • SetRecoveryCacheMaxSize() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetRecoveryCheckpointTime() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetRecoveryEnabled() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetRecoveryLogFile() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetReturnParameter() : com.sparsity.sparksee.algorithms.RandomWalk
  • SetRollbackEnabled() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetRowReader() : com.sparsity.sparksee.io.EdgeTypeLoader , com.sparsity.sparksee.io.TypeLoader , com.sparsity.sparksee.io.NodeTypeLoader
  • SetRowWriter() : com.sparsity.sparksee.io.TypeExporter , com.sparsity.sparksee.io.EdgeTypeExporter , com.sparsity.sparksee.io.NodeTypeExporter
  • SetSeed() : com.sparsity.sparksee.algorithms.RandomWalk
  • SetSeparator() : com.sparsity.sparksee.io.CSVWriter , com.sparsity.sparksee.io.CSVReader
  • SetShape() : com.sparsity.sparksee.gdb.NodeExport
  • SetSingleLine() : com.sparsity.sparksee.io.CSVReader
  • SetSparkseeConfigFile() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetStartingNode() : com.sparsity.sparksee.algorithms.PageRank
  • SetStartLine() : com.sparsity.sparksee.io.CSVReader
  • SetStream() : com.sparsity.sparksee.gdb.Query
  • SetString() : com.sparsity.sparksee.gdb.Value
  • SetStringVoid() : com.sparsity.sparksee.gdb.Value
  • SetTailAttribute() : com.sparsity.sparksee.io.EdgeTypeLoader , com.sparsity.sparksee.io.EdgeTypeExporter
  • SetTailMEP() : com.sparsity.sparksee.io.EdgeTypeLoader
  • SetTailPosition() : com.sparsity.sparksee.io.EdgeTypeLoader , com.sparsity.sparksee.io.EdgeTypeExporter
  • SetTimeLimit() : com.sparsity.sparksee.algorithms.KOpt
  • SetTimestamp() : com.sparsity.sparksee.gdb.Value , com.sparsity.sparksee.gdb.ValueArray , com.sparsity.sparksee.gdb.Value , com.sparsity.sparksee.gdb.ValueArray
  • SetTimestampFormat() : com.sparsity.sparksee.io.EdgeTypeLoader , com.sparsity.sparksee.io.NodeTypeLoader , com.sparsity.sparksee.io.TypeLoader
  • SetTimestampVoid() : com.sparsity.sparksee.gdb.Value
  • SetTmpEnabled() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetTmpFolder() : com.sparsity.sparksee.gdb.SparkseeConfig
  • SetTolerance() : com.sparsity.sparksee.algorithms.PageRank
  • SetType() : com.sparsity.sparksee.io.EdgeTypeExporter , com.sparsity.sparksee.io.NodeTypeExporter , com.sparsity.sparksee.io.TypeLoader , com.sparsity.sparksee.io.EdgeTypeLoader , com.sparsity.sparksee.io.TypeExporter , com.sparsity.sparksee.io.NodeTypeLoader
  • SetUnweightedEdgeCost() : com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra
  • SetVoid() : com.sparsity.sparksee.gdb.Value
  • SetWidth() : com.sparsity.sparksee.gdb.NodeExport , com.sparsity.sparksee.gdb.EdgeExport
  • SinglePairShortestPathBFS() : com.sparsity.sparksee.algorithms.SinglePairShortestPathBFS
  • SinglePairShortestPathDijkstra() : com.sparsity.sparksee.algorithms.SinglePairShortestPathDijkstra
  • Size() : com.sparsity.sparksee.gdb.ValueArray
  • Sparksee() : com.sparsity.sparksee.gdb.Sparksee
  • SparkseeConfig() : com.sparsity.sparksee.gdb.SparkseeConfig
  • Start() : com.sparsity.sparksee.gdb.QueryStream
  • StringList() : com.sparsity.sparksee.gdb.StringList
  • StrongConnectivityGabow() : com.sparsity.sparksee.algorithms.StrongConnectivityGabow
Generated on Thu Feb 24 2022 11:05:33 for SparkseeNet by doxygen 1.8.2


SparkseeNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- t -

  • Tails() : com.sparsity.sparksee.gdb.Graph
  • TailsAndHeads() : com.sparsity.sparksee.gdb.Graph
  • TextStream() : com.sparsity.sparksee.gdb.TextStream
  • TopK() : com.sparsity.sparksee.gdb.Graph
  • ToString() : com.sparsity.sparksee.gdb.Value , com.sparsity.sparksee.gdb.KeyValue
  • TraversalBFS() : com.sparsity.sparksee.algorithms.TraversalBFS
  • TraversalDFS() : com.sparsity.sparksee.algorithms.TraversalDFS
  • TypeList() : com.sparsity.sparksee.gdb.TypeList
Generated on Thu Feb 24 2022 11:05:33 for SparkseeNet by doxygen 1.8.2


SparkseeNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- u -

  • Union() : com.sparsity.sparksee.gdb.Objects
Generated on Thu Feb 24 2022 11:05:33 for SparkseeNet by doxygen 1.8.2


SparkseeNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- v -

  • Value() : com.sparsity.sparksee.gdb.Value
  • ValueList() : com.sparsity.sparksee.gdb.ValueList
  • VerifyChecksums() : com.sparsity.sparksee.gdb.Sparksee
Generated on Thu Feb 24 2022 11:05:33 for SparkseeNet by doxygen 1.8.2


SparkseeNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- w -

  • WeakConnectivityDFS() : com.sparsity.sparksee.algorithms.WeakConnectivityDFS
  • Write() : com.sparsity.sparksee.gdb.TextStream , com.sparsity.sparksee.io.RowWriter , com.sparsity.sparksee.io.CSVWriter
Generated on Thu Feb 24 2022 11:05:33 for SparkseeNet by doxygen 1.8.2


SparkseeNet: Class Members - Variables

  • All
  • Functions
  • Variables
  • EdgesType : com.sparsity.sparksee.gdb.Type
  • GlobalType : com.sparsity.sparksee.gdb.Type
  • InvalidAttribute : com.sparsity.sparksee.gdb.Attribute
  • InvalidOID : com.sparsity.sparksee.gdb.Objects
  • InvalidType : com.sparsity.sparksee.gdb.Type
  • MaxLengthString : com.sparsity.sparksee.gdb.Value
  • NodesType : com.sparsity.sparksee.gdb.Type
  • Version : com.sparsity.sparksee.gdb.Sparksee
Generated on Thu Feb 24 2022 11:05:33 for SparkseeNet by doxygen 1.8.2


SparkseeNet: doc Directory Reference

  • binnative
  • sparkseenet
  • doc
doc Directory Reference
Directory dependency graph for doc:

Files

file | Attribute.cs
file | AttributeKind.cs
file | AttributeList.cs
file | AttributeListIterator.cs
file | AttributeStatistics.cs
file | BooleanList.cs
file | BooleanListIterator.cs
file | CommunitiesSCD.cs
file | CommunityDetection.cs
file | Condition.cs
file | ConnectedComponents.cs
file | Connectivity.cs
file | Context.cs
file | CSVLoader.cs
file | CSVReader.cs
file | CSVWriter.cs
file | Database.cs
file | DatabaseStatistics.cs
file | DataType.cs
file | DefaultExport.cs
file | DisjointCommunities.cs
file | DisjointCommunityDetection.cs
file | EdgeData.cs
file | EdgeExport.cs
file | EdgesDirection.cs
file | EdgeTypeExporter.cs
file | EdgeTypeLoader.cs
file | ExportManager.cs
file | ExportType.cs
file | Graph.cs
file | GraphExport.cs
file | Int32List.cs
file | Int32ListIterator.cs
file | KeyValue.cs
file | KeyValues.cs
file | KOpt.cs
file | LogLevel.cs
file | MissingEndpoint.cs
file | NodeExport.cs
file | NodeShape.cs
file | NodeTypeExporter.cs
file | NodeTypeLoader.cs
file | Objects.cs
file | ObjectsIterator.cs
file | ObjectType.cs
file | OIDList.cs
file | OIDListIterator.cs
file | Order.cs
file | PageRank.cs
file | Platform.cs
file | PlatformStatistics.cs
file | Query.cs
file | QueryContext.cs
file | QueryLanguage.cs
file | QueryStream.cs
file | RandomWalk.cs
file | ResultSet.cs
file | ResultSetList.cs
file | ResultSetListIterator.cs
file | RowReader.cs
file | RowWriter.cs
file | ScriptParser.cs
file | Session.cs
file | ShortestPath.cs
file | SinglePairShortestPath.cs
file | SinglePairShortestPathBFS.cs
file | SinglePairShortestPathDijkstra.cs
file | SinglePairShortestPathDijkstraDynamicCost.cs
file | Sparksee.cs
file | SparkseeConfig.cs
file | SparkseeProperties.cs
file | StringList.cs
file | StringListIterator.cs
file | StrongConnectivity.cs
file | StrongConnectivityGabow.cs
file | TextStream.cs
file | Traversal.cs
file | TraversalBFS.cs
file | TraversalDFS.cs
file | Type.cs
file | TypeExporter.cs
file | TypeExporterEvent.cs
file | TypeExporterListener.cs
file | TypeList.cs
file | TypeListIterator.cs
file | TypeLoader.cs
file | TypeLoaderEvent.cs
file | TypeLoaderListener.cs
file | Value.cs
file | ValueArray.cs
file | ValueList.cs
file | ValueListIterator.cs
file | Values.cs
file | ValuesIterator.cs
file | WeakConnectivity.cs
file | WeakConnectivityDFS.cs


SparkseeNet: binnative Directory Reference

  • binnative
binnative Directory Reference
Directory dependency graph for binnative:

Directories

directory sparkseenet


SparkseeNet: sparkseenet Directory Reference

  • binnative
  • sparkseenet
sparkseenet Directory Reference
Directory dependency graph for sparkseenet:

Directories

directory doc


SparkseeNet: Main Page

SparkseeNet Documentation


SparkseeNet: Class Hierarchy

Class Hierarchy

Go to the textual class hierarchy